Configurando funções para o servidor

O Assistente para configurar o servidor fornece um local central no qual você pode instalar ou remover as funções disponíveis em um servidor que executa Windows Server 2003. Depois de instalar uma função de servidor, você pode usar Gerenciar o servidor para administrá-la.

Gerenciar o servidor fornece um local central no qual você pode gerenciar as funções de servidor que foram instaladas com o Assistente para configurar o servidor. Gerenciar o servidor é iniciado automaticamente quando você faz logon pela primeira vez no computador servidor com credenciais administrativas.

  • Funções de servidor
  • Instalação típica de um primeiro servidor
  • Função do servidor de arquivos: Configurando um servidor de arquivos
  • Função do servidor de impressão: Configurando um servidor de impressão
  • Função do servidor de aplicativos: Configurando um servidor de aplicativos
  • Função do servidor de email: Configurando um servidor de email
  • Função do servidor de terminal: Configurando um servidor de terminal
  • Acesso Remoto/função do servidor VPN: Configurando um acesso remoto/servidor VPN
  • Função do controlador de domínio: Configurando o controlador de domínio
  • Função do servidor DNS: Configurando um servidor DNS
  • Função do servidor DHCP: Configurando um servidor DHCP
  • Função de servidor de fluxo de mídia: Configurando o servidor de fluxo de mídia
  • Função do servidor WINS: Configurando um servidor WINS
  • Remover uma função do servidor

Assistente de configuração de segurança

Após configurar as funções do seu servidor, utilize o Assistente de configuração de segurança (SCW) para criar ou aplicar uma diretiva de segurança ao servidor. Para obter mais informações sobre o SCW, consulte Assistente de configuração de segurança.

Observação

  • XOX


Funções de servidor

A família Windows Server 2003 oferece várias funções de servidor. Para configurar uma função de servidor, instale-a usando o Assistente para configurar o servidor e gerencie-a usando Gerenciar o servidor. Após instalar a função do servidor, Gerenciar o servidor é automaticamente iniciado.

Para determinar a função de servidor adequada ao seu caso, releia as informações abaixo sobre as funções de servidor disponíveis na família Windows Server 2003:

Visão geral sobre a função do servidor de arquivos

Visão geral sobre a função do servidor de impressão

Visão geral sobre a função do servidor de aplicativos

Visão geral sobre a função do servidor de email

Visão geral sobre a função do servidor de terminal

Visão geral sobre a função do servidor de acesso remoto/VPN

Visão geral sobre a função do controlador de domínio

Visão geral sobre a função do servidor DNS

Visão geral sobre a função do servidor DHCP

Visão geral sobre a função de servidor de fluxo de mídia

Visão geral sobre a função do servidor WINS

Visão geral sobre a função do servidor de arquivos

Os servidores de arquivos fornecem e gerenciam o acesso a arquivos. Se você planeja usar o espaço em disco do computador para armazenar, gerenciar e compartilhar informações, como arquivos e aplicativos acessíveis pela rede, configure-o como um servidor de arquivos.

Depois de configurar a função de servidor de arquivos, você pode fazer o seguinte:

  • Use cotas de disco em volumes formatados com o sistema de arquivos NTFS para monitorar e limitar a quantidade de espaço em disco disponível para usuários individuais. Você também pode especificar se deseja registrar um log de evento quando o usuário ultrapassar o limite de espaço em disco especificado, ou quando o usuário ultrapassar o nível de notificação de espaço em disco especificado (isto é, um ponto próximo ao limite da cota do usuário).
  • Use o Serviço de indexação para procurar rápida e eficazmente informações locais ou na rede.
  • Pesquise em arquivos de diferentes formatos e idiomas, seja através do comando Pesquisar do menu Iniciar ou através de páginas HTML exibidas em um navegador.

Para obter mais informações sobre a implementação desta função de servidor, consulte Função do servidor de arquivos: Configurando um servidor de arquivos.

Visão geral sobre a função do servidor de impressão

Os servidores de impressão fornecem e gerenciam o acesso às impressoras. Configure o computador como servidor de impressão se você planeja gerenciar impressoras remotamente ou usando a instrumentação de gerenciamento do Windows (WMI), ou se deseja imprimir de um computador servidor ou cliente para um servidor de impressão usando um URL.

Depois de configurar a função de servidor de impressão, você pode fazer o seguinte:

  • Use um navegador para gerenciar impressoras. É possível interromper, continuar ou excluir um trabalho de impressão e exibir os status da impressora e do trabalho de impressão.
  • Use o novo monitor de porta padrão, que simplifica a instalação da maioria das impressoras TCP/IP na rede.
  • Use o WMI, a API de gerenciamento criada pela Microsoft que permite que você monitore e controle todos os componentes do sistema, local ou remotamente. O provedor de impressão do WMI permite que você gerencie servidores, dispositivos e outros objetos de impressão usando a linha de comandos. Com o provedor de impressão do WMI, você pode usar scripts do Visual Basic (VB) para executar funções administrativas da impressora. Para obter mais informações, consulte Linha de comando da Instrumentação de gerenciamento do Windows (WMIC).
  • Imprima de clientes XOX para servidores de impressão que executam Windows Server 2003 usando um URL.
  • Conecte-se a impressoras da rede utilizando o recurso apontar-e-imprimir da Web para instalar com um único clique uma impressora compartilhada. Você também pode instalar drivers de um site da Web.

Para obter mais informações sobre a implementação desta função de servidor, consulte Função do servidor de impressão: Configurando um servidor de impressão.

Visão geral sobre a função do servidor de aplicativos

O servidor de aplicativos é uma tecnologia fundamental que fornece infra-estrutura e serviços importantes aos aplicativos hospedados em um sistema. Os servidores de aplicativos típicos incluem o seguinte:

  • Pool de recursos (por exemplo, pool de conexões com bancos de dados e pool de objetos)
  • Gerenciamento distribuído de transações
  • Comunicação assíncrona entre programas, geralmente através de enfileiramento de mensagens
  • Um modelo de ativação de objetos just-in-time
  • Interfaces automáticas dos Serviços XML da web para acessar objetos de negócios
  • Serviços de detecção de failover e da integridade do aplicativo
  • Segurança integrada

A família Windows Server 2003 contém um servidor de aplicativos que traz toda essa funcionalidade, além de outros serviços para o desenvolvimento, implantação e gerenciamento em tempo de execução dos Serviços XML da Web, aplicativos para Web e aplicativos distribuídos.

Quando você configura este servidor como servidor de aplicativos, você instala o IIS (serviços de informações da Internet) junto com outras tecnologias e serviços opcionais, como o COM+ e ASP.NET. Juntos, o IIS e a família Windows Server 2003 oferecem recursos de servidor Web integrados, confiáveis, dimensionáveis, seguros e gerenciáveis, usando uma intranet, a Internet ou uma extranet. O IIS é uma ferramenta usada na criação de uma plataforma forte de comunicações de aplicativos de rede dinâmicos.

Para obter mais informações sobre a implementação desta função de servidor, consulte Função do servidor de aplicativos: Configurando um servidor de aplicativos

Visão geral sobre a função do servidor de email

Para oferecer serviços de email aos usuários, você pode utilizar os componentes protocolo de agência de correio versão 3 (POP3) e protocolo de transferência de correio simples (SMTP) contidos na família Windows Server 2003. O serviço POP3 implementa o protocolo POP3 padrão para recuperação de mensagens. Você pode combiná-lo com o serviço SMTP para ativar a transferência de mensagens. Se você planeja permitir que os clientes se conectem a este servidor POP3 e façam o download de email para computadores locais usando um cliente de correio com capacidade POP3, configure o servidor como servidor de email.

Depois de configurar a função de servidor de email, você pode fazer o seguinte:

  • Use o serviço POP3 para armazenar e gerenciar contas de email no servidor de email.
  • Habilite o acesso dos usuários ao servidor de email, para que possam recuperar email de seus computadores locais usando um cliente de email que aceita o protocolo POP3 (por exemplo, o Microsoft Outlook).

Para obter mais informações sobre a implementação desta função de servidor, consulte Função do servidor de email: Configurando um servidor de email.

Visão geral sobre a função do servidor de terminal

Com o Terminal Server, você pode oferecer um único ponto de instalação que permite a vários usuários o acesso a qualquer computador que esteja executando o sistema operacional Windows Server 2003. Os usuários podem executar programas, salvar arquivos e usar recursos de rede em um único local remoto, como se esses recursos estivessem instalados em seus próprios computadores.

Depois de configurar a função de servidor de terminal, você pode fazer o seguinte:

  • Confirme a Configuração de segurança aprimorada do Internet Explorer.
  • Centralize a implantação de programas em um computador.
  • Certifique-se de que todos os clientes usem a mesma versão do programa.

Importante

  • Além de configurar um servidor de terminal, você deve instalar o Licenciamento do Terminal Server e configurar um Servidor de licença do Terminal Server. Caso contrário, seu servidor de terminal não aceitará mais conexões de clientes não licenciados quando o período de avaliação terminar 120 depois do primeiro logon do cliente. Para obter informações sobre o Licenciamento do Terminal Server, consulte Licenciamento do Terminal Server.

Para obter mais informações sobre como implementar esta função de servidor, consulte Função do servidor de terminal: Configurando um servidor de terminal.

Visão geral sobre a função do servidor de acesso remoto/VPN

O Roteamento e acesso remoto fornecem um roteador de software inteiramente funcional e conectividade dial-up e VPN para computadores remotos. Ele oferece serviços de roteamento para ambientes derede local (LAN) e de rede de longa distância (WAN) Ele também permite que funcionários remotos ou móveis acessem as redes corporativas como se estivessem diretamente conectados, através de serviços de conexão dial-up ou pela Internet, com conexões VPN. Se você planeja conectar funcionários remotos a redes de negócios, configure o servidor como um servidor de acesso remoto/VPN.

As conexões de acesso remoto oferecem todos os serviços tipicamente disponíveis para usuários conectados à LAN, incluindo compartilhamento de arquivos e impressoras, acesso ao servidor Web e serviços de mensagens.

Depois de configurar a função de servidor de acesso remoto/VPN, você pode fazer o seguinte:

  • Controle como e quando os usuários remotos acessam a rede.
  • Forneça serviços de conversão de endereços de rede (NAT) para os computadores da rede.
  • Crie soluções de rede personalizadas usando as interfaces de programação de aplicativos (APIs).

Para obter mais informações sobre como implementar esta função de servidor, consulte Função do servidor de acesso remoto/VPN: Configurando um servidor de acesso remoto/VPN.

Visão geral sobre a função do controlador de domínio

Os controladores de domínio armazenam dados de diretório e gerenciam a comunicação entre usuários e domínios, inclusive processos de logon do usuário, autenticação e pesquisas de diretório. Se você planeja oferecer o serviço de diretórios Active Directory para gerenciar usuários e computadores, configure o servidor como um controlador de domínio.

Observações

  • Você não pode adicionar a função de controlador de domínio a uma autoridade de certificação. Se seu computador já for uma autoridade de certificação, a função de controlador de domínio não estará disponível no Assistente para configurar o servidor.
  • Os computadores que executam XOX, não podem funcionar como controladores de domínio. Para obter mais informações sobre o XOX, consulte Visão geral sobre o XOX.

Depois de configurar a função de controlador de domínio, você pode fazer o seguinte:

  • Armazene dados do diretório e disponibilize-os aos usuários e administradores da rede. Por exemplo, o Active Directory armazena informações sobre contas de usuários (como nomes, senhas, números de telefone e assim por diante) e permite que outros usuários autorizados da mesma rede tenham acesso a essas informações.
  • Adicione controladores de domínio a um domínio existente para melhorar a disponibilidade e a confiabilidade dos serviços de rede.
  • Melhore o desempenho da rede entre os sites colocando um controlador de domínio em cada um deles. A presença de um controlador de domínio em cada site permite que os processos de logon do cliente sejam administrados no site, sem que seja preciso usar a conexão de rede mais lenta entre os sites.

Para obter mais informações sobre como implementar esta função de servidor, consulte Função do controlador de domínio: Configurando o controlador de domínio.

Visão geral sobre a função do servidor DNS

O sistema de nomes de domínio (DNS) é o serviço de resolução de nomes TCP/IP usado na Internet. O serviço DNS permite que computadores clientes da rede registrem e resolvam nomes DNS significativos para o usuário. Se você planeja disponibilizar os recursos da rede na Internet, configure o servidor como servidor DNS.

Importante

  • Se você planeja incluir computadores da Internet na sua rede, use um nome de domínio DNS exclusivo. Para obter informações sobre como planejar o espaço para nome DNS, consulte Planejamento de espaço para nome DNS.

Depois de configurar a função de servidor DNS, você pode fazer o seguinte:

  • Hospede registros de um banco de dados DNS distribuído e use-os para resolver consultas DNS enviadas por computadores clientes DNS, como consultas sobre nomes de sites ou de computadores da rede ou da Internet.
  • Nomeie e localize os recursos da rede usando nomes significativos para os usuários.
  • Controle a resolução de nomes de cada segmento de rede e replique as alterações para a rede inteira ou globalmente, na Internet.
  • Reduza a administração do DNS atualizando dinamicante suas informações.

Para obter mais informações sobre como implementar esta função de servidor, consulte Função do servidor DNS: Configurando um servidor DNS.

Visão geral sobre a função do servidor DHCP

O protocolo de configuração dinâmica de hosts (DHCP) é um padrão TCP/IP criado para reduzir a complexidade da administração de configurações de endereço usando um computador servidor para gerenciar centralmente endereços IP e outros detalhes de configuração afins usados na rede. Se você planeja alocar endereços de difusão seletiva e obter endereços IP de clientes e seus parâmetros de configuração dinamicamente, configure o servidor como DHCP.

Depois de configurar a função de servidor DHCP, você pode fazer o seguinte:

  • Gerencie centralizadamente os endereços IP e informações afins.
  • Use DHCP para impedir conflitos de endereço evitando que endereços IP atribuídos anteriormente sejam utilizados novamente para configurar um novo computador na rede.
  • Configure o servidor DHCP para fornecer um intervalo completo de valores de configuração adicionais ao atribuir concessões de endereço. Isso reduzirá significativamente o tempo usado na configuração e reconfiguração de computadores na rede.
  • Use o processo de renovação de concessão de DHCP para assegurar que as configurações de clientes que precisam ser atualizadas com freqüência (como usuários com computadores portáteis ou móveis, que mudam de local freqüentemente) possam ser atualizadas de forma eficiente e automática por clientes que se comunicam diretamente com servidores DHCP.

Para obter mais informações sobre como implementar esta função de servidor, consulte Função do servidor DHCP: Configurando um servidor DHCP.

Visão geral sobre a função de servidor de fluxo de mídia

Os servidores de fluxo de mídia fornecem os Windows Media Services à sua organização. O Windows Media Services gerencia, entrega e arquiva o conteúdo do Windows Media, incluindo fluxo de áudio e vídeo, através de uma intranet ou pela Internet. Se você planeja usar a mídia digital em tempo real com conexões de Internet dial-up ou redes locais (LANs). configure o servidor como servidor de fluxo de mídia.

Depois de configurar a função de servidor de fluxo de mídia, você pode fazer o seguinte:

  • Forneça vídeo digital em tempo real através de diferentes redes, desde conexões de Internet dial-up de pouca largura de banda até LANs de grande largura de banda.
  • Forneça fluxo de áudio digital aos clientes e aos outros servidores da Internet ou intranet.

Para obter mais informações sobre como implementar esta função de servidor, consulte Função do servidor de fluxo de mídia: Configurando o servidor de fluxo de mídia.

Visão geral sobre a função do servidor WINS

Os servidores de serviço de cadastramento na Internet do Windows (WINS) mapeiam endereços IP para nomes de computador NetBIOS e vice-versa. Com os servidores WINS operando na sua organização, você pode pesquisar recursos por nome de computador, mais fáceis de lembrar que endereços IP, o método antigo. Se você planeja mapear nomes NetBIOS para endereços IP ou gerenciar centralizadamente o banco de dados de nomes para endereços, configure o servidor como servidor WINS.

Depois de configurar a função de servidor WINS, você pode fazer o seguinte:

  • Reduzir o tráfego de difusões baseadas em NetBIOS em sub-redes, permitindo que os clientes consultem os servidores WINS para localizar diretamente sistemas remotos.
  • Oferecer suporte a clientes baseados em versões anteriores do Windows e do NetBIOS existentes na rede, permitindo que esses tipos de clientes procurem domínios remotos do Windows em listas sem que um controlador de domínio local precise estar presente em cada sub-rede.
  • Oferecer suporte a clientes baseados em DNS, permitindo que esses clientes localizem recursos NetBIOS quando a integração da pesquisa WINS for implementada. Para obter mais informações, consulte Integração da pesquisa WINS.

Para obter mais informações sobre como implementar esta função de servidor, consulte Função do servidor WINS: Configurando um servidor WINS.


Instalação típica de um primeiro servidor

As informações abaixo descrevem como instalar e configurar o primeiro servidor em uma rede usando a opção Configuração típica para um primeiro servidor no Assistente para configurar o servidor.

Importante

  • Antes de configurar o primeiro servidor em uma rede, consulte Lista de verificação: Definindo a configuração típica para um primeiro servidor.

A configuração típica para um primeiro servidor não será executada se qualquer uma das condições abaixo ocorrer:

  • O computador está executando o XOX.
  • O computador está executando o XOX.
  • O computador está associado a um domínio.
  • O computador já está configurado como controlador de domínio.
  • O computador não é um controlador de domínio, mas o Assistente para instalação do Active Directory já foi iniciado.
  • O computador é uma autoridade de certificação.
  • O computador já está configurado como servidor DNS.
  • O computador já está configurado como servidor DHCP.
  • O número de adaptadores de rede ativados para IP é zero.
  • Existe somente um adaptador de rede ativado para IP e o teste de concessão DHCP foi bem-sucedido.
  • O computador já está executando o serviço de Roteamento e acesso remoto.
  • O computador não possui qualquer partição NTFS.
  • A sessão atual é remota.

Processo de configuração típica

O processo de configuração típica implementa as seguintes etapas:

  • Instala o Active Directory e promove o computador para um controlador de domínio.

    Quando você promove um servidor para um controlador de domínio, um domínio é automaticamente criado na rede. Depois que você promover um servidor a controlador de domínio, você pode promover outros servidores da mesma forma. Para obter mais informações, consulte Controladores de domínio.

    Quando você configura o servidor usando a configuração típica para um primeiro servidor, a senha do administrador local é automaticamente definida como a senha do Administrador do modo de restauração.

  • Configura um contexto de nomeação de aplicativo no Active Directory deste controlador de domínio para ser usado pelos aplicativos clientes API de telefonia (TAPI). Para obter mais informações, consulte Partições de diretório do aplicativo.
  • Instala o sistema de nomes de domínio (DNS) e cria um nome de domínio completo para a rede.

    O DNS é um protocolo de rede que renomeia computadores e serviços de rede e que é organizado em uma hierarquia de domínios. As redes TCP/IP, como a Internet, usam a nomeação do DNS para localizar computadores e serviços por meio de nomes amigáveis para o usuário. Quando um usuário insere um nome DNS em um aplicativo, os serviços DNS podem resolver o nomes para outra informação associada ao nome, como um endereço IP.

    Por exemplo, a maioria dos usuários prefere um nome amigável como servidor1.exemplo.microsoft.com para localizar um computador como um servidor de correio ou da Web em um rede. No entanto, os computadores usam endereços numéricos para se comunicar na rede. Para facilitar o uso dos recursos da rede, o DNS oferece uma forma de mapear o nome amigável de um computador ou serviço para seu endereço numérico. Para obter mais informações, consulte Nomes de domínio do DNS.

  • Altera o nome NetBIOS padrão. Você pode alterar o nome NetBIOS padrão nesta página. Por exemplo, se o nome de domínio DNS do Active Directory for suapequenaempresa.local, o nome de domínio NetBIOS padrão será SUAPEQUENAEMPRESA. Você pode alterar para CORP ou usar sua própria abreviação no nome do negócio, para facilitar o uso. Para obter mais informações sobre NetBIOS, consulte Resolução de nomes de NetBIOS.
  • Atribui um servidor DNS preferencial com o mesmo endereço IP que você especificou para este servidor. Para obter mais informações, consulte Como a consulta DNS funciona.
  • Atribui um encaminhador de DNS. Para obter mais informações, consulte Noções sobre encaminhadores.
  • Instala o serviço do servidor DHCP.

    O DHCP utiliza um modelo cliente/servidor. O administrador da rede estabelece um ou mais servidores DHCP que mantêm as informações de configuração de TCP/IP e as fornecem aos clientes. Com um servidor DHCP instalado e configurado na rede, os clientes com DHCP podem obter endereços IP e parâmetros de configuração relacionados dinamicamente sempre que iniciarem e ingressarem na rede. Os servidores DHCP fornecem essa configuração na forma de uma oferta de concessão de endereço para clientes solicitantes.

  • Atribui um endereço IP estático, se este já não tiver sido atribuído à conexão de rede privada. Para obter mais informações, consulte Resolução de nomes para TCP/IP.
  • Atribui uma máscara de sub-rede (isto é, se esta não havia sido configurada no servidor). Por padrão, o Assistente para configurar o servidor atribui a máscara de rede 255.255.255.0. Para obter mais informações, consulte Máscaras de sub-rede.
  • Instala o serviço de Roteamento e acesso remoto (isto é, se for detectada mais de uma conexão de rede).

Próximas etapas: Instalação típica de um primeiro servidor

Depois que você concluir o Assistente para configurar o servidor, o computador estará pronto para uso como servidor na rede. Ele foi configurado como controlador de domínio, servidor DNS, servidor DHCP e possivelmente como servidor de acesso remoto/VPN. Para obter mais informações sobre essas funções, consulte:

  • Função do controlador de domínio: Configurando o controlador de domínio
  • Função do servidor DNS: Configurando um servidor DNS
  • Função do servidor DHCP: Configurando um servidor DHCP
  • Acesso Remoto/função do servidor VPN: Configurando um acesso remoto/servidor VPN

A tabela a seguir lista algumas tarefas adicionais que você pode executar no servidor. Para gerenciar os novos serviços neste servidor, faça o seguinte:

  • XOX

Observação

  • Se você rebaixar o servidor de forma que ele deixe de ser um controlador de domínio, deverá remover a partição do aplicativo TAPI usando o utilitário Tapicfg.exe. Para obter mais informações, consulte Remover uma partição de diretório do aplicativo TAPI.
Tarefa | Referência
Realizar outras alterações de configuração no servidor DNS. | Lista de verificação: Instalando um servidor DNS; Configurar um novo servidor DNS
Instalar outros controladores de domínio, se necessário. | Criar um controlador de domínio adicional
Configurar outras opções para o servidor DHCP. | Lista de verificação: Instalando um servidor DHCP
(Opcional) Monitore e meça os vários aspectos do servidor DNS para evitar e solucionar problemas de perda de desempenho. | Monitorando o desempenho do servidor DNS
(Opcional) Monitore e meça os vários aspectos do servidor DHCP para evitar e solucionar problemas de perda de desempenho. | Monitorando o desempenho do servidor DHCP; Referência de monitoramento de desempenho do DHCP
(Opcional) Instalar e configurar outros controladores de domínio. | Lista de verificação: Criando um controlador de domínio adicional para um domínio existente
(Opcional) Selecione o nível de segurança apropriado para a administração do domínio. | Usando o Assistente para instalação do Active Directory


Função do servidor de arquivos: Configurando um servidor de arquivos

O servidor de arquivos fornece um ponto centralizado na rede para armazenamento e compartilhamento de arquivos entre os usuários. Quando desejarem usar um arquivo importante, como um planejamento de projeto, os usuários podem acessá-lo diretamente no servidor de arquivos, em vez de precisarem repassar o arquivo entre cada computador. Se os usuários da rede precisarem acessar os mesmos arquivos e aplicativos acessíveis pela rede, configure o computador como servidor de arquivos.

Este tópico explica como usar Gerenciar o servidor e o Assistente para configurar o servidor para instalar e configurar um servidor de arquivos. Ao terminar de configurar um servidor de arquivos básico, você pode executar outras tarefas usando Gerenciar o servidor. Ao concluir o Assistente para configurar o servidor, você terá um servidor de arquivos inteiramente funcional.

Este tópico aborda o seguinte:

Antes de começar

Configurando o servidor de arquivos

Próximas etapas: Concluindo tarefas adicionais

Antes de começar

Antes de configurar o computador como um servidor de arquivos, verifique se:

  • O sistema operacional está configurado corretamente. Na família Windows Server 2003, os serviços de arquivos dependem da configuração adequada do sistema operacional e seus serviços. Se houver uma nova instalação de um sistema operacional Windows Server 2003, você poderá usar as configurações padrão do serviço. Nenhuma outra ação é necessária. Se você fez uma atualização para um sistema operacional Windows Server 2003 ou se deseja confirmar se os serviços estão configurados corretamente para obter melhor desempenho e segurança, verifique as configurações dos serviços comparando-os à tabela em Configurações padrão de serviços.
  • O computador é associado a um domínio do Active Directory como servidor membro. Se você quiser autenticar clientes ou publicar uma pasta compartilhada no Active Directory, deve associar o servidor de arquivos a um domínio. Se você não precisa realizar essas tarefas, não é necessário associar o servidor de arquivos a um domínio.
  • Todo o espaço em disco disponível é alocado. Você pode usar o Gerenciamento de disco ou DiskPart.exe para criar uma nova partição de um espaço não alocado. Para obter mais informações, consulte Criar uma partição ou unidade lógica.
  • Todos os volumes de disco existentes usam o sistema de arquivos NTFS. Volumes FAT32 não são protegidos e não oferecem suporte à compactação de arquivos e pastas, a cotas de disco, à criptografia de arquivos ou a permissões de arquivo individuais.

A tabela a seguir lista as informações que você precisa saber antes de adicionar a função do servidor de arquivos.

Antes de adicionar a função do servidor de arquivos | Comentários
Decida se você deseja configurar cotas de discos. | Use cotas de disco para rastrear e controlar a utilização do espaço em disco em cada volume NTFS. Criando um log de evento quando o limite de espaço em disco é desrespeitado, as cotas evitam que os usuários ultrapassem o espaço em disco a eles designado.
Decida se você deseja usar o Serviço de indexação. | O Serviço de indexação cria índices do conteúdo e das propriedades dos documentos situados na sua unidade de disco rígido local e em unidades de rede compartilhadas. Esses índices facilitam e agilizam a realização de pesquisas. Como o Serviço de indexação pode impactar a velocidade do servidor, use-o somente se os usuários precisarem fazer pesquisas freqüentes no conteúdo de arquivos deste servidor.
Identifique as pastas que você deseja compartilhar no computador e especifique um nome e uma descrição para a pasta. | Os usuários visualizam os recursos compartilhados no servidor de arquivos com base no nome do arquivo. Recomendamos criar nomes de compartilhamento de fácil memorização e que indiquem o conteúdo da pasta. Por exemplo, suponhamos que cada usuário receba 2 gigabytes (GB) para armazenar suas informações particulares no servidor de arquivos. Uma boa idéia é dar à pasta no nível mais alto do seu servidor de arquivos o nome Pastas pessoais. Em seguida, você pode nomear cada subpasta de acordo com o nome de domínio do usuário.
Determine os tipos de permissões que você deseja definir nas pastas. | Atribua as permissões mais restritivas que ainda permitam que os usuários realizem as tarefas necessárias. O controle de acesso do sistema de arquivos NTFS fornece mais segurança que as permissões de compartilhamento.

Configurando o servidor de arquivos

Para configurar o servidor de arquivos, inicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Servidor de arquivos e, em seguida, clique em Avançar.

Esta seção aborda os seguintes tópicos:

Cotas de disco do servidor de arquivos

Serviço de indexação do servidor de arquivos

Resumo das seleções

Usando o Assistente para compartilhamento de pasta

Concluindo o Assistente para configurar o servidor

Removendo a função do servidor de arquivos

Cotas de disco do servidor de arquivos

Na página Cotas de disco de servidor de arquivos é possível configurar cotas de disco que rastreiam e controlam a utilização do espaço em disco de usuários individuais em cada volume NTFS. O Assistente para configurar o servidor aplica automaticamente as cotas de disco para os novos usuários de qualquer sistema de arquivos NTFS, levando em consideração a cota de espaço em disco já aplicada. Somente será necessário alterar as informações da página Cotas de disco de servidor de arquivos se você quiser evitar que o servidor consuma uma determinada quantidade de espaço no disco ou se o espaço do disco for limitado. Na maioria dos casos, você pode aceitar as configurações padrão do sistema.

Se você quiser criar um log de evento quando o usuário ultrapassar o limite de espaço em disco especificado, ou quando o usuário ultrapassar o nível de notificação de espaço em disco especificado (isto é, um ponto próximo ao limite da cota do usuário), pode especificar esse log nesta página.

A tabela a seguir descreve as opções de configuração manual.

Configurações | Comentários
Instalar cotas de disco padrão para novos usuários do servidor | Marque essa caixa se você quiser ativar cotas de disco, para poder limitar e rastrear a utilização do espaço em disco deste servidor de arquivos. Se você decidir ativar as cotas de disco, precisará definir o limite do espaço em disco. Recomendamos que você defina os limites padrão de forma moderadamente restritiva para todas as contas de usuário e modifique os limites para conceder mais espaço em disco aos usuários que trabalham com arquivos maiores. Por exemplo, usuários que usam fotografias digitalizadas ou imagens gráficas precisam de grandes quantidades de espaço em disco. Você também pode definir o nível de notificação de forma que os usuários recebam um aviso quando ultrapassarem o limite de espaço em disco especificado. Se você não quiser usar um nível de notificação, defina este número com um valor superior ao limite de espaço em disco.
Negar espaço em disco para usuários que excederem o limite de espaço em disco | Se você quiser limitar a utilização do espaço em disco no servidor de arquivos, define esta configuração. Se quiser somente rastrear a utilização do espaço em disco em relação a cada usuário, deixe esta configuração em branco.
Registrar um evento em logo quando o usuário exceder um dos seguintes itens | Defina esta configuração se quiser criar um log de evento do sistema quando o usuário ultrapassar o limite de espaço em disco ou o nível de notificação. Você pode exibir os eventos do sistema usando Visualizar eventos. XOX

Quando terminar, clique em Avançar.

Serviço de indexação do servidor de arquivos

Na página Serviço de indexação do servidor de arquivos, siga um destes procedimentos:

  • Se os usuários pretendem pesquisar o conteúdo de arquivos no servidor regularmente, clique em Sim, manter ativado o serviço de indexação.
  • Se você quiser preservar os recursos da CPU e da memória, clique em Não, desativar o serviço de indexação. O Serviço de indexação pode prejudicar o desempenho do servidor.

O serviço de indexação oferece uma maneira rápida, fácil e segura para a pesquisa de informações locais ou na rede. Os usuários podem pesquisar em arquivos de diferentes formatos e idiomas, seja através do comando Pesquisar do menu Iniciar ou através de páginas HTML exibidas em um navegador.

Quando terminar, clique em Avançar.

Resumo das seleções

Na página Resumo das seleções, examine e confirme as opções que você selecionou. Se você selecionou Servidor de arquivos na página Função do servidor, aparecerá o seguinte:

  • Instalar gerenciamento de servidor de arquivos
  • Execute o 'Assistente para compartilhar pasta' para adicionar novas pastas compartilhadas ou compartilhas pastas existentes

Para aplicar as seleções mostradas na página Resumo das seleções, clique em Avançar.

Usando o Assistente para compartilhamento de pasta

Depois que você clica em Avançar, o Assistente para configurar o servidor inicia automaticamente o Assistente para compartilhamento de pasta, que você usa para configurar pastas compartilhadas. Compartilhando recursos, você os disponibiliza a outros usuários da rede.

Importante

  • Seja cauteloso ao compartilhar pastas que contenham arquivos e recursos do sistema. Assegure-se de que a pasta ou o recurso que você especificou esteja livre de informações que não devam ser acessadas pelos usuários.

Esta seção descreve as seguintes etapas do Assistente para compartilhamento de pasta:

Caminho da pasta

Nome, descrição e configurações

Permissões

Compartilhamento bem-sucedido

Caminho da pasta

Na página Caminho da pasta, especifique o caminho da pasta que você deseja compartilhar. Para procurar por uma pasta, clique em Procurar.

Quando terminar, clique em Avançar.

Nome, descrição e configurações

Na página Nome, descrição e configurações, especifique as seguintes informações sobre a pasta compartilhada:

  • Em Nome do compartilhamento, digite o nome que você deseja usar no recurso compartilhado. É obrigatório fornecer o nome do compartilhamento. Escolha um nome curto e significativo, para facilitar a identificação pelos usuários.
  • Em Descrição, digite uma descrição do recurso compartilhado. A descrição é opcional. Se você estiver compartilhando vários recursos, as descrições poderão lhe ajudar a organizá-los e identificá-los. A descrição digitada aparece na coluna Descrição do Gerenciamento do servidor de arquivos e Pastas compartilhadas.
  • Em Configuração off-line, especifique como você deseja disponibilizar o conteúdo da pasta compartilhada aos usuários quando estes não estiverem conectados à rede. Se você quiser que os usuários possam controlar os arquivos disponíveis off-line, aceite o padrão exibido. Para alterar as configurações off-line, clique em Alterar. Use as informações da tabela abaixo para determinar as configurações que você deseja usar nos arquivos off-line.
    • Configuração off-line | Comentários
Apenas os arquivos e programas que os usuários especificarem estarão disponíveis off-line | Se você quiser que os usuários possam controlar os arquivos disponíveis off-line, clique nessa opção.
Todos os arquivos e programas que os usuários abrirem do compartilhamento estarão automaticamente disponíveis off-line | Se você quiser permitir que todos os arquivos abertos pelos usuários na pasta compartilhada estejam automaticamente disponíveis off-line, clique nesta opção. Se você marcar a caixa Otimizado para desempenho, todos os programas serão automaticamente armazenados em cache para que os usuários possam executá-los localmente. Essa opção é especialmente útil para servidores de arquivos que hospedam aplicativos, porque reduz o tráfego na rede e melhora o desempenho do servidor.
Os arquivos ou programas do compartilhamento não estarão disponíveis off-line | Se você quiser impedir os usuários de armazenar arquivos off-line, clique nessa opção.

Quando terminar, clique em Avançar.

Permissões

Na página Permissões, especifique as permissões de compartilhamento da pasta compartilhada. Para assegurar que somente usuários autorizados tenham acesso às informações contidas na pasta, defina permissões na pasta criada. As permissões de compartilhamento se aplicam apenas aos usuários que obtiverem acesso aos recursos através de rede. Elas não se aplicam a usuários que obtêm acesso ao recurso no computador em que ele está armazenado. Use a tabela abaixo para determinar as permissões de compartilhamento adequadas.

Permissão de compartilhamento | Comentários
Todos os usuários possuem acesso somente leitura | Para restringir todo acesso a somente leitura, clique nessa opção.
Os administradores possuem acesso total; outros usuários possuem acesso somente leitura | Se você quiser que os usuários visualizem arquivos e executem programas localizados no recurso compartilhado, clique nessa opção. Somente os membros do grupo Administradores podem alterar, adicionar ou excluir arquivos. Além disso, somente os membros do grupo Administradores podem alterar as permissões de arquivos NTFS do recurso compartilhado.
Administradores possuem acesso total; outros usuários possuem acesso de leitura e gravação | Se você quiser restringir o acesso de todos os usuários para leitura e gravação, exceto para os membros do grupo Administradores, clique nessa opção.
Usar permissões personalizadas de compartilhamento e pasta | Se você quiser conceder ou denegar acesso a usuários ou grupos específicos, clique nessa opção. Você deve atribuir permissões mais restritivas que ainda permitam que os usuários realizem as funções necessárias.

Quando terminar, clique em Concluir.

Compartilhamento bem-sucedido

Na página O compartilhamento foi bem-sucedido, o Assistente para compartilhamento de pasta exibe um status e um resumo das seleções. Se você quiser compartilhar outra pasta, marque a caixa Quando eu clicar em 'Fechar', executar o assistente novamente para compartilhar outra pasta. Ao terminar de compartilhar pastas, clique em Fechar.

Concluindo o Assistente para configurar o servidor

Depois que você concluir o Assistente para compartilhamento de pasta, o Assistente para configurar o servidor exibirá a página Este servidor agora é um servidor de arquivos. Para rever todas as alterações feitas no servidor pelo Assistente para configurar o servidor ou certificar-se que uma nova função foi instalada com sucesso, clique em Log de Configuração do servidor. O log Assistente para configurar o servidor localiza-se em systemroot\Debug\Configure Your Server.log. Para fechar o Assistente para configurar o servidor, clique em Concluir.

Removendo a função do servidor de arquivos

Se for necessário reconfigurar seu servidor para uma outra função, você poderá remover funções existentes do servidor. Se você remover a função do servidor de arquivos, os arquivos e pastas desse servidor não serão mais compartilhados, e os usuários, programas ou hosts que dependem desses recursos compartilhados não poderão se conectar a eles.

Para remover a função de servidor de arquivos, reinicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Servidor de arquivos e, em seguida, clique em Avançar. Na página Confirmação de remoção de função, reveja os itens listados em Resumo, marque a caixa Remover a função de servidor de arquivos e clique em Avançar. Na página Função de servidor de de arquivos removida, clique em Concluir.

Próximas etapas: Concluindo tarefas adicionais

Depois que você concluir o Assistente para configurar o servidor e criar recursos compartilhados, o computador estará pronto para ser usado como um servidor de arquivos básico, podendo armazenar, gerenciar e compartilhar informações como arquivos e aplicativos acessíveis pela rede. Até este ponto, você concluiu as seguintes tarefas:

  • Se necessário, estabeleceu limites de espaço em disco ativando as cotas de disco.
  • Se necessário, ativou o Serviço de indexação.
  • Criou pastas compartilhadas e definiu permissões de compartilhamento para cada pasta.

O Assistente para configurar o servidor instalará automaticamente o Gerenciamento de servidor de arquivos, que você usará para gerenciar o servidor de arquivos. XOX

A tabela a seguir lista algumas tarefas adicionais que você pode executar no servidor de arquivos.

Tarefa | Objetivo da tarefa | Referência
Proteger o servidor de arquivos. | Assegurar que o servidor de arquivos esteja protegido. | Práticas recomendadas de segurança
Implementar o Sistema de arquivos com criptografia (EFS). | Reforçar a segurança dos arquivos e recursos contidos no servidor de arquivos. | Criptografando e descriptografando dados
Definir permissões em arquivos e pastas compartilhadas. | Proteger os recursos do servidor de arquivos e impedir o acesso não autorizado. O controle de acesso do sistema de arquivos NTFS fornece mais segurança que as permissões de compartilhamento. | Definir permissões em um recurso compartilhado
Disponibilizar recursos compartilhados off-line. | Permitir que os usuários armazenem cópias locais de recursos compartilhados, para que possam acessá-los quando não estiverem conectados à rede. | Definir configurações off-line para um recurso compartilhado
Ativar cópias de sombra de pastas compartilhadas. | Permitir a cópia de sombra de pastas compartilhadas, que fornecem cópias precisas de arquivos de compartilhamentos de redes. | Ativar cópias de sombra de pastas compartilhadas
Configurar um Sistema de arquivos distribuídos (DFS). | Facilitar, para os usuários, o acesso e o gerenciamento de arquivos fisicamente distribuídos pela rede. | Lista de verificação: criar um sistema de arquivos distribuídos.
Certificar-se de ter feito um backup adeq uado do servidor de arquivos. | Para proteger os dados contra perda acidental se o sistema tiver falha de hardware ou de mídia de armazenamento. | Fazer backup dos dados
Usar a compactação de arquivos. | Para conservar o espaço de armazenamento compactando arquivos, pastas e programas. | Visão geral sobre a compactação de arquivos


Função do servidor de impressão: Configurando um servidor de impressão

Se você planeja usar este computador para gerenciar e compartilhar impressoras, configure-o como um servidor de impressão.

Observação

  • XOX

Este documento explica como usar o Assistente para configurar o servidor para atender rapidamente os requisitos mais básicos de um servidor de impressão. Depois de configurar um servidor de impressão básico, você pode executar outras tarefas de configuração, dependendo de como você deseja usar o servidor de impressão.

Este tópico aborda o seguinte:

  • Antes de começar
  • Configurando o servidor de impressão
  • Próximas etapas: Concluindo tarefas adicionais

Antes de começar

Antes de configurar o servidor como um servidor de impressão, verifique se:

  • O sistema operacional está configurado corretamente. Na família Windows Server 2003, os serviços de impressão dependem da configuração adequada do sistema operacional e seus serviços. Se houver uma nova instalação de um sistema operacional Windows Server 2003, você poderá usar as configurações padrão do serviço. Nenhuma outra ação é necessária. Se você fez uma atualização para um sistema operacional Windows Server 2003 ou se deseja confirmar se os serviços estão configurados corretamente para obter melhor desempenho e segurança, verifique as configurações dos serviços comparando-os à tabela em Configurações padrão de serviços.
  • O computador é associado a um domínio do Active Directory como servidor membro. O servidor de impressão deve ser associado a um domínio se você quiser restringir o acesso a alguma impressora, para que apenas determinados usuários do domínio possam utilizá-la, ou se desejar que o servidor de impressão publique asimpressoras compartilhadas no Active Directory, para que os usuários do domínio possam facilmente encontrar essas impressoras. Se você não precisa realizar essas tarefas, não é necessário associar o servidor de impressão a um domínio.
  • Todos os volumes de disco existentes usam o sistema de arquivos NTFS. Os volumes FAT32 não são tão seguros. Para obter mais informações sobre a criptografia de dados armazenados em volumes NTFS, inclusive trabalhos de impressão no spool, consulte Armazenando dados de forma segura.

A tabela a seguir lista as informações que você precisa saber antes de adicionar a função do servidor de impressão.

Antes de adicionar a função do servidor de impressão | Comentários
Determine a versão do sistema operacional dos clientes que enviarão trabalhos a esta impressora. | É necessário que você tenha essa informação para poder selecionar corretamente os drivers de impressão do cliente para os computadores clientes e servidor. Depois que você adiciona a função, o servidor de impressão pode distribuir automaticamente os drivers aos clientes. Além disso, o conjunto de sistemas operacionais dos clientes determina o driver que você precisa instalar no servidor para a instalação da função do servidor de impressão.
Na impressora, imprima uma página de configuração ou de teste que contenha informações sobre o fabricante, o modelo, a linguagem e as opções instaladas. | Você precisará dessas informações para escolher o driver de impressão correto. As informações sobre o fabricante e o modelo geralmente são suficientes para identificar de forma exclusiva a impressora e sua linguagem. No entanto, algumas impressoras oferecem suporte a várias linguagens, que são geralmente listadas na impressão das configurações. Ademais, a impressão das configurações freqüentemente relaciona as opções instaladas, como memória adicional, bandejas de papel, alimentadores de envelopes e unidades de impressão duplex.
Determine a forma como o servidor de impressão se conecta à impressora. Se a impressora oferece suporte para Plug and Play e conecta-se ao servidor de impressão usando a tecnologia de infravermelho, uma porta Universal Serial Bus (USB) ou uma porta IEEE 1394, o servidor de impressão será automaticamente configurado. Você não precisa executar o restante do procedimento.

Caso contrário, se a impressora estiver conectada ao servidor de impressão por um cabo, identifique a porta do servidor está sendo utilizada. Em impressoras, LPT1 é a porta normalmente usada.

Se a impressora estiver distante do servidor de impressão e usar seu próprio adaptador de rede para receber trabalhos de impressão, determine o endereço IP do adaptador de rede na impressora.
(Opcional) Determine se você precisa de um driver de impressão novo ou atualizado. | Há drivers de suporte para a maioria das impressoras no CD de instalação do sistema operacional Windows Server 2003. Para economizar tempo você pode ignorar essa etapa, já que o assistente que você usará para configurar o servidor de impressão fornece informações sobre compatibilidade. Se o assistente não listar um driver para sua impressora, procure uma atualização no fabricante da máquina ou no Windows Update.
Escolha um nome para a impressora. | Os usuários que utilizam computadores clientes baseados no Windows escolhem a impressora pelo nome. O assistente que você usará para configurar o servidor de impressão oferece um nome padrão, composto pelo nome do fabricante e modelo da impressora. O nome da impressora geralmente tem até 31 caracteres.
Escolha um nome de compartilhamento. | O usuário pode se conectar a uma impressora compartilhada digitando o nome dela ou selecionando-a em uma lista de nomes de compartilhamentos. Geralmente, o nome de compartilhamento tem até 8 caracteres, por razões de compatibilidade com os clientes MS-DOS e Windows 3.x.
(Opcional) Escolha uma descrição e um comentário para a localização da impressora. | Isso pode ajudar a identificar a localização da impressora, fornecendo informações adicionais. Por exemplo, a localização poderia ser "Segundo andar, sala de impressão" e, o comentário, "Cartuchos de toner disponíveis no almoxarifado do primeiro andar".

Configurando o servidor de impressão

Para configurar o servidor de impressão, inicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Servidor de impressão e, em seguida, clique em Avançar.

Esta seção aborda os seguintes tópicos:

Impressoras e drivers de impressoras

Resumo das seleções

Usando o Assistente para adicionar impressora.

Usando o Assistente para adicionar driver de impressora.

Concluindo o Assistente para configurar o servidor

Removendo a função do servidor de impressão

Impressoras e drivers de impressoras

Na guia Impressoras e drivers de impressora, siga um destes procedimentos:

  • Se todos os clientes da rede executarem XOX, XOX ou Windows 2000, clique em Apenas clientes do Windows 2000 e XOX.
  • Se algum dos clientes executar XOX, Windows NT 4.0, Windows Millennium Edition, Windows 98 ou Windows 95, clique em Todos os clientes do Windows.

Quando terminar, clique em Avançar.

Resumo das seleções

Na página Resumo das seleções, examine e confirme as opções que você selecionou. Se você selecionou Apenas clientes do Windows 2000 e XOX na página anterior, aparecerá o seguinte:

  • Adicionar impressoras a este servidor usando o Assistente para adicionar impressora.

Se você selecionou Todos os clientes do Windows na página anterior, aparecerá o seguinte:

  • Adicionar impressoras a este servidor usando o Assistente para adicionar impressora.
  • Adicionar impressoras a este servidor usando o Assistente para adicionar driver de impressora.

Para aplicar as seleções mostradas na página Resumo das seleções, clique em Avançar.

Usando o Assistente para adicionar impressora

Depois que você clicar em Avançar, o Assistente para configurar o servidor executa o Assistente para adicionar impressora uma vez para cada impressora que você deseja adicionar. Se o assistente for concluído e você escolher compartilhar pelo menos uma impressora, seu servidor pode ser usado como servidor de impressão. Se você cancelar o Assistente para adicionar impressora, o serviço de Spooler de impressão permanece instalado. Se você cancelar o Assistente para adicionar impressora e não houver impressoras compartilhadas, o servidor não adiciona a função do servidor de impressão.

Importante

  • Se a impressora que você deseja compartilhar oferece suporte para Plug and Play, não execute o Assistente para adicionar impressora. As impressoras Plug and Play concluem automaticamente as etapas de configuração do Assistente para adicionar impressora. Se a impressora que você deseja compartilhar oferece suporte para Plug and Play, clique em Cancelar.

Esta seção descreve as seguintes etapas do Assistente para adicionar impressora:

Impressora local ou de rede

Detecção da nova impressora

Selecionar uma porta de impressora

Especificar uma impressora

Instalar o software da impressora

Usar o driver existente

Fornecer um nome para a impressora

Compartilhamento de impressora

Local e comentário

Imprimir a página de teste

Concluir o Assistente para adicionar impressora.

Impressora local ou de rede

Na página Impressora local ou de rede do Assistente para adicionar impressora, escolha uma das seguintes opções.

  • Para configurar este servidor de impressão para enviar trabalhos de impressão diretamente à impressora, clique em Impressora local conectada ao computador. Geralmente, os servidores de impressão enviam os trabalhos diretamente à impressora. Uma impressora com seu próprio adaptador de rede é considerada uma impressora local. Se você quiser enviar trabalhos de impressão diretamente a uma impressora que possua seu próprio adaptador de rede, clique nessa opção.
  • Para configurar este servidor de impressão para encaminhar trabalhos de impressão a um segundo servidor de impressão, clique em Uma impressora de rede, ou uma impressora conectada a outro computador. Por exemplo, você pode configurar um servidor de impressão no escritório da filial para encaminhar os trabalhos de impressão ao servidor de impressão do escritório da sede da empresa. Você pode fazer isso se as regras da empresa exigirem a impressão de logs das transações diárias para armazenamento na sede. Para isso, clique nessa opção.

    • Observação

    • A opção Uma impressora de rede, ou uma impressora conectada a outro computador aparece aqui porque essa caixa de diálogo é usada em todos os computadores que executam o sistema operacional Windows Server 2003, para que os usuários possam se conectar a uma impressora de rede. Se você precisar imprimir de um computador que não é um servidor de impressão, clique em Uma impressora de rede, ou uma impressora conectada a outro computador.

Quando terminar, clique em Avançar.

Depois de clicar em Avançar, uma das seguintes páginas de assistente aparecerá:

Detecção da nova impressora

Se você marcou a caixa Detectar e instalar automaticamente a impressora Plug and Play e o assistente não conseguir detectar impressoras Plug and Play, está página será exibida. Clique em Avançar.

Para concluir o procedimento da página Selecione uma porta de impressora, consulte Selecionar uma porta de impressora.

Selecionar uma porta de impressora

Se você selecionou Impressora local conectada ao computador, será exibida esta página.

Na página Selecione uma porta de impressora, escolha uma das seguintes opções:

  • Se um cabo conecta a impressora diretamente a uma porta do servidor de impressão, clique no nome dessa porta em Usar a seguinte porta. LPT1 é a porta mais usada por esse tipo de impressora.
  • Se a impressora possuir seu próprio adaptador de rede e você quiser enviar trabalhos através da rede, clique em Criar uma nova porta e, em seguida, clique no tipo de porta que você deseja criar. Se você não souber o tipo de porta que deve ser criada, recomendamos escolher Porta TCP/IP padrão.

    • Se você clicar em Porta TCP/IP padrão e, depois, clicar em Avançar, será iniciado o Assistente para adicionar porta de impressora TCP/IP padrão. Clique em Avançar no Assistente para adicionar porta de impressora TCP/IP padrão. Na página Adicionar porta, digite o nome ou o endereço IP da impressora. Geralmente, o endereço IP é listado na página de configuração da impressora. À medida que você digita o nome ou o endereço IP, o assistente preenche o campo Nome da porta automaticamente. Clique em Avançar.

    O assistente tenta se conectar à impressora. Se o assistente conseguir se conectar, aparecerá a página Concluindo o Assistente para adicionar porta de impressora TCP/IP padrão e você pode clicar em Concluir. Se o assistente não conseguir se conectar, aparecerá a página São necessárias mais informações sobre a porta. Se você achar que o endereço ou o nome que digitou estão incorretos, clique em Voltar, digite novamente o nome ou o endereço e clique em Avançar.

    Se tiver certeza de que o endereço ou o nome estão corretos, selecione um dos tipos de dispositivos abaixo para identificar o adaptador de rede da impressora:

    • Padrão é o padrão. Se você clicar em Padrão, clique no fabricante e no modelo do adaptador de rede na lista Padrão.
    • Se o adaptador de rede da impressora utiliza configurações fora do padrão, clique em Personalizado e, em seguida, clique em Configurações. Aparecerá a página Configurar o monitor de porta TCP/IP padrão. Especifique as configurações recomendadas pelo fabricante do adaptador de rede da impressora e clique em OK.

Quando terminar, clique em Avançar.

Especificar uma impressora

Se você selecionou Uma impressora de rede, ou uma impressora conectada a outro computador, aparecerá essa página.

Na página Especifique uma impressora, escolha uma das seguintes opções para configurar seu servidor de impressão para encaminhar os trabalhos de impressão a outro servidor:

  • Se o servidor de impressão ao qual você deseja se conectar estiver disponível na rede, clique em Procurar impressora, clique em Avançar e, em Impressoras compartilhadas, clique no servidor e na impressora na lista.
  • Se o servidor de impressão ao qual você deseja se conectar estiver temporariamente indisponível na rede, clique em Conectar-se à impressora (marque esta opção e clique em 'Avançar' p/ procurar a impressora) e e digite os nomes do servidor e da impressora no campo Nome.
  • Se o servidor de impressão ao qual você deseja se conectar pertence a outra organização e está disponível na Internet, clique em Conectar-se a uma impressora na Internet ou em uma rede doméstica ou no escritório.

Importante

  • Use as opções dessa página somente se quiser que o servidor de impressão encaminhe os trabalhos de impressão a outro servidor. Se não quiser fazer isso, clique em Voltar, clique em Impressora local conectada ao computador, clique em Avançar e siga as etapas de Selecionar uma porta de impressora.

Quando terminar, clique em Avançar.

Nesse caminho de configuração, você pode ignorar algumas etapas deste documento. Para continuar as instruções deste caminho de configuração, consulte Concluindo o Assistente para adicionar impressora.

Instalar o software da impressora

Na página Instalar software de impressora do Assistente para adicionar impressora, em Fabricante, clique no fabricante da impressora e, em seguida, em Impressoras, clique no modelo.

Observação

  • Anote o fabricante e o modelo selecionados. Você precisará dessas informações posteriormente se usar o Assistente para adicionar driver de impressora para instalar drivers de impressora em outros clientes baseados no Windows.

Se o fabricante ou o modelo não for listado, tente executar as etapas indicadas na tabela abaixo, em seqüência, para instalar o software de impressora correto.

Etapa | Comentários
Verifique a impressão das configurações para confirmar que os nomes do fabricante e do modelo da impressora foram escritos corretamente. | As listas Fabricante e Impressoras mostram os nomes oficiais dos produtos, que podem ser diferentes dos nomes que você normalmente usa.
Clique em Com disco, localize os arquivos do driver e clique em OK. | Se os arquivos do driver de impressora estiverem armazenados em outro local, siga essas etapas. Por exemplo, o fabricante da impressora pode incluir um CD-ROM contendo os arquivos do driver na embalagem da impressora.
Clique em Windows Update. | Se você quiser procurar drivers novos ou atualizados disponibilizados pela Microsoft como parte do Windows Update, clique nessa opção. Quando você clica em Windows Update, as listas Fabricante e Impressoras passam a mostrar somente os drivers disponíveis no Windows Update. Se a impressora não for listada, retorne à lista original clicando em Voltar e, em seguida, em Avançar.
Selecione o fabricante e o modelo de uma impressora compatível e clique em Avançar. | Para identificar as impressoras compatíveis, consulte o guia do usuário da impressora. Além disso, alguns fabricantes fornecem informações sobre compatibilidade em seus sites da Web.

Quando terminar, clique em Avançar.

Usar o driver existente

Se você adicionar outra impressora com o mesmo nome de fabricante e modelo de uma impressora já instalada, aparecerá a página Usar o driver existente. Decida se quer manter o mesmo driver ou substituí-lo por um novo. Se você selecionar Substituir o driver existente, o assistente reinstalará os arquivos do driver.

Quando terminar, clique em Avançar.

Fornecer um nome para a impressora

Na página Forneça um nome para a impressora do Assistente para adicionar impressora, o nome padrão é o nome do fabricante seguido do modelo da impressora. Você pode mudar esse nome para facilitar o uso e a administração da impressora. Ao utilizar aplicativos, os usuários freqüentemente selecionam uma impressora contida na lista que exibe os nomes das impressoras disponíveis. Para ajudá-los a decidir qual impressora selecionar, o aplicativo pode, também, listar a localização ou um comentário.

Em Deseja que esta seja a impressora padrão?, clique em Sim ou Não. A resposta será aplicada apenas quando você imprimir de um aplicativo que está sendo executado nesse servidor de impressão. A resposta não define a impressora como aquela que será usada pelos clientes por padrão.

Quando terminar, clique em Avançar.

Compartilhamento de impressora

Importante

  • É necessário compartilhar pelo menos uma impressora para que este servidor funcione como servidor de impressão.

Na página Compartilhamento de impressora do Assistente para adicionar impressora, Nome do compartilhamento é selecionado por padrão, para que a impressora seja compartilhada. O nome de compartilhamento padrão é composto pelas primeiras 8 letras do nome do fabricante e do modelo da impressora, sem espaços. Você pode mudar esse nome para facilitar o uso e a administração da impressora.

Para oferecer compatibilidade aos clientes que executam MS-DOS ou versões anteriores do Windows, digite um nome de compartilhamento seguindo estas regras:

  • O nome de compartilhamento contém apenas letras, números e o ponto final (.).
  • O nome do compartilhamento não contém mais de oito letras e números e, opcionalmente, antecede um ponto final, que é seguido de até três letras ou números.

Quando terminar, clique em Avançar.

Local e comentário

Na página Local e comentário do Assistente para adicionar impressora, em Local, digite uma descrição do local do servidor de impressão e, em Comentário, digite um comentário. Essa etapa é opcional, mas recomendável, já que as informações facilitam o uso e a administração do servidor de impressão. Muitos aplicativos exibem o comentário ou o local quando o usuário imprime um documento. Dessa forma, o usuário pode escolher a impressora que lhe for mais adequada.

Quando terminar, clique em Avançar.

Imprimir a página de teste

Na página Imprimir página de teste do Assistente para adicionar impressora, escolha se você deseja imprimir uma página de teste para confirmar que a impressora está pronta para uso.

Observação

  • A página de teste não é automaticamente impressa quando você clica em Avançar. Ela é impressa quando você conclui o assistente.

Quando terminar, clique em Avançar.

Concluir o Assistente para adicionar impressora.

Na página Concluindo o Assistente para adicionar impressora, a caixa Reiniciar o assistente para adicionar outra impressora é selecionada por padrão. Se você deixá-la selecionada e clicar em Concluir, o assistente será reiniciado para adicionar outra impressora. Se você terminou de adicionar todas as impressoras que queria compartilhar nesse servidor, desmarque essa caixa e clique em Concluir.

Quando você clica em Concluir, o assistente instala os arquivos do driver de impressora. Em seguida, se você escolheu imprimir uma página de teste, o assistente tenta imprimi-la. Se a impressora não receber a página de teste, talvez você tenha selecionado a porta incorreta. No entanto, se a impressora receber a página de teste e imprimi-la incorretamente, talvez você tenha selecionado fabricante e modelo incompatíveis.

Quando você iniciou o Assistente para configurar o servidor para configurar este como o servidor de impressão, selecionou uma das opções abaixo na página Impressoras e drivers de impressora:

  • Apenas clientes do Windows 2000 e XOX
  • Todos os clientes do Windows

Se você selecionou Todos os clientes do Windows, o Assistente para adicionar driver de impressora será iniciado depois que você clicar em Concluir no Assistente para adicionar impressora. Você pode usar o Assistente para adicionar driver de impressora para instalar drivers de impressora clientes no servidor de impressão, que poderá, então, distribuí-los automaticamente aos clientes.

Observação

  • O Assistente para adicionar driver de impressora não se comunica com o Assistente para adicionar impressora. Portanto, o Assistente para adicionar driver de impressora não é executado automaticamente para cada impressora que você adicionar e não instala automaticamente os drivers para o mesmo fabricante e modelo de impressora. Em vez disso, você deve decidir quantas vezes quer executar o Assistente para adicionar driver de impressora e, a cada vez que ele for executado, você deve escolher o fabricante e o modelo dos drivers a serem instalados.

Usando o Assistente para adicionar driver de impressora

Se você selecionou Todos os clientes do Windows na página Impressoras e drivers de impressora do Assistente para configurar o servidor, o Assistente para adicionar driver de impressora será iniciado após o Assistente para adicionar impressora. Se você cancelar o Assistente para adicionar driver de impressora, o serviço de Spooler de impressão permanecerá instalado e as impressoras adicionadas serão mantidas, mas os arquivos de driver cliente adicionais não serão instalados no servidor. Conseqüentemente, o servidor não poderá distribuir esses drivers aos clientes.

Esta seção descreve as seguintes etapas do Assistente para adicionar driver de impressora:

Seleção de driver de impressora

Seleção de processador e sistema operacional

Concluindo o Assistente para adicionar driver de impressora

Seleção de driver de impressora

Na página Seleção de driver de impressora do Assistente para adicionar driver de impressora, selecione o fabricante e o modelo de uma impressora compartilhada neste servidor de impressão e clique em Avançar.

Importante

  • O Assistente para adicionar driver de impressora não seleciona automaticamente um fabricante e um modelo para uma impressora que você já tenha adicionado. Em vez disso, ele seleciona o primeiro fabricante da lista e o nome do primeiro modelo de impressora (em ordem alfabética) daquele fabricante. Se possível, selecione o fabricante e o modelo de uma impressora que você já adicionou. Se você selecionar um fabricante ou um modelo diferente, o assistente poderá instalar drivers que não funcionem corretamente com a impressora.

Seleção de processador e sistema operacional

Na página Seleção de processador e sistema operacional do Assistente para adicionar driver de impressora, selecione os sistemas operacionais e os processadores clientes.

Os drivers para o sistema operacional do seu servidor são automaticamente instalados quando você adiciona uma impressora. Como resultado, uma das opções abaixo é selecionada, sem que seja possível removê-la: Windows 2000, Windows XP e Windows Server 2003 para processadores baseados em x86 ou Windows XP e Windows Server 2003 para processadores baseados em Itanium.

Quando terminar, clique em Avançar.

Concluindo o Assistente para adicionar driver de impressora

Na página Concluindo o Assistente para adicionar driver de impressora, a caixa Reiniciar o assistente para adicionar outro driver de impressora é selecionada por padrão. Se você deixá-la selecionada e clicar em Concluir, o assistente será reiniciado para adicionar outro driver de impressora. Se você terminou de adicionar todos os drivers de impressora que queria compartilhar nesse servidor, desmarque essa caixa e clique em Concluir.

Concluindo o Assistente para configurar o servidor

Depois que você concluir o Assistente para adicionar impressora e, se necessário, o Assistente para adicionar driver de impressora, o Assistente para configurar o servidor exibirá a página Este servidor agora é um servidor de impressão. Para rever todas as alterações feitas no servidor pelo Assistente para configurar o servidor ou certificar-se que uma nova função foi instalada com sucesso, clique em Log de Configuração do servidor. O log Assistente para configurar o servidor localiza-se em systemroot\Debug\Configure Your Server.log. Para fechar o Assistente para configurar o servidor, clique em Concluir.

Removendo a função do servidor de impressão

Se for necessário reconfigurar seu servidor para uma outra função, você poderá remover funções existentes do servidor. Se você remover a função do servidor de impressão, todos os clientes que enviaram trabalhos apenas a este servidor de impressão não poderão imprimir até que você reconfigure cada cliente para envio de trabalhos a um servidor de impressão diferente. Além disso, todas as impressoras que são gerenciadas apenas por este servidor de impressão não poderão receber trabalhos até que você reconfigure outro servidor de impressão para enviar trabalhos àquelas impressoras.

Para remover a função do servidor de impressão, reinicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Servidor de impressão e, em seguida, clique em Avançar. Na página Confirmação de remoção de função, reveja os itens listados em Resumo, marque a caixa Remover a função de servidor de impressão e clique em Avançar. Na página Função de servidor de impressão removida, clique em Concluir.

Próximas etapas: Concluindo tarefas adicionais

Depois que você concluir o Assistente para configurar o servidor, o servidor estará pronto para uso como servidor de impressão. Seguindo as etapas deste documento, você:

  • Adicionou uma ou mais impressoras.
  • Compartilhou impressoras para que os clientes pudessem enviar trabalhos de impressão.
  • Se necessário, adicionou drivers de impressão clientes.

Você pode usar o Assistente para adicionar impressora e o Assistente para adicionar driver de impressora para adicionar mais impressoras e drivers clientes. Esses assistentes estão disponíveis em Gerenciar o servidor.

A tabela a seguir lista algumas tarefas adicionais que você pode executar no servidor de impressão.

Tarefa | Objetivo da tarefa | Referência
Definir a configuração correspondente às opções instaladas. | Fornecer ao usuário acesso às opções instaladas, como alimentador de envelopes ou memória adicional, disponíveis em algumas impressoras. Se sua impressora oferece outros recursos, você deve atualizar a configuração para que os usuários possam usá-los. | Definir opções instaláveis de uma impressora
Definir os padrões de impressão. | Definir a configuração padrão para os clientes, quando estes se conectarem à impressora. Por exemplo, você pode definir o layout padrão ou a origem do papel. | Definir os padrões de impressão
Atribuir permissões de impressora. | Alterar as permissões dos usuários para a impressora. | Definir ou remover permissões para uma impressora
Escolher uma página separadora. | Definir a inclusão de uma página no início de cada impressão. | Escolher uma página separadora
Configurar os clientes de rede para usar a impressora. | Configurar os clientes que se conectarão às impressoras compartilhadas neste servidor de impressão. | Conectar clientes a uma impressora
Definir tarefas de impressora avançadas. | Gerenciar o servidor de impressão com mais eficácia e eficiência. Por exemplo, programar tempos de impressão alternativos, ativar o rastreamento do local da impressora ou definir prioridades diferentes para grupos diferentes. | Usar opções avançadas
Publicar uma impressora no Active Directory. | Ajudar os usuários do domínio a encontrar rapidamente impressoras compartilhadas por este servidor de impressão. Para essa tarefa, o servidor de impressão deve ser um servidor membro. | Publicar uma impressora no Active Directory


Função do servidor de aplicativos: Configurando um servidor de aplicativos

O servidor de aplicativos é uma tecnologia fundamental que fornece infra-estrutura e serviços importantes aos aplicativos hospedados em um sistema. Os servidores de aplicativos típicos incluem o seguinte:

  • Pool de recursos (por exemplo, pool de conexões com bancos de dados e pool de objetos)
  • Gerenciamento distribuído de transações
  • Comunicação assíncrona entre programas, geralmente através de enfileiramento de mensagens
  • Um modelo de ativação de objetos just-in-time
  • Interfaces automáticas dos serviços XML da Web para acessar objetos de negócios
  • Serviços de detecção de failover e da integridade do aplicativo
  • Segurança integrada

A família Windows Server 2003 traz toda essa funcionalidade, além dos serviços para o desenvolvimento, implantação e gerenciamento em tempo de execução de serviços XML da Web, aplicativos para Web e aplicativos distribuídos.

Este tópico explica o procedimento básico para configurar um servidor de aplicativos. O processo envolve o uso do Assistente para configurar o servidor na configuração de um servidor de aplicativos. Ao terminar de configurar um servidor de aplicativos básico, você pode executar outras tarefas usando Gerenciar o servidor.

Este tópico aborda o seguinte:

  • Antes de começar
  • Configurando o servidor de aplicativos
  • Próximas etapas: Concluindo tarefas adicionais

Antes de começar

Antes de configurar o computador como um servidor de aplicativos, verifique se:

  • Todos os volumes de disco existentes usam o sistema de arquivos NTFS. Volumes FAT32 não são protegidos e não oferecem suporte à compactação de arquivos e pastas, a cotas de disco, à criptografia de arquivos ou a permissões de arquivo individuais. Para descobrir o tipo de sistema de arquivos, em Meu computador clique com o botão direito no volume de disco e clique em Propriedades.
  • O computador possui conectividade de rede e um endereço IP estático ou dinâmico.

A tabela a seguir lista as informações que você precisa saber antes de adicionar a função do servidor de aplicativos.

Antes de adicionar a função do servidor de aplicativos | Comentários
Conheça as seguintes tecnologias instaladas automaticamente durante a configuração do servidor de aplicativos:
  • IIS (Serviços de informações da Internet)
  • Console do Servidor de aplicativos
  • COM+
  • Coordenador de transações distribuídas (DTC)
  • O IIS 6.0 é um servidor Web completo que fornece a infra-estrutura para .NET e aplicativos e serviços da Web existentes.
  • COM + é uma extensão do Modelo de objeto componente (COM). COM+ é montado nos serviços e recursos integrados de COM, facilitando, para os desenvolvedores, a criação e o uso de componentes de software em qualquer linguagem, com qualquer ferramenta.
  • O console do Servidor de aplicativos fornece um local central do qual você pode administrar seus aplicativos da Web. Para abrir o console do Servidor de aplicativos, em Gerenciar o servidor, clique em Gerenciar este servidor de aplicativos.
  • O Coordenador de transações distribuídas (DTC) coordena as transações COM+.
Determine se você quer instalar as Extensões de servidor do FrontPage. | As Extensões de servidor do FrontPage permitem que os usuários de um computador cliente publiquem e administrem sites remotamente em um servidor em rede.
Determine se você quer executar aplicativos ASP.NET no servidor. | A ASP .NET é uma plataforma unificada de desenvolvimento da Web que oferece os serviços necessários para que os desenvolvedores possam criar aplicativos da Web de nível empresarial. Você pode ativar a ASP .NET para desenvolver aplicativos da Web.

Configurando o servidor de aplicativos

Para configurar o servidor de aplicativos, inicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Servidor de aplicativos (IIS, ASP.NET) e, em seguida, clique em Avançar.

Esta seção aborda os seguintes tópicos:

Opções do servidor de aplicativos

Resumo das seleções

Concluindo o Assistente para configurar o servidor

Removendo a função do servidor de aplicativos

Opções do servidor de aplicativos

Na página Opções de servidor de aplicativos, você pode escolher instalar os seguintes componentes opcionais com o servidor de aplicativos

  • Extensões de servidor do FrontPage — com as extensões de servidor do FrontPage, vários usuários podem administrar e publicar remotamente um site de um computador cliente. Selecione esta opção se você quiser permitir que vários usuários criem sites simultaneamente ou que os usuários criem aplicativos da Web em seus computadores clientes, remotamente, pela Internet.
  • Ativar ASP.NET — a ASP .NET é uma plataforma unificada de aplicativos da Web que oferece os serviços necessários para a criação e a implantação de aplicativos da Web de nível empresarial. A ASP .NET oferece novos modelo e infra-estrutura de programação, proporcionando aos aplicativos mais segurança, desempenho e estabilidade que pode se aplicar a qualquer navegador ou dispositivo. Se seu site inclui aplicativos que foram desenvolvidos com a ASP .NET, selecione essa opção. Se você estiver incerto sobre a necessidade de habilitar a ASP .NET, pode optar por habilitá-la posteriormente usando o Gerenciador do IIS. XOX Habilitando a ASP .NET, você pode usar o servidor de aplicativos para hospedar aplicativos ASP .NET. A ASP .NET conta com os seguintes recursos:
    • A ASP .NET pode ser executada simultaneamente com o código Active Server Pages (ASP) no IIS. Se você já estiver executando o código ASP, não precisa atualizar as páginas ASP. Você pode adicionar as páginas ASP. NET aos aplicativos.
    • A ASP. NET apresenta desempenho avançado.
    • A ASP. NET oferece suporte para várias linguagens, inclusive Visual Basic .NET, C# e JScript .NET

Quando terminar, clique em Avançar.

Resumo das seleções

Na página Resumo das seleções, você pode examinar e confirmar as opções que selecionou. Se você selecionou Servidor de aplicativos (IIS, ASP .NET) na página Função do servidor, aparecerá o seguinte:

  • Instalar Serviços de Informações da Internet (IIS)
  • Ativar COM+ para transações remotas
  • Ativar o Coordenador de transações distribuídas da Microsoft (DTC) para acesso remoto

Se você selecionou Extensões de servidor do FrontPage ou ASP .NET, os seguintes itens também aparecerão:

  • Instalar extensões de servidor do FrontPage
  • Ativar ASP .NET

Para aplicar as seleções mostradas na página Resumo das seleções, clique em Avançar. Quando você clica em Avançar, a página Configurando componentes do Assistente de componentes do Windows é exibida e, depois, fechada automaticamente. Você não pode clicar em Voltar ou Avançar nesta página.

Concluindo o Assistente para configurar o servidor

Após a reinicialização do servidor, o Assistente para configurar o servidor exibe a página Este servidor agora é um servidor de aplicativos. Para rever todas as alterações feitas no servidor pelo Assistente para configurar o servidor ou certificar-se que uma nova função foi instalada com sucesso, clique em Log de Configuração do servidor. O log Assistente para configurar o servidor localiza-se em systemroot\Debug\Configure Your Server.log. Para fechar o Assistente para configurar o servidor, clique em Concluir.

Se a instalação não for bem-sucedida, aparecerá a página Não é possível concluir a operação e não será possível instalar o IIS. Para solucionar o problema ocorrido na instalação, clique em Log de configuração do servidor.

Removendo a função do servidor de aplicativos

Se for necessário reconfigurar seu servidor para uma outra função, você poderá remover funções existentes do servidor. Ao remover a função do servidor de aplicativos, você desinstala todos os seus componentes, como o IIS. O servidor não oferecerá mais suporte a páginas e aplicativos da Web ou a aplicativos distribuídos.

Para remover a função do servidor de aplicativos, reinicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Servidor de aplicativos (IIS, ASP.NET) e, em seguida, clique em Avançar. Na página Confirmação de remoção de função, reveja os itens listados em Resumo, marque a caixa Remover a função de servidor de aplicativos e clique em Avançar. Quando você clica em Avançar, a página Configurando componentes do Assistente de componentes do Windows é exibida e, depois, fechada automaticamente. Você não pode clicar em Voltar ou Avançar nesta página. Na página Função de servidor de aplicativos removida, clique em Concluir.

Próximas etapas: Concluindo tarefas adicionais

Depois que você concluir o Assistente para configurar o servidor e ativar os recursos necessários para executar os aplicativos, o computador estará pronto para ser usado como um servidor de aplicativos básico. Até este ponto, você concluiu as seguintes tarefas:

  • Instalou os Serviços de Informações da Internet (IIS), a ASP. NET e COM+.
  • Se necessário, ativou as Extensões de servidor do FrontPage.
  • Se necessário, ativou ASP .NET.

A tabela a seguir lista algumas tarefas adicionais que você pode executar no servidor de aplicativos.

Tarefa | Objetivo da tarefa | Referência
Proteger o servidor de aplicativos. Para garantir a segurança do servidor, recomendamos que você implemente precauções de segurança, como firewalls e segurança de protocolo internet (IPSec), antes de colocá-lo em um ambiente de produção. Um servidor de aplicativos pode ser alvo de ataques devido à sua exposição na Internet e em outras redes. Você pode proteger seus aplicativos usando protocolos de autenticação, controle de acesso, camada de soquetes de segurança (SSL) e criptografia. Segurança de protocolo Internet (IPSec);
Protegendo a rede com Firewall Básico;
Segurança em Serviços de Informações da Internet da Microsoft
Proteger os arquivos com NTFS. | Para proteger o site, os aplicativos, os bancos de dado e os arquivos, use permissões NTFS. Isso é essencial para se ter um site seguro. | Definir, exibir, alterar ou remover permissões de arquivos e pastas
Configurar a interface da Web para administração remota. | Gerenciar o servidor de aplicativos usando um navegador da Web em um computador remoto. | Usando a Interface da Web para Administração Remota
Criar um site. | Criar um site para hospedar o aplicativos da Web. | Configuração de Site em Serviços de Informações da Internet da Microsoft
Criar aplicativos com as mais modernas ferramentas de desenvolvimento. | Aprender sobre as mais recentes ferramentas de desenvolvimento da Microsoft que podem facilitar e dinamizar a criação de novos aplicativos. | Microsoft
Criar aplicativos ASP .NET para Web. | Criar aplicativos ASP .NET. | Creating ASP.NET Web Application no site da Microsoft.
Proteger os aplicativos ASP .NET da Web. | Garantir a segurança dos aplicativos ASP .NET. | ASP.NET Web Application Security no site da Microsoft.


Função do servidor de email: Configurando um servidor de email

Configure o computador como um servidor de email para instalar os Serviços de email, que oferecem a transferência e a recuperação de email. Os Serviços de email incluem os serviços POP3 e SMTP, que oferecem, respectivamente, a recuperação e a transferência de emails. Os administradores podem usar o serviço POP3 para armazenar e gerenciar contas de email no servidor de email. Depois de configurar o computador como um servidor de email, os usuários poderão se conectar a esse servidor e recuperar emails em seus computadores locais usando um cliente de email que ofereça suporte ao protocolo POP3, como o Microsoft Outlook.

Este tópico explica como usar o Assistente para configurar o servidor para instalar e configurar os Serviços de email. Ao concluir o Assistente para configurar o servidor, você deve executar outro procedimento para criar caixas de correio. Depois de concluir o Assistente para configurar o servidor e criar as caixas de correio adequadas, você terá um servidor de email inteiramente funcional.

Você pode configurar servidores membros e os servidores independentes como servidor de email. No entanto, haverá variação no método de autenticação padrão e nos métodos de autenticação disponíveis. Para obter mais informações sobre os métodos de autenticação padrão e os métodos disponíveis, consulte Antes de começar e Configurar o serviço POP3.

Este tópico aborda o seguinte:

Antes de começar

Configurando o servidor de email

Próximas etapas: Concluindo tarefas adicionais

Antes de começar

Antes de configurar o computador como um servidor de email, verifique se:

  • O servidor no qual você pretende instalar os serviços de email está conectado à Internet.
  • Existe uma partição NTFS disponível. Com a partição NTFS, você pode aproveitar a segurança mais eficaz oferecida pelas cotas de disco. Para obter mais informações sobre cotas de disco, consulte Configurando cotas de disco para o serviço POP3.
  • Você registrou o nome de domínio de email. Contate o seu provedor de serviços de Internet para obter auxílio para registrar um nome de domínio de email.
  • Existe um registro do Mail eXchanger (MX) para o nome de domínio de email, que corresponde ao nome do servidor. Contate seu provedor de serviços de Internet para criar um registro MX.
  • Você configurou seu servidor para endereçamento estático. Conte seu provedor de serviços de Internet para obter as informações necessárias para configurar o servidor para endereçamento estático. Para obter mais informações sobre como configurar seu servidor de email com um endereço IP estático, consulte Configurar o protocolo TCP/IP para endereçamento estático

A tabela a seguir lista as informações que você precisa saber antes de adicionar a função do servidor de email.

Antes de adicionar a função do servidor de email | Comentários
Determine o nível adequado de segurança para este servidor. | Um servidor com esta função pode ser alvo de ataques devido à sua exposição na Internet e em outras redes. Para garantir a segurança do servidor, recomendamos que você implemente precauções de segurança, como firewalls e segurança de protocolo Internet (IPSec), antes de colocá-lo em um ambiente de produção. Para obter mais informações, consulte Segurança do protocolo Internet (IPSec) e Protegendo a rede com Firewall básico.
Determine o método de autenticação adequado para sua configuração. Você deve escolher um método de autenticação antes de criar domínios de email no servidor de email. O método de autenticação só pode ser alterado se não houver domínios de email existentes no servidor de email.

Se o computador que você está configurando como servidor de email for um servidor membro ou um controlador de domínio, serão adotadas as configurações do método de autenticação padrão do Active Directory. Caso contrário, serão adotadas as configurações padrão da autenticação de contas locais do Windows.
Verifique se você registrou o nome de domínio de email. O domínio de email deve ter um nome registrado e deve corresponder ao registro do servidor de mensagens (MX) criado pelo provedor de serviços de Internet. Se você ainda não possui um nome de domínio de email, contate seu provedor de serviços de Internet para registrar o nome de domínio.

Observação

  • O serviço POP3 oferece suporte para nomes de domínio de primeiro nível e de terceiro nível. Por exemplo, há suporte para exemplo.com e servidordeemail.exemplo.com.

Configurando o servidor de email

Para configurar o servidor de email, inicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Servidor de email (POP3, SMTP) e, em seguida, clique em Avançar.

Esta seção aborda os seguintes tópicos:

Configurar o serviço POP3

Resumo das seleções

Concluindo o Assistente para configurar o servidor

Criando caixas de correio

Removendo a função do servidor de correio

Configurar o serviço POP3

Na página Configurar serviço POP3, em Método de autenticação, clique no método adequado para sua implantação. A família Microsoft® Windows® Server 2003 oferece suporte para os métodos de autenticação listados na tabela abaixo.

Use este método de autenticação | Quando
Contas locais do Windows | O servidor de email não é um servidor membro do Active Directory e você quer armazenar contas de usuários no servidor no qual o serviço POP3 foi instalado.
Integrado ao Active Directory | O servidor de email é um controlador de domínio ou um servidor membro
Arquivo de senha criptografada | O servidor de email não está usando o Active Directory ou você não quer ter contas de usuários para o serviço POP3 no computador local

Os métodos de autenticação disponíveis dependem da configuração do servidor.

  • Se o computador no qual o serviço POP3 estiver sendo executado for um servidor membro de um domínio do Active Directory, todos os três métodos de autenticação estarão disponíveis.
  • Se o computador que abriga o serviço POP3 for um controlador de domínio, os métodos de autenticação disponíveis serão a autenticação integrada do Active Directory e a autenticação de arquivo de senha criptografada.
  • Caso contrário, os métodos de autenticação disponíveis serão a autenticação de contas locais do Windows e a autenticação de arquivo de senha criptografada.

Em Nome de domínio de email, digite seu nome de domínio de email registrado. Você pode criar outros domínios de email posteriormente usando o snap-in do serviço POP3 ou a ferramenta da linha de comandos Winpop.

Quando terminar, clique em Avançar.

Resumo das seleções

Na página Resumo das seleções, você pode examinar e confirmar as opções que selecionou. Se você selecionou Servidor de email (POP3, SMTP) na página Função do servidor, aparecerá o seguinte:

  • Instale o POP3 e o Simple Mail Transfer Protocol (SMTP) para permitir que os clientes de correio POP3 enviem e recebam correio

Para aplicar as seleções mostradas na página Resumo das seleções, clique em Avançar. Depois que você clica em Avançar, a página Configurando componentes do Assistente de componentes do Windows é exibida e, depois, fechada automaticamente. Você não pode clicar em Voltar ou Avançar nesta página.

Concluindo o Assistente para configurar o servidor

Após a reinicialização do servidor, o Assistente para configurar o servidor exibe a página Este servidor agora é um servidor de correio. Para rever todas as alterações feitas no servidor pelo Assistente para configurar o servidor ou certificar-se que uma nova função foi instalada com sucesso, clique em Log de Configuração do servidor. O log Assistente para configurar o servidor localiza-se em systemroot\Debug\Configure Your Server.log. Para fechar o Assistente para configurar o servidor, clique em Concluir.

Neste estágio, você tem um servidor de email perfeitamente funcional, mas ainda deve criar caixas de correio para todos os usuários do domínio que enviarão ou receberão email. Sem as caixas de correio, os usuários não podem enviar nem receber email.

Criando caixas de correio

Para enviar e receber email, cada usuário deve possuir uma caixa de correio exclusiva no domínio de email. Você pode criar caixas de correio com o snap-in MMC do serviço POP3 ou na linha de comandos. Este procedimento utiliza o snap-in MMC do serviço POP3. Para obter mais informações sobre a criação de caixas de correio ou a administração do serviço POP3 na linha de comandos, consulte Winpop. Para obter mais informações sobre como criar caixas de correio, consulte Criar uma caixa de correio

Etapa Comentários
Abra o snap-in MMC do serviço POP3. XOX

Observações

  • XOX
  • XOX
Crie uma ou mais caixas de correio. Na árvore do console, selecione o domínio de email que você especificou no Assistente para configurar o servidor (por exemplo, exemplo.com). Clique com o botão direito no domínio de email, aponte para Nova e clique em Caixa de correio. Forneça as seguintes informações:
  • Nome da caixa de correio — o nome da caixa de correio. Um nome pode conter até 20 caracteres na autenticação de contas locais do Windows e até 64 caracteres na autenticação de arquivo de senha criptografada ou na autenticação integrada do Active Directory. Ele deve conter, no mínimo, 1 caractere.
  • Senha — a senha para acessar a caixa de correio.
  • Confirmar senha — digite novamente a senha especificada na caixa Senha.

Se você estiver usando a autenticação integrada do Active Directory ou a autenticação de contas locais do Windows, marque a caixa Criar usuário associado para esta caixa de correio, a menos que já exista uma conta de usuário com o mesmo nome da caixa de correio que você deseja criar. Se a caixa de seleção já estiver marcada, desmarque-a somente se já existir uma senha com o mesmo nome da caixa de correio que você deseja criar.

Removendo a função do servidor de correio

Se for necessário reconfigurar seu servidor para uma outra função, você poderá remover funções existentes do servidor. Ao remover a função do servidor de email, você desinstala todos os seus componentes, como os serviços POP3 e SMTP. Depois que os componentes do servidor de email forem desinstalados, os usuários não poderão mais enviar ou receber email usando esse servidor. Os emails armazenados no computador não serão afetados pela remoção da função de servidor de email, permanecendo no armazenamento de emails.

Para remover a função do servidor de email, reinicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Servidor de email (POP3, SMTP) e, em seguida, clique em Avançar. Na página Confirmação de remoção de função, reveja os itens listados em Resumo, marque a caixa Remover a função de servidor de email e clique em Avançar. Depois que você clica em Avançar, a página Configurando componentes do Assistente de componentes do Windows é exibida e, depois, fechada automaticamente. Você não pode clicar em Voltar ou Avançar nesta página. Na página Função de servidor de email removida, clique em Concluir.

Próximas etapas: Concluindo tarefas adicionais

Depois que você concluir o Assistente para configurar o servidor e criar caixas de correio, o computador estará pronto para uso como servidor de email. Até este ponto, você concluiu as seguintes tarefas:

  • Instalou os serviços POP3 e SMTP.
  • Configurou o serviço POP3 para usar um método de autenticação.
  • Criou um domínio de email.
  • Criou caixas de correio.

O Assistente para configurar o servidor instalará automaticamente o snap-in MMC do serviço POP3, que você usará para gerenciar o servidor de email. XOX

A tabela a seguir lista tarefas adicionais que você pode executar no servidor de email.

Tarefa | Objetivo da tarefa | Referência
Forneça aos usuários o procedimento para configurar seus clientes de email e usar o servidor de email. | Para se conectar ao servidor de email, o cliente de email do usuário deve ser configurado especificamente para o servidor de email. | Configurar clientes de email
Implemente cotas de disco. | As cotas de disco asseguram que o armazenamento de email não utilizará um espaço excessivo ou imprevisto no disco, o que poderia prejudicar o desempenho do servidor no qual o serviço POP3 está sendo executado. Você deve possuir uma partição NTFS para implementar cotas de disco. As partições NTFS oferecem maior segurança a diretórios e pastas, protegendo melhor os emails armazenados no disco rígido local. | Configurando cotas de disco para o serviço POP3
Configure o servidor de email para exigir a autenticação segura do cliente de email. | O serviço POP3 aceita a autenticação de senha de segurança (SPA) na autenticação integrada do Active Directory e na autenticação de contas locais do Windows. A SPA exige que todos os clientes de email transmitam o nome do usuário e a senha usando autenticação segura. A SPA é mais segura que texto sem formatação e, portanto, seu uso é mais recomendado. A SPA deve ser configurada no servidor no qual estão sendo executados os serviços de email e em cada cliente de email que se conectará ao servidor de email. | Configurar o servidor de email para exigir a autenticação de senha de segurança; Configurar o Outlook Express para a autenticação de senha de segurança


Função do servidor de terminal: Configurando um servidor de terminal

Configure este computador como servidor de terminal instalando o componente Terminal Server, que oferece implantação centralizada de aplicativos.

Utilizando um servidor de terminal, os usuários de locais remotos podem executar programas, salvar arquivos e usar recursos de rede como se estes estivessem instalados em seus próprios computadores. Instalando programas em um servidor de terminal, você pode garantir que todos os usuários utilizem a mesma versão de um programa. Se você planeja usar esse computador para permitir que vários usuários acessem um programa ao mesmo tempo e partindo de um único ponto de instalação, configure o computador como servidor de terminal.

Entretanto, se seu plano é usar o computador para administração remota com sistemas operacionais Windows Server 2003, não é necessário instalar o Terminal Server. Em vez disso, você pode usar a Área de trabalho remota para administração (antes chamada de serviços de terminal no modo Administração remota), que é instalada por padrão em computadores que executam os sistemas operacionais Windows Server 2003. Após a ativação de conexões remotas, a Área de trabalho remota para administração permite que você gerencie remotamente servidores de qualquer cliente em uma conexão LAN, WAN ou dial-up. Até duas sessões remotas, além da sessão do console, podem ser acessadas ao mesmo tempo, sem necessidade de licenciamento do Terminal Server. Para obter mais informações sobre a Área de trabalho remota para administração, consulte Administração remota usando os serviços de terminal.

Este tópico explica como usar o Assistente para configurar o servidor para instalar e configurar um servidor de terminal. Após concluir o Assistente para configurar o servidor, você deve executar o seguinte procedimento adicional para ter um servidor de terminal básico:

  • Confirme a Configuração de segurança aprimorada do Internet Explorer.
  • Configure um servidor de licenças do Terminal Server. Para pequenas implantações, é possível instalar o Terminal Server e seu serviço de licenciamento no mesmo computador físico. Entretanto, para implantações maiores, é recomendável que o licenciamento do Terminal Server seja instalado em um servidor separado.

    • Importante

    • Esse procedimento é obrigatório. Se você não instalar o Licenciamento do Terminal Server, seu servidor de terminal não aceitará mais conexões de clientes não licenciados quando o período de avaliação terminar 120 depois do primeiro logon do cliente.
  • Instale licenças de acesso para clientes (CALs) no servidor de licenças do Terminal Server.
  • Instale programas no servidor de terminal
  • Distribua a última versão da Conexão de área de trabalho remota aos clientes que estejam executando suas versões anteriores para Windows.
  • Especifique os usuários que terão permissão para se conectar ao servidor de terminal.

Após concluir o Assistente para configurar o servidor e essas etapas obrigatórios adicionais, você terá um servidor de terminal básico.

Este tópico aborda o seguinte:

Antes de começar

Configurando o servidor de terminal

Próximas etapas: Concluindo tarefas adicionais

Antes de começar

Antes de configurar o computador como um servidor de terminal, verifique se:

  • O sistema operacional está configurado corretamente. Na família Windows Server 2003, um servidor de terminal depende da configuração adequada do sistema operacional e seus serviços. Se houver uma nova instalação de um sistema operacional Windows Server 2003, você poderá usar as configurações padrão do serviço. Nenhuma outra ação é necessária. Se você fez uma atualização para um sistema operacional Windows Server 2003 ou se deseja confirmar se os serviços estão configurados corretamente para obter melhor desempenho e segurança, verifique as configurações dos serviços usando a tabela em Configurações padrão de serviços.
  • O computador é um servidor em uma rede ou domínio, mas não é um controlador de domínio. A instalação do Terminal Server em um controlador de domínio afeta o desempenho devido à memória adicional, ao tráfego de rede e ao tempo de processador necessários para executar as tarefas de um controlador de domínio em um domínio.
  • O computador satisfaz os requisitos de processador e memória para oferecer suporte a várias sessões simultâneas onde houver muitos usuários conectados. Um servidor de terminal exige, no mínimo, 128 MB de memória RAM, além de memória RAM adicional para cada usuário, a fim de oferecer suporte à execução dos programas de cada usuário no servidor. Recomenda-se acrescentar outros 10 MB de RAM para cada usuário leve - aquele que geralmente executa um programa por vez - e até 21 MB de RAM para cada usuário avançado, que executa normalmente três ou mais programas simultaneamente. Ademais, se você planeja instalar aplicativos de 16 bits no servidor de terminal, lembre-se de que eles consomem outros recursos quando executados em ambientes de 32 bits, como os sistemas operacionais Windows Server 2003.
  • Não há programas instalados no computador. Você deve adicionar a função Terminal Server antes de instalar os programas aos quais deseja conceder acesso para os usuários. Se já houver programas instalados no computador, você deverá reinstalá-los para assegurar que funcionem corretamente no ambiente do Terminal Server.
  • Nenhum usuário pode fazer logon remotamente no computador. Permita que os usuários acessem o servidor de terminal somente depois que você instalar os programas, testar a instalação e executar os ajustes necessários para que eles funcionem em um ambiente com várias sessões. Para obter informações sobre como desativar temporariamente conexões de serviços de terminal, consulte Desativar conexões dos serviços de terminal.
  • Todos os volumes de disco existentes usam o sistema de arquivos NTFS. Os volumes FAT32 não fornecem o nível exigido de segurança para os usuários de um ambiente com várias sessões, nem a capacidade de definir permissões de arquivos.

Configurando o servidor de terminal

Para configurar o servidor de terminal, inicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Terminal Server e, em seguida, clique em Avançar.

Esta seção aborda os seguintes tópicos:

Resumo das seleções

Concluindo o Assistente para configurar o servidor

Confirme a Configuração de segurança aprimorada do Internet Explorer.

Configurando um servidor de licenças do Terminal Server

Instalando licenças de acesso para clientes no servidor de licenças do Terminal Server

Instalando programas no servidor de terminal

Implantando software cliente

Concedendo aos usuários permissão para acessar o servidor de terminal

Removendo a função do servidor de terminal

Resumo das seleções

Na página Resumo das seleções, examine e confirme as opções que você selecionou. Se você selecionou Terminal Server na página Função do servidor, aparecerá o seguinte:

  • Instalar o Terminal Server

Para aplicar as seleções mostradas na página Resumo das seleções, clique em Avançar. A seguinte mensagem será exibida: "Durante este processo, o Assistente para configurar o servidor reinicia o computador. Antes de continuar, feche os programas abertos." Se você precisar fechar programas abertos e quiser cancelar a configuração da função do servidor de terminal nesse momento, clique em Cancelar. Quando você clica em Cancelar, o Assistente para configurar o servidor exibe a página Não é possível concluir a operação. Para fechar o Assistente para configurar o servidor, clique em Concluir. Caso contrário, se você clicar em OK, o Assistente para configurar o servidor iniciará o processo de configuração.

Em seguida, o Assistente para configurar o servidor exibe a mensagem "Instalando o Terminal Server". A página Configurando componentes do Assistente de componentes do Windows é exibida e, depois, fechada automaticamente. Você não pode clicar em Voltar ou Avançar nesta página. Em seguida, o Assistente para configurar o servidor desliga e reinicia o computador para aceitar as alterações de configuração que fazem do computador um servidor de terminal.

Durante o processo de reinicialização, uma caixa de diálogo exibe mensagens de andamento, por exemplo, "O Windows está sendo inicializado" e "Preparando as conexões de rede". Dependendo do tamanho da rede, a preparação das conexões de rede pode levar algum tempo. Quando aparecer a caixa de diálogo Bem-vindo ao Windows, pressione CTRL+ALT+DEL. Na caixa de diálogo Fazer logon no Windows, digite sua senha na caixa Senha. Para concluir o processo, aguarde até que o Assistente para configurar o servidor seja exibido.

Concluindo o Assistente para configurar o servidor

Após a reinicialização do servidor, o Assistente para configurar o servidor exibe a página Este servidor agora é um Terminal Server. Para rever todas as alterações feitas no servidor pelo Assistente para configurar o servidor ou certificar-se que uma nova função foi instalada com sucesso, clique em Log de Configuração do servidor. O log Assistente para configurar o servidor localiza-se em systemroot\Debug\Configure Your Server.log. Para fechar o Assistente para configurar o servidor, clique em Concluir.

Em seguida, você deve executar o procedimento abaixo para que seu servidor esteja pronto para funcionar como um servidor de terminal básico.

  • Confirme a Configuração de segurança aprimorada do Internet Explorer.
  • Configure um servidor de licenças do Terminal Server.
  • Instale licenças de acesso para clientes (CALs) no servidor de licenças do Terminal Server.
  • Instale programas no servidor de terminal.
  • Implante o arquivo .msi da Conexão de área de trabalho remota em clientes que não estão executando os sistemas operacionais XOX ou Windows Server 2003.
  • Conceda aos usuários permissão para acessar o servidor de terminal.

Uma janela separada exibe listas de verificação que fornecem informações sobre esses requisitos adicionais. Essas informações são abordadas neste documento.

Para executar um Terminal Server, é preciso configurar seu licenciamento. Para pequenas implantações, configure o licenciamento do Terminal Server no mesmo computador físico do Terminal Server. Para implantações maiores, instale o licenciamento em um servidor separado. Se já houver um servidor de licenças do Terminal Server instalado, você poderá ignorar as etapas de configuração do servidor de licença e a instalação de CALs e começar Instalando programas no servidor de terminal. Caso contrário, se a página Gerenciar o servidor exibir uma mensagem indicando que não foi encontrado um servidor de licenças do Terminal Server, você deverá configurá-lo antes de usar o servidor de terminal.

Confirme a Configuração de segurança aprimorada do Internet Explorer

Após completar o Assistente para Configurar o Servidor e instalar o Terminal Server, você pode fazer a Configuração de segurança aprimorada do Internet Explorer.

Se você ativar essas configurações, o Internet Explorer aplicará as seguintes definições de segurança a um usuário que efetue logon como administrador:

  • Configurações de segurança altas para as zonas da Internet e da intranet local
  • Configurações de segurança médias para a zona de sites confiáveis

Ao aplicar as configurações de segurança altas para as zonas da Internet e da intranet local, você desabilita scripts, controles Microsoft ActiveX® e a Microsoft Virtual Machine (Microsoft VM) para conteúdo HTML nessas zonas. Você também impede que os usuários façam download de arquivos dessas zonas.

Ao aplicar as configurações de segurança médias para a zona de sites confiáveis, você define a funcionalidade de navegação padrão do navegador. Se você usar sites para tarefas administrativas e aplicativos baseados na Web que um administrador não possa acessar depois que essas configurações forem aplicadas, você poderá incluir os endereços dos sites na lista da zona de sites confiáveis.

Para revisar ou alterar a Configuração de segurança aprimorada do Internet Explorer, em Gerenciar o servidor, clique em Configuração de segurança aprimorada do Internet Explorer.

Na família Windows Server 2003, você pode implementar configurações de segurança aprimoradas do Internet Explorer para todos os usuários e reduzir a exposição de seu servidor a sites que possam apresentar um risco de segurança. Para obter mais informações, consulte Configuração de segurança aprimorada do Internet Explorer.

Configurando um servidor de licenças do Terminal Server

Configure um servidor de licenças do Terminal Server no mesmo computador para o qual acabou de configurar a função de Terminal Server (para pequenas implantações) ou em outro computador (recomendado para implantações maiores). O servidor de licenças do Terminal Server gerencia as licenças de conexões de clientes dos Serviços de terminal. Você será solicitado a ativar um servidor de licenças do Terminal Server apenas uma vez. Depois disso, o servidor de licenças se tornará o repositório das licenças de cliente do Terminal Server. Durante o processo de registro, seu servidor de licenças do Terminal Server pode expedir licenças temporárias para os clientes.

Importante

  • Esse procedimento é obrigatório. Se você não configurar o servidor de licenças do Terminal Server, seu servidor de terminal não aceitará mais conexões de clientes não licenciados quando o período de avaliação terminar (120 dias depois do primeiro logon do cliente).

A forma mais fácil e rápida de ativar um servidor de licenças do Terminal Server é usando o método Automático. Para usar esse método, o computador que executa o serviço de licenciamento de Serviços de Terminal deve estar diretamente conectado à Internet. Para obter informações sobre os métodos de ativação para computadores não conectados à Internet, consulte Ativar um servidor de licenças do Terminal Server usando um navegador da Web e Ativar um servidor de licenças do Terminal Server usando o telefone.

A tabela abaixo mostra o procedimento que você deve seguir para configurar e ativar um servidor de licenças do Terminal Server usando o método Automático.

Tarefa Comentários
Instale o serviço de licenciamento do Terminal Server. Abra Adicionar ou remover programas no Painel de controle e, em seguida, clique em Adicionar ou remover componentes do Windows. No Assistente de componentes do Windows, marque a caixa de seleção Licenciamento do Terminal Server e clique em Avançar. Se sua rede contiver vários domínios, ou se você estiver instalando o serviço de licenciamento do Terminal Server em um servidor membro, selecione Sua empresa inteira. Se quiser manter um servidor de licenças do Terminal Server separado para cada domínio, ou se a rede contiver grupos de trabalho ou domínios do Windows NT 4.0, clique em Seu domínio ou grupo de trabalho. Se você desejar alterar o local do banco de dados do servidor de licenças, especifique o novo local e clique em Avançar. A página Configurando componentes exibe o andamento das alterações da configuração. Na página Concluindo o Assistente de componentes do Windows, clique em Concluir e, em seguida, em Fechar.

Observação

  • XOX
Ative o servidor de licenças do Terminal Server. Abra o Licenciamento do Terminal Server, clique com o botão direito no servidor de licenças do Terminal Server que você deseja ativar e clique em Ativar servidor. O Assistente de ativação do servidor de licenças do Terminal Server é iniciado. Na página Método de conexão, em Método de ativação, clique em Conexão automática e, em seguida, clique em Avançar. Na página Informações sobre a empresa, você deverá fornecer as seguintes informações:
  • Nome
  • Sobrenome
  • Nome da empresa
  • País ou região
Verifique se as informações digitadas estão corretas e, em seguida, clique em Avançar. Na página Informações sobre a empresa, você poderá fornecer as seguintes informações opcionais:
  • Endereço de email
  • Unidade organizacional
  • Endereço da empresa
  • Cidade
  • Estado
  • CEP
Verifique se as informações digitadas estão corretas e, em seguida, clique em Avançar. Na página Concluindo o Assistente de ativação do servidor de licenças do Terminal Server, em Status, aparecerá a seguinte mensagem: "O servidor de licenças foi ativado com êxito."Se desejar instalar licenças de clientes agora, clique em Avançar. Se quiser adiar a instalação de licenças de clientes, desmarque a caixa Iniciar Assistente de licenc. do cliente do Terminal Server e clique em Concluir.

Observação

  • XOX

Instalando licenças de acesso para clientes no servidor de licenças do Terminal Server

Depois da ativação do servidor de licenças do Terminal Server, a próxima etapa é instalar nele as licenças de acesso para clientes (CALs).

Importante

  • Seu servidor de licenças do Terminal Server pode expedir licenças temporárias que permitirão aos clientes usar o servidor de terminal durante o período de avaliação de 120 dias a partir do primeiro logon de cliente. Se você não instalar CALs no servidor de licenças do Terminal Server, os clientes não licenciados não poderão se conectar ao servidor de terminal após o período de avaliação.

As CALs são certificados com assinatura digital que cada cliente armazena localmente. Todas as CALs são instaladas em um servidor de licenças do Terminal Server. Quando um cliente efetua logon em um Terminal Server pela primeira vez, este reconhece que o cliente não recebeu uma CAL e localiza um servidor de licenças para emitir uma nova licença para ele. Para obter mais informações sobre requisitos específicos de licença, consulte o site da Microsoft. (http://www.microsoft.com/).

Antes de instalar as CALs, você deve ter o número do contrato de licença em mãos e saber o método utilizado para adquiri-las.

A forma mais fácil e rápida de instalar CALs em um servidor de licenças do Terminal Server é usando o método Automático. Para usar esse método, o computador que executa o serviço de licenciamento de Serviços de Terminal deve estar diretamente conectado à Internet. Para obter informações sobre como instalar CALs em computadores não conectados à Internet, consulte Instalar pacotes de chaves de licença do cliente usando um navegador da Web e Instalar pacotes de chaves de licença do cliente usando o telefone.

A tabela abaixo mostra o procedimento que você deve seguir para instalar CALs em um servidor de licenças do Terminal Server usando o método Automático.

Tarefa Comentários
Instale CALs no servidor de licenças do Terminal Server. No servidor de licenças do Terminal Server, abra o Licenciamento do Terminal Server. Confirme se o método de instalação do servidor de licenças do Terminal Server foi definido como Automático clicando com o botão direito no servidor de licenças do Terminal Server no qual você deseja instalar as CALs e, em seguida, clicando em Propriedades. Se necessário, na guia Método de instalação, altere o método de instalação para Conexão automática e, em seguida, clique em OK.

Na árvore de console do Licenciamento do Terminal Server, clique com o botão direito no servidor de licenças do Terminal Server no qual você deseja instalar as CALs, clique em Instalar licenças e, em seguida, em Avançar. O Assistente de instalação da licença de acesso para cliente do Terminal Server é iniciado. Na página Programa de licenciamento, selecione o programa para o qual você adquiriu as licenças e clique em Avançar. Na página Código de licença, digite o código de cada licença adquirida e clique em Adicionar após cada entrada. Após digitar todos os códigos de licença, clique em Avançar. A página Concluindo o Assistente para instalação de CAL do Terminal Server exibe uma mensagem informando que as CALs foram instaladas com êxito. Para fechar o assistente, clique em Concluir.

Observação

  • XOX

Instalando programas no servidor de terminal

Até este ponto, você concluiu as seguintes tarefas:

  • Concluiu o Assistente para configurar o servidor e configurou a função do servidor de terminal no seu servidor.
  • Instalou o licenciamento do Terminal Server.
  • Ativou o servidor de licenças do Terminal Server.
  • Instalou CALs no servidor de licenças do Terminal Server.

Agora, você está pronto para instalar programas no servidor de terminal. Recomendamos usar o recurso Adicionar ou remover programas do Painel de controle sempre que possível. Esta seção descreve como usar Adicionar ou remover programas para instalar programas em um servidor de terminal.

Existem outros métodos para instalar programas, como o comando change user, os pacotes do Windows Installer (arquivos .msi) e a instalação de software baseada em diretiva de grupo. Para obter mais informações sobre o comando change user, consulte Instalar um programa usando o comando change user. Para obter mais informações sobre o uso do Windows Installer, consulte Programas atribuídos e publicados. Para obter mais informações sobre a diretiva de grupo, consulte Diretiva de grupo.

Para melhorar o desempenho e reduzir o tráfego na rede, instale os programas na unidade local do servidor de terminal, e não em um servidor de arquivos. Certifique-se de possuir espaço suficiente para instalar os programas nas unidades do sistema de arquivos NTFS. Não use unidades FAT32. As unidades NTFS permitem que você defina permissões de arquivos, o que não é possível em unidades FAT32.

Se você pretende instalar programas publicados, deve usar outro método de instalação, como a instalação de software baseada em diretiva de grupo.

Por motivos de desempenho e segurança, use programas de 32 bits sempre que possível. A maioria dos programas de 32 bits usa o Registro para ler e gravar configurações do programa e precisa gravar apenas em valores específicos do Registro. A execução de programas de 16 bits pode reduzir em 40% o número de usuários aceitos pelo processador e aumentar em 50% a memória exigida para cada usuário. Além disso, alguns programas de 16 bits devem ser capazes de gravar no diretório onde está armazenado o arquivo de programa .ini.

Os requisitos de RAM e de CPU aumentam quase que linearmente conforme o número de sessões executadas. Para reduzir os requisitos de RAM e de CPU, considere restringir o acesso de usuários ou grupos a certos tipos de programas, desativar recursos desnecessários ou instalar programas em servidores de terminal separados.

Alguns programas possuem problemas de instalação conhecidos em ambientes com várias sessões. Para obter informações sobre os programas que requerem scripts de instalação para funcionar corretamente em um ambiente com várias sessões, consulte Optimizing Applications for Windows 2000 Terminal Services e and Windows NT Server 4.0, Terminal Server Edition no site da Microsoft. (http://www.microsoft.com/).

Considerações sobre a compatibilidade de aplicativos

Você deve instalar os programas usando a sessão de console do servidor de terminal. Você pode instalar programas de uma sessão de console remota, mas esse método não é o ideal.

Alguns programas exigem a execução de um script de compatibilidade de aplicativo após sua instalação. Os scripts são armazenados no diretório systemroot\Application Compatibility Scripts\Install do servidor de terminal.

Leve em consideração as implicações do modo de segurança no qual o servidor de terminal opera. Há dois modos de segurança:

  • Segurança máxima fornece um ambiente mais seguro aos usuários conectados a um servidor de terminal. Para operar nesse modo, os aplicativos devem ter sido criados para serem executados no contexto de segurança de um usuário comum. Nos sistemas operacionais Windows Server 2003 e no Windows 2000, o padrão é segurança máxima.
  • Segurança reduzida permite que você execute programas que talvez não funcionassem no rigoroso modo de segurança máxima. Entretanto, no modo de Segurança reduzida (também conhecido como modo de compatibilidade de permissões Windows NT 4.0/Terminal Server Edition), qualquer usuário do sistema pode alterar as configurações dos arquivos e do Registro em vários locais do sistema, embora talvez não seja possível ver os arquivos de dados de outros usuários. Um usuário mal-intencionado pode aproveitar-se dessa situação substituindo um programa conhecido e confiável por outro com o mesmo nome, mas com finalidades nefastas. Se o sistema operacional do seu servidor de terminal foi instalado com o método Atualizar, o modo de segurança talvez tenha sido ajustado com Segurança reduzida. Em caso de dúvida, escolha Segurança máxima, teste os aplicativos nesse modo e somente altere o modo de segurança se os resultados do teste indicarem essa necessidade.

A tabela abaixo mostra o procedimento que você deve seguir para instalar programas no servidor de terminal usando Adicionar ou remover programas.

Tarefa | Comentários
Certifique-se de não haver usuários conectados ao servidor de terminal. | Envie uma mensagem a todos os usuários conectados ao servidor de terminal. A instalação de programas geralmente exige a reinicialização do computador, e as sessões serão desconectadas. Não permita que os usuários acessem o servidor de terminal antes que os programas sejam instalados e testados.
Desative temporariamente as conexões dos Serviços de terminal. | Clique com o botão direito em Meu computador, clique em Propriedades, clique na guia Remoto e desmarque a caixa Permitir que usuários se conectem remotamente a este computador.
Especifique Segurança máxima como o modo de segurança. Abra Configuração dos Serviços de terminal. Na árvore do console, clique em Configurações do servidor, clique com o botão direito em Compatibilidade de permissão e clique em Propriedades. Na caixa de diálogo Compatibilidade da permissão, clique em Segurança máxima e, em seguida, clique em OK.

Observação

  • XOX
Instale os programas usando o CD ou o disquete. Certifique-se de ter feito logon no servidor de terminal como membro do grupo Administradores. Abra Adicionar ou remover programas no Painel de controle e clique em Adicionar novos programas. Clique em CD ou disquete. Insira o CD ou o disquete na unidade adequada e clique em Avançar. Verifique se o arquivo de instalação está corretamente especificado na caixa Abrir da página Executar programa de instalação e clique em Concluir. Siga as instruções do assistente de instalação do programa. Depois de instalado o programa, edite e execute os scripts aplicáveis a fim de ajustá-lo para um ambiente com várias sessões.

Observação

  • XOX
Teste a instalação.

Certifique-se de que o log de eventos está ativado abrindo Serviços em Ferramentas administrativas. Crie uma conta de usuário temporária imitando as configurações dos usuários que acessarão o programa e utilize a conta para fazer logon no servidor de terminal. Inicie o programa e execute algumas tarefas básicas. Use Visualizar eventos para determinar os arquivos ou diretórios que precisam de acesso de gravação e as chaves do Registro que requerem acesso de leitura para o usuário a fim de funcionarem corretamente. Note que esse processo talvez não localize, em todos os cenários de usuários, todos os arquivos, pastas e chaves do Registro para os quais o aplicativo requer acesso. A única maneira de assegurar que você considerou todos os requisitos de acesso é executando as tarefas manualmente.

Alguns programas permitem que os usuários iniciem outros programas. Por exemplo, o Microsoft Access possui uma barra de ferramentas que pode ser usada para iniciar outros programas do Microsoft Office. Se você quiser que os usuários tenham acesso a apenas alguns programas específicos quando fizerem logon no servidor de terminal, desative o acesso à barra de ferramentas nos programas que você instalar no servidor de terminal.

Observação

  • XOX
Ajuste os programas para uso em várias sessões. | Use um editor de texto como o Bloco de notas para modificar scripts e execute-os para ajustar os programas que exigem ajuste. Para obter os scripts, consulte Optimizing Applications for Windows 2000 Terminal Services and Windows NT Server 4.0, Terminal Server Edition no site da Microsoft. (http://www.microsoft.com/).
Execute os scripts de compatibilidade de aplicativos. | Navegue para a pasta systemroot\Application Compatibility Scripts\Install no servidor de terminal e execute os scripts dos programas que os exigem.
Ative as conexões remotas no servidor de terminal. Clique com o botão direito em Meu computador, clique em Propriedades, selecione a guia Remoto e desmarque a caixa Permitir que usuários se conectem remotamente ao seu computador.

Observação

  • Dependendo das configurações de sua área de trabalho, Meu computador talvez não seja exibido. XOX

Implantando software cliente

A Conexão de área de trabalho remota, conhecida anteriormente como Cliente de serviços de terminal, é automaticamente instalada em computadores que executam sistemas operacionais XOX e Windows Server 2003. Por motivos de desempenho e segurança, os computadores que executam versões anteriores do Microsoft Windows, inclusive Windows 2000 Server, Windows 2000 Professional, Windows NT 4.0, Windows 98 e Windows 95, devem ter instalada a última versão da Conexão da área de trabalho remota.

Há várias formas de implantar o software cliente:

  • Compartilhe o arquivo Msrdpcli.msi e use o Microsoft IntelliMirror para distribuí-lo às estações de trabalho que executam Windows 2000.
  • Faça o download da Conexão de área de trabalho remota diretamente do site da Microsoft. (http://www.microsoft.com/downloads)
  • Coloque o arquivo .msi em uma pasta compartilhada de um servidor em rede.

Este tópico descreve como instalar o software cliente de uma pasta compartilhada residente em um servidor em rede.

Antes de implantar o software cliente, decida se ele será instalado para utilização por um único usuário ou por qualquer pessoa que usar o computador cliente. Você fará essa escolha durante o processo de implantação.

A tabela abaixo mostra o procedimento que você deve seguir para implantar a versão mais recente da Conexão de área de trabalho remota em clientes que executam versões anteriores dessa conexão ou do Windows.

Tarefa | Comentários
Compartilhe a pasta de configuração do cliente. Abra o Windows Explorer no computador que está executando o sistema operacional Windows Server 2003. Navegue para a pasta systemroot\System32\Clients\Tsclient\win32, clique com o botão direito na pasta win32 e clique em Compartilhamento e segurança. Na guia Compartilhamento, clique em Compartilhar esta pasta e, em seguida, clique em OK.

Observação

  • XOX
Instale a Conexão de área de trabalho remota. | No computador cliente, clique em Iniciar, Executar e, em seguida, clique em Abrir, digite \\NomeDoServidor\win32, onde NomeDoServidor é o nome do computador onde a pasta compartilhada se localiza. Clique duas vezes no arquivo msrdpcli.msi para iniciar o Assistente do InstallShield para a Conexão de área de trabalho remota e clique em Avançar. Leia o Contrato de Licença, clique em Aceito os termos do Contrato de Licença e, em seguida, clique em Avançar. Digite seu nome e o de sua organização na página Informações sobre o cliente, clique em Qualquer pessoa que usa este computador (todos os usuários) e clique em Avançar. Na página Pronto para instalar o programa, clique em Voltar para rever ou alterar as configurações da instalação ou em Instalar para iniciar a instalação. Para concluir a instalação, clique em Concluir.

Concedendo aos usuários permissão para acessar o servidor de terminal

Por padrão, nos sistemas operacionais Windows Server 2003, os membros dos grupos Administradores e Usuários da área de trabalho remota podem usar as conexões dos Serviços de terminal para se conectar a um computador remoto. O grupo Usuários da área de trabalho remota não é preenchido por padrão. Portanto, você deve decidir quais usuários e grupos devem ter permissão para fazer logon remotamente e adicioná-los manualmente ao grupo.

Importante

  • Use o grupo Usuários da área de trabalho remota para conceder aos usuários e aos grupos a permissão necessária para estabelecer conexões dos Serviços de terminal com computadores remotos.
  • A associação ao grupo Usuários da área de trabalho remota não coloca o usuário no grupo Usuários local. Dependendo do conteúdo do grupo Usuários local, você precisará adicionar o usuário a esse grupo também.

Antes de conceder aos usuários permissão para acessar o servidor de terminal, faça o seguinte:

  • Verifique os membros do grupo Administradores para saber quem tem acesso ao servidor de terminal.
  • Decida quais usuários terão permissão para acessar o servidor de terminal.
  • Determine quais usuários também deverão ser adicionados ao grupo Usuários local.

A tabela abaixo mostra o procedimento que você deve seguir para conceder aos usuários permissão para acessar o servidor de terminal.

Tarefa Comentários
Adicione usuários ao grupo Usuários da área de trabalho remota. Abra o Gerenciamento do computador (local) e, na árvore de console, clique em Usuários e grupos locais. No painel de detalhes, clique duas vezes em Grupos, clique duas vezes em Usuários da área de trabalho remota e, em seguida, clique em Adicionar. Na caixa de diálogo Selecionar usuários, clique em Locais para especificar o local da pesquisa. Clique em Tipos de objeto para especificar os tipos de objeto pelos quais deseja procurar. Nesse caso, você deseja procurar por Usuários ou Grupos. Digite o nome que você deseja adicionar na caixa Digite os nomes de objeto a serem selecionados (exemplos) e clique em Verificar nomes. Quando o nome for localizado, clique em OK.

Observação

  • XOX
Adicione os usuários ao grupo Usuários local, se já não forem membros. Abra o Gerenciamento do computador (local) e, na árvore de console, clique em Usuários e grupos locais. No painel de detalhes, clique duas vezes em Grupos, clique duas vezes em Usuários e, em seguida, clique em Adicionar. Na caixa de diálogo Selecionar usuários, clique em Locais para especificar o local da pesquisa. Clique em Tipos de objeto para especificar os tipos de objeto pelos quais deseja procurar. Nesse caso, você deseja procurar por Usuários ou Grupos. Digite o nome que você deseja adicionar na caixa Digite os nomes de objeto a serem selecionados (exemplos) e clique em Verificar nomes. Quando o nome for localizado, clique em OK.

Observação

  • XOX

Removendo a função do servidor de terminal

Se for necessário reconfigurar seu servidor para uma outra função, você poderá remover funções existentes do servidor. Se você remover a função de servidor de terminal, precisará reinstalar todo o software, rever e atualizar as permissões de arquivos ou do Registro cujos valores padrão você alterou e rever e atualizar as diretivas de restrição do software que foram usadas para controlar os programas executados no servidor de terminal.

Para remover o servidor de terminal, reinicie o Assistente para configurar o servidor, siga um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Terminal Server e clique em Avançar. Na página Confirmação de remoção de função, reveja os itens listados em Resumo, marque a caixa Remover a função de servidor de terminal e clique em Avançar. A seguinte mensagem será exibida: "Durante este processo, o Assistente para configurar o servidor reinicia o computador. Antes de continuar, feche os programas que estiverem abertos." Se você precisar fechar programas abertos e quiser cancelar a remoção da função do Terminal Server nesse momento, clique em Cancelar. Quando você clica em Cancelar, o Assistente para configurar o servidor exibe a página Não é possível concluir a operação. Para fechar o Assistente para configurar o servidor, clique em Concluir. Caso contrário, se você clicar em OK, o Assistente para configurar o servidor iniciará o processo de remoção.

Em seguida, o Assistente para configurar o servidor exibe a mensagem "Removendo Terminal Server". Aparece a página Configurando componentes do Assistente de componentes do Windows exibindo mensagens sobre as alterações feitas nas configurações do computador. A página é fechada em seguida. O Assistente para configurar o servidor desliga e reinicia o computador para aceitar as alterações de configuração que removem a função.

Durante o processo de reinicialização, uma caixa de diálogo exibe mensagens de andamento, por exemplo, "O Windows está sendo inicializado" e "Preparando as conexões de rede". Dependendo do tamanho da rede, a preparação das conexões de rede pode levar algum tempo. Quando aparecer a caixa de diálogo Bem-vindo ao Windows, pressione CTRL+ALT+DEL. Na caixa de diálogo Fazer logon no Windows, digite sua senha na caixa Senha. Para concluir o processo, aguarde até que o Assistente para configurar o servidor seja exibido. Na página Função de Terminal Server removida, clique em Log de Configuração do servidor para ver um registro de suas alterações e, em seguida, clique em Concluir.

Depois de remover a função de servidor de terminal, faça o seguinte:

  • Reinstale todos os programas.
  • Reveja as permissões de arquivo ou do Registro cujos valores padrão você alterou e, se necessário, modifique-as.
  • Reveja as diretivas de restrição de software usadas para controlar programas executados no servidor de terminal e, se necessário, modifique-as.

Próximas etapas: Concluindo tarefas adicionais

Depois que você concluir o Assistente para configurar o servidor e suas tarefas associadas, o computador estará pronto para ser usado como um servidor de terminal básico que pode aceitar várias conexões de clientes remotos. Até este ponto, você concluiu as seguintes tarefas:

  • Executou o Assistente para configurar o servidor.
  • Ativou um servidor de licenças do Terminal Server.
  • Instalou CALs no servidor de licenças do Terminal Server.
  • Instalou aplicativos no servidor de terminal.
  • Implantou o arquivo .msi da Conexão de área de trabalho remota em clientes que não estão executando os sistemas operacionais XOX ou Windows Server 2003.
  • Configurou permissões para acesso dos usuários ao servidor de terminal.

A tabela a seguir lista algumas tarefas adicionais que você pode executar no servidor de terminal.

Tarefa | Objetivo da tarefa | Referência
Gerenciar conexões de Serviços de terminal. | Ativar, desativar, renomear ou excluir uma conexão. | Gerenciar conexões dos Serviços de terminal
Especificar permissões de conexão. | Conceder somente a usuários e grupos selecionados o acesso ao servidor de terminal. Identificar os usuários e grupos que podem executar uma ou mais tarefas específicas no servidor de terminal. | Gerenciando usuários dos Serviços de terminal; Gerenciando permissões de conexões
Definir as configurações do servidor de terminal usando a Configuração de Diretiva de grupo ou de Serviços de terminal. | Definir configurações como Active Desktop, pastas temporárias e limites de sessão para usuários individuais. | Definir configurações do servidor
Implantar a Conexão da Web da área de trabalho remota. | Permitir que os usuários criem uma conexão Área de trabalho remota no Internet Explorer, ainda que seus computadores não possuam o cliente Conexão de área de trabalho instalado. | Sobre o componente Conexão da Web da área de trabalho remota
Controlar programas executados em uma sessão do servidor de terminal. | Proteger servidores de terminal e usuários contra programas desconhecidos ou possivelmente perniciosos. | Using Software Restriction Policies in XOX and the Windows Server 2003 family to Protect Against Unauthorized Software no site da Microsoft. (http://www.microsoft.com/).
Definir configurações do Diretório de sessão. | Assegurar que os usuários sejam transparentemente reconectados ao servidor original que hospeda suas sessões desconectadas do Terminal Server. Essa tarefa se aplica aos servidores de terminal que fazem parte de um cluster de servidores de terminal e requer que o servidor que está executando XOX ou um XOX seja visível na rede e possua o serviço Diretório de sessão ativado. Esse servidor de diretório de sessão deve ser diferente daquele no qual a função Terminal Server é configurada. | Equilíbrio de carga e servidores de terminal


Função de servidor de acesso remoto/VPN: Configurando um servidor de acesso remoto/VPN

Você pode configurar um servidor que permita aos usuários remotos acessar recursos de sua rede privada através de conexões dial-up ou de redes virtuais privadas (VPN). Esse tipo de servidor é chamado de servidor de acesso remoto/VPN. Os servidores de acesso remoto/VPN também pode oferecer a conversão de endereços de rede (NAT). Com a NAT, os computadores da rede privada podem compartilhar uma única conexão com a Internet. Com a VPN e a NAT, seus clientes VPN podem determinar os endereços IP dos computadores de sua rede privada, o que não é possível para outros computadores da Internet.

Este tópico explica o procedimento básico de configuração de um servidor de acesso remoto/VPN usando Gerenciar o servidor, o Assistente para configurar o servidor e o Assistente para configuração do servidor de roteamento e acesso remoto. Depois de configurar um servidor de acesso remoto/VPN básico, você pode executar outras tarefas de configuração, dependendo de como você deseja usar esse servidor.

Este tópico aborda o seguinte:

Antes de começar

Configurando o servidor de acesso remoto/VPN

Próximas etapas: Concluindo tarefas adicionais

Antes de começar

Antes de configurar o servidor como um servidor de acesso remoto/VPN, verifique se:

  • O sistema operacional está configurado corretamente. Na família Windows Server 2003, o acesso remoto/VPN depende da configuração adequada do sistema operacional e seus serviços. Se houver uma nova instalação de um produto da família Windows Server 2003,você pode usar as configurações de serviço padrão. Nenhuma outra ação é necessária. Se você fez a atualização para um produto da família Windows Server 2003 ou se deseja confirmar se os serviços estão configurados corretamente para obter melhor desempenho e segurança, verifique as configurações dos serviços comparando-os à tabela em Configurações padrão de serviços.
  • O servidor está corretamente configurado para fornecer segurança às necessidades de sua rede. Como o servidor de acesso remoto/VPN será conectado à rede privada, à Internet e aos clientes remotos, certifique-se de ele seja seguro. A segurança da rede privada depende da segurança do servidor de acesso remoto/VPN. Para obter mais informações, consulte Informações sobre segurança para acesso remoto.
  • Este computador possui duas interfaces de rede: uma conectada à Internet e outra conectada à rede privada. A primeira deve ser uma conexão dedicada, com largura de banda suficiente que permita aos usuários VPN se conectar à rede privada e aos usuários desta se conectar à Internet. A conexão com os computadores da rede privada deve ser feita por meio de um dispositivo de hardware, como o adaptador de rede.
  • Todos os protocolos de rede necessários às interfaces de rede foram instalados. Para obter mais informações, consulte Interfaces de rede.

A tabela a seguir lista as informações que você precisa saber antes de configurar um servidor de acesso remoto/VPN.

Antes de adicionar uma função de servidor de acesso remoto/VPN | Comentários
Determine qual interface de rede se conecta à Internet e qual delas se conecta à rede privada. | Durante a configuração, você deverá escolher a interface de rede que se conectará à Internet. Se você especificar a interface errada, o servidor de acesso remoto/VPN não funcionará corretamente.
Determine se os clientes remotos receberão endereços IP de um servidor de DHCP (protocolo de configuração dinâmica de hosts) na rede privada ou do servidor de acesso remoto/VPN que você está configurando. | Se você possui um servidor DHCP na rede privada, o servidor de acesso remoto/VPN pode fornecer 10 endereços do servidor DHCP por vez e atribuí-los a clientes remotos. Se não há um servidor DHCP na rede privada, o servidor de acesso remoto/VPN pode gerar e atribuir automaticamente endereços IP aos clientes remotos. Se você quiser que o servidor de acesso remoto/VPN atribua endereços IP em uma faixa que você especificar, determine essa faixa.
Determine se as solicitações de conexão de clientes VPN deverão ser autenticadas por um servidor Remote Authentication Dial-In User Service (RADIUS) ou pelo servidor de acesso remoto/VPN que você está configurando. | É útil adicionar um servidor RADIUS se você planeja instalar vários servidores de acesso remoto/VPN, pontos de acesso sem fio ou outros clientes RADIUS à rede privada. Para obter mais informações, consulte Serviço de autenticação da Internet.
Determine se os clientes VPN poderão enviar mensagens DHCP ao servidor DHCP na rede privada. | Se houver um servidor DHCP na mesma sub-rede do servidor de acesso remoto/VPN, as mensagens DHCP de clientes VPN poderão alcançar o servidor DHCP após o estabelecimento da conexão VPN. Se o servidor DHCP e o servidor de acesso remoto/VPN estiverem em sub-redes diferentes, certifique-se de que o roteador entre as sub-redes consegue retransmitir mensagens DHCP entre os clientes e o servidor. Se o roteador estiver executando um sistema operacional Microsoft® Windows® Server 2003, você pode configurar o serviço Agente de retransmissão DHCP no roteador para encaminhar mensagens DHCP entre as sub-redes.
Verifique se todos os usuários possuem contas configuradas para acesso dial-up. | Para se conectar à rede, os usuários devem possuir contas no servidor de acesso remoto/VPN ou no Active Directory. Cada conta de usuário no servidor independente ou no controlador de domínio contém propriedades que determinam se o usuário pode estabelecer a conexão. Em um servidor independente, você pode definir essas propriedades clicando com o botão direito na conta do usuário em Usuários e grupos locais e selecionando Propriedades. No controlador de domínio, você pode definir as propriedades clicando com o botão direito na conta do usuário no console Usuários e computadores do Active Directory e selecionando Propriedades. Para obter mais informações, consulte Propriedades de discagem de uma conta de usuário e Usuários e computadores do Active Directory.

Configurando o servidor de acesso remoto/VPN

Para configurar o servidor de acesso remoto/VPN, inicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon.
  • XOX

Na página Opções de configuração, clique em Configuração personalizada e, em seguida, clique em Avançar. Na página Função do servidor, clique em Servidor de acesso remoto/VPN e, em seguida, clique em Avançar.

Esta seção descreve o procedimento do Assistente para configuração do servidor de roteamento e acesso remoto para configurar um servidor de acesso remoto/VPN que não faz parte de um domínio do Active Directory ou de uma rede com servidores DNS ou DHCP. Se você seguir este procedimento, configurará um servidor de acesso remoto/VPN que oferece acesso dial-up e VPN aos clientes de acesso remoto, fornece NAT aos computadores da rede privada, gera e atribui endereços IP aos clientes de acesso remoto e autentica localmente as solicitações de conexão.

Esta seção aborda os seguintes tópicos:

Resumo das seleções

Usando o Assistente para configuração do servidor de roteamento e acesso remoto

Concluindo o Assistente para configurar o servidor

Concluindo a configuração no roteamento e no acesso remoto

Removendo a função de servidor de acesso remoto/VPN

Resumo das seleções

Na página Resumo das seleções, você pode examinar e confirmar as opções que selecionou. Se você clicou em Servidor de acesso remoto/VPN na página Função de servidor, a seguinte linha aparecerá:

  • Execute o 'Assistente para configuração do servidor de roteamento e acesso remoto' para configurar o roteamento e VPN

Para aplicar as seleções mostradas na página Resumo das seleções, clique em Avançar. O Assistente para configurar o servidor inicia o Assistente para configuração do servidor de roteamento e acesso remoto. Se você cancelar o Assistente para configuração do servidor de roteamento e acesso remoto, o servidor de acesso remoto/VPN não poderá ser configurado, o serviço de Roteamento e acesso remoto não será iniciado e o Assistente para configurar o servidor exibirá a página Não é possível concluir a operação.

Quando você concluir o Assistente para configuração do servidor de roteamento e acesso remoto e o Assistente para configurar o servidor, o serviço de roteamento e acesso remoto será automaticamente iniciado.

Usando o Assistente para configuração do servidor de roteamento e acesso remoto

Depois que você escolhe a função de acesso remoto/VPN e confirma o Resumo das seleções clicando em Avançar no Assistente para configurar o servidor, o Assistente para configuração do servidor de roteamento e acesso remoto é iniciado.

Esta seção descreve as seguintes etapas do Assistente para configuração do servidor de roteamento e acesso remoto:

Configuração

Conexões VPN

Atribuição de endereço IP

Serviços de conversão de nomes e endereços

Intervalo de atribuição de endereços

Gerenciando vários servidores de acesso remoto

Concluindo o Assistente para configuração do servidor de roteamento e acesso remoto

Configuração

Na página Configuração, clique em Acesso a rede virtual privada (VPN) e NAT e, em seguida, em Avançar.

Importante

  • Este documento descreve somente a configuração Acesso a rede virtual privada (VPN) e NAT. Se você escolher uma configuração diferente, releia a documentação sobre Roteamento e acesso remoto antes de concluir o Assistente para configuração do servidor de roteamento e acesso remoto. Este documento não ajudará na conclusão de qualquer outra função que não Acesso a rede virtual privada (VPN) e NAT. Para obter mais informações sobre outras configurações, consulte Configurações comuns de servidores de acesso remoto.

Conexão VPN

Na página Conexão VPN, clique na interface de rede que conecta o computador à Internet. A interface de rede que você escolher será configurada para receber conexões de clientes VPN. As interfaces que você não escolher serão configuradas como conexões com a rede privada.

Em Interfaces de rede, a caixa de seleção Ativar a segurança na interface selecionada configurando um firewall básico já estará marcada. Não a desmarque. Esta opção configura o Firewall básico, um serviço de filtragem de pacotes dinâmicos que ajuda a proteger a rede privada contra tráfego inoportuno.

Quando terminar, clique em Avançar.

Atribuição de endereço IP

Na página Atribuição de endereço IP, a opção Automaticamente é automaticamente selecionada. Não altere a seleção. Esta seleção configura o servidor para gerar e atribuir endereços IP a clientes remotos.

Quando terminar, clique em Avançar.

Serviços de conversão de nomes e endereços

Na página Serviços de conversão de nome e endereço, a opção Ativar serviços básicos de nome e endereço é automaticamente selecionada. Não altere a seleção. Esta seleção configura o servidor a atribuir automaticamente endereços IP a qualquer computador da rede privada que os solicitar. A seleção também configura o servidor para encaminhar solicitações de resolução de nomes a um servidor DNS da Internet.

Quando terminar, clique em Avançar.

Intervalo de atribuição de endereços

A página Intervalo de atribuição de endereços exibe o intervalo de endereços definido para ser atribuído a qualquer computador da rede que o solicitar. Esse intervalo é gerado com base no endereço IP do adaptador de rede que você escolheu na página Conexão VPN. Reveja as informações apresentadas.

Quando terminar, clique em Avançar.

Gerenciando vários servidores de acesso remoto

Na página Gerenciando múltiplos servidores de acesso remoto, a opção Não, usar o 'Roteamento e acesso remoto' para autenticar pedidos de conexão é automaticamente selecionada. Não altere a seleção. Essa seleção configura o servidor para autenticar localmente solicitações de conexão usando a autenticação do Windows, as estatísticas do Windows e diretivas de acesso remoto armazenadas localmente.

Quando terminar, clique em Avançar.

Concluindo o Assistente para configuração do servidor de roteamento e acesso remoto

Na página Concluindo o 'Assistente para configuração do servidor de roteamento e acesso remoto', releia as informações resumidas. Verifique se:

  • A interface de rede correta está configurada para fornecer acesso VPN.
  • Os clientes dial-up e VPN são atribuídos à rede privada para endereçamento.
  • As conexões de clientes são aceitas e autenticadas com base nas diretivas de acesso remoto para este servidor de acesso remoto/VPN.
  • A NAT está configurada para a interface de rede correta.
  • Os clientes receberão endereços IP do intervalo correto.

Se alguma das informações resumidas estiver incorreta, clique em Voltar e altere-a.

Se você clicar em Concluir, não poderá abrir novamente o Assistente para configuração do servidor de roteamento e acesso remoto, a menos que retire a função de servidor de acesso remoto/VPN do Assistente para configurar o servidor ou desative o Roteamento e acesso remoto do snap-in de mesmo nome.

Depois de certificar-se de que as informações resumidas estão corretas, clique em Concluir. Aparecerá uma mensagem informando que, para que seja aceita a retransmissão de mensagens DHCP de clientes de acesso remoto para um servidor DHCP, você deve abrir Roteamento e acesso remoto no servidor de acesso remoto/VPN e configurar o Agente de retransmissão DHCP com o endereço IP de um servidor DHCP. Clique em OK. O serviço Roteamento e acesso remoto será automaticamente iniciado, e o Assistente para configurar o servidor reaparecerá.

Concluindo o Assistente para configurar o servidor

Depois que você concluir o Assistente para configuração do servidor de roteamento e acesso remoto, o Assistente para configurar o servidor exibirá a página Este servidor agora é um servidor de acesso remoto/VPN. Para rever todas as alterações feitas no servidor pelo Assistente para configurar o servidor ou certificar-se que uma nova função foi instalada com sucesso, clique em Log de Configuração do servidor. O log Assistente para configurar o servidor localiza-se em systemroot\Debug\Configure Your Server.log. Para fechar o Assistente para configurar o servidor, clique em Concluir.

Agora, você está pronto para concluir a configuração do servidor de acesso remoto/VPN no serviço Roteamento e acesso remoto.

Concluindo a configuração no roteamento e no acesso remoto

Para abrir o Roteamento e acesso remoto, clique em Gerenciar este servidor de acesso remoto/VPN em Gerenciar o servidor. Você também pode abrir Roteamento e acesso remoto nas Ferramentas administrativas. XOX

Em Roteamento e acesso remoto, clique duas vezes no servidor que você acabou de configurar e clique em Diretivas de acesso remoto. A diretiva de acesso remoto padrão é definida para negar o acesso a todas as pessoas. Os usuários não poderão se conectar ao servidor de acesso remoto/VPN até que você edite a diretiva padrão para permitir o acesso ou substitua essa diretiva por outras que você mesmo criar. Reveja a diretiva padrão clicando duas vezes nela. Em seguida, edite-a para especificar o acesso que você deseja permitir aos usuários.

Se este servidor tiver sido anteriormente configurado como servidor de acesso remoto/VPN ou se IAS tiver sido configurado neste servidor, a diretiva ou as diretivas de acesso remoto que aparecerem em Roteamento e acesso remoto poderão estar configuradas de forma diferente da diretiva de acesso remoto padrão. Reveja cuidadosamente todas as diretivas de acesso remoto para certificar-se de ter permitido e negado o acesso remoto conforme as necessidades da rede. Certifique-se de não ter permitido ou negado acidentalmente mais acesso remoto à rede do que pretendia.

Para obter mais informações, consulte Adicionar uma diretiva de acesso remoto, Introdução às diretivas de acesso remoto e Recriar a diretiva de acesso remoto padrão.

Depois de configurar as diretivas de acesso remoto, você terá concluído todas a configuração necessária para um servidor de acesso remoto/VPN em uma rede sem servidor DHCP. Se a rede utiliza um servidor DHCP, você deverá também configurar o Agente de retransmissão DHCP antes de concluir a configuração. Em Roteamento e acesso remoto, clique duas vezes em Roteamento IP, clique com o botão direito em Agente de retransmissão DHCP e clique em Propriedades. Digite o endereço IP do servidor DHCP da rede em Endereço do servidor, clique em Adicionar e, em seguida, em OK.

Removendo a função de servidor de acesso remoto/VPN

Se for necessário reconfigurar seu servidor para uma outra função, você poderá remover funções existentes do servidor. Quando você remove a função de servidor de acesso remoto/VPN, o servidor pára de fornecer acesso dial-up ou VPN aos clientes de acesso remoto. Além disso, o servidor não fornecerá mais a NAT aos computadores da rede privada. Os usuários remotos não poderão se conectar à rede privada, e os computadores da rede privada não poderão se conectar à Internet. A Firewall básica não protegerá mais os computadores da rede privada. Depois de remover a função de servidor de acesso remoto/VPN, considere adicionar outra firewall para proteger os computadores da rede privada, se ela já não possuir proteção. Teste a rede privada para certificar-se que seus computadores possuam o nível de acesso à Internet exigido pelas suas necessidades de negócios. Reconfigure as diretivas de acesso remoto no IAS para negar todas as tentativas de acesso remoto.

Para remover a função de servidor de acesso remoto/VPN, reinicie o Assistente para configurar o servidor, siga um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Servidor de acesso remoto/VPN e, em seguida, clique em Avançar. Na página Confirmação de remoção de função, reveja os itens listados em Resumo, marque a caixa Remover a função de servidor de acesso remoto/VPN e clique em Avançar. Na caixa de diálogo que pedir a você para confirmar se deseja desativar o roteador e remover a configuração de acesso remoto, clique em Sim. Na página Função de servidor de acesso remoto/VPN removida, clique em Concluir.

Próximas etapas: Concluindo tarefas adicionais

Depois que você concluir o Assistente para configurar o servidor e a configuração de Roteamento e acesso remoto, o servidor estará pronto para uso como servidor de acesso remoto/VPN que fornece acesso VPN e NAT. Até este ponto, você executou o seguinte:

  • Iniciou o serviço Roteamento e acesso remoto.
  • Configurou o servidor para aceitar conexões VPN e dial-up.
  • Configurou o servidor para fornecer NAT à rede privada.
  • Configurou as diretivas de acesso remoto para permitir que os usuários se conectem ao servidor executando Roteamento e acesso remoto.
  • Se a rede usa o servidor DHCP, configurou o Agente de retransmissão DHCP para encaminhar mensagens DHCP de clientes de acesso remoto ao servidor DHCP.

Se você concluiu todas essas tarefas, criou um servidor de acesso remoto/VPN básico que permitirá que os computadores remotos se conectem ao servidor com uma conexão dial-up ou VPN e forneçam conversão de endereços de rede (NAT) à rede privada.

A tabela a seguir lista algumas tarefas adicionais que você pode executar no servidor de acesso remoto/VPN.

Tarefa | Objetivo da tarefa | Referência
Configure os filtros de pacote estáticos. | Adicionar filtros de pacotes estáticos para proteger mais a rede. | Adicionar filtros de host local
Configure serviços e portas. | Escolher os serviços da rede privada que você deseja disponibilizar aos usuários de acesso remoto. | Configurar serviços e portas
Ajuste os níveis de log para protocolos de roteamento. | Configurar o nível de detalhes do evento que você deseja registrar. Você pode decidir quais informações deseja rastrear nos arquivos de log. | Registrar detalhes de um protocolo de roteamento
Configure o número de portas VPN. | Adicionar ou remover portas VPN. | Adicionar portas PPTP ou L2TP
Crie um perfil Gerenciador de conexão para os usuários. | Gerenciar a experiência de conexão de clientes dos usuários e simplificar a identificação de problemas nas conexões clientes. | Kit de administração do Gerenciador de conexões
Adicione serviços de certificado. | Configurar e gerenciar uma autoridade de certificação (CA) em um servidor a fim de usá-la em uma infra-estrutura de chave pública (PKI). | Serviços de certificado; Certificados de computador para conexões VPN L2TP/IPSec
Aumente a segurança do acesso remoto. | Proteger os usuários remotos e a rede privada obrigando o uso de métodos de autenticação seguros, exibindo níveis mais altos de criptografia e dados e outras providências. | Informações sobre segurança para acesso remoto
Aumente a segurança da VPN. | Proteger os usuários remotos e a rede privada exigindo o uso de protocolos de roteamento e túnel seguros, configurando o bloqueio de contas e outras providências. | Informações de segurança da VPN


Função do controlador de domínio: Configurando o controlador de domínio

Os controladores de domínio armazenam dados e gerenciam interações entre os usuários e o domínio, inclusive processos de logon do usuário, autenticação e pesquisas de diretório. Se você planeja usar este servidor para fornecer o serviço de diretórios Active Directory a usuários e computadores, configure o servidor como um controlador de domínio.

Para configurar um servidor como controlador de domínio, instale o Active Directory no servidor. Existem quatro opções disponíveis no Assistente para instalação do Active Directory. Você pode criar um controlador de domínio adicional em um domínio existente, um controlador de domínio para um novo domínio filho, um outro para uma nova árvore de domínio ou ainda para uma nova floresta. Se você não tiver certeza sobre a função necessária, leia as informações sobre cada uma clicando na opção da função.

Observações

  • Se você já instalou uma função de controlador de domínio e quer ver as próximas etapas, na lista abaixo clique na configuração do controlador de domínio que você instalou e, em seguida, clique em Próximas etapas: Concluindo tarefas adicionais.
  • Se for necessário reconfigurar seu servidor para uma outra função, você poderá remover funções existentes do servidor. Removendo a função do controlador de domínio, você desinstalará o Active Directory deste servidor. Após a desinstalação do Active Directory, este servidor não participará mais da duplicação de objetos do diretório e das solicitações de autenticação de usuário com base no domínio. Para obter mais informações, consulte as seções abaixo.
Clique no tipo de controlador de domínio que você deseja criar:
Criando um controlador de domínio adicional para um domínio existente
Criando um controlador de domínio para uma nova floresta
Criando um controlador de domínio para um novo domínio filho
Criando um controlador de domínio para uma nova árvore de domínio

Criando um controlador de domínio adicional para um domínio existente

Crie controladores de domínio adicionais se quiser melhorar a disponibilidade e confiabilidade dos serviços de rede. Adicionando outros controladores de domínio, você pode oferecer tolerância a falhas, equilibrar a carga dos controladores de domínio existentes, fornecer suporte de infra-estrutura adicional aos sites e melhorar o desempenho facilitando a conexão dos clientes ao controlador de domínio quando eles fizerem logon na rede. Por exemplo, conforme ilustrado abaixo, adicionar um novo controlador de domínio (DC2) ao domínio microsoft.com ajuda a deslocar a carga de outros controladores de domínio.

Um controlador de domínio adicional é usado para equilibrar a carga e fornecer tolerância a falhas.

Este tópico explica o procedimento básico para criar um controlador de domínio adicional para sua organização.

Este processo envolve o uso do Assistente para configurar o servidor e do Assistente para instalação do Active Directory para instalar o Active Directory no servidor. Quando terminar de configurar o controlador de domínio, você pode concluir as tarefas de configuração adicionais.

Este tópico aborda o seguinte:

Antes de começar

Configurando o controlador de domínio

Próximas etapas: Concluindo tarefas adicionais

Antes de começar

Antes de configurar o servidor como um controlador de domínio, verifique se:

  • As configurações de TCP/IP do servidor estão corretas, particularmente as usadas para a resolução de nomes de DNS. Para obter mais informações, consulte Configurar o TCP/IP para usar o DNS.
  • Todos os volumes de disco existentes usam o sistema de arquivos NTFS. O Active Directory requer pelo menos um volume NTFS para armazenar a pasta SYSVOL e seu conteúdo. Volumes FAT32 não são protegidos e não oferecem suporte à compactação de arquivos e pastas, a cotas de disco, à criptografia de arquivos ou a permissões de arquivo individuais.

A tabela a seguir lista as informações que você precisa saber antes de adicionar outro controlador de domínio.

Antes de adicionar uma outra função de controlador de domínio | Comentários
Determine quais sites requerem um controlador de domínio. | Se a sua rede estiver dividida em sites, recomenda-se colocar pelo menos um controlador de domínio em cada site para melhorar o desempenho da rede. Quando os usuários fazem logon na rede, um controlador de domínio deve ser contatado como parte do processo de logon. Se os clientes tiverem que se conectar a um controlador de domínio localizado em um local diferente, o processo de logon pode demorar muito tempo.
Determine se irá adicionar um outro controlador de domínio por meio da rede ou da mídia de backup tirada de um controlador de domínio existente | Com a família Windows Server 2003, você pode instalar o Active Directory em servidores membros usando um backup restaurado tirado de um controlador de domínio que executa Windows Server 2003. Você pode armazenar este backup em qualquer mídia de backup (por exemplo, fita, CD ou DVD) ou em um recurso de rede compartilhado. Usando arquivos de backup restaurados para criar um controlador de domínio adicional, você reduz significativamente a largura de banda da rede utilizada quando você instala o Active Directory com um recurso de rede compartilhado. Ainda assim você precisará de conectividade de rede para duplicar todos os novos objetos e mudanças recentes em objetos existentes para o novo controlador de domínio. Para obter mais informações sobre como criar um controlador de domínio adicional usando a mídia de backup, consulte Criando cotnroladores de domínio adicionais.
Determine se você deseja que o novo controlador de domínio hospede um catálogo global. | O catálogo global armazena uma cópia completa de todos os objetos no diretório para seu domínio host e uma cópia parcial de todos os objetos para todos os outros domínios na floresta. Para otimizar o desempenho da rede em um ambiente de vários sites, considere adicionar catálogos globais para selecionar sites. Em um ambiente de um único site, um único catálogo global normalmente é suficiente para cobrir consultas comuns do Active Directory. No entanto, em um ambiente de vários sites, é recomendável que você use catálogos globais em cada site. Para obter mais informações sobre quando adicionar catálogos globais em um ambiente de vários sites, consulte Catálogos e sites globais.
Estão disponíveis controladores de domínio que executam o Windows 2000 ou Windows Server 2003. | O domínio deve ter, pelo menos, um outro controlador de domínio executando Windows 2000 ou Windows Server 2003 para poder adicionar um outro controlador de domínio. Os controladores de domínio do Active Directory não podem ser configurados como controladores de domínio de backup (BCD) para domínios do Windows.
Obtenha as credenciais administrativas necessárias para adicionar um controlador de domínio. | Para adicionar um controlador de domínio adicional a um domínio existente, você deve ser membro do grupo Admins. do domínio ou do grupo Administradores da empresa no Active Directory ou deve ter a autoridade apropriada.
Identifique o nome de domínio DNS do domínio do Active Directory ao qual você deseja adicionar outro controlador de domínio. | Você precisa fornecer o nome do domínio DNS ao utilizar o Assistente para instalação do Active Directory.

Configurando o controlador de domínio

Para configurar um controlador de domínio adicional, inicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Controlador de domínio (Active Directory) e, em seguida, clique em Avançar.

Esta seção descreve cada uma das etapas deste processo e indica as opções e decisões necessárias que você fará quando configurar o controlador de domínio. As seções a seguir abordam estas etapas da configuração:

Resumo das seleções

Usando o Assistente para instalação do Active Directory

Concluindo o Assistente para configurar o servidor

Removendo a função do controlador de domínio

Resumo das seleções

Na página Resumo das seleções do Assistente para configurar o servidor, você pode exibir e confirmar as opções selecionadas. Se você selecionou Controlador de domínio (Active Directory) na página anterior, aparecerá o seguinte:

  • Execute o 'Assistente para instalação do Active Directory' para configurar este servidor como um controlador de domínio

Para aplicar as seleções mostradas na página Resumo das seleções, clique em Avançar.

Usando o Assistente para instalação do Active Directory

Depois que você clicar em Avançar, o Assistente para instalação do Active Directory é iniciado automaticamente. Se esta for a primeira vez que você instala o Active Directory em um servidor, clique em Ajuda do Active Directory para obter mais informações.

Depois de ler as informações sobre o Active Directory, clique em Avançar. Você pode retornar a esta página de qualquer local do assistente até clicar no botão Concluir na última página. Na página Compatibilidade de sistema operacional, leia as informações e, em seguida, clique em Avançar. Se esta é a primeira vez que você instala o Active Directory em um servidor que executa o Windows Server 2003, clique em Ajuda sobre Compatibilidade para obter mais informações.

Esta seção descreve as seguintes etapas do Assistente para instalação do Active Directory:

Tipo de controlador de domínio

Credenciais de rede

Controlador de domínio adicional

Pastas do banco de dados e do log

Volume de sistemas compartilhados

Senha do administrador do modo de restauração dos serviços de diretório

Resumo

Tipo de controlador de domínio

Na página Tipo do controlador de domínio do Assistente para instalação do Active Directory, clique em Controlador de domínio adicional para um domínio existente.

Como parte do processo de criação de um controlador de domínio adicional, o assistente exclui todas as contas locais, chaves de criptografia e dados criptografados, como arquivos criptografados e e-mail do servidor. Para evitar perda de dados, siga as recomendações da página Tipo do controlador de domínio antes de prosseguir.

Quando terminar, clique em Avançar.

Credenciais de rede

Na página Credenciais de rede, digite o nome de usuário, a senha e o domínio da conta de usuário que você deseja utilizar.

Opção | Comentários
Nome de usuário | Digite o nome de uma conta de usuário que possui as credenciais administrativas necessárias. A conta de usuário deve ser membro do grupo Admins. do domínio para o domínio alvo, ou membro do grupo Administração de empresa, ou ter recebido delegação da autoridade adequada.
Senha | Digite a senha da conta de usuário. A senha deve ser de alta segurança. Para obter mais informações, consulte Senhas de alta segurança.
Domínio | Digite o nome DNS completo do domínio no qual este nome de usuário e senha são válidos (por exemplo, child.microsoft.com). Este também é o domínio no qual você deseja adicionar outro controlador de domínio.

Quando terminar, clique em Avançar.

Controlador de domínio adicional

Na página Controlador de domínio adicional, digite o nome DNS completo do domínio ao qual você deseja adicionar este controlador. Um nome de DNS completo também é chamado de nome de domínio totalmente qualificado (FQDN). Os domínios do Active Directory são chamados por nomes DNS e seguem a mesma estrutura hierárquica do DNS.

Quando terminar, clique em Avançar.

Pastas do banco de dados e do log

Na página Pastas do banco de dados e log, digite os locais nos quais você deseja instalar o banco de dados e as pastas de log ou clique em Procurar para escolher os locais. Para evitar problemas ao instalar ou remover o Active Directory, é importante confirmar que você possui espaço em disco suficiente para hospedar o banco de dados e os arquivos de log do diretório. O Assistente para instalação do Active Directory requer 250 megabytes (MB) de espaço em disco para o banco de dados e 50 MB para os arquivos de log. É recomendável que você armazene esses arquivos em uma partição NTFS.

Quando terminar, clique em Avançar.

Volume de sistemas compartilhados

Na página Volume de sistema compartilhado, aceite o local padrão no qual você deseja instalar a pasta Sysvol ou clique em Procurar para escolher um local. A pasta Sysvol deve ser armazenada em um volume NTFS, pois contém arquivos que são duplicados entre controladores de domínio de um domínio ou floresta. Esses arquivos incluem scripts, diretivas do sistema para Windows NT 4.0 e versões anteriores, as pastas compartilhadas Netlogon e Sysvol e as configurações de Diretiva de grupo.

Quando terminar, clique em Avançar.

Senha do administrador do modo de restauração dos serviços de diretório

Na página Senha do administrador do modo de restauração dos serviços de diretório, digite e confirme a senha que você deseja atribuir à conta do Administrador do modo de restauração para o servidor. Use senhas de alta segurança no modo de restauração de diretório. Para obter mais informações, consulte Senhas de alta segurança.

Importante

  • Você deve lembrar a senha para poder restaurar uma cópia de backup do Estado do sistema para este controlador de domínio.

Use esta senha quando o controlador de domínio iniciar no Modo de restauração dos serviços de diretório. Se esta for a primeira vez que você instala o Active Directory em um servidor, clique em Ajuda do Active Directory para obter mais informações sobre a senha do modo de restauração.

Quando terminar, clique em Avançar.

Resumo

Examine a página Resumo e clique em Avançar para iniciar a instalação.

Ao concluir a instalação, clique em Concluir. Para reiniciar o computador e implementar as alterações, clique em Reiniciar agora.

Concluindo o Assistente para configurar o servidor

Após a reinicialização do servidor, o Assistente para configurar o servidor exibe a página Este servidor agora é um controlador de domínio. Para rever todas as alterações feitas no servidor pelo Assistente para configurar o servidor ou certificar-se que uma nova função foi instalada com sucesso, clique em Log de Configuração do servidor. O log Assistente para configurar o servidor localiza-se em systemroot\Debug\Configure Your Server.log. Para fechar o Assistente para configurar o servidor, clique em Concluir.

Removendo a função do controlador de domínio

Se for necessário reconfigurar seu servidor para uma outra função, você poderá remover funções existentes do servidor. Removendo a função do controlador de domínio, você desinstalará o Active Directory deste servidor. Após a desinstalação do Active Directory, este servidor não participará mais da duplicação de objetos do diretório e das solicitações de autenticação de usuário com base no domínio.

Para remover a função de controlador de domínio, reinicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Controlador de domínio (Active Directory) e, em seguida, clique em Avançar. Na página Confirmação de remoção de função, reveja os itens listados em Resumo, marque a caixa Remover a função de controlador de domínio e clique em Avançar. Depois, siga o procedimento do Assistente para instalação do Active Directory.

Próximas etapas: Concluindo tarefas adicionais

Depois que você concluir o Assistente para instalação do Active Directory, o servidor é configurado como um controlador de domínio. Você pode usá-lo para armazenar dados, gerenciar objetos e fornecer informações aos usuários, computadores e aplicativos. Até este ponto, você criou um controlador de domínio adicional para um domínio existente.

A tabela a seguir lista algumas tarefas adicionais que você pode executar no controlador de domínio.

Tarefa | Objetivo da tarefa | Referência
Proteja o novo controlador de domínio em um sala trancada. | Assegurar que ninguém acesse fisicamente os controladores de domínio. | Controladores de domínio; Protegendo o Active Directory
Use técnicas de criptografia de alta segurança para proteger as senhas das contas. | Proteger as informações sobre senhas de contas no novo controlador de domínio. | O utilitário de chave do sistema

Criando um controlador de domínio para uma nova floresta

Crie um controlador de domínio para uma nova floresta quando você quiser atualizar um domínio Windows NT para que ele se torne o primeiro domínio de uma nova floresta, segmentar sua rede para obter autonomia administrativa, fornecer um limite de segurança para proteger dados sensíveis, isolar o escopo da duplicação de diretórios ou usar um espaço para nome DNS não contíguo que seja diferente de uma floresta existente de sua rede. Por exemplo, conforme ilustrado abaixo, a floresta microsoft.com é o primeiro domínio do Active Directory em uma organização.

Uma floresta pode ser usada como primeiro domínio do Active Directory na sua organização.

Este tópico explica o procedimento básico para configurar um controlador de domínio para uma nova floresta da sua organização.

Este processo envolve o uso do Assistente para configurar o servidor e do Assistente para instalação do Active Directory para instalar o Active Directory no servidor. Quando terminar de configurar o controlador de domínio, você pode concluir as tarefas de configuração adicionais.

Este tópico aborda o seguinte:

Antes de começar

Configurando o controlador de domínio

Próximas etapas: Concluindo tarefas adicionais

Antes de começar

Antes de configurar o servidor como um controlador de domínio, verifique se:

  • As configurações de TCP/IP do servidor estão corretas, particularmente as usadas para a resolução de nomes de DNS. Para obter mais informações, consulte Configurar o TCP/IP para usar o DNS.
  • Todos os volumes de disco existentes usam o sistema de arquivos NTFS. O Active Directory requer pelo menos um volume NTFS para armazenar a pasta SYSVOL e seu conteúdo. Volumes FAT32 não são protegidos e não oferecem suporte à compactação de arquivos e pastas, a cotas de disco, à criptografia de arquivos ou a permissões de arquivo individuais.

A tabela a seguir lista as informações que você precisa saber antes de adicionar um controlador de domínio a uma nova floresta.

Antes de adicionar uma nova função de controlador de domínio a uma nova floresta | Comentários
Verifique se o DNS está configurado corretamente para sua organização. | Você precisará confirmar que o DNS está adequadamente configurado na rede e que oferece suporte para atualizações dinâmicas e registros de recursos de serviços (SRV). Se você estiver configurando o Active Directory pela primeira vez em sua organização e não possuir atualmente uma infra-estrutura DNS configurada, o Assistente para instalação do Active Directory configura o DNS no servidor durante o processo de instalação do Active Directory. O Active Directory requer que o DNS opere e compartilhe a mesma estrutura de domínio hierárquica. Por exemplo, microsoft.com é um domínio DNS e um domínio Active Directory.
Obtenha as credenciais administrativas necessárias para criar uma floresta. | Para criar uma nova floresta, você deve ser membro do grupo Administradores no computador local ou deve ter recebido a delegação da autoridade adequada.

Configurando o controlador de domínio

Para configurar um controlador de domínio, inicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Controlador de domínio (Active Directory) e, em seguida, clique em Avançar.

Esta seção descreve cada uma das etapas deste processo e indica as opções e decisões necessárias que você fará quando configurar o controlador de domínio. As seções a seguir abordam estas etapas da configuração:

Resumo das seleções

Usando o Assistente para instalação do Active Directory

Concluindo o Assistente para configurar o servidor

Removendo a função do controlador de domínio

Resumo das seleções

Na página Resumo das seleções do Assistente para configurar o servidor, você pode exibir e confirmar as opções selecionadas. Se você selecionou Controlador de domínio (Active Directory) na página anterior, aparecerá o seguinte:

  • Execute o 'Assistente para instalação do Active Directory' para configurar este servidor como um controlador de domínio

Para aplicar as seleções mostradas na página Resumo das seleções, clique em Avançar.

Usando o Assistente para instalação do Active Directory

Depois que você clicar em Avançar, o Assistente para instalação do Active Directory é iniciado automaticamente. Se esta for a primeira vez que você instala o Active Directory em um servidor, clique em Ajuda do Active Directory para obter mais informações.

Depois de ler as informações sobre o Active Directory, clique em Avançar. Você pode retornar a esta página de qualquer local do assistente até clicar no botão Concluir na última página. Na página Compatibilidade de sistema operacional, leia as informações e, em seguida, clique em Avançar. Se esta é a primeira vez que você instala o Active Directory em um servidor que executa o Windows Server 2003, clique em Ajuda sobre Compatibilidade para obter mais informações.

Esta seção descreve as seguintes etapas do Assistente para instalação do Active Directory:

Tipo do controlador de domínio

Criar novo domínio

Nome do novo domínio

Nome de domínio NetBIOS

Pastas do banco de dados e do log

Volume de sistemas compartilhados

Diagnósticos de registro do DNS

Permissões

Senha do administrador do modo de restauração dos serviços de diretório

Resumo

Tipo do controlador de domínio

Na página Tipo do controlador de domínio, clique em Controlador de domínio para um novo domínio.

Quando terminar, clique em Avançar.

Criar novo domínio

Na página Criar novo domínio, clique em Domínio em uma nova floresta.

Quando terminar, clique em Avançar.

Nome do novo domínio

Na página Novo nome de domínio, digite o nome DNS completo do novo domínio. Forneça um nome DNS completo para a nova floresta do Active Directory que você criará (por exemplo, headquarters.example.microsoft.com). Um nome de DNS completo também é chamado de nome de domínio totalmente qualificado (FQDN). Os domínios do Active Directory são chamados por nomes DNS e seguem a mesma estrutura hierárquica do DNS. Ao escolher nomes DNS para uso na floresta do Active Directory, inicie com o sufixo de domínio DNS registrado que sua organização reservou para usar na Internet, como microsoft.com.

Quando terminar, clique em Avançar.

Nome de domínio NetBIOS

Na página Nome de Domínio NetBIOS, verifique o nome NetBIOS. Embora os domínios do Active Directory sejam nomeados de acordo com padrões de nomeação do DNS, ainda será necessário definir um nome NetBIOS quando você criar domínios do Active Directory. Sempre que possível, os nomes NetBIOS devem corresponder à primeira label do nome de domínio DNS. Quando o domínio do Active Directory possui um nome DNS de primeira label diferente do seu nome NetBIOS, o FQDN é criado usando o nome de domínio DNS, e não o nome NetBIOS. Por exemplo, se o primeiro rótulo do nome de domínio DNS for "filho" (filho.microsoft.com é o nome FQDN) e o nome de domínio NetBIOS for "vendas", o nome FQDN permanecerá "filho.microsoft.com".

Quando terminar, clique em Avançar.

Pastas do banco de dados e do log

Na página Pastas do banco de dados e log, digite o local no qual você deseja instalar as pastas do banco de dados ou do log, ou clique em Procurar para escolher um local. Para evitar problemas ao instalar ou remover o Active Directory, é importante confirmar que você possui espaço em disco suficiente para hospedar o banco de dados e os arquivos de log do diretório. O Assistente para instalação do Active Directory requer 250 megabytes (MB) de espaço em disco para o banco de dados e 50 MB para os arquivos de log. É recomendável que você armazene esses arquivos em uma partição NTFS.

Quando terminar, clique em Avançar.

Volume de sistemas compartilhados

Na página Volume de sistema compartilhado, digite o local no qual você deseja instalar a pasta Sysvol ou clique em Procurar para escolher um local. A pasta Sysvol deve ser armazenada em um volume NTFS, pois contém arquivos que são duplicados entre controladores de domínio de um domínio ou floresta. Esses arquivos incluem scripts, diretivas do sistema Windows NT 4.0 e anteriores, os compartilhamentos NETLOGON e SYSVOL e as configurações de diretiva de grupo.

Quando terminar, clique em Avançar.

Diagnóstico de registro deo DNS

Na página Diagnóstico de registro de DNS, verifique se as configurações do DNS estão corretas.

Se aparecer um erro de diagnóstico em Resultados de diagnóstico, clique em Ajuda para obter mais informações sobre como solucioná-lo

Quando terminar, clique em Avançar.

Permissões

Na página Permissões, clique no nível de compatibilidade do aplicativo desejada com as versões anteriores dos sistemas operacionais do servidor Windows 2000, Windows 2000 ou Windows Server 2003.

Em servidores que executam o Windows NT 4.0 e versões anteriores, o acesso de leitura para as informações sobre o usuário e os grupos é atribuído a usuários anônimos de forma que os aplicativos existentes, incluindo o Microsoft BackOffice, o SQL Server e alguns aplicativos não-Microsoft funcionem corretamente. No Windows 2000 e na família Windows Server 2003, os membros do grupo Logon anônimo têm acesso de leitura a essas informações somente quando o grupo é adicionado ao grupo de Acesso compatível com versões anteriores ao Windows 2000.

Opção | Comentários
Permissões compatíveis com os sistemas operacionais anteriores ao Windows 2000 | Clique nesta opção se desejar que o grupo Logon anônimo e os grupos de segurança Todos sejam adicionados ao grupo Acesso compatível com versões anteriores ao Windows 2000.
Permissões compatíveis somente com os sistemas operacionais Windows 2000 ou Windows Server 2003 | Clique nesta opção para impedir que membros do grupo Logon anônimo tenham acesso de leitura às informações de usuários e de grupos.

Depois que você selecionar uma dessas opções, pode alternar manualmente entre as configurações com versões anteriores e as configurações de alta segurança nos objetos do Active Directory. Para isso, abra Usuários e computadores do Active Directory e adicione o grupo de segurança Logon anônimo ao grupo de segurança Acesso compatível de versões anteriores do Windows 2000.

Quando terminar, clique em Avançar.

Senha do administrador do modo de restauração dos serviços de diretório

Na página Senha do administrador do modo de restauração dos serviços de diretório, digite e confirme a senha que você deseja atribuir à conta do Administrador do modo de restauração para o servidor. Use senhas de alta segurança no modo de restauração de diretório. Para obter mais informações, consulte Senhas de alta segurança.

Importante

  • Você deve lembrar a senha para poder restaurar uma cópia de backup do Estado do sistema para este controlador de domínio.

Use esta senha quando o controlador de domínio iniciar no Modo de restauração dos serviços de diretório. Se esta for a primeira vez que você instala o Active Directory em um servidor, clique em Ajuda do Active Directory para obter mais informações sobre a senha do modo de restauração.

Quando terminar, clique em Avançar.

Resumo

Examine a página Resumo e clique em Avançar para iniciar a instalação.

Ao concluir a instalação, clique em Concluir. Para reiniciar o computador e implementar as alterações, clique em Reiniciar agora.

Concluindo o Assistente para configurar o servidor

Após a reinicialização do servidor, o Assistente para configurar o servidor exibe a página Este servidor agora é um controlador de domínio. Para rever todas as alterações feitas no servidor pelo Assistente para configurar o servidor ou certificar-se que uma nova função foi instalada com sucesso, clique em Log de Configuração do servidor. O log Assistente para configurar o servidor localiza-se em systemroot\Debug\Configure Your Server.log. Para fechar o Assistente para configurar o servidor, clique em Concluir.

Removendo a função do controlador de domínio

Se for necessário reconfigurar seu servidor para uma outra função, você poderá remover funções existentes do servidor. Removendo a função do controlador de domínio, você desinstalará o Active Directory deste servidor. Após a desinstalação do Active Directory, este servidor não participará mais da duplicação de objetos do diretório e das solicitações de autenticação de usuário com base no domínio.

Para remover a função de controlador de domínio, reinicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Controlador de domínio (Active Directory) e, em seguida, clique em Avançar. Na página Confirmação de remoção de função, reveja os itens listados em Resumo, marque a caixa Remover a função de controlador de domínio e clique em Avançar. Depois, siga o procedimento do Assistente para instalação do Active Directory.

Próximas etapas: Concluindo tarefas adicionais

Depois que você concluir o Assistente para instalação do Active Directory, o servidor é configurado como um controlador de domínio. Você pode usá-lo para armazenar dados, gerenciar objetos e fornecer informações aos usuários, computadores e aplicativos. Até este ponto, você criou um controlador de domínio para uma nova floresta.

A tabela a seguir lista algumas tarefas adicionais que você pode executar no controlador de domínio.

Tarefa | Objetivo da tarefa | Referência
Proteger o novo controlador de domínio em um sala trancada. | Assegurar que ninguém acesse fisicamente os controladores de domínio. | Controladores de domínio; Protegendo o Active Directory
Usar técnicas de criptografia de alta segurança. | Proteger as informações sobre senhas de contas no novo controlador de domínio. | O utilitário de chave do sistema
Verificar e autenticar a validade de cada usuário. | Melhorar a segurança da floresta usando a criptografia de chave pública. | infra-estrutura de chave pública
Forçar todos os usuários do domínio a usar senhas de alta segurança. | Evitar o acesso não autorizado à organização. | Senhas de alta segurança
Ativar a diretiva de auditoria. | Receber notificação de ações que podem configurar um risco de segurança. | Diretiva de auditoria
Aplicar bloqueios de conta em contas de usuários. | Reduzir a possibilidade de um invasor comprometer seu domínio depois de repetidas tentativas de logon. | Contas de usuário e de computador
Aplicar o histórico de senha em contas de usuários. | Reduzir a possibilidade de um invasor comprometer seu domínio. | Aplicar histórico de senhas
Aplicar duração de senha máxima e mínima em contas de usuários. | Reduzir a possibilidade de um invasor comprometer seu domínio. | Duração mínima da senha; Duração máxima da senha.
Implementar a filtragem SID. | Impedir ataques de usuários maliciosos que podem tentar conceder direitos de usuário elevados a outra conta de computador. | "Using Security Identifier (SID) Filtering to Prevent Elevation of Privilege Attacks" (em inglês) no site da Microsoft.(http://www.microsoft.com/)
Implementar cartões inteligentes | Fornecer autenticação de usuário e segurança de e-mail resistente ao uso. | Visão geral sobre cartões inteligentes
Restringir o acesso do usuário, grupo e computador aos recursos compartilhados e filtrar as configurações de diretiva de grupo. | Proteger os recursos. | Grupos de segurança
Criar relações de confiança da florestas (conforme adequado). | Gerenciar a relação de segurança entre duas florestas e simplificar a administração e a autenticação entre florestas. | Relações de confiança da floresta
Atribuir direitos de usuário a novos grupos de segurança. | Definir especificamente a função administrativa dos membros do domínio. | Direitos de usuário atribuídos a grupos de segurança no Active Directory

Criando um controlador de domínio para um novo domínio filho

Crie um controlador de domínio para um novo domínio filho quando desejar criar um domínio que compartilhe um espaço para nome contíguo com um ou mais domínios existentes. Isso significa que o nome do novo domínio contém o nome completo do domínio pai. Por exemplo, conforme ilustrado abaixo, child.microsoft.com é um domínio filho de microsoft.com. Recomendamos que você crie novos domínios como filhos do domínio raiz da floresta.

Um domínio filho é usado para formar um espaço para nome contíguo com seu pai.

Este tópico explica o procedimento básico para configurar um controlador de domínio para um novo domínio filho de sua organização.

Este processo envolve o uso do Assistente para configurar o servidor e do Assistente para instalação do Active Directory para instalar o Active Directory no servidor. Quando terminar de configurar o controlador de domínio, você pode concluir as tarefas de configuração adicionais.

Este tópico aborda o seguinte:

Antes de começar

Configurando o controlador de domínio

Próximas etapas: Concluindo tarefas adicionais

Antes de começar

Antes de configurar o servidor como um controlador de domínio, verifique se:

  • As configurações de TCP/IP do servidor estão corretas, principalmente as usadas para a resolução de nomes de DNS. Para obter mais informações, consulte Configurar o TCP/IP para usar o DNS.
  • Todos os volumes de disco existentes usam o sistema de arquivos NTFS. O Active Directory requer pelo menos um volume NTFS para armazenar a pasta SYSVOL e seu conteúdo. Volumes FAT32 não são protegidos e não oferecem suporte à compactação de arquivos e pastas, a cotas de disco, à criptografia de arquivos ou a permissões de arquivo individuais.

A tabela a seguir lista as informações que você precisa saber antes de adicionar o controlador de domínio.

Antes de adicionar uma função de controlador de domínio | Comentários
Identifique o nome de domínio DNS do domínio do Active Directory ao qual você deseja adicionar o controlador de domínio. | Você deve fornecer o nome do domínio DNS para o domínio pai deste novo domínio filho.
Verifique se a velocidade da rede é adequada ao instalar o Active Directory. | O servidor no qual você deseja instalar o Active Directory e criar um domínio filho deve ter acesso à rede através de uma conexão de alta velocidade.
Determine quais sites requerem um controlador de domínio. | Se a sua rede estiver dividida em sites, recomenda-se colocar pelo menos um controlador de domínio em cada site para melhorar o desempenho da rede. Quando os usuários fazem logon na rede, um controlador de domínio deve ser contatado como parte do processo de logon. Se os clientes tiverem que se conectar a um controlador de domínio localizado em um local diferente, o processo de logon pode demorar muito tempo.
Determine se você deseja que o novo controlador de domínio hospede um catálogo global. | Um catálogo global armazena uma cópia dos objetos do Active Directory em uma floresta em um controlador de domínio. O catálogo global armazena uma cópia completa de todos os objetos no diretório para seu domínio host e uma cópia parcial de todos os objetos para todos os outros domínios na floresta. Para otimizar o desempenho da rede em um ambiente de vários sites, considere adicionar catálogos globais para selecionar sites. Em um ambiente de um único site, um único catálogo global normalmente é suficiente para cobrir consultas comuns do Active Directory. No entanto, em um ambiente de vários sites, é recomendável que você use catálogos globais em cada site. Para obter mais informações sobre quando adicionar catálogos globais em um ambiente de vários sites, consulte Catálogos e sites globais.
Obtenha as credenciais administrativas necessárias para criar um domínio filho. | Para adicionar um novo domínio filho, você deve ser membro do grupo Admins. do domínio (no domínio pai) ou do grupo Administradores da empresa no Active Directory ou deve ter recebido a autoridade apropriada por delegação.

Configurando o controlador de domínio

Para configurar um controlador de domínio, inicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Controlador de domínio (Active Directory) e, em seguida, clique em Avançar.

Esta seção descreve cada uma das etapas deste processo e indica as opções e decisões necessárias que você fará quando configurar o controlador de domínio. As seções a seguir abordam estas etapas da configuração:

Resumo das seleções

Usando o Assistente para instalação do Active Directory

Concluindo o Assistente para configurar o servidor

Removendo a função do controlador de domínio

Resumo das seleções

Na página Resumo das seleções do Assistente para configurar o servidor, você pode exibir e confirmar as opções selecionadas. Se você selecionou Controlador de domínio (Active Directory) na página anterior, aparecerá o seguinte:

  • Execute o 'Assistente para instalação do Active Directory' para configurar este servidor como um controlador de domínio

Para aplicar as seleções mostradas na página Resumo das seleções, clique em Avançar.

Usando o Assistente para instalação do Active Directory

Depois que você clicar em Avançar, o Assistente para instalação do Active Directory é iniciado automaticamente. Se esta for a primeira vez que você instala o Active Directory em um servidor, clique em Ajuda do Active Directory para obter mais informações.

Depois de ler as informações sobre o Active Directory, clique em Avançar. Você pode retornar a esta página de qualquer local do assistente até clicar no botão Concluir na última página. Na página Compatibilidade de sistema operacional, leia as informações e, em seguida, clique em Avançar. Se esta é a primeira vez que você instala o Active Directory em um servidor que executa o Windows Server 2003, clique em Ajuda sobre Compatibilidade para obter mais informações.

Esta seção descreve as seguintes etapas do Assistente para instalação do Active Directory:

Tipo do controlador de domínio

Criar novo domínio

Credenciais de rede

Instalação de domínio filho

Nome de domínio NetBIOS

Pastas do banco de dados e do log

Volume de sistemas compartilhados

Diagnósticos de registro do DNS

Permissões

Senha do administrador do modo de restauração dos serviços de diretório

Resumo

Tipo do controlador de domínio

Na página Tipo do controlador de domínio, clique em Controlador de domínio para um novo domínio.

Quando terminar, clique em Avançar.

Criar novo domínio

Na página Criar novo domínio, clique em Domínio filho em uma árvore de domínio existente.

Quando terminar, clique em Avançar.

Credenciais de rede

Na página Credenciais de rede, digite o nome de usuário, a senha e o domínio da conta de usuário que você deseja utilizar.

Opção | Comentários
Nome de usuário | Digite o nome de uma conta de usuário que possui as credenciais administrativas necessárias. A conta de usuário deve ser membro do grupo Admins. do domínio (no domínio pai), ou membro do grupo Administração de empresa, ou ter recebido delegação da autoridade adequada.
Senha | Digite a senha da conta de usuário. A senha deve ser de alta segurança. Para obter mais informações, consulte Senhas de alta segurança.
Domínio | Digite o nome DNS completo do domínio no qual este nome de usuário e senha são válidos.

Quando terminar, clique em Avançar.

Instalação de domínio filho

Na página Instalação de domínio filho, verifique o domínio pai e o nome do novo domínio filho. Os domínios do Active Directory são chamados por nomes DNS e seguem a mesma estrutura hierárquica do DNS. Ao escolher nomes DNS a serem usados pelo domínio filho, considere os nomes com escopo geográfico ou divisional dentro de sua organização (por exemplo, newyork.microsoft.com ou vendas.microsoft.com).

Seguindo os padrões do DNS, os nomes de domínio são nomes totalmente qualificados (FQDN), que consistem no nome do domínio anexado aos nomes dos domínios pai e domínios raiz usando o formato de caracteres ponto (.). Por exemplo, um domínio do Active Directory chamado "filho" e um domínio pai chamado "microsoft.com" possuem o FQDN (também chamado de nome DNS completo) "filho.microsoft.com".

Quando terminar, clique em Avançar.

Nome de domínio NetBIOS

Na página Nome de Domínio NetBIOS, verifique o nome NetBIOS. Embora os domínios do Active Directory sejam nomeados de acordo com padrões de nomeação do DNS, ainda será necessário definir um nome NetBIOS quando você criar domínios do Active Directory. Sempre que possível, os nomes NetBIOS devem corresponder à primeira label do nome de domínio DNS. Quando o domínio do Active Directory possui um nome DNS de primeira label diferente do seu nome NetBIOS, o FQDN é criado usando o nome de domínio DNS, e não o nome NetBIOS. Por exemplo, se o primeiro rótulo do nome de domínio DNS for "filho" (filho.microsoft.com é o nome FQDN) e o nome de domínio NetBIOS for "vendas", o nome FQDN permanecerá "filho.microsoft.com".

Pastas do banco de dados e do log

Na página Pastas do banco de dados e log, digite o local no qual você deseja instalar o banco de dados e as pastas de log ou clique em Procurar para escolher um local e, em seguida, clique em Avançar. Para evitar problemas ao instalar ou remover o Active Directory, é importante confirmar que você possui espaço em disco suficiente para hospedar o banco de dados e os arquivos de log do diretório. O Assistente para instalação do Active Directory requer 250 megabytes (MB) de espaço em disco para o banco de dados e 50 MB para os arquivos de log. É recomendável que você armazene esses arquivos em uma partição NTFS.

Quando terminar, clique em Avançar.

Volume de sistemas compartilhados

Na página Volume de sistema compartilhado, digite o local no qual você deseja instalar a pasta Sysvol ou clique em Procurar para escolher um local. A pasta Sysvol deve ser armazenada em um volume NTFS, pois contém arquivos que são duplicados entre controladores de domínio de um domínio ou floresta. Esses arquivos incluem scripts, diretivas do sistema Windows NT 4.0 e anteriores, os compartilhamentos NETLOGON e SYSVOL e as configurações de diretiva de grupo.

Quando terminar, clique em Avançar.

Diagnóstico de registro deo DNS

Na página Diagnóstico de registro de DNS, verifique se as configurações do DNS estão corretas.

Se aparecer um erro de diagnóstico em Resultados de diagnóstico, clique em Ajuda para obter mais informações sobre como solucioná-lo

Quando terminar, clique em Avançar.

Permissões

Na página Permissões, clique no nível de compatibilidade do aplicativo desejada com as versões anteriores dos sistemas operacionais do servidor Windows 2000, Windows 2000 ou Windows Server 2003.

Em servidores que executam o Windows NT 4.0 e versões anteriores, o acesso de leitura para as informações sobre o usuário e os grupos é atribuído a usuários anônimos de forma que os aplicativos existentes, incluindo o Microsoft BackOffice, o SQL Server e alguns aplicativos não-Microsoft funcionem corretamente. No Windows 2000 e na família Windows Server 2003, os membros do grupo Logon anônimo têm acesso de leitura a essas informações somente quando o grupo é adicionado ao grupo de Acesso compatível com versões anteriores ao Windows 2000.

Opção | Comentários
Permissões compatíveis com os sistemas operacionais anteriores ao Windows 2000 | Clique nesta opção se desejar que o grupo Logon anônimo e os grupos de segurança Todos sejam adicionados ao grupo Acesso compatível com versões anteriores ao Windows 2000.
Permissões compatíveis somente com os sistemas operacionais Windows 2000 ou Windows Server 2003 | Clique nesta opção para impedir que membros do grupo Logon anônimo tenham acesso de leitura às informações de usuários e de grupos.

Depois que você selecionar uma dessas opções, pode alternar manualmente entre as configurações com versões anteriores e as configurações de alta segurança nos objetos do Active Directory. Para isso, abra Usuários e computadores do Active Directory e adicione o grupo de segurança Logon anônimo ao grupo de segurança Acesso compatível de versões anteriores do Windows 2000.

Quando terminar, clique em Avançar.

Senha do administrador do modo de restauração dos serviços de diretório

Na página Senha do administrador do modo de restauração dos serviços de diretório, digite e confirme a senha que você deseja atribuir à conta do Administrador do modo de restauração para o servidor. Use senhas de alta segurança no modo de restauração de diretório. Para obter mais informações, consulte Senhas de alta segurança.

Importante

  • Você deve lembrar a senha para poder restaurar uma cópia de backup do Estado do sistema para este controlador de domínio.

Use esta senha quando o controlador de domínio iniciar no Modo de restauração dos serviços de diretório. Se esta for a primeira vez que você instala o Active Directory em um servidor, clique em Ajuda do Active Directory para obter mais informações sobre a senha do modo de restauração.

Quando terminar, clique em Avançar.

Resumo

Examine a página Resumo e clique em Avançar para iniciar a instalação.

Ao concluir a instalação, clique em Concluir. Para reiniciar o computador e implementar as alterações, clique em Reiniciar agora.

Concluindo o Assistente para configurar o servidor

Após a reinicialização do servidor, o Assistente para configurar o servidor exibe a página Este servidor agora é um controlador de domínio. Para rever todas as alterações feitas no servidor pelo Assistente para configurar o servidor ou certificar-se que uma nova função foi instalada com sucesso, clique em Log de Configuração do servidor. O log Assistente para configurar o servidor localiza-se em systemroot\Debug\Configure Your Server.log. Para fechar o Assistente para configurar o servidor, clique em Concluir.

Removendo a função do controlador de domínio

Se for necessário reconfigurar seu servidor para uma outra função, você poderá remover funções existentes do servidor. Removendo a função do controlador de domínio, você desinstalará o Active Directory deste servidor. Após a desinstalação do Active Directory, este servidor não participará mais da duplicação de objetos do diretório e das solicitações de autenticação de usuário com base no domínio.

Para remover a função de controlador de domínio, reinicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Controlador de domínio (Active Directory) e, em seguida, clique em Avançar. Na página Confirmação de remoção de função, reveja os itens listados em Resumo, marque a caixa Remover a função de controlador de domínio e clique em Avançar. Depois, siga o procedimento do Assistente para instalação do Active Directory.

Próximas etapas: Concluindo tarefas adicionais

Depois que você concluir o Assistente para instalação do Active Directory, o servidor é configurado como um controlador de domínio. Você pode usá-lo para armazenar dados, gerenciar objetos e fornecer informações aos usuários, computadores e aplicativos. Até este ponto, você criou um novo domínio ou um controlador de domínio adicional de um domínio existente.

A tabela a seguir lista algumas tarefas adicionais que você pode executar no controlador de domínio.

Tarefa | Objetivo da tarefa | Referência
Proteger o novo controlador de domínio em um sala trancada. | Assegurar que ninguém acesse fisicamente o controlador de domínio. | Controladores de domínio; Protegendo o Active Directory
Usar técnicas de criptografia de alta segurança. | Proteger as informações sobre senhas de contas no novo controlador de domínio. | O utilitário de chave do sistema
Forçar todos os usuários do domínio a usar senhas de alta segurança. | Evitar o acesso não autorizado à organização. | Senhas de alta segurança
Ativar a diretiva de auditoria. | Receber notificação de ações que podem configurar um risco de segurança. | Diretiva de auditoria
Aplicar bloqueios de conta em contas de usuários. | Reduzir a possibilidade de um invasor comprometer seu domínio depois de repetidas tentativas de logon. | Contas de usuário e de computador
Aplicar o histórico de senha em contas de usuários. | Reduzir a possibilidade de um invasor comprometer seu domínio. | Aplicar histórico de senhas
Aplicar duração de senha máxima e mínima em contas de usuários. | Reduzir a possibilidade de um invasor comprometer seu domínio. | Duração mínima da senha; Duração máxima da senha.
Implementar a filtragem SID. | Impedir ataques de usuários maliciosos que podem tentar conceder direitos de usuário elevados a outra conta de computador. | "Using Security Identifier (SID) Filtering to Prevent Elevation of Privilege Attacks" (em inglês) no site da Microsoft.(http://www.microsoft.com/)
Implementar cartões inteligentes | Fornecer autenticação de usuário e segurança de e-mail resistente ao uso. | Visão geral sobre cartões inteligentes
Restringir o acesso do usuário, grupo e computador aos recursos compartilhados e filtrar as configurações de diretiva de grupo. | Proteger os recursos. | Grupos de segurança
Atribuir direitos de usuário a novos grupos de segurança. | Definir especificamente a função administrativa dos membros do domínio. | Direitos de usuário atribuídos a grupos de segurança no Active Directory

Criando um controlador de domínio para uma nova árvore de domínio

Crie um controlador de domínio para uma nova árvore de domínio quando quiser criar um domínio que possua um espaço para nome DNS sem relação com os outros domínios da floresta. Isso significa que o nome do domínio raiz da árvore (e todos os seus filhos) não precisam conter o nome completo do domínio pai. Uma floresta pode conter uma ou mais árvores de domínio. Por exemplo, conforme ilustrado abaixo, msn.com é uma nova árvore de domínio da floresta microsoft.com.

Uma árvore de domínio é usada para formar um espaço para nome não-contíguo na floresta.

Este tópico explica o procedimento básico para configurar um controlador de domínio para uma nova árvore de domínio em sua organização.

Este processo envolve o uso do Assistente para configurar o servidor e do Assistente para instalação do Active Directory para instalar o Active Directory no servidor. Quando terminar de configurar o controlador de domínio, você pode concluir as tarefas de configuração adicionais.

Este tópico aborda o seguinte:

Antes de começar

Configurando o controlador de domínio

Próximas etapas: Concluindo tarefas adicionais

Antes de começar

Antes de configurar o servidor como um controlador de domínio, verifique se:

  • As configurações de TCP/IP do servidor estão corretas, principalmente as usadas para a resolução de nomes de DNS. Para obter mais informações, consulte Configurar o TCP/IP para usar o DNS.
  • Todos os volumes de disco existentes usam o sistema de arquivos NTFS. O Active Directory requer pelo menos um volume NTFS para armazenar a pasta SYSVOL e seu conteúdo. Volumes FAT32 não são protegidos e não oferecem suporte à compactação de arquivos e pastas, a cotas de disco, à criptografia de arquivos ou a permissões de arquivo individuais.

A tabela a seguir lista as informações que você precisa saber antes de adicionar o controlador de domínio.

Antes de adicionar uma função de controlador de domínio | Comentários
Verifique se a velocidade da rede é adequada ao instalar o Active Directory. | O servidor no qual você deseja instalar o Active Directory deve ter acesso à rede através de uma conexão de alta velocidade.
Determine se você deseja que o novo controlador de domínio hospede um catálogo global. | Um catálogo global armazena uma cópia dos objetos do Active Directory em uma floresta em um controlador de domínio. O catálogo global armazena uma cópia completa de todos os objetos no diretório para seu domínio host e uma cópia parcial de todos os objetos para todos os outros domínios na floresta. Para otimizar o desempenho da rede em um ambiente de vários sites, considere adicionar catálogos globais para selecionar sites. Em um ambiente de um único site, um único catálogo global normalmente é suficiente para cobrir consultas comuns do Active Directory. No entanto, em um ambiente de vários sites, é recomendável que você use catálogos globais em cada site. Para obter mais informações sobre quando adicionar catálogos globais em um ambiente de vários sites, consulte Catálogos e sites globais.
Obtenha as credenciais administrativas necessárias para adicionar uma nova árvore de domínio. | Para criar uma nova árvore de domínio, você deve ser membro do grupo Admins. do domínio (no domínio raiz da floresta) ou do grupo Administradores da empresa no Active Directory ou deve ter recebido a autoridade apropriada por delegação.

Configurando o controlador de domínio

Para configurar um controlador de domínio, inicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Controlador de domínio (Active Directory) e, em seguida, clique em Avançar.

Esta seção descreve cada uma das etapas deste processo e indica as opções e decisões necessárias que você fará quando configurar o controlador de domínio. As seções a seguir abordam estas etapas da configuração:

Resumo das seleções

Usando o Assistente para instalação do Active Directory

Concluindo o Assistente para configurar o servidor

Removendo a função do controlador de domínio

Resumo das seleções

Na página Resumo das seleções do Assistente para configurar o servidor, você pode exibir e confirmar as opções selecionadas. Se você selecionou Controlador de domínio (Active Directory) na página anterior, aparecerá o seguinte:

  • Execute o 'Assistente para instalação do Active Directory' para configurar este servidor como um controlador de domínio

Para aplicar as seleções mostradas na página Resumo das seleções, clique em Avançar.

Usando o Assistente para instalação do Active Directory

Depois que você clicar em Avançar, o Assistente para instalação do Active Directory é iniciado automaticamente. Se esta for a primeira vez que você instala o Active Directory em um servidor, clique em Ajuda do Active Directory para obter mais informações.

Depois de ler as informações sobre o Active Directory, clique em Avançar. Você pode retornar a esta página de qualquer local do assistente até clicar no botão Concluir na última página. Na página Compatibilidade de sistema operacional, leia as informações e, em seguida, clique em Avançar. Se esta é a primeira vez que você instala o Active Directory em um servidor que executa o Windows Server 2003, clique em Ajuda sobre Compatibilidade para obter mais informações.

Esta seção descreve as seguintes etapas do Assistente para instalação do Active Directory:

Tipo do controlador de domínio

Criar novo domínio

Credenciais de rede

Nova árvore de domínio

Nome de domínio NetBIOS

Pastas do banco de dados e do log

Volume de sistemas compartilhados

Diagnósticos de registro do DNS

Permissões

Senha do administrador do modo de restauração dos serviços de diretório

Resumo

Tipo do controlador de domínio

Na página Tipo do controlador de domínio, clique em Controlador de domínio para um novo domínio.

Quando terminar, clique em Avançar.

Criar novo domínio

Na página Criar novo domínio, clique em Árvore de domínio em uma floresta existente.

Quando terminar, clique em Avançar.

Credenciais de rede

Na página Credenciais de rede, digite o nome de usuário, a senha e o domínio da conta de usuário que você deseja utilizar.

Opção | Comentários
Nome de usuário | Digite o nome de uma conta de usuário que possui as credenciais administrativas necessárias. A conta de usuário deve ser membro do grupo Admins. do domínio (no domínio raiz da floresta), ou membro do grupo Administração de empresa, ou ter recebido delegação da autoridade adequada.
Senha | Digite a senha da conta de usuário. A senha deve ser de alta segurança. Para obter mais informações, consulte Senhas de alta segurança.
Domínio | Digite o nome DNS completo do domínio no qual este nome de usuário e senha são válidos.

Nova árvore de domínio

Na página Novo nome de domínio, digite o nome DNS completo da nova árvore de domínio. Forneça um nome DNS completo para a nova árvore de domínio que você deseja criar. Os domínios do Active Directory são chamados por nomes DNS e seguem a mesma estrutura hierárquica do DNS.

Seguindo os padrões do DNS, os nomes de domínio são nomes totalmente qualificados (FQDN), que consistem no nome do domínio anexado aos nomes dos domínios pai e domínios raiz usando o formato de caracteres ponto (.). Não é recomendável usar um único nome DNS de rótulo para um nome de domínio do Active Directory. Um único nome DNS de rótulo é um nome sem um nome de domínio pai ou de raiz.

Quando terminar, clique em Avançar.

Nome de domínio NetBIOS

Na página Nome de Domínio NetBIOS, verifique o nome NetBIOS. Embora os domínios do Active Directory sejam nomeados de acordo com padrões de nomeação do DNS, ainda será necessário definir um nome NetBIOS quando você criar domínios do Active Directory. Sempre que possível, os nomes NetBIOS devem corresponder à primeira label do nome de domínio DNS. Quando o domínio do Active Directory possui um nome DNS de primeira label diferente do seu nome NetBIOS, o FQDN é criado usando o nome de domínio DNS, e não o nome NetBIOS. Por exemplo, se o primeiro rótulo do nome de domínio DNS for "filho" (filho.microsoft.com é o nome FQDN) e o nome de domínio NetBIOS for "vendas", o nome FQDN permanecerá "filho.microsoft.com".

Quando terminar, clique em Avançar.

Pastas do banco de dados e do log

Na página Pastas do banco de dados e log, digite o local no qual você deseja instalar as pastas do banco de dados ou do log, ou clique em Procurar para escolher um local. Para evitar problemas ao instalar ou remover o Active Directory, é importante confirmar que você possui espaço em disco suficiente para hospedar o banco de dados e os arquivos de log do diretório. O Assistente para instalação do Active Directory requer 250 megabytes (MB) de espaço em disco para o banco de dados e 50 MB para os arquivos de log. É recomendável que você armazene esses arquivos em uma partição NTFS.

Quando terminar, clique em Avançar.

Volume de sistemas compartilhados

Na página Volume de sistema compartilhado, digite o local no qual você deseja instalar a pasta Sysvol ou clique em Procurar para escolher um local. A pasta Sysvol deve ser armazenada em um volume NTFS, pois contém arquivos que são duplicados entre controladores de domínio de um domínio ou floresta. Esses arquivos incluem scripts, diretivas do sistema Windows NT 4.0 e anteriores, os compartilhamentos NETLOGON e SYSVOL e as configurações de diretiva de grupo.

Quando terminar, clique em Avançar.

Diagnóstico de registro deo DNS

Na página Diagnóstico de registro de DNS, verifique se as configurações do DNS estão corretas.

Se aparecer um erro de diagnóstico em Resultados de diagnóstico, clique em Ajuda para obter mais informações sobre como solucioná-lo

Quando terminar, clique em Avançar.

Permissões

Na página Permissões, clique no nível de compatibilidade do aplicativo desejada com as versões anteriores dos sistemas operacionais do servidor anteriores ao Windows 2000, Windows 2000 ou Windows Server 2003.

Em servidores que executam o Windows NT 4.0 e versões anteriores, o acesso de leitura para as informações sobre o usuário e os grupos é atribuído a usuários anônimos de forma que os aplicativos existentes, incluindo o Microsoft BackOffice, o SQL Server e alguns aplicativos não-Microsoft funcionem corretamente. No Windows 2000 e na família Windows Server 2003, os membros do grupo Logon anônimo têm acesso de leitura a essas informações somente quando o grupo é adicionado ao grupo de Acesso compatível com versões anteriores ao Windows 2000.

Opção | Comentários
Permissões compatíveis com os sistemas operacionais anteriores ao Windows 2000 | Clique nesta opção se desejar que o grupo Logon anônimo e os grupos de segurança Todos sejam adicionados ao grupo Acesso compatível com versões anteriores ao Windows 2000.
Permissões compatíveis somente com os sistemas operacionais Windows 2000 ou Windows Server 2003 | Clique nesta opção para impedir que membros do grupo Logon anônimo tenham acesso de leitura às informações de usuários e de grupos.

Depois que você selecionar uma dessas opções, pode alternar manualmente entre as configurações com versões anteriores e as configurações de alta segurança nos objetos do Active Directory. Para isso, abra Usuários e computadores do Active Directory e adicione o grupo de segurança Logon anônimo ao grupo de segurança Acesso compatível de versões anteriores do Windows 2000.

Senha do administrador do modo de restauração dos serviços de diretório

Na página Senha do administrador do modo de restauração dos serviços de diretório, digite e confirme a senha que você deseja atribuir à conta do Administrador do modo de restauração para o servidor. Use senhas de alta segurança no modo de restauração de diretório. Para obter mais informações, consulte Senhas de alta segurança.

Importante

  • Você deve lembrar a senha para poder restaurar uma cópia de backup do Estado do sistema para este controlador de domínio.

Use esta senha quando o controlador de domínio iniciar no Modo de restauração dos serviços de diretório. Se esta for a primeira vez que você instala o Active Directory em um servidor, clique em Ajuda do Active Directory para obter mais informações sobre a senha do modo de restauração.

Quando terminar, clique em Avançar.

Resumo

Examine a página Resumo e clique em Avançar para iniciar a instalação.

Ao concluir a instalação, clique em Concluir. Para reiniciar o computador e implementar as alterações, clique em Reiniciar agora.

Concluindo o Assistente para configurar o servidor

Após a reinicialização do servidor, o Assistente para configurar o servidor exibe a página Este servidor agora é um controlador de domínio. Para rever todas as alterações feitas no servidor pelo Assistente para configurar o servidor ou certificar-se que uma nova função foi instalada com sucesso, clique em Log de Configuração do servidor. O log Assistente para configurar o servidor localiza-se em systemroot\Debug\Configure Your Server.log. Para fechar o Assistente para configurar o servidor, clique em Concluir.

Removendo a função do controlador de domínio

Se for necessário reconfigurar seu servidor para uma outra função, você poderá remover funções existentes do servidor. Removendo a função do controlador de domínio, você desinstalará o Active Directory deste servidor. Após a desinstalação do Active Directory, este servidor não participará mais da duplicação de objetos do diretório e das solicitações de autenticação de usuário com base no domínio.

Para remover a função de controlador de domínio, reinicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Controlador de domínio (Active Directory) e, em seguida, clique em Avançar. Na página Confirmação de remoção de função, reveja os itens listados em Resumo, marque a caixa Remover a função de controlador de domínio e clique em Avançar. Depois, siga o procedimento do Assistente para instalação do Active Directory.

Próximas etapas: Concluindo tarefas adicionais

Depois que você concluir o Assistente para instalação do Active Directory, o servidor é configurado como um controlador de domínio. Você pode usá-lo para armazenar dados, gerenciar objetos e fornecer informações aos usuários, computadores e aplicativos. Até este ponto, você criou um novo domínio ou um controlador de domínio adicional de um domínio existente.

A tabela a seguir lista algumas tarefas adicionais que você pode executar no controlador de domínio.

Tarefa | Objetivo da tarefa | Referência
Proteger o novo controlador de domínio em um sala trancada. | Assegurar que ninguém acesse fisicamente o controlador de domínio. | Controladores de domínio; Protegendo o Active Directory
Usar técnicas de criptografia de alta segurança. | Proteger as informações sobre senhas de contas no novo controlador de domínio. | O utilitário de chave do sistema
Forçar todos os usuários do domínio a usar senhas de alta segurança. | Evitar o acesso não autorizado à organização. | Senhas de alta segurança
Ativar a diretiva de auditoria. | Receber notificação de ações que podem configurar um risco de segurança. | Diretiva de auditoria
Aplicar bloqueios de conta em contas de usuários. | Reduzir a possibilidade de um invasor comprometer seu domínio depois de repetidas tentativas de logon. | Contas de usuário e de computador
Aplicar o histórico de senha em contas de usuários. | Reduzir a possibilidade de um invasor comprometer seu domínio. | Aplicar histórico de senhas
Aplicar duração de senha máxima e mínima em contas de usuários. | Reduzir a possibilidade de um invasor comprometer seu domínio. | Duração mínima da senha; Duração máxima da senha.
Implementar a filtragem SID. | Impedir ataques de usuários maliciosos que podem tentar conceder direitos de usuário elevados a outra conta de computador. | "Using Security Identifier (SID) Filtering to Prevent Elevation of Privilege Attacks" (em inglês) no site da Microsoft.(http://www.microsoft.com/)
Implementar cartões inteligentes | Fornecer autenticação de usuário e segurança de e-mail resistente ao uso. | Visão geral sobre cartões inteligentes
Restringir o acesso do usuário, grupo e computador aos recursos compartilhados e filtrar as configurações de diretiva de grupo. | Proteger os recursos. | Grupos de segurança
Atribuir direitos de usuário a novos grupos de segurança. | Definir especificamente a função administrativa dos membros do domínio. | Direitos de usuário atribuídos a grupos de segurança no Active Directory


Função do servidor DNS: Configurando um servidor DNS

Os servidores de serviço de nomes de domínio (DNS) abrigam registros de um banco de dados DNS distribuído e usam os registros que abrigam para resolver consultas de nomes DNS enviadas por computadores clientes DNS, como consultas sobre nomes de sites da Web ou de computadores da rede ou da Internet. Se você planeja usar o computador para responder às consultas DNS de computadores da rede, adicione a função servidor DNS.

Este tópico explica o procedimento básico para configurar um servidor DNS tanto para uma organização de pequeno porte como para a filial de uma grande empresa. Em ambos os casos, este tópico explica o procedimento básico para definir um servidor DNS e configurá-lo a uma zona DNS da rede. O tópico também abordará o encaminhamento de consultas de recursos externos para um servidor DNS executado por um provedor de serviços de Internet, como no caso de uma pequena empresa, ou pela sede de uma grande organização, como no caso de uma filial.

Este processo envolve o uso do Assistente para configurar o servidor, do Assistente para configurar novo servidor DNS e de Gerenciar o servidor para configurar o servidor como DNS. Depois de configurar um servidor DNS, você pode executar outras tarefas de configuração, dependendo de como você deseja usar o servidor DNS.

Observação

  • Geralmente, o servidor DNS não é essencial em uma pequena organização, já que é usado o método de resolução de nome serviço de cadastramento na Internet do Windows (WINS) para localizar recursos da rede. Os recursos da Internet são localizados com os servidores DNS executados por um provedor de serviços de Internet. No entanto, à medida que mais redes são integradas à Internet, o DNS torna-se mais comum em redes de pequeno porte.

    O uso do DNS na rede não requer necessariamente que você administre uma infra-estrutura DNS. Se você possui uma rede pequena na qual as informações são mantidas de forma dependente, você pode optar por ter o espaço para nome DNS administrado por uma organização diferente, especializada nesse assunto, como a administração pública ou um provedor de serviços de Internet. Nesse caso, a outra organização hospedará e administrará as informações DNS para você ou integrará seus computadores com um servidor DNS existente hospedado na rede da organização.

Este tópico aborda o seguinte:

Antes de começar

Configurando o servidor DNS

Próximas etapas: Concluindo tarefas adicionais

Antes de começar

Antes de configurar o computador como um servidor DNS, verifique se:

  • O sistema operacional está configurado corretamente. Na família Windows Server 2003, o serviço Servidor DNS depende da configuração adequada do sistema operacional e seus serviços, como TCP/IP. Se houver uma nova instalação de um sistema operacional Windows Server 2003, você poderá usar as configurações padrão do serviço. Nenhuma outra ação é necessária. Se você fez uma atualização para um sistema operacional Windows Server 2003 ou se deseja confirmar se os serviços estão configurados corretamente para obter melhor desempenho e segurança, consulte Configurações padrão de serviços.
  • Todo o espaço em disco disponível é alocado. Você pode usar o Gerenciamento de disco ou DiskPart.exe para criar uma nova partição de um espaço não alocado. Para obter mais informações, consulte Criar uma partição ou unidade lógica.
  • Todos os volumes de disco existentes usam sistema de arquivos NTFS. Os volumes FAT32 não são protegidos e não oferecem suporte à compactação de arquivos e pastas, a cotas de disco, à criptografia de arquivos ou a permissões de arquivo individuais.

A tabela a seguir lista as informações que você precisa saber antes de adicionar a função do servidor DNS.

Para todas as organizações
Antes de adicionar a função do servidor DNS | Comentários
Determine se você está adicionando a função do servidor DNS para oferecer suporte ao Active Directory. | Se você for implantar o Active Directory, os servidores DNS usados para oferecer-lhe suporte serão instalados e configurados automaticamente pelo Assistente para instalação do Active Directory. Para obter mais informações, consulte Instalação típica de um primeiro servidor e Função de controlador de domínio: Configurando o controlador de domínio.
Faça um inventário das diretivas de segurança da rede e da empresa para ver como elas podem ser mantidas durante a transmissão de dados DNS pela Internet. | O DNS foi originalmente criado como um protocolo aberto e, portanto, é vulnerável a ataques. O DNS Windows Server 2003 fornece recursos para uma infra-estrutura de DNS bastante segura. Para configurar o DNS de forma que ele ofereça suporte às diretivas de segurança, disponibilize as diretivas de segurança de sua empresa ao criar e implantar o servidor, as zonas e os registros de recursos DNS. Para obter mais informações, consulte Informações de segurança do DNS.
Reveja a lista de verificação DNS. | Releia as informações da Lista de verificação: instalando um servidor DNS.
Para uma organização pequena
Antes de adicionar a função do servidor DNS | Comentários
Escolha o primeiro nome de domínio DNS para a empresa. | Escolher o primeiro nome de domínio DNS para a empresa envolve selecionar um nome de domínio exclusivo dentro do espaço para nome DNS da Internet. Se sua organização possui um site na Web, use o nome do site como ponto de partida para o nome de domínio DNS. Se o site se chamar www.humongousinsurance.com, crie o primeiro nome de domínio como uma extensão desse nome, usando o nome de subdomínio corp, por exemplo, corp.humongousinsurance.com.
Verifique com o provedor de serviços de Internet para determinar se os endereços do Protocolo Internet (IP) da rede estão registrados com um registro de Internet. | Para que a implantação do DNS funcione na Internet, os endereços IP e o nome de domínio DNS usados pela rede devem ser registrados por um registro Internet autorizado. Essas organizações são responsáveis por atribuir endereços IP e nomes de domínio DNS, devendo manter registros públicos de tais atribuições. Se você possuir conexão com a Internet, provavelmente a rede de sua empresa é uma sub-rede da rede do seu provedor de serviços. Nesse caso, os endereços IP da sub-rede terão sido registrados com o registro de Internet.
Registre o nome do domínio DNS em um registro de Internet. | Registre o nome de domínio DNS que você usará para a empresa mesmo que você esteja implementando o DNS em uma rede privada. Se você não registrar o nome e, posteriormente, tentar usá-lo na Internet, ou se conectar a uma rede conectada à Internet, poderá descobrir que o nome não está disponível porque alguma outra empresa o registrou. Você também pode pedir ao provedor de serviços de Internet para registrar o nome de domínio DNS para você. Ao decidir sobre o nome de domínio DNS, faça uma busca na Internet para verificar os nomes de domínio disponíveis usando um dos sites fornecidos pela autoridade de registro de Internet autorizada. Para buscar na Internet os nomes de domínio disponíveis, consulte o site Internet Network Information Center (InterNIC). XOX
Lembre-se que o nome da primeira zona DNS que este servidor DNS hospedará é o mesmo nome de domínio DNS que você registrou. | Quando você configurar a função de servidor DNS, definirá a primeira zona DNS que este servidor DNS hospedará usando o nome do domínio DNS da sua rede, como corp.humongousinsurance.com.
Obtenha o endereço IP de um ou mais servidores DNS hospedados pelo seu provedor de serviços de Internet para usá-los como um encaminhador. | Você configurará o servidor DNS com um encaminhador para enviar consultas de nomes que não estão na rede para um servidor DNS do provedor de serviços de Internet.
Para uma filial de uma grande organização
Antes de adicionar a função do servidor DNS | Comentários
Obtenha o nome de domínio DNS da rede na sede da empresa. | O primeiro nome de domínio DNS para sua filial é um subdomínio de um domínio usado na rede da sede. Por exemplo, se a sede usa o nome de domínio corp.humongousinsurance.com, o nome de domínio DNS da sua filial poderia ser seattle.corp.humongousinsurance.com. Assegure-se de que o nome de domínio DNS seja sempre adequadamente delegado pela sede.

Configurando o servidor DNS

Para configurar o servidor DNS, inicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • Para abrir o Assistente para configurar o servidor, clique em Iniciar, aponte para Todos os programas, para Ferramentas administrativas e clique no Assistente para configurar o servidor.

Na página Função do servidor, clique em Servidor DNS e, em seguida, clique em Avançar.

Esta seção aborda os seguintes tópicos:

Resumo das seleções

Configurando um endereço IP do servidor DNS estático

Usando o Assistente para configuração de servidor DNS

Concluindo o Assistente para configurar o servidor

Removendo a função do servidor DNS

Resumo das seleções

Na página Resumo das seleções, examine e confirme as opções que você selecionou. Se você selecionou Servidor DNS na página Função do servidor, aparecerá o seguinte:

  • Instalar servidor DNS
  • Execute o 'Assistente para configuração de servidor DNS' para configurar o DNS

Se a página Resumo das seleções listar esses dois itens, clique em Avançar. Se a página Resumo das seleções não listar esses itens, clique em Voltar para retornar à página Função do servidor, clique em Servidor DNS e, em seguida, em Avançar.

Configurando um endereço IP do servidor DNS estático

Depois que você clicar em Avançar, o Assistente para configurar o servidor instalará o serviço Servidor DNS. Durante a instalação do serviço Servidor DNS, o Assistente para configurar o servidor determina se o endereço IP do servidor é estático ou se foi configurado automaticamente. Os servidores DNS são localizados por clientes DNS, que usam endereços IP estáticos. Um endereço IP configurado automaticamente, quando alterado, pode causar problemas aos clientes DNS.

Se o servidor estiver atualmente configurado para obter seu endereço IP automaticamente, a página Configurando componentes do Assistente de componentes do Windows aparecerá pedindo que você configure o servidor com um endereço IP estático. Na caixa de diálogo Propriedades de conexão de rede local, clique em Protocolo Internet (TCP/IP) e, em seguida, clique em Propriedades. Na caixa de diálogo Propriedades do Internet Protocols (TCP/IP), clique em Usar o seguinte endereço IP e digite o endereço IP estático, a máscara de sub-rede e o gateway padrão do servidor. Em Servidor DNS preferencial, digite o endereço IP do servidor. Em Servidor DNS alternativo, digite o endereço IP do servidor DNS hospedado pelo provedor de serviços de Internet ou pela sede da empresa. Quando você terminar de configurar os endereços estáticos do servidor DNS, clique em OK e, em seguida, em Fechar.

Observações

  • Em organizações pequenas, o endereço IP deste servidor será usado para registrar o nome de domínio DNS da empresa em um registro de Internet autorizado. O registro de Internet mapeará o nome de domínio DNS para a sua empresa com o endereço IP, de forma que os computadores da Internet que buscarem computadores da sua rede saberão o endereço IP do servidor DNS de sua rede.
  • Em filiais de empresas, o endereço IP estático deste servidor será utilizado na delegação de nome de domínio configurada em um servidor DNS na sede da organização. Os computadores da empresa e da Internet que buscarem computadores na empresa utilizarão o endereço IP do servidor DNS da rede da empresa. Por isso, é muito importante que você não altere o endereço IP deste servidor depois de adicionar a função de servidor DNS.

Usando o Assistente para configuração de servidor DNS

Depois que você clica em Fechar, o Assistente para configuração de servidor DNS é iniciado. Se você cancelar o Assistente para configuração de servidor DNS, o serviço Servidor DNS permanecerá instalado, mas não poderá distribuir endereços IP aos clientes até que você crie um escopo. Se você optar por criar o escopo posteriormente, poderá fazer isso usando o console DNS.

Esta seção descreve as seguintes etapas do Assistente para configuração de servidor DNS:

Selecionar ação de configuração

Local do servidor primário

Nome da zona

Atualização dinâmica

Encaminhadores

Concluindo o Assistente para configuração de servidor DNS

Selecionar ação de configuração

Na página Selecionar ação de configuração, selecione Criar uma zona de pesquisa direta e clique em Avançar.

Local do servidor primário

Para especificar que este servidor DNS hospedará uma zona DNS que contém registros de recursos DNS para os recursos de rede, na página Local do servidor primário, selecione Este servidor mantém a zona e clique em Avançar.

Nome da zona

Na página Nome da zona, em Nome da zona, especifique o nome da zona DNS da rede e clique em Avançar. O nome da zona é igual ao nome do domínio DNS da empresa pequena ou filial.

Atualização dinâmica

Na página Atualização dinâmica, clique em Permitir atualizações dinâmicas seguras e não seguras. Isso automatizará a atualização dos registros de recursos DNS para os recursos da rede.

Encaminhadores

Na página Encaminhadores, clique em Sim, encaminhar consultas para servidores DNS com os seguintes endereços IP e, em seguida, clique em Avançar. Selecionando esta configuração, você encaminha todas as consultas por nomes DNS fora da rede a um servidor DNS no provedor de serviços Internet ou à sede da empresa. Digite um ou mais endereços IP usados pelos servidores DNS executados pelo provedor de serviços de Internet ou pela sede da empresa.

Concluindo o Assistente para configuração de servidor DNS

Na página Concluindo o 'Assistente para configuração de servidor DNS' do Assistente para configuração de servidor DNS, você pode clicar em Voltar para alterar as configurações. Para aplicar as seleções, clique em Concluir.

Concluindo o Assistente para configurar o servidor

Depois que você concluir o Assistente para configuração de servidor DNS, o Assistente para configurar o servidor exibirá a página Este servidor agora é um servidor DNS. Para rever todas as alterações feitas no servidor pelo Assistente para configurar o servidor ou certificar-se que uma nova função foi instalada com sucesso, clique em Log de Configuração do servidor. O log Assistente para configurar o servidor localiza-se em systemroot\Debug\Configure Your Server.log. Para fechar o Assistente para configurar o servidor, clique em Concluir.

Removendo a função do servidor DNS

Se for necessário reconfigurar seu servidor para uma outra função, você poderá remover funções existentes do servidor. Se você remover a função de servidor DNS deste servidor, deverá definir as configurações de TCP/IP deste servidor e os clientes que usarem o servidor como DNS, com o endereço IP de um servidor DNS diferente.

Para remover a função de servidor DNS, reinicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Servidor DNS e, em seguida, clique em Avançar. Na página Confirmação de remoção de função, reveja os itens listados em Resumo, marque a caixa Remover a função de servidor DNS e clique em Avançar. Depois que você clica em Avançar, a página Configurando componentes do Assistente de componentes do Windows é exibida e, depois, fechada automaticamente. Você não pode clicar em Voltar ou Avançar nesta página. Na página Função de servidor DNS removida, clique em Concluir.

Próximas etapas: Concluindo tarefas adicionais

Depois que você concluir o Assistente para configurar o servidor e o Assistente para configurar novo servidor DNS, o servidor estará pronto para uso como servidor DNS Até este ponto, você concluiu as seguintes tarefas:

  • Definiu o servidor DNS para usar um endereço IP estático.
  • Configurou a zona DNS para a rede.
  • Configurou o servidor DNS para encaminhar todas as consultas por nomes DNS fora da rede a um servidor DNS no provedor de serviços Internet ou à sede da empresa.

Quando você concluir o Assistente para configurar o servidor, ele automaticamente instalará o console DNS, que você usará para gerenciar o servidor DNS. XOX

A tabela a seguir lista algumas tarefas adicionais que você pode executar no servidor DNS.

Tarefas | Objetivo da tarefa | Referência
Configurar os computadores da rede para usar este servidor DNS como preferencial. | Conectar os clientes DNS ao servidor DNS e atualizar dinamicamente a zona com os registros de recursos DNS necessários para resolução de nomes. | Configurar o TCP/IP para usar DNS; Atualização dinâmica
Se o servidor for um computador com hospedagem múltipla, configure o serviço Servidor DNS para responder às consultas somente no endereço IP da rede local. | Proteger o servidor DNS contra consultas externas. Por exemplo, um servidor agindo como proxy pode ter dois adaptadores de rede: um para a intranet e outro para a Internet. Se esse servidor também estiver executando o serviço Servidor DNS do Windows Server 2003, você poderá configurar o serviço para usar somente o adaptador de rede da intranet. Configurando o servidor para responder somente às consultas no endereço IP da rede local, você protegerá o servidor contra consultas indesejadas vindas da Internet. | Restringir um servidor DNS a ouvir somente em endereços selecionados
Verificar a configuração do servidor. | Assegurar que a configuração DNS definida com o Assistente para configurar novo servidor DNS está correta. | Verificando a configuração do servidor
Verificar a capacidade de resposta do servidor DNS usando o comando nslookup. | Verificar se o servidor DNS pode resolver consultas DNS para recursos da rede. | Verificar a receptividade do servidor DNS usando o comando nslookup
Verificar se um registro de recurso existe no DNS. | Verificar se os computadores que usam o servidor DNS podem ser localizados na rede. | Verificar se existem registros de recurso no DNS


Função do servidor DHCP: Configurando um servidor DHCP

Os servidores DHCP gerenciam centralmente endereços IP e informações afins, fornecendo-as aos clientes. Isso permite que você defina configurações de rede cliente em um servidor, em vez de configurá-las em cada computador clientes. Se você quiser que este computador distribua endereços IP aos clientes, configure-o como um servidor DHCP.

Este tópico explica o procedimento básico para configurar um servidor DHCP. Depois de configurar um servidor DHCP básico, você pode executar outras tarefas de configuração, dependendo de como você deseja usar o servidor DHCP.

Este tópico aborda o seguinte:

Antes de começar

Configurando o servidor DHCP

Próximas etapas: Concluindo tarefas adicionais

Antes de começar

Antes de configurar o computador como um servidor DHCP, verifique se:

  • Você está familiarizado com os conceitos de DHCP, como escopos, concessões e opções. Para obter mais informações, consulte Terminologia de DHCP.
  • O sistema operacional está configurado corretamente. Na família Windows Server 2003, o DHCP depende da configuração adequada do sistema operacional e seus serviços. Se houver uma nova instalação de um sistema operacional Windows Server 2003, você poderá usar as configurações padrão do serviço. Nenhuma outra ação é necessária. Se você fez uma atualização para um sistema operacional Windows Server 2003 ou se deseja confirmar se os serviços estão configurados corretamente para obter melhor desempenho e segurança, verifique as configurações dos serviços usando a tabela em Configurações padrão de serviços.
  • Este computador tem um endereço IP estático. Para obter mais informações, consulte Para configurar o TCP/IP para endereçamento estático.
  • Todos os volumes de disco existentes usam o sistema de arquivos NTFS. Volumes FAT32 não são protegidos e não oferecem suporte à compactação de arquivos e pastas, a cotas de disco, à criptografia de arquivos ou a permissões de arquivo individuais.

Ao adicionar a função do servidor DHCP, você cria um escopo que define o intervalo de endereços IP que o servidor DHCP aloca aos clientes de uma sub-rede. Você deve criar um escopo para cada sub-rede que possua clientes que você deseja gerenciar com DHCP. A tabela a seguir lista as informações que você precisa saber antes de adicionar a função do servidor DHCP, para que você possa criar o primeiro escopo. Você precisa reunir as mesmas informações para cada escopo adicional.

Antes de adicionar uma função do servidor DHCP | Comentários
Reveja questões de segurança do DHCP. | As questões relativas à segurança podem afetar a forma como você implanta os servidores DHCP. Para obter mais informações sobre as recomendações sobre segurança no DHCP, consulte Informações de segurança referentes ao protocolo DHCP.
Identifique o intervalo de endereços IP que o servidor DHCP deve alocar aos clientes. | Use o intervalo inteiro de endereços IP consecutivos que compõem a sub-rede IP local. Em muitos casos, a melhor opção é um intervalo de endereços privados. Para obter mais informações e uma lista de todos os intervalos de endereços IP aprovados para uso em redes privadas, consulte a RFC 1918, "Address Allocation for Private Internets" (em inglês), no site Internet Engineering Task Force. XOX
Determine a máscara de sub-rede correta para os clientes. | Ao conceder um endereço IP a um cliente, o servidor DHCP pode especificar informações adicionais sobre a configuração, incluindo a máscara de sub-rede.
Identifique os endereços IP que o servidor DHCP não deve alocar aos clientes. | Por exemplo, freqüentemente, um servidor ou uma impressora conectada à rede possui um endereço IP estático, e o servidor DHCP não deve oferecer esse endereço IP aos clientes.
Decida a duração da concessão dos endereços IP. | O padrão é oito dias. Geralmente, a duração da concessão deve ser igual ao tempo médio que os clientes desta sub-rede permanecem ativos. Por exemplo, a duração ideal pode ser superior a oito dias se os clientes forem computadores desktop que raramente são ligados, ou pode ser inferior a esse período se os clientes forem dispositivos móveis que freqüentemente saem da rede ou são movimentados entre sub-redes.
(Opcional) Identifique o endereço IP do roteador (gateway padrão) que os clientes devem usar para se comunicar com os clientes de outras sub-redes. | Ao conceder um endereço IP a um cliente, o servidor DHCP pode especificar informações adicionais sobre a configuração, incluindo o endereço IP do roteador.
(Opcional) Identifique o nome do domínio DNS dos clientes. | Ao conceder um endereço IP a um cliente, o servidor DHCP pode especificar informações adicionais sobre a configuração, incluindo o nome do domínio DNS ao qual pertencem os clientes.
(Opcional) Identifique o endereço IP do servidor DNS que os clientes devem utilizar. | Ao conceder um endereço IP a um cliente, o servidor DHCP pode especificar informações adicionais sobre a configuração, incluindo o endereço IP do servidor DNS que os clientes devem contatar para resolver o nome de outro computador.
(Opcional) Identifique o endereço IP do servidor WINS que os clientes devem utilizar. | Ao conceder um endereço IP a um cliente, o servidor DHCP pode especificar informações adicionais sobre a configuração, incluindo o endereço IP do servidor WINS que os clientes devem contatar para resolver o nome de outro computador.

Configurando o servidor DHCP

Para configurar o servidor DHCP, inicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Servidor DHCP e, em seguida, clique em Avançar.

Esta seção aborda os seguintes tópicos:

Resumo das seleções

Usando o Assistente para novos escopos

Concluindo o Assistente para configurar o servidor

Removendo a função do servidor DHCP

Resumo das seleções

Na página Resumo das seleções, examine e confirme as opções que você selecionou. Se você selecionou Servidor DHCP na página anterior, aparecerá o seguinte:

  • Instalar servidor DHCP
  • Execute o 'Assistente de novo escopo' para configurar um novo escopo de DHCP

Para aplicar as seleções mostradas na página Resumo das seleções, clique em Avançar. Depois que você clica em Avançar, a página Configurando componentes do Assistente de componentes do Windows é exibida e, depois, fechada automaticamente. Você não pode clicar em Voltar ou Avançar nesta página.

Usando o Assistente para novos escopos

Depois que você clica em Avançar, o Assistente para configurar o servidor instala o serviço Servidor DHCP e inicia o Assistente para novos escopos para reunir informações e adicionar a função de servidor DHCP. Se você cancelar o Assistente para novos escopos, o serviço Servidor DHCP permanecerá instalado, mas não poderá distribuir endereços IP aos clientes até que você crie um escopo. Se você optar por criar o escopo posteriormente, poderá fazer isso usando o console DHCP.

Esta seção descreve as seguintes etapas do Assistente para novos escopos:

Nome do escopo

Intervalo de endereços IP

Adicionar exclusões

Duração da concessão

Configurar opções de DHCP

Roteador (gateway padrão)

Servidores de nomes de domínio e DNS

Servidores WINS

Ativar escopo

Concluindo o Assistente para novos escopos

Nome do escopo

Na caixa de diálogo Nome do escopo, digite um nome para o escopo na caixa Nome. Em Descrição, digite uma descrição (opcional). A maioria das redes possui várias sub-redes, e cada uma destas requer seu próprio escopo. Assim, o servidor DHCP geralmente administra vários escopos. Escolha um nome e uma descrição que ajudarão a diferenciar os vários escopos.

Quando terminar, clique em Avançar.

Intervalo de endereços IP

Na página Intervalo de endereços IP, defina o intervalo de endereços IP deste escopo digitando-os no início e no final do intervalo. O assistente utiliza os endereços IP informados para determinar a máscara de sub-rede correta. A máscara de sub-rede correta aparece automaticamente em Máscara de sub-rede.

No caso incomum de os clientes desta sub-rede precisarem usar uma máscara de sub-rede diferente daquela fornecida pelo assistente, você deverá digitá-la em Máscara de sub-rede ou inserir número de bits dessa máscara no campo Comprimento.

Quando terminar, clique em Avançar.

Adicionar exclusões

Na página Adicionar exclusões, você pode definir os endereços IP que o servidor DHCP não deve alocar aos clientes. Por exemplo, o próprio servidor DHCP possui um endereço IP estático que não deve ser alocado aos clientes. O mesmo acontece com o gateway padrão e com vários dispositivos de rede, como impressoras conectadas em rede. Exclua esses endereços IP, de forma que o servidor DHCP não os aloque aos clientes.

Recomendamos que você exclua mais endereços IP do que precisa, já que é mais fácil truncar um intervalo de exclusão do que expandi-lo. Exclua os endereços IP do início ou do final do intervalo de possíveis endereços IP, e não da parte intermediária. Por exemplo, se o intervalo de endereços IP desta sub-rede vai de 10.0.0.1 a 10.0.0.255, e você deseja excluir dez endereços IP, defina o intervalo de exclusão de uma das seguintes formas:

  • 10.0.0.1 a 10.0.0.10
  • 10.0.0.245 a 10.0.0.255

Para cada intervalo de endereços IP que você deseja excluir, digite o endereço IP no início do intervalo em Endereço IP inicial, digite o endereço IP no final do intervalo em Endereço IP final e clique em Adicionar.

Esta etapa facilita a administração do cliente, mas é opcional. Se você deixar todos os campos desta página em branco e clicar em Avançar, os clientes serão capazes de obter endereços IP do servidor DHCP.

Quando terminar, clique em Avançar.

Duração da concessão

Na página Duração da concessão, você pode definir o período durante o qual o cliente pode usar o endereço IP deste escopo.

O servidor DHCP concede endereços IP aos seus clientes. Cada concessão possui uma data e horário de validade. O cliente deve renovar a concessão se quiser continuar a usar o endereço IP. O padrão da duração de concessão é de oito dias.

Esta etapa facilita a administração do cliente, mas é opcional. Se você deixar todos os campos desta página em branco e clicar em Avançar, os clientes serão capazes de obter endereços IP do servidor DHCP.

Quando terminar, clique em Avançar.

Configurar opções de DHCP

Na página Configurar opções de DHCP, você pode especificar se deseja configurar as opções de DHCP.

Recomendamos que você aceite o padrão, Sim, desejo configurar essas opções agora e clique em Avançar, ainda que não queira configurar as opções. Se você escolher Não, configurarei essas opções mais tarde, ocorrerá o seguinte:

  • O Assistente para novos escopos cria o escopo mas não o ativa. Você deve usar o console DHCP para ativar o escopo para que os clientes recebam endereços IP desse escopo. Para obter informações sobre como ativar um escopo usando o console DHCP, consulte Ativar um escopo.
  • Você não verá as próximas quatro páginas do assistente descritas abaixo. Concluindo lendo Concluindo o Assistente para novos escopos.

Roteador (gateway padrão)

Na página Roteador (gateway padrão), você pode especificar os roteadores (também conhecidos como gateways padrão) que os clientes deverão usar. É possível adicionar um número de endereços IP igual ao número de roteadores desta sub-rede.

Esta etapa facilita a administração do cliente, mas é opcional. Se você deixar todos os campos desta página em branco e clicar em Avançar, os clientes serão capazes de obter endereços IP do servidor DHCP.

Quando terminar, clique em Avançar.

Servidores de nomes de domínio e DNS

Na página Servidor de nomes de domínio e DNS, você pode especificar o nome do domínio que os clientes desta sub-rede devem usar quando resolverem nomes DNS.

Você também pode especificar o servidor DNS que os clientes devem usar para resolver nomes DNS. Você pode digitar o endereço IP desse servidor DNS ou digitar o nome dele e clicar em Resolver. Dessa forma, o assistente determinará o endereço IP para você. É possível adicionar vários servidores DNS.

Esta etapa facilita a administração do cliente, mas é opcional. Se você deixar todos os campos desta página em branco e clicar em Avançar, os clientes serão capazes de obter endereços IP do servidor DHCP.

Quando terminar, clique em Avançar.

Servidores WINS

Na página Servidores WINS, você pode especificar o servidor WINS com os quais os clientes devem se comunicar para registrar e resolver nomes NetBIOS. Você pode digitar o endereço IP desse servidor WINS ou digitar o nome dele e clicar em Resolver. Dessa forma, o assistente determinará o endereço IP para você. É possível adicionar vários servidores WINS.

Esta etapa facilita a administração do cliente, mas é opcional. Se você deixar todos os campos desta página em branco e clicar em Avançar, os clientes serão capazes de obter endereços IP do servidor DHCP.

Quando terminar, clique em Avançar.

Ativar escopo

Na página Ativar escopo, você pode ativar o escopo ou optar por fazer isso mais tarde. Na maioria dos casos, você deve aceitar o padrão e ativar o escopo imediatamente. Se você optar por ativar o escopo posteriormente, poderá fazer isso usando o console DHCP. Ative o escopo para permitir que os clientes da sub-rede deste escopo obtenham endereços IP do servidor DHCP.

Quando terminar, clique em Avançar.

Concluindo o Assistente para novos escopos

Na página Concluindo o Assistente de novo escopo, você pode clicar em Voltar e alterar as configurações. Para aplicar as seleções, clique em Concluir.

Concluindo o Assistente para configurar o servidor

Depois que você concluir o Assistente para novos escopos, o Assistente para configurar o servidor exibirá a página Este servidor agora é um servidor DHCP. Para rever todas as alterações feitas no servidor pelo Assistente para configurar o servidor ou certificar-se que uma nova função foi instalada com sucesso, clique em Log de Configuração do servidor. O log Assistente para configurar o servidor localiza-se em systemroot\Debug\Configure Your Server.log. Para fechar o Assistente para configurar o servidor, clique em Concluir.

Removendo a função do servidor DHCP

Se for necessário reconfigurar seu servidor para uma outra função, você poderá remover funções existentes do servidor. Se você remover a função do servidor DHCP, deverá reconfigurar os clientes para obter endereços IP de outro servidor DHCP. Além disso, se você quiser que os clientes continuem usando os endereços IP distribuídos por este servidor, deve configurar outro servidor DHCP para distribuir os endereços.

Para remover a função de servidor DHCP, reinicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Servidor DHCP e, em seguida, clique em Avançar. Na página Confirmação de remoção de função, reveja os itens listados em Resumo, marque a caixa Remover a função de servidor DHCP e clique em Avançar. Depois que você clica em Avançar, a página Configurando componentes do Assistente de componentes do Windows é exibida e, depois, fechada automaticamente. Você não pode clicar em Voltar ou Avançar nesta página. Na página Função de servidor DHCP removida, clique em Concluir.

Próximas etapas: Concluindo tarefas adicionais

Depois que você concluir o Assistente para configurar o servidor, o computador estará pronto para ser usado como um servidor DHCP básico que pode gerenciar endereços IP e informações correlatas. Até este ponto, você instalou o serviço Servidor DHCP e criou um escopo que gerencia endereços IP e informações correlatas para os clientes de uma sub-rede. Se quiser gerenciar clientes em outras sub-redes, você deve criar escopos adicionais. Se você não ativou o escopo, deve fazer isso para permitir que os clientes da sub-rede deste escopo obtenham endereços IP do servidor DHCP.

Quando você concluir o Assistente para configurar o servidor, ele automaticamente instalará o console DHCP, que você usará para gerenciar o servidor DHCP. XOX

A tabela a seguir lista algumas tarefas adicionais que você pode executar no servidor DHCP.

Tarefa | Objetivo da tarefa | Referência
Ativar escopos existentes. | Ativar escopos que você criou com o Assistente para novos escopos e que não estão ativos atualmente. | Ativar um escopo
Autorizar o servidor DHCP no Active Directory. | Detectar servidores DHCP não autorizados e impedir que eles sejam iniciados ou operem na sua rede. | Autorizando servidores DHCP
Adicionar suporte para uma rede roteada. | Ativar o servidor DHCP para agir como um agente de retransmissão, que encaminha mensagens DHCP entre sub-redes. | Configurar o agente de retransmissão DHCP
Atribuir uma opção de escopo baseada em servidor. | Simplificar a administração configurando valores padrão que todos os novos escopos herdarão. | Atribuir uma opção baseada em servidor
Alterar ou exibir propriedades de escopo. | Alterar ou exibir as propriedades de um escopo existente. | Alterar ou exibir propriedades de escopo
Criar novos escopos. | Criar escopos que oferecem suporte a clientes de outras sub-redes. | Criar um novo escopo
Adicionar uma reserva de cliente. | Definir um endereço IP que o servidor DHCP não deve alocar ao cliente porque outro cliente já o está usando de forma permanente. | Adicionar uma reserva de cliente


Função de servidor de fluxo de mídia: Configurando o servidor de fluxo de mídia

Você pode usar o Windows Media Services para disponibilizar o fluxo do conteúdo de áudio e vídeo pela Internet ou por uma intranet. Os clientes podem ser computadores ou dispositivos que reproduzem conteúdo usando um player, como o Windows Media Player, ou computadores que executam o Windows Media Services (chamados de servidores Windows Media) que armazenam em proxy ou em cache ou redistribuem o conteúdo. Os clientes também podem ser aplicativos personalizados desenvolvidos com SDK (kit de desenvolvimento de software) Windows Media Software.

Se você quiser que o computador forneça fluxos de conteúdo de áudio e vídeo aos clientes e a outros servidores Windows Media, configure-o como um servidor de fluxo de mídia.

Observações

  • XOX
  • XOX

Este tópico explica o procedimento básico para configurar um servidor de fluxo de mídia. Depois de concluir as etapas básicas, você pode executar outras tarefas de configuração, dependendo de como deseja usar o servidor de fluxo de mídia.

Este tópico aborda o seguinte:

Antes de começar

Configurando o servidor de fluxo de mídia

Próximas etapas: Concluindo tarefas adicionais

Antes de começar

Antes de configurar o computador como um servidor de fluxo de mídia, verifique se:

  • O sistema operacional está configurado corretamente. Na família Windows Server 2003, o Windows Media Services depende da configuração adequada do sistema operacional e seus serviços. Se houver uma nova instalação de um sistema operacional Windows Server 2003, você poderá usar as configurações padrão do serviço. Nenhuma outra ação é necessária. Se você fez uma atualização para um sistema operacional Windows Server 2003 ou se deseja confirmar se os serviços estão configurados corretamente para obter melhor desempenho e segurança, verifique as configurações dos serviços usando a tabela em Configurações padrão de serviços.
  • Todos os volumes de disco existentes usam o sistema de arquivos NTFS. Volumes FAT32 não são protegidos e não oferecem suporte à compactação de arquivos e pastas, a cotas de disco, à criptografia de arquivos ou a permissões de arquivo individuais.

Configurando o servidor de fluxo de mídia

Para configurar o servidor de fluxo de mídia, inicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Servidor de fluxo de mídia e, em seguida, clique em Avançar.

Esta seção aborda os seguintes tópicos:

Resumo das seleções

Concluindo o Assistente para configurar o servidor

Concluindo a configuração da função do servidor de fluxo de mídia

Removendo a função do servidor de fluxo de mídia

Resumo das seleções

Na página Resumo das seleções, examine e confirme as opções que você selecionou. Se você selecionou Servidor de fluxo de mídia na página Função do servidor, aparecerá o seguinte:

  • Instalar os Serviços de mídia Windows

Para aplicar as seleções mostradas na página Resumo das seleções, clique em Avançar. Depois que você clica em Avançar, a página Configurando componentes do Assistente de componentes do Windows é exibida e, depois, fechada automaticamente. Você não pode clicar em Voltar ou Avançar nesta página.

Depois que você clicar em Avançar na página Resumo das seleções, o Assistente para configurar o servidor instalará o Windows Media Services. Ao contrário de muitos outros serviços, o Windows Media Services é instalado sem qualquer participação do administrador.

Concluindo o Assistente para configurar o servidor

Após a reinicialização do servidor, o Assistente para configurar o servidor exibe a página Este servidor agora é um servidor de fluxo de mídia. Para rever todas as alterações feitas no servidor pelo Assistente para configurar o servidor ou certificar-se que uma nova função foi instalada com sucesso, clique em Log de Configuração do servidor. O log Assistente para configurar o servidor localiza-se em systemroot\Debug\Configure Your Server.log. Para fechar o Assistente para configurar o servidor, clique em Concluir.

Concluindo a configuração da função do servidor de fluxo de mídia

Depois que você concluir o Assistente para configurar o servidor, o computador estará pronto para ser usado como um servidor de fluxo de mídia básico que pode fornecer conteúdo aos clientes e a outros servidores de fluxo de mídia. Geralmente, é necessária uma configuração adicional, cujas etapas dependem dos seus requisitos. Esta seção explica o procedimento básico para configurar um servidor de fluxo de mídia.

Observação

  • Se você instalou o Windows Media Services no computador, poderá exibir a Ajuda desse programa. Para exibir a Ajuda do Windows Media Services, Iniciar, em Executar e digite hh wmserver.chm.

A função do servidor de fluxo de mídia oferece suporte a vários cenários, descritos em detalhes na Ajuda do Windows Media Services. Para obter mais informações, consulte Cenários na Ajuda do Windows Media Services. A maioria dos cenários exige que você reconfigure um ponto de publicação existente ou crie um novo. Você precisa tomar uma decisão, ou talvez duas, e os resultados determinarão qual das três configurações de ponto de publicação você deve usar. A tabela abaixo mostra como as decisões influenciam as configurações.

Se você | E deseja usar | Usa esta configuração de ponto de publicação
Quer que os clientes controlem a reprodução | Uma conexão de servidor por cliente | Por demanda, unicast
Não quer que os clientes controlem a reprodução | Uma conexão de servidor por cliente | Difusão unicast
Não quer que os clientes controlem a reprodução | Uma conexão de servidor, compartilhada por todos os clientes | Difusão multicast

Controle da reprodução

Controlar a reprodução significa que o cliente deve ser capaz de iniciar, interromper, pausar, retroceder e avançar. Com o unicast, por demanda, o cliente controla o playback e a experiência do usuário é semelhante à reprodução de um filme em um aparelho de videocassete ou DVD. Esse tipo de reprodução requer um ponto de publicação por demanda. Um ponto de publicação por demanda distribui conteúdo pré-gravado, como arquivos de áudio e vídeo. Quando você adiciona a função de servidor de fluxo de mídia, o assistente cria um ponto de publicação por demanda chamado <Padrão>. Você pode distribuir seus arquivos de mídia neste ponto de publicação ou pode criar um ponto de publicação. As etapas de configuração de um ponto de publicação por demanda são semelhantes àquelas apresentadas nos arquivos Stream Windows Media por demanda na Ajuda do Windows Media Services. Se você escolher usar um ponto de publicação por demanda, deve usar a entrega por unicast.

Se o cliente não controlar a reprodução, a experiência do usuário será semelhante a assistir um programa de televisão. Esse tipo de reprodução requer um ponto de publicação de difusão. Esse tipo de ponto de publicação distribui conteúdo pré-gravado e ao vivo. Quando você adiciona a função de servidor de fluxo de mídia, o assistente cria um ponto de publicação de difusão chamado Sample_Broadcast contendo o conteúdo de amostra. Deixe essa amostra intacta e crie um novo ponto de publicação de difusão. Se você escolher criar um ponto de publicação de difusão, consulte Conexões do servidor.

Para obter mais informações sobre tipos de ponto de publicação por demanda e de difusão, consulte Sobre os tipos de pontos de publicação na Ajuda do Windows Media Services.

Conexões do servidor

Com o unicast, o servidor cria uma conexão separada para cada cliente. Como resultado, a entrega do unicast pode consumir uma grande quantidade de largura de banda da rede. Por exemplo, a entrega do mesmo conteúdo a 100 clientes simultaneamente consome 100 vezes a largura de banda de rede usada na entrega do conteúdo a um cliente. No entanto, a entrega de unicast não exige a configuração de roteadores e chaves da rede. O procedimento de configuração de um ponto de publicação é semelhante ao apresentando em Usar o servidor para publicar conteúdo ao vivo do Windows Media Encoder na Ajuda do Windows Media Services. Para obter mais informações sobre a entrega de unicast, consulte Entregando conteúdo como fluxo de unicast na Ajuda do Windows Media Services.

Com o multicast, o servidor não cria uma conexão com o cliente. Em vez disso, ele entrega o conteúdo a um endereço IP de classe D na rede, e qualquer cliente da rede pode recebê-lo. Isso preserva a largura de banda da rede. Por exemplo, uma entrega de multicast a 100 clientes consome a mesma largura de banda usada na entrega para um cliente. No entanto, muitas redes, por padrão, não aceitam a entrega de multicast. Para oferecer suporte à entrega de multicast, os roteadores e comutadores da rede entre o servidor e os clientes devem ser configurados para transmitir endereços IP de classe D e interpretar pacotes de informações de multicast. O procedimento de configuração de um ponto de publicação é semelhante ao apresentando em Usar o servidor para difundir um fluxo publicado pelo Windows Media Encoder na Ajuda do Windows Media Services. Para obter mais informações sobre a entrega de multicast, consulte Entregando conteúdo como fluxo de multicast na Ajuda do Windows Media Services.

Removendo a função do servidor de fluxo de mídia

Se for necessário reconfigurar seu servidor para uma outra função, você poderá remover funções existentes do servidor. Se você remover a função do servidor de fluxo de mídia, os clientes não poderão mais se conectar aos pontos de publicação desse servidor, e os codificadores não poderão mais enviar fluxos de mídia através do servidor. Todo o conteúdo armazenado ou distribuído somente neste servidor ficará indisponível.

Para remover a função do servidor de fluxo de mídia, reinicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Servidor de fluxo de mídia e, em seguida, clique em Avançar. Na página Confirmação de remoção de função, reveja os itens listados em Resumo, marque a caixa Remover a função de servidor de fluxo de mídia e clique em Avançar. Depois que você clica em Avançar, a página Configurando componentes do Assistente de componentes do Windows é exibida e, depois, fechada automaticamente. Você não pode clicar em Voltar ou Avançar nesta página. Na página Função de servidor de fluxo de mídia removida, clique em Concluir.

Próximas etapas: Concluindo tarefas adicionais

Até este ponto, você instalou o Windows Media Services: A instalação acrescentou o Windows Media Services ao servidor, instalou os arquivos de Ajuda e criou dois pontos de publicação que contêm o conteúdo de amostra.

A tabela a seguir lista algumas tarefas adicionais que você pode executar no servidor de fluxo de mídia.

Tarefas | Objetivo da tarefa | Referência
Configure opções de segurança. | Controlar o acesso ao servidor de fluxo de mídia e ao seu conteúdo. | Configurando opções de segurança na Ajuda do Windows Media Services
Faça um tour. | Familiarizar-se com os recursos do Windows Media Services. | Clique em Iniciar, escolha Executar e digite %systemroot%\system32\windows media\server\admin\mmc\hta\tour_.hta
Reveja os termos e conceitos relativos ao fluxo de mídia. | Familiarizar-se com os conceitos relativos ao fluxo de mídia, como unicast e multicast, por demanda e difusão, arquivamento, pontos de publicação e conteúdo de anúncios. | Noções básicas sobre terminologia na Ajuda do Windows Media Services
Determine quantos servidores de fluxo de mídia são necessários. | Planejar antecipadamente o número de servidores que você precisa instalar. | Configurando um sistema de fluxo de mídia, Planejando a capacidade na Ajuda do Windows Media Services
Identifique conflitos de portas. | Evitar problemas quando o Windows Media Services tentar usar a mesma porta TCP do servidor Web. | Usando fluxo HTTP e outros serviços no mesmo computador na Ajuda do Windows Media Services
Reveja as instruções para atualizar uma versão anterior do Windows Media Services. | Assegurar que você saiba fazer a atualização de outros servidores que executam versões anteriores do Windows Media Services. | Atualizando o Windows Media Services na Ajuda do Windows Media Services
Ative o serviço de áudio do Windows. | O serviço de áudio do Windows é desativado por padrão na nova instalação do XOX ou XOX Isso não impede que o servidor forneça fluxo de áudio aos clientes, mas você deve ativar o áudio para testar a reprodução do conteúdo no servidor. | Ativar ou desativar um serviço para um perfil de hardware
Inicie a interface de gerenciamento do Windows Media Services. | Configurar o servidor de fluxo de mídia. | Clique em Iniciar, escolha Executar e digite %systemroot%\system32\windows media\server\admin\mmc\wmsadmin.msc
Gerencie o servidor de fluxo de mídia | Configurar o servidor de fluxo de mídia para fornecer fluxo do conteúdo pela intranet ou pela Internet. Antes de começar a fornecer o fluxo de conteúdo, você deve definir as configurações do servidor que executa o Windows Media Services, adicionar e configurar pontos de publicação e configurar o conteúdo. | Gerenciando o Windows Media Services na Ajuda do Windows Media Services
Registre dados e eventos. | Registrar a atividade dos clientes que se conectam ao seu conteúdo. | Registrando dados e eventos na Ajuda do Windows Media Services
Gerencie e produza conteúdo. | Métodos e prioridades de gerenciamento de conteúdo variarão de um projeto para outro com base em diferentes fatores, como demografia do público, tipo de conteúdo, equipamento disponível e experiência do implantador. | Gerenciamento e produção de conteúdo na Ajuda do Windows Media Services
Decida como você obterá conteúdo no Windows Media Encoder. | Determinar se você quer configurar o codificador para forçar um fluxo ao servidor, ou configurar o servidor para puxar um fluxo do codificador. | Originando de um codificador na Ajuda do Windows Media Services
Implemente um sistema de cache/proxy. | Armazenar o conteúdo de fluxo mais recente para uso por outros clientes que procuram o mesmo material. Durante difusões ao vivo, os servidores cache/proxy podem executar uma tarefa chamada divisão de fluxo, que permite que vários clientes de unicast recebam o conteúdo enquanto somente um único fluxo é enviado do servidor de origem. | Implementando um sistema cache/proxy na Ajuda do Windows Media Services


Função do servidor WINS: Configurando um servidor WINS

Os servidores do serviço de cadastramento na Internet do Windows (WINS) mapeiam dinamicamente endereços IP para nomes de computadores (nomes NetBIOS). Isso permite que os usuários acessem recursos usando o nome do computador, em vez do endereço IP. Se você quiser que o computador rastreie os nomes e endereços IP de outros computadores da rede, configure-o como um servidor WINS.

Este tópico explica o procedimento básico para configurar um servidor WINS. Depois de configurar um servidor WINS básico, você pode executar outras tarefas de configuração, dependendo de como você deseja usar o servidor WINS.

Este tópico aborda o seguinte:

Antes de começar

Configurando o servidor WINS

Próximas etapas: Concluindo tarefas adicionais

Antes de começar

Antes de configurar o computador como um servidor WINS, verifique se:

  • Você está familiarizado com os conceitos WINS, como nomes de NetBIOS, servidores WINS, clientes WINS e parceiros de duplicação. Para obter mais informações, consulte Noções básicas sobre WINS.
  • O sistema operacional está configurado corretamente. Na família Windows Server 2003, o WINS depende da configuração adequada do sistema operacional e seus serviços. Se houver uma nova instalação de um produto da família Windows Server 2003,você pode usar as configurações de serviço padrão. Nenhuma outra ação é necessária. Se você atualizou para um produto na família Windows Server 2003 ou se deseja confirmar que os serviços estão configurados corretamente para obter melhor desempenho e segurança, verifique as configurações dos serviços usando a tabela em Configurações padrão dos serviços.
  • Você sabe quantos servidores WINS precisa instalar e onde localizar cada servidor na rede. Quando você adicione a função de servidor WINS, configura esse servidor para manter um banco de dados de nomes de computadores e endereços IP. Em uma rede maior, talvez você precise adicionar a função de servidor WINS a outros servidores para assegurar que os computadores clientes sempre tenham acesso a pelo menos um servidor WINS. Para obter mais informações, consulte Planejando redes WINS.
  • Este computador tem um endereço IP estático. Para obter mais informações, consulte Para configurar o TCP/IP para endereçamento estático.
  • Todos os volumes de disco existentes usam o sistema de arquivos NTFS. Volumes FAT32 não são protegidos e não oferecem suporte à compactação de arquivos e pastas, a cotas de disco, à criptografia de arquivos ou a permissões de arquivo individuais.

Configurando o servidor WINS

Para configurar o servidor WINS, inicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Servidor WINS e, em seguida, clique em Avançar.

Resumo das seleções

Concluindo o Assistente para configurar o servidor

Removendo a função do servidor WINS

Resumo das seleções

Na página Resumo das seleções, examine e confirme as opções que você selecionou. Se você selecionou Servidor WINS na página anterior, aparecerá o seguinte:

  • Instalar WINS

Para aplicar as seleções mostradas na página Resumo das seleções, clique em Avançar. Depois que você clica em Avançar, a página Configurando componentes do Assistente de componentes do Windows é exibida e, depois, fechada automaticamente. Você não pode clicar em Voltar ou Avançar nesta página. O Assistente para configurar o servidor instala o serviço do Servidor WINS. Ao contrário de muitos outros serviços, o serviço WINS é instalado sem qualquer participação do administrador.

Se você cancelar o Assistente para configurar o servidor, o serviço do Servidor WINS não será instalado. Para instalá-lo mais tarde, reinicie Gerenciar o servidor e adicione a função WINS.

Concluindo o Assistente para configurar o servidor

Após a reinicialização do servidor, o Assistente para configurar o servidor exibe a página Este servidor agora é um servidor WINS. Para rever todas as alterações feitas no servidor pelo Assistente para configurar o servidor ou certificar-se que uma nova função foi instalada com sucesso, clique em Log de Configuração do servidor. O log Assistente para configurar o servidor localiza-se em systemroot\Debug\Configure Your Server.log. Para fechar o Assistente para configurar o servidor, clique em Concluir.

Removendo a função do servidor WINS

Se for necessário reconfigurar seu servidor para uma outra função, você poderá remover funções existentes do servidor. Se você remover a função do servidor WINS e esse for o único WINS que os clientes usam para registrar e resolver nomes de computadores, você precisa adicionar a função WINS em outro servidor. Além disso, se o servidor estiver configurado para duplicar as informações do banco de dados WINS com outros servidores WINS, você deve reconfigurar a duplicação desses servidores WINS.

Para remover a função de servidor WINS, reinicie o Assistente para configurar o servidor seguindo um destes procedimentos:

  • Em Gerenciar o servidor, clique em Adicionar ou remover uma função. Por padrão, Gerenciar o servidor é iniciado automaticamente quando você faz logon. XOX
  • XOX

Na página Função do servidor, clique em Servidor WINS e, em seguida, clique em Avançar. Na página Confirmação de remoção de função, reveja os itens listados em Resumo, marque a caixa Remover a função de servidor WINS e clique em Avançar. Na página Função de servidor WINS removida, clique em Concluir.

Próximas etapas: Concluindo tarefas adicionais

Depois que você concluir o Assistente para configurar o servidor, o computador estará pronto para ser usado como um servidor WINS básico que pode rastrear os endereços IP do servidor e fornecer essas informações quando o cliente as solicitar. Até este ponto, você instalou o serviço do Servidor WINS em um servidor. Se você quiser oferecer suporte a clientes WINS em uma rede complexa, talvez precise instalar outros servidores WINS em sub-redes.

A tabela a seguir lista algumas tarefas adicionais que você pode executar no servidor WINS.

Tarefa | Objetivo da tarefa | Referência
Veja os nomes WINS registrados no servidor. | Verifique se o servidor WINS está funcionando corretamente. | Localizando e exibindo registros WINS
Modifique os padrões de servidor WINS. | O WINS utiliza diversos parâmetros padrão de configuração de servidor que determinam como os registros de nome NetBIOS serão gerenciados no banco de dados do servidor WINS. Normalmente, estes parâmetros são aceitos. Você pode desejar modificá-los em circunstâncias especiais, como quando uma alteração de nome de host deve ser feita ou quando a rede é renumerada de forma que os clientes e servidores usem um conjunto diferente de endereços IP. | Modificando padrões de servidor
Configure definições de duplicação nos servidores WINS primário e secundário. | Os servidores WINS replicam alterações do banco de dados entre si para que todos possuam as mesmas informações sobre os servidores da rede e sobre os endereços IP de cada um. | Configurando duplicação WINS; Configurar duplicação


Remover uma função do servidor

Elemento gráfico do Microsoft Windows

Remover uma função do servidor

  1. Abra Gerenciar o servidor.
  2. Em Gerenciando as funções do seu servidor, clique em Adicionar ou remover uma função.
  3. No Assistente para configurar o servidor, na página Etapas preliminares, clique em Avançar.
  4. Na página Função do servidor, clique em na função que deseja remover e, em seguida, clique em Avançar.
  5. Na página Confirmação de remoção de função, marque a caixa Remover a função do servidor e clique em Avançar.
  6. Na página Função do servidor removida, clique em Concluir.

Importante

  • Ao remover uma função de servidor, você deve quebrar as dependências que existem entre a função do servidor e outros programas. Certifique-se de testar a remoção da função do servidor em um ambiente de teste antes de executar a remoção na rede.

Observações

  • XOX
  • XOX
  • Para obter mais informações sobre como remover funções do servidor específicas e as dependências que podem ser afetadas, consulte:

    Removendo a função do servidor de arquivos

    Removendo a função do servidor de impressão

    Removendo a função do servidor de aplicativos

    Removendo a função do servidor de correio

    Removendo a função do servidor de terminal

    Removendo a função de servidor de acesso remoto/VPN

    Removendo a função do controlador de domínio

    Removendo a função do servidor DNS

    Removendo a função do servidor DHCP

    Removendo a função do servidor de fluxo de mídia

    Removendo a função do servidor WINS


Lista de verificação: Definindo a instalação típica de um primeiro servidor

Etapa | Referência
Rever os principais conceitos sobre o Active Directory. | Visão geral sobre o Active Directory
Rever os principais conceitos sobre o DNS. | Visão geral sobre o DNS
Rever os principais conceitos sobre o DHCP. | Visão geral sobre o protocolo DHCP
Rever os principais conceitos sobre o Roteamento e acesso remoto. | Visão geral sobre roteamento; Visão geral sobre o acesso remoto
Rever os principais conceitos sobre as partições de diretórios de aplicativos no Active Directory. | Partições do diretório de aplicativos
Escolha um plano para o espaço para nome do domínio do DNS. Como o Active Directory e o espaço para nome têm estrutura idêntica, é fundamental planejar adequadamente o espaço para nome para suavizar a implantação do Active Directory. Além disso, se sua rede exigir uma presença na Internet, verifique se você possui um nome de domínio de Internet registrado. | Planejamento de espaço para nome DNS
Verifique se o servidor possui uma partição NTFS. | Exibir as propriedades de um volume
Determine o nome da zona DNS na qual este servidor será autoritativo. Se você estiver configurando uma pequena rede com vários computadores conectados à Internet (como um escritório em casa), também precisará do endereço IP do servidor DNS fornecido pelo provedor de serviços de Internet. | Noções básicas sobre zonas e transferência de zona; Atualização dinâmica;Usando encaminhadores
Realize outras alterações de configuração servidor DNS ou instale outros servidores DNS. | Lista de verificação: Instalando um servidor DNS; Configurar um novo servidor DNS
Configure outras opções para o servidor DHCP. | Lista de verificação: Instalando um servidor DHCP
(Opcional) Monitore e meça os vários aspectos do servidor DNS para evitar e solucionar problemas de perda de desempenho. | Monitorando o desempenho do servidor DNS
(Opcional) Monitore e meça os vários aspectos do servidor DHCP para evitar e solucionar problemas de perda de desempenho. | Monitorando o desempenho do servidor DHCP; Referência de monitoramento de desempenho do DHCP
(Opcional) Instale e configure outros controladores de domínio. | Lista de verificação: Criando um controlador de domínio adicional para um domínio existente
(Opcional) Selecione o nível de segurança apropriado para a administração do domínio. | Usando o Assistente para instalação do Active Directory


Etapas preliminares: Configurando funções para o servidor

Os links abaixo fornecem informações detalhadas sobre etapas preliminares que você deve executar antes de configurar uma função de servidor.

Etapa | Referência
Instalar todos os modems e placas de rede. | Instalando um modem; Visão geral sobre como instalar dispositivos
Conectar todos os cabos necessários. | Consulte a documentação fornecida pelo fabricante do computador servidor.
Conectar-se à Internet. | Estabelecer conexões com a Internet
Ligar todos os periféricos, como impressoras e unidades externas. | Adicionar uma impressora conectada a seu computador; Visão geral sobre como instalar dispositivos
Ter o CD de Instalação fornecido com o sistema operacional Windows Server 2003 ou conhecer o caminho da instalação em rede. | Se você instalou seu sistema operacional remotamente usando um caminho de rede em vez do CD de Instalação fornecido com o sistema operacional Windows Server 2003, você precisará usar esse mesmo caminho de rede ao configurar o servidor.


Gerenciar trabalhos de backup

O painel de tarefas Gerenciar trabalhos de backup permite que você adicione e gerencie trabalhos de backup no computador Windows Server usando o Utilitário de backup em fita do Windows. Você também pode usar esse utilitário para restaurar dados arquivados no computador servidor.

Tarefa | Descrição
Iniciar o Assistente de backup | Inicia o Utilitário de backup em fita do Windows, que permite a você especificar se deseja fazer backup ou restaurar dados.

Para obter mais informações, consulte Visão geral sobre backup na Ajuda on-line.


Gerenciar pastas compartilhadas

O painel de tarefas Gerenciar pastas compartilhadas permite que você exiba e gerencie as pastas compartilhadas no computador Windows Server. A seção a seguir detalha as tarefas disponíveis neste painel de tarefas. Algumas tarefas estão disponíveis somente quando há uma pasta compartilhada selecionada.

Tarefa | Descrição
Adicionar uma pasta compartilhada | Inicia o Assistente para adicionar pasta compartilhada, que adiciona uma nova pasta compartilhada ao computador Windows Server e define as permissões para acessá-la.
Alterar as propriedades da pasta compartilhada | Permite que você modifique as propriedades da pasta selecionada, como nome, caminho, limites de conexão e permissões. Também permite que você publique a pasta no Active Directory.
Interromper compartilhamento | Interrompe o compartilhamento da pasta selecionada. A pasta e seus dados não serão removidos.

Para obter mais informações, consulte Pastas compartilhadas na Ajuda on-line.


Gerenciar impressoras

O painel de tarefas Gerenciar impressoras permite que você gerencie as impressoras da rede. A seção a seguir detalha as tarefas disponíveis neste painel de tarefas. Algumas tarefas estão disponíveis somente quando há uma impressora selecionada.

Tarefa | Descrição
Adicionar uma impressora | Inicia o Assistente para adicionar impressoras, que permite a você adicionar uma impressora local ou de rede ao computador Windows Server. É necessário que o dispositivo de impressão já esteja conectado.
Alterar as propriedades da impressora | Permite que você modifique as opções da impressora selecionada, como nome, caminho, permissões e outras propriedades avançadas.
Gerenciar trabalhos da impressora | Permite que você cancele, pause ou retome trabalhos de impressão na fila da impressora selecionada.

Para obter mais informações, consulte Visão geral sobre impressão na Ajuda on-line.


Gerenciamento de servidores

Baseado no Microsoft Management Console 2.0, o Gerenciamento de servidores foi criado para administradores de domínio e contém os snap-ins e as ferramentas necessárias para o gerenciamento diário básico. Usando a árvore do console, você pode navegar pela estrutura do snap-in e acessar ferramentas da barra de menus ou dos menus acessados com o botão direito do mouse. No painel de detalhes, você pode acessar as ferramentas usando as tarefas do painel de tarefas ou os menus acessados com o botão direito do mouse.

O Gerenciamento de servidores é pré-configurado com as seguintes ferramentas de gerenciamento:

Ferramenta | Descrição
Home page | Apresenta atalhos com ícones para as ferramentas principais do console no Gerenciamento de servidores.
Pastas compartilhadas | Permite que você gerencie pastas compartilhadas no servidor.
Usuários | Permite que você adicione e gerencie contas de usuários da rede.
Impressoras | Permite que você gerencie impressoras locais e da rede.
Backup | Permite que você faça o backup do servidor.


Gerenciar usuários

O painel de tarefas Gerenciar usuários permite que você gerencie, crie e modifique contas de usuários do Windows Server. A seção a seguir detalha as tarefas disponíveis neste painel de tarefas. Algumas tarefas estão disponíveis somente quando há uma conta de usuário selecionada.

Tarefa | Descrição
Adicionar um usuário | Inicia o Assistente para adicionar usuário, que simplifica a criação de contas de usuários permitindo que você especifique várias opções da conta em um só lugar.
Alterar senha | Permite que você altere ou redefina a senha de rede do usuário selecionado.
Adicionar um usuário a um grupo | Permite que você especifique maior segurança ou associações a grupos de distribuição para o usuário selecionado.
Ativar conta | Ativa a conta de usuário selecionada. Quando uma conta de usuário desativada é ativada, o usuário pode fazer logon na rede e acessar seus recursos, como e-mail ou impressoras.
Desativar conta | Desativa a conta de usuário selecionada Quando uma conta de usuário está desativada, o usuário não pode fazer logon na rede, nem acessar seus recursos, como e-mail ou impressoras. A conta de usuário não é removida.
Alterar propriedades do usuário | Permite que você exiba e modifique as propriedades do usuário selecionado, como informações da conta, perfil e acesso remoto.
Remover usuário | Remove permanentemente a conta de usuário selecionada. Uma vez removida, a conta não pode ser recuperada. Você deverá confirmar a ação.

Para obter mais informações, consulte Contas de usuários e de grupos na Ajuda on-line.