Guia de Introdução

Os tópicos de introdução fornecem informações sobre os novos recursos e também para ajudá-lo a instalar ou atualizar uma rede que disponha de um a sete servidores e 100 ou menos clientes.

Neste guia

  • Guias passo a passo para implantação
  • O que há de novo no Microsoft Windows Server 2003 R2
  • Novos recursos
  • Instalando e atualizando o sistema operacional
  • Instalando e atualizando em nós de cluster
  • Configurando funções para o servidor
  • Ativação do produto Windows

Se você administrar um conjunto maior de servidores, consulte também o Windows Server 2003 Deployment Kit no site Microsoft Windows Resource Kits. (http://www.microsoft.com/)

Para obter informações sobre como obter o Windows Deployment and Resource Kits, consulte Windows Deployment and Resource Kits.

Para acessar os recursos e serviços adicionais para a utilização e manutenção do sistema operacional Windows Server, consulte o TechCenter do Windows Server 2003 . (http://go.microsoft.com/fwlink/?LinkID=34402)


Guias passo a passo para implantação

O site da Microsoft fornece tutoriais que ensinam sobre o sistema operacional e como implantá-lo. Essas orientações técnicas oferecem instruções passo a passo e ilustrações sobre como instalar e configurar recursos importantes.

Você pode acessar os guias passo a passo no site da Microsoft (http://www.microsoft.com).

A lista a seguir inclui alguns dos tópicos que podem ser encontrados nesses guias:

Infra-estrutura

  • Criando uma infra-estrutura de rede comum

Active Directory

  • Configurando controladores de domínio adicionais
  • Delegando o controle de objetos
  • Gerenciando o Active Directory
  • Gerenciando a topologia de replicação
  • Usando LDAP e VBScript para gerenciar o Active Directory
  • Estendendo o Active Directory com uso do Esquema e de especificadores de exibição

Serviços de gerenciamento

  • Noções básicas sobre Diretivas de grupo
  • Gerenciando a instalação remota do sistema operacional
  • Gerenciando implantações de aplicativos para grupos de usuários e computadores
  • Gerenciando dados e configurações de usuários

Serviços de segurança

Instalando e configurando certificados

  • Instalando uma autoridade de certificação
  • Configurando um domínio para confiar em uma autoridade de certificação externa
  • Gerenciando serviços de certificados
  • Obtendo e gerenciando certificados
  • Configurando solicitações automáticas de certificados

Usando certificados

  • Solicitando certificados com páginas da Web
  • Mapeando certificados para contas de usuários para uso em um site

Recursos de segurança adicionais

  • Configurando a diretiva de segurança local em computadores individuais
  • Gerenciando a segurança em uma rede corporativa
  • Criptografando arquivos
  • Usando o Kerberos V5
  • Criptografando o tráfego de rede IP com segurança do protocolo Internet (IPSec)

Serviços de arquivos e impressão

  • Criando modos de exibição lógicos de pastas e arquivos

Cluster

  • Instalando um cluster típico de dois nós em Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition


O que há de novo no Microsoft Windows Server 2003 R2

Elemento gráfico do Microsoft Windows

O que há de novo no Windows Server 2003 R2

Os tópicos a seguir descrevem os novos componentes do Windows Server 2003 R2 e como instalá-los:

  • Aprender mais sobre os novos componentes do Windows Server 2003 R2
  • Instalando componentes opcionais e funções de servidor

Para acessar os recursos e serviços adicionais para a utilização e manutenção do sistema operacional Windows Server, consulte o TechCenter do Windows Server 2003 . (http://go.microsoft.com/fwlink/?LinkID=34402)


Aprender mais sobre os novos componentes do Windows Server 2003 R2

O Microsoft® Windows Server™ 2003 R2, uma atualização de software do sistema operacional Windows Server 2003, torna mais fácil e econômica a extensão da conectividade e do controle a identidades, localizações, dados e aplicativos na sua organização e além dela.

Incluído no Windows Server 2003 com Service Pack 1 (SP1), o Windows Server 2003 R2 se beneficia da estabilidade e segurança da base de códigos ao estender a conectividade e o controle em novas áreas. Com o Windows Server 2003 R2, você obtém as seguintes melhorias:

  • Gerenciamento de identidade e acesso
  • Gerenciamento do servidor local
  • Configuração e gerenciamento do armazenamento
  • Desenvolvimento de aplicativo dentro e fora dos limites tradicionais da organização.

Para obter mais informações sobre o Windows Server 2003 R2, consulte o site da Microsoft. (http://go.microsoft.com/fwlink/?LinkId=45560)

Este tópico descreve os componentes novos a seguir que podem ser instalados com o Windows Server 2003 R2. Este tópico também fornece links para mais informações sobre cada um deles.

Capacidade de gerenciamento do servidor

  • Pacotes de ferramentas administrativas

  • Gerenciamento de hardware

  • MMC 3.0

Recursos do Active Directory

  • Modo de Aplicativo do Active Directory (ADAM)

  • Serviços de Federação do Active Directory

Recursos de gerenciamento de discos e arquivos

  • Filial

  • Sistema de Arquivos Distribuídos (DFS)

  • Sistema de Arquivos de Log Comuns (CLFS)

  • Gerenciamento de Servidor de Arquivos

  • Gerenciador de Recursos de Servidor de Arquivos

  • Serviços de NFS da Microsoft

  • Gerenciamento de Armazenamento para Redes SAN

Suporte a impressoras e protocolos

  • Gerenciamento de Impressão

Microsoft .NET Framework

  • Microsoft .NET Framework versão 2.0

Serviços e recursos de Internet e email

  • Windows SharePoint Services

Interoperabilidade com UNIX

  • Gerenciamento de Identidade para UNIX

  • Subsistema para Aplicativos UNIX

Capacidade de gerenciamento do servidor

Para ajudá-lo no gerenciamento do servidor, o Windows Server 2003 R2 fornece pacotes de ferramentas administrativas e as seguintes melhorias do gerenciamento de hardware e do Microsoft Management Console (MMC) 3.0.

Pacotes de ferramentas administrativas

Para facilitar o gerenciamento remoto dos servidores, você pode instalar os pacotes de ferramentas administrativas do Windows Server 2003 R2 localizadas no CD 2, no diretório \mgmttls. Cada um dos seguintes componentes possui um pacote de ferramentas administrativas:

  • Microsoft Management Console (MMC) 3.0
  • Gerenciamento de Impressão
  • Gerenciador de Recursos de Servidor de Arquivos
  • Replicação DFS
  • Gerenciamento de Identidade para UNIX
  • Gerenciamento de Servidor de Arquivos

Para administrar um componente, você primeiro deve instalar o pacote de ferramentas administrativas do MMC 3.0. Os pacotes de ferramentas administrativas podem ser instalados em computadores que estejam executando o Windows® XP Professional com Service Pack 2 (SP2). Para obter instruções específicas sobre a instalação, consulte o site da Microsoft. (http://go.microsoft.com/fwlink/?LinkId=54293)

Gerenciamento de hardware

Você pode usar o Windows Remote Management (WinRM) para gerenciar hardware de servidor remotamente em firewalls e monitorar as condições em servidores que estiverem offline.

Este novo recurso do Windows Server 2003 R2 é implementado usando-se o WS-Management, um protocolo remoto, padrão da indústria e baseado em serviços da Web. O WS-Management usa HTTPS como o transporte seguro que permite atravessar o firewall.

O WinRM fornece uma interface de linha de comando para tarefas comuns de gerenciamento e uma API de script para escrever scripts de administração de sistema baseados em host de scripts do Windows (WSH).

Com o WinRM, você pode escrever scripts para monitorar e controlar o estado do hardware do servidor estabelecendo uma comunicação com um controlador BMC. Um controlador BMC é um micro-controlador separado com seu próprio adaptador de rede conectado à placa do processador de um servidor e pode monitorar condições mesmo que o servidor esteja desligado ou com problemas de funcionamento. Um novo provedor de WMI (Windows Management Interface) para IPMI (Intelligent Platform Management Interface) apresenta seis novas classes de WMI para acessar as informações do BMC com scripts.

O WinRM não é instalado por padrão com o Windows Server 2003 R2. Para instalá-lo, abra Adicionar ou Remover Programas no Painel de Controle e clique em Adicionar ou Remover Componentes do Windows.

Para obter mais informações sobre gerenciamento de hardware, consulte o tópico sobre o "gerenciamento de hardware no Microsoft Windows Server 2003 R2" no site da Microsoft. (http://go.microsoft.com/fwlink/?LinkId=45204)

Voltar para o início

MMC 3.0

O Microsoft Management Console (MMC) 3.0 oferece suporte a recursos mais elaborados em snap-ins criados para a infra-estrutura do MMC 3.0. Além disso, as seguintes melhorias aplicam-se a todos os consoles do MMC 3.0:

  • Painel de ações. O painel de ações aparece no lado direito do snap-in console. Ele relaciona as ações disponíveis para você no momento, com base nos itens selecionados no momento na árvore ou no painel de resultados.

    Para mostrar ou ocultar o painel de ações, clique no botão Mostrar/Ocultar Painel de Ações na barra de ferramentas, que é similar ao botão Mostrar/Ocultar Árvore de Console.

  • Nova caixa de diálogo Adicionar ou Remover Snap-ins. A nova caixa de diálogo Adicionar ou Remover Snap-ins facilita a adição, organização e remoção de snap-ins. Você pode controlar quais extensões estão disponíveis e se os snap-ins que forem instalados posteriormente devem ser habilitados automaticamente. Você pode aninhar os snap-ins e reorganizá-los na árvore.

    Para usar este recurso nesta versão beta, você deve definir uma chave do Registro manualmente.

  • Tratamento de erros aprimorado. O MMC 3.0 avisa sobre os erros em snap-ins que poderiam causar falhas no MMC e fornece várias opções para solucioná-los.

O MMC 3.0 é instalado automaticamente quando você instala o Windows Server 2003 R2.

Para obter mais informações, consulteMicrosoft Management Console.

Voltar para o início

Recursos do Active Directory

Os seguintes componentes do Active Directory agora estão incluídos no Windows Server 2003 R2.

Modo de Aplicativo do Active Directory (ADAM)

O Modo de Aplicativo do Active Directory (ADAM) é um modo independente do serviço de diretório do Active Directory®, sem recursos de infra-estrutura, que fornece serviços de diretório para aplicativos. Ele fornece um armazenamento de dados e serviços para acessá-lo. Ele usa APIs (interfaces de programação de aplicativo) padrão para acessar os dados do aplicativo. O ADAM opera como um armazenamento de dados autônomo ou com replicação. Sua independência possibilita o controle local e a autonomia dos serviços de diretório de aplicativos específicos. Ele também facilita contextos de nomeação e esquemas flexíveis e independentes.

Para obter mais informações, consulteModo de Aplicativo do Active Directory (ADAM).

Voltar para o início

Serviços de Federação do Active Directory

A finalidade principal dos Serviços de Federação do Active Directory (ADFS) é aproveitar a conexão única de usuário para autenticar o usuário em vários aplicativos da Web relacionados durante uma única sessão online. O ADFS realiza isso com segurança compartilhando a identidade digital e a autorização pelos limites de segurança e da empresa.

Para obter mais informações, consulte Serviços de Federação do Active Directory (ADFS).

Voltar para o início

Recursos de gerenciamento de discos e arquivos

O Windows Server 2003 R2 inclui os seguintes recursos de gerenciamento de discos e arquivos.

Filial

Filiais são locais remotos de uma organização que se conecta à sede ou ao hub por meio de uma rede de longa distância. As tecnologias incluídas no Windows Server 2003 R2 podem simplificar o modo como você gerencia várias atividades e tarefas nas filiais. Essas atividades e tarefas incluem:

  • Publicação de arquivos de hubs centralizados para filiais.
  • Replicação de arquivos de filiais para backup, tolerância a falhas ou publicação cruzada.
  • Colaboração em documentos compartilhados entre filiais ou entre hubs e filiais.
  • Gerenciamento eficiente de impressoras, drivers de impressora e filas de impressão nas filiais.

As ferramentas de gerenciamento de impressão avançadas oferecem suporte a essas melhorias no Windows Server 2003 R2. O suporte também é oferecido pelo DFS (sistema de arquivos distribuídos) no Windows Server 2003 R2.

Para obter mais informações sobre estas tecnologias no Windows Server 2003 R2, consulte o site da Microsoft. (http://go.microsoft.com/fwlink/?LinkId=51679)

Voltar para o início

Sistema de Arquivos Distribuídos (DFS)

A solução Sistema de Arquivos Distribuídos (DFS) no Windows Server 2003 R2 fornece acesso simplificado e tolerante a falhas aos arquivos e replicação amigável em uma WAN. O Sistema de Arquivos Distribuídos consiste em duas tecnologias:

  • Espaços para Nome do DFS. Anteriormente conhecido como Sistema de Arquivos Distribuídos, o Espaços para Nome do DFS permite que administradores agrupem pastas compartilhadas localizadas em servidores diferentes e as apresentem aos usuários como uma árvore virtual de pastas conhecida como espaço para nome. Um espaço para nome oferece vários benefícios, incluindo maior disponibilidade de dados, balanceamento de carga e migração de dados simplificada.
  • Replicação DFS. A sucessora do serviço de Replicação de Arquivos (FRS), a Replicação DFS, é um mecanismo de replicação multimestre baseado em estado, que oferece suporte ao agendamento de replicação e à aceleração da largura de banda. A Replicação DFS usa um novo algoritmo de compactação conhecido como RDC (Compactação Diferencial Remota). RDC é um protocolo que pode ser usado para atualizar arquivos de forma eficaz através de uma rede com largura de banda limitada. O RDC detecta inserções, remoções, reorganizações de dados nos arquivos, permitindo que o recurso Replicação DFS replique somente os deltas (alterações) quando os arquivos forem atualizados.

Para obter mais informações sobre o Sistema de Arquivos Distribuídos no Windows Server 2003 R2, consulte o site da Microsoft. (http://go.microsoft.com/fwlink/?LinkId=51679)

Voltar para o início

Sistema de Arquivos de Log Comuns (CLFS)

O Sistema de Arquivos de Log Comuns (CLFS) é um driver carregável que fornece aplicativos de modo de usuário ou núcleo com um subsistema de log robusto. O CLFS é uma tecnologia exclusiva do Windows que pode ser usada para desenvolver aplicativos e middleware que dependam de gravação e leitura consistentes de dados seqüenciais. Alguns exemplos são os agentes de replicação, agentes de auditoria, bancos de dados e outros gerenciadores de recursos transacionais.

Os recursos incluem a capacidade de criar arquivos de log com um único fluxo de dados ou com vários fluxos de dados para uso compartilhado por um ou mais clientes; log circular e linear; capacidade garantida de liberar dados em buffer, reservando espaço no log; gerenciamento de espaço e tamanho do log baseado em diretiva; compartilhamento de um log único por clientes do usuário e do núcleo; um mecanismo de notificação para permitir que usuários diferentes no mesmo log coordenem o uso do log; buffer flexível dos dados do log; o arquivamento de APIs não interfere nas operações normais; gravações atômicas de vários setores; e detecção de gravação interrompida.

O CLFS é otimizado para melhor desempenho. Todas as gravações no arquivo de log serão armazenadas em buffer até que ocorra uma liberação explícita, uma oportunidade de compartilhar uma gravação com outro cliente, ou o buffer for preenchido. Os dados do log são gravados diretamente no disco rígido dos buffers de log sem cópia. Vários fluxos de dados podem ser gravados durante a mesma operação de E/S, resultando em uma única busca em disco para o que normalmente levaria várias pesquisas e gravações. As leituras são armazenadas em cache para economizar acessos ao disco durante a operação normal ou intermitência da atividade de leitura.

Para obter mais informações, consulte a "Platforma SDK" no site da Microsoft. (http://go.microsoft.com/fwlink/?LinkId=44489)

Voltar para o início

Gerenciamento de Servidor de Arquivos

Você pode usar o Gerenciamento de Servidor de Arquivos para realizar várias tarefas como formatar volumes, criar compartilhamentos, desfragmentar volumes, criar e gerenciar compartilhamentos, definir limites de cota, criar relatórios sobre o uso do armazenamento, replicar dados de entrada e saída do servidor de arquivos, gerenciar redes SAN (Redes de Área de Armazenamento) e compartilhar arquivos com sistemas UNIX e Macintosh.

Para obter mais informações, consulte Visão geral do Gerenciamento de Servidor de Arquivos.

Voltar para o início

Gerenciador de Recursos de Servidor de Arquivos

Com a demanda crescente de recursos de armazenamento, como as organizações dependem mais dos dados do que antes, os administradores de TI enfrentam o desafio de examinar uma infra-estrutura maior e mais complexa, enquanto ao mesmo tempo, controlam o tipo de informações disponíveis nela.

O Gerenciador de Recursos de Servidor de Arquivos é um novo snap-in do Microsoft Management Console (MMC) que fornece um conjunto de ferramentas que permite que os administradores compreendam, controlem e gerenciem a quantidade e o tipo de dados armazenados em seus servidores. Ao usar o Gerenciador de Recursos de Servidor de Arquivos, os administradores podem inserir cotas em pastas e volumes, arquivos de triagem ativos e gerar relatórios de armazenamento abrangentes.

Comparação entre as cotas do Gerenciador de Recursos de Servidor de Arquivos e as cotas de disco do NTFS

Os sistemas operacionais Windows 2000 e Windows Server 2003 oferecem suporte a cotas de disco, que são usadas para acompanhar e controlar o uso de disco por usuário nos volumes NTFS. A tabela a seguir descreve as vantagens do uso das ferramentas de gerenciamento de cota no Gerenciador de Recursos de Servidor de Arquivos.

Recursos da cota | Gerenciador de Recursos de Servidor de Arquivos | Cotas de disco do NTFS
Controle de cota | Por pasta ou por volume | Por usuário em um volume
Cálculo do uso do disco | Espaço em disco real | Tamanho lógico do arquivo
Mecanismos de notificação | Email, relatórios personalizados, execução de comandos, logs de eventos | Logs de eventos somente

Para obter mais informações, consulteGerenciador de Recursos de Servidor de Arquivos.

Voltar para o início

Serviços de NFS da Microsoft

O Serviços de NFS da Microsoft é um componente do Windows Server 2003 R2 que fornece uma solução de compartilhamento de arquivos para empresas que possuam um ambiente misto de Windows e UNIX. O Serviços de NFS da Microsoft permite que os usuários transfiram arquivos entre computadores com Windows Server 2003 R2 e UNIX usando o protocolo NFS.

O Serviços de NFS da Microsoft é uma atualização dos componentes NFS que estavam disponíveis no Services for UNIX 3.5. O Serviços de NFS da Microsoft inclui os seguintes recursos novos:

  • Suporte para 64 bits

    Os componentes do Serviços de NFS da Microsoft podem ser instalados em todas as edições do Windows Server 2003 R2, incluindo as versões de 64 bits.

  • Snap-in de administração do Microsoft Management Console (MMC) atualizado para o Serviços de NFS da Microsoft
  • Confiabilidade aprimorada.
  • Suporte para dispositivos especiais UNIX (mknod)

O Serviços de NFS da Microsoft permite que você ofereça suporte a um ambiente misto com sistemas operacionais baseados em Windows e UNIX. Ele também permite que você atualize os computadores da organização oferecendo suporte à tecnologia mais antiga durante a fase de transição. Os seguintes cenários são exemplos de como as empresas podem se beneficiar da implantação do Serviços de NFS da Microsoft.

  • Permite que clientes UNIX acessem recursos em computadores que executem o Windows Server 2003 R2. Sua empresa pode ter clientes UNIX acessando recursos, tais como arquivos, em servidores de arquivos UNIX. Para aproveitar os novos recursos do Windows Server 2003, tais como Cópias de Sombra de Pastas Compartilhadas, você pode mover recursos dos servidores UNIX para computadores com o Windows Server 2003 R2 e depois configurar o Serviços de NFS da Microsoft para conceder acesso aos clientes UNIX que estejam executando o software NFS. Todos os clientes UNIX poderão acessar os recursos usando o protocolo NFS sem a necessidade de alterações.
  • Permite que os computadores com Windows Server 2003 R2 acessem recursos em servidores de arquivos UNIX. Sua empresa pode ter um ambiente misto de Windows e UNIX com recursos, como arquivos, armazenados em servidores de arquivos UNIX. Você pode usar o Serviços de NFS da Microsoft para permitir que computadores com Windows Server 2003 R2 acessem esses recursos quando os servidores de arquivos estiverem executando o software NFS.

Para obter mais informações, consulte Serviços de NFS da Microsoft.

Gerenciamento de Armazenamento para Redes SAN

O Gerenciador de Armazenamento para Redes SAN é um novo snap-in do MMC que ajuda você a criar e gerenciar LUNs (números de unidades lógicas) em subsistemas de unidades de disco iSCSI e de Fibre Channel na rede de área de armazenamento (Rede SAN). O Gerenciador de Armazenamento para Redes SAN pode ser usado em subsistemas de armazenamento que ofereçam suporte ao VDS (Servidor de Disco Virtual).

Use o Gerenciador de Armazenamento para Redes SAN para criar e atribuir LUNs, gerenciar conexões entre LUNs e os servidores na sua rede SAN e definir as propriedades de segurança dos subsistemas de armazenamento iSCSI.

Para obter mais informações, consulteGerenciador de Armazenamento para Redes SAN.

Voltar para o início

Suporte a impressoras e protocolos

O Windows Server 2003 R2 fornece um snap-in do MMC atualizado para o Gerenciamento de Impressão.

Gerenciamento de Impressão

O Gerenciamento de Impressão é um snap-in atualizado do MMC que você pode usar para exibir e gerenciar impressoras e servidores de impressão na sua organização. Você pode usar o Gerenciamento de Impressão em qualquer computador que execute o Windows Server 2003 R2 e gerenciar todas as impressoras de rede e todos os servidores de impressão que executem o Windows 2000 Server, o Windows Server 2003 ou o Windows Server 2003 R2.

O Gerenciamento de Impressão fornece detalhes atualizados como os status da fila, o nome da impressora, do driver e do servidor. Você também pode definir modos de exibição personalizados usando os filtros do Gerenciamento de Impressão. Por exemplo, você pode criar um modo de exibição que exiba somente as impressoras que apresentem um estado de erro em particular. Você também pode configurar o Gerenciamento de Impressão para enviar notificações por email ou executar scripts quando uma impressora ou servidor de impressão precisar de atenção. A capacidade de filtragem também permite que você edite trabalhos de impressão em massa, como cancelar todos os trabalhos de impressão de uma vez. Você também pode excluir várias impressoras ao mesmo tempo.

Os administradores podem instalar as impressoras remotamente usando o recurso de detecção automática, que localiza e instala impressoras da sub-rede local no servidor de impressão local. Os administradores podem efetuar logon em um servidor local de uma filial usando a Área de Trabalho Remota e depois instalar as impressoras facilmente de forma remota.

Quando um modelo de impressora possui um recurso de página da Web, o Gerenciamento de Impressão pode exibir detalhes de solução de problemas, como o local da obstrução do papel ou nível de toner da impressora. Alguns modelos de impressora possuem páginas da Web que fornecem opções para funções de controle remoto que podem ajudar na solução de problemas em filiais.

Para obter mais informações, consulte o "Guia passo a passo do Gerenciamento de Impressão" no site da Microsoft. (http://go.microsoft.com/fwlink/?LinkId=50141)

Voltar para o início

Microsoft .NET Framework

Há novos recursos do .NET Framework 2.0 disponíveis no Windows Server 2003 R2.

Microsoft .NET Framework versão 2.0

O .NET Framework versão 2.0 é a versão mais recente do .NET Framework, um componente do Windows para a criação, implantação e execução de aplicativos. O .NET Framework 2.0 está focalizado na entrega de produtividade do desenvolvedor, na excelência operacional e na capacidade de preservar e aumentar os investimentos existentes em software. As principais melhorias incluem o suporte a processadores de 64 bits para melhorar o desempenho e a escalabilidade, otimizações e melhorias transacionais, melhorias de produtividade no ASP.NET e suporte para WS-I BP 1.1 e SOAP 1.2 com serviços da Web.

Para obter uma lista abrangente dos novos recursos do .NET Framework 2.0, consulte o site da Microsoft. (http://go.microsoft.com/fwlink/?LinkId=50322)

Voltar para o início

Serviços e recursos de Internet e email

O Windows SharePoint Services está incluído no Windows Server 2003 R2.

Windows SharePoint Services

O Microsoft Windows® SharePoint® Services é um portfólio integrado de serviços de colaboração e comunicação criados para conectar pessoas, informações, processos e sistemas dentro e além do firewall da organização. O Windows SharePoint Services Service Pack 2 está incluído nesta versão do Windows Server 2003. Agora, você pode instalar o Windows SharePoint Services diretamente do Assistente para Configurar o Servidor ou Gerenciar o Servidor. Quando você instala o Windows SharePoint Services, obtém os seguintes recursos:

Sites do SharePoint – armazenamento de arquivos mais colaboração

Os sites baseados no Microsoft Windows SharePoint Services 2.0 oferecem um local em as equipes podem se comunicar, compartilhar documentos e trabalhar em conjunto em um projeto. Os sites do SharePoint incluem:

  • Recursos de colaboração de equipe, como calendários de eventos, contatos, links da Web, discussões, listas de problemas, anúncios e muito mais.
  • Bibliotecas de documentos, nas quais os usuários podem armazenar e recuperar documentos e se beneficiar dos recursos avançados como check-in e check-out, histórico da versão, metadados personalizados e modos de exibição flexíveis e personalizáveis.
  • Partes da Web, que podem fornecer acesso a dados, serviços da Web e muitos outros aplicativos e conteúdo para sites do SharePoint.

Os usuários do site podem contribuir usando apenas um navegador da Web. Entretanto, se os usuários possuem programas clientes compatíveis com o Windows SharePoint Services instalados em seus computadores, tal como o Microsoft Office 2003, eles poderão trabalhar totalmente integrados com o site, salvando arquivos em bibliotecas, editando documentos no programa cliente, movendo ou vinculando essas informações ao site.

Administração central do SharePoint – interface do navegador da Web para gerenciamento do servidor

Você pode gerenciar um único servidor ou um server farm inteiro executando o Windows SharePoint Services de uma interface de navegador da Web chamada Administração Central do SharePoint. Use a Administração Central do SharePoint para estender um servidor virtual, criar sites ou ativar a Criação de Site Pessoal para que os usuários possam criar seus próprios sites, gerenciar configurações de segurança, gerenciar a lista de servidores no server farm e assim por diante. Se você preferir, também poderá usar o utilitário de linha de comando Stsadm.exe para gerenciar servidores usando o Windows SharePoint Services.

Aplicativos do Windows SharePoint Services – faça download de aplicativos prontos para usar, instale-os e comece a trabalhar rapidamente

Aumente a produtividade dos funcionários baixando e instalando um aplicativo para Windows SharePoint Services. Esses aplicativos são feitos para lidar com tarefas ou processos específicos. Existem várias opções, incluindo recrutamento, gerenciamento de projeto, controle de problemas de suporte técnico, registro de horas e agendamento, planejamento de eventos, e muito mais. Use os aplicativos assim que são instalados ou personalize-os para que se adequem às necessidades e exigências específicas da sua organização.

Para obter mais informações, consulte a seção sobre "os aplicativos do Windows SharePoint Services" no site da Microsoft. (http://go.microsoft.com/fwlink/?LinkId=47987)

Suporte para configurações avançadas de extranet

Um recurso de mapeamento de zona de URL (novo no Windows SharePoint Services, Service Pack 2) permite interações mais fáceis com um servidor proxy ou firewall. O Windows SharePoint Services usa URLs absolutos para gerar alguns hiperlinks em suas páginas da Web e mensagens de email. Isso impedia que o Windows SharePoint Services oferecesse suporte a certas configurações avançadas de extranet (como terminação SSL, modificação de cabeçalho do host e conversão de porta) onde um servidor proxy reverso fosse implantado na frente do servidor do Windows SharePoint Services. Agora, você pode configurar zonas de URL, como internet, intranet e extranet e mapear URLs de entrada e saída para essas zonas, de forma que essas configurações possam funcionar corretamente.

Para obter mais informações sobre o Windows SharePoint Services no Windows Server 2003 R2, consulte o site da Microsoft. (http://go.microsoft.com/fwlink/?LinkId=45560)

Voltar para o início

Interoperabilidade com UNIX

Para uma maior interoperabilidade com UNIX, os seguintes recursos estão disponíveis no Windows Server 2003 R2.

Gerenciamento de Identidade para UNIX

O Windows Services for UNIX fornece integração entre Windows e UNIX com soluções de gerenciamento de identidade atualizadas. As seguintes soluções ajudam a fornecer acesso de usuário ininterrupto e gerenciamento eficiente de recursos de rede nos sistemas operacionais:

  • Servidor para NIS. Ajuda a integrar servidores NIS baseados em Windows e UNIX habilitando um controlador de domínio do Active Directory para atuar como um servidor NIS mestre para um ou mais domínios NIS.
  • Sincronização de Senhas. Ajuda a integrar servidores Windows e UNIX simplificando o processo de manutenção de senhas seguras. Com a Sincronização de Senhas, os usuários não precisam manter senhas separadas para as contas do Windows e do UNIX ou lembrar de alterar a senha em vários locais.

Para obter mais informações, consulte Visão geral sobre o Gerenciamento de Identidade para UNIX.

Voltar para o início

Subsistema para Aplicativos UNIX

O Subsistema para Aplicativos UNIX (SUA) é um subsistema de compatibilidade de origem para a compilação e execução de aplicativos UNIX personalizados em um computador com um sistema operacional de classe de servidor Windows. Você pode tornar os aplicativos UNIX totalmente interoperáveis com o Windows no SUA com pouca ou nenhuma alteração no código fonte original.

O Subsistema para Aplicativos UNIX fornece um sistema operacional para processos POSIX (Interface do Sistema Operacional Portátil). O SUA, junto com seu pacote de utilitários de suporte (como shells e um cliente telnet), fornece um ambiente UNIX completo. O pacote de utilitários de suporte inclui um conjunto abrangente de utilitários de script e um SDK (software development kit) criados para oferecer total suporte aos recursos de desenvolvimento do SUA.

O SUA também oferece suporte a nomes de arquivos com diferenciação de maiúsculas e minúsculas, ao controle de trabalho, a ferramentas de compilação e ao uso de mais de 300 comandos, utilitários e scripts de shell do UNIX. Como o subsistema é instalado separadamente do núcleo do Windows, ele oferece funcionalidade UNIX real sem emulação.

Os novos recursos desta versão incluem os seguintes:

  • Conectividade com biblioteca do banco de dados (OCI/ODBC). O SUA oferece suporte à conectividade com o Oracle e o SQL Server a partir de aplicativos do banco de dados usando os padrões OCI (Oracle Call Interface) e ODBC (Open Database Connectivity).
  • Extensão de Depurador do Microsoft® Visual Studio® para depuração de aplicativos POSIX. O SUA inclui suporte para depuração dos processos POSIX usando o IDE do Visual Studio.
  • Utilitários baseados em ambientes SVR-5 e BSD UNIX. O pacote de download do SUA oferece suporte a dois ambientes UNIX diferentes: SVR-5 e BSD.
  • Suporte a aplicativos de 64 bits. Usando um processo chamado thunking, o SUA oferece suporte não apenas a aplicativos de 64 bits que estejam sendo executados em um sistema operacional de 64 bits, mas também oferece um suporte padrão a binários de 32 bits que estejam sendo executados em um sistema operacional de 64 bits.

Para fazer o download dos utilitários de suporte, consulte a seção sobre "instalação e uso de utilitários e do SDK em aplicativos UNIX" no site da Microsoft. (http://go.microsoft.com/fwlink/?LinkId=38959)

Para obter mais informações, consulte Subsistema para Aplicativos UNIX.

Voltar para o início


Instalando componentes opcionais e funções do servidor

Elemento gráfico do Microsoft Windows

Instalando os componentes opcionais e funções do servidor

Depois que a instalação estiver completa, você poderá instalar os componentes opcionais usando Adicionar ou Remover Componentes do Windows no Painel de Controle. Você também tem a opção de adicionar ou atualizar funções do servidor usando Gerenciar o Servidor.

Para obter mais informações, consulte Instalando os componentes opcionais e funções do servidor.


Novos recursos

O Windows Server 2003, Enterprise Edition inclui o conjunto de recursos completo do Windows Server 2003, Standard Edition e também oferece suporte para processadores com mais de 4 GB de memória e múltiplos, além de clustering. O suporte a memória e processador expandidos significa que os aplicativos de servidor podem funcionar com mais rapidez, fornecendo melhor resposta para usuários na rede. O Windows Clustering inclui várias tecnologias de clustering: Clusters de balanceamento de carga de rede e clusters de servidores. Você pode configurar essas tecnologias de cluster para trabalharem juntas e obter desempenho e alta disponibilidade para aplicativos de rede. Para obter mais informações, consulte Clusters do Windows.

  • Para obter informações sobre os componentes do Windows Server 2003 R2, consulte Novidades no Windows Server 2003 R2.
  • Para obter informações sobre recursos e componentes que trocaram de nome ou de posição, consulte Novas formas de executar tarefas conhecidas.
  • Para exibir uma tabela que compara recursos nesta versão com recursos em versões anteriores, consulte Comparação de recursos: Windows NT, Windows 2000 e a família de produtos Windows Server 2003. Esta tabela é especialmente útil se você fizer uma atualização a partir do Windows NT 4.0 ou Windows 2000 e desejar examinar as diferenças entre os recursos.
  • Para saber mais sobre os recursos que são úteis para uma função específica ou tarefa administrativa, consulte Escolhendo os recursos que são mais úteis para o servidor.
  • Para obter uma lista concisa de recursos em ordem alfabética, consulte Lista alfabética de recursos.
  • Para obter uma visão geral dos recursos nestes tópicos, consulte Visão geral de recursos.


Comparação de recursos: Windows NT, Windows 2000 e a família de produtos Windows Server 2003

A tabela a seguir apresenta uma comparação de recursos com base no seu caminho de atualização. Por exemplo, se você fizer a atualização a partir do Windows NT 4.0, selecione a opção "Windows NT 4.0 para a família de produtos Windows Server 2003" a seguir. Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

A tabela, que é categorizada por área de recurso, exibe informações sobre recursos aperfeiçoados que foram introduzidos em sistemas operacionais anteriores, além de recursos novos para esta versão.

Alguns recursos não estão disponíveis em alguns dos produtos da família Windows Server 2003. Para obter mais informações, clique nos links na tabela a seguir. Para obter informações sobre o Windows Server 2003, Web Edition, consulte Visão geral sobre o Windows Server 2003, Web Edition. Para obter informações sobre limitações de recursos em versões de 64 bits da família de produtos Windows Server 2003, consulte Recursos não disponíveis nas versões de 64 bits da família de produtos Windows Server 2003.

Clique na opção que descreve seu caminho de atualização:

Windows NT 4.0 para a família de produtos Windows Server 2003

Área de recurso Recursos que foram adicionados a partir do Windows NT 4.0 e atualizados nesta versão Recursos que são novos na família de produtos Windows Server 2003
Confiabilidade de servidor
  • Melhor gerenciamento de memória
  • Arquitetura de sistema robusta
  • Ferramentas de diagnóstico
  • Inicialização em modo de segurança
  • Console de recuperação
  • Proteção de arquivo do Windows
  • Utilitário de backup avançado
  • Recuperação automatizada do sistema (ASR)
  • Modo de compatibilidade
Disponibilidade do servidor
  • Clusters de servidor
  • Clusters de balanceamento de carga de rede
  • Poucas reinicializações de servidor
  • Plug and Play
  • Iniciar a partir de volumes espelhados
  • Ferramenta de migração de estado do usuário
  • Serviços de gerenciamento de emergência
Desempenho de servidor
  • Adaptabilidade de hardware
  • Suporte a I2O
  • Aprimoramentos de multiprocessamento simétrico
  • Balanceamento de carga de rede
  • Clusters de servidor
  • Arquitetura de memória corporativa
  • Serviços de Informações da Internet (IIS) 6.0
Gerenciabilidade do servidor
  • IntelliMirror
  • Windows Management Instrumentation (WMI)
  • Serviços de instalação remota (RIS)
  • Gerenciar o servidor
  • Área de trabalho remota para administração
  • Suporte a servidor administrado remotamente
  • Ferramenta de migração de estado do usuário
  • Serviços de gerenciamento de emergência
  • Conjunto de diretivas resultante (RSOP)
  • Gerenciador de autorização
Desempenho e ajuste
  • Winsock Direct
  • Suporte a I2O
  • Redução de uso de CPU para sites ou aplicativos da Web
  • Estatísticas de processo para sites ou aplicativos da Web
  • Qualidade de serviço (QoS) ponto a ponto previsível
  • Balanceamento de carga de rede
  • Novas ferramentas de desempenho
  • Desfragmentador de disco
  • Aprimoramentos de rastreamento de eventos
  • Opções de desempenho
  • Novos utilitários de linha de comando do Monitor do sistema
Suporte a autenticação e cartão inteligente
  • Suporte total ao protocolo Kerberos V5
  • Infra-estrutura de chave pública (PKI), Serviços de certificados e cartões inteligentes
  • Rede virtual privada
  • Autenticação e autorização flexíveis e seguras
  • Serviço de autenticação da Internet (IAS)
  • Roteamento e acesso remoto
  • Nomes de usuário e senhas armazenados
  • Acesso a cartão inteligente através do Terminal Server
Segurança
  • Sistema de arquivos com criptografia (EFS)
  • Segurança de protocolo Internet (IPSec)
  • Propriedade da porta TCP/UDP
  • Diretivas de restrição de software
Gerenciamento remoto
  • Console de Gerenciamento Microsoft (MMC)
  • Criar scripts com o Windows Script Host
  • Serviços de instalação remota (RIS)
  • Área de trabalho remota para administração
  • Assistência Remota
  • Interface da Web para administração remota (somente Windows Server 2003, Web Edition)
Manutenção e atualização de produtos
  • Windows Update
 —
Internacionalização
  • Suporte multilíngüe
  • Suporte multi-regional
  • Novo editor de método de entrada fonética (IME) para chinês tradicional
Active Directory
  • Gerenciamento simplificado de recursos de rede e usuários
  • Autenticação e autorização flexíveis e seguras
  • Consolidação de diretórios
  • Infra-estrutura e aplicativos habilitados por diretório
  • Desempenho sem complexidade
  • Uso dos padrões da Internet
  • Ambiente de desenvolvimento avançado
  • Replicação e monitoramento de relações de confiança
  • Listas de distribuição do enfileiramento de mensagens
  • Para obter uma lista dos novos recursos do Active Directory disponíveis nesta versão, consulte Novos recursos do Active Directory.
Recursos de gerenciamento de arquivos e disco
  • Gerenciamento de disco
  • Suporte a cota de disco
  • Sistema de arquivos distribuídos
  • Rastreamento de link distribuído
  • Criação e versão distribuídas (DAV)
  • Indexação de conteúdo de alto desempenho
  • Sistema de arquivos com criptografia (EFS)
  • Armazenamento removível e armazenamento remoto
  • Compartilhamento remoto de documentos
  • Suporte a linha de comando para gerenciamento de discos
  • Tabela de partições GUID (GPT) (somente versões de 64 bits)
  • Cópias de sombra de pastas compartilhadas
Suporte a protocolos e impressoras
  • Impressoras publicadas no Active Directory
  • Amplo suporte a protocolos e dispositivos
  • Plug and Play
  • Protocolo de impressão da Internet
  • Recursos de gerenciamento de impressoras
  • Recursos de impressão em rede
  • Novo suporte de linha de comando para impressão
  • Instalação simplificada de driver de impressora em clusters de servidor
Serviços e recursos de Internet e email
  • Active Server Pages (ASP)
  • Windows Media Services
  • Criação e versão distribuídas na Web (WebDAV)
  • Reciclagem de aplicativos
  • Componentes do Microsoft .NET Framework
  • Serviços de Informações da Internet (IIS) 6.0
  • Serviços UDDI
  • Serviços de email (POP3, SMTP)
  • Provedor Windows Management Instrumentation (WMI)
Colaboração
  • Windows Media Services
  • Qualidade de serviço (QoS) ponto a ponto previsível
  • Modo de transferência assíncrona (ATM)
  • Microsoft .NET Framework
  • Aceleração de áudio no servidor de acesso remoto
Suporte a sistemas existentes
  • Padrões da indústria
  • Suporte a aplicativos de servidor existentes
  • Integração com sistemas operacionais existentes
  • Modo de compatibilidade
  • Assistente de compatibilidade de programa
Suporte a aplicativos
  • A mais ampla variedade de aplicativos fechados
  • Serviços abrangentes de aplicativos da Internet
  • Acessibilidade ativa Microsoft
  • TAPI 3.1
  • Serviços de transações
  • Enfileiramento de mensagens
  • Serviços de componentes
  • Objetos de trabalho
  • Integração de dados do host
  • Modo de compatibilidade
  • Web Gardens em Serviços de Informações da Internet (IIS)
Gerenciamento e implantação
  • Gerenciamento de configuração e alteração com diretiva de grupo
  • Consolidação de pasta no Active Directory
  • IntelliMirror
  • Serviços de instalação remota (RIS)
  • Windows Management Instrumentation (WMI)
  • Compartilhamento de componentes lado a lado
  • Adicionar ou remover programas
  • Windows Installer
  • Gerenciamento de aplicativos
  • Suporte a servidor administrado remotamente
  • Conjunto de diretivas resultante (RSOP)
Terminal Server
  • Implantação centralizada de programas
  • Acesso remoto a aplicativos
  • Acesso a um único aplicativo
  • Gerenciador de serviços de terminal
  • Controle remoto
  • Redirecionamento de áudio
Suporte a desenvolvimento
  • Visual Studio .NET
  • Tecnologia multilíngüe
  • Geração automática de identificações de links
  • Serviço de transferência inteligente de plano de fundo (BITS)
Protocolos e tecnologias de rede
  • Winsock Direct
  • DHCP com DNS e Active Directory
  • Compartilhamento de conexão com a Internet (ICS)
  • Conversão de endereços de rede (NAT)
  • Rede virtual privada
  • Roteamento e acesso remoto
  • Modo de transferência assíncrona (ATM)
  • Protocolo simples de acesso a objetos (SOAP)
  • Suporte a Fibre Channel
  • Configuração automática para várias redes
  • Redirecionador de criação e versão digital na Web (WebDAV)
  • Serviço de autenticação da Internet (IAS) como proxy RADIUS
  • Redes sem fio
  • IP versão 6 (IPv6)

Windows 2000 para a família de produtos Windows Server 2003

Área de recurso Recursos que foram adicionados ao Windows 2000 e atualizados nesta versão Recursos que são novos na família de produtos Windows Server 2003
Confiabilidade de servidor —
  • Recuperação automatizada do sistema (ASR)
  • Modo de compatibilidade
Disponibilidade do servidor
  • Suporte à rede de área de armazenamento (SAN) e ao servidor de acesso à rede (NAS)
  • Aperfeiçoamentos no balanceamento de carga de rede
  • Ferramenta de migração de estado do usuário
  • Serviços de gerenciamento de emergência
Desempenho de servidor
  • Aperfeiçoamentos no balanceamento de carga de rede
  • Serviços de Informações da Internet (IIS) 6.0
Gerenciabilidade do servidor
  • Aperfeiçoamentos do Windows Management Instrumentation (WMI)
  • Aperfeiçoamentos do Servidor de instalação remota (RIS)
  • Área de trabalho remota para administração
  • Suporte a servidor administrado remotamente
  • Ferramenta de migração de estado do usuário
  • Serviços de gerenciamento de emergência
  • Conjunto de diretivas resultante (RSoP)
  • Gerenciador de autorização
Desempenho e ajuste
  • Aprimoramentos do Monitor do Sistema
  • Logs e Alertas de Desempenho
  • Opções de desempenho
  • Novos utilitários de linha de comando do Monitor do sistema
Suporte a autenticação e cartão inteligente
  • Aprimoramentos das autoridades de certificação subordinadas
  • Armazenamento de nomes de usuário e senhas
  • Acesso a cartão inteligente através do Terminal Server
Segurança
  • Aperfeiçoamentos no sistema de arquivos com criptografia (EFS)
  • Aperfeiçoamentos na monitoração da segurança do protocolo Internet (IPSec)
  • Propriedade de porta TCP/UDP
  • Diretivas de restrição de software
Gerenciamento remoto
  • Aperfeiçoamentos do Servidor de instalação remota (RIS)
  • Área de trabalho remota para administração
  • Assistência femota
  • Interface da Web para administração remota (somente Windows Server 2003, Web Edition)
Manutenção e atualização de produtos
  • Aperfeiçoamentos no Windows Update
 —
Internacionalização
  • Editor de método de entrada (IME) para japonês aprimorado
  • IME para coreano aprimorado
  • IME para chinês simplificado aprimorado
  • Novo editor de método de entrada (IME) fonética para chinês tradicional
Active Directory
  • Para obter uma lista dos novos recursos do Active Directory disponíveis nesta versão, consulte Novos recursos do Active Directory.
  • Para obter uma lista dos novos recursos do Active Directory disponíveis nesta versão, consulte Novos recursos do Active Directory.
Recursos de gerenciamento de arquivos e disco
  • Aperfeiçoamentos no gerenciamento de arquivos
  • Compartilhamento remoto de documentos
  • Suporte a linha de comando para gerenciamento de discos
  • Tabela de partições GUID (GPT) (somente versões de 64 bits)
  • Cópias de sombra de pastas compartilhadas
Suporte a protocolos e impressoras
  • Instalação simplificada de driver de impressora em clusters de servidor
  • Novo suporte de linha de comando para impressão
Serviços e recursos de Internet e email —
  • Componentes do Microsoft .NET Framework
  • Serviços de Informações da Internet (IIS) 6.0
  • Serviços UDDI
  • Serviços de email (POP3, SMTP)
  • Provedor Windows Management Instrumentation (WMI) para IIS
Colaboração
  • Aperfeiçoamentos do NetMeeting
  • Microsoft .NET Framework
  • Aceleração de áudio no servidor de acesso remoto
Suporte a sistemas existentes —
  • Modo de compatibilidade
  • Assistente de compatibilidade de programa
Suporte a aplicativos —
  • Modo de compatibilidade
  • Web Gardens em Serviços de Informações da Internet (IIS)
Gerenciamento e implantação
  • Aperfeiçoamentos do Windows Management Instrumentation (WMI)
  • Suporte a criação de scripts
  • Aperfeiçoamentos do Servidor de instalação remota (RIS)
  • Suporte a servidor administrado remotamente
  • Conjunto de diretivas resultante (RSOP)
Terminal Server
  • Aperfeiçoamentos de resolução e cor
  • Integração de Diretivas de grupo
  • Redirecionamento de áudio
Suporte a desenvolvimento —
  • Geração automática de identificações de links
  • Serviço de transferência inteligente de plano de fundo (BITS)
Protocolos e tecnologias de rede
  • Aperfeiçoamentos no Gerenciador de conexões
  • Protocolo simples de acesso a objetos (SOAP)
  • Suporte a Fibre Channel
  • Configuração automática para várias redes
  • Redirecionador de criação e versão digital na Web (WebDAV)
  • Serviço de autenticação da Internet (IAS) como proxy RADIUS
  • Redes sem fio
  • IP versão 6 (IPv6)


Escolhendo os recursos que são mais úteis para o servidor

Para saber mais sobre os recursos que são mais úteis para seu servidor de acordo com a função, consulte a tabela a seguir. Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

Função Descrição do recurso
ou tipo de suporte 		Informações sobre como usar o recurso
Servidor de arquivos
  • Active Directory
  • Recursos de gerenciamento de arquivos e disco
  • Administrando o Active Directory
  • Discos e dados
  • Computadores clientes
Servidor de impressão
  • Active Directory
  • Suporte a protocolos e impressoras
  • Administrando o Active Directory
  • Impressão
  • Impressoras e faxes
Servidor Web
  • Visão geral sobre o Windows Server 2003, Web Edition
  • Serviços e recursos de Internet e email
  • Suporte a aplicativo

    • Áreas relacionadas:
    Servidor de aplicativos
    Rede/comunicações
    Segurança de servidores
  • Serviços de Internet e email
  • Serviços de Informações da Internet (IIS) 6.0
  • Suporte a aplicativos e desenvolvimento
Servidor
multimídia
  • Recursos de colaboração
  • Usando o Windows Media Services
  • Qualidade do serviço (QoS)
  • Serviços ATM do Windows
Servidor de
aplicativos
  • Microsoft .NET Framework
  • Suporte a sistemas existentes
  • Recursos do Terminal Server
  • Suporte a aplicativo
  • Gerenciamento e implantação
  • Recursos de desempenho e ajuste
  • Suporte a desenvolvimento
  • Área de trabalho remota para administração
  • Diretivas de grupo
  • IntelliMirror
  • Ferramentas de monitoração e status
  • Qualidade do serviço (QoS)
  • Serviços ATM do Windows
  • Arquitetura de Memória Corporativa (Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition, sem incluir versões de 64 bits)
  • Clusters de balanceamento de carga de rede
  • Clusters do Windows (Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition somente)
  • Suporte a aplicativos e desenvolvimento
    Consulte também Microsoft Platform SDK. Você pode baixar o SDK no site Platform SDK Update (http://www.microsoft.com).
Rede/
comunicação
  • Protocolos e tecnologias de rede
  • Suporte a sistemas existentes
  • Recursos de desempenho e ajuste
  • Serviços de rede
  • Configurando links de comunicação
  • Ferramentas de monitoração e status
  • Qualidade do serviço (QoS)
  • Serviços ATM do Windows
Confiabilidade,
disponibilidade,
desempenho
e gerenciabilidade
do servidor
  • Confiabilidade do servidor
  • Disponibilidade do servidor
  • Desempenho do servidor
  • Gerenciabilidade do servidor
  • Discos e dados
  • Ferramentas de monitoração e status
  • Visão geral sobre Plug and Play
  • Clusters de balanceamento de carga de rede
  • Clusters do Windows (Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition somente)
Segurança
de servidor
  • Suporte a autenticação e cartão inteligente
  • Recursos de segurança adicionais
  • Segurança
  • Novos recursos de segurança
  • Autenticação
  • Internet Authentication Service (IAS) (não disponível no Windows Server 2003, Web Edition)
  • Segurança do protocolo Internet (IPSec)
Configuração
e
gerenciamento
  • Active Directory
  • Recursos do Terminal Server
  • Gerenciamento remoto

  • Recursos de gerenciamento de arquivos e disco
  • Recursos de internacionalização

    • Área relacionada:
    Servidor de arquivos
  • Computadores clientes
  • Visão geral sobre o Active Directory
  • IntelliMirror
  • Administração remota
  • Ferramentas de administração e script
  • Serviços de Instalação Remota (RIS) (não disponíveis no Windows Server 2003, Web Edition)


Lista alfabética de recursos

Esta é uma lista parcial do extenso conjunto de novos recursos incluídos na família Windows Server 2003. Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

Active Directory

O Active Directory é o serviço de diretório para Windows Server 2003, Standard Edition; Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition. Ele armazena informações sobre objetos na rede e permite que administradores e usuários localizem e utilizem essas informações com facilidade. O Active Directory usa um armazenamento estruturado de dados como base para uma organização lógica e hierárquica das informações de diretório. Para obter mais informações, consulte Active Directory.

Modo de transferência assíncrona

O modo de transferência assíncrona (ATM) é um protocolo de alta velocidade orientado a conexões e projetado para transportar vários tipos de tráfego através de uma rede. Aplica-se a redes locais (LANs) e redes de longa distância (WANs). Com o ATM, a rede pode transportar simultaneamente uma grande variedade de tráfego de rede: voz, dados, imagem e vídeo.

Recuperação automatizada do sistema

A recuperação automatizada do sistema (ASR) ajuda na recuperação do sistema em caso de falha do disco rígido ou de danos sérios ao sistema. Você pode preparar facilmente o material de backup necessário para a ASR, através dos assistentes que fazem parte do Backup. Usando a ASR juntamente com backups padrão (backups de dados e aplicativos), você pode restaurar um sistema ao estado em que se encontrava por ocasião do backup. Para obter mais informações sobre ASR, consulte Visão geral sobre a recuperação automatizada do sistema (ASR). Para obter mais informações sobre outras opções para recuperação de desastres, consulte Recuperação de desastres.

Serviços de certificados

Usando os serviços de certificados e as ferramentas de gerenciamento de certificados, você pode implantar sua própria infra-estrutura de chave pública (PKI). Com uma PKI, é possível implementar tecnologias baseadas em padrões, como recursos de logon de cartão inteligente, autenticação de clientes (através de camada de soquetes de segurança (SSL) e segurança da camada de transporte (TSL)), email seguro, assinaturas digitais e conectividade segura, (usando segurança do protocolo Internet (IPSec)). Usando os serviços de certificados, você pode configurar e gerenciar autoridades de certificação (CAs) que emitem e revogam certificados X.509 v3. Isso significa que você não precisa depender de serviços de autenticação de clientes comerciais, embora possa integrar a autenticação de clientes comerciais à sua PKI, se desejar. Para obter mais informações, consulte Serviços de certificados.

Cluster

Um cluster é um grupo de computadores independentes que trabalham juntos para executar um conjunto de aplicativos comum e fornecer a imagem de um único sistema ao cliente e ao aplicativo. Para obter mais informações, consulte "Clusters de balanceamento de carga de rede" ou "Clusters de servidores" nesta lista.

Os clusters de servidores só estão disponíveis em Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition.

Modo de compatibilidade

Um novo recurso de Modo de compatibilidade garante a compatibilidade inicial para vários aplicativos populares. A tecnologia do Modo de compatibilidade fornece um ambiente que reflete com maior semelhança o comportamento dos sistema operacionais Windows 95, Windows 98, Windows NT 4.0 ou Windows 2000. Esses modos resolvem vários dos problemas mais comuns que impedem que aplicativos antigos funcionem corretamente. Os aplicativos que apresentam problemas após a migração podem se beneficiar caso sejam iniciados em um desses ambientes de compatibilidade. Os usuários avançados também podem aproveitar essa tecnologia para criar soluções para seus próprios aplicativos.

Serviços de componentes

Os serviços de componentes são um conjunto de serviços baseados em extensões do modelo de objeto componente (COM) e no Microsoft Transaction Server (uma versão anterior de um sistema de processamento de transações baseado em componentes). Fornecem segmentação e segurança, gerenciamento de transações, pool de objetos, componentes enfileirados e administração e empacotamento de aplicativos.

Para ver a documentação completa da Ajuda para aplicativos COM+ e serviços de componentes, clique em Iniciar, aponte para Todos os Programas, clique em Ferramentas Administrativas e, em seguida, clique em Serviços de Componentes. Em Serviços de componentes, clique em Ajuda e, em seguida, clique em Tópicos da Ajuda.

Gerenciador de conexões

O Gerenciador de conexões oferece suporte para conexões locais e remotas com o seu serviço usando uma rede de pontos de acesso, como as disponíveis em todo o mundo através dos provedores de serviço de Internet. Para obter mais informações, consulte Connection Manager Administration Kit.

DHCP com DNS e Active Directory

O protocolo de configuração dinâmica de hosts (DHCP) trabalha com o DNS e o Active Directory em redes IP, ajudando a liberar você das tarefas de atribuição e controle de endereços IP estáticos. O DHCP atribui dinamicamente endereços IP a computadores ou outros recursos conectados a uma rede IP. Para obter mais informações, consulte Serviços de rede.

Gerenciamento de disco

O Gerenciamento de disco é uma ferramenta gráfica para gerenciar o armazenamento em disco que inclui recursos como:

  • Suporte a volumes dinâmicos, trabalhando fora da restrição de quatro partições por disco.
  • Gerenciamento de disco online (menos reinicializações).
  • Gerenciamento de unidade local e remota.
  • Pontos de montagem de volumes, que podem ser usados para conectar, ou montar, uma unidade local em qualquer pasta vazia a um volume local formatado pelo NTFS.

Para obter mais informações, consulte Gerenciamento de discos.

Suporte a cota de disco

Você pode usar cotas de disco em volumes formatados com o sistema de arquivos NTFS para monitorar e limitar a quantidade de espaço em disco disponível para usuários individuais. É possível definir as respostas que são geradas quando os usuários ultrapassam os limites especificados. Para obter mais informações, consulte Cotas de disco.

Serviços de email (POP3, SMTP)

O serviço POP3 (protocolo de agência de correio versão 3) fornece serviços de transferência e recuperação de emails. Os administradores podem usar o serviço POP3 para armazenar e gerenciar contas de email no servidor de email. O protocolo de transferência de correio simples (SMTP) suporta a transferência de email entre servidores. Para obter mais informações, consulte serviço POP3 e serviço do protocolo de transferência de correio simples (SMTP).

Sistema de arquivos com criptografia

O sistema de arquivos com criptografia (EFS) complementa outros controles de acesso e fornece um nível de proteção adicional aos dados. O EFS é executado como um serviço de sistema integrado, o que o torna fácil de gerenciar, difícil de atacar e transparente para o usuário. Para obter mais informações, consulte Sistema de arquivos com criptografia.

Diretiva de grupo (parte do Active Directory)

Você pode usar diretivas para definir as configurações e ações permitidas para usuários e computadores. Em contraste com a diretiva local, a diretiva de grupo pode ser usada para definir diretivas que se aplicam a um determinado site, domínio ou unidade organizacional no Active Directory. O gerenciamento baseado em diretivas simplifica tarefas como atualização do sistema operacional, instalação de aplicativos, perfis de usuário e bloqueio de sistema de área de trabalho. Para obter mais informações, consulte Diretiva de grupo.

Serviço de indexação

O serviço de indexação fornece uma maneira rápida, fácil e segura para pesquisar informações em nível local ou na rede. Os usuários podem pesquisar em arquivos de diferentes formatos e idiomas, seja com o comando Pesquisar no menu Iniciar ou por páginas em HTML exibidas em um navegador.

Serviço de autenticação da Internet

O serviço de autenticação da Internet (IAS) oferece um ponto central para gerenciamento de autenticação, autorização, estatísticas e auditoria de usuários de rede dial-up ou rede virtual privada (VPN). O IAS usa o protocolo IETF denominado RADIUS. Para obter mais informações, consulte Serviço de autenticação da Internet.

Este recurso não está incluído em computadores que executam o sistema operacional Microsoft® Windows® Server 2003, Web Edition. Para obter mais informações, consulte Visão geral sobre o Windows Server 2003, Web Edition. No Windows Server 2003, Standard Edition, é possível configurar o IAS com no máximo 50 clientes RADIUS e 2 grupos de servidores RADIUS remotos. Para obter mais informações sobre esses limites, consulte Serviço de autenticação da Internet.

Compartilhamento de conexão com a Internet

Com o recurso de compartilhamento de conexão com a Internet (ICS) do Network Connections, você pode conectar sua rede residencial ou de escritório pequeno à Internet. Por exemplo, você pode ter uma rede residencial que se conecte à Internet por uma conexão dial-up. Ao habilitar o compartilhamento de conexão com a Internet no computador que utiliza a conexão dial-up, você poderá fornecer serviços de conversão de endereços de rede, endereçamento e resolução de nomes a todos os computadores da rede. Para obter mais informações, consulte Compartilhamento de conexão com a Internet e conversão de endereços de rede.

Este recurso só está disponível em Windows Server 2003, Standard Edition e Windows Server 2003, Enterprise Edition e somente em computadores baseados em x86.

Serviços de Informações da Internet 6.0

O Serviços de Informações da Internet (IIS) 6.0 é um servidor Web completo que serve de base para a família Windows Server 2003 e para os aplicativos e serviços para Web existentes. O IIS 6.0 oferece o modo de aplicativo dedicado, que executa todo o código de aplicativos em um ambiente isolado. O IIS 6.0 também fornece suporte a ambientes Web, nos quais um conjunto de processos equivalentes, cada um em um computador, recebe uma parte das solicitações normalmente servidas por um processo único, obtendo melhor escalabilidade com vários processadores. Para obter mais informações, consulte Serviços de Informações da Internet (IIS) 6.0.

Observação

  • Por padrão, o IIS não é instalado em novas instalações de Windows Server 2003, Standard Edition; Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition. Ele pode ser adicionado usando o Assistente para configurar o servidor ou Adicionar ou remover programas.

Suporte à segurança do protocolo Internet

Você pode usar a segurança do protocolo Internet (IPSec) para proteger a comunicação em uma intranet e criar soluções seguras de rede virtual privada (VPN) pela Internet. O IPSec foi projetado pela Internet Engineering Task Force (IETF) e constitui um padrão da indústria para criptografia de tráfego TCP/IP. Para obter mais informações, consulte Segurança do protocolo Internet (IPSec).

Suporte ao protocolo Kerberos V5

O Kerberos V5 é um antigo protocolo de autenticação de rede padrão da indústria. Com o suporte a Kerberos V5, um processo único de logon rápido fornece aos usuários o acesso de que precisam aos recursos de empresa, bem como a outros ambientes que ofereçam suporte a esse protocolo. O suporte a Kerberos V5 inclui benefícios adicionais, como autenticação mútua (tanto o cliente quanto o servidor devem fornecer autenticação) e autenticação delegada (a credencial do usuário é controlada de ponta a ponta). Para obter mais informações, consulte Autenticação Kerberos V5.

Suporte a protocolo de encapsulamento de camada 2

O protocolo de encapsulamento de camada 2 (L2TP) é uma versão mais segura do protocolo de encapsulamento ponto a ponto (PPTP) e é usado para encapsulamento, atribuição de endereços e autenticação. Para obter mais informações, consulte Protocolo de encapsulamento de camada 2.

Suporte a protocolo de acesso a pastas leves

O protocolo de acesso a pastas leves (LDAP), um padrão da indústria, é o principal protocolo de acesso do Active Directory. O LDAP versão 3 foi definido pela Internet Engineering Task Force (IETF). Para obter mais informações, consulte Protocolo de acesso a pastas.

Enfileiramento de mensagens

O recurso de enfileiramento de mensagens ajuda os desenvolvedores a criar e implantar aplicativos que são executados de modo mais confiável em redes, incluindo a Internet. Esses aplicativos podem interoperar com aplicativos executados em diferentes plataformas, como mainframes e sistemas baseados em UNIX. Para obter mais informações, consulte Usando o enfileiramento de mensagens.

Console de Gerenciamento Microsoft

Você pode usar o Console de Gerenciamento Microsoft (MMC) para organizar as ferramentas e os processos administrativos em uma única interface. Também é possível delegar tarefas a usuários específicos criando consoles MMC pré-configurados para eles. Os consoles fornecem aos usuários as ferramentas que você selecionar. Para obter mais informações, consulte Console de Gerenciamento Microsoft.

Conversão de endereços de rede

A conversão de endereços de rede (NAT) oculta das redes externas os endereços IP gerenciados internamente, através da conversão de endereços internos privados em endereços externos públicos. Isso reduz os custos de registro de endereços IP ao permitir a utilização de endereços IP privados internamente, com a conversão em uma pequena quantidade de endereços IP registrados externamente. A estrutura de rede interna também é ocultada, reduzindo o risco de ataques contra os sistemas internos. Para obter mais informações, consulte Noções básicas sobre conversão de endereços de rede.

Clusters de balanceamento de carga de rede

Conhecido anteriormente como serviço de balanceamento de carga do Windows NT (WLBS), o balanceamento de carga de rede distribui o tráfego TCP/IP de entrada por vários servidores. Os aplicativos em clusters, principalmente os aplicativos de servidor Web, podem gerenciar um tráfego maior e fornecer maior disponibilidade e tempos de resposta mais rápidos. Para obter mais informações, consulte Clusters de balanceamento de carga de rede.

Migração, suporte e integração de sistemas operacionais

A família de produtos Windows Server 2003 integra-se perfeitamente aos sistemas já existentes e contém suporte a sistemas operacionais Windows anteriores e a outros sistemas operacionais bem aceitos. O seguinte suporte foi incluído:

  • Interoperabilidade com Windows NT Server 3.51 e 4.0.
  • Suporte a clientes que executam diversos sistemas operacionais, incluindo Windows 3.x, Windows 95, Windows 98, Windows 2000 e Windows NT Workstation 4.0.
  • Interoperabilidade com UNIX, fornecida através de um pacote suplementar denominado Windows Services for UNIX. Os serviços Telnet (para administração e acesso remotos) estão incluídos na família Windows Server 2003 e no pacote de complementos.
  • Conectividade com computadores mainframe e de médio porte, usando transação S/390 e AS/400, e gateways de enfileiramento através do Host Integration Server 2000.

  • Servidor de arquivos para Macintosh, que permite aos clientes Macintosh utilizarem o protocolo TCP/IP (AFP sobre IP) para compartilhar arquivos e acessar compartilhamentos em um servidor com Windows Server 2003, Standard Edition; Windows Server 2003, Enterprise Edition ou Windows Server 2003, Datacenter Edition. Para obter mais informações, consulte Serviços para Macintosh.

    Este recurso não está incluído em computadores que executam o sistema operacional Microsoft® Windows® Server 2003, Web Edition. Para obter mais informações, consulte Visão geral sobre o Windows Server 2003, Web Edition.

Plug and Play

Com o Plug and Play, uma combinação de suporte a hardware e software, o servidor reconhece as alterações de configuração de hardware e se adapta automaticamente a elas, sem a intervenção do usuário e sem reinicialização. Para obter mais informações, consulte Visão geral sobre Plug and Play.

Infra-estrutura de chave pública e infra-estrutura de cartão inteligente

Usando os serviços de certificados e as ferramentas de gerenciamento de certificados, você pode implantar sua própria infra-estrutura de chave pública (PKI). Com uma PKI, é possível implementar tecnologias baseadas em padrões, como recursos de logon de cartão inteligente, autenticação de clientes (através de camada de soquetes de segurança (SSL) e segurança da camada de transporte (TSL)), email seguro, assinaturas digitais e conectividade segura, usando segurança do protocolo Internet (IPSec). Usando os serviços de certificados, você pode configurar e gerenciar autoridades de certificação (CAs) que emitem e revogam certificados X.509 v3. Isso significa que você não precisa depender de serviços de autenticação de clientes comerciais, embora possa integrar a autenticação de clientes comerciais à sua PKI, se desejar. Para obter mais informações, consulte Serviços de certificados e Cartões inteligentes.

Qualidade de serviço

Os serviços e protocolos baseados na qualidade do serviço (QoS) oferecem um sistema de entrega expressa ponto a ponto garantida para informações através da rede. Para obter mais informações, consulte Qualidade do serviço (QoS).

Console de recuperação

Com o Console de recuperação, você pode iniciar um console de linha de comando em um sistema no qual um problema de software (com drivers ou arquivos, por exemplo) esteja impedindo a inicialização do sistema. No Console de recuperação, você pode usar comandos básicos para tentar recuperar o sistema. Para obter mais informações, consulte Visão geral sobre o Console de recuperação.

Assistência remota

Você pode usar a Assistência remota para administrar um computador remotamente. Se você tiver um convite, a Assistência Remota será uma maneira conveniente de conectar-se a um computador remoto a partir de um computador com Windows XP ou qualquer produto da família Windows Server 2003. Depois de estabelecer a conexão, você poderá exibir a tela do computador remoto e comunicar-se através de bate-papo em tempo real. Se a pessoa que solicitar assistência permitir, você poderá até usar o mouse e o teclado para trabalhar no computador remoto. Para obter mais informações, consulte Assistência remota.

XOX

Área de trabalho remota para administração

Com a Área de trabalho remota para administração (anteriormente conhecida como Serviços de terminal no Modo de administração remota), você pode administrar um computador a partir de praticamente qualquer computador da rede. Com base na tecnologia Serviços de terminal, a Área de trabalho remota para administração foi especificamente projetada para o gerenciamento de servidores. Para obter mais informações sobre esse recurso, consulte Área de trabalho remota para administração.

Serviços de instalação remota

Com os serviços de instalação remota (RIS), você pode criar imagens de instalações de sistemas operacionais ou mesmo de configurações completas de computadores, incluindo configurações de área de trabalho e aplicativos. Depois, você pode disponibilizar essas imagens aos usuários em clientes. Os clientes devem fornecer suporte à inicialização remota com a ROM de ambiente Pre-Boot eXecution (PXE) ou devem ser iniciados com um disquete de inicialização remota. Para obter mais informações, consulte Serviços de instalação remota.

Este recurso não está incluído em computadores que executam o sistema operacional Microsoft® Windows® Server 2003, Web Edition. Para obter mais informações, consulte Visão geral sobre o Windows Server 2003, Web Edition.

Armazenamento remoto

O armazenamento remoto usa critérios especificados por você para copiar automaticamente os arquivos pouco utilizados para mídias removíveis. Se o espaço em disco rígido for inferior aos níveis especificados, o armazenamento remoto removerá o conteúdo do arquivo (em cache) do disco. Se o arquivo for necessário posteriormente, o conteúdo será recuperado do armazenamento de forma automática. Para obter mais informações, consulte Armazenamento remoto.

O Armazenamento remoto não está disponível em Windows Server 2003, Web Edition ou em Windows Server 2003, Standard Edition. Para obter mais informações sobre o Windows Server 2003, Web Edition, consulte Visão geral sobre o Windows Server 2003, Web Edition.

Armazenamento removível

O armazenamento removível facilita o controle das mídias de armazenamento removíveis (fitas e discos óticos) e o gerenciamento das bibliotecas de hardware, como alteradores e jukeboxes, que contenham as mídias. Como as fitas e os discos óticos removíveis custam menos por megabyte (MB) do que os discos rígidos, o armazenamento removível e o armazenamento remoto podem reduzir os custos. Para obter mais informações, consulte Armazenamento removível.

Roteamento e acesso remoto

O Roteamento e acesso remoto substitui os recursos serviço de roteamento e acesso remoto (RRAS) e serviço de acesso remoto (RAS) contidos no Windows NT 4.0. O Roteamento e acesso remoto é um serviço único integrado que encerra conexões de clientes dial-up ou de rede virtual privada (VPN) ou que fornece roteamento (IP, IPX e serviços para Macintosh) ou ambos. Com o Roteamento e acesso remoto, seu servidor pode funcionar como um servidor de acesso remoto, um servidor VPN, um gateway ou um roteador de filial. Para obter mais informações, consulte Roteamento e acesso remoto.

Modo de segurança

Com o Modo de segurança, você pode iniciar o sistema operacional Windows com um conjunto mínimo de drivers e serviços e, em seguida, exibir um log mostrando a seqüência de eventos da inicialização. Usando o Modo de segurança, você pode diagnosticar problemas com drivers e outros componentes que podem impedir a inicialização normal. Para obter mais informações, consulte Opções de inicialização.

Assistente de Configuração de Segurança

O Assistente de Configuração de Segurança reduz a superfície de ataque dos computadores que executam o Windows Server 2003 com Service Pack 1 (SP1). Esse assistente faz uma série de perguntas ao usuário para determinar os requisitos funcionais do servidor. Qualquer funcionalidade não necessária às funções executadas pelo servidor é desabilitada. Além de ser uma prática recomendada de segurança fundamental, a redução da superfície de ataque aumenta a diversidade do cenário do Windows e reduz a quantidade de sistemas que necessitarão de atualização imediata em caso de problema de segurança. Para obter mais informações, consulte o site da Microsoft. (http://www.microsoft.com/).

Clusters de servidores (somente Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition)

Os clusters de servidores fornecem alta disponibilidade, escalabilidade e capacidade de gerenciamento para recursos e aplicativos importantes. Vários servidores (nós) em um cluster permanecem em comunicação constante. Se um dos nós no cluster não estiver disponível devido a falha ou manutenção, um outro nó começará imediatamente a fornecer o serviço (um processo conhecido como failover). Os usuários que acessam o cluster têm conexão constante com os recursos baseados em servidor.

Com Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition, é possível configurar clusters de servidores em um de três modelos de clusters disponíveis, segundo suas necessidades. Para obter mais informações, consulte Clusters de servidores.

Infra-estrutura de cartão inteligente

Usando os serviços de certificados e as ferramentas de gerenciamento de certificados, você pode implantar sua própria infra-estrutura de chave pública (PKI). Com uma PKI, é possível implementar tecnologias baseadas em padrões, como recursos de logon de cartão inteligente, autenticação de clientes (através de camada de soquetes de segurança (SSL) e segurança da camada de transporte (TSL)), email seguro, assinaturas digitais e conectividade segura, usando segurança do protocolo Internet (IPSec). Para obter mais informações, consulte Serviços de certificados e Cartões inteligentes.

Diretivas de restrição de software

Com as diretivas de restrição de software, você poderá proteger o ambiente do computador contra código não confiável, identificando e especificando quais aplicativos podem ser executados. Para obter mais informações, consulte Diretivas de restrição de software.

TAPI 3.1

O TAPI 3.1 unifica o protocolo Internet (IP) e a telefonia tradicional para permitir que os desenvolvedores criem aplicativos de telefonia computadorizada que funcionem pela Internet ou intranet com a mesma eficiência com que funcionam pela rede telefônica tradicional. Para obter mais informações, consulte Telefonia.

Terminal Server

Com o Terminal Server, um usuário pode acessar programas em execução no servidor a partir de vários dispositivos antigos. Por exemplo, um usuário pode acessar uma área de trabalho virtual do Windows XP Professional e aplicativos do Windows baseados em x86 a partir de hardwares que não podem executar o software localmente. O Terminal Server fornece esse recurso para dispositivos clientes baseados ou não no Windows. (Outros dispositivos requerem um software complementar da Citrix Systems.) Para obter uma descrição mais detalhada, consulte Recursos do Terminal Server.

Este recurso não está incluído em computadores que executam o sistema operacional Microsoft® Windows® Server 2003, Web Edition. Para obter mais informações, consulte Visão geral sobre o Windows Server 2003, Web Edition. Observe que a Área de Trabalho Remota para Administração está disponível no Windows Server 2003, Web Edition.

Serviços UDDI

UDDI é uma especificação da indústria para publicar e localizar informações sobre serviços da Web. Alguns produtos da família Windows Server 2003 incluem Serviços UDDI, um serviço da Web que fornece recursos UDDI para uso dentro de uma empresa ou entre organizações. Para obter mais informações, consulte Visão geral sobre Serviços UDDI.

Os Serviços UDDI não estão incluídos no Windows Server 2003, Web Edition. Além disso, o Windows Server 2003, Standard Edition fornece suporte apenas a instalações autônomas dos Serviços UDDI. O suporte a instalação distribuída está disponível com Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition. Em uma instalação autônoma dos Serviços UDDI, o componente de servidor Web UDDI e o componente de banco de dados UDDI são instalados em um único servidor. Em uma instalação distribuída, os componentes UDDI são distribuídos em vários servidores.

Para obter mais informações sobre o Windows Server 2003, Web Edition, consulte Visão geral sobre o Windows Server 2003, Web Edition.

Rede virtual privada

Você pode permitir que os usuários tenham acesso imediato à rede da sua organização mesmo quando estiverem fora do escritório — e reduzir o custo desse acesso — implementando uma VPN (rede virtual privada). A conexão VPN cria um encapsulamento seguro pela Internet para a rede privada.

Há dois tipos de tecnologia VPN na família Windows Server 2003:

  • O protocolo de encapsulamento ponto a ponto (PPTP), que emprega métodos de autenticação do protocolo ponto a ponto (PPP) em nível de usuário e a criptografia ponto a ponto da Microsoft (MPPE) para criptografar dados.
  • O protocolo de encapsulamento de camada 2 (L2TP) com segurança do protocolo Internet (IPSec). O L2TP usa métodos de autenticação PPP em nível de usuário e certificados em nível de computador com IPSec para criptografia de dados.

XOX

Para obter mais informações sobre redes virtuais privadas, consulte Redes virtuais privadas.

Firewall do Windows

O Firewall do Windows é uma tecnologia de firewall de host. Dessa forma, ele é executado em cada um de seus clientes e servidores, oferecendo proteção contra ataques de rede que ultrapassam sua rede de perímetro ou originados dentro da organização, como ataques do tipo cavalo de Tróia, ataques através de exame de porta e worms. Da mesma forma que várias tecnologias de firewall, o Firewall do Windows é um firewall monitorador. Conseqüentemente, ele inspeciona e filtra todo o tráfego IPv4 e IPv6. Qualquer tráfego de entrada não solicitado será ignorado, a menos que seja a resposta a uma solicitação do host (tráfego solicitado) ou seja especificamente permitido (tráfego de exceção). Você pode especificar um tráfego de exceção de acordo com o número da porta, o nome do aplicativo ou o nome do serviço, definindo as configurações do Firewall do Windows. O Firewall do Windows permite todo o tráfego de saída, exceto algumas mensagens ICMP.

Windows Media Services

O Windows Media Services fornece suporte para a distribuição de fluxo de áudio e vídeo em intranets corporativas e na Internet. Em Windows Server 2003, Enterprise Edition ou Windows Server 2003, Datacenter Edition, o Windows Media Services disponibiliza recursos de fluxo avançados, como multicasting, suporte a rede sem fio, autenticação da Internet, plug-ins de servidor e APIs de Cache/Proxy.

O Windows Media Services não é incluído no Windows Server 2003, Web Edition ou nas versões de 64 bits da família de produtos Windows Server 2003.

Host de scripts do Windows

Usando o host de scripts do Windows (WSH), você pode automatizar ações como criar um atalho e conectar-se e desconectar-se de um servidor de rede. O WSH independe da linguagem: você pode criar scripts em linguagens comuns como Microsoft Visual Basic, Scripting Edition e JScript. Para obter mais informações, consulte Host de scripts do Windows.

Windows Update

O Windows Update é uma extensão online do Windows que detecta arquivos de sistema do Windows desatualizados e os substitui pelas versões mais recentes. O Windows Update pode aumentar significativamente a estabilidade do sistema de computadores por um longo período. Ele também reduz a carga sobre administradores e equipe de suporte encarregados da manutenção de um ambiente operacional produtivo. O Windows Update requer conexão com a Internet. Para obter mais informações, consulte Windows Update e Usando Windows Update.

Winsock Direct

O Winsock Direct, agora disponível em todas as edições de servidores, permite que aplicativos utilizem o Winsock de forma mais rápida e com menor sobrecarga quando se comunicam através de uma rede de área do sistema (SAN). Se houver uma SAN em uso, o Winsock Direct atua agilizando a comunicação entre os componentes distribuídos. Para obter mais informações sobre o Winsock Direct, consulte o "Appendix B: Windows Server 2003 Network Architecture" (em inglês) do manual Internetworking Guide no site do Windows Deployment and Resource Kits (http://www.microsoft.com/).


Visão geral sobre recursos

Esta seção fornece informações sobre recursos novos e aperfeiçoados nos sistemas operacionais da família Microsoft® Windows® Server 2003. Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

Esta seção aborda:

  • Recursos para gerenciamento, segurança e melhor desempenho
  • Recursos para serviços de arquivos, impressão e colaboração
  • Recursos para serviços de Internet, aplicativos e rede

Observação

  • Para obter informações sobre os componentes do Windows Server 2003 R2, consulte Novidades no Windows Server 2003 R2.


Recursos para gerenciamento, segurança e melhor desempenho

Os recursos na família Windows Server 2003 asseguram que o acesso, o armazenamento e a troca de dados atendam às suas necessidades e também ofereçam grande segurança e desempenho.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

Esta seção aborda:

  • Confiabilidade de servidor
  • Disponibilidade do servidor
  • Desempenho de servidor
  • Gerenciabilidade do servidor
  • Recursos de desempenho e ajuste
  • Suporte a autenticação e cartão inteligente
  • Recursos de segurança adicionais
  • Gerenciamento remoto
  • Manutenção e atualização de produtos
  • Recursos de internacionalização

Observação

  • Para obter informações sobre os componentes do Windows Server 2003 R2, consulte Novidades no Microsoft Windows Server 2003 R2.


Confiabilidade de servidor

Este tópico contém uma visão geral sobre os recursos que oferecem suporte a confiabilidade do servidor. Está dividido em duas seções: Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

Confiabilidade é a probabilidade de um sistema de computadores ou dispositivo continuar a funcionar por determinado período e sob condições especificadas. Para obter descrições dos recursos relacionados à disponibilidade, que está relacionada à confiabilidade, consulte Disponibilidade de servidor.

Recursos novos e atualizados a partir do Windows NT 4.0

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows NT) que ajudam a oferecer níveis superiores de confiabilidade de servidor:

Melhor gerenciamento de memória
Os aperfeiçoamentos no gerenciamento de memória tanto no Windows 2000 quanto na família de produtos Windows Server 2003 significam mais velocidade, confiabilidade e flexibilidade para os servidores.
Arquitetura de sistema robusta
Um sistema robusto fornece maior confiabilidade, mesmo que algum aplicativo ou serviço encontre problemas. Por exemplo, com melhor tratamento de aplicativos que não respondem, você pode mover, redimensionar, minimizar e fechar a janela de um aplicativo que não esteja respondendo. Além disso, caso um driver atualizado não funcione adequadamente, é possível restaurar os drivers anteriores. A infra-estrutura de suporte ao sistema garante que os aplicativos que funcionavam em sistemas operacionais Windows anteriores continuarão a funcionar na família de produtos Microsoft® Windows® Server 2003.
Ferramentas de diagnóstico
Você pode monitorar os estados do sistema e impedir problemas usando as ferramentas de diagnóstico aprimoradas, incluídas nesta versão. Para obter mais informações, consulte Ferramentas de monitoração e status.
Inicialização em modo de segurança
Com o modo de segurança, você pode iniciar o sistema operacional com um conjunto mínimo de drivers e serviços e, em seguida, exibir um log mostrando a seqüência de eventos da inicialização. Usando o Modo de segurança, você pode diagnosticar problemas com drivers e outros componentes que podem impedir a inicialização normal. Para obter mais informações, consulte Recuperação de desastres.
Console de recuperação
Com o Console de recuperação, você pode iniciar um console de linha de comando em um sistema no qual um problema de software (com drivers ou arquivos, por exemplo) esteja impedindo a inicialização do sistema. No Console de recuperação, você pode usar os comandos básicos para tentar recuperar o sistema. Para obter mais informações, consulte Visão geral sobre o Console de recuperação.
Proteção de arquivos do Windows
A Proteção de arquivos do Windows evita a substituição de arquivos protegidos do sistema, como os arquivos .sys, .dll, .ocx, .ttf, .fon e .exe. A Proteção de arquivos do Windows é executada em segundo plano e impede que outros programas alterem esses arquivos necessários ao sistema operacional. Para obter mais informações, consulte Proteção de arquivos do Windows.
Utilitário de backup avançado
Você pode fazer backup dos dados em diversas mídias de armazenamento, como unidades de fita, discos rígidos externos e discos Zip. Para obter mais informações, consulte Backup e restauração de dados.

Recursos novos e atualizados a partir do Windows 2000

A família Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows 2000) que ajudam a oferecer níveis superiores de confiabilidade de servidor:

Recuperação automatizada do sistema
A recuperação automatizada do sistema (ASR) ajuda na recuperação do sistema no caso de falha do disco rígido ou de danos sérios ao sistema. Você pode preparar facilmente o material de backup necessário para a ASR, através dos assistentes que fazem parte do Backup. Usando a ASR juntamente com backups padrão (backups de dados e aplicativos), você pode restaurar um sistema ao estado em que se encontrava por ocasião do backup. Para obter mais informações sobre ASR, consulte Visão geral sobre a recuperação automatizada do sistema (ASR). Para obter mais informações sobre outras opções para recuperação de desastres, consulte Recuperação de desastres.
Modo de compatibilidade
Um novo recurso de Modo de compatibilidade garante a compatibilidade inicial para vários aplicativos populares. A tecnologia do Modo de compatibilidade fornece um ambiente que reflete com maior semelhança o comportamento dos sistema operacionais Windows 95, Windows 98, Windows NT 4.0 ou Windows 2000. Esses modos resolvem vários dos problemas mais comuns que impedem que aplicativos antigos funcionem corretamente. Os aplicativos que apresentam problemas após a migração podem se beneficiar caso sejam iniciados em um desses ambientes de compatibilidade. Os usuários avançados também podem aproveitar essa tecnologia para criar soluções para seus próprios aplicativos.


Disponibilidade do servidor

Este tópico contém uma visão geral sobre os recursos que oferecem suporte a disponibilidade de servidor. Está dividido em duas seções: Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

A disponibilidade é um nível de serviço fornecido por aplicativos, serviços ou sistemas. Os sistemas altamente disponíveis têm tempos de paralisação mínimos, sejam eles planejados ou não. A família Windows Server 2003 oferece suporte a altos níveis de disponibilidade de servidor para suas soluções corporativas críticas. Este sistema operacional também fornece clustering, recursos avançados de tolerância a falhas e recuperação do sistema de arquivos.

Recursos novos e atualizados a partir do Windows NT 4.0

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows NT) que ajudam a oferecer níveis superiores de disponibilidade de servidor:

Clusters de servidores (somente Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition)
Os clusters de servidores fornecem alta disponibilidade, escalabilidade e capacidade de gerenciamento para recursos e aplicativos importantes. Vários servidores (nós) em um cluster permanecem em comunicação constante. Se um dos nós no cluster não estiver disponível devido a falha ou manutenção, um outro nó começará imediatamente a fornecer o serviço (um processo conhecido como failover). Os usuários que acessam o cluster têm conexão constante com os recursos baseados em servidor. Para obter mais informações, consulte Clusters do Windows.
Balanceamento de carga de rede
O Balanceamento de carga de rede aumenta a disponibilidade e a escalabilidade de programas de servidores da Internet em servidores de missão crítica. As duas principais funções do Balanceamento de carga de rede consistem em fornecer alta disponibilidade para programas de servidor Web e adaptar o desempenho do servidor. Combinando os recursos de dois ou mais computadores em um único cluster, o Balanceamento de carga de rede fornece confiabilidade e desempenho distribuindo o tráfego de entrada da rede. Para obter mais informações, consulte Visão geral sobre rede e balanceamento de carga.
Poucas reinicializações de servidor
A configuração de hardware e software fica mais fácil porque várias atividades podem ser executadas sem que o servidor tenha que ser reiniciado. Essas atividades incluem, mas não estão limitadas a:
  • Estender um volume de armazenamento
  • Configurar protocolos de rede
  • Gerenciar o armazenamento de forma dinâmica (Gerenciamento de volume dinâmico).
  • Redefinir configurações na interconexão de componentes periféricos (PCI) e outro hardware Plug and Play.
Plug and Play
Com o Plug and Play, uma combinação de suporte a hardware e software, o servidor reconhece as alterações de configuração de hardware e se adapta automaticamente a elas, sem a intervenção do usuário e sem reiniciar. Com o Plug and Play, as reinicializações de sistema planejadas são reduzidas em mais de 90 por cento.
Iniciar a partir de volumes espelhados
Com a preparação apropriada, você pode iniciar o servidor a partir de uma cópia redundante de dados em um volume espelhado, o que aumenta a disponibilidade do sistema durante a recuperação de servidores ou na manutenção planejada. Para obter mais informações, consulte Usando volumes espelhados.

Recursos novos e atualizados a partir do Windows 2000

A família Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows 2000) que ajudam a oferecer níveis superiores de disponibilidade de servidor:

Ferramenta de migração de estado do usuário
A ferramenta de migração de estado do usuário (USMT) ajuda na implantação capturando e restaurando as configurações, os arquivos e os documentos do usuário. Os usuários não precisam redefinir as configurações da área de trabalho para itens como, por exemplo, servidores de email, servidores proxy, esquemas de cores e papel de parede da área de trabalho.
Serviços de gerenciamento de emergência
Com os Serviços de gerenciamento de emergência, combinados com o hardware apropriado, você pode executar o gerenciamento remoto e as tarefas de recuperação do sistema, mesmo quando o servidor não está disponível através de ferramentas e mecanismos padrão de administração remota. Para obter mais informações, consulte Serviços de gerenciamento de emergência.
Suporte à rede de área de armazenamento e ao servidor de acesso à rede
O suporte à rede de área de armazenamento e ao servidor de acesso à rede (NAS) na família Windows Server 2003 dispõe de vários novos aperfeiçoamentos de sistema que aumentam a disponibilidade do servidor. Esses aprimoramentos incluem tolerância a falhas, cenários conectados à rede, como a conexão com servidores SAN e NAS. Durante a conexão com SANs, a família de produtos Windows Server 2003 oferece suporte a failover de vários caminhos, o que ativa caminhos redundantes a partir do servidor host (que execute o Windows 2000 Server, Windows 2000 Advanced Server, Windows 2000 Datacenter Server ou qualquer produto da família Windows Server 2003) até o volume SAN. Há também suporte na família Windows Server 2003 para conexão com NAS bem como para uso como um NAS.
Aperfeiçoamentos no balanceamento de carga de rede
Vários aprimoramentos foram feitos ao Balanceamento de carga de rede nesta versão:
  • O Balanceamento de carga de rede pode agora ser vinculado a vários adaptadores de rede, o que permite configurar vários clusters independentes em cada host. Para obter mais informações sobre clusters virtuais, consulte Clusters virtuais.
  • O Balanceamento de carga de rede utiliza o suporte ao protocolo de gerenciamento de grupos da Internet (IGMP) para limitar a saturação do comutador, de forma que o tráfego direcionado a um cluster de balanceamento de carga de rede passe somente pelas portas que servem aos hosts de clusters e não por todas as portas de comutação.
  • Com o Gerenciador de balanceamento de carga de rede, você pode criar novos clusters de balanceamento de carga de rede, além de configurar e gerenciar clusters e todos os respectivos hosts, em um único computador remoto ou local.


Desempenho de servidor

Este tópico contém uma rápida visão geral sobre os recursos que oferecem suporte a desempenho de servidor. Está dividido em duas seções: Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

Desempenho é a medida que determina como um computador, serviço ou aplicativo pode atender melhor às necessidades crescentes de performance. No caso de clusters de servidores, o desempenho é a capacidade de adicionar incrementalmente um ou mais sistemas a um cluster existente quando a carga total sobre o cluster excede seus recursos. Os produtos da família Windows Server 2003 podem ser escalonados de pequenos grupos de trabalho a implantações de centros de dados empresariais e oferecem suporte a até 64 processadores e E/S avançadas. A família Windows Server 2003 também integra balanceamento de carga de rede e otimizações de multiprocessadores aos aplicativos corporativos.

Recursos novos e atualizados a partir do Windows NT 4.0

A família Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows NT) que ajudam a oferecer níveis superiores de desempenho de servidor:

Desempenho de hardware
Ao escolher produtos da família Windows Server 2003, você pode se beneficiar do número crescente de computadores com multiprocessadores a preços competitivos.
Suporte a I2O
A arquitetura I2O (também chamada de Entrada/Saída Inteligente) fornece maior desempenho de E/S nos servidores, transferindo a carga de determinadas operações de E/S para um processador secundário. A I2O melhora o desempenho de E/S em aplicativos de largura de banda alta, como vídeo de rede, groupware e processamento de cliente/servidor.
Aprimoramentos de multiprocessamento simétrico
A família Windows Server 2003 oferece suporte a várias CPUs que atendam ao padrão SMP (multiprocessamento simétrico). Com o SMP, o sistema operacional pode executar segmentos em qualquer processador disponível, o que possibilita aos aplicativos usarem vários processadores quando mais energia de processamento é necessária para aumentar a capacidade do sistema. Novos recursos incluem o desempenho de bloqueio SMP, melhor desempenho do Registro e maior número de sessões do Terminal Server.
Balanceamento de carga de rede
Conhecido anteriormente como Serviço de balanceamento de carga do Windows NT (WLBS), o Balanceamento de carga de rede distribui o tráfego TCP/IP de entrada por vários servidores. Os aplicativos em clusters, principalmente os aplicativos de servidor Web, podem gerenciar um tráfego maior e fornecer maior disponibilidade e tempos de resposta mais rápidos.
Cluster de servidores (somente XOX e XOX)
Os clusters de servidores fornecem alta disponibilidade, desempenho e capacidade de gerenciamento para recursos e aplicativos importantes. Vários servidores (nós) em um cluster permanecem em comunicação constante. Se um dos nós no cluster não estiver disponível devido a falha ou manutenção, um outro nó começará imediatamente a fornecer o serviço (um processo conhecido como tolerância a falhas). Os usuários que acessam o cluster têm conexão constante com os recursos baseados em servidor. Para obter mais informações, consulte Clusters do Windows.
Arquitetura de memória corporativa (XOX e XOX, sem incluir versões de 64 bits)
Com a Arquitetura de memória corporativa, você pode executar aplicativos que se beneficiam de grandes quantidades de memória física no XOX. Com o uso de aplicativos criados com a API de extensões de janela de endereço (AWE), você pode mapear mais memória física para o espaço de memória de endereço virtual dos aplicativos, e obter melhor desempenho. No caso de sistemas com memória de 2 GB a 4 GB, também é possível utilizar um ajuste de memória de aplicativo, também conhecido como ajuste de 4 gigabytes (4GT). Isso permite fornecer até 3 GB de sua memória de endereço virtual para aplicativos (fornecendo menos memória ao sistema operacional).

Recursos novos e atualizados a partir do Windows 2000

A família Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows 2000) que ajudam a oferecer níveis superiores de desempenho de servidor:

Serviços de Informações da Internet 6.0
O Serviços de Informações da Internet (IIS) 6.0 é um servidor Web completo que serve de base para a família Windows Server 2003 e para os aplicativos e serviços para Web existentes. O IIS 6.0 oferece o modo de aplicativo dedicado, que executa todo o código de aplicativos em um ambiente isolado. O IIS 6.0 também fornece suporte a Ambientes Web, em que os processos equivalentes em um computador recebem um compartilhamento das solicitações que são normalmente atendidas por um único processo, alcançando melhor desempenho de multiprocessadores. Para obter mais informações, consulte Serviços de Informações da Internet (IIS) 6.0.

Observação

  • Por padrão, o IIS não é instalado em novas instalações de XOX XOX e XOX. Ele pode ser adicionado usando o Assistente para configurar o servidor ou Adicionar ou remover programas.
Aperfeiçoamentos no balanceamento de carga de rede
Vários aprimoramentos foram feitos ao Balanceamento de carga de rede nesta versão:
  • O Balanceamento de carga de rede pode agora ser vinculado a vários adaptadores de rede, o que permite configurar vários clusters independentes em cada host. Para obter mais informações sobre clusters virtuais, consulte Clusters virtuais.
  • O Balanceamento de carga de rede utiliza o suporte ao protocolo de gerenciamento de grupos da Internet (IGMP) para limitar a saturação do comutador, de forma que o tráfego direcionado a um cluster de Balanceamento de carga de rede passe somente pelas portas que servem aos hosts de clusters e não por todas as portas de comutação.
  • Com o Gerenciador de balanceamento de carga de rede, você pode criar novos clusters de Balanceamento de carga de rede, além de configurar e gerenciar clusters e todos os respectivos hosts, em um único computador remoto ou local.


Gerenciabilidade do servidor

Este tópico contém uma visão geral sobre os recursos que fornecem suporte a gerenciamento de servidores. Está dividido em duas seções: Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

O melhor gerenciamento na família Windows Server 2003 facilita a implantação e a manutenção de aplicativos e sistemas Windows.

Recursos novos e atualizados a partir do Windows NT 4.0

A família Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows NT) que ajudam a oferecer níveis superiores de gerenciamento de servidores:

IntelliMirror
Para ajudar a reduzir custos, os administradores precisam de níveis mais altos de controle em sistemas portáteis e de mesa. O IntelliMirror fornece esse controle em sistemas cliente que executam o Windows 2000 Professional ou o Windows XP Professional. Você pode usar o IntelliMirror para definir configurações de diretiva baseadas em funções comerciais, membros de grupo e locais. Com essas configurações de diretivas, as áreas de trabalho do Windows 2000 Professional e do Windows XP Professional serão reconfiguradas automaticamente para atender aos requisitos de um usuário específico sempre que ele fizer logon na rede, independentemente do local de acesso. Para obter mais informações sobre o IntelliMirror, consulte IntelliMirror.
WMI (Instrumentação de gerenciamento do Windows)
O WMI é uma infra-estrutura de gerenciamento escalonável baseada na iniciativa de gerenciamento de empresas pela Web (WBEM). Com o WMI, o que inclui recursos de linha de comando e de criação de script, você pode monitorar e controlar os eventos do sistema relacionados a aplicativos, componentes de hardware e redes. O WMI inclui uma API de criação de scripts uniforme que define todos os objetos gerenciados sob uma estrutura de objetos comum baseada no modelo CIM (modelo de informações comuns). O WMI possibilita que aplicativos e scripts descubram quais informações estão disponíveis para um sistema, enumerando as classes disponíveis. O WMI pode enviar consultas que filtram solicitações referentes a informações bem específicas e pode assinar eventos WMI com base em seus interesses particulares, em vez de ficar limitado aos eventos predefinidos pelos desenvolvedores originais. Para obter mais informações sobre o WMI, consulte Visão geral sobre o WMI.
Ferramenta de migração do Active Directory
A Ferramenta de migração do Active Directory (ADMT) pode ajudar na migração de contas de usuários, grupos e contas de computador de domínios do Windows NT 4.0 para os domínios do Active Directory (ou seja, domínios nos quais os controladores de domínio executem o Windows 2000 ou Windows Server 2003). Para obter mais informações, consulte Ferramentas de suporte do Active Directory e Projetando e implantando serviços de diretório e segurança no site Microsoft Windows Resource Kits. (http://www.microsoft.com/).
Serviços de instalação remota
Com os serviços de instalação remota (RIS), você pode criar imagens de instalações de sistemas operacionais ou mesmo de configurações completas de computadores, incluindo configurações de área de trabalho e aplicativos. Depois, você pode disponibilizar essas imagens aos usuários em computadores clientes. Os clientes devem fornecer suporte à inicialização remota com a ROM de ambiente Pre-Boot eXecution (PXE) ou devem ser iniciados com um disquete de inicialização remota. Para obter mais informações, consulte Serviços de instalação remota.

Este recurso não está incluído em computadores que executam o sistema operacional Microsoft® Windows® Server 2003, Web Edition. Para obter mais informações, consulte Visão geral sobre o Windows Server 2003, Web Edition.

Gerenciar o servidor
O Assistente para gerenciar o servidor fornece um local central para configurar várias funções de servidor e executar tarefas adminisrativas diárias. Para obter mais informações, consulte Configurando funções para o servidor.

Recursos novos e atualizados a partir do Windows 2000

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows 2000) que ajudam a oferecer níveis superiores de gerenciamento de servidores:

Área de trabalho remota para administração
Com a Área de trabalho remota para administração (anteriormente conhecida como Serviços de terminal no Modo de administração remota), você pode administrar um computador a partir de praticamente qualquer computador da rede. Com base na tecnologia Serviços de terminal, a Área de trabalho remota para administração foi projetada especificamente para o gerenciamento de servidores. Para obter mais informações sobre esse recurso, consulte Área de trabalho remota para administração.
Suporte a servidor administrado remotamente
O suporte ao servidor administrado remotamente fornece a capacidade de instalar e gerenciar um computador que não dispõe de monitor, adaptador de vídeo VGA, teclado nem mouse. Este recurso também inclui os Serviços de gerenciamento de emergência, que fornecem um mecanismo para gerenciar o servidor administrado remotamente quando o sistema operacional não está em operação, como, por exemplo, quando o computador é reinicializado, quando o servidor fica indisponível em uma rede ou durante o uso dos Serviços de instalação remota.
Ferramenta de migração de estado do usuário
A ferramenta de migração de estado do usuário (USMT) ajuda na implantação capturando e restaurando as configurações, os arquivos e os documentos do usuário. Os usuários não precisam redefinir as configurações da área de trabalho para itens como, por exemplo, servidores de email, servidores proxy, esquemas de cores e papel de parede da área de trabalho.
Serviços de gerenciamento de emergência
Com os Serviços de gerenciamento de emergência, combinados com o hardware apropriado, você pode executar o gerenciamento remoto e as tarefas de recuperação do sistema, mesmo quando o servidor não está disponível através de ferramentas e mecanismos de administração remota padrão. Para obter mais informações, consulte Serviços de gerenciamento de emergência.
Conjunto de diretivas resultante
Você pode usar o conjunto de diretivas resultante (RSoP) para simular e testar as configurações de diretivas aplicadas aos computadores ou usuários através de diretivas de grupo. O RSoP é um mecanismo de consulta que controla as diretivas existentes, e também as diretivas planejadas, informando os resultados das consultas. Ele monitora as diretivas existentes com base no site, no domínio, no controlador de domínio e na unidade organizacional. O RSoP reúne essas informações a partir do WMI. Para obter mais informações, consulte Conjunto de diretivas resultante.
Aperfeiçoamentos do WMI
A filtragem do WMI aprimora a infra-estrutura de diretiva de grupo ajudando você a determinar o efeito de um objeto de diretiva de grupo (GPO).
Aperfeiçoamentos nos serviços de instalação remota
Os aperfeiçoamentos no RIS incluem suporte para instalações da família Windows Server 2003 e de produtos do Windows XP, mais controle sobre o processamento de arquivos de resposta para uma instalação RIS e acesso a arquivos de rede em modos de recuperação.

Este recurso não está incluído em computadores que executam o sistema operacional Microsoft® Windows® Server 2003, Web Edition. Para obter mais informações, consulte Visão geral sobre o Windows Server 2003, Web Edition.

Gerenciador de autorização
O Gerenciador de autorização é uma nova ferramenta para tarefas relacionadas a autorização. É útil para desenvolvedores de aplicativos que utilizam serviços de autorização em seus aplicativos e administradores que definem grupos e designam objetos de segurança para desempenhar funções e tarefas que requeiram direitos de usuário e permissões apropriados. Para obter mais informações, consulte Gerenciador de autorização.


Recursos de desempenho e ajuste

Este tópico contém uma rápida visão geral sobre os recursos de desempenho e ajuste na família Windows Server 2003. Ele está dividido em duas seções: Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

Novos recursos da família Windows Server 2003 proporcionam melhor desempenho e a capacidade de ajustar o servidor a suas necessidades e seu ambiente. Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

Recursos novos e atualizados a partir do Windows NT 4.0

A família Windows Server 2003 fornece os seguintes aperfeiçoamentos (em comparação com o Windows NT 4.0) que ajudam a oferecer níveis superiores de desempenho de servidor:

Winsock Direct
O Winsock Direct permite que os aplicativos utilizem o Winsock para apresentar um desempenho mais rápido e com menor sobrecarga da CPU quando se comunicam por uma rede de área do sistema (SAN). O Winsock Direct agiliza a comunicação entre os componentes distribuídos, se houver uma SAN instalada.
Suporte a I2O
A arquitetura I2O (também chamada de Entrada/saída inteligente) fornece maior desempenho de entrada/saída (E/S) nos servidores, descarregando determinadas operações de E/S em um processador secundário. A I2O melhora o desempenho de E/S em aplicativos de largura de banda alta, como vídeo de rede, groupware e processamento de cliente/servidor.
Regulagem da CPU para sites e aplicativos da Web
A regulagem da CPU limita o período de utilização da CPU por um site ou um aplicativo da Web, o que garante que o tempo do processador esteja disponível para outros sites ou aplicativos que não sejam da Web.
Contabilização de processos para sites e aplicativos da Web
Com as estatísticas de processo, você pode obter informações sobre como os sites da Web usam os recursos da CPU. Essas informações podem ser essenciais na tomada de decisões sobre como alterar ou aprimorar hardware ou aplicativos. Também podem ser importantes ao monitorar ou diagnosticar problemas com scripts ou aplicativos.
Qualidade de serviço ponto a ponto previsível
Os serviços e os protocolos baseados na QoS (qualidade do serviço) oferecem um sistema de entrega expressa garantida, ponta a ponta, para o tráfego gerado por programas ativados por QoS em uma rede ou em várias redes distintas. Para obter mais informações, consulte Qualidade do serviço (QoS).
Balanceamento de carga de rede
Conhecido anteriormente como Serviço de balanceamento de carga do Windows NT (WLBS), o Balanceamento de carga de rede distribui o tráfego TCP/IP de entrada por vários servidores. Os aplicativos em clusters, principalmente os aplicativos de servidor Web, podem gerenciar um tráfego maior e fornecer maior disponibilidade e tempos de resposta mais rápidos.
Novas ferramentas de desempenho
Várias novas ferramentas de desempenho estão disponíveis para ajudá-lo a diagnosticar e resolver problemas de memória, Registro, driver e outros problemas do sistema.
Desfragmentador de disco
Os aprimoramentos do Desfragmentador de disco incluem o Defrag.exe, uma nova ferramenta de linha de comando. Tanto o Desfragmentador de disco quanto o Defrag.exe podem agora desfragmentar a tabela mestra de arquivos (MFT) em volumes NTFS. Para obter mais informações, consulte Desfragmentador de disco.
Aprimoramentos de rastreamento de eventos
O rastreamento de eventos fornece um mecanismo para gerenciar os dados úteis para monitores de desempenho, ferramentas de planejamento de capacidade e outros aplicativos que analisam as informações relacionadas à utilização dos recursos do sistema. Novas ferramentas de linha de comando controlam a programação, coleta e análise do log de rastreamento de eventos em computadores locais e remotos.

Recursos novos e atualizados a partir do Windows 2000

A família Windows Server 2003 fornece os seguintes aperfeiçoamentos (em comparação com o Windows 2000) que ajudam a oferecer níveis superiores de desempenho de servidor:

Opções de desempenho
Opções de desempenho é uma ferramenta que consolida as configurações de processador, memória e memória virtual, de modo que você possa configurar de forma rápida e fácil um computador para obter melhor desempenho.
Novos utilitários de linha de comando do Monitor do sistema
Novas ferramentas de linha de comando são fornecidas para controlar o contador de desempenho e a programação do log de rastreamento de eventos, bem como a coleta e análise em computadores locais e remotos, sem usar o Monitor do sistema (Sysmon). Essas ferramentas de linha de comando incluem logman, relog, tracerpt e typeperf. Para obter mais informações, consulte Logman, Relog, Tracerpt e Typeperf.
Aprimoramentos do Monitor do sistema
A família de produtos Windows Server 2003 oferece suporte à exibição de dados a partir de vários arquivos de log simultaneamente e a partir de dados armazenados em um banco de dados SQL que tenha sido coletado com uso do serviço Logs e Alertas de Desempenho. Os dados selecionados em um arquivo de log de desempenho ou banco de dados SQL podem ser salvos em um novo arquivo para análise posterior. Os aprimoramentos de exibição facilitam a seleção de vários objetos de contador e a exibição da página de propriedades de dados de um contador selecionado, diretamente na janela de lista.
Aprimoramentos em logs e alertas de desempenho
A família Windows Server 2003 oferece suporte a arquivos de log com mais de 1 GB e, com o novo formato de arquivo de log, os dados de desempenho agora podem ser acrescentados a um arquivo de log existente. Você pode fazer log de dados diretamente em um banco de dados SQL através de conexões de dados de conectividade aberta de banco de dados (ODBC).
Aprimoramentos do gerenciador de memória do Windows
Como parte do desenvolvimento do Windows Server 2003, foram feitas alterações no Gerenciador de memória com o objetivo de aprimorar as operações de paginação. O Gerenciador de memória sempre tenta manter a memória física da forma mais flexível possível. Portanto, todas as alterações feitas na memória serão gravadas no disco sempre que houver tempo, tornando essa parte da memória física disponível a todos os componentes em execução no sistema. Essa operação é chamada de "saída de página" e ocorrerá de forma proativa mesmo que o sistema não esteja com pouca memória.

No Windows Server 2003, houve um aumento da eficiência das operações de paginação. Como resultado, os aplicativos que dependem bastante dessas operações são executados com mais rapidez e a taxa das operações aumenta nos discos rígidos conectados.

Você pode monitorar as operações de saída de página usando o objeto de monitoramento de desempenho "Memória / Saída de páginas/s." Um aumento nesse contador indica simplesmente uma maior atividade da memória do sistema, e não necessariamente uma condição de memória insuficiente.

Se desejar monitorar a condição de memória insuficiente no sistema, utilize os contadores "Memória / Bytes disponíveis" junto com a operação de paginação inversa "Memória / Entrada de páginas/s" para obter melhores resultados.

Para obter mais informações, consulte o Windows Server TechCenter (http://www.microsoft.com/).


Suporte a autenticação e cartão inteligente

Este tópico contém uma rápida visão geral sobre os recursos de suporte a autenticação e cartão inteligente nesta versão. Está dividido em duas seções: Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

A família de produtos Windows Server 2003 oferece uma grande variedade de tecnologias de autenticação, incluindo tecnologias para o uso de cartões inteligentes. Para obter mais informações sobre novos recursos de segurança, consulte Novos recursos em segurança.

Recursos novos e atualizados a partir do Windows NT 4.0

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows NT 4.0) que ajudam a fornecer níveis superiores de suporte à autenticação e ao uso de cartões inteligentes:

Suporte total ao protocolo Kerberos V5
Com o suporte a Kerberos V5, um processo de logon único e rápido proporciona aos usuários o acesso que precisam a recursos da empresa que executam o Windows 2000 ou a família de produtos Windows Server 2003. O suporte a Kerberos V5 inclui benefícios adicionais, como autenticação mútua (tanto cliente quanto servidor devem fornecer autenticação) e autenticação delegada (a credencial do usuário é controlada ponto a ponto). Para obter mais informações, consulte Autenticação Kerberos V5.
Infra-estrutura de chave pública, serviços de certificados e cartões inteligentes
Usando os serviços de certificados e as ferramentas de gerenciamento de certificados, você pode implantar sua própria infra-estrutura de chave pública. Com a PKI, é possível implementar tecnologias baseadas em padrões, como recursos de logon de cartão inteligente, autenticação de clientes (através da camada de soquetes de segurança (SSL) e da segurança da camada de transporte (TSL)), email seguro, assinaturas digitais e conectividade segura, usando segurança do protocolo Internet (IPSec). Usando os serviços de certificados, você pode configurar e gerenciar autoridades de certificação (CAs) que emitem e revogam certificados X.509 v3. Isso significa que você não depende de serviços de autenticação de clientes comerciais, embora possa integrar a autenticação de cliente comercial à infra-estrutura de chave pública se desejar.
Rede virtual privada
Você pode permitir que os usuários tenham acesso imediato à rede da sua organização mesmo quando estiverem fora do escritório – e reduzir o custo desse acesso – implementando uma rede virtual privada (VPN). A conexão VPN cria um encapsulamento seguro pela Internet para a rede privada.

Há dois tipos de tecnologia VPN na família de produtos Windows Server 2003:

  • O protocolo de encapsulamento ponto a ponto (PPTP), que emprega métodos de autenticação do protocolo ponto a ponto (PPP) em nível de usuário e a criptografia ponto a ponto da Microsoft (MPPE) para criptografar dados.
  • O protocolo de encapsulamento de camada 2 (L2TP) com segurança do protocolo Internet (IPSec). O L2TP usa métodos de autenticação PPP em nível de usuário e certificados em nível de computador com IPSec para criptografia de dados.

XOX

Autenticação e autorização flexíveis e seguras
Os serviços de autenticação e de autorização flexíveis e seguros fornecem proteção para dados e, ao mesmo tempo, minimizam os obstáculos para a realização de negócios pela Internet. O Active Directory fornece suporte a vários protocolos de autenticação, como Kerberos V5, camada de soquetes de segurança (SSL) v3 e segurança da camada de transporte (TLS), usando certificados X.509 v3, e a grupos de segurança que se estendem por domínios com eficiência.
Serviço de autenticação da Internet
O serviço de autenticação da Internet (IAS) oferece um ponto central para gerenciamento de autenticação, autorização, estatísticas e auditoria de usuários de rede dial-up ou rede virtual privada (VPN). O IAS usa o protocolo IETF denominado RADIUS.

Este recurso não está incluído em computadores que executam o sistema operacional Microsoft® Windows® Server 2003, Web Edition. Para obter mais informações, consulte Visão geral sobre o Windows Server 2003, Web Edition. No Windows Server 2003, Standard Edition, é possível configurar o IAS com no máximo 50 clientes RADIUS e 2 grupos de servidores RADIUS remotos. Para obter mais informações sobre esses limites, consulte Serviço de autenticação da Internet.

Roteamento e acesso remoto
O Roteamento e acesso remoto substitui os recursos de serviço de roteamento e acesso remoto (RRAS) e de serviço de acesso remoto (RAS) do Windows NT 4.0. O Roteamento e o acesso remoto é um serviço único integrado que encerra conexões de clientes dial-up ou VPN ou que fornece roteamento (IP, IPX e serviços para AppleTalk) ou ambos. Com o Roteamento e acesso remoto, seu servidor pode funcionar como um servidor de acesso remoto, um servidor VPN, um gateway ou um roteador de filial. Para obter mais informações, consulte Roteamento e acesso remoto.

Recursos novos e atualizados a partir do Windows 2000

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows 2000) que ajudam a fornecer níveis superiores de suporte à autenticação e ao uso de cartões inteligentes:

Armazenamento de nomes de usuário e senhas
O armazenamento de nomes de usuário e senhas armazena credenciais de usuários, incluindo senhas e certificados X.509 v3, para que possam ser associados a computadores remotos e reutilizados automaticamente. Esse procedimento fornece início de sessão universal consistente para usuários, inclusive usuários móveis.
Acesso a cartão inteligente pelo Terminal Server
Com o Terminal Server, você pode fazer logon a partir de uma conexão de área de trabalho remota em um domínio do Windows Server 2003, usando certificados X.509 v3 confiáveis armazenados em um cartão inteligente. Por exemplo, é possível usar um cartão inteligente para fazer logon no Active Directory em um servidor de terminal.
Aperfeiçoamentos da autoridade de certificação subordinada
As autoridades de certificação subordinadas agora fornecem suporte à subordinação qualificada, que permite aos administradores da infra-estrutura de chave pública (PKI) usar autoridades de certificação subordinadas qualificadas para fins administrativos e de segurança mais precisos que os das autoridades de certificação padrão. Por exemplo, ter uma autoridade de certificação subordinada para emitir apenas os certificados referentes a assuntos de determinados domínios, que só poderão ser usados por aplicativos específicos. Para obter mais informações, consulte Subordinação qualificada.


Recursos de segurança adicionais

Este tópico fornece uma rápida visão geral sobre os recursos de segurança adicionais na família Windows Server 2003. Ele está dividido em três seções: Recursos novos e atualizados a partir do Windows Server 2003 (sem SP1), Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

Para obter informações sobre recursos de suporte a autenticação e cartão inteligente, consulte Suporte a autenticação e cartão inteligente. Para obter mais informações sobre novos recursos de segurança, consulte Novos recursos em segurança. Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

A família Windows Server 2003 inclui diversos recursos para a criação de um sistema de segurança robusto e flexível, incluindo criptografia e os recursos de segurança embutidos no Active Directory. Para obter informações sobre os tipos de autenticação disponíveis, consulte Suporte a autenticação e cartão inteligente.

Recursos novos e atualizados a partir do Windows Server 2003 (sem SP1)

As versões do Windows Server 2003 com SP1 fornecem os aperfeiçoamentos a seguir (em comparação com o Windows Server 2003 sem SP1) que ajudam oferecer níveis superiores de suporte à segurança:

Assistente de configuração de segurança
O SCW (Assistente de configuração de segurança) reduz a superfície de ataque dos servidores Microsoft Windows fazendo uma série de perguntas ao usuário com o objetivo de determinar os requisitos funcionais de um servidor. Qualquer funcionalidade não necessária às funções executadas pelo servidor é desativada. Além de ser uma prática recomendada de segurança fundamental, a redução da superfície de ataque aumenta a diversidade do cenário do Windows e reduz a quantidade de sistemas que necessitarão de atualização imediata em caso de problema de segurança. Para obter mais informações, consulte Assistente de Configuração de Segurança.
Firewall do Windows
O Firewall do Windows é uma tecnologia de firewall de host. Dessa forma, ele é executado em cada um de seus clientes e servidores, oferecendo proteção contra ataques de rede que ultrapassam sua rede de perímetro ou originados dentro da organização, como ataques do tipo cavalo de Tróia, ataques através de exame de porta e worms. Da mesma forma que várias tecnologias de firewall, o Firewall do Windows é um firewall monitorador. Conseqüentemente, ele inspeciona e filtra todo o tráfego IPv4 e IPv6. Qualquer tráfego de entrada não solicitado será ignorado, a menos que seja a resposta a uma solicitação do host (tráfego solicitado) ou seja especificamente permitido (tráfego de exceção). Você pode especificar um tráfego de exceção de acordo com o número da porta, o nome do aplicativo ou o nome do serviço, definindo as configurações do Firewall do Windows. O Firewall do Windows permite todo o tráfego de saída, exceto algumas mensagens ICMP.

Ele não está incluído na versão original do Windows Server 2003, mas está incluído em todas as versões do Windows Server 2003 com SP1.

O Firewall de conexão com a Internet é incluído apenas na versão original do Windows Server 2003, Standard Edition e na versão original de 32 bits do Windows Server 2003, Enterprise Edition.

Para obter mais informações, consulte o Windows Server TechCenter (http://www.microsoft.com/).

Serviço de gerenciamento de identidades digitais e credenciais móveis
O DIMS (serviço de gerenciamento de identidades digitais) e a credencial móvel permitem que o usuário que fizer logon em qualquer computador que esteja executando o Windows Server 2003 com SP1 e que faça parte de um domínio obtenha, sem problemas e silenciosamente, todos os certificados e chaves privadas disponíveis para aplicativos e serviços. Os administradores podem usar a diretiva de grupo para ativar a credencial móvel, o que sincronizará e replicará automaticamente chaves privadas e certificados do usuário com o objeto de usuário do Active Directory. Para obter mais informações, consulte o Windows Server TechCenter (http://www.microsoft.com/).
Informações de privacidade do Windows Server 2003
O Windows Server 2003 com SP1 oferece configurações de Diretiva de Grupo que não estão disponíveis na versão original do Windows Server 2003. Você pode encontrar novas configurações que ajudam a proteger a sua privacidade no Editor de Objeto de Diretiva de Grupo sob um novo nó chamado Gerenciamento da comunicação com a internet. As configurações sob Gerenciamento da comunicação com a internet ajudam você a controlar a forma em que os componentes do Windows se comunicam com a Internet. Uma das novas configurações do Windows Server 2003 com SP1 é Restringir comunicação com a Internet, que você pode usar para controlar simultaneamente. várias configurações relacionadas à privacidade. Para obter mais informações sobre privacidade, consulte "Using Windows Server 2003 in a Managed Environment" (em inglês) no site TechNet Web. (http://www.microsoft.com/).
Ativando a autenticação para conexões dos serviços de terminal
Com o Windows Server 2003 com SP1, você pode configurar as conexões dos serviços de terminal, a fim de usar o TLS (segurança da camada de transporte) para criptografia e autenticação de servidor. O TLS é mais conhecido como SSL/TLS. Por padrão, ele não é ativado na instalação do SP1. Para obter mais informações, consulte "Terminal Services Security" (em inglês) no site da Microsoft.

Recursos novos e atualizados a partir do Windows NT 4.0

A família de produtos Windows Server 2003 fornece os seguintes aperfeiçoamentos (em comparação com o Windows NT 4.0) que ajudam a oferecer níveis superiores de suporte à segurança:

Sistema de arquivos com criptografia
O sistema de arquivos com criptografia (EFS) complementa outros controles de acesso e oferece um nível de proteção adicional aos dados. O EFS é executado como um serviço de sistemas integrados, o que o torna fácil de gerenciar, difícil de atacar e transparente para o usuário. Para obter mais informações, consulte Sistema de arquivos com criptografia.
Segurança do protocolo Internet
Você pode usar a segurança do protocolo Internet (IPSec) para proteger a comunicação em uma intranet e criar soluções seguras de rede virtual privada (VPN) pela Internet. A IPSec foi criada pela Internet Engineering Task Force (IETF) e constitui um padrão da indústria para criptografia de tráfego TCP/IP. Para obter mais informações, consulte Segurança do protocolo Internet (IPSec).

Recursos novos e atualizados a partir do Windows 2000

A família Windows Server 2003 fornece os seguintes aperfeiçoamentos (em comparação com o Windows 2000), que ajudam a oferecer níveis superiores de suporte à segurança:

Propriedade da porta TCP/UDP
Uma nova opção de comando netstat exibe o processo que possui a porta TCP/UDP (protocolo de controle de transmissão/protocolo de datagrama de usuário). Também é possível usar esse recurso para configurar servidores seguros, auditorias de segurança e aprimoramentos de desempenho.
Aperfeiçoamentos no sistema de arquivos com criptografia
O sistema de arquivos com criptografia (EFS) foi aperfeiçoado de diversas formas. Algoritmos de criptografia de alta segurança encontram-se disponíveis com chaves maiores. Vários usuários podem ser autorizados a compartilhar arquivos criptografados. É possível criptografar arquivos offline através do EFS, de modo que você possa proteger localmente os documentos em cache. Para obter mais informações, consulte Sistema de arquivos com criptografia.
Diretivas de restrição de software
Com as diretivas de restrição de software, você poderá proteger o ambiente do computador contra código não confiável, identificando e especificando quais aplicativos podem ser executados. Para obter mais informações, consulte Diretivas de restrição de software.
Aperfeiçoamentos na monitoração da segurança do protocolo Internet
Os aperfeiçoamentos na monitoração da segurança do protocolo Internet (IPSec) incluem um snap-in do Console de Gerenciamento Microsoft (MMC) que fornece informações detalhadas sobre configuração de diretiva IPSec e estados de segurança ativa. Este recurso substitui o programa de monitoração Ipsecmon.exe no Windows 2000. Para obter mais informações, consulte Segurança do protocolo Internet (IPSec).


Gerenciamento remoto

Este tópico contém uma rápida visão geral sobre os recursos de gerenciamento remoto disponíveis na família Windows Server 2003. Está dividido em duas seções: Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

A família Windows Server 2003 inclui diversos recursos de gerenciamento remoto. Para obter informações detalhadas sobre como usar esses recursos, consulte Administração remota.

Recursos novos e atualizados a partir do Windows NT 4.0

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação ao Windows NT 4.0) que ajudam a oferecer níveis superiores de suporte a gerenciamento remoto:

Console de Gerenciamento Microsoft
Você pode usar o Console de Gerenciamento Microsoft (MMC) para organizar as ferramentas e os processos administrativos necessários em uma única interface. Você também pode delegar tarefas a usuários específicos criando MMCs pré-configurados que contenham as ferramentas selecionadas. Para obter mais informações, consulte Console de Gerenciamento Microsoft.
Criar scripts com o Host de scripts do Windows
Usando o host de scripts do Windows (WSH), você pode automatizar ações como a criação de atalhos e a conexão e desconexão de um servidor de rede. O WSH é independente de linguagem. É possível criar scripts em linguagens comuns como Microsoft Visual Basic®, Scripting Edition, (VBScript) e JScript. Para obter mais informações, consulte Host de scripts do Windows.
Serviços de instalação remota
Com os serviços de instalação remota (RIS), você pode criar imagens de instalações de sistemas operacionais ou mesmo de configurações completas de computadores, incluindo configurações de área de trabalho e aplicativos. Depois, você pode disponibilizar essas imagens aos usuários em clientes. Os clientes devem fornecer suporte à inicialização remota com a ROM de ambiente Pre-Boot eXecution (PXE) ou devem ser iniciados com um disquete de inicialização remota. Para obter mais informações, consulte Serviços de instalação remota.

Este recurso não está incluído em computadores que executam o sistema operacional Microsoft® Windows® Server 2003, Web Edition. Para obter mais informações, consulte Visão geral sobre o Windows Server 2003, Web Edition.

Recursos novos e atualizados a partir do Windows 2000

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação ao Windows 2000) que ajudam a oferecer níveis superiores de suporte a gerenciamento remoto:

Área de trabalho remota para administração
Com a Área de trabalho remota para administração (anteriormente conhecida como Serviços de terminal no Modo de Administração remota), você pode administrar um computador a partir de praticamente qualquer computador da rede. Com base na tecnologia Serviços de terminal, a Área de trabalho remota para administração foi projetada especificamente para o gerenciamento de servidores. Você pode usar a Área de trabalho remota para administração para fazer logon no servidor remotamente, embora tenha feito logon nele localmente. Além disso, a Área de trabalho remota para administração agora fornece suporte a uma maior intensidade de cores e resolução de tela. Para obter mais informações sobre esse recurso, consulte Área de trabalho remota para administração.
Assistência remota
Você pode usar a Assistência remota para administrar um computador remotamente. Se você tiver um convite, a Assistência Remota será uma maneira conveniente de conectar-se a um computador remoto a partir de um computador com Windows XP ou qualquer produto da família Windows Server 2003. Depois de estabelecer a conexão, você poderá exibir a tela do computador remoto e comunicar-se através de bate-papo em tempo real. Se a pessoa que solicitar assistência permitir, você poderá até usar o mouse e o teclado para trabalhar no computador remoto. Para obter mais informações, consulte Assistência remota.

XOX

Interface da Web para administração remota (somente Windows Server 2003, Web Edition)
No Windows Server 2003, Web Edition, a Interface da Web para administração remota é um aplicativo baseado em HTML que é utilizado para configurar e gerenciar o servidor a partir de um cliente remoto. Servidores individuais, server farms inteiros e vários sites por servidor podem ser gerenciados a partir de uma única estação de trabalho remota.

A Interface da Web para administração remota fornece um meio simples de executar tarefas de configuração comuns em servidores Web, inclusive:

  • Criar e excluir sites
  • Definir configurações de rede
  • Gerenciar contas de usuários locais
  • Reiniciar o servidor Web.
Aperfeiçoamentos nos serviços de instalação remota
Os aperfeiçoamentos no RIS incluem suporte para instalações da família Windows Server 2003 e de produtos do Windows XP, mais controle sobre o processamento de arquivos de resposta para uma instalação RIS e acesso a arquivos de rede em modos de recuperação.

Este recurso não está incluído em computadores que executam o sistema operacional Microsoft® Windows® Server 2003, Web Edition. Para obter mais informações, consulte Visão geral sobre o Windows Server 2003, Web Edition.


Manutenção e atualização de produtos

Este tópico contém uma rápida visão geral sobre os recursos de manutenção e atualizações de produtos na família Windows Server 2003. Está dividido em duas seções: Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

A família Windows Server 2003 oferece vários recursos que podem ajudar a manter o seu sistema atualizado com os mais recentes arquivos de sistema e atualizações de produtos.

Recursos novos e atualizados a partir do Windows NT 4.0

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação ao Windows NT 4.0) que ajudam a manter seu sistema atualizado com os arquivos de sistema mais recentes:

Windows Update
O Windows Update é uma extensão online do Windows que detecta arquivos de sistema do Windows desatualizados e os substitui pelas versões mais recentes. O Windows Update pode aumentar significativamente a estabilidade do sistema de computadores por um longo período. Também pode reduzir a carga de trabalho dos administradores e da equipe de suporte, os quais precisam manter um ambiente operacional produtivo. O Windows Update requer uma conexão com a Internet. Para obter mais informações, consulte Windows Update no site da Microsoft. (http://www.microsoft.com/) Além disso, consulte Usando o Windows Update.

Ele inclui a Atualização dinâmica, que está disponível durante a instalação. Se você tiver uma conexão com a Internet ativa no computador em que estiver executando a instalação, poderá usar a Atualização dinâmica para obter os arquivos da instalação mais atualizados, inclusive drivers e outros arquivos. Para obter mais informações, consulte Usando a Atualização dinâmica para drivers atualizados e outros arquivos de instalação.

Recursos novos e atualizados a partir do Windows 2000

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows 2000) que ajudam a manter seu sistema atualizado com os arquivos de sistema mais recentes:

Aperfeiçoamentos no Windows Update
O Windows Update agora fornece opções adicionais:
  • Com o Windows Update Catalog, você pode selecionar as atualizações que planeja implantar posteriormente, de modo que possa controlar como e quando as atualizações serão implantadas. Para obter mais informações, consulte Windows Update Catalog no site da Microsoft. (http://www.microsoft.com/)
  • Com o recurso Atualizações automáticas, incorporado ao Windows XP e aos produtos da família Windows Server 2003, o sistema operacional pode baixar e instalar automaticamente as atualizações críticas a partir do site do Windows Update. Para obter mais informações, consulte Atualizações automáticas do Windows.
  • Com o Windows Server Update Services, você pode implantar uma versão limitada do site Windows Update em seu firewall. É possível controlar como e quando as atualizações são implantadas, e você pode enviar atualizações para usuários pela intranet em vez de fazer com que as atualizações ocorram diretamente da Internet. Para obter mais informações, consulte Windows Server Update Services no site da Microsoft. (http://www.microsoft.com/)


Recursos de internacionalização

Este tópico contém uma rápida visão geral sobre os recursos de internacionalização na família de produtos Windows Server 2003. Está dividido em duas seções: Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

Recursos novos e atualizados a partir do Windows NT 4.0

A família Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows NT 4.0) que ajudam a fornecer níveis superiores de suporte à internacionalização:

Suporte multilíngüe
A família Windows Server 2003 oferece suporte a vários idiomas em um único sistema. Devido à arquitetura do sistema, o sistema operacional, os utilitários e os aplicativos desenvolvidos adequadamente podem ser traduzidos e adaptados para versões locais em centenas de idiomas. Portanto, os administradores locais não precisam ser fluentes em inglês técnico.
Suporte multi-regional
O suporte para localidades adicionais e opções regionais e de idioma também está incluído nesta versão, o que torna ainda mais fácil acessar o conteúdo relevante.

Recursos novos e atualizados a partir do Windows 2000

Vários produtos da família Windows Server 2003 oferecem os aperfeiçoamentos a seguir (em comparação com o Windows 2000) que ajudam a fornecer mais suporte à internacionalização. Alguns destes idiomas poderão não estar disponíveis em determinados produtos:

Novo editor de método de entrada fonética para chinês tradicional
O novo projeto do editor de método de entrada (IME) fonético baseia-se em tecnologia de ponta de entrada de teclado em chinês. É uma atualização da edição 98a CHT do IME fonético da Microsoft.
IME para japonês aprimorado
O IME para japonês versão 8 recebe caracteres de teclado alfabéticos, converte-os em caracteres japoneses e insere o resultado no aplicativo. Esse novo recurso também fornece suporte ao uso dos dicionários do IME para japonês em uma rede. O IME salva as palavras definidas pelo usuário e as regras de conversão em um dicionário do usuário, que pode ser editado no computador local. (Esse dicionário era somente leitura no Windows 2000.)
IME para coreano aprimorado
O IME para coreano mapeia seqüências de teclas para Korean Jamo e converte-os em sílabas coreanas. O novo IME para coreano fornece suporte à entrada de manuscrito em Hangul e Hanja.
IME para chinês simplificado aprimorado
O IME MSPY3.0 fornece um léxico para IME ampliado (aproximadamente 100.000 palavras e frases) e regras para IME atualizadas, um modelo de idioma aprimorado com maior precisão e desempenho do IME, além de digitação sem janela restrita (entrada mista em chinês/inglês).


Recursos para serviços de diretório, arquivo, impressão e colaboração

A família Windows Server 2003 contém suporte aperfeiçoado para serviços de diretório, arquivos, impressão e colaboração. Os tópicos nesta seção descrevem os recursos que oferecem suporte a esses tipos de servidores.

O Windows Server 2003, Web Edition não foi concebido para uso como servidor de arquivos ou de impressão. O sistema operacional Windows Server 2003, Web Edition oferece um suporte limitado a serviços de arquivos e impressão.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

Esta seção aborda:

  • Active Directory
  • Recursos de colaboração
  • Recursos de gerenciamento de arquivos e disco
  • Suporte a protocolos e impressoras

Observação

  • Para obter informações sobre os componentes do Windows Server 2003 R2, consulte Novidades no Microsoft Windows Server 2003 R2.


Active Directory

Este tópico contém uma rápida visão geral sobre os recursos do serviço de diretório do Active Directory na família Windows Server 2003. Ele está dividido em três seções: Recursos novos e atualizados no Windows Server 2003 com Service Pack 1 (SP1), Recursos novos e atualizados a partir do Windows NT 4.0, e Recursos novos e atualizados a partir do Windows 2000.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos. Para obter mais informações sobre o Active Directory, consulte Active Directory. Para obter uma lista mais detalhada dos novos recursos do Active Directory, consulte Novos recursos do Active Directory.

O Active Directory é um serviço de diretório de classe empresarial adaptável, desenvolvido com base em tecnologias padrão da Internet e totalmente integrado no sistema operacional. O Active Directory simplifica a administração e facilita a localização de recursos pelo usuário. O Active Directory fornece um grande número de recursos.

Observação

  • Os computadores com o sistema operacional XOX não podem atuar como controladores de domínio. Para obter mais informações sobre o XOX, consulte Visão geral do XOX.

Recursos novos e atualizados no Windows Server 2003 with Service Pack 1 (SP1)

Os sistemas operacionais Windows Server 2003 com Service Pack 1 (SP1) fornecem os seguintes aperfeiçoamentos (em comparação com o Windows Server 2003 sem SP1), que ajudam a oferecer níveis superiores de suporte para o Active Directory:

Recursos de teste de diagnóstico do DNS e replicação aprimorados
O Active Directory® foi atualizado para fornecer lembretes automáticos de backup do serviço de diretório, proteção aprimorada contra erros de replicação, melhorias na opção Instalar da Mídia (para facilitar a adição de novos controladores de domínio que sejam servidores DNS), capacidades aprimoradas de teste de diagnóstico DNS e acesso a uma nova plataforma para executar controladores de domínio em máquinas virtuais no Microsoft® Virtual Server 2005. Para obter mais informações sobre esses e outros recursos novos e melhorias no Active Directory, consulte Novos recursos do Active Directory.

Recursos novos e atualizados a partir do Windows NT 4.0

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows NT 4.0) que ajudam a oferecer níveis superiores de suporte ao Active Directory:

Gerenciamento simplificado de recursos de rede e usuários
Com o Active Directory, você pode criar estruturas hierárquicas de informações que facilitam o controle de credenciais administrativas e outras configurações de segurança, além de facilitar aos usuários a localização de recursos de rede, como arquivos e impressoras.
Autenticação e autorização flexíveis e seguras
Os serviços de autenticação e de autorização flexíveis e seguros fornecem proteção para dados e, ao mesmo tempo, minimizam os obstáculos para a realização de negócios pela Internet. O Active Directory oferece suporte a vários protocolos de autenticação, como o protocolo Kerberos V5, camada de soquetes de segurança (SSL) v3 e segurança da camada de transporte (TLS), usando certificados X.509 v3 e grupos de segurança que se estendem por domínios com eficiência.
Consolidação de diretórios
Você pode organizar e simplificar o gerenciamento de usuários, computadores, aplicativos e dispositivos, bem como facilitar para os usuários a localização das informações de que necessitam. Você pode beneficiar-se do suporte à sincronização através de interfaces baseadas no protocolo de acesso a pastas leves (LDAP) e pode trabalhar com requisitos de consolidação de diretórios específicos dos seus aplicativos.
Infra-estrutura e aplicativos habilitados por diretório
Os recursos do Active Directory facilitam a configuração e o gerenciamento de aplicativos e outros componentes de rede habilitados por diretório.
Desempenho sem complexidade
O Active Directory se adapta a milhões de objetos por domínio e usa a tecnologia de indexação e técnicas avançadas de replicação para acelerar o desempenho.
Uso dos padrões da Internet
O Active Directory fornece acesso por LDAP e usa um espaço para nome baseado no sistema de nomes de domínios (DNS).
Um ambiente de desenvolvimento avançado
O Active Directory oferece um ambiente de desenvolvimento avançado, com a interface do serviço de diretório ativo (ADSI), que oferece ao Active Directory uma interface orientada a objetos. A ADSI permite que programadores e administradores criem programas de diretório com facilidade, usando ferramentas de alto nível, como Microsoft Visual Basic, Java, C ou Visual C++, fazendo com que não seja preciso se preocupar com as diferenças subjacentes entre os diferentes espaços para nome. Para obter mais informações, consulte Interfaces de programação.
Replicação e monitoramento de relações de confiança
O Active Directory fornece classes de WMI que permitem monitorar se os controladores de domínio estão replicando com êxito as informações do Active Directory e se as relações de confiança estão funcionando corretamente.
Listas de distribuição do enfileiramento de mensagens
O enfileiramento de mensagens (também conhecido como MSMQ) permite enviar mensagens a listas de distribuição hospedadas no Active Directory.

Recursos novos e atualizados a partir do Windows 2000

A família de produtos Windows Server 2003 oferece diversos aperfeiçoamentos (em comparação com o Windows 2000) que ajudam a fornecer níveis superiores de suporte e um melhor gerenciamento do Active Directory. Para obter uma lista dos novos recursos do Active Directory disponíveis nesta versão, consulte Novos recursos do Active Directory.


Recursos de colaboração

Este tópico contém uma rápida visão geral sobre os recursos de colaboração, incluindo suporte a multimídia, na família de produtos Windows Server 2003. Está dividido em duas seções: Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

A família de produtos Windows Server 2003 aperfeiçoa a comunicação e a colaboração entre funcionários com ferramentas de colaboração de equipe, comunicações seguras em tempo real, dados móveis e fluxo de mídia em uma grande variedade de dispositivos conectados. Como os servidores estão disponíveis continuamente, os funcionários podem acessar informações em qualquer lugar, a qualquer momento e em qualquer dispositivo, aumentando a produtividade em toda a organização.

Recursos novos e atualizados a partir do Windows NT 4.0

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows NT 4.0) que ajudam a oferecer níveis superiores de suporte à colaboração:

Windows Media Services
O Windows Media Services fornece suporte para a distribuição de fluxo de áudio e vídeo em intranets corporativas e na Internet. Em Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition, o Windows Media Services disponibiliza recursos de fluxo avançados, como multicasting, suporte a rede sem fio, autenticação da Internet, plug-ins de servidor e APIs Cache/Proxy.

Os principais componentes do Windows Media Services foram desenvolvidos com o uso do modelo de objeto componente (COM), criando uma arquitetura flexível que é facilmente personalizada para aplicações específicas. Diversos recursos são implementados com uso de plug-ins. Com essa plataforma, os desenvolvedores podem facilmente estender a funcionalidade do Windows Media Services e integrar-se a sistemas e soluções já existentes, como sistemas de armazenamento, aplicativos de cobrança e aplicativos de log.

O Windows Media Services não é incluído no Windows Server 2003, Web Edition ou nas versões de 64 bits da família de produtos Windows Server 2003.

Qualidade de serviço ponto a ponto previsível
Os serviços e os protocolos baseados na qualidade do serviço (QoS) fornecem um sistema de entrega expressa garantida ponto a ponto para o tráfego gerado por programas habilitados por QoS em uma rede ou em várias redes totalmente distintas. Para obter mais informações, consulte Qualidade do serviço (QoS).
Modo de transferência assíncrona
O modo de transferência assíncrona (ATM) é um protocolo de alta velocidade orientado a conexões e projetado para transportar vários tipos de tráfego através de uma rede. Aplica-se a redes locais (LANs) e redes de longa distância (WANs). Com o ATM, a rede pode transportar simultaneamente uma grande variedade de tráfego de rede: voz, dados, imagem e vídeo.

Recursos novos e atualizados a partir do Windows 2000

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows 2000) que ajudam a oferecer níveis superiores de suporte à colaboração:

Microsoft .NET Framework
O Microsoft .NET Framework fornece os meios mais abrangentes e eficientes de criar, implantar e gerenciar serviços da Web em XML. Os serviços XML da Web permitem que aplicativos se comuniquem e compartilhem dados pela Internet, independentemente do sistema operacional ou da linguagem de programação. A família de produtos Windows Server 2003 é a base da visão Microsoft .NET e oferece uma base de computação .NET sem precedentes a organizações de todos os tamanhos. Para obter mais informações, consulte Microsoft .NET Framework.
Aceleração de áudio no servidor de acesso remoto
O recurso Aceleração de áudio prioriza o tráfego multimídia em relação a outros fluxos de dados, o que oferece um melhor desempenho, especialmente em redes de velocidade mais baixa. A aceleração de áudio no servidor de acesso remoto garante a qualidade da comunicação do fluxo de áudio e vídeo.
Aperfeiçoamentos do NetMeeting
Você pode utilizar o NetMeeting para se comunicar com outra pessoa usando a conferência multicast do Microsoft Exchange, o que permite a comunicação e a colaboração em tempo real por intranets e pela Internet. O NetMeeting também oferece uma plataforma para comunicação em tempo real, o que permite aos fornecedores de software integrar a conferência via Internet a seus aplicativos e serviços. Para obter mais informações, consulte Usando o NetMeeting.

XOX


Recursos de gerenciamento de arquivos e disco

Este tópico contém uma visão geral sobre os recursos de gerenciamento de discos e arquivos na família Windows Server 2003. Está dividido em duas seções: Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

Os recursos de gerenciamento de discos, volumes e arquivos nesta versão fazem dela uma plataforma flexível para servidores de arquivos, simplificando a localização e o acesso a informações pelos usuários.

Recursos novos e atualizados a partir do Windows NT 4.0

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows NT 4.0) que ajudam a oferecer níveis superiores de suporte ao gerenciamento de discos e arquivos:

Gerenciamento de disco
O Gerenciamento de disco é um utilitário do sistema para gerenciar discos rígidos e os volumes ou as partições neles contidos. Com o Gerenciamento de disco, você pode inicializar discos; criar volumes; formatar volumes com o sistema de arquivos FAT, FAT32 ou NTFS e criar sistemas de discos tolerantes a falhas. O Gerenciamento de disco permite que você execute a maioria das tarefas relacionadas a discos sem desligar o sistema ou interromper os usuários. A maioria das alterações de configuração entra em vigor imediatamente. Para obter mais informações, consulte Gerenciamento de disco.
Suporte a cota de disco
Você pode usar cotas de disco em volumes formatados com o sistema de arquivos NTFS para monitorar e limitar a quantidade de espaço em disco disponível para usuários individuais. É possível definir as respostas que são geradas quando os usuários ultrapassam os limites especificados. Para obter mais informações, consulte Cotas de disco.
Sistema de arquivos distribuídos
Com o sistema de arquivos distribuídos (DFS), você pode criar uma única árvore de pastas que inclui vários servidores de arquivos e compartilhamentos de arquivos em um grupo, divisão ou empresa. Isso permite que os usuários localizem facilmente arquivos ou pastas distribuídos na rede. Os compartilhamentos DFS também podem ser publicados como objetos de volume no Active Directory. Para obter mais informações, consulte Sistema de arquivos distribuídos (DFS).
Rastreamento de link distribuído
Usando o Rastreamento de link distribuído e o NTFS, você pode habilitar aplicativos clientes para rastrear origens de links que foram movidos. Por exemplo, um aplicativo cliente poderá sempre acessar um banco de dados vinculado, ainda que a localização do banco de dados seja alterada.
Criação e versão distribuídas
Usando criação e versão distribuídas (DAV), os autores remotos podem editar, mover ou excluir arquivos, propriedades de arquivos, pastas e propriedades de pastas no servidor através de uma conexão HTTP.
Indexação de conteúdo de alto desempenho
Você pode usar o serviço de indexação para fornecer aos usuários um modo rápido, fácil e seguro de procurar informações localmente ou na rede. Os usuários podem pesquisar em arquivos de diferentes formatos e idiomas, seja com o comando Pesquisar no menu Iniciar ou por páginas em HTML exibidas em um navegador.
Sistema de arquivos com criptografia
O sistema de arquivos com criptografia (EFS) complementa outros controles de acesso e oferece um nível de proteção adicional aos dados. O EFS é executado como um serviço de sistema integrado, o que o torna fácil de gerenciar, difícil de atacar e transparente para o usuário. Para obter mais informações, consulte Sistema de arquivos com criptografia.
Armazenamento removível e armazenamento remoto
O armazenamento removível facilita o controle das mídias de armazenamento removíveis (fitas e discos óticos) e o gerenciamento das bibliotecas de hardware, como alteradores e jukeboxes, que contenham as mídias. O armazenamento remoto usa critérios especificados por você para copiar automaticamente os arquivos pouco utilizados para mídias removíveis. Se o espaço em disco rígido for inferior aos níveis especificados, o armazenamento remoto removerá o conteúdo do arquivo (em cache) do disco. Se o arquivo for necessário posteriormente, o conteúdo será recuperado do armazenamento de forma automática. Como as fitas e os discos óticos removíveis custam menos por megabyte (MB) do que os discos rígidos, o armazenamento removível e o armazenamento remoto podem reduzir os custos. Para obter informações sobre o Armazenamento removível, consulte Armazenamento removível. Para obter mais informações sobre o Armazenamento remoto, consulte Armazenamento remoto.

O Armazenamento remoto não está disponível em Windows Server 2003, Web Edition ou em Windows Server 2003, Standard Edition. Para obter mais informações sobre o Windows Server 2003, Web Edition, consulte Visão geral sobre o Windows Server 2003, Web Edition.

Recursos novos e atualizados a partir do Windows 2000

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows 2000) que ajudam a oferecer níveis superiores de suporte ao gerenciamento de discos e arquivos:

Compartilhamento remoto de documentos
Um novo redirecionador de criação e versão distribuídas na Web (WebDAV) oferece suporte ao protocolo WebDAV para compartilhamento de documentos remotos por HTTP. O redirecionador de WebDAV oferece suporte ao uso de aplicativos existentes e permite o compartilhamento de arquivos pela Internet (através de firewalls, roteadores etc.) com servidores HTTP. Com o redirecionador de WebDAV, é possível hospedar repositórios da Web que podem ser acessados a partir de qualquer ponto na Internet e com qualquer aplicativo, não apenas com os que interpretam protocolos de publicação na Web.
Suporte a linha de comando para gerenciamento de discos
Com o novo comando DiskPart, é possível realizar várias tarefas de gerenciamento de discos a partir da linha de comando. Para obter mais informações, consulte Gerenciando discos e volumes a partir da linha de comando e DiskPart.
Tabela de partições GUID (somente versões de 64 bits)
O Windows XP 64-Bit Edition e as versões de 64 bits da família Windows Server 2003 (a versão de 64 bits do Windows Server 2003, Enterprise Edition e a versão de 64 bits do Windows Server 2003, Datacenter Edition) fornecem suporte ao novo estilo de particionamento de discos, a tabela de partições GUID (GPT). Diferentemente dos discos particionados com registro de inicialização principal (MBR), os dados críticos para o funcionamento da plataforma localizam-se em partições e não em setores não particionados ou ocultos. Além disso, discos particionados com o método GPT têm tabelas de partição redundantes primárias e de backup para proporcionar uma melhor integridade da estrutura dos dados de partição. Para obter mais informações, consulte Tabela de partições GUID.
Cópias de sombra de pastas compartilhadas
Com cópias de sombra de pastas compartilhadas, é possível abrir, exibir e salvar versões de arquivos em momentos específicos que são armazenados em pastas de rede compartilhadas. Por exemplo, se excluir acidentalmente um arquivo de um compartilhamento de rede, você poderá usar o recurso de cópia de sombra para recuperar uma versão anterior do arquivo. Para obter mais informações, consulte Cópias de sombra de pastas compartilhadas.
Aperfeiçoamentos no gerenciamento de arquivos
Com opções de pasta aperfeiçoadas, é possível gerenciar arquivos de forma mais eficaz. Por exemplo, você pode personalizar a exibição da pasta para mostrar tarefas comuns de arquivos e pastas, o que facilita o envio de arquivos através de email ou permite acesso de usuários a um local em um servidor Web. O tamanho maior das miniaturas facilita a identificação de documentos.
Suporte a redes de área de armazenamento (SANs)
Para obter maior interoperabilidade em ambientes de rede de área de armazenamento (SAN), em Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition, volumes de novos discos não são automaticamente montados e não recebem letras da unidade, por padrão, ao serem adicionados ao sistema.


Suporte a protocolos e impressoras

Este tópico contém uma rápida visão geral sobre os recursos de suporte a impressoras e protocolos na família Windows Server 2003. Está dividido em duas seções: Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

A família Windows Server 2003 oferece diversos recursos de suporte a protocolos e impressoras para servidores de impressão. Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

Recursos novos e atualizados a partir do Windows NT 4.0

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação ao Windows NT 4.0) que ajudam a oferecer níveis superiores de suporte a servidores de impressão:

Impressoras publicadas no Active Directory
Os usuários podem procurar e localizar rapidamente os recursos de impressão mais convenientes através de uma interface de usuário intuitiva.
Amplo suporte a protocolos e dispositivos
Você pode escolher entre milhares de impressoras diferentes.
Plug and Play
Com o Plug and Play, uma combinação de suporte a hardware e software, o servidor reconhece e se adapta automaticamente às alterações de configuração de hardware, sem intervenção do usuário e sem reinicialização.
Protocolo de impressão da Internet
Com o protocolo de impressão da Internet (IPP), os usuários podem imprimir diretamente para uma URL por uma intranet ou pela Internet. Além disso, os servidores que executam produtos da família Windows Server 2003 podem gerar automaticamente informações de trabalhos de impressão em formato HTML (linguagem de marcação de hipertexto), para que os usuários possam exibi-las nos navegadores.
Recursos de gerenciamento de impressoras
Você pode monitorar a operação de impressoras locais e remotas usando o Monitor do sistema. É possível definir contadores com vários critérios, como bytes impressos por segundo, erros do trabalho e total de páginas impressas.
Recursos de impressão em rede
Você pode administrar remotamente um servidor de impressão com o Windows Server 2003 usando o Console de gerenciamento Microsoft (MMC) a partir de qualquer lugar da rede. Além disso, se o cliente estiver executando Windows 2000 ou Windows XP, não será preciso instalar um driver de impressora para que esse computador use uma impressora. O download do driver é feito automaticamente quando o cliente se conecta com o servidor de impressão. Isso simplifica a impressão em rede.

Recursos novos e atualizados a partir do Windows 2000

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows 2000) que ajudam a oferecer níveis superiores de suporte servidores de impressão:

Novo suporte de linha de comando para impressão
Com os novos utilitários de linha de comando, você pode gerenciar impressoras e filas de impressão usando um provedor WMI. Também é possível desenvolver scripts ou arquivos em lote para gerenciar impressoras de forma mais eficiente.
Instalação simplificada de driver de impressora em clusters de servidores (somente Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition)
No Windows 2000, era necessário instalar manualmente cada driver de impressora em cada nó de um cluster de servidores. Com Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition, quando um driver de impressora é instalado em um cluster, o driver é propagado automaticamente para todos os nós.


Recursos para serviços de Internet, aplicativos e rede

A família Windows Server 2003 inclui diversos recursos da Internet, suporte a aplicativos e desenvolvimento de aplicativos, e recursos de rede e comunicações.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

Esta seção aborda:

  • Microsoft .NET Framework
  • Serviços e recursos de Internet e email
  • Suporte a aplicativos e desenvolvimento
  • Protocolos e tecnologias de rede

Observação

  • Para obter informações sobre os componentes do Windows Server 2003 R2, consulte Novidades no Microsoft Windows Server 2003 R2.


Microsoft .NET Framework

Elemento gráfico do Microsoft Windows

Microsoft .NET Framework versão 2.0

O .NET Framework versão 2.0 é a versão mais recente do .NET Framework, um componente do Windows para a criação, implantação e execução de aplicativos. O .NET Framework 2.0 está focalizado na entrega de produtividade do desenvolvedor, na excelência operacional e na capacidade de preservar e aumentar os investimentos existentes em software. As principais melhorias incluem o suporte a processadores de 64 bits para melhorar o desempenho e a escalabilidade, otimizações e melhorias transacionais, melhorias de produtividade no ASP.NET e suporte para WS-I BP 1.1 e SOAP 1.2 com serviços da Web.

Para obter uma lista abrangente dos novos recursos do .NET Framework 2.0, consulte o site da Microsoft. (http://go.microsoft.com/fwlink/?LinkId=50322)


Serviços e recursos de Internet e email

A família Windows Server 2003 inclui suporte aperfeiçoado a uma grande quantidade de recursos da Internet. Este tópico fornece uma rápida visão geral sobre os serviços e recursos de Internet e de email desta versão. Ele está dividido em três seções: Recursos novos e atualizados a partir do Windows Server 2003 (sem SP1), Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

Recursos novos e atualizados a partir do Windows Server 2003 (sem SP1)

Os sistemas operacionais Windows Server 2003 com Service Pack 1 (SP1) fornecem os seguintes aperfeiçoamentos (em comparação com o Windows Server 2003 sem SP1) que ajudam a oferecer níveis superiores de suporte a serviços da Internet:

Inclusões de diretiva de grupo em "Gerenciamento da comunicação da Internet"
O Windows Server 2003 com SP1 contém configurações de diretiva de grupo não disponíveis na versão original do Windows Server 2003. Algumas delas podem ser encontradas na diretiva de grupo, na chave denominada Gerenciamento da comunicação da Internet. A chave está localizada no GPMC, em Configuração do computador\Modelos administrativos\Sistema e em Configuração do usuário\Modelos administrativos\Sistema.

As configurações na chave Gerenciamento da comunicação da Internet foram projetadas para ajudar a controlar o modo de comunicação dos componentes do Windows Server 2003 com SP1 com a Internet.

Recursos novos e atualizados a partir do Windows NT 4.0

A família Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows NT 4.0), que ajudam a oferecer níveis superiores de suporte aos serviços da Internet:

Active Server Pages
O ASP é um ambiente de script de servidor para a criação dinâmica de aplicativos interativos de servidor Web. Com o ASP, os desenvolvedores podem combinar páginas HTML, comandos de script e componentes do Component Object Model (COM), conforme a necessidade, visando criar aplicativos flexíveis baseados na Web.
Windows Media Services
Com os Windows Media Services, é possível fornecer fluxo de multimídia de alta qualidade a usuários na Internet e em intranets.

O Windows Media Services não está incluído no XOX nem em versões de 64 bits da família Windows Server 2003.

Criação e versão distribuídas na Web
Com a criação e versão distribuídas na Web (WebDAV), os autores remotos podem utilizar uma conexão HTTP para trabalhar com arquivos. Para obter mais informações, consulte Recursos de gerenciamento de discos e arquivos.
Reciclagem de aplicativos
A reciclagem de aplicativos aumenta a confiabilidade e a integridade dos servidores. Você pode atualizar aplicativos e evitar possíveis perdas de recursos, o que aumenta a confiabilidade e disponibilidade dos servidores.

Recursos novos e atualizados a partir do Windows 2000

A família Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows 2000) que ajudam a oferecer níveis superiores de suporte aos serviços da Internet:

Componentes do Microsoft .NET Framework
O Microsoft .NET Framework oferece inúmeras possibilidades de criação, implantação e gerenciamento de serviços da Web. Para obter mais informações, consulte Microsoft .NET Framework.
Serviços de Informações da Internet 6.0
O Serviços de Informações da Internet (IIS) 6.0 é um servidor Web completo que foi otimizado para executar aplicativos e serviços da Web em um ambiente de hospedagem. Vários recursos novos foram adicionados ao IIS 6.0 para aumentar a confiabilidade, a segurança, a capacidade de gerenciamento e o desempenho. Para obter mais informações, consulte Serviços de Informações da Internet (IIS) 6.0.

Observação

  • Por padrão, o IIS não é instalado em novas instalações de XOX, XOX e XOX. Ele pode ser adicionado usando o Assistente para configurar o servidor ou Adicionar ou remover programas.
Serviços UDDI
UDDI é uma especificação da indústria para publicar e localizar informações sobre serviços da Web. Alguns produtos da família Windows Server 2003 incluem Serviços UDDI, um serviço da Web que fornece recursos UDDI para uso dentro de uma empresa ou entre organizações. Os serviços UDDI constituem um serviço da Web em XML baseado em padrões e projetado para permitir que desenvolvedores corporativos localizem, compartilhem e reutilizem com eficiência serviços da Web diretamente através de suas ferramentas de desenvolvimento.

Os Serviços UDDI não estão incluídos no XOX. Além disso, o XOX oferece suporte apenas a instalações autônomas de Serviços UDDI. O suporte à instalação distribuída está disponível no XOX e no XOX. Em uma instalação autônoma dos Serviços UDDI, o componente de servidor Web UDDI e o componente de banco de dados UDDI são instalados em um único servidor. Em uma instalação distribuída, os componentes UDDI são distribuídos em vários servidores.

Para obter mais informações sobre o XOX, consulte Visão geral sobre o Windows Server 2003, Web Edition.

Serviços de email (POP3, SMTP)
O serviço POP3 oferece serviços de recuperação e transferência de email. Os administradores podem usar o serviço POP3 para armazenar e gerenciar contas de email no servidor de email. O protocolo de transferência de correio simples (SMTP) suporta a transferência de email entre servidores. Para obter mais informações, consulte serviço POP3 e serviço do protocolo de transferência de correio simples (SMTP).
Provedor WMI de banco de dados de configuração
O provedor WMI de banco de dados de configuração para IIS facilita a administração entre aplicativos de servidores que estão executando o IIS. A instrumentação de gerenciamento do Windows (WMI) dispõe de um esquema variado e uma abordagem associativa com relação à modelagem de configuração de aplicativos, o que torna possível a criação de scripts que gerenciam todos os aspectos de um aplicativo da Web, incluindo configuração do sistema, arquivos de aplicativos e bancos de dados.


Suporte a aplicativos e desenvolvimento

Para obter uma tabela que relacione os tipos de suporte listados neste tópico com outros tipos de suporte nesta versão, consulte Escolhendo os recursos mais úteis para o servidor.

Esta seção aborda:

  • Suporte a sistemas existentes
  • Suporte a aplicativos
  • Gerenciamento e implantação
  • Recursos do Terminal Server
  • Suporte a desenvolvimento


Suporte a sistemas existentes

Este tópico contém uma rápida visão geral dos recursos de interoperabilidade na família Windows Server 2003. Está dividido em duas seções: Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

A família Windows Server 2003 oferece suporte a Windows NT 4.0, Windows 2000, UNIX e Macintosh, bem como interoperabilidade com vários sistemas operacionais clientes. Você pode introduzir produtos da família Windows Server 2003 de forma incremental em um ambiente de rede, porque os caminhos de migração são fornecidos a partir de qualquer quantidade de sistemas, dispositivos e aplicativos existentes.

Esta versão inclui os recursos de projeto a seguir para assegurar sua compatibilidade com o maior número de sistemas e aplicativos possível.

Recursos novos e atualizados a partir do Windows NT 4.0

A família Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows NT 4.0) que ajudam a oferecer níveis superiores de suporte a sistemas existentes:
Padrões da indústria
O Windows Server 2003 oferece suporte aos padrões mais atuais da indústria, dentre eles:
  • XML
  • Protocolo simples de acesso a objetos (SOAP)
  • Protocolo de acesso a pastas leves (LDAP)
  • DNS
  • Interface de serviço do Active Directory (ADSI)
  • Protocolo de autenticação Kerberos V5
  • UDDI

    Os Serviços UDDI não estão incluídos no Windows Server 2003, Web Edition. Além disso, o Windows Server 2003, Standard Edition fornece suporte apenas a instalações autônomas dos Serviços UDDI. O suporte a instalação distribuída está disponível com Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition. Em uma instalação autônoma dos Serviços UDDI, o componente de servidor Web UDDI e o componente de banco de dados UDDI são instalados em um único servidor. Em uma instalação distribuída, os componentes UDDI são distribuídos em vários servidores.

Suporte a aplicativos de servidor existentes
Aplicativos de servidor já existentes, como o Microsoft Exchange Server e o Microsoft SQL Server, são compatíveis com Windows Server 2003, Standard Edition; Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition. Para obter suporte integral, talvez seja preciso instalar as atualizações mais recentes dos produtos. Para obter mais informações, consulte Windows Update no site da Microsoft.(http://www.microsoft.com/) Consulte também o Application Center no site da Microsoft.(http://www.microsoft.com/)
Integração com sistemas operacionais existentes
Os produtos da família Windows Server 2003 integram-se perfeitamente aos sistemas operacionais já existentes e contêm suporte a sistemas operacionais Windows anteriores, bem como a outros sistemas operacionais difundidos. Os recursos a seguir estão incluídos nesta versão:
  • Interoperabilidade com Windows NT Server 4.0 e Windows 2000 Server.
  • Suporte a clientes que executam vários sistemas operacionais, incluindo Windows 3.x, Windows 95, Windows 98, Windows Millennium Edition, Windows NT Workstation 4.0, Windows 2000 Professional e Windows XP.
  • Interoperabilidade com UNIX, fornecida através de um pacote complementar denominado Windows Services for UNIX. O pacote complementar fornece suporte a sistema de arquivos de rede (NFS), sincronização de senha, um shell de comandos UNIX e um conjunto de utilitários UNIX. O pacote complementar também fornece suporte ao serviço de informação de rede (NIS). Também foram incluídos serviços Telnet (para acesso e administração remota).

  • Servidor de arquivos para Macintosh, que permite a clientes Macintosh usarem o protocolo TCP/IP (AFP via IP) para compartilhar arquivos e acessar compartilhamentos em um servidor que execute Windows Server 2003, Standard Edition; Windows Server 2003, Enterprise Edition ou Windows Server 2003, Datacenter Edition.

    Este recurso não está incluído em computadores que executam o sistema operacional Microsoft® Windows® Server 2003, Web Edition. Para obter mais informações, consulte Visão geral sobre o Windows Server 2003, Web Edition.

Recursos novos e atualizados a partir do Windows 2000

A família Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows 2000) que ajudam a oferecer níveis superiores de suporte a sistemas existentes:

Modo de compatibilidade
O modo de compatibilidade oferece um ambiente para execução de aplicativos que reflete com maior semelhança o comportamento do sistema operacional Windows 95, Windows 98, Windows NT 4.0 ou Windows 2000. Esses modos resolvem vários dos problemas mais comuns que impedem que aplicativos antigos funcionem corretamente. Também é possível utilizar esta tecnologia para criar soluções para seus próprios aplicativos.
Assistente de compatibilidade de programa
Você pode usar o Assistente de compatibilidade de programa para detectar e testar configurações de compatibilidade. Para obter mais informações, consulte Solucionando problemas de compatibilidade.


Suporte a aplicativos

Este tópico contém uma rápida visão geral sobre os recursos de suporte a aplicativos na família de produtos Windows Server 2003. Está dividido em duas seções: Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

A família de produtos Windows Server 2003 fornece suporte para uma ampla variedade de soluções fechadas de distribuidor de software independente (ISV) e um conjunto abrangente de serviços de aplicativos da Internet para o desenvolvimento rápido de aplicativos personalizados.

Observação

  • O sistema operacional Windows Server 2003, Web Edition tem por objetivo atender a serviços de aplicativos da Web e não operar como um servidor de aplicativos genéricos.

Recursos novos e atualizados a partir do Windows NT 4.0

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows NT 4.0) que ajudam a oferecer níveis superiores de suporte a aplicativos:

A mais ampla variedade de aplicativos fechados
Você pode executar uma ampla variedade de aplicativos na família de produtos Windows Server 2003. Para obter as informações mais recentes sobre aplicativos compatíveis, consulte as informações sobre compatibilidade de software no Catálogo do Windows localizado no site da Microsoft (http://www.microsoft.com).
Serviços abrangentes de aplicativos da Internet
Usando os serviços integrados da Web para gerenciamento de componentes, processamento de transações e enfileiramento de mensagens nesta versão, os programadores poderão desenvolver e implantar aplicativos escalonáveis baseados em componentes.
Acessibilidade ativa Microsoft
A acessibilidade ativa Microsoft é uma interface de programação de aplicativos (API) que ajuda os desenvolvedores a criarem aplicativos que possam ser personalizados por usuários com graus variados de deficiência física. Como a acessibilidade ativa reduz a necessidade de um código específico para o aplicativo, ela reduz também os custos gerais de manutenção e permite que os desenvolvedores de software inovem as interfaces com o usuário sem prejudicar a compatibilidade com os recursos de acessibilidade. Para obter mais informações, consulte a página sobre acessibilidade no site da Microsoft (http://www.microsoft.com).
TAPI 3.1
O TAPI 3.1 unifica a telefonia IP e tradicional a fim de permitir que os desenvolvedores criem aplicativos de telefonia computadorizada que funcionem pela Internet ou intranet com a mesma eficiência que funcionam pela rede de telefonia tradicional.
Serviços de transações
Os serviços de transações integrados na família de produtos Windows Server 2003 fornecem blocos de construção simples que podem executar transações complexas de modo eficiente e confiável através de redes amplamente distribuídas.
Enfileiramento de mensagens
O recurso de enfileiramento de mensagens integrado ajuda os desenvolvedores a criar e distribuir aplicativos que funcionem de modo mais confiável através de redes, incluindo a Internet. Esses aplicativos podem interagir com aplicativos executados em diferentes plataformas, como mainframes e sistemas baseados em UNIX.
Serviços de componentes
Os serviços de componentes são um conjunto de serviços baseados em extensões do modelo de objeto componente (COM) e no Microsoft Transaction Server (uma versão anterior de um sistema de processamento de transação baseado em componentes). Fornecem segmentação e segurança, gerenciamento de transações, pool de objetos, componentes enfileirados e administração e empacotamento de aplicativos.
Objetos de trabalho
Os produtos na família Windows Server 2003 contêm uma extensão ao modelo de processo denominada trabalho. Os objetos de trabalho são objetos que podem receber nomes, ser protegidos, compartilhados e controlar os atributos dos processos associados a eles. Uma função básica do objeto de trabalho é permitir que grupos de processos possam ser gerenciados e manipulados como uma unidade. Por exemplo, um aplicativo da Web pode usar um objeto de trabalho para explicar a utilização da CPU.
Integração de dados do host
Os produtos na família Windows Server 2003 fornecem uma excelente plataforma para execução de aplicativos de banco de dados, incluindo suporte nativo a ODBC (conectividade aberta de banco de dados), Oracle e Microsoft SQL Server.

Recursos novos e atualizados a partir do Windows 2000

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows 2000) que ajudam a oferecer níveis superiores de suporte a aplicativos:

Modo de compatibilidade
O modo de compatibilidade oferece um ambiente para execução de aplicativos que reflete com maior semelhança o comportamento do sistema operacional Windows 95, Windows 98, Windows NT 4.0 ou Windows 2000. Esses modos resolvem vários dos problemas mais comuns que proíbem o funcionamento correto de aplicativos mais antigos. Também é possível utilizar essa tecnologia para criar soluções para seus próprios aplicativos. Para obter mais informações, consulte Acessando informações sobre compatibilidade.
Ambientes Web em Serviços de Informações da Internet
Em Serviços de Informações da Internet (IIS), um Ambiente Web é um pool de aplicativos que dispõe de vários processos de trabalho servindo às solicitações roteadas ao pool. Um Ambiente Web pode ser configurado para que os processos a ele servidos tenham afinidade por determinados processadores em um computador com multiprocessador. Com o uso de Ambientes Web, os aplicativos da Web ganham em desempenho. Se um processo de operador tiver problemas com um Active Server Page (ASP), os outros processos de operador continuarão a servir conteúdo e assumirão a função do processo de operador bloqueado.


Gerenciamento e implantação

Este tópico contém uma rápida visão geral sobre os recursos de gerenciamento e implantação de aplicativos na família Windows Server 2003. Está dividido em duas seções: Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

Os recursos a seguir ajudam a simplificar a implantação de aplicativos em sistemas de mesa e portáteis. O Terminal Server fornece opções e recursos adicionais que simplificam a implantação. Para obter mais informações, consulte Recursos do Terminal Server.

Recursos novos e atualizados a partir do Windows NT 4.0

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação ao Windows NT 4.0) que ajudam a oferecer níveis superiores de suporte a gerenciamento e implantação:

Gerenciamento de configuração e alteração com diretiva de grupo
Você pode usar configurações de diretivas para definir as ações e configurações permitidas para usuários e computadores. Em contraste com a diretiva local, a diretiva de grupo pode ser usada para definir configurações de diretivas que se aplicam a todo um site, domínio ou unidade organizacional no Active Directory. Para obter mais informações sobre diretivas de grupo, consulte Diretiva de grupo. A família Windows Server 2003 inclui mais de 200 novas configurações de diretivas.
Consolidação de pastas no Active Directory
Com o Active Directory, você pode organizar e simplificar o gerenciamento de usuários, computadores, aplicativos e dispositivos, bem como facilitar para os usuários a localização das informações de que necessitam. Você pode beneficiar-se do suporte à sincronização através de interfaces baseadas no protocolo de acesso a pastas leves (LDAP) e pode trabalhar com requisitos de consolidação de diretórios específicos dos seus aplicativos.
IntelliMirror
Para ajudar a reduzir custos, os administradores precisam de níveis mais altos de controle em sistemas portáteis e de mesa. O IntelliMirror fornece esse controle em sistemas cliente que executam o Windows 2000 Professional ou o Windows XP Professional. Você pode usar o IntelliMirror para definir configurações de diretiva baseadas em funções comerciais, membros de grupo e locais. Com essas configurações de diretivas, as áreas de trabalho do Windows 2000 Professional e do Windows XP Professional serão reconfiguradas automaticamente para atender aos requisitos de um usuário específico sempre que ele fizer logon na rede, independentemente do local de acesso. Para obter mais informações sobre o IntelliMirror, consulte IntelliMirror.
Serviços de instalação remota
Com os serviços de instalação remota (RIS), você pode criar imagens de instalações de sistemas operacionais ou mesmo de configurações completas de computadores, incluindo configurações de área de trabalho e aplicativos. Depois, você pode disponibilizar essas imagens aos usuários em computadores clientes. Os clientes devem fornecer suporte à inicialização remota com a ROM de ambiente Pre-Boot eXecution (PXE) ou devem ser iniciados com um disquete de inicialização remota. Para obter mais informações, consulte Serviços de instalação remota.

Este recurso não está incluído em computadores que executam o sistema operacional Microsoft® Windows® Server 2003, Web Edition. Para obter mais informações, consulte Visão geral sobre o Windows Server 2003, Web Edition.

Windows Management Instrumentation (WMI)
O Windows Management Instrumentation (WMI) é uma infra-estrutura de gerenciamento escalonável baseada na iniciativa de gerenciamento de empresas pela Web (WBEM). Com o WMI, o que inclui recursos de linha de comando e de criação de script, você pode monitorar e controlar os eventos do sistema relacionados a aplicativos, componentes de hardware e redes. O WMI é baseado em padrões (originando-se do Modelo de informação comum (CIM)) e flexível, permitindo personalizar a forma como as informações são coletadas e filtradas. Para obter mais informações sobre o WMI, consulte Visão geral sobre o WMI.
Compartilhamento de componentes lado a lado
O compartilhamento lado a lado minimiza a fragilidade dos aplicativos, permitindo que várias versões do mesmo modelo de objeto componente (COM) ou componente Win32, como um arquivo .dll, sejam executadas ao mesmo tempo na memória. Isso significa que os aplicativos podem usar os componentes específicos para os quais foram projetados e com os quais foram testados, mesmo que outro aplicativo requeira uma versão diferente do mesmo componente. Isso permite que os desenvolvedores criem aplicativos mais confiáveis, pois podem escolher a versão do componente que desejam usar com o aplicativo, independente dos outros aplicativos no sistema.
Adicionar ou remover programas
Com Adicionar ou remover programas, você pode facilmente adicionar ou remover programas ou componentes e manter o controle da lista de programas instalados atualmente.
Windows Installer
Com o Windows Installer, você pode personalizar as implantações de componentes de software, além de monitorar a resiliência de arquivos e manter uma recuperação de sistema básica com reversões. Para obter mais informações, consulte Windows Installer.
Gerenciamento de aplicativos
Com o gerenciamento de aplicativos, você pode fazer alterações em aplicativos de forma controlada, sem recompilar nem criar nova versão.

Recursos novos e atualizados a partir do Windows 2000

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação ao Windows 2000) que ajudam a fornecer níveis superiores de suporte a gerenciamento e implantação:

Suporte a servidor administrado remotamente
O suporte ao servidor administrado remotamente fornece a capacidade de instalar e gerenciar um computador que não dispõe de monitor, adaptador de vídeo VGA, teclado nem mouse. Este recurso também inclui os Serviços de gerenciamento de emergência, que fornecem um mecanismo para gerenciar o servidor administrado remotamente quando o sistema operacional não está em operação, como, por exemplo, quando o computador é reinicializado, quando o servidor fica indisponível em uma rede ou durante o uso dos Serviços de instalação remota (RIS).
Aperfeiçoamentos do Windows Management Instrumentation (WMI)
A filtragem do WMI aprimora a infra-estrutura de diretiva de grupo ajudando você a determinar o efeito de um objeto de diretiva de grupo (GPO).
Suporte a criação de scripts
A família Windows Server 2003 dispõe de melhor suporte a scripts, incluindo novas ferramentas de linha de comando e aperfeiçoamentos no host de scripts do Windows. Para obter uma lista das novas ferramentas de linha de comando, consulte Novas ferramentas de linha de comando. Para obter mais informações sobre os aperfeiçoamentos no Host de scripts do Windows, consulte Visão geral sobre o Host de scripts do Windows.
Conjunto de diretivas resultante
Você pode usar o conjunto de diretivas resultante (RSoP) para simular e testar as configurações de diretivas aplicadas aos computadores ou usuários através de diretivas de grupo. O RSoP é um mecanismo de consulta que controla as configurações de diretivas existentes — e também as planejadas — informando os resultados das consultas. Ele controla as diretivas existentes com base no site, domínio, controlador de domínio e unidade organizacional. O RSoP reúne essas informações a partir do WMI.
Aperfeiçoamentos nos serviços de instalação remota
Os aperfeiçoamentos dos Serviços de Instalação Remota (RIS) incluem suporte à família Windows Server 2003 e às instalações de produtos Windows XP, mais controle sobre o processamento de arquivos de resposta para uma instalação de serviços de instalação remota e acesso a arquivos de rede em modos de recuperação.

Este recurso não está incluído em computadores que executam o sistema operacional Microsoft® Windows® Server 2003, Web Edition. Para obter mais informações, consulte Visão geral sobre o Windows Server 2003, Web Edition.


Recursos do Terminal Server

Este tópico contém uma visão geral sobre os recursos do Terminal Server nesta versão. Está dividido em duas seções: Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

O Terminal Server permite que computadores remotos tenham acesso a programas baseados no Windows executados em Windows Server 2003, Standard Edition, Windows Server 2003, Enterprise Edition ou Windows Server 2003, Datacenter Edition. Com o Terminal Server, você pode oferecer um único ponto de instalação que permite a vários usuários o acesso a qualquer computador que esteja executando um desses produtos. Os usuários podem executar programas, salvar arquivos e usar recursos de rede — tudo a partir de um local remoto — como se esses recursos estivessem instalados em seus próprios computadores.

Observações

  • Vários recursos do Terminal Server e da Área de trabalho remota foram renomeados ou substituídos nesta versão. Para obter uma tabela que lista os novos nomes dos recursos no Terminal Server, consulte Novas formas de executar tarefas conhecidas. Para obter uma tabela que lista os novos nomes da Área de trabalho remota para administração (anteriormente serviços de terminal em modo de administração remota), consulte Novas formas de executar tarefas conhecidas.
  • A Área de trabalho remota para administração é mais uma parte da tecnologia de serviços de terminal que é oferecida nesta versão. A administração remota de servidores através da área de trabalho remota para administração pode ser ativada em qualquer computador que execute a família de produtos Windows Server 2003, com o Terminal Server instalado ou não. Para obter mais informações, consulte Área de trabalho remota para administração.
  • O Terminal Server (anteriormente conhecido como serviços de terminal no modo de servidor de aplicativos) não foi incluído em computadores que executam o sistema operacional Windows Server 2003, Web Edition. Para obter mais informações sobre o Windows Server 2003, Web Edition, consulte Visão geral sobre o Windows Server 2003, Web Edition.

Recursos novos e atualizados a partir do Windows NT 4.0

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows NT) que ajudam a oferecer níveis superiores de suporte ao Terminal Server:

Implantação centralizada de programas
Com o Terminal Server, a execução de programa, o processamento de dados e o armazenamento de dados ocorrem no servidor, que centraliza a implantação de programas. O Terminal Server assegura que todos os clientes possam acessar a mesma versão de um programa. O software é instalado apenas uma vez no servidor, e não em cada computador da organização, reduzindo os custos associados à atualização de computadores individuais.
Acesso remoto a aplicativos
O Terminal Server envia a tela do aplicativo, em vez dos dados subjacentes do aplicativo, do servidor para o cliente. Isso significa que você pode permitir que os usuários tenham acesso a aplicativos carregados de dados através de conexões com largura de banda inferior (por exemplo, uma conexão dial-up de 28,8 Kbps), além de oferecer um desempenho melhor do que o possível sem o Terminal Server.
Acesso a um único aplicativo
O Terminal Server permite que os usuários tenham acesso a um único aplicativo publicado quando o acesso a um computador Windows XP completo é desnecessário.
Gerenciador de serviços de terminal
Com o Gerenciador do serviços de terminal, é possível exibir informações sobre Terminal Servers em domínios seguros. Essas informações incluem sessões, usuários e processos de cada Terminal Server. Este utilitário também pode ser usado para executar várias ações de gerenciamento do servidor.
Controle remoto
Os serviços de terminal oferecem controle remoto interno à família Windows Server 2003.

Recursos novos e atualizados a partir do Windows 2000

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows 2000) que ajudam a oferecer níveis superiores de suporte ao Terminal Server:

Redirecionamento de áudio
O redirecionamento de áudio permite a reprodução de som em um cliente com qualquer aplicativo que tente reproduzir um som wave em uma sessão do Terminal Server. Esse recurso oferece a capacidade de áudio básico, por exemplo, para arquivos .wav anexados em emails, documentos ou fluxo de mídia simples.
Integração de diretivas de grupo
O Terminal Server é integrado à diretiva de grupo, o que permite gerenciar a forma como um servidor com o Terminal Server habilitado pode ser usado através da aplicação de recursos de redirecionamento, acesso por senha e configurações de papel de parede.
Aperfeiçoamentos de resolução e cor
Os serviços de terminal, a tecnologia subjacente do Terminal Server, oferecem agora maior suporte a profundidade de cores e resolução de tela. Usando a Conexão de área de trabalho remota, a profundidade de cor pode ser definida como qualquer valor entre 256 cores e True Color, e a resolução, de 640 × 480 ao nível mais alto compatível com os dispositivos de vídeo do cliente. A resolução e os limites de cor devem ser habilitados tanto no servidor como no cliente.


Suporte a desenvolvimento

Este tópico contém uma rápida visão geral sobre os recursos de suporte a desenvolvimento na família de produtos Windows Server 2003. Está dividido em duas seções: Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

Os desenvolvedores que estiverem criando aplicativos baseados em servidor poderão trabalhar com as ferramentas disponíveis no Microsoft Visual Studio® e com outras ferramentas de desenvolvimento. A arquitetura do sistema na família de produtos Windows Server 2003 permite aos desenvolvedores projetar aplicativos que sejam facilmente convertidos e adaptados em versões locais.

Recursos novos e atualizados a partir do Windows NT 4.0

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows NT 4.0) que ajudam a oferecer níveis superiores de suporte a desenvolvedores:

Visual Studio .NET
O Visual Studio .NET foi projetado para atender aos principais requisitos de organizações que criam modernas soluções empresariais. Os temas de projeto do Visual Studio .NET incluem:
  • Um conjunto completo de ferramentas de desenvolvimento baseadas em componentes
  • Produtividade avançada de ciclo de vida
  • Ferramentas de bancos de dados de empresas
  • Suporte avançado a equipes
  • Integração com serviços de aplicativos
Tecnologia multilíngüe
Devido à arquitetura do sistema na família de produtos Windows Server 2003, o sistema operacional, os utilitários e os aplicativos criados corretamente podem ser convertidos e adaptados em versões locais em centenas de idiomas.

Recursos novos e atualizados a partir do Windows 2000

A família de produtos Windows Server 2003 oferece os seguintes aperfeiçoamentos (em comparação com o Windows 2000) que ajudam a oferecer níveis superiores de suporte a desenvolvedores:

Geração automática de identificações de links
As identificações de links são usadas por aplicativos à medida que criam novas estruturas do Active Directory (extensões do esquema do Active Directory). Se um aplicativo solicitar uma nova identificação de link que duplique uma identificação de link já em uso, a extensão do esquema não será carregada. A geração automática de identificações de links evita esse problema ao oferecer ao desenvolvedor de aplicativos a opção de solicitar que a identificação de link seja gerada automaticamente.
Serviço de transferência inteligente de plano de fundo
O serviço de transferência inteligente em segundo plano (BITS) é um mecanismo de transferência de arquivos em segundo plano. O BITS prioriza solicitações e pode ser usado para determinar que as transferências de baixa prioridade só ocorram quando a rede não estiver em plena capacidade. As transferências continuam mesmo depois de desconexões da rede ou reinicializações do computador. Você pode criar um aplicativo que baixe ou carregue arquivos em segundo plano usando o BITS. Por exemplo, se um usuário solicitar que o Windows Update execute vários downloads, o aplicativo recuperará essas atualizações em segundo plano apresentando uma solicitação ao BITS. Em seguida, o serviço BITS baixa os arquivos em segundo plano e informa ao usuário o término do processo.


Protocolos e tecnologias de rede

Este tópico fornece uma rápida visão geral sobre os protocolos e as tecnologias de rede na família Windows Server 2003. Ele está dividido em três seções: Recursos novos e atualizados a partir do Windows Server 2003 (sem SP1), Recursos novos e atualizados a partir do Windows NT 4.0 e Recursos novos e atualizados a partir do Windows 2000.

A família Windows Server 2003 inclui diversos protocolos e tecnologias de rede que podem estender os recursos do servidor. Para obter informações sobre tecnologias adicionais relacionadas a redes, consulte Recursos de desempenho e ajuste. Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

Observações

  • Os seguintes protocolos de rede foram removidos de todos os produtos da família Windows Server 2003: o protocolo DLC (controle de link de dados), relacionado a alguns modelos de interface, e a Interface de usuário estendida de NetBIOS (NetBEUI).
  • Os seguintes protocolos de rede foram removidos das versões baseadas em Itanium da família de produtos Windows Server 2003: IPX/SPX, serviços dependentes de IPX e OSPF (Open Shortest Path First). Para obter mais informações, consulte Recursos não disponíveis nas versões de 64 bits da família de produtos Windows Server 2003.
  • Na família de produtos Windows Server 2003, somente o XOX oferece suporte a rede via infravermelho.

Recursos novos e atualizados a partir do Windows Server 2003 (sem SP1)

Os sistemas operacionais Windows Server 2003 com Service Pack 1 (SP1) fornecem os seguintes aperfeiçoamentos (em comparação com o Windows Server 2003 sem SP1) que ajudam a oferecer níveis superiores de suporte a protocolos e tecnologias de rede:

Serviço de quarentena de acesso remoto, parte do Controle de quarentena de acesso à rede
O Serviço de quarentena de acesso remoto é um componente essencial do Controle de quarentena de acesso à rede para o Windows Server 2003 com SP1. Os administradores de rede podem aplicar requisitos de acesso a redes aos computadores remotos usando o Controle de quarentena de acesso à rede. A falta de acesso dificulta a aplicação de requisitos de rede (como o uso de software antivírus) aos computadores remotos. A implantação dos componentes do Controle de quarentena de acesso à rede, inclusive a instalação do componente opcional Serviço de quarentena de acesso remoto (RQS.exe) no Windows Server 2003 com SP1, e a inclusão do componente RQC.exe com os recursos avançados de personalização do Gerenciador de conexões, permitem que os administradores de rede criem conexões para a verificação dos programas necessários, das configurações do Registro, de arquivos ou de suas combinações. Eles também podem colocar uma sessão de acesso remoto em quarentena até a conclusão dessas verificações.

A instalação do Serviço de quarentena de acesso remoto não inicia automaticamente o serviço Agente de quarentena de acesso remoto, um outro aspecto do Controle de quarentena de acesso à rede. Como administrador da rede, você deve decidir o melhor momento de iniciar o serviço em relação à configuração do serviço Roteamento e acesso remoto. O serviço Agente de quarentena de acesso remoto depende dele. Entretanto, o reinício do serviço Roteamento e acesso remoto não reinicia automaticamente o serviço Agente de quarentena de acesso remoto. Você deve reiniciá-lo manualmente.

Para obter mais informações, consulte:

Network Access Quarantine Control in Windows Server 2003 (em inglês) no site do Microsoft Windows Server System (http://www.microsoft.com/)

Step-by-Step Guide for Setting Up Network Quarantine and Remote Access Certificate Provisioning in a Test Lab (em inglês) no site do Microsoft Download Center (http://www.microsoft.com/)

VPN Quarantine Sample Scripts for Verifying Client Health Configurations (em inglês) no site do Microsoft Download Center (http://www.microsoft.com/)

A pasta ValueAdd foi substituída pela pasta Suporte
A pasta ValueAdd foi removida do Windows Server 2003 com SP1. Para instalar as ferramentas de suporte existentes anteriormente nessa pasta, como o Administrador de catálogo telefônico, vá para a pasta Suporte no CD de instalação.

Recursos novos e atualizados a partir do Windows NT 4.0

A família Windows Server 2003 fornece os seguintes aperfeiçoamentos (em comparação com o Windows NT 4.0) que ajudam a oferecer níveis superiores de suporte a protocolos e tecnologias de rede:

Winsock Direct
Com o Winsock Direct, os aplicativos que utilizam Winsock podem apresentar um desempenho mais rápido e com menor sobrecarga da CPU quando se comunicam por uma rede de área do sistema (SAN). O Winsock Direct agiliza a comunicação entre os componentes distribuídos, se houver uma SAN instalada.
DHCP com DNS e Active Directory
O protocolo DHCP trabalha com o DNS (sistema de nomes de domínios) e o Active Directory em redes IP, o que ajuda a liberá-lo das tarefas de atribuição e controle de endereços IP estáticos. O DHCP atribui dinamicamente endereços IP a computadores ou outros recursos conectados a uma rede IP.
Compartilhamento de conexão com a Internet
Com o recurso Compartilhamento de conexão com a Internet de conexões de rede, é possível conectar sua rede residencial ou de pequeno escritório com a Internet. Por exemplo, talvez você tenha uma rede residencial com acesso à Internet através de uma conexão de linha de assinante digital (DSL). Com a ativação do Compartilhamento de conexão com a Internet no computador que usa a DSL, você fornece serviços de conversão de endereços de rede, endereçamento e resolução de nomes a todos os computadores da rede residencial. Para obter mais informações, consulte Compartilhamento de conexão com a Internet e conversão de endereços de rede.

Este recurso está disponível apenas no XOX e no XOX e somente em computadores baseados em x86.

Conversão de endereços de rede
A conversão de endereços de rede (NAT) oculta de redes externas os endereços IP gerenciados internamente através da conversão de endereços internos privados em endereços externos públicos. Isso reduz os custos de registro de endereços IP ao permitir a utilização de endereços IP privados internamente, com a conversão em uma pequena quantidade de endereços IP registrados externamente. A estrutura de rede interna também é ocultada, reduzindo o risco de ataques contra os sistemas internos.
Rede virtual privada
Você pode permitir que os usuários tenham acesso imediato à rede da sua organização mesmo quando estiverem fora do escritório – e reduzir o custo desse acesso – implementando uma rede virtual privada (VPN). A conexão VPN cria um encapsulamento seguro pela Internet para a rede privada.

Há dois tipos de tecnologia VPN na família de produtos Windows Server 2003:

  • O protocolo de encapsulamento ponto a ponto (PPTP), que emprega métodos de autenticação do protocolo ponto a ponto (PPP) em nível de usuário e a criptografia ponto a ponto da Microsoft (MPPE) para criptografar dados.
  • O protocolo de encapsulamento de camada 2 (L2TP) com segurança do protocolo Internet (IPSec). O L2TP usa métodos de autenticação PPP em nível de usuário e certificados em nível de computador com IPSec para criptografia de dados.

XOX

Roteamento e acesso remoto
O Roteamento e acesso remoto substitui os recursos de serviço de roteamento e acesso remoto (RRAS) e de serviço de acesso remoto (RAS) do Windows NT 4.0. O Roteamento e acesso remoto é um serviço único integrado que encerra conexões de clientes dial-up ou VPN ou que fornece roteamento (IP, IPX e AppleTalk) ou ambos. Com o Roteamento e acesso remoto, seu servidor pode funcionar como um servidor de acesso remoto, um servidor VPN, um gateway ou um roteador de filial. Para obter mais informações, consulte Roteamento e acesso remoto.
Modo de transferência assíncrona
O modo de transferência assíncrona (ATM) é um protocolo de alta velocidade orientado a conexões e projetado para transportar vários tipos de tráfego através de uma rede. Aplica-se a redes locais (LANs) e redes de longa distância (WANs). Com o ATM, a rede pode transportar simultaneamente uma grande variedade de tráfego, incluindo transmissões de voz, dados, imagem e vídeo.

Recursos novos e atualizados a partir do Windows 2000

A família Windows Server 2003 fornece os seguintes aperfeiçoamentos (em comparação com o Windows 2000) que ajudam a oferecer níveis superiores de suporte a protocolos e tecnologias de rede:

Protocolo de acesso a objeto simples
O protocolo de acesso a objeto simples (SOAP) é um protocolo baseado em XML para trocar informações em um ambiente distribuído e descentralizado. Ele consiste basicamente em duas partes principais: um envelope para tratamento de extensibilidade e modularidade e um mecanismo de codificação para representação de tipos de dados no envelope. Ele não requer execução síncrona nem interação de solicitações/respostas. O SOAP oferece um protocolo simples com um mecanismo de extensibilidade para adição de recursos, como roteamento de mensagens, segurança e entrega garantida. Por contar com a disponibilidade de protocolos muito difundidos, incluindo não apenas XML e HTTP, mas também SMTP e FTP, o SOAP fica disponível para uma grande variedade de plataformas e clientes.
Suporte a Fibre Channel
Fibre Channel é uma tecnologia para transferência de dados a 1 gigabit por segundo que mapeia protocolos de transporte comuns, como interface de sistema de computadores de pequeno porte (SCSI) e IP, combinando redes com alta velocidade de entrada/saída (E/S) em uma única tecnologia de conectividade. A tecnologia Fibre Channel oferece uma forma de resolver as limitações de distância e de espaço de endereço para as tecnologias de canal convencionais. Para obter mais informações, consulte Configuração do hardware Fibre Channel.
Configuração automática para várias redes
A configuração automática para várias redes oferece acesso fácil a dispositivos de rede e à Internet. Ela também oferece ao usuário de computador móvel operações contínuas tanto na rede do escritório quanto na residencial, sem a necessidade de reconfigurar definições de TCP/IP manualmente. Com a configuração automática para várias redes, o TCP/IP poderá utilizar uma configuração alternativa se um servidor DHCP não for encontrado.
Aperfeiçoamentos no Gerenciador de conexões
O Gerenciador de conexões oferece vários recursos novos:
  • Configuração automática de proxy para clientes do Gerenciador de conexões. Configure as definições de proxy para garantir que o usuário tenha acesso apropriado a recursos internos e externos enquanto estiver conectado ao seu serviço.
  • Favoritos do Gerenciador de conexões. Elimina a configuração repetitiva das propriedades do Gerenciador de conexões quando os usuários alternam entre locais de discagem comuns.
  • Arquivos de log do cliente. Solucione problemas com as conexões do Gerenciador de conexões.
  • Kit de administração do Gerenciador de conexões. Use o Assistente do CMAK (Kit de administração do Gerenciador de conexões) a fim de personalizar o Gerenciador de conexões para atender às suas necessidades.
Redirecionador de criação e versão distribuídas na Web
O redirecionador de criação e versão distribuídas na Web (WebDAV) fornece suporte ao protocolo WebDAV para compartilhamento de documentos remotos por HTTP. O redirecionador WebDAV oferece suporte ao uso de aplicativos existentes e ao compartilhamento de arquivos pela Internet (através de firewalls, roteadores etc.) com servidores HTTP.
Serviço de autenticação da Internet como proxy RADIUS
Este recurso fornece suporte à capacidade do Serviço de autenticação da Internet (IAS) de encaminhar solicitações de autenticação e contabilização RADIUS para outro servidor RADIUS. Isso inclui encaminhamento flexível baseado em regra, balanceamento de carga e failover entre várias solicitações de servidor IAS/RADIUS e RADIUS-EAP de balanceamento de carga; capacidade de forçar o cliente em um encapsulamento compulsório com ou sem a autenticação do usuário; e encaminhamento seletivo de solicitações de autenticação e contabilização para diversos servidores RADIUS.

XOX No XOX, é possível configurar o IAS com no máximo 50 clientes RADIUS e 2 grupos de servidores RADIUS remotos. Para obter mais informações sobre esses limites, consulte Serviço de autenticação da Internet.

Redes sem fio
O recurso de rede sem fio da família Windows Server 2003 oferece suporte ao padrão IEEE 802.11 e também minimiza a configuração necessária ao acesso a redes sem fio. O recurso de configuração automática de rede sem fio permite a movimentação dos usuários entre várias redes sem fio em diversos locais, sem a necessidade de reconfigurar as configurações de conexão de rede para cada novo local. As opções de segurança para IEEE 802.11 incluem serviços de autenticação e serviços de criptografia baseados no algoritmo WEP (Wired Equivalent Privacy). Para maior segurança, a autenticação IEEE 802.11 é ativada, por padrão, na família de produtos Windows Server 2003. A autenticação IEEE 802.1X fornece acesso autenticado a redes sem fio 802.11 e a redes Ethernet que utilizam cabo. A autenticação IEEE 802.1X fornece suporte a tipos de segurança EAP (protocolo de autenticação estendido), de forma que os usuários possam usar métodos de autenticação, como certificados.
IPv6
A família Windows Server 2003 oferece suporte ao IPv6, um conjunto de protocolos padrão que representa a próxima geração dos protocolos de camada de rede da Internet. Para obter mais informações, consulte IPv6.


Instalando e atualizando o sistema operacional

Estes tópicos podem ajudá-lo a planejar a atualização ou instalação do Windows Server 2003, Enterprise Edition em uma rede com um a cinco servidores e 100 ou menos clientes. Para obter ajuda no planejamento da atualização ou instalação de um número maior de servidores, consulte o Kit de Implantação do Windows Server 2003 no site da Microsoft. (http://www.microsoft.com/).

  • Antes de executar a instalação, consulte Listas de verificação.
  • Para obter dicas de instalação, consulte Práticas recomendadas.
  • Para obter ajuda sobre como executar tarefas específicas, consulte Como....
  • Para obter informações gerais básicas, consulte Conceitos.
  • Para obter instruções sobre como solucionar problemas, consulte Solucionando problemas.


Listas de verificação

  • Lista de verificação: Executando uma atualização
  • Lista de verificação: Executando uma nova instalação


Lista de verificação: Executando uma atualização

Etapa | Referência
Verifique os requisitos do sistema. | Requisitos do sistema
Leia o Relnotes.htm e as informações de compatibilidade de hardware. | Arquivos importantes a serem revisados Compatibilidade de hardware
Determine se é possível atualizar o sistema operacional atual para o Windows Server 2003, Enterprise Edition. | Comparação entre atualizações e instalações novas
Se você tiver clusters de servidores, revise as opções para atualização em nós de clusters. | Atualizando para Windows Server 2003, Enterprise Edition em nós de cluster Lista de verificação: Preparação para atualizar um cluster
No caso de atualizações em um domínio em que todos os controladores de domínio utilizam o Windows NT 4.0, revise o plano de atualização. | Atualizações em um domínio do Windows NT 4.0
No caso de atualizações em um domínio em que um ou mais controladores de domínio utilizam o Windows 2000, execute uma ferramenta para atualizar o esquema (antes de atualizar o sistema operacional). | Preparar-se para atualizações em um domínio que contenha controladores de domínio do Windows 2000
Decida se irá atualizar partições FAT ou FAT32 para NTFS. | Escolhendo um sistema de arquivos para a partição de instalação
Verifique se o log do sistema contém algum erro que possa causar problemas durante a atualização. | Preparando o sistema para uma atualização
Faça backup dos arquivos. | Preparando o sistema para uma atualização
Se a atualização for a partir do Windows NT 4.0, prepare conjuntos de espelhos ou outros conjuntos de discos para atualização. | Trabalhando com conjuntos de volumes, de espelhos, de distribuição ou de distribuição com paridade
Desconecte os dispositivos no-break. | Preparando o sistema para uma atualização
Revise os hardwares e os softwares. | Preparando o sistema para uma atualização
Inicie a instalação e siga as instruções fornecidas. | Iniciar a instalação em um computador baseado em x86 Iniciar a instalação em um computador com arquitetura baseada em Itanium
Depois de concluir as atualizações dos controladores de domínio, revise os conceitos sobre os níveis funcionais dos domínios e, se for apropriado, aumente o nível funcional. | Funcionalidade de domínio e de floresta Atualizando de um domínio do Windows NT


Lista de verificação: Executando uma nova instalação

Etapa | Referência
Verifique os requisitos do sistema. | Requisitos do sistema
Leia o Relnotes.htm e as informações de compatibilidade de hardware. | Arquivos importantes a serem revisados Compatibilidade de hardware
Decida se irá atualizar ou instalar. | Atualizando ou instalando
Se você tiver clusters de servidores, revise o processo para instalação em nós de clusters. | Lista de verificação: Preparação para instalar um cluster
Decida o modo de licenciamento a ser usado: por dispositivo ou por usuário ou por servidor. | Escolhendo um modo de licenciamento
Decida se deseja escolher entre sistemas operacionais diferentes sempre que iniciar o computador. | Decidindo se um computador conterá mais de um sistema operacional
Decida o sistema de arquivos a ser usado: NTFS, FAT32 ou FAT32. | Escolhendo um sistema de arquivos para a partição de instalação
Decida em qual partição fará a instalação ou se haverá necessidade de uma nova partição para a instalação. | Planejando volumes ou partições de disco para novas instalações
Decida como tratar redes, endereços IP e resolução de nomes TCP/IP. | Redes: TCP/IP, endereços IP e resolução de nomes
Decida se criará domínios ou grupos de trabalho para os servidores. | Decidindo entre grupos de trabalho e domínios
Se o computador já tiver um sistema operacional instalado, faça backup dos arquivos e verifique se há erros no log do sistema. | Preparando o sistema para uma nova instalação
Descompacte volumes DriveSpace ou DoubleSpace. | Preparando o sistema para uma nova instalação
Se o computador executar o Windows NT 4.0 e utilizar definições de espelho ou outras definições de disco, prepare os discos. | Trabalhando com conjuntos de volumes, de espelhos, de distribuição ou de distribuição com paridade
Desconecte os dispositivos no-break. | Preparando o sistema para uma nova instalação
Inicie a instalação e siga as instruções fornecidas. | Iniciar a instalação em um computador baseado em x86 Iniciar a instalação em um computador com arquitetura baseada em Itanium


Práticas recomendadas

Prepare o servidor antes de atualizar ou instalar.

  • Se você estiver executando uma atualização, consulte:
    • Lista de verificação: Executando uma atualização
    • Preparando o sistema para uma atualização

  • Se você estiver executando uma nova instalação, consulte:

    • Lista de verificação: Executando uma nova instalação
    • Preparando o sistema para uma nova instalação

Confirme as configurações do servidor depois de executar a instalação.

  • Verifique o recurso Visualizar eventos. Verifique se Visualizar eventos contém mensagens associadas ao processo de instalação ou inicialização. Para obter mais informações, consulte Visualizar eventos.
  • Defina o tamanho do log e a configuração de quebra de Visualizar eventos. Defina o tamanho do log de eventos e a configuração de quebra (substituição) que corresponda às suas necessidades comerciais e de segurança. Para obter informações, consulte Definir opções de log de eventos.
  • Verifique a otimização do servidor. Ajuste a definição de otimização de servidor para atender à função que o computador executará na organização. Para obter informações sobre como acessar as configurações de otimização de servidor, consulte Configurar definições relacionadas à memória no computador.
  • Verifique as configurações de IP, DNS, WINS e de gateway padrão. Use as ferramentas administrativas descritas em Serviços de rede para configurar e verificar as definições. Você também pode abrir um prompt de comando, digitar ipconfig /all e verificar as configurações exibidas.
  • Exiba o nome completo do computador. Abra um prompt de comando e digite net config rdr para exibir o nome completo do computador. Compare os resultados com o nome do Active Directory para confirmar se coincidem ou variam da forma pretendida.
  • Valide configuração de cluster de servidores. Siga os procedimentos em Lista de verificação: Validando o sistema do cluster para confirmar as configurações básicas de armazenamento do cluster.
  • Especifique opções para arquivos de paginação e despejos de memória. Defina o tamanho e a localização do arquivo de paginação com base no tamanho da memória e uso do servidor. Para obter informações sobre como realizar isso, consulte Alterar configurações de memória virtual. Além disso, defina opções a serem usadas pelo sistema operacional caso o sistema pare inesperadamente (por exemplo, as opções para despejos de memória). Para obter mais informações, consulte Especificar o que ocorre quando o sistema pára inesperadamente.
  • Configure para administração remota. Identifique os métodos de administração remota a serem utilizados e configure-os conforme a necessidade. Para obter mais informações, consulte Administração remota.

Confirme as configurações de segurança do servidor depois de executar a instalação.

  • Verifique as configurações de inicialização para serviços. XOX Na pasta Serviços, em Serviços e aplicativos, altere o Tipo de inicialização dos serviços para que somente os serviços necessários ao servidor sejam iniciados automaticamente. Confirme também se todos os serviços definidos para início automático podem ser iniciados sem intervenção do usuário nem necessidade de novas tentativas. Para obter uma lista de tópicos sobre serviços, consulte Serviços. Para obter informações específicas sobre serviços iniciados por padrão após a instalação (que são diferentes em relação ao Windows 2000), consulte Configurações padrão para serviços.
  • Verificar as configurações de segurança do Internet Explorer. Em sistemas operacionais da família de produtos Windows Server 2003, a configuração de segurança aprimorada do Internet Explorer é ativada por padrão. As configurações de segurança ajudam a proteger melhor o computador, limitando a exposição do mesmo a sites mal-intencionados. Portanto, com o nível aprimorado de segurança, você poderá descobrir que alguns sites não são exibidos corretamente no Internet Explorer quando você estiver navegando por alguns sites da Internet e de intranets. Você também poderá receber uma solicitação para fornecer suas credenciais quando estiver acessando os recursos da rede, como arquivos em pastas compartilhadas UNCs. Essas configurações aprimoradas de segurança são facilmente alteradas. Para obter mais informações, consulte Visão geral sobre a configuração de segurança aprimorada do Internet Explorer.
  • Verifique as portas de rede abertas. Para ajudar a proteger os servidores contra ataques, feche as portas que o sistema não precisar manter abertas para funcionar corretamente. Verifique as portas com o comando netstat. Recomenda-se também usar um verificador de portas externas e comparar os resultados com os do netstat. Notifique outros administradores de sistemas ou o pessoal responsável pelas operações afetadas antes de executar o verificador de portas, caso ele afete o comportamento do sistema ou habilite disparadores existentes para detecção de intrusos. Para obter mais informações sobre o netstat e como determinar qual processo está associado a cada porta aberta, consulte Netstat. Para obter mais informações, consulte também as atribuições de números de porta no site da Internet Assigned Numbers Authority (IANA).

    Observação

    • Os endereços da Web podem ser alterados; portanto, você talvez não consiga se conectar ao site ou sites da Web mencionados aqui.
  • Renomeie ou desabilite a conta Administrador; configure ou revise as permissões e contas relevantes para o servidor. Renomeie ou desabilite a conta Administrador criada durante a instalação (ela não pode ser excluída). Defina as contas e permissões apropriadas para configurar, fazer backup, operar e utilizar o servidor. Tanto para usuários quanto para administradores, limite o acesso ao mínimo necessário; por exemplo, para alguém que só realize backups, use o grupo Operadores de cópia. Defina também diretivas para garantir que os usuários mantenham senhas de alta segurança. Para obter mais informações, consulte:
    • Práticas recomendadas de segurança e Práticas recomendadas para usuários e computadores com Active Directory
    • Noções básicas sobre grupos e Grupos padrão
    • Senhas de alta segurança
  • Entenda as implicações de segurança que se aplicam ao seu servidor. As perguntas a serem feitas sobre segurança variam de acordo com o uso pretendido para o servidor. Por exemplo, no caso de um servidor de arquivos, quem precisa de acesso a determinado arquivo ou diretório, que tipo de acesso será necessário e quais são as possíveis conseqüências de um acesso não autorizado? No caso de um servidor Web, quais aplicativos da Web serão utilizados, quais os riscos inerentes a esses aplicativos e que configurações ajudarão a minimizar os riscos? Para obter mais informações, consulte os links na tabela a seguir:
    • Tipo de servidor | Tópicos de segurança sugeridos
Qualquer servidor | Consulte Práticas recomendadas de segurança e os tópicos relacionados às tecnologias que você utiliza em Práticas recomendadas.
Servidor de arquivos | Se estiver utilizando pastas compartilhadas, consulte Práticas recomendadas. Se estiver utilizando o Active Directory, consulte Visão geral sobre segurança.
Servidor multimídia | Consulte as seções de segurança na documentação do Windows Media Services, que ficam disponíveis quando o produto é instalado. Para obter mais informações, consulte Usando o Windows Media Services.
Servidor de impressão | Consulte Práticas recomendadas para impressão.
Terminal Server | Consulte Práticas recomendadas para o Terminal Server.
Servidor Web | Consulte a seção sobre segurança do Guia de Administração do Servidor para Serviços de Informações da Internet (IIS); esta documentação está disponível quando você instala o IIS. Para obter mais informações, consulte Serviços de Informações da Internet (IIS) 6.0.
  • Configure as definições de auditoria e as proteções do sistema e instale um programa antivírus. Verifique e implemente as configurações de auditoria, incluindo as de eventos de segurança, para permitir o controle de todas as alterações do sistema e a proteção contra alterações de softwares indesejadas. Para obter mais informações, consulte:
    • Auditoria em eventos de segurança
    • Tópicos sobre informações do sistema e a proteção de arquivos e drivers de sistema:
      Informações sobre o sistema, Proteção de arquivos do Windows, Assinatura de drivers para Windows, Verificador de arquivos de sistema, Usando verificação de assinatura de arquivos e Definir opções de verificação de assinatura de arquivos.
    • Práticas recomendadas de segurança
  • Tenha um firewall apropriado no local. Um firewall é um sistema de segurança que age como barreira de proteção entre uma rede e o mundo externo. Para obter informações sobre os recursos de firewall disponíveis no Windows Server 2003, Enterprise Edition e no Windows Server 2003, Standard Edition, consulte Firewall de conexão com a Internet. Para obter informações sobre produtos de firewall oferecidos pela Microsoft, consulte Internet Security and Acceleration (ISA) Server no site da Microsoft. (http://www.microsoft.com/)
  • Recomenda-se o uso do Assistente de Configuração de Segurança. Ele reduz a superfície de ataque dos servidores que executam o Windows Server 2003 com Service Pack 1 (SP1). Esse assistente faz uma série de perguntas ao usuário para determinar os requisitos funcionais do servidor. Qualquer funcionalidade não necessária às funções executadas pelo servidor é desabilitada. Além de ser uma prática recomendada de segurança fundamental, a redução da superfície de ataque aumenta a diversidade do cenário do Windows e reduz a quantidade de sistemas que necessitarão de atualização imediata em caso de problema de segurança. Para obter mais informações, consulte o site da Microsoft. (http://www.microsoft.com/)

Inicie operações de rotina como, por exemplo, backups.

  • Faça uma verificação de fragmentação no disco. Depois de executar a instalação dos programas, verifique se o disco rígido precisa ser desfragmentado. Para obter mais informações, consulte Para analisar um volume.
  • Execute backups e instale o Console de recuperação. Execute backups, instale o Console de recuperação para que esteja prontamente disponível sempre que o computador for iniciado, e pratique ou simule operações de recuperação (nos momentos em que a demanda sobre o servidor for baixa). Para obter mais informações, consulte:
    • Backup e restauração de dados
    • Instalar o Console de recuperação como opção de inicialização em um computador baseado em x86
    • Recuperação de desastres

Familiarize-se com as informações disponíveis.

  • Revise os tópicos de práticas recomendadas e as listas de verificação relacionadas aos recursos e componentes que você utilizará. Para obter uma lista dos tópicos de práticas recomendadas, consulte Práticas recomendadas. Para obter uma relação das listas de verificação, consulte Listas de verificação.
  • Familiarize-se com outras fontes de informação e ferramentas. Há diversas listas de recursos em Ajuda e suporte, incluindo o tópico Recursos do Guia de Introdução. As fontes relacionadas em Recursos de suporte também oferecem diversas informações.


Como...

  • Preparar-se para atualizações em um domínio que contenha controladores de domínio do Windows 2000
  • Iniciar a instalação em um computador baseado em x86
  • Iniciar a instalação em um computador com arquitetura baseada em Itanium
  • Inserir as configurações do servidor para uma nova instalação


Prepare-se para atualizações em um domínio que contenha controladores de domínio do Windows 2000

Elemento gráfico do Microsoft Windows

Preparar-se para atualizações em um domínio que contenha controladores de domínio do Windows 2000

  1. Antes de realizar esse procedimento, recomenda-se a aplicação do Service Pack 2 ou posterior a todos os controladores de domínio que executam Windows 2000.
  2. Localize o servidor que é o mestre de esquema e o servidor que é o mestre de infra-estrutura (podem ser o mesmo servidor).
  3. Faça backup do mestre de esquema. Você também pode fazer backup de outros servidores, como parte da preparação para atualização, mas não deixe de fazer backup do mestre de esquema antes de passar para a etapa seguinte.
  4. Desconecte o mestre de esquema da rede e só restabeleça a conexão na etapa 9 deste procedimento.
  5. No mestre de esquema, enquanto o Windows 2000 está funcionando, insira o CD de instalação do Windows Server 2003, Enterprise Edition na unidade de CD-ROM.
  6. Abra um prompt de comando, passe para a unidade de CD-ROM e vá para a pasta \i386 no CD.
  7. No mestre de esquema, no prompt de comando, digite

    adprep /forestprep

  8. Depois que o comando anterior tiver sido concluído no mestre de esquema, confirme se a preparação da floresta foi bem-sucedida. Para isso, você pode seguir estas etapas:
    • Confirme se nenhuma mensagem de erro foi exibida.
    • Execute qualquer ferramenta de diagnóstico do controlador de domínio que esteja disponível, por exemplo, Dcdiag. Lembre-se de que aparecerão erros de replicação enquanto o controlador de domínio estiver desconectado da rede.
    • Abra Visualizar eventos e verifique se há erros ou eventos inesperados no log do sistema.
  9. Avalie as informações reunidas na etapa anterior e faça a escolha apropriada:
    • Se adprep /forestprep for executado sem erros, reconecte o mestre de esquema à rede e continue com a próxima etapa deste procedimento.
    • Se adprep /forestprep for executado, mas as mensagens de erro fornecerem instruções para procedimentos adicionais, siga as instruções e, em seguida, retorne ao processo de confirmação descrito na etapa anterior.
    • Se adprep /forestprep não tiver sido executado com êxito, ou a ferramenta de diagnóstico, como o Dcdiag, tiver revelado um problema significativo, restaure o mestre de esquema a partir do backup e tome as providências corretivas necessárias para que o adprep /forestprep possa ser executado com êxito.
  10. Se o mestre de esquema for um computador diferente do mestre de infra-estrutura, aguarde as alterações efetuadas por adprep /forestprep para replicar do mestre de esquema para o mestre de infra-estrutura. Aguarde pelo menos quinze minutos, mas disponha de mais tempo (meio dia ou um dia) se os mestres de esquema e infra-estrutura não estiverem no mesmo site. Se você tentar realizar a preparação do domínio no mestre de infra-estrutura antes que as alterações sejam replicadas, o Adprep apresentará uma mensagem de erro para notificar que há necessidade de mais tempo.
  11. No mestre de infra-estrutura, enquanto o Windows 2000 está funcionando, insira o CD de instalação do Windows Server 2003, Enterprise Edition na unidade de CD-ROM.
  12. Abra um prompt de comando, passe para a unidade de CD-ROM e vá para a pasta \i386 no CD.
  13. No mestre de infra-estrutura, digite

    adprep /domainprep

  14. Depois que o comando anterior tiver sido concluído no mestre de infra-estrutura, confirme se a preparação do domínio foi bem-sucedida. Para isso, você pode seguir estas etapas:
    • Confirme se nenhuma mensagem de erro foi exibida.
    • Execute qualquer ferramenta de diagnóstico do controlador de domínio disponível.
    • Abra Visualizar eventos e verifique se há erros ou eventos inesperados no log do sistema.
  15. Avalie as informações reunidas na etapa anterior e faça a escolha apropriada:
    • Se adprep /domainprep for executado sem erros, continue com a próxima etapa deste procedimento.
    • Se adprep /domainprep for executado, mas as mensagens de erro fornecerem instruções para procedimentos adicionais, siga as instruções e, em seguida, retorne ao processo de confirmação descrito na etapa anterior.
  16. Aguarde até que as alterações efetuadas por adprep /domainprep sejam replicadas do mestre de infra-estrutura para outros controladores de domínio. Aguarde pelo menos quinze minutos, mas disponha de mais tempo (meio dia ou um dia) se o controlador de domínio estiver em um site remoto. Se você começar a atualizar um dos outros controladores de domínio antes que as alterações sejam replicadas, uma mensagem pop-up informará sobre a necessidade de mais tempo.

Observações

  • Para executar o comando adprep /forestprep, é necessário que você seja membro do grupo Administração de empresa e do grupo Administradores de esquemas no Active Directory ou que a autorização apropriada tenha sido delegada a você. Para executar adprep /domainprep, você precisa ser membro do grupo Admins. do domínio ou do grupo Administração de empresa no Active Directory ou precisa receber a delegação de autoridade apropriada. Como uma prática recomendada de segurança, é aconselhável usar Executar como para executar este procedimento.
  • Depois de concluir este procedimento, você pode deixar os controladores de domínio executando o Windows 2000 por um período de tempo indefinido ou pode iniciar imediatamente a atualização dos controladores de domínio.
  • A primeira etapa no planejamento da atualização de determinado servidor é verificar a compatibilidade do hardware com os produtos da família Windows Server 2003. Para obter mais obter informações sobre compatibilidade de hardware, consulte Tópicos relacionados.

Tópicos relacionados


Iniciar a instalação

Elemento gráfico do Microsoft Windows

Iniciar a instalação em um computador baseado em x86

  • Iniciar a instalação a partir do CD em um computador com Windows
  • Iniciar a instalação a partir de uma rede
  • Iniciar uma nova instalação a partir do CD em um computador com MS-DOS
  • Iniciar uma nova instalação iniciando o computador a partir do CD
  • Iniciar a instalação e fornecer um driver de armazenamento em massa ou um arquivo HAL


Iniciar a instalação a partir do CD em um computador com Windows

Elemento gráfico do Microsoft Windows

Para iniciar a instalação a partir do CD em um computador com Windows

  1. Insira o CD na unidade.
  2. Para iniciar a instalação, siga um destes procedimentos:
    • No caso de computadores com qualquer versão do Windows, exceto a 3.x, aguarde a instalação exibir uma caixa de diálogo.
    • No caso de computadores com Windows 3.x, use o Gerenciador de arquivos para ir para a unidade de CD-ROM e vá para a pasta I386. Em seguida, clique duas vezes em Winnt.exe.
  3. Siga as instruções da instalação.

Observações

  • Para realizar uma atualização com a instalação, você deverá ser membro do grupo Administradores no computador local ou deverá ter recebido a delegação de autoridade apropriada. Se o computador tiver ingressado em um domínio, os participantes do grupo Admins. do domínio poderão executar esse procedimento. Como uma prática recomendada de segurança, é aconselhável usar Executar como para executar este procedimento.
  • Se você estiver executando a instalação em um computador com Windows 3.x ou MS-DOS, para ser mais eficiente, use o cache de disco. Caso contrário, o processo de instalação (iniciado do Winnt.exe) pode ser demorado. Para habilitar o cache de disco em um computador com Windows 3.x ou MS-DOS, use o SMARTDrive. Para obter informações sobre o SMARTDrive, consulte a documentação do Windows 3.x ou do MS-DOS.
  • A instalação funciona em vários estágios, solicitando informações, copiando arquivos e reiniciando.
  • Para obter informações sobre instalação autônoma, consulte Tópicos relacionados.
  • Se você tiver um controlador de armazenamento em massa (como um adaptador SCSI, RAID ou Fibre Channel) para o disco rígido, consulte Tópicos relacionados para obter informações sobre como garantir que o arquivo de driver do controlador fique disponível para a instalação.
  • Se você tiver um hardware especializado que requeira um arquivo de camada de abstração de hardware (HAL) personalizado fornecido pelo fabricante do computador, consulte Tópicos relacionados para obter informações sobre como tornar o arquivo HAL disponível durante a instalação.

Tópicos relacionados


Iniciar a instalação a partir de uma rede

Elemento gráfico do Microsoft Windows

Para iniciar a instalação a partir de uma rede

  1. Em um servidor de rede, compartilhe os arquivos de instalação, inserindo o CD e compartilhando a unidade de CD-ROM ou copiando os arquivos da pasta I386 no CD para uma pasta compartilhada.
  2. No computador onde será feita a instalação, conecte-se com os arquivos compartilhados da instalação:
    • Se você estiver compartilhando a unidade de CD-ROM, conecte-se com a unidade compartilhada e vá para a pasta I386.
    • Se você estiver compartilhando uma pasta, conecte-se com essa pasta.
  3. Localize e execute o arquivo apropriado na pasta I386 do CD ou na pasta compartilhada:
    • Em um computador com MS-DOS ou Windows 3.x, execute o Winnt.exe.
    • Em um computador com Windows 95, Windows 98, Windows Millennium Edition, Windows NT com Service Pack 5 ou posterior, Windows 2000 ou Windows XP, execute o Winnt32.exe.
  4. Siga as instruções da instalação.

Observações

  • Para realizar uma atualização com a instalação, você deverá ser membro do grupo Administradores no computador local ou deverá ter recebido a delegação de autoridade apropriada. Se o computador tiver ingressado em um domínio, os participantes do grupo Admins. do domínio poderão executar esse procedimento. Como uma prática recomendada de segurança, é aconselhável usar Executar como para executar este procedimento.
  • A instalação funciona em vários estágios, solicitando informações, copiando arquivos e reiniciando.
  • Para obter informações sobre instalação autônoma, consulte Tópicos relacionados.
  • Se você tiver um controlador de armazenamento em massa (como um adaptador SCSI, RAID ou Fibre Channel) para o disco rígido, consulte Tópicos relacionados para obter informações sobre como garantir que o arquivo de driver do controlador fique disponível para a instalação.
  • Se você tiver um hardware especializado que requeira um arquivo de camada de abstração de hardware (HAL) personalizado fornecido pelo fabricante do computador, consulte Tópicos relacionados para obter informações sobre como tornar o arquivo HAL disponível durante a instalação.

Tópicos relacionados


Iniciar uma nova instalação a partir do CD em um computador que execute MS-DOS

Elemento gráfico do Microsoft Windows

Para iniciar uma nova instalação a partir do CD em um computador que execute MS-DOS

  1. Insira o CD na unidade.
  2. No prompt de comando, digite:

    d:

    onde d é a letra da unidade de CD-ROM.

  3. Digite:

    cd i386

  4. Digite:

    winnt

  5. Siga as instruções da instalação.

Observações

  • Se você estiver executando a instalação em um computador com Windows 3.x ou MS-DOS, para ser mais eficiente, use o cache de disco. Caso contrário, o processo de instalação (iniciado do Winnt.exe) pode ser demorado. Para habilitar o cache de disco em um computador com Windows 3.x ou MS-DOS, use o SMARTDrive. Para obter informações sobre o SMARTDrive, consulte a documentação do Windows 3.x ou do MS-DOS.
  • A instalação funciona em vários estágios, solicitando informações, copiando arquivos e reiniciando.
  • Para obter informações sobre instalação autônoma, consulte Tópicos relacionados.
  • Se você tiver um controlador de armazenamento em massa (como um adaptador SCSI, RAID ou Fibre Channel) para o disco rígido, consulte Tópicos relacionados para obter informações sobre como garantir que o arquivo de driver do controlador fique disponível para a instalação.
  • Se você tiver um hardware especializado que requeira um arquivo de camada de abstração de hardware (HAL) personalizado fornecido pelo fabricante do computador, consulte Tópicos relacionados para obter informações sobre como tornar o arquivo HAL disponível durante a instalação.

Tópicos relacionados


Iniciar uma nova instalação iniciando o computador a partir do CD

Elemento gráfico do Microsoft Windows

Para iniciar uma nova instalação iniciando o computador a partir do CD

  1. Determine se o computador em que você deseja iniciar a instalação pode ser iniciado a partir da unidade de CD-ROM e se deseja executar uma nova instalação (não uma atualização). Continue somente se as duas afirmativas forem verdadeiras.
  2. Insira o CD na unidade e reinicie o computador.
  3. Siga as instruções para que o sistema operacional inicialize o computador a partir do CD.
  4. Espere até a instalação exibir uma caixa de diálogo e siga as instruções desse programa.

Observações

  • Este método só se aplica se você desejar executar uma nova instalação, e não uma atualização. Este método pode ser utilizado para executar uma instalação em computadores com ou sem sistema operacional.
  • A instalação funciona em vários estágios, solicitando informações, copiando arquivos e reiniciando.
  • Para obter informações sobre instalação autônoma, consulte Tópicos relacionados.
  • Se você tiver um controlador de armazenamento em massa (como um adaptador SCSI, RAID ou Fibre Channel) para o disco rígido, consulte Tópicos relacionados para obter informações sobre como garantir que o arquivo de driver do controlador fique disponível para a instalação.
  • Se você tiver um hardware especializado que requeira um arquivo de camada de abstração de hardware (HAL) personalizado fornecido pelo fabricante do computador, consulte Tópicos relacionados para obter informações sobre como tornar o arquivo HAL disponível durante a instalação.

Tópicos relacionados


Iniciar a instalação e fornecer um driver de armazenamento em massa ou um arquivo HAL

Elemento gráfico do Microsoft Windows

Para iniciar a instalação e fornecer um driver de armazenamento em massa ou um arquivo HAL

  1. Determine se é necessário fornecer à instalação um arquivo especial (um driver de armazenamento em massa ou arquivo de camada de abstração de hardware (HAL)) fornecido pelo fabricante do hardware:
    • Se você tiver um controlador de armazenamento em massa (como um adaptador SCSI, RAID ou Fibre Channel) para o disco rígido, verifique se o fabricante forneceu um arquivo de driver separado para uso com a família Windows Server 2003.
    • Se você tiver um sistema de computador altamente especializado, examine a documentação do hardware para verificar se o fabricante do computador forneceu um arquivo HAL personalizado.
  2. Se você determinar que precisa de um driver ou arquivo HAL fornecido pelo fabricante do hardware, antes de iniciar a instalação, localize o disquete ou outra mídia que contém o arquivo.
  3. Durante a parte inicial da instalação, observe a parte inferior da tela até que seja exibida a solicitação para pressionar F6. Pressione a tecla apropriada da seguinte forma:
    • Para fornecer o driver de um controlador de armazenamento em massa à instalação, pressione F6 conforme instruído.
    • Para fornecer um arquivo HAL à instalação, pressione F5.
  4. Siga as orientações posteriores para saber sobre como fornecer o arquivo de driver à instalação para que ela possa ter acesso ao controlador de armazenamento em massa.

Observação

  • Se você não tiver certeza de que deve obter um arquivo de driver separado, com o fabricante do controlador de armazenamento em massa, tente executar a instalação. Se o controlador não for compatível com os arquivos de driver no CD de instalação e, portanto, requerer um arquivo de driver fornecido pelo fabricante do hardware, a instalação pára e exibe uma mensagem informando que não foi possível encontrar dispositivos de disco ou exibe uma lista incompleta de controladores. Depois de obter o arquivo de driver necessário, reinicie a instalação e pressione F6 quando solicitado.

Tópicos relacionados


Iniciar a instalação em um computador com arquitetura baseada em Itanium

Elemento gráfico do Microsoft Windows

Iniciar a instalação em um computador com arquitetura baseada em Itanium

  1. Imediatamente após ligar o computador, insira o CD da instalação na unidade de CD-ROM.
  2. Quando o menu Gerenciador de inicialização EFI aparecer, selecione a opção de CD-ROM.
  3. Quando solicitado, pressione qualquer tecla para iniciar do CD-ROM.
  4. Siga as instruções de instalação na tela.

Importante

  • Computadores com arquitetura baseada em Itanium requerem um mínimo de 100 MB na partição com FAT para a operação da interface de firmware extensível (EFI). A partição do sistema EFI é criada automaticamente durante a instalação e armazena programas e arquivos de informações que a EFI usa para iniciar o sistema operacional. Não exclua ou reformate essa partição.
  • A instalação também cria uma partição reservada da Microsoft (MSR), que é necessária para o sistema operacional. O tamanho dessa partição depende do tamanho do disco rígido. Em unidades menores que 16 GB, a MSR é de 32 MB. Em unidade maiores ou iguais a 16 GB, a MSR é de 128 MB. Não exclua ou reformate essa partição.

Observações

  • Antes de instalar, verifique se você está usando a versão correta do firmware. Para obter mais informações, consulte a documentação do fabricante do hardware.
  • A EFI define um novo estilo de partição chamado tabela de partição GUID (GPT), que está disponível somente para computadores com arquitetura baseada em Itanium. A partição de instalação em um computador com arquitetura baseada em Itanium deve estar em um disco GPT. A instalação especifica automaticamente o GPT para o disco usado para a instalação. Você ainda pode ler e gravar em volumes do registro de inicialização mestre (MBR), que são comuns na maioria dos PCs, mas você não pode instalar em um deles. Para obter mais informações, consulte Tópicos relacionados.
  • Você não pode acessar discos GPT localmente de um computador com x86. Se desejar mover um disco de um computador com arquitetura baseada em Itanium para um computador x86, use um disco MBR. Isso é verdadeiro independentemente de o disco ser básico ou dinâmico.

Tópicos relacionados


Inserir as configurações do servidor para uma nova instalação

  • Especificar as opções regionais e de idioma, além do nome do usuário, durante a instalação
  • Especificar o modo de licenciamento durante a instalação
  • Digitar o nome do computador
  • Definir a senha da conta do administrador
  • Definir a data e hora
  • Permitir que a instalação atribua ou obtenha um endereço IP
  • Especificar um endereço IP estático e as configurações necessárias para DNS e WINS
  • Especificar nome de domínio ou grupo de trabalho

Observações

  • Os tópicos desta seção oferecem detalhes sobre como digitar configurações do servidor para uma nova instalação. Se você estiver fazendo uma atualização, poderá ignorar estes tópicos porque a instalação usará as configurações anteriores.
  • Se você tiver um controlador de armazenamento em massa, como um adaptador SCSI, RAID ou Fibre Channel, para o disco rígido ou se tiver um computador especializado que necessite de um arquivo HAL personalizado fornecido pelo fabricante do computador, consulte Iniciar a instalação e fornecer um driver de armazenamento em massa ou um arquivo HAL.
  • Depois que você inicia a instalação, começa um processo no qual os arquivos de instalação necessários são copiados para o disco rígido. Durante esse processo, a instalação exibe caixas de diálogo que você pode usar para selecionar várias opções.


Especificar as opções regionais e de idioma, além do nome do usuário, durante a instalação

Elemento gráfico do Microsoft Windows

Para especificar opções regionais e de idioma, além do nome do usuário, durante a instalação

  1. Durante a instalação, na caixa de diálogo Opções regionais e de idioma, siga as instruções para personalizar configurações de idioma e localidade. Você pode usar várias opções regionais e de idiomas.
  2. Na caixa de diálogo Personalizar o software, digite seu nome e, opcionalmente, o nome da organização.
  3. Prossiga com a instalação.

Observações

  • XOX
  • Se você selecionar um país ou região da Europa na lista de países/regiões, ou se viver em um país ou região em que o euro tenha sido introduzido, é recomendável verificar se as configurações de moeda padrão em Opções regionais e de idioma atendem às suas necessidades.
  • Depois de realizar a instalação, você pode modificar as opções regionais e de idiomas no Painel de controle. Para obter mais informações, consulte Tópicos relacionados.

Tópicos relacionados


Especificar o modo de licenciamento durante a instalação

Elemento gráfico do Microsoft Windows

Para especificar um modo de licenciamento durante a instalação

  1. Durante a instalação, na caixa de diálogo Modos de licenciamento, selecione o modo de licenciamento do cliente:
    • por servidor
    • por dispositivo ou por usuário
  2. Prossiga com a instalação.

Observação

  • Se você não estiver certo quanto ao modo a ser utilizado, selecione Por servidor, pois é possível passar uma vez de Por servidor para Por dispositivo ou por usuário sem custo algum. Para obter mais informações sobre modos de licenciamento, consulte Tópicos relacionados.

Tópicos relacionados


Digitar o nome do computador

Elemento gráfico do Microsoft Windows

Para digitar o nome do computador

  • Durante a instalação, na caixa de diálogo Nome do computador e senha do administrador, siga as instruções para digitar o nome do computador. O tamanho recomendado na maioria dos idiomas é 15 caracteres ou menos. Em idiomas que requeiram mais espaço de armazenamento por caractere, como o chinês, japonês e coreano, recomenda-se um nome com até 7 caracteres.

Observações

  • É recomendável usar apenas caracteres padrão da Internet no nome do computador. Os caracteres padrão são os números de 0 a 9, letras maiúsculas e minúsculas de A a Z e o caractere hífen (-). Os nomes de computador não podem ser inteiramente constituídos de números.
  • Se você estiver usando o DNS (sistema de nomes de domínios) na rede, poderá usar uma variedade mais ampla de caracteres, incluindo Unicode e outros caracteres não-padrão, como o E comercial (&). O uso de caracteres fora do padrão pode afetar a capacidade de um software que não seja da Microsoft de operar na rede. Para obter mais informações sobre DNS, consulte Tópicos relacionados.
  • O tamanho máximo de um nome de computador é 63 bytes. Se o nome for maior que 15 bytes (15 caracteres na maioria dos idiomas e 7 em alguns), os computadores com Windows NT Server 4.0 ou versões anteriores reconhecerão esse computador apenas pelos primeiros 15 bytes do nome. Além disso, existem etapas adicionais de configuração para nomes com mais de 15 bytes. Para obter mais informações, consulte Tópicos relacionados.
  • Se o computador fizer parte de um domínio, você deverá escolher um nome de computador diferente de qualquer outro computador do domínio. Para evitar conflitos de nomes, o computador deve ser exclusivo no domínio, grupo de trabalho ou rede. Se esse computador fizer parte de um domínio, e contiver mais de um sistema operacional, use um nome de computador exclusivo para cada sistema operacional instalado. Por exemplo, se o nome do computador for ServidorArqNT ao ser iniciado com Windows NT Server 4.0, deverá ter um nome diferente, como ServidorArqNovo, ao ser iniciado com um produto da família Windows Server 2003. Esse requisito também se aplica a um computador que contém várias instalações do mesmo sistema operacional.

Tópicos relacionados


Definir a senha da conta Administrador

Elemento gráfico do Microsoft Windows

Para definir a senha da conta Administrador

  1. Durante a instalação, na caixa de diálogo Nome do computador e senha do administrador, digite uma senha com até 127 caracteres na caixa Senha do administrador. Para obter maior segurança do sistema, use uma senha que tenha no mínimo 7 caracteres e uma combinação de letras maiúsculas e minúsculas, números e outros caracteres como *, ? ou $.
  2. Na caixa Confirmar senha, digite essa senha novamente.
  3. Prossiga com a instalação.

Importante

  • Após a conclusão da instalação, para maior segurança, altere o nome da conta do administrador (ela não pode ser excluída) e mantenha sempre uma senha de alta segurança na conta. Para obter mais informações, consulte Senhas de alta segurança.

Tópicos relacionados


Definir a data e hora

Elemento gráfico do Microsoft Windows

Para definir a data e hora

  1. Durante a instalação, na caixa de diálogo Configurações de data e hora, defina data, hora e fuso horário.
  2. Se desejar que o sistema se ajuste automaticamente para o horário de verão, marque a caixa de seleção Ajustar automaticamente o relógio para o horário de verão.
  3. Prossiga com a instalação.

Observações

  • É possível alterar a data e hora do computador após concluir a instalação. Para obter mais informações, consulte Tópicos relacionados.
  • Se seu computador for membro de um domínio, provavelmente o relógio dele é sincronizado automaticamente por um servidor de horário da rede. Caso não seja, você poderá sincronizar o relógio com um servidor de horário da Internet. Para obter mais informações, consulte Tópicos relacionados.

Tópicos relacionados


Permita que a instalação atribua ou obtenha um endereço IP

Elemento gráfico do Microsoft Windows

Para permitir que a instalação atribua ou obtenha um endereço IP

  • Durante a instalação, na caixa de diálogo Configurações de rede, clique em Configurações típicas.

Observações

  • Quando você clica em Configurações típicas na caixa de diálogo Configurações de rede, a instalação verifica se existe um servidor DHCP na rede. Se houver um servidor DHCP na rede, o DHCP fornecerá um endereço IP. Caso não haja servidor DHCP na rede, a instalação usará uma opção de endereçamento IP limitada denominada endereçamento IP particular automático (APIPA). Em um servidor com APIPA, conclua a configuração da rede após a instalação, porque um servidor com APIPA só pode se comunicar com outros computadores que usam esse recurso no mesmo segmento de rede.
  • Para obter informações sobre como configurar o endereçamento IP automático após a instalação, consulte Tópicos relacionados.

Tópicos relacionados


Especificar um endereço IP local estático e as configurações necessárias para DNS e WINS

Elemento gráfico do Microsoft Windows

Para especificar um endereço IP estático e as configurações necessárias para DNS e WINS

  1. Durante a instalação, na caixa de diálogo Configurações de rede, clique em Configurações personalizadas e, em seguida, em Avançar.
  2. Na caixa de diálogo Componentes de rede, clique em Protocolo TCP/IP.
  3. Clique em Propriedades.
  4. Na caixa de diálogo Propriedades do Internet Protocol (TCP/IP), clique em Usar o seguinte endereço IP.
  5. Em Endereço IP, Máscara de sub-rede e Gateway padrão, digite os endereços apropriados.
  6. Em Usar os seguintes endereços de servidor DNS, digite o endereço de um servidor DNS preferencial e, opcionalmente, um servidor DNS alternativo.

    Se o servidor local for o servidor DNS preferencial ou alternativo, digite o mesmo endereço IP atribuído na etapa anterior.

  7. Se você usar um servidor WINS, clique em Avançado e, em seguida, clique na guia WINS da caixa de diálogo Configurações TCP/IP avançadas para adicionar o endereço IP de um ou mais servidores WINS.
  8. Clique em OK em cada caixa de diálogo e continue com a instalação.

Observações

  • Para obter informações sobre como definir as configurações de rede (incluindo um endereço IP estático) após a instalação, consulte Tópicos relacionados.

Tópicos relacionados


Especificar nome de domínio ou grupo de trabalho

Elemento gráfico do Microsoft Windows

Para especificar nome do grupo de trabalho ou domínio

  1. Durante a instalação, na caixa de diálogo Domínio do computador ou grupo de trabalho escolha se o servidor ficará em um grupo de trabalho ou em um domínio.
  2. Especifique o nome do grupo de trabalho ou domínio.
  3. Prossiga com a instalação.

Observações

  • Para evitar conflitos de nomes, o computador deve ser exclusivo no domínio, grupo de trabalho ou rede. Se o computador fizer parte de um domínio e contiver mais de um sistema operacional, use um nome de computador exclusivo para cada sistema operacional instalado. Por exemplo, se o computador tiver o nome de ServidorArqNT ao ser iniciado com Windows NT Server 4.0, deverá ter um nome diferente, talvez ServidorArqNovo, ao ser iniciado com Windows NT Server 4.0, deverá ter um nome diferente, talvez ServidorArqNovo, ao ser iniciado com Windows Server 2003, Standard Edition. Esse requisito também se aplica a um computador que contém várias instalações do mesmo sistema operacional.
  • Para obter mais informações sobre os requisitos para ingresso em um grupo de trabalho ou domínio, consulte Tópicos relacionados.

Tópicos relacionados


Conceitos

Esta seção oferece fundamentos para planejar a instalação do Windows Server 2003, Enterprise Edition. Para obter informações sobre quais tópicos se aplicam caso você esteja atualizando e quais se aplicam no caso de uma nova instalação, consulte os seguintes itens:

  • Lista de verificação: Executando uma atualização
  • Lista de verificação: Executando uma nova instalação

Os tópicos a seguir fornecem informações detalhadas sobre as opções feitas durante o processo de instalação.

  • Arquivos importantes a serem revisados
  • Escolhendo um modo de licenciamento
  • Usando a atualização dinâmica para drivers atualizados e outros arquivos de instalação
  • Planejando uma instalação autônoma
  • Requisitos do sistema e compatibilidade de hardware
  • Atualizando ou instalando
  • Decidindo se um computador conterá mais de um sistema operacional
  • Escolhendo um sistema de arquivos para a partição de instalação
  • Planejando volumes ou partições de disco para novas instalações
  • Redes: TCP/IP, endereços IP e resolução de nomes
  • Decidindo entre grupos de trabalho e domínios
  • Preparando o sistema antes de executar a instalação
  • Recursos


Arquivos importantes a serem revisados

Em algum momento no processo de planejamento de uma nova instalação ou atualização, familiarize-se com o arquivo Relnotes.htm encontrado na pasta \Docs no CD do Windows Server 2003, Enterprise Edition. Este arquivo contém informações importantes sobre a utilização de hardware, redes, aplicativos e impressão. Familiarize-se também com as informações sobre compatibilidade de hardware para produtos da família Windows Server 2003. Para obter mais informações, consulte Compatibilidade de hardware.

Para obter as informações mais recentes sobre aplicativos compatíveis com produtos da família Windows Server 2003, consulte a seção sobre compatibilidade de software do site da Microsoft (http://www.microsoft.com).

A maioria das informações contida nos tópicos do Guia de Introdução também são exibidas na pasta \Docs no Windows Server 2003, Enterprise Edition CD, em arquivos de texto (que usam uma extensão de nome de arquivo "TXT").


Escolhendo um modo de licenciamento

Os produtos da família Windows Server 2003 oferecem suporte a dois modos de licenciamento:

  • por dispositivo ou por usuário
  • por servidor

O diagrama a seguir ilustra os dois modos:

Licenças por servidor comparadas a licenças por dispositivo ou por usuário

Se você escolher o modo por dispositivo ou por usuário, cada dispositivo ou usuário que acessar um servidor que execute um produto da família Windows Server 2003 precisará de uma licença de acesso para cliente (CAL) separada. Com uma Licença de Acesso para Cliente, um computador cliente poderá se conectar com qualquer número de servidores executando produtos da família Windows Server 2003. Este é o método de licenciamento mais comumente usado para empresas com mais de um servidor executando produtos da família Windows Server 2003.

Por outro lado, o licenciamento Por servidor significa que cada conexão simultânea com o servidor precisará de uma CAL separada. Em outras palavras, esse servidor poderá, a qualquer momento, fornecer suporte a um número fixo de conexões. Por exemplo, se você selecionar o modo de licenciamento de cliente Por servidor com cinco licenças, esse servidor poderá ter cinco conexões simultâneas em um momento (se cada cliente precisar de uma conexão, isso significará cinco clientes ao mesmo tempo). Os clientes que usam as conexões não precisam de licenças adicionais.

O modo de licenciamento Por servidor geralmente é preferido por empresas pequenas com apenas um servidor. Também é útil para servidores da Internet ou de acesso remoto em que os computadores cliente talvez não estejam licenciados como clientes de rede para produtos da família Windows Server 2003. Você pode especificar um número máximo de conexões de servidor simultâneas e rejeitar quaisquer solicitações de logon adicionais.

Se você ainda não souber que modo usar, escolha Por servidor, pois é possível alterar uma vez desse modo para o modo Por dispositivo ou Por usuário sem custo algum. Para obter mais informações sobre licenciamento e modos de licenciamento, consulte Visão geral sobre licenciamento e as Listas de verificação de licenciamento.

Observação

  • Se utilizar o Terminal Server, você precisará de medidas adicionais para configurar e ativar o licenciamento do Terminal Server. Para obter mais informações, consulte Licenciando o Terminal Server.


Usando a atualização dinâmica para drivers atualizados e outros arquivos de instalação

Se houver uma conexão com a Internet ativa no computador em que você está executando a instalação, será possível escolher a Atualização dinâmica durante a instalação e obter os arquivos mais atualizados desse programa, inclusive drivers e outros arquivos. Sempre que é feita uma atualização importante em qualquer arquivo essencial da instalação, essa atualização torna-se disponível através da funcionalidade Atualização dinâmica, disponível no site Windows Update. Alguns arquivos atualizados serão substituições (por exemplo, um driver ou arquivo atualizado da instalação) e outros serão adições (por exemplo, um driver não disponível na época em que o CD da instalação foi criado). É recomendável usar a Atualização dinâmica durante a execução da instalação.

A Atualização dinâmica foi projetada cuidadosamente, de modo a ser confiável e fácil de usar:

  • Os arquivos da seção sobre Atualização dinâmica do site do Windows Update foram testados e selecionados cuidadosamente. Apenas os arquivos importantes para garantir que a instalação seja executada corretamente são disponibilizados pela Atualização dinâmica. Os arquivos com atualizações secundárias que não afetarão de forma significativa a instalação não fazem parte da Atualização dinâmica.
  • Como a Atualização dinâmica só baixa os arquivos necessários ao computador, o software de Atualização dinâmica examina brevemente o hardware do computador. Nenhuma informação pessoal é coletada e nenhuma informação é salva. A única finalidade é selecionar os drivers apropriados para a sua configuração de hardware. Isso mantém o download o mais breve possível e garante que apenas os drivers necessários sejam baixados no disco rígido.
  • A Atualização dinâmica pode ser usada ao verificar a compatibilidade de pré-instalação a partir do CD do produto ou na instalação propriamente dita. De qualquer forma, você obtém os arquivos mais atualizados para executar a instalação. Para obter informações sobre a verificação de compatibilidade, consulte Compatibilidade de hardware.
  • É possível usar a Atualização dinâmica com a instalação autônoma. A preparação para isso requer várias etapas. Para obter uma descrição rápida da instalação autônoma, consulte Planejando uma instalação autônoma. Para obter informações detalhadas sobre como usar a Atualização Dinâmica com a instalação autônoma (também chamada instalação automática), consulte o tópico sobre automatização e personalização de instalações no site da Microsoft (http://www.microsoft.com/).

O site Windows Update oferece várias atualizações que você pode usar depois de concluir a instalação. Para obter mais informações, consulte Windows Update no site da Microsoft. Para obter uma descrição das diferentes formas de usar o Windows Update, consulte Windows Update.


Planejar a instalação autônoma

Este tópico fornece informações gerais sobre a instalação autônoma. Para obter informações detalhadas sobre como usar a instalação autônoma (também chamada de instalação automática), consulte Automating and Customizing Installations no site Microsoft Windows Resource Kits (http://www.microsoft.com/). (http://www.microsoft.com/) Consulte também o Windows XP Professional Resource Kit no site Microsoft Windows Resource Kits. (http://www.microsoft.com/) Para obter informações sobre os Windows Deployment and Resource Kits, consulte o site Windows Deployment and Resource Kits.

Para simplificar o processo de configurar um produto da família Windows Server 2003 em vários computadores, execute a instalação autônoma. Para isso, crie e use um arquivo de resposta, ou seja, um script personalizado que responde às perguntas da instalação automaticamente. Em seguida, execute o Winnt32.exe ou Winnt.exe com as opções de instalação autônoma apropriadas. Escolha o comando de acordo com o sistema operacional executado quando você iniciar a instalação autônoma:

  • Para iniciar a instalação autônoma em um computador que execute o MS-DOS ou o Windows 3.x, use o Winnt.exe (com as opções apropriadas).
  • Para iniciar uma Instalação autônoma em um computador que execute Windows 95, Windows 98, Windows Millennium Edition, Windows NT, Windows 2000, Windows XP ou um produto da família Windows Server 2003, use o Winnt32.exe (com as opções apropriadas). Com o Windows NT 4.0, antes de iniciar uma instalação autônoma, aplique o Service Pack 5 ou posterior.

Para saber sobre a instalação autônoma, consulte as seguintes fontes:

  • Para obter instruções detalhadas sobre como executar uma instalação autônoma (também denominada instalação automatizada): Consulte os Windows Deployment and Resource Kits listados no primeiro parágrafo deste tópico.
  • Para exibir as opções de comando disponíveis para o Winnt.exe: Em um computador com Windows 3.x ou MS-DOS, insira o CD de instalação de um produto da família Windows Server 2003 na unidade de CD-ROM e abra o prompt de comando. Em seguida, mude para a unidade de CD-ROM, vá para a pasta I386 e digite:
    winnt /?
  • Para usar um computador baseado em x86 para exibir as opções de comando disponíveis para o Winnt32.exe: Em um computador com Windows 95, Windows 98, Windows Millennium Edition, Windows NT, Windows 2000, Windows XP ou um produto da família Windows Server 2003, insira o CD de instalação de um produto da família Windows Server 2003 na unidade de CD-ROM e abra o prompt de comando. Em seguida, mude para a unidade de CD-ROM, vá para a pasta I386 e digite:
    winnt32 /?
  • Para usar um computador com arquitetura baseada em Itanium para exibir as opções de comando disponíveis para o Winnt32.exe: Em um computador com arquitetura baseada em Itanium com Windows XP 64-Bit Edition, a versão de 64 bits do Windows Server 2003, Enterprise Edition ou a versão de 64 bits do Windows Server 2003, Datacenter Edition, insira o CD de instalação da versão de 64 bits do produto na unidade de CD-ROM e abra o prompt de comando (clique em Iniciar, clique em Executar e digite cmd). Em seguida, mude para a unidade de CD-ROM, vá para a pasta I386 e digite:
    winnt32 /?

Para obter informações sobre como usar o Winnt.exe ou o Winnt32.exe em instalações interativas (instalações não autônomas), consulte Como....


Requisitos do sistema e compatibilidade de hardware

  • Requisitos do sistema
  • Visão geral sobre hardware
  • Compatibilidade de hardware
  • Fazendo um levantamento dos dispositivos que não utilizam Plug and Play
  • Drivers de armazenamento em massa e o processo de instalação
  • Noções básicas sobre BIOS da ACPI em um computador x86


Requisitos do sistema

Para garantir um desempenho adequado, verifique se os computadores nos quais instalará ou atualizará para Windows Server 2003, Enterprise Edition atendem os seguintes requisitos:

  • Em computadores x86:
    • Um ou mais processadores com uma velocidade mínima recomendada de 550 megahertz (MHz). A velocidade mínima com suporte é 133 MHz. Há suporte para um máximo de oito processadores por computador. É recomendável utilizar os processadores da família Intel Pentium/Celeron, AMD K6/Athlon/Duron ou processadores compatíveis.
    • 256 megabytes (MB) de RAM (mínimo recomendado). O mínimo aceito é de 128 MB e o máximo de 32 gigabytes (GB). Em computadores com mais de 4 GB de RAM, confirme a compatibilidade do hardware clicando no link apropriado em Recursos de suporte.
  • Em computadores com arquitetura baseada em Itanium:
    • Um ou mais processadores com uma velocidade mínima de 733 MHz. Há suporte para um máximo de oito processadores por computador.
    • Mínimo de 1 GB de memória RAM, máximo de 1024 GB (1 Terabyte).

      Em computadores com mais de 4 GB de RAM, confirme a compatibilidade do hardware clicando no link apropriado em Recursos de suporte.

  • Em um computador baseado em x64:
    • Um ou mais processadores com velocidade mínima de 1,4 GHz. Há suporte para um máximo de oito processadores por computador.
    • Mínimo de 1 GB de memória RAM, máximo de 1024 GB (1 Terabyte).

      Em computadores com mais de 4 GB de RAM, confirme a compatibilidade do hardware clicando no link apropriado em Recursos de suporte.

  • Uma partição de disco rígido ou volume com espaço livre suficiente para acomodar o processo de instalação. Para garantir flexibilidade no uso posterior do sistema operacional, é recomendável que haja bem mais espaço disponível do que o mínimo necessário para executar a instalação, que é de aproximadamente 2 GB a 3 GB para as versões baseadas em x86 do Windows Server 2003 e de 4 GB para as versões baseadas em Itanium e x64 desse sistema. Será necessário maior quantidade de espaço se você estiver executando a instalação através de uma rede, e não de um CD-ROM, ou se estiver instalando em uma partição FAT ou FAT32, no caso das versões do Windows Server 2003 baseadas em x86 ou x64. (NTFS é o sistema de arquivos recomendado para ambas as versões do Windows Server 2003 baseadas em x86 e x64. As versões desse sistema baseadas em Itanium oferecem suporte apenas ao NFTS). A quantidade de espaço maior será necessária se você estiver realizando a instalação via rede e não a partir de um CD-ROM, ou se estiver fazendo uma instalação em uma partição FAT ou FAT32 (NTFS é o sistema de arquivos recomendado).

    Além disso, uma atualização do controlador do domínio a partir do Windows NT 4.0 poderá requerer muito mais espaço que outras atualizações ou instalações, uma vez que o banco de dados de contas de usuários poderá ser expandido em até dez vezes durante a atualização, à medida que a funcionalidade do Active Directory for adicionada.

    Observação

    • O processo de instalação requer o espaço livre em disco descrito nos parágrafos anteriores. Depois de concluída a instalação, o espaço real em disco rígido usado pelo sistema operacional será maior que o espaço livre requerido para a instalação, devido ao espaço necessário para o arquivo de paginação, para quaisquer componentes opcionais que venham a ser instalados e (em controladores de domínio) para contas de usuário e outras informações do Active Directory. O tamanho comum do arquivo de paginação é 1,5 vezes o tamanho da RAM. Para obter mais informações, consulte:
      • Alterar configurações de memória virtual
      • Especificar o que acontecerá se o sistema parar de forma inesperada
      • Escolhendo os componentes a serem instalados
      • Noções básicas sobre o Active Directory
      • Armazenamento de dados de diretório

      Para obter informações adicionais sobre como planejar o tamanho de partições de disco ou volumes, incluindo informações sobre como criar uma partição separada para os Serviços de instalação remota, consulte Considerações ao planejar partições de disco e Requisitos de sistema dos Serviços de instalação remota.

  • Monitor VGA ou com resolução superior (é recomendável VGA 800x600 ou superior), teclado e (opcionalmente) um mouse ou outros dispositivo apontador.

    Como alternativa, para operar sem monitor ou teclado, você pode escolher um processador de diagnóstico e suporte remotos projetado para produtos da família Windows Server 2003. Para obter mais informações sobre compatibilidade de hardware, clique no link apropriado em Recursos de suporte.

Para instalação a partir de CD-ROM:

  • Uma unidade de CD-ROM ou DVD.

Para instalação a partir da rede:

  • Um ou mais adaptadores de rede e cabos correspondentes projetados para produtos da família Windows Server 2003. Para obter mais informações sobre compatibilidade de hardware, clique no link apropriado em Recursos de suporte.
  • Um servidor a partir do qual oferecer acesso à rede para os arquivos de instalação.

Para obter funcionalidade adicional baseada em hardware:

  • Hardware apropriado para a funcionalidade necessária. Por exemplo, se você planeja suportar clientes de rede, os servidores e os clientes devem ter os adaptadores e os cabos de rede apropriados. Se você precisa de um servidor de cluster, toda a solução de cluster deve ser listada como compatível com Windows Server 2003, Enterprise Edition (para obter mais detalhes, consulte as informações sobre hardware e drivers de cluster em Planejamento e preparação para instalação de cluster). Para obter mais detalhes sobre o hardware, clique no link apropriado em Recursos de suporte.


Compatibilidade de hardware

Uma das medidas mais importantes a serem tomadas antes de executar a instalação é confirmar se o hardware é compatível com os produtos da família Windows Server 2003. Você pode fazer isso executando uma verificação de compatibilidade de pré-instalação a partir do CD de instalação ou verificando as informações de compatibilidade de hardware disponíveis na Microsoft. Além disso, como parte da confirmação da compatibilidade de hardware, verifique se você obteve drivers de dispositivo de hardware atualizados e um BIOS (ou, para um computador com arquitetura baseada em Itanium, o firmware correto).

Mesmo que você não execute uma verificação de compatibilidade de pré-instalação, a instalação verifica a compatibilidade de hardware e software no início de uma atualização ou uma nova instalação e exibe um relatório caso haja alguma incompatibilidade.

Executando uma verificação de compatibilidade de pré-instalação a partir do CD de instalação
É possível executar uma verificação de compatibilidade de hardware e software a partir do CD de Instalação. A verificação de compatibilidade não exige que você inicie uma atualização ou instalação. Para executar a verificação, insira o CD de Instalação na unidade de CD-ROM e, quando for exibida uma tela, siga os prompts para verificar a compatibilidade do sistema. Você terá a opção de baixar os arquivos da instalação mais recentes (através da Atualização dinâmica) quando executar a verificação. Se você tiver conectividade com a Internet, é recomendável permitir o download.

Para obter mais informações sobre o download dos arquivos de instalação mais recentes, consulte Usando a atualização dinâmica para drivers atualizados e outros arquivos de instalação.

Para executar a verificação de compatibilidade de outra forma, insira o CD de instalação na unidade de CD-ROM, abra um prompt de comando e digite

d:\i386\winnt32 /checkupgradeonly

onde d representa a unidade de CD-ROM.

Verificando as informações de compatibilidade de hardware e software disponíveis na Microsoft
Outra forma de confirmar se o hardware e o software foram projetados para produtos da família Windows Server 2003 é clicar nos links apropriados para obter informações de compatibilidade em Recursos de suporte.

Observe que não há mais suporte para o tipo de hardware microchannel bus.

Verificando drivers e o BIOS do sistema ou firmware
Verifique se você obteve os drivers atualizados para os dispositivos de hardware e se você tem a última versão do BIOS do sistema (para um computador x86) ou o firmware correto (para um computador com arquitetura baseada em Itanium). Os fabricantes de dispositivos podem ajudá-lo a obter esses itens. Para obter mais informações sobre a interface de energia e configuração avançada (ACPI) padrão para o BIOS, consulte Noções básicas sobre a ACPI para BIOS para um computador baseado em x86.

Entretanto, se você tiver dispositivos que não usem o recurso Plug and Play ou souver que os dispositivos Plug and Play não foram implementados exatamente de acordo com os padrões, é aconselhável realizar um inventário dos dispositivos de hardware do computador. Para obter mais informações, consulte Fazendo um levantamento dos dispositivos que não utilizam Plug and Play.


Fazendo um levantamento dos dispositivos que não utilizam Plug and Play

Esta seção descreve as etapas que podem ser seguidas se os dispositivos do computador não usarem a tecnologia Plug and Play. Para obter informações importantes sobre compatibilidade de hardware (incluindo a compatibilidade de dispositivos), consulte:

  • Requisitos do sistema
  • Compatibilidade de hardware

Para obter informações específicas sobre como usar um controlador de armazenamento em massa (como adaptadores SCSI, RAID ou Fibre Channel) com um driver fornecido pelo fabricante, consulte Drivers de armazenamento em massa e o processo de instalação.

Os produtos da família Windows Server 2003 incluem a tecnologia Plug and Play que permite o reconhecimento automático de dispositivos (por exemplo, adaptadores de vídeo e de rede) pelo sistema operacional, evita conflitos de configuração e a especificação manual das configurações de cada dispositivo. Entretanto, se houver dispositivos que não utilizam o Plug and Play ou se você souber que os dispositivos Plug and Play não foram implementados exatamente de acordo com os padrões, é aconselhável proceder de modo a evitar conflitos de configuração de dispositivos. Esta seção descreve os procedimentos que podem ser executados, se você desejar, para compreender a configuração dos seus dispositivos antes de realizar a instalação.

Para fazer um levantamento dos dispositivos, se o computador já tiver um sistema operacional, use-o para obter as configurações atuais, como endereço de memória e solicitação de interrupção (IRQ), usados com os dispositivos. Por exemplo, com o Windows NT 4.0, você pode usar o Painel de controle para exibir as configurações (no menu Iniciar, aponte para Configurações, clique em Painel de controle e, em seguida, clique duas vezes nos ícones Rede ou Portas, por exemplo). Você também pode optar por exibir informações sobre o BIOS. Para isso, observe a tela enquanto inicia o computador e pressione a tecla apropriada quando solicitado.

No início de uma instalação ou atualização, a instalação também faz automaticamente um levantamento dos dispositivos. No caso de dispositivos que não usam Plug and Play, ou que não foram implementados exatamente de acordo com os padrões de Plug and Play, realizar o seu próprio levantamento ajuda a evitar as seguintes dificuldades:

  • Se dois ou mais adaptadores compartilharem configurações de IRQ ou endereços de memória, a instalação poderá não ser capaz de resolver o conflito. Para evitar que isso aconteça, adote um dos procedimentos a seguir.

    Remova um dos adaptadores antes de executar a instalação e volte a instalá-lo posteriormente. Para obter mais informações, consulte:

    • Visão geral sobre hardware
    • Visão geral sobre como instalar dispositivos
    • Visão geral sobre tipos de hardware

    Como alternativa, você pode modificar as configurações IRQ e os endereços de memória de um adaptador antes de executar a instalação, para que cada configuração de adaptador seja exclusiva.

  • Se os adaptadores não responderem de um modo padrão às tentativas feitas pela instalação para detectá-los ou enumerá-los, esse programa poderá receber informações indecifráveis ou imprecisas. Nesse caso, talvez você precise remover esses dispositivos antes de executar a instalação. Reinstale-os e reconfigure-os posteriormente. Para obter mais informações, consulte:
    • Visão geral sobre hardware
    • Visão geral sobre como instalar dispositivos
    • Visão geral sobre tipos de hardware

A tabela a seguir lista os tipos de informações a serem reunidas se você tiver dispositivos que não usam Plug and Play, e decidir realizar um levantamento dos dispositivos antes de iniciar a instalação.

Adaptador | Informações a serem reunidas
Vídeo | Tipo de adaptador ou chipset e a quantidade de adaptadores de vídeo
Rede | IRQ, endereço de E/S, tipo de conector DMA (se utilizado) (por exemplo, BNC ou par trançado) e tipo de barramento
Controlador SCSI | Modelo de adaptador ou chipset, IRQ e tipo de barramento
Mouse | Tipo de mouse e porta (COM1, COM2, barramento ou PS/2) ou USB
Porta de E/S | IRQ, endereço de E/S e DMA (se usado) para cada porta de E/S
Adaptador de som | IRQ, endereço de E/S e DMA
Barramento serial universal (USB) | Quais dispositivos e hubs estão conectados
Placas PCMCIA | Quais adaptadores estão inseridos e em quais slots
Plug and Play | Se está habilitado ou desabilitado no BIOS
Configurações do BIOS | Data e revisão do BIOS
Modem externo | Conexões de porta COM (COM1, COM2 e assim por diante)
Modem interno | Conexões de porta COM para configurações não-padrão, IRQ e endereço de E/S
Interface de energia e configuração avançada (ACPI), Opções de energia | Habilitadas ou desabilitadas, configuração atual
PCI | Quais adaptadores PCI estão inseridos e em quais slots


Drivers de armazenamento em massa e o processo de instalação

Se você tiver um controlador de armazenamento em massa (como um adaptador SCSI, RAID ou Fibre Channel) para o disco rígido, confirme se ele é compatível com os produtos da família Windows Server 2003 clicando no link apropriado em Recursos de suporte.

Se o controlador for compatível, mas você estiver ciente de que o fabricante forneceu um arquivo de driver específico para ser usado com os produtos da família Windows Server 2003, obtenha o arquivo (em disquete) antes de iniciar a instalação. Durante a parte inicial da instalação, uma linha na parte inferior da tela solicitará que você pressione F6. Solicitações posteriores o orientarão no fornecimento do arquivo de driver para a instalação de modo que ela possa ter acesso ao controlador de armazenamento em massa.

Se você não tiver certeza de que deve obter um arquivo de driver separado, com o fabricante do controlador de armazenamento em massa, tente executar a instalação. Se os arquivos de driver do CD de instalação não fornecerem suporte ao controlador e, portanto, esse controlador necessitar de um arquivo fornecido pelo fabricante de hardware, a instalação será interrompido e exibirá uma mensagem informando que nenhum dispositivo de disco foi encontrado ou exibirá uma lista incompleta de controladores. Depois de obter o arquivo de driver necessário, reinicie a instalação e pressione F6 quando solicitado.


Noções básicas sobre BIOS da ACPI em um computador x86

Em um computador x86, o sistema de entrada e saída básico (BIOS) é um conjunto de softwares através do qual o sistema operacional (ou a instalação) se comunica com os dispositivos de hardware do computador. A interface de energia e configuração avançada (ACPI) é o padrão atual para o modo de funcionamento do BIOS. Os produtos da família Windows Server 2003 oferecem suporte não só a versões de BIOS compatíveis com ACPI, mas também a algumas versões de BIOS com base em projetos anteriores de gerenciamento avançado de energia (APM) e Plug and Play.

Algumas versões de BIOS baseadas em ACPI não são compatíveis com o padrão. Quanto mais recente for a versão do BIOS de ACPI, maiores serão as chances de compatibilidade. Um BIOS baseado em ACPI que não seja compatível com o padrão ACPI talvez não forneça suporte a comunicação viável entre o sistema operacional (ou a instalação) e o hardware. Se não houver suporte para comunicação viável, a instalação irá parar e exibir instruções sobre como contatar o fabricante do hardware e como realizar outros procedimentos para solucionar o problema. Se isso ocorrer, siga as instruções fornecidas.

Para saber mais sobre a compatibilidade de ACPI do BIOS:

  • Para obter informações sobre a versão do BIOS, antes de executar a instalação, reinicie o computador e observe o texto na tela. Preste atenção especial aos blocos de texto com as palavras "BIOS" ou "BIOS da ACPI".
  • Para obter informações sobre as versões do BIOS para o hardware, verifique a documentação do hardware e contate o fabricante.
  • Se você supõe que a ACPI do seu BIOS pode não ser compatível, consulte a seção sobre BIOS de ACPI no apêndice "Recuperação e solução de problemas do sistema" do manual impresso Guia de Introdução.


Atualizando ou instalando

Esta seção fornece informações que irão ajudá-lo a decidir se deseja atualizar ou instalar. Ela fornece detalhes sobre atualização e instalação, como uma lista dos sistemas operacionais a partir dos quais é possível atualizar. Além disso, fornece informações sobre os procedimentos a serem executados ao atualizar um domínio pequeno.

  • Comparação entre atualizações e instalações novas
  • Atualizações em um domínio que contenha controladores de domínio do Windows 2000
  • Atualizações em um domínio do Windows NT 4.0


Comparação entre atualizações e instalações novas

Depois de verificar Requisitos do sistema e compatibilidade de hardware e Arquivos importantes a serem revisados, e antes de executar a instalação, determine se fará uma atualização ou uma nova instalação. Atualizar é substituir o Windows NT 4.0 (com Service Pack 5 ou posterior) por um produto da família Windows Server 2003 ou substituir o Windows 2000 por um produto da família Windows Server 2003. A instalação, diferentemente da atualização, implica a remoção completa do sistema operacional anterior ou a instalação de um produto da família Windows Server em um disco ou partição de disco sem qualquer sistema operacional.

Se você já tomou uma decisão quanto a fazer uma atualização ou uma nova instalação, consulte Lista de verificação: Executando uma atualizaçãoTAG ou Lista de verificação: Executando uma nova instalação.

A lista a seguir descreve itens a serem considerados ao decidir entre uma atualização e uma nova instalação.

Pontos a serem considerados para uma atualização

  • Com uma atualização, a configuração é mais simples e os usuários, as configurações, os grupos, os direitos e as permissões existentes são mantidos.
  • Com uma atualização, não é necessário reinstalar os arquivos e aplicativos. Entretanto, como em qualquer alteração importante feita no disco rígido, é recomendável fazer backup do disco antes de iniciar uma atualização.
  • Antes de planejar uma atualização, consulte "Sistemas operacionais dos quais é possível atualizar" mais adiante neste tópico.
  • Se você estiver fazendo uma atualização em um domínio que inclua controladores de domínio que executam Windows 2000, não deixe de ler Atualizações em um domínio que contenha controladores de domínio do Windows 2000.
  • Se você estiver atualizando em um domínio em que todos os controladores de domínio executam o Windows NT 4.0, não deixe de ler Atualizações em um domínio do Windows NT 4.0.
  • Se você deseja atualizar e usar os mesmos aplicativos que antes, não deixe de examinar as informações sobre aplicativos no arquivo Relnotes.htm (na pasta \Docs do CD de Instalação). Além disso, para obter as informações mais recentes sobre aplicativos compatíveis com produtos da família Windows Server 2003, consulte a seção sobre compatibilidade de software do site da Microsoft (http://www.microsoft.com).

Pontos a serem considerados para uma nova instalação

  • Se você reformatar o disco rígido e executar uma nova instalação, talvez a eficiência do disco aumente (em comparação com a opção de não reformatá-lo). Com a reformatação, você terá a oportunidade de modificar o tamanho ou número das partições de disco, para fazer com que atendam mais adequadamente aos requisitos.
  • Se você deseja praticar um gerenciamento cuidadoso de configuração, por exemplo, em relação a um servidor em que a alta disponibilidade é importante, convém executar uma nova instalação nesse servidor, e não uma atualização. Isso ocorre especialmente em servidores em que o sistema operacional foi atualizado várias vezes.
  • É possível instalar o Windows Server 2003, Enterprise Edition e também permitir que, algumas vezes, o computador execute outro sistema operacional. Entretanto, configurar o computador dessa maneira apresenta certas complexidades associadas ao sistema de arquivos. Para obter mais informações, consulte Decidindo se um computador conterá mais de um sistema operacional.

Observações

  • Não instale o Windows Server 2003, Enterprise Edition em uma unidade compactada, a menos que a unidade tenha sido compactada com o utilitário de compactação do sistema de arquivos NTFS. Descompacte um volume DriveSpace ou DoubleSpace antes de executar a instalação nele.
  • Se você tiver usado o Windows NT 4.0 para criar um conjunto de volumes, de espelhos, de distribuição ou de distribuição com paridade, e desejar executar a instalação do Windows Server 2003, Enterprise Edition nesse computador, será preciso primeiro preparar o conjunto de discos. Para obter detalhes, consulte Trabalhando com conjuntos de volumes, de espelhos ou de distribuição ou conjuntos de distribuição com paridade.

Sistemas operacionais dos quais é possível atualizar

Se você fizer uma atualização, a instalação instalará automaticamente o Windows Server 2003, Enterprise Edition na mesma pasta do sistema operacional instalado no momento. Você pode atualizar para o Windows Server 2003, Enterprise Edition a partir das seguintes versões do Windows:

  • Windows NT Server 4.0 com Service Pack 5 ou posterior
  • Windows NT Server 4.0, Terminal Server Edition, com Service Pack 5 ou posterior
  • Windows NT Server 4.0, Enterprise Edition, com Service Pack 5 ou posterior
  • Windows 2000 Server
  • Windows 2000 Advanced Server
  • Windows Server 2003, Standard Edition

Observações

  • Se você tiver uma versão do Windows NT anterior à 4.0, não será possível atualizar diretamente para um produto da família Windows Server 2003. Primeiro será preciso atualizar para Windows NT 4.0 e aplicar o Service Pack 5 antes de atualizar para um produto da família Windows Server 2003.
  • Caso tenha servidores ou clientes com Windows NT 3.51, é recomendável instalar um sistema operacional mais recente em todos esses computadores, ou retirá-los de operação. Se houver mais de um domínio, atualize os controladores de domínio que executam Windows NT 3.51 para que haja validação de logon confiável. Em qualquer circunstância, a atualização ou retirada de computadores com Windows NT 3.51 aumenta a segurança e reduz o número de versões diferentes entre computadores, simplificando o gerenciamento e a solução de problemas.


Atualizações em um domínio que contenha controladores de domínio do Windows 2000

Se você estiver atualizando servidores em um domínio que contenha controladores de domínio do Windows 2000, tenha em mente alguns itens. Os seguintes itens são os mais importantes:

  • A primeira etapa no planejamento da atualização de determinado servidor é verificar a compatibilidade do hardware com os produtos da família Windows Server 2003. Para obter mais informações, consulte Compatibilidade de hardware.
  • Antes de atualizar o primeiro controlador de domínio em um domínio onde um ou mais controladores de domínio executam o Windows 2000, ou adicionar um controlador de domínio executando um produto da família Windows Server 2003, é necessário preparar o domínio (e a floresta onde está localizado) usando uma ferramenta simples no CD de instalação do Windows Server 2003, Enterprise Edition. Para obter informações, consulte Preparar-se para atualizações em um domínio que contenha controladores de domínio do Windows 2000.

    Antes de preparar o domínio (e a floresta na qual ele está contido), recomenda-se a aplicação do Service Pack 2 ou posterior a todos os controladores de domínio que executam Windows 2000.

  • Caso tenha o Serviços de Informações da Internet (IIS) 5.0 instalado em um servidor, quando você atualizar o sistema operacional, o IIS será atualizado para IIS 6.0. Porém, para compatibilidade de aplicativos, o IIS é executado em modo de isolamento do IIS 5.0 após a atualização. Para obter mais informações sobre os modos de isolamento do IIS, consulte a Ajuda do ISS 6.0.
  • Por padrão, a configuração aprimorada de segurança do Internet Explorer está habilitada quando a atualização é feita. As configurações de segurança ajudam a proteger melhor o computador, limitando a exposição do mesmo a sites mal-intencionados. Portanto, com o nível aprimorado de segurança, você poderá descobrir que alguns sites não são exibidos corretamente no Internet Explorer quando você estiver navegando por alguns sites da Internet e de intranets. Você também poderá receber uma solicitação para fornecer suas credenciais quando estiver acessando os recursos da rede, como arquivos em pastas compartilhadas UNCs. Essas configurações aprimoradas de segurança são facilmente alteradas. Para obter mais informações, consulte Configuração de segurança aprimorada do Internet Explorer.
  • Ao concluir as atualizações de controladores de domínio e reduzir o número de versões diferentes do sistema operacional que são executadas, você poderá ajustar adequadamente os níveis funcionais do domínio e da floresta. Para obter mais informações sobre níveis funcionais, consulte Funcionalidade de domínio e floresta e Elevando os níveis funcionais de domínio e floresta. Para obter informações gerais sobre o Active Directory, consulte Active Directory.

Se você tiver servidores que executam o Windows NT, observe também os seguintes itens:

  • Antes de executar a instalação, recomenda-se verificar os sistemas de arquivos e as partições existentes no servidor. É necessário ter pelo menos uma partição NTFS em controladores de domínio. É recomendável usar NTFS em todas as partições de todos os servidores do domínio, pois vários recursos de segurança não existem em partições FAT ou FAT32. Por exemplo, em partições FAT ou FAT32, uma pasta compartilhada pode ser protegida apenas através das permissões definidas na pasta compartilhada, em lugar de arquivos individuais, e não há proteção de software contra o acesso local à partição. Para obter mais informações, consulte Reformatando ou convertendo uma partição para usar NTFS e Converter.
  • Se alguns dos controladores de domínio executarem o Windows 2000 e outros o Windows NT, recomenda-se atualizar os controladores de domínio com Windows NT assim que for possível, para reduzir as diferenças de versão entre computadores, simplificar o gerenciamento e a solução de problemas e aumentar a segurança.
  • Antes de iniciar uma atualização do Windows NT 4.0, aplique o Service Pack 5 ou posterior.
  • Caso tenha servidores ou clientes com Windows NT 3.51, é recomendável instalar um sistema operacional mais recente em todos esses computadores, ou retirá-los de operação. Se houver mais de um domínio, atualize os controladores de domínio que executam Windows NT 3.51 para que haja validação de logon confiável. Em qualquer circunstância, a atualização ou retirada de computadores com Windows NT 3.51 aumenta a segurança e reduz o número de versões diferentes entre computadores, simplificando o gerenciamento e a solução de problemas.

Após a preparação do domínio e da floresta, há dois estágios na atualização de um controlador de domínio. Primeiro, execute a instalação para atualizar o sistema operacional e, em seguida, ao término da instalação, execute o Assistente para instalação do Active Directory (que aparece na tela quando você faz logon pela primeira vez).


Atualizações em um domínio do Windows NT 4.0

Essa seção fornece informações sobre como atualizar servidores em um domínio do Windows NT 4.0, ou seja, um domínio em que todos os controladores de domínio executam o Windows NT 4.0. Essas diretrizes fornecidas são para uma rede com um a cinco servidores e 100 ou menos clientes (o tamanho de rede discutido nestes tópicos introdutórios). Para obter informações sobre como atualizar servidores em um domínio em que um ou mais controladores de domínio executam Windows 2000, consulte Atualizações em um domínio que contenha controladores de domínio do Windows 2000.

A lista a seguir descreve os tópicos sobre como atualizar servidores em um domínio do Windows NT 4.0:

  • Para obter informações sobre preparações iniciais, como a verificação de compatibilidade de hardware e do tamanho das partições nos discos rígidos de servidores, consulte Preparações básicas para a atualização de servidores em um domínio do Windows NT.
  • Para obter mais informações sobre como planejar procedimentos que ajudem a ajustar a atualização à sua situação específica, consulte os seguintes tópicos:
    • Planejando funções de servidores e a ordem de atualizações de servidores a partir do Windows NT
    • Planejando a ordem de atualização de servidores em um domínio do Windows NT 4.0
    • Planejando o DNS para atualização de controladores de domínio que executam Windows NT 4.0
  • Para obter mais informações sobre opções a serem feitas durante a atualização de controladores de domínio, consulte Realizando as preparações finais e as atualizações de controladores de domínio que executam Windows NT 4.0.

Importante

  • Caso tenha servidores ou clientes com Windows NT 3.51, é recomendável instalar um sistema operacional mais recente em todos esses computadores, ou retirá-los de operação. Se houver mais de um domínio, atualize os controladores de domínio que executam Windows NT 3.51 para que haja validação de logon confiável. Em qualquer circunstância, a atualização ou retirada de computadores com Windows NT 3.51 aumenta a segurança e reduz o número de versões diferentes entre computadores, simplificando o gerenciamento e a solução de problemas.

Observação

  • Por padrão, a configuração aprimorada de segurança do Internet Explorer está habilitada quando a atualização é feita. As configurações de segurança ajudam a proteger melhor o computador, limitando a exposição do mesmo a sites mal-intencionados. Portanto, com o nível aprimorado de segurança, você poderá descobrir que alguns sites não são exibidos corretamente no Internet Explorer quando você estiver navegando por alguns sites da Internet e de intranets. Você também poderá receber uma solicitação para fornecer suas credenciais quando estiver acessando os recursos da rede, como arquivos em pastas compartilhadas UNCs. Essas configurações aprimoradas de segurança são facilmente alteradas. Para obter mais informações, consulte Configuração de segurança aprimorada do Internet Explorer.

Para obter informações adicionais, consulte:

  • Para obter mais informações sobre o Active Directory em relação a uma atualização do Windows NT, consulte Atualizando a partir de um domínio do Windows NT e Funcionalidade de domínio e floresta.
  • Para obter informações sobre implantações e atualizações em vários domínios ou em domínios com mais de cinco servidores, consulte o Kit de Implantação do Windows Server 2003 no site da Microsoft. (http://www.microsoft.com/).


Preparações básicas para a atualização de servidores em um domínio do Windows NT

É necessário executar algumas preparações básicas antes de atualizar servidores em um domínio em que todos os controladores de domínio executem Windows NT 4.0. Para obter informações sobre como essas preparações se encaixam no processo geral da atualização, consulte Atualizações em um domínio do Windows NT 4.0.

Importante

  • Caso tenha servidores ou clientes com Windows NT 3.51, é recomendável instalar um sistema operacional mais recente em todos esses computadores, ou retirá-los de operação. Se houver mais de um domínio, atualize os controladores de domínio que executam Windows NT 3.51 para que haja validação de logon confiável. Em qualquer circunstância, a atualização ou retirada de computadores com Windows NT 3.51 aumenta a segurança e reduz o número de versões diferentes entre computadores, simplificando o gerenciamento e a solução de problemas.
Verificação de compatibilidade
Verifique se os aplicativos e o hardware nos seus sistemas são compatíveis com os produtos da família de produtos Windows Server 2003 e atualize ou substitua-os conforme necessário. Para obter detalhes importantes sobre como fazer isso, consulte Compatibilidade de hardware e Arquivos importantes a verificar.
Verifique o tamanho das partições, principalmente nos controladores de domínio
Examine as partições nos servidores para verificar se há espaço livre disponível suficiente para a execução do sistema operacional da família de produtos Windows Server 2003. É muito importante que haja espaço livre suficiente em controladores de domínio, pois o banco de dados de contas de usuários existente pode se expandir até dez vezes quando a funcionalidade do Active Directory é adicionada. Para obter informações sobre os requisitos de espaço em disco do sistema operacional, consulte Requisitos do sistema.
Verifique os sistemas de arquivos em partições de servidor
É necessário ter pelo menos uma partição NTFS em controladores de domínio. É recomendável usar NTFS em todas as partições de todos os servidores do domínio, pois vários recursos de segurança não existem em partições FAT ou FAT32. Por exemplo, em partições FAT ou FAT32, uma pasta compartilhada pode ser protegida apenas através das permissões definidas na pasta compartilhada, em lugar de arquivos individuais, e não há proteção de software contra o acesso local à partição. Para obter mais informações, consulte Reformatando ou convertendo uma partição para usar NTFS e Converter.
Service Pack
Obtenha o Service Pack 5 ou posterior, pois será necessário para a atualização.
Conjuntos de espelhos ou outros conjuntos de discos
Se você usou o Windows NT 4.0 para criar um conjunto de volumes, um conjunto de espelhos, um conjunto de distribuição ou um conjunto de distribuição com paridade e se deseja executar a instalação do Windows Server 2003, Enterprise Edition no computador, prepare primeiro o conjunto de discos. Para obter detalhes, consulte Trabalhando com conjuntos de volumes, de espelhos ou de distribuição ou conjuntos de distribuição com paridade.


Planejando funções de servidores e a ordem de atualizações de servidores a partir do Windows NT

Esta seção fornece uma lista de orientações básicas a serem utilizadas ao planejar funções de servidores e a ordem de atualizações de servidores em um domínio em que todos os controladores de domínio executem o Windows NT 4.0 Para obter informações sobre como esse planejamento se ajusta ao processo geral da atualização, consulte Atualizações em um domínio do Windows NT 4.0.

Utilize as orientações a seguir ao planejar funções de servidores e a ordem de atualizações de servidores a partir do Windows NT

  • Familiarize-se com as ligeiras diferenças entre os nomes das funções de servidor para os servidores que executam o Windows NT em comparação com os que executam o Windows Server 2003:
    • No Windows NT, há dois tipos de controladores de domínio, o controlador de domínio primário, que é único por domínio e contém um banco de dados de leitura e gravação, e o controlador de domínio de backup, que não é limitado em número e contém um banco de dados somente leitura.
    • Para os controladores de domínio que executam o Windows Server 2003, só existe um tipo de controlador de domínio, sem qualquer designação de "primário" ou "backup". Todos os controladores de domínio contêm cópias correspondentes às contas de usuário e outros dados do Active Directory em um determinado domínio, além de fornecerem acesso de leitura e gravação a esse dados.
    • Além de controladores de domínio, as possíveis funções para ambos os sistemas operacionais incluem servidor membro, que pertence a um domínio, mas não contém cópia dos dados do Active Directory, e servidor autônomo, que pertence a um grupo de trabalho e não a um domínio.
  • Observe que, diferentemente do Windows NT, você pode alterar a função de um servidor sem precisar executar novamente a instalação. No entanto, como regra geral, é melhor planejar as funções com antecedência e alterá-las somente quando necessário.
  • Como ocorria com o Windows NT, um domínio deve ter pelo menos um controlador de domínio, mas recomenda-se que um domínio tenha vários controladores de domínio para efeito de resiliência no tratamento de solicitações de logon e atualizações de pastas.
  • Se os recursos de que você mais precisa não são recursos do Active Directory, concentre-se primeiro na atualização de servidores membros. Para obter informações sobre motivos para atualizar um determinado servidor membro logo no início do processo, consulte Planejando a ordem de atualização de servidores em um domínio do Windows NT 4.0.
  • Se os recursos de que você mais precisa são recursos do Active Directory, concentre-se primeiro na atualização dos controladores de domínio e faça o planejamento antecipado necessário a essa parte da atualização.

    Importante

    • Quando você iniciar a atualização de controladores de domínio que executam o Windows NT 4.0, atualize primeiro o controlador de domínio primário.

    Para obter informações sobre os recursos associados ao Active Directory, consulte Planejando a ordem de atualização de servidores em um domínio do Windows NT 4.0. Para obter informações sobre o planejamento necessário antes de atualizar para o Active Directory, consulte Planejando o DNS para atualização de controladores de domínio que executam Windows NT 4.0.

  • Ao iniciar a atualização dos controladores de domínio, caso haja um servidor de acesso remoto que seja um servidor membro, recomenda-se atualizá-lo antes da atualizar o último controlador de domínio. Esse servidor depende dos controladores de domínio para obter informações de usuários e, portanto, não deve ser "deixado para trás" na atualização dos controladores de domínio. Como alternativa, você pode reduzir as permissões de segurança no Active Directory para que o servidor de acesso remoto que executa o Windows NT possa ler os atributos de usuário dos controladores de domínio que executam produtos da família Windows Server 2003. Para obter mais informações, consulte o Kit de Implantação do Windows Server 2003 no site da Microsoft. (http://www.microsoft.com/).


Planejando a ordem de atualização de servidores em um domínio do Windows NT 4.0

Este tópico lista os recursos disponíveis com a atualização de qualquer servidor com Windows NT 4.0 e também lista os recursos disponíveis com a atualização do primeiro controlador de domínio a partir do Windows NT 4.0. Planeje a ordem de atualização dos servidores de acordo com os recursos nos quais estiver mais interessado.

Os tópicos a seguir fornecem informações adicionais:

  • Para obter informações sobre outros recursos em produtos da família Windows Server 2003, consulte Novos recursos.
  • Para obter mais informações sobre como atualizar servidores em um domínio em que todos os controladores de domínio executam o Windows NT 4.0, consulte Atualizações em um domínio do Windows NT 4.0.
  • Para obter informações sobre o Active Directory, consulte Active Directory.

Recursos disponíveis com a atualização de qualquer servidor em um domínio do Windows NT

Se você estiver interessado nos recursos da lista a seguir, talvez deseje concentrar-se na atualização dos servidores membros no domínio do Windows NT 4.0. Para obter informações sobre os motivos para atualizar os controladores de domínio, consulte "Recursos disponíveis com a atualização do primeiro controlador de domínio em um domínio do Windows NT", mais adiante neste tópico.

  • Ferramentas de gerenciamento:
    Console de Gerenciamento da Microsoft
    Plug and Play
    Gerenciador de dispositivos
    Assistente para adicionar hardware (no Painel de controle)
    Suporte a barramento serial universal
    Utilitário de backup aperfeiçoado
  • Suporte a sistema de arquivos: A versão do NTFS na família Windows Server 2003 inclui suporte a cotas de disco, a capacidade de desfragmentar estruturas de pastas e E/S de rede compactada.
  • Serviços de aplicativos: Win32 Driver Model, DirectX 7.0 e Host de scripts do Windows
  • Suporte a protocolo de impressora: Suporte a protocolo e dispositivo permitindo mais de 2.500 diferentes opções de impressoras. Outros aperfeiçoamentos de impressão incluem, por exemplo, suporte a IPP (protocolo de impressão da Internet), que permite aos usuários imprimirem diretamente para uma URL em uma intranet ou na Internet.
  • Desempenho e disponibilidade: Suporte aperfeiçoado a multiprocessadores simétricos, em comparação com o Windows NT.
  • Segurança: Sistema de arquivos com criptografia.

Recursos disponíveis com a atualização do primeiro controlador de domínio em um domínio do Windows NT

Se você estiver interessado nos recursos da lista a seguir (todos pertencem ao Active Directory), concentre-se na atualização do controlador de domínio primário, e não nos servidores membros. (O primeiro controlador de domínio a ser atualizado deve ser o controlador de domínio primário. Recomenda-se também a atualização dos controladores de domínio de backup.) Para obter informações sobre o planejamento de DNS necessário antes de começar a atualização de controladores de domínio com Windows NT, consulte Planejando o DNS para atualização de controladores de domínio que executam Windows NT 4.0.

Observação

  • Quando um controlador de domínio é atualizado, ele dispõe de todos os recursos do sistema operacional da família Windows Server 2003, o que significa que ele possui todos os recursos da lista a seguir, além dos recursos de "Recursos disponíveis com a atualização de qualquer servidor em um domínio do Windows NT", descrito anteriormente neste tópico.

Quando você atualiza um controlador de domínio para executar o sistema operacional da família Windows Server 2003 no lugar do Windows NT, vários recursos do Active Directory ficam disponíveis no domínio:

  • Gerenciamento simplificado de informações de recursos de rede e informações de usuário.
  • Diretiva de Grupo, que pode ser utilizada para definir diretivas que se aplicam a determinado site, domínio ou unidade organizacional no Active Directory.
  • Recursos de autenticação e segurança, incluindo suporte a Kerberos V5, Secure Sockets Layer (SSL) 3.0 e Transport Layer Security (TLS) utilizando certificados X.509v3.
  • Consolidação de pastas, através da qual você pode organizar e simplificar o gerenciamento de usuários, computadores, aplicativos e dispositivos, bem como facilitar para os usuários a localização das informações de que necessitam. Você pode se beneficiar do suporte a sincronização através de interfaces baseadas no LDAP e trabalhar com requisitos de consolidação de pastas específicos dos seus aplicativos.
  • Aplicativos e infra-estrutura ativados por pasta, o que facilita a configuração e o gerenciamento de aplicativos e outros componentes de rede habilitados por diretório.
  • Desempenho sem complexidade, resultado da escalabilidade do Active Directory para milhões de objetos por domínio e do uso de tecnologia de indexação e técnicas avançadas de replicação para acelerar o desempenho.
  • Uso dos padrões da Internet, incluindo o acesso através de LDAP e um espaço para nome baseado no sistema de nomes de domínios (DNS).
  • Interface do serviço de diretório ativo (ADSI), um ambiente de desenvolvimento sofisticado.
  • Recursos adicionais, conforme descritos em Active Directory.


Planejando o DNS para atualizar controladores de domínio que executam Windows NT 4.0

O sistema de nomes de domínios (DNS) é um sistema de identificação hierárquico usado para localizar computadores na Internet e em redes TCP/IP privadas. Este tópico descreve o planejamento para DNS que é recomendado antes da atualização para o Active Directory, ou seja, antes que o controlador de domínio primário em um domínio Windows NT seja atualizado para se tornar um controlador de domínio que execute o Windows Server 2003.

DNS é o serviço de resolução de nomes utilizado pelo Active Directory. Os produtos da família Windows Server 2003 podem fornecer suporte ao serviço de cadastramento na Internet do Windows (WINS), comum em redes Windows NT, e ao DNS. É necessário implantar o DNS para fornecer suporte ao Active Directory. Para obter informações, consulte Integração com o Active Directory. Você pode optar por migrar do WINS para DNS ou configurar sua nova infra-estrutura DNS para fornecer suporte à infra-estrutura WINS atual.

No caso de atualização de uma rede com um a cinco servidores e 100 ou menos clientes (que é o tamanho de rede discutido nestes tópicos introdutórios), só será necessário um plano DNS simples, porque não haverá domínios pai nem filho. Para obter informações sobre como atualizar redes com mais de cinco servidores, consulte o Kit de Implantação do Windows Server 2003 no site da Microsoft. (http://www.microsoft.com/).

Os nomes DNS consistem em rótulos de nomes separados por pontos. Um nome de domínio DNS simples para uma família Windows Server 2003 poderia ter a forma de nomedodomínio.ext, onde ext é um tipo de "domínio de nível superior" estabelecido, como com ou org. Com um nome de domínio nesse formato, o formato de um nome de computador no domínio seria:

nomedocomputador.nomedodomínio.ext

Ao atualizar o controlador de domínio primário em um domínio do Windows NT 4.0 (o controlador de domínio primário deve ser atualizado primeiro, antes dos controladores de domínio de backup), você receberá várias opções diferentes para tratamento do DNS. Caso não haja um servidor DNS disponível para trabalhar com o Active Directory, você receberá, por padrão, a opção de instalar o DNS no controlador de domínio que estiver atualizando (anteriormente, o controlador de domínio primário). Em uma rede com um a cinco servidores, o método mais simples é aceitar esse padrão. Depois de concluir a atualização do servidor no qual o DNS foi instalado, tome nota do endereço IP estático e configure outros computadores para enviar todas as solicitações DNS para esse endereço IP.

Para obter mais informações, consulte:

  • Para obter informações básicas adicionais sobre DNS e como configurá-lo durante a instalação, consulte Resolução de nomes para TCP/IP.
  • Para obter informações mais detalhadas sobre DNS, consulte DNS.
  • Para obter informações específicas sobre o planejamento de espaço para nome para DNS, consulte Planejamento de espaço para nome para DNS.


Realizando as preparações finais e as atualizações de controladores de domínio que executam Windows NT 4.0

Durante as preparações finais antes de iniciar uma atualização a partir do Windows NT 4.0, você pode remover um controlador de domínio de backup temporariamente da rede para proteger a integridade da rede existente. Durante a atualização, há algumas opções a serem feitas para a atualização de uma rede com dois a cinco servidores (uma rede do tamanho discutido nestes tópicos introdutórios). Este tópico descreve a remoção de um controlador de domínio de backup da rede e fornece diretrizes para definição de opções durante a atualização.

Antes do início desta etapa do processo de atualização, revise as informações importantes contidas em outros tópicos listados em Atualizações em um domínio do Windows NT 4.0.

Removendo um controlador de domínio de backup da rede

Antes de iniciar uma atualização de servidores em um domínio onde todos os controladores de domínio executam Windows NT 4.0, você pode tomar uma medida de precaução adicional no estágio preparatório final, quando estiver confirmando se o Service Pack 5 ou posterior foi aplicado e estiver realizando backups de servidor.

Se você estiver se preparando para atualizar o controlador de domínio primário, para proteger a integridade da rede existente, considere a possibilidade de remover um controlador de domínio de backup temporariamente da rede. Para isso, na rede Windows NT existente, escolha um controlador de domínio de backup, verifique se ele inclui uma cópia atualizada do banco de dados de contas de usuários e faça o backup. Em seguida, desconecte o cabo de rede. Após a atualização do controlador de domínio primário para que se torne um controlador de domínio com Windows Server 2003 (é preciso atualizar o controlador de domínio primário primeiro), esse sistema desconectado estará disponível para promoção para um controlador de domínio primário do Windows NT, se necessário. Entretanto, durante uma atualização normal, você não iria e nem poderia promover o controlador de domínio de backup do Windows NT a controlador de domínio primário. Em vez disso, você continuaria o processo de atualização, voltando, mais tarde, a conectar o servidor desconectado e atualizando-o.

Executando o Assistente para instalação do Active Directory após a atualização do controlador de domínio primário

Para atualizar o controlador de domínio primário para que ele se torne um controlador de domínio que executa o Windows Server 2003, primeiro você deve executar a instalação para atualizar o sistema operacional. Após a instalação do sistema operacional, você pode executar o Assistente para instalação do Active Directory (que aparece na tela quando você faz logon pela primeira vez). Esta seção fornece diretrizes para fazer opções no Assistente para instalação do Active Directory ao atualizar o controlador de domínio primário.

Importante

  • Quando você iniciar a atualização de controladores de domínio que executam o Windows NT 4.0, atualize primeiro o controlador de domínio primário.

A tabela a seguir mostra as opções que são recomendadas ao executar o Assistente para instalação do Active Directory no servidor que foi anteriormente o controlador de domínio primário. Essas recomendações são para uma rede com dois a cinco servidores (uma rede do tamanho discutido nestes tópicos introdutórios).

Opções no servidor que foi anteriormente o controlador de domínio primário | Ação recomendada para uma rede com dois a cinco servidores
Domínio em uma nova floresta ou Domínio filho em uma árvore de domínios existente ou Árvore de domínios em uma floresta existente | Escolha Domínio em uma nova floresta.
Nível funcional da floresta de Windows Server 2003 interim (Essa opção só é exibida se Domínio em uma nova floresta tiver sido previamente selecionado.) | Escolha Windows Server 2003 interim. Com este nível funcional de domínio, você pode ter controladores de domínio que executem o Windows NT 4.0 ou Windows Server 2003, mas nenhum controlador de domínio que execute o Windows 2000.

Durante a atualização, você pode escolher a localização de três itens importantes: o banco de dados que contém contas de usuários e outros dados do Active Directory, o arquivo de log e a pasta de volume do sistema (Sysvol). O banco de dados e o arquivo de log podem ficar em qualquer tipo de partição (FAT, FAT32 ou NTFS); o banco de dados poderá expandir em até dez vezes o tamanho que tinha no Windows NT. Portanto, deixe espaço suficiente para isso. (Inicialmente, o arquivo de log ocupará muito pouco espaço.) A pasta de volume do sistema deve ficar em uma partição NTFS. (Para obter informações sobre NTFS e outros sistemas de arquivos, consulte Escolhendo um sistema de arquivos para a partição de instalação.)

Observação

  • Ao iniciar a atualização dos controladores de domínio, caso haja um servidor de acesso remoto que seja um servidor membro, recomenda-se atualizá-lo antes da atualizar o último controlador de domínio. Para obter mais informações, consulte Planejando funções de servidores e a ordem de atualizações de servidores a partir do Windows NT.

Para obter informações adicionais sobre atualizações em relação ao Active Directory, consulte Funcionalidade de domínio e floresta e Atualizando a partir de um domínio do Windows NT. Para obter uma lista geral de tópicos sobre o Active Directory, consulte Active Directory.


Decidindo se um computador conterá mais de um sistema operacional

  • Considerações para computadores que contêm mais de um sistema operacional
  • Vários sistemas operacionais e compatibilidade de sistema de arquivos
  • Computadores que contêm várias partições da família de produtos Windows Server 2003
  • Computadores que contêm Windows 2000 e Windows Server 2003, Enterprise Edition
  • Computadores que contêm Windows NT 4.0 e Windows Server 2003, Enterprise Edition
  • Computadores que contêm Windows 98 ou Windows Millennium Edition e Windows Server 2003, Enterprise Edition
  • Computadores que contêm MS-DOS e Windows Server 2003, Enterprise Edition


Considerações para computadores que contêm mais de um sistema operacional

Em um computador com uma configuração de disco apropriada (descrita na tabela mais adiante neste tópico), é possível instalar mais de um sistema operacional e, a cada inicialização, escolher o sistema operacional desejado.

Observação

  • Em um computador com arquitetura baseada em Itanium, você pode instalar o Windows XP 64-Bit Edition, a versão de 64 bits do Windows Server 2003, Enterprise Edition ou a versão de 64 bits do Windows Server 2003, Datacenter Edition. Neste tópico e em outros tópicos sobre a instalação de vários sistemas operacionais, considere somente as informações sobre sistemas operacionais que podem ser instalados. Por exemplo, as informações sobre Windows 2000 ou Windows NT 4.0 não se aplicam a computadores com arquitetura baseada em Itanium.

Por exemplo, em um computador baseado em x86, você poderia configurar um servidor para executar Windows Server 2003, Enterprise Edition na maioria do tempo mas permitir que algumas vezes execute Windows NT Server 4.0, Enterprise Edition para suportar um aplicativo mais antigo. (Para isso, porém, você precisaria fazer opções entre sistemas de arquivos específicos e precisaria do Service Pack 5 ou posterior, conforme descrito em Vários sistemas operacionais e compatibilidade entre sistemas de arquivos.) Ao reiniciar, uma tela aparecerá por alguns segundos, permitindo que você opte entre dois sistemas operacionais. (Você pode especificar um sistema operacional padrão que será executado se nenhuma seleção for feita durante o processo de reinicialização.)

A tabela a seguir mostra a configuração de disco na qual você pode instalar mais de um sistema operacional.

Importante

  • Siga os requisitos da tabela a seguir. Por exemplo, em um disco básico, será necessário instalar cada sistema operacional, incluindo o Windows Server 2003, Enterprise Edition, em uma partição separada. Isso assegura que cada sistema operacional não substitua arquivos cruciais de outro sistema operacional.
Configuração de disco | Requisitos para vários sistemas operacionais
Disco ou discos básicos | Você pode instalar vários sistemas operacionais, incluindo o Windows NT 4.0 e sistemas operacionais anteriores, em um disco básico. Cada sistema operacional deverá estar em uma partição ou unidade lógica separada no disco. Uma partição ou unidade lógica é uma seção do disco que funciona como uma unidade separada. Em geral, partições diferentes têm letras de unidade diferentes, por exemplo, C: e D:.
Apenas um disco dinâmico | Só é possível instalar um sistema operacional. No entanto, se você tiver utilizado o Windows 2000 ou o Windows XP para transformar um disco sem partições diretamente em disco dinâmico, será preciso reverter o disco para básico antes de instalar nele um sistema operacional. Para obter mais informações, consulte a observação após esta tabela.
Vários discos dinâmicos | Cada disco dinâmico pode conter uma instalação do Windows 2000, Windows XP ou de um produto da família Windows Server 2003. Nenhum outro sistema operacional pode inicializar a partir de um disco dinâmico. No entanto, se você tiver utilizado o Windows 2000 ou o Windows XP para transformar um disco sem partições diretamente em disco dinâmico, será preciso reverter o disco para básico antes de instalar nele um sistema operacional. Para obter mais informações, consulte a observação após esta tabela.
Disco de registro de inicialização principal (MBR) em computadores com arquitetura baseada em Itanium. | Não é possível iniciar sistemas operacionais de um disco MBR em computadores com arquitetura baseada em Itanium. É necessário usar um disco GPT para essa finalidade.
Disco de tabela de partição GUID (GPT) em computadores com arquitetura baseada em Itanium | É possível instalar um ou mais sistemas operacionais de um disco GPT em computadores com arquitetura baseada em Itanium. As diretrizes nesta tabela para discos básicos e dinâmicos aplicam-se a discos GPT em computadores com arquitetura baseada em Itanium. Em um computador com arquitetura baseada em Itanium, você pode instalar o Windows XP 64-Bit Edition, a versão de 64 bits do Windows Server 2003, Enterprise Edition e a versão de 64 bits do Windows Server 2003, Datacenter Edition. Não é possível instalar versões mais antigas do sistema operacional, como o Windows 2000, em computadores com arquitetura baseada em Itanium.

Observação

  • Se você tiver utilizado o Windows 2000 ou o Windows XP para transformar um disco sem partições diretamente em disco dinâmico, será preciso reverter o disco para básico antes de instalar nele um sistema operacional. Todos os dados serão perdidos neste processo. Portanto, faça backup primeiro. Em seguida, você pode usar Windows 2000 ou Windows XP para reverter o disco, ou usar a instalação do Windows Server 2003, Enterprise Edition . Para usar o Windows 2000 ou o Windows XP, siga as instruções na Ajuda relativas ao seu sistema operacional. Para usar Windows Server 2003, Enterprise Edition A instalação, durante a fase de particionamento, localiza o disco dinâmico na lista de partições disponíveis e o exclui (o que apaga todos os dados em todos os volumes). Você será solicitado a confirmar sua ação. Em seguida, o disco conterá apenas o espaço não particionado, e será possível usar a instalação para criar nele uma nova partição (disco básico).

Razões para instalar somente um sistema operacional

A configuração de um computador para optar entre dois ou mais sistemas operacionais na inicialização traz, de fato, uma vantagem: permite a utilização de aplicativos que só podem ser executados em um determinado sistema operacional. Porém, há razões muito concretas para instalar somente um sistema operacional:

  • Cada sistema operacional utiliza um valioso espaço em disco.
  • As questões de compatibilidade, especialmente a compatibilidade entre sistemas de arquivos, podem ser complexas. Para obter mais informações, consulte Vários sistemas operacionais e compatibilidade de sistema de arquivos.
  • Em um disco dinâmico (um tipo de armazenamento disponível com produtos da família Windows Server 2003), só é possível ter um sistema operacional por disco. Os discos dinâmicos também não funcionarão com alguns sistemas operacionais. Para obter mais informações, consulte a tabela apresentada anteriormente neste tópico.
  • Não será mais necessário manter vários sistemas operacionais como proteção contra problemas com a inicialização do computador. Nos produtos da família Windows Server 2003, existem outras opções de recuperação do sistema. Por exemplo, se tiver um problema com um driver de dispositivo recém-instalado, você poderá usar o modo de segurança, no qual o Windows Server 2003, Enterprise Edition reinicializa com configurações padrão e a quantidade mínima de drivers. Para obter mais informações sobre o modo de segurança e outras opções, consulte Noções básicas sobre recuperação de desastres.

Detalhes específicos a considerar

Antes de decidir configurar um computador com mais de um sistema operacional, reveja os tópicos que se aplicam à sua situação:

Sistema operacional
que pode alternar
com o Windows Server 2003, Enterprise Edition 		Tópicos a rever
Outro produto da família Windows Server 2003
  • Computadores que contêm várias partições da família de produtos Windows Server 2003
Windows 2000
  • Computadores que contêm Windows 2000 e Windows Server 2003, Enterprise Edition
Windows NT 4.0
  • Vários sistemas operacionais e compatibilidade de sistema de arquivos
  • Computadores que contêm Windows NT 4.0 e Windows Server 2003, Enterprise Edition
Windows 98 ou Windows Millennium Edition
  • Computadores que contêm Windows 98 ou Windows Millennium Edition e Windows Server 2003, Enterprise Edition
MS-DOS
  • Computadores que contêm MS-DOS e Windows Server 2003, Enterprise Edition


Vários sistemas operacionais e compatibilidade de sistema de arquivos

Em computadores com vários sistemas operacionais, a compatibilidade torna-se mais complexa quando você considera as opções de sistemas de arquivos. Os sistemas de arquivos disponíveis são NTFS, FATe FAT32. (Para obter mais informações, consulte Escolhendo um sistema de arquivos para a partição de instalação.)

O NTFS é o sistema de arquivos normalmente recomendado por ser mais eficiente e confiável e por oferecer suporte a recursos importantes, como o Active Directory e a segurança baseada em domínios. Entretanto, com o NTFS, será preciso levar em consideração a compatibilidade entre sistemas de arquivos ao considerar a possibilidade de configurar um computador para conter mais de um sistema operacional, já que no Windows 2000 e na família de produtos Windows Server 2003, o NTFS dispõe de novos recursos, além dos contidos no Windows NT. Os arquivos que usarem os novos recursos ficarão totalmente disponíveis para uso ou legíveis somente quando o computador for iniciado com o Windows 2000 ou um produto da família Windows Server 2003.

Por exemplo, um arquivo que usar o novo recurso de criptografia não será legível quando o computador for iniciado com Windows NT Server 4.0 ou Windows NT 4.0 Server Enterprise Edition, que foram lançados antes do recurso de criptografia.

Para obter mais informações sobre recursos que afetam a acessibilidade de arquivos a produtos da família Windows Server 2003, consulte NTFS.

Observações

  • Se você desejar configurar um computador com Windows NT e Windows Server 2003, Enterprise Edition e desejar ter uma partição NTFS, a única versão apropriada do Windows NT será a 4.0 com o último Service Pack lançado. O uso do Service Pack mais atual maximiza a compatibilidade entre o Windows NT 4.0 e o Windows Server 2003, Enterprise Edition. (Especificamente, você deve ter o Service Pack 5 ou posterior.) Contudo, mesmo o último Service Pack não fornece acesso aos arquivos que usem os novos recursos no NTFS.
  • Usar o NTFS como o único sistema de arquivos em um computador que contenha Windows Server 2003, Enterprise Edition e Windows NT não é recomendado. Nesses computadores, uma partição FAT com o sistema operacional Windows NT 4.0 assegura que, quando iniciado com o Windows NT 4.0, o computador terá acesso aos arquivos necessários. Além disso, se o Windows NT não for instalado na partição do sistema (normalmente, é a primeira partição no disco), recomenda-se que a partição do sistema também seja formatada com FAT.
  • Se você configurar um computador para que inicie com o Windows NT 3.51 ou anterior em uma partição FAT e com o Windows Server 2003, Enterprise Edition em uma partição NTFS, quando esse computador for iniciado com o Windows NT 3.51, a partição NTFS não ficará visível. Se você configurar um computador dessa forma e a partição que contém o Windows NT 3.51 não for a partição do sistema (normalmente, é a primeira partição no disco), essa partição também deverá ser formatada com FAT.


Computadores que contêm várias partições da família de produtos Windows Server 2003

Você pode configurar um servidor para conter uma combinação de Windows XP e produtos da família Windows Server 2003 ou conter várias instalações de produtos da família Windows Server 2003. Se você estiver planejando isso, observe o seguinte:

  • Instale cada sistema operacional em uma partição diferente ou, no caso de discos dinâmicos, em um disco diferente, e instale os aplicativos usados com um sistema operacional no mesmo disco ou na mesma partição. Se um aplicativo for usado com dois sistemas operacionais diferentes, instale-o em dois locais.
  • No caso de um computador com x86, escolha qualquer produto da família Windows Server 2003 para instalação em uma partição específica. Por exemplo, você pode instalar o Windows Server 2003, Standard Edition em um local e o Windows Server 2003, Enterprise Edition em outro.

    No caso de um computador com arquitetura baseada em Itanium, você pode escolher entre o Windows XP 64-Bit Edition, a versão de 64 bits do Windows Server 2003, Enterprise Edition e a versão de 64 bits do Windows Server 2003, Datacenter Edition.

  • Se o computador participar de um domínio, use outro nome de computador para cada instalação. Como é usado um identificador de segurança (SID) exclusivo para cada instalação de Windows Server 2003, Enterprise Edition em um domínio, o nome do computador de cada instalação deve ser único, até para várias instalações no mesmo computador.
  • Se você configurar um servidor de forma que contenha alguma combinação de Windows Server 2003, Enterprise Edition com Windows 2000 ou Windows XP, ou contenha várias partições com produtos da família Windows Server 2003, e desejar utilizar o Sistema de Arquivos com Criptografia (EFS) no computador, é necessário seguir alguns procedimentos. Esses procedimentos permitem a leitura dos arquivos criptografados em instalações diferentes.
    • Um dos métodos consiste em garantir que todas as instalações estejam no mesmo domínio e que os usuários dessas instalações tenham um perfil móvel.
    • Outro método consiste em exportar o certificado de criptografia de arquivo do usuário e a chave particular associada de uma instalação e importá-los para outras instalações.

    Para obter mais informações, consulte Introdução ao uso do sistema de arquivos com criptografia, Usando perfis de usuários móveis e Importando e exportando certificados.


Computadores que contêm Windows 2000 e Windows Server 2003, Enterprise Edition

Você pode configurar um computador para que contenha tanto o Windows 2000 quanto o Windows Server 2003, Enterprise Edition. Se você estiver planejando isso, observe o seguinte:

  • Instale cada sistema operacional em uma partição diferente ou, no caso de discos dinâmicos, em um disco diferente, e instale os aplicativos usados com um sistema operacional no mesmo disco ou na mesma partição. Se um aplicativo for usado com dois sistemas operacionais diferentes, instale-o em dois locais.
  • O Windows Server 2003, Enterprise Edition deve ser instalado por último. Caso contrário, arquivos importantes necessários à inicialização do Windows Server 2003, Enterprise Edition serão substituídos.
  • Se o computador participar de um domínio, use outro nome de computador para cada instalação. Como um identificador de segurança (SID) exclusivo é usado para cada instalação em um domínio, o nome do computador de cada instalação deve ser único, mesmo para várias instalações no mesmo computador.
  • Se você usar o sistema de arquivos com criptografia (EFS) em um computador que contenha Windows 2000 e um produto da família Windows Server 2003, os arquivos criptografados não poderão ser lidos de uma instalação para a outra, a menos que siga um destes métodos:
    • Um dos métodos consiste em garantir que todas as instalações estejam no mesmo domínio e que os usuários dessas instalações tenham um perfil móvel.
    • Outro método consiste em exportar o certificado de criptografia de arquivo do usuário e a chave particular associada de uma instalação e importá-los para outras instalações.

    Para obter mais informações, consulte Introdução ao uso do sistema de arquivos com criptografia, Usando perfis de usuários móveis e Importando e exportando certificados.


Computadores que contêm Windows NT 4.0 e Windows Server 2003, Enterprise Edition

Se você estiver planejando configurar um computador para que contenha o Windows NT 4.0 e o Windows Server 2003, Enterprise Edition, observe primeiro as seguintes precauções:

  • Não será mais necessário manter vários sistemas operacionais como proteção contra problemas com a inicialização do computador. Nos produtos da família Windows Server 2003, existem outras opções de recuperação do sistema. Por exemplo, se tiver um problema com um driver de dispositivo recém-instalado, você poderá usar o modo de segurança, no qual o Windows Server 2003, Enterprise Edition reinicia com configurações padrão e a quantidade mínima de drivers. Para obter mais informações sobre o modo de segurança e outras opções, consulte Noções básicas sobre recuperação de desastres.
  • Usar o NTFS como o único sistema de arquivos em um computador que contenha Windows Server 2003, Enterprise Edition e Windows NT não é recomendado. Para obter mais informações, consulte Vários sistemas operacionais e compatibilidade de sistema de arquivos.
  • Verifique se o Windows NT 4.0 foi atualizado com a versão mais recente do Service Pack. Para obter detalhes, consulte Vários sistemas operacionais e compatibilidade de sistema de arquivos.
  • Instale cada sistema operacional em uma partição distinta, e instale os aplicativos usados com cada um deles na mesma partição. Se um aplicativo for usado com dois sistemas operacionais distintos, instale-o em duas partições.
  • Não instale o Windows Server 2003, Enterprise Edition em uma unidade compactada a menos que a unidade tenha sido compactada com o recurso de compactação do sistema de arquivos NTFS.
  • O Windows Server 2003, Enterprise Edition deve ser instalado por último. Caso contrário, arquivos importantes necessários à inicialização do Windows Server 2003, Enterprise Edition serão substituídos.
  • Se o computador participar de um domínio, use outro nome de computador para cada instalação.


Computadores que contêm Windows 98 ou Windows Millennium Edition e Windows Server 2003, Enterprise Edition

Se você planeja configurar um computador para que contenha Windows 98 ou Windows Millennium Edition e Windows Server 2003, Enterprise Edition, observe:

  • Instale cada sistema operacional em uma partição distinta, e instale os aplicativos usados com cada um deles na mesma partição. Se um aplicativo for usado com dois sistemas operacionais distintos, instale-o em duas partições.
  • O Windows 98 ou o Windows Millennium Edition devem ser instalados em um disco básico em uma partição formatada com FAT ou FAT32. Se o Windows 98 ou o Windows Millennium Edition não for instalado na partição do sistema, que quase sempre é a primeira partição no disco, a partição do sistema deverá também ser formatada com FAT ou FAT32.
  • O Windows Server 2003, Enterprise Edition deve ser instalado por último. Caso contrário, arquivos importantes necessários à inicialização do Windows Server 2003, Enterprise Edition serão substituídos.
  • A compatibilidade entre sistemas de arquivos pode ser um problema. Consulte Vários sistemas operacionais e compatibilidade de sistema de arquivos.


Computadores que contêm o

Elemento gráfico do Microsoft Windows

Computadores que contêm o MS-DOS e o Windows Server 2003, Enterprise Edition

Se estiver planejando configurar um computador para que contenha MS-DOS e Windows Server 2003, Enterprise Edition, observe:

  • Instale cada sistema operacional em uma partição distinta, e instale os aplicativos usados com cada um deles na mesma partição. Se um aplicativo for usado com dois sistemas operacionais distintos, instale-o em duas partições.
  • O MS-DOS deverá ser instalado em um disco básico em uma partição formatada com FAT. Se o MS-DOS não for instalado na partição do sistema, que quase sempre é a primeira partição no disco, a partição do sistema também deverá ser formatada com FAT.
  • O Windows Server 2003, Enterprise Edition deve ser instalado por último. Caso contrário, arquivos importantes necessários à inicialização do Windows Server 2003, Enterprise Edition serão substituídos.
  • A compatibilidade entre sistemas de arquivos pode ser um problema. Consulte Vários sistemas operacionais e compatibilidade de sistema de arquivos.


Escolhendo um sistema de arquivos para a partição de instalação

  • Escolhendo um sistema de arquivos: NTFS, FAT ou FAT32
  • Reformatando ou convertendo uma partição para usar NTFS
  • Comparação entre NTFS, FAT e FAT32
  • NTFS


Escolhendo um sistema de arquivos: NTFS, FAT ou FAT32

É possível escolher entre três sistemas de arquivos para uma partição de instalação: NTFS, FAT e FAT32. O NTFS é bastante recomendável na maioria das situações.

Para obter detalhes sobre cada sistema de arquivos ou sobre o processo de conversão ou reformatação de uma partição, consulte:

  • Reformatando ou convertendo uma partição para usar NTFS
  • Comparação entre NTFS, FAT e FAT32
  • NTFS

Observação

  • Você só poderá usar recursos importantes, como o Active Directory e a segurança baseada em domínios, se optar pelo sistema de arquivos NTFS.

Importante

  • Em discos GPT, disponíveis somente em computadores com arquitetura baseada em Itanium, recomenda-se enfaticamente o uso de NTFS para a partição de instalação. No entanto, se você tiver um computador com arquitetura baseada em Itanium e observar que ele tem uma pequena partição FAT de 100 MB ou mais, não exclua nem reformate essa partição. A partição é necessária ao carregamento do sistema operacional. Para obter mais informações, consulte Iniciar a instalação em um computador com arquitetura baseada em Itanium.

A tabela a seguir lista alguns cenários de instalação ou atualização para computadores baseados em x86 (os últimos dois cenários são incomuns) e fornece diretrizes de sistemas de arquivos para cada um deles:

Cenário de instalação ou atualização para um computador baseado em x86 | Sistema de arquivos a ser utilizado e informações adicionais a serem lidas
O computador atualmente utiliza somente o NTFS (não usa FAT nem FAT32). | Continue a usar o NTFS. Não há necessidade de informações adicionais sobre sistemas de arquivos.
O computador é baseado em x86 e possui uma ou mais partições FAT ou FAT32. E O computador contém somente um sistema operacional, ou os sistemas operacionais no computador incluem Windows 2000, Windows XP ou um produto da família Windows Server 2003, mas nenhum outro sistema operacional. Se o computador tem arquitetura baseada em Itanium, consulte a observação importante anteriormente neste tópico. | Considere a reformatação ou conversão de partições de forma que todas utilizem NTFS. Para obter mais informações, consulte Reformatando ou convertendo uma partição para usar NTFS.
O computador conterá vários sistemas operacionais, um dos quais é o MS-DOS, Windows 95, Windows 98 ou Windows Millennium Edition. | Para qualquer partição que precise estar acessível a partir de MS-DOS, Windows 95, Windows 98 ou Windows Millennium Edition, use FAT (ou, quando adequado, FAT32). Para obter mais informações, consulte Decidindo se um computador conterá mais de um sistema operacional.
O computador conterá vários sistemas operacionais, um dos quais é o Windows NT. | Consulte Vários sistemas operacionais e compatibilidade entre sistemas de arquivos.


Reformatando ou convertendo uma partição para usar NTFS

Se você tiver uma partição FAT ou FAT32 onde deseja instalar um produto da família Windows Server 2003 utilizando NTFS em seu lugar, há duas opções:

  • Você pode converter a partição FAT ou FAT32 em NTFS. Esse procedimento deixa os arquivos intactos, embora a partição possa ser um pouco mais fragmentada e ter desempenho mais lento que a partição formatada com o NTFS. Todavia, ainda é vantajoso usar o NTFS, independentemente de a partição ter sido formatada com o NTFS ou convertida.

    Se instalar um produto da família Windows Server 2003 em uma partição FAT ou FAT32, você terá a opção de converter a partição em NTFS. Também é possível converter uma partição FAT ou FAT32 após a instalação usando Convert.exe. Para obter mais informações sobre Convert.exe, consulte Converter.

  • É possível reformatar a partição com o NTFS. Esse procedimento apaga todos os arquivos da partição, mas resulta em menos fragmentação e melhor desempenho que em uma partição convertida.

Importante

  • Se tiver um computador com arquitetura baseada em Itanium e observar que ele tem uma partição FAT pequena de 100 MB ou mais, não exclua ou reformate essa partição. A partição é necessária ao carregamento do sistema operacional. Para obter mais informações, consulte Iniciar a instalação em um computador com arquitetura baseada em Itanium.

Se você formatar uma partição durante a instalação, as opções de sistemas de arquivos serão listadas como NTFS e FAT. A tabela a seguir fornece informações sobre a relação entre as opções de tamanho de partição e de sistema de arquivos durante a instalação.

Estado e tamanho da partição | Opções de instalação e respostas (durante a formatação da partição)
Não formatada, menor que 2 GB. | A instalação oferece NTFS ou FAT. A instalação usa o formato escolhido.
Não formatada, 2 GB ou maior, até o máximo de 32 GB. | A instalação oferece NTFS ou FAT. Se FAT for escolhido, a instalação usará FAT32.
Não formatada, maior que 32 GB. | A instalação só permite NTFS.
Formatado anteriormente com FAT32 e maior que 32 GB. (Partição criada com Windows 95, Windows 98 ou Windows Millennium Edition.) | Não há necessidade de formatação, embora uma partição não formatada desse tamanho, quando formatada durante ou após a instalação de um produto da família Windows Server 2003, tenha que usar NTFS. Em outras palavras, a família Windows Server 2003 continua a fornecer suporte às partições FAT32 desse tamanho anteriormente formatadas.

Se você formatar uma partição durante a instalação, poderá optar por uma formatação rápida ou uma formatação completa:

Formatação rápida
A formatação rápida cria a estrutura do sistema de arquivos no disco, sem verificar a integridade de cada setor. Escolha este método para qualquer disco rígido que não tenha setores defeituosos nem histórico de problemas de arquivos corrompidos que possam estar relacionados a setores defeituosos.
Formatação completa
Uma formatação completa identifica e controla setores defeituosos, de modo que não sejam usados para armazenar dados. Escolha este método para qualquer disco que tenha setores defeituosos ou um histórico de problemas de arquivos corrompidos que possam estar relacionados a setores defeituosos.


Comparação entre NTFS, FAT e FAT32

O NTFS sempre foi um sistema de arquivos mais poderoso do que FAT e FAT32. O Windows 2000, o Windows XP e a família de produtos Windows Server 2003 incluem uma nova versão do NTFS, com suporte a vários recursos, incluindo o Active Directory, que é necessário para domínios, contas de usuário e outros recursos de segurança importantes. Para obter mais detalhes sobre recursos em NTFS, consulte NTFS.

FAT e FAT32 são semelhantes, exceto que o FAT32 destina-se a discos maiores que o FAT. O sistema de arquivos que funciona melhor com discos maiores é o NTFS.

A tabela a seguir descreve a compatibilidade de cada sistema de arquivos com vários sistemas operacionais.

Observação

  • As opções por sistemas de arquivos não têm efeito sobre o acesso a arquivos na rede. Por exemplo, o uso de NTFS em todas as partições de um servidor não afeta a conexão de clientes em uma rede com pastas compartilhadas ou arquivos compartilhados nesse servidor, mesmo que esses clientes executem um sistema operacional mais antigo, como o Windows 98 ou o Windows NT.
NTFS | FAT | FAT32
Um computador que execute o Windows 2000, o Windows XP ou um produto da família Windows Server 2003 pode acessar arquivos em uma partição NTFS local. Um computador que executa o Windows NT 4.0 com Service Pack 5 ou posterior pode ter acesso a alguns arquivos. Outros sistemas operacionais não permitem acesso local. | O acesso a arquivos em uma partição local está disponível através de MS-DOS, todas as versões do Windows e OS/2. | O acesso a arquivos em uma partição local está disponível somente através do Windows 95 OSR2, Windows 98, Windows Millennium Edition, Windows 2000, Windows XP e produtos da família Windows Server 2003.

A tabela a seguir compara os possíveis tamanhos de disco e arquivo com cada sistema de arquivos.

NTFS | FAT | FAT32
O tamanho de volume mínimo recomendado é de aproximadamente 10 MB. Os tamanhos máximos de volume e partição iniciam em 2 terabytes (TB) e se estendem até tamanhos superiores. Por exemplo, um disco dinâmico formatado com um tamanho padrão de unidade de alocação (4 KB) pode ter partições de 16 TB menos 4 KB. Para obter mais informações sobre tamanhos máximos de volume e partição, consulte o tópico sobre o Conjunto de Tecnologias de Armazenamento no site da Microsoft. (http://www.microsoft.com/) Não pode ser usado em disquetes. | Volumes do tamanho de disquetes até 4 GB. Não fornece suporte a domínios. | Os volumes de 33 MB a 2 TB podem ser gravados ou lidos usando produtos da família Windows Server 2003. Os volumes até 32 GB podem ser formatados como FAT32 usando produtos da família Windows Server 2003. Não fornece suporte a domínios.
O tamanho máximo de arquivo é potencialmente 16 TB menos 64 KB, embora os arquivos não possam ser maiores que o volume ou a partição em que estão localizados. | O tamanho máximo de arquivo é de 2 GB. | O tamanho máximo de arquivo é de 4 GB.

Observação

  • Em computadores com arquitetura baseada em Itanium com vários discos, as opções incluem não somente sistemas de arquivos mas também estilos de partição. Um estilo de partição determina como as informações sobre a partição são armazenadas. Há dois estilos de partição: O mais recente (usado somente em computadores com arquitetura baseada em Itanium) armazena informações da tabela de partições (GPT) do identificador global exclusivo (GUID). O mais antigo armazena informações no registro mestre de inicialização (MBR). Em computadores com arquitetura baseada em Itanium, é necessário instalar o Windows Server 2003, Enterprise Edition em um disco GPT.

    Para obter mais informações sobre os dois estilos de partição disponíveis em computadores com arquitetura baseada em Itanium, consulte Estilos de partição e o tópico sobre o Conjunto de Tecnologias de Armazenamento no site da Microsoft. (http://www.microsoft.com/).


NTFS

Alguns dos recursos que você pode usar quando escolhe o NTFS são:

  • Melhor escalabilidade para grandes unidades. O tamanho máximo da partição ou do volume para NTFS é muito maior do que para FAT e, à medida que o tamanho da partição ou do volume aumenta, o desempenho com NTFS não degrada como ocorre com FAT.
  • Active Directory (e domínios, que fazem parte do Active Directory). Com o Active Directory, você pode exibir e controlar facilmente os recursos de rede. Com domínios, você pode ajustar as opções de segurança e, ao mesmo tempo, manter simples a administração. Os controladores de domínio e o Active Directory requerem o NTFS.
  • Recursos de compactação, inclusive a capacidade de compactar ou descompactar uma unidade, uma pasta ou um arquivo específico. (Contudo, um arquivo não pode ser compactado e criptografado ao mesmo tempo.)
  • Criptografia de arquivos, que melhora muito a segurança. (Contudo, um arquivo não pode ser compactado e criptografado ao mesmo tempo.)
  • Permissões que podem ser definidas em arquivos específicos em vez de apenas em pastas.
  • Armazenamento remoto, que fornece uma extensão no espaço em disco tornando a mídia removível (como fitas) mais acessível.
  • Log de recuperação de atividades de disco, que permite ao NTFS restaurar informações rapidamente no caso de falha de energia ou outros problemas do sistema.
  • Arquivos esparsos. Esses são arquivos muito grandes criados por aplicativos de modo que seja necessário somente um espaço limitado em disco. Isto é, o NTFS aloca espaço em disco apenas para as partes gravadas de um arquivo.
  • Cotas de disco, que você pode usar para monitorar e controlar a quantidade de espaço em disco utilizada por usuários individualmente.

Esta é apenas uma lista parcial dos recursos do NTFS na família de produtos Windows Server 2003. Para obter mais informações sobre novos recursos, consulte Novos recursos.

Para obter informações sobre tamanhos máximos de arquivos com NTFS, consulte Comparação entre NTFS, FAT e FAT32. Para obter informações sobre a conversão e reformatação de uma partição FAT ou FAT32, consulte Reformatando ou convertendo uma partição para usar NTFS.


Planejando volumes ou partições de disco para novas instalações

  • Considerações ao planejar partições de disco
  • Opções ao particionar um disco
  • Trabalhando com discos dinâmicos e a instalação


Considerações ao planejar partições de disco

Só será necessário planejar as partições de disco antes de executar a instalação se as duas condições a seguir forem verdadeiras:

  • Você está executando uma nova instalação, e não uma atualização.
  • O disco no qual você está fazendo a instalação é um disco básico, e não um disco dinâmico. Os discos básicos existiam antes do Windows 2000; a maioria dos discos são básicos. Um disco dinâmico é um disco que já foi básico, mas foi transformado em dinâmico com uso do Windows 2000, Windows XP ou de um produto da família Windows Server 2003. Se você planeja executar uma instalação em um disco dinâmico, não pode alterar os tamanhos do volume ou da partição no disco durante a instalação. Portanto, nenhum planejamento é necessário com relação ao tamanho das partições. Em vez disso, verifique as orientações em Trabalhando com discos dinâmicos e a instalação.

Partição de disco é um modo de dividir o disco físico a fim de que cada seção funcione como uma unidade separada. Ao criar partições em um disco básico, você divide o disco em uma ou mais áreas que podem ser formatadas para uso por um sistema de arquivos, como FAT ou NTFS. Em geral, partições diferentes têm letras de unidade diferentes (por exemplo, C: e D:). Um disco básico pode ter até quatro partições primárias ou três partições primárias e uma partição estendida. (Uma partição estendida pode ser subdividida em unidades lógicas, enquanto uma partição primária não.)

Importante

  • Se você planeja excluir ou criar partições em um disco rígido, faça backup do conteúdo dos discos antes, porque essas ações destruirão quaisquer dados existentes. Como para qualquer alteração importante feita no conteúdo do disco, é recomendável fazer backup do conteúdo total do disco rígido antes de trabalhar com partições, mesmo que planeje deixar uma ou mais partições isoladas.

Antes de executar uma nova instalação, determine o tamanho da partição em que será feita a instalação. Não há um conjunto de fórmulas que determine um tamanho de partição. O princípio básico consiste em fornecer bastante espaço para o sistema operacional, aplicativos e outros arquivos que serão incluídos na partição da instalação. Os arquivos para instalação do Windows Server 2003, Enterprise Edition exigem aproximadamente 1,25 GB a 2 GB em um computador x86 e 3 GB a 4 GB em um computador com arquitetura baseada em Itanium, conforme descrito em Requisitos do sistema. Recomenda-se que seja fornecido mais espaço em disco que a quantidade mínima. Não é sensato fornecer 4 GB a 10 GB na partição ou mais espaço para instalações grandes. Isso fornece espaço para vários itens, inclusive componentes opcionais, contas de usuário, informações do Active Directory, logs, service packs futuros, o arquivo de paginação usado pelo sistema operacional e outros itens.

Para obter informações sobre alguns dos itens que exigem espaço no disco, consulte:

  • Alterar configurações de memória virtual
  • Especificar o que acontecerá se o sistema parar de forma inesperada
  • Escolhendo os componentes a serem instalados
  • Noções básicas sobre o Active Directory
  • Armazenamento de dados de diretório

Ao executar uma nova instalação, você pode especificar a partição em que ela deve ser feita. Se você especificar uma partição em que exista um outro sistema operacional, será solicitado a confirmar sua escolha.

Durante a instalação, crie e dimensione somente a partição onde deseja instalar Windows Server 2003, Enterprise Edition. Depois de concluir a instalação, você pode usar o Gerenciamento de disco para gerenciar discos e volumes novos e existentes. Isso abrange a criação de novas partições a partir de espaço não particionado; excluir, renomear e reformatar partições existentes, adicionar e remover discos rígidos e alterar um disco básico para o tipo de armazenamento de disco dinâmico ou de dinâmico para básico. (Se desejar um disco dinâmico em um computador que contenha mais de um sistema operacional, não deixe de ler Considerações para computadores que contenham mais de um sistema operacional.)

Em computadores com arquitetura baseada em Itanium com mais de um disco, você pode planejar não apenas o tamanho das partições, mas o estilo de partição de cada disco. Um estilo de partição determina como as informações sobre a partição são armazenadas. Há dois estilos de partição: O mais novo (usado somente em computadores com arquitetura baseada em Itanium) armazena informações da tabela de partições (GPT) do identificador global exclusivo (GUID). O mais antigo armazena informações no registro mestre de inicialização (MBR). Em computadores com arquitetura baseada em Itanium, é necessário instalar o Windows Server 2003, Enterprise Edition em um disco GPT. Com o GPT, você pode criar mais partições e volumes maiores, além de obter outros benefícios. Para obter mais informações sobre os estilos de partição disponíveis em computadores com arquitetura baseada em Itanium, consulte Estilos de partição, assim como o tópico sobre o Conjunto de Tecnologias de Armazenamento no site da Microsoft. (http://www.microsoft.com/).

Importante

  • Se você estiver configurando um computador para que contenha vários sistemas operacionais, instale o Windows Server 2003, Enterprise Edition em sua própria partição ou unidade lógica. Isso impedirá o Windows Server 2003, Enterprise Edition de substituir arquivos essenciais necessários a outros sistemas operacionais. Para obter mais informações, consulte Decidindo se um computador conterá mais de um sistema operacional.

Requisitos de partição de disco para Serviços de instalação remota

Se você estiver planejando usar os Serviços de instalação remota no servidor, de modo que possa instalar sistemas operacionais em outros computadores, precisará de uma partição separada para ser usada por esse recurso. Considere a utilização do NTFS nessa partição. O NTFS é necessário ao recurso Single Instance Store (SIS) dos Serviços de instalação remota.

Se for necessário criar uma nova partição para os Serviços de instalação remota, considere fazer isso após a instalação, e deixe espaço em disco não particionado suficiente para criá-la (é recomendável pelo menos 4 GB de espaço). Como alternativa, para o disco do sistema (não para discos de cluster), você pode planejar transformá-lo em um disco dinâmico, o que permite maior flexibilidade de uso do espaço em relação a um disco básico. (No entanto, se desejar um disco dinâmico em um computador que contenha mais de um sistema operacional, consulte Decidindo se um computador conterá mais de um sistema operacional.)

Para obter informações sobre os requisitos dos serviços de instalação remota, consulte Requisitos de sistema dos serviços de instalação remota. Para obter informações adicionais sobre opções de disco e partição, consulte Gerenciamento de disco. Para obter uma visão geral, listas de verificação e outras informações sobre os serviços de instalação remota, consulte Serviços de instalação remota.


Opções ao particionar um disco

Você poderá alterar as partições no disco durante a execução da instalação apenas se estiver executando uma nova instalação, não uma atualização. Você pode modificar as partições do disco após a instalação usando o Gerenciamento de disco.

Se você estiver executando uma nova instalação, a instalação examinará o disco rígido para determinar a configuração existente e, em seguida, oferecerá as seguintes opções:

  • Se o disco rígido não tiver partições, você poderá criar e dimensionar a partição onde irá instalar um produto da família Windows Server 2003.
  • Se o disco rígido estiver particionado mas houver espaço não particionado suficiente, você poderá criar a partição para o produto da família Windows Server 2003 usando o espaço não particionado.
  • Se o disco rígido já tiver uma partição que seja suficientemente grande, você poderá instalar um produto da família Windows Server 2003 nessa partição, tendo ou não reformatado primeiro a partição. Reformatar uma partição apaga todos os dados nessa partição. Se você não reformatar a partição, mas instalar um produto da família Windows Server 2003 onde já houver um sistema operacional, esse sistema operacional será substituído e você terá que reinstalar todos os aplicativos que desejar utilizar com o produto da família Windows Server 2003.
  • Se o disco rígido já tiver uma partição, você poderá excluí-la a fim de criar mais espaço não particionado em disco para uma partição referente a um produto da família Windows Server 2003. Excluir uma partição existente também apagará quaisquer dados nessa partição.


Trabalhando com discos dinâmicos e a instalação

Os discos dinâmicos usam o novo tipo de armazenamento apresentado no Windows 2000. Se você alterou um disco para dinâmico e deseja executar uma nova instalação no disco, examine o seguinte.

  • Se você tiver utilizado o Windows 2000 ou o Windows XP para transformar um disco sem partições diretamente em disco dinâmico, será preciso reverter o disco para básico antes de instalar nele um sistema operacional.

    Cuidado

    • Todos os dados serão perdidos no processo de reverter o disco para básico; portanto, faça backup deles primeiro.

    Você pode usar o Windows 2000 ou o Windows XP para reverter o disco ou pode usar a instalação de um produto da família Windows Server 2003. Para usar o Windows 2000 ou o Windows XP, siga as instruções na Ajuda relativas ao seu sistema operacional. Para usar a instalação de um produto da família Windows Server 2003, durante a fase de particionamento, localize o disco dinâmico na lista de partições disponíveis e exclua-o (o que apaga todos os dados em todos os volumes). Você será solicitado a confirmar sua ação. Em seguida, o disco conterá apenas o espaço não particionado, e será possível usar a instalação para criar nele uma nova partição (disco básico).

  • Se você planeja executar novamente a instalação em um computador com um produto da família Windows Server 2003 já instalado e que contenha discos dinâmicos, certifique-se de ler sobre as limitações para instalar sistemas operacionais em discos transformados em dinâmicos usando um produto da família Windows Server 2003. Para obter mais informações, consulte Discos dinâmicos e volumes.


Redes: TCP/IP, endereços IP e resolução de nomes

  • Visão geral sobre rede e TCP/IP
  • Endereços de protocolo Internet (IP)
  • Resolução de nomes para TCP/IP


Visão geral sobre rede e TCP/IP

O TCP/IP (protocolo de controle de transmissão/protocolo Internet) é um protocolo de rede que fornece acesso à Internet. É o protocolo usado pela maioria dos servidores, embora você possa usar adaptadores de rede adicionais ou diferentes e seus protocolos associados nos servidores.

Para usar o TCP/IP, verifique se cada servidor recebeu um endereço IP, seja um endereço dinâmico ou automático fornecido através do software ou um endereço estático que você obtém e define. Como os endereços são números e, portanto, difíceis de lembrar, você precisará fornecer aos usuários nomes fáceis de serem usados. O mapeamento desse tipo de nome para um endereço IP é chamado resolução de nomes e pode ser realizado através de vários métodos, principalmente sistema de nomes de domínios (DNS) e serviço de cadastramento na Internet do Windows (WINS). Para obter mais informações, consulte Endereços do protocolo Internet (IP) e Resolução de nomes para TCP/IP.


Endereços de protocolo Internet (IP)

Conforme descrito em Visão geral sobre rede e TCP/IP, o uso de TCP/IP requer o fornecimento de um endereço IP a cada computador. Este tópico fornece uma descrição rápida das opções para realizar esses procedimentos. Para obter informações mais detalhadas, consulte DHCP e Endereçamento e roteamento IP.

Há dois métodos básicos para fornecer um endereço IP para um servidor que você está instalando:

Protocolo de configuração dinâmica de hosts (DHCP)
Você pode fornecer endereços IP aos computadores na rede configurando um ou mais servidores DHCP, o que fornece endereços IP dinamicamente aos outros computadores. Um servidor DHCP deve ser atribuído a um endereço IP estático.

Um servidor ou vários servidores podem fornecer DHCP juntamente com um ou mais serviços de resolução de nomes, denominados sistema de nomes de domínios (DNS) e serviço de nomes da Internet do Windows (WINS).

Se desejar executar a instalação antes de tomar uma decisão final sobre qual servidor deverá ser usado como servidor DHCP e qual endereço IP estático deverá ser atribuído a esse servidor, escolha Configurações típicas na caixa de diálogo Configurações de rede durante a instalação e conclua a configuração de rede mais tarde. Se fizer isso e não houver servidor DHCP na rede, a instalação usará uma opção de endereçamento IP limitada denominada endereçamento IP particular automático (APIPA). Durante o tempo em que um servidor está usando APIPA, ele somente pode se comunicar com outro computador com APIPA no mesmo segmento de rede. Um servidor que está usando APIPA não pode estabelecer conexões com a Internet (para navegação ou email) e não pode ser usado com o DNS ou o Active Directory (que depende do DNS).

Se você souber qual servidor deseja usar como servidor DHCP, ao instalar esse servidor, na caixa de diálogo Configurações de rede da instalação, escolha Configurações personalizadas e especifique um endereço IP estático e as configurações de rede relacionadas. Para obter mais informações, consulte Especificar um endereço IP local estático e as configurações necessárias ao DNS e WINS.

Endereçamento IP estático
Para certos tipos de servidores, você deve atribuir um endereço IP estático e uma máscara de sub-rede durante ou após a instalação. Esses servidores abrangem servidores DHCP, servidores DNS, servidores WINS e qualquer servidor que forneça acesso a usuários na Internet. É recomendável também atribuir um endereço IP estático e uma máscara de sub-rede a cada controlador de domínio. Se um computador tiver mais de um adaptador de rede, será necessário atribuir um endereço IP separado para cada adaptador.

Se desejar executar a instalação em um servidor antes de tomar uma decisão final sobre o endereço IP estático a ser atribuído a esse servidor, escolha Configurações típicas na caixa de diálogo Configurações de rede durante a instalação e configure o servidor mais tarde. Nessa situação, se houver um servidor DHCP na rede, a instalação obterá uma configuração de endereço IP do DHCP. Se não houver nenhum servidor DHCP na rede, a instalação usará o endereço IP particular automático (APIPA). O APIPA foi descrito no item anterior desta lista.

Para obter mais informações sobre endereços IP estáticos, incluindo endereços IP particulares (escolhidos a partir de certas faixas de endereços) e endereços IP públicos (obtidos de um provedor de serviços de Internet), consulte Endereçamento e roteamento IP.

Depois de criar um plano para o endereçamento IP, os próximos componentes a considerar referem-se à resolução de nomes, que é o processo de mapeamento de um nome de computador (algo que os usuários podem reconhecer e lembrar) para o endereço IP apropriado. Para obter mais informações, consulte Resolução de nomes para TCP/IP.


Resolução de nomes para TCP/IP

A resolução de nomes é um processo que fornece aos usuários nomes de servidores fáceis de lembrar, em vez de requisitar o uso de endereços IP numéricos pelos quais os servidores se identificam na rede TCP/IP. Os serviços de resolução de nomes são sistema de nomes de domínio (DNS) e serviço de cadastramento na Internet do Windows (WINS).

DNS
O DNS é um sistema de nomeação hierárquico usado para localizar computadores na Internet e em redes TCP/IP privadas. Na maioria das instalações, são necessários um ou mais servidores DNS. O DNS é necessário para email na Internet, navegação na Web e Active Directory. O DNS é também muito utilizado como um serviço de resolução de nomes em domínios com clientes que executam o Windows 2000, Windows XP ou produtos da família Windows Server 2003. O DNS é instalado automaticamente quando você cria um controlador de domínio (ou quando você instala o Active Directory em um servidor membro existente, o que o torna um controlador de domínio), a menos que o Windows Server 2003, Enterprise Edition detecte que já existe um servidor DNS para esse domínio. Você também pode instalar o DNS escolhendo a função de servidor DNS em Gerenciar o servidor ou usando o Painel de controle.

Se você planeja instalar o DNS em um servidor, especifique um endereço IP estático nesse servidor e configure-o para usar esse endereço IP para a respectiva resolução de nomes.

Para obter mais informações, consulte:

  • Para escolher a partir de uma lista de tópicos sobre como configurar o DNS, consulte DNS.
  • Para obter informações sobre como instalar o DNS escolhendo a função do servidor DNS em Gerenciar o servidor, consulte Configurando funções do servidor.
  • Para obter informações sobre como instalar o DNS utilizando o Painel de controle, consulte Instalar um servidor DNS.
  • Para obter informações sobre como atribuir um endereço IP estático durante a instalação, consulte Especificar um endereço IP local estático e as configurações necessárias ao DNS e WINS.
  • Para obter informações sobre como atribuir um endereço IP estático após a instalação, consulte Configurar o TCP/IP para endereçamento estático.
  • Para obter informações sobre como instalar um controlador de domínio (ou sobre como instalar o Active Directory em um servidor membro existente, o que o torna um controlador de domínio), consulte Gerenciar controladores de domínio.
WINS
Se você fornece suporte a clientes com Windows NT ou qualquer sistema operacional anterior da Microsoft, talvez precise instalar o serviço de cadastramento na Internet do Windows (WINS) em um ou mais servidores no domínio. Talvez você também precise instalar o WINS se ele for necessário para os aplicativos. Você pode instalar o WINS escolhendo a função de servidor WINS em Gerenciar o servidor ou usando o Painel de controle.

Se você planeja instalar o WINS em um servidor, especifique um endereço IP estático nesse servidor.

Para obter mais informações, consulte:

  • Para escolher a partir de uma lista de tópicos sobre como configurar o WINS, consulte WINS.
  • Para obter informações sobre como instalar o WINS escolhendo a função do servidor WINS em Gerenciar o servidor, consulte Configurando funções do servidor.
  • Para obter informações sobre como instalar o WINS utilizando o Painel de controle, consulte Instalar um servidor WINS.
  • Para obter informações sobre como atribuir um endereço IP estático durante a instalação, consulte Especificar um endereço IP local estático e as configurações necessárias ao DNS e WINS.
  • Para obter informações sobre como atribuir um endereço IP estático após a instalação, consulte Configurar o TCP/IP para endereçamento estático.


Decidindo entre grupos de trabalho e domínios

Esta seção contém informações que ajudarão você a decidir se irá colocar os servidores em um grupo de trabalho ou em um domínio. Ela também contém outras informações que, caso você crie um domínio, o ajudarão a efetuar o planejamento básico das funções de servidores dentro do domínio.

Para obter informações sobre como atualizar servidores em um domínio em que todos os controladores de domínio executam o Windows NT 4.0, consulte Atualizações em um domínio do Windows NT 4.0. Para obter informações sobre como atualizar servidores em um domínio que contenha um ou mais controladores de domínio do Windows 2000, consulte Atualizações em um domínio com controladores de domínio do Windows 2000. Para obter informações sobre redes com mais de cinco servidores, consulte o Kit de Implantação do Windows Server 2003 no site da Microsoft. (http://www.microsoft.com/).

Para obter informações adicionais, consulte:

  • Comparação entre grupos de trabalho e domínios
  • Planejando controladores de domínio e servidores membros
  • Aspectos especiais de controladores de domínio da família de produtos Windows Server 2003
  • Informações adicionais sobre domínios


Comparação entre grupos de trabalho e domínios

Um domínio é um grupo de contas e recursos de rede que compartilham um mesmo banco de dados de diretórios e conjunto de diretivas de segurança, e podem ter relacionamentos de segurança com outros domínios. Um grupo de trabalho é um agrupamento mais simples, destinado apenas a ajudar os usuários a localizar objetos, como impressoras e pastas compartilhadas dentro desse grupo. Os domínios são a opção recomendada para todas as redes, exceto redes muito pequenas com poucos usuários.

Em um grupo de trabalho, os usuários podem precisar memorizar várias senhas, uma para cada recurso de rede. (Além disso, usuários diferentes podem usar senhas diferentes para cada recurso.) Em um domínio, é mais fácil controlar senhas e permissões, já que um domínio tem um único banco de dados centralizado de contas de usuário, permissões e outros detalhes de rede. As informações desse banco de dados são replicadas automaticamente entre os controladores de domínio. Você determina quais servidores são controladores de domínio e quais são simples membros do domínio. Você pode determinar essas funções não apenas durante a instalação mas também posteriormente.

Os domínios e o sistema de diretórios do Active Directory do qual eles fazem parte oferecem várias opções para tornar os recursos disponíveis mais facilmente para os usuários enquanto mantêm um bom monitoramento e segurança. Para obter mais informações, consulte Active Directory.


Planejando controladores de domínio e servidores membros

Elemento gráfico do Microsoft Windows

Planejando controladores de domínio e servidores membro

Com Windows Server 2003, Standard Edition, Windows Server 2003, Enterprise Edition ou Windows Server 2003, Datacenter Edition, os servidores em um domínio podem ter uma das duas funções a seguir: controladores de domínio, que contêm cópias correspondentes das contas de usuário e outros dados do Active Directory em um determinado domínio e servidores membros, que pertencem a um domínio mas não contêm uma cópia dos dados do Active Directory. (Um servidor que pertence a um grupo de trabalho, não a um domínio, é chamado de servidor autônomo.) É possível alterar a função de um servidor, de controlador de domínio para servidor membro (ou servidor autônomo), mesmo após a conclusão da instalação. Entretanto, é recomendável planejar o domínio antes de executar a instalação e alterar as funções de servidor (e nomes de servidor) apenas quando necessário.

Vários controladores de domínio fornecem melhor suporte para usuários, em comparação com um único controlador de domínio. Com vários controladores de domínio, você tem várias cópias dos dados de conta de usuário e de outros dados do Active Directory; contudo, ainda é importante executar backups regulares, inclusive backups de Recuperação automatizada do sistema, e familiarizar-se com os métodos de restauração de um controlador de domínio. Além disso, vários controladores de domínio trabalham juntos para fornecer suporte a funções de controlador de domínio, como a execução de validações de logon.

Para obter mais informações, consulte Funções de servidor.


Aspectos especiais de controladores de domínio da família Windows Server 2003

Ao gerenciar os domínios da família Windows Server 2003, talvez você queira saber mais sobre funções do mestre de operações. Este tópico descreve sucintamente as funções do mestre de operações. Diversos tópicos de domínio são discutidos com mais profundidade em Active Directory.

As funções de mestre de operações são funções especiais atribuídas a um ou mais controladores de domínio em um domínio do Active Directory. Os controladores de domínio aos quais são atribuídas essas funções executam operações do mestre único (não é permitido que atuem em diferentes locais da rede ao mesmo tempo). Por exemplo, a criação de identificadores de segurança para novos recursos (como novos computadores) deve ser supervisionada por um único controlador de domínio para garantir que os identificadores sejam exclusivos.

Ao primeiro controlador de domínio instalado em um domínio, são atribuídas automaticamente todas as funções de mestre de operações. Você pode alterar a atribuição de funções de mestre de operações após a instalação, mas normalmente isto não é necessário. Você precisará prestar atenção especial às funções de mestre de operações se ocorrerem problemas com um mestre de operações ou se planejar desabilitar um deles. Para obter mais informações, consulte Funções de mestre de operações.


Informações adicionais sobre domínios

Para obter informações sobre como atualizar servidores em um domínio em que todos os controladores de domínio executam o Windows NT 4.0, consulte Atualizações em um domínio do Windows NT 4.0. Para obter informações sobre como atualizar servidores em um domínio que contenha um ou mais controladores de domínio do Windows 2000, consulte Atualizações em um domínio com controladores de domínio do Windows 2000.

Para obter informações detalhadas sobre domínios e florestas, nível funcional do domínio e nível funcional da floresta, funções do mestre de operações, catálogo global e outros tópicos relacionados a domínios, consulte Active Directory.

Para obter informações sobre como configurar vários domínios com relacionamentos estruturados, consulte o Microsoft Windows Server 2003 Deployment Kit (em inglês) no site do Microsoft Windows Server 2003 Deployment Kit. (http://www.microsoft.com/).


Preparando o sistema antes de executar a instalação

  • Preparando o sistema para uma atualização
  • Preparando o sistema para uma nova instalação
  • Trabalhando com conjuntos de volumes, de espelhos, de distribuição ou de distribuição com paridade


Preparando o sistema para uma atualização

Este tópico descreve procedimentos básicos a serem executados na preparação do servidor para uma atualização.

Se estiver atualizando para o Windows Server 2003, Enterprise Edition em nós de cluster de servidores, não deixe de ler Atualizando para o Windows Server 2003, Enterprise Edition em nós de cluster.

Verificando se há erros no log do sistema

Use Visualizar eventos para verificar se há erros recentes ou recorrentes no log do sistema, que possam causar problemas durante a atualização. Para obter informações sobre Visualizar eventos, consulte Noções básicas sobre Visualizar eventos ou a Ajuda do sistema operacional que estiver usando.

Fazer backup de arquivos

Antes da atualização, é recomendável fazer backup dos arquivos atuais, inclusive de todos os itens que contenham informações de configuração, como o estado do sistema e as partições de sistema e inicialização. Você pode fazer backup dos arquivos em vários tipos de mídia, como uma unidade de fita ou o disco rígido de outro computador na rede.

Preparando conjuntos de espelhos e outros conjuntos de discos para atualização (somente Windows NT 4.0)

Com as tecnologias de gerenciamento de disco do Windows NT 4.0, é possível criar conjuntos de volumes, de espelhos, de distribuição ou de distribuição com paridade, cada um com recursos e limitações específicos. Com o uso de discos dinâmicos, introduzidos com o Windows 2000, você pode se beneficiar de tecnologias similares e, com o Windows Server 2003, Enterprise Edition, também pode estender volumes dinâmicos sem reparticionar ou reformatar.

Essa transição em relação às tecnologias utilizadas no Windows NT 4.0 significa que você deve fazer certas opções antes de executar a instalação do Windows Server 2003, Enterprise Edition. Para obter informações importantes sobre essas opções, consulte Trabalhando com conjuntos de volumes, de espelhos, de distribuição ou de distribuição com paridade.

Desconectando no-breaks

Se você tiver um no-break conectado ao computador de destino, desconecte o cabo de conexão serial antes de executar a instalação. A instalação tenta detectar automaticamente dispositivos conectados a portas seriais e o no-break pode causar problemas no processo de detecção.

Revisando hardware e software

Quando você inicia a instalação para uma atualização, o primeiro processo que ele executa é uma verificação de compatibilidade do hardware e do software no computador. A instalação exibe um relatório antes de continuar. Use esse relatório, juntamente com informações no Relnotes.htm (na pasta \Docs do CD de instalação), para saber se precisa atualizar o hardware, drivers ou softwares antes de fazer a atualização.

Importante

  • Se você for um provedor de serviços de Internet, preste especial atenção às recomendações sobre atualização do software do provedor necessário à conectividade com a Internet.

Para obter as informações mais recentes sobre compatibilidade de hardware e software para produtos da família Windows Server 2003, clique nos links apropriados em Recursos de suporte. Se você tiver dispositivos de hardware que não utilizam Plug and Play, consulte Fazendo um levantamento dos dispositivos que não utilizam Plug and Play.


Preparando o sistema para uma nova instalação

Este tópico descreve procedimentos básicos a serem executados na preparação do servidor para uma nova instalação.

Se estiver instalando o Windows Server 2003, Enterprise Edition em nós de cluster de servidores, não deixe de ler Instalando o Windows Server 2003, Enterprise Edition em nós de cluster.

Verificando se há erros no log do sistema

Se o computador já tiver um sistema operacional em funcionamento, verifique se há erros recentes ou recorrentes no log do sistema (especialmente erros de hardware) que poderiam causar problemas durante a instalação. Para obter informações sobre como exibir os logs de eventos, consulte a Ajuda referente ao sistema operacional do computador.

Fazer backup de arquivos

Antes de executar uma nova instalação, é recomendável fazer backup dos arquivos atuais, a menos que o computador não tenha arquivos ou que os arquivos do sistema operacional atual tenham sido danificados. Você pode fazer backup dos arquivos em vários tipos de mídia, como uma unidade de fita ou o disco rígido de outro computador na rede.

Descompactando a unidade

Descompacte os volumes DriveSpace ou DoubleSpace antes de instalar. Não instale o Windows Server 2003, Enterprise Edition em uma unidade compactada a menos que a unidade tenha sido compactada com o recurso de compactação do sistema de arquivos NTFS.

Preparando conjuntos de espelhos e outros conjuntos de discos (somente Windows NT 4.0)

Com as tecnologias de gerenciamento de disco do Windows NT 4.0, é possível criar conjuntos de volumes, de espelhos ou de distribuição, ou conjuntos de distribuição com paridade, cada um com recursos e limitações específicos. Com os discos dinâmicos, introduzidos com o Windows 2000, você pode se beneficiar de tecnologias similares e, com o Windows Server 2003, Enterprise Edition, também pode estender volumes dinâmicos sem reparticionar ou reformatar.

Essa transição em relação às tecnologias utilizadas no Windows NT 4.0 significa que você deve fazer certas opções antes de executar a instalação do Windows Server 2003, Enterprise Edition. Para obter informações importantes sobre essas opções, consulte Trabalhando com conjuntos de volumes, de espelhos, de distribuição ou de distribuição com paridade.

Desconectando no-breaks

Se você tiver um no-break conectado ao computador de destino, desconecte o cabo de conexão serial antes de executar a instalação. A instalação tenta detectar automaticamente dispositivos conectados a portas seriais e o no-break pode causar problemas no processo de detecção.


Trabalhando com conjuntos de volumes, de espelhos, de distribuição ou de distribuição com paridade

Com as tecnologias de gerenciamento de disco do Windows NT 4.0, é possível criar conjuntos de volumes, de espelhos ou de distribuição, ou conjuntos de distribuição com paridade, cada um com recursos e limitações específicos. Ao usar a tecnologia de disco dinâmico apresentada no Windows 2000, você pode usar tecnologias semelhantes, com a flexibilidade adicional de poder estender os volumes de disco sem fazer reparticionamento ou reformatação.

Essa transição em relação às tecnologias utilizadas no Windows NT 4.0 significa que você deve fazer certas opções antes de executar a instalação do Windows Server 2003, Enterprise Edition. Qualquer conjunto de volumes, conjunto de espelhos, conjunto de distribuição ou conjunto de distribuição com paridade criado com Windows NT 4.0 não é suportado no Windows Server 2003, Enterprise Edition, embora seja suportado de forma limitada no Windows 2000.

Se você usou o Windows NT 4.0 para criar um conjunto de volumes, um conjunto de espelhos, um conjunto de distribuição ou um conjunto de distribuição com paridade e se deseja executar a instalação do Windows Server 2003, Enterprise Edition nesse computador, você deve escolher um dos seguintes métodos.

Para obter informações sobre outros preparativos a serem feitos antes da instalação, consulte Lista de verificação e Preparando o sistema antes de executar a instalação.

No caso de um conjunto de espelhos, quebre o espelhamento
Se você está executando o Windows NT 4.0 em um computador que possui um conjunto de espelhos e deseja executar a instalação para Windows Server 2003, Enterprise Edition nesse computador, faça primeiro o backup dos dados (para garantir que não serão apagados) e, em seguida, quebre o espelhamento. Verifique se você aplicou o Service Pack 5 ou posterior, necessário antes de executar a instalação do Windows Server 2003, Enterprise Edition. Em seguida, execute a instalação.
No caso de um conjunto de volumes, de distribuição ou de distribuição com paridade, faça backup dos dados e exclua o conjunto
Se você está executando o Windows NT 4.0 em um computador que possui um conjunto de volumes, conjunto de distribuição ou conjunto de distribuição com paridade e deseja executar a instalação para Windows Server 2003, Enterprise Edition nesse computador, faça primeiro o backup dos dados. Em seguida, exclua o conjunto (o que excluirá os dados). Verifique se você aplicou o Service Pack 5 ou posterior, necessário antes de executar a instalação do Windows Server 2003, Enterprise Edition. Em seguida, execute a instalação.

Depois de executar a instalação para Windows Server 2003, Enterprise Edition, você pode tornar o disco dinâmico, restaurar dados de backup conforme a necessidade e usar as opções de volume apresentadas na tabela mais adiante nesta seção. Para obter mais informações sobre discos dinâmicos, consulte Discos e volumes dinâmicos e Usando discos dinâmicos.

Se necessário, use a ferramenta de suporte Ftonline
Os métodos anteriores são recomendados para preparação da instalação do Windows Server 2003, Enterprise Edition em um computador que contenha um conjunto de volumes, conjunto de espelhos, conjunto de distribuição ou conjunto de distribuição com paridade criado com Windows NT 4.0. Porém, se você não usar esses métodos e precisar acessar um desses conjuntos depois de executar a instalação para Windows Server 2003, Enterprise Edition, você pode utilizar a ferramenta Ftonline. A ferramenta Ftonline é parte das ferramentas de suporte nos produtos da família Windows Server 2003. Para obter mais informações, consulte Ferramentas de Suporte no CD do Windows.

Tipos de volumes com vários discos em discos dinâmicos

Os conjuntos de discos descritos na seção anterior têm nomes diferentes na família Windows Server 2003 em relação ao que tinham no Windows NT 4.0:

Nome no Windows NT 4.0 | Nome na família Windows Server 2003
Conjunto de volumes | Volume estendido em um disco dinâmico
Conjunto de espelhos | Volume espelhado em um disco dinâmico
Conjunto de distribuição | Volume distribuído em um disco dinâmico
Conjunto de distribuição com paridade | Volume RAID-5 em um disco dinâmico


Recursos

Este tópico fornece fontes de informações adicionais sobre como obter um novo servidor pronto para uso na sua empresa.

  • Para confirmar se os computadores, os componentes de sistemas e os periféricos são compatíveis com produtos da família Windows Server 2003, clique no link apropriado em Recursos de suporte.
  • Para obter as informações mais recentes sobre aplicativos compatíveis com produtos da família Windows Server 2003, consulte a seção sobre compatibilidade de software do site da Microsoft (http://www.microsoft.com).
  • Para obter aperfeiçoamentos e atualizações do Windows e de outros softwares da Microsoft, consulte Windows Update no site da Microsoft. (http://www.microsoft.com/) Para obter uma descrição das diferentes formas como você pode usar o Windows Update, consulte Windows Update.
  • Para obter informações sobre os Windows Deployment and Resource Kits, que fornecem informações técnicas detalhadas sobre os produtos da família Windows Server 2003 e também sobre a implantação do Windows XP, consulte:
    • O Kit de Implantação do Windows Server 2003 no site da Microsoft. (http://www.microsoft.com/).
    • O Windows Server 2003 Technical Reference no site da Microsoft. (http://www.microsoft.com/).
    • O Windows XP Professional Resource Kit no site Microsoft Windows Resource Kits. (http://www.microsoft.com/)
    • Windows Deployment and Resource Kits
  • O Microsoft TechNet é um serviço que contém recursos para profissionais de tecnologia da informação. Inclui acesso a informes técnicos e artigos escritos por profissionais de suporte da Microsoft, informações sobre carreira e sobre o ramo, grupos de discussão, comentários técnicos e softwares. Para obter mais informações sobre o TechNet, consulte o site da Microsoft (http://www.microsoft.com/).
  • O site Information Technology Infrastructure Library (ITIL) oferece orientações a profissionais de tecnologia da informação. Veja a seguir um trecho retirado do site: "A ITIL consiste em uma série de livros que oferecem orientação sobre o fornecimento de serviços de informática de qualidade e sobre os recursos ambientais e de adaptação necessários ao suporte à tecnologia da informação." (Os endereços da Web podem ser alterados, por isso talvez você não consiga se conectar ao site ou sites da Web mencionados aqui.)


Solucionando problemas

Esta seção descreve as etapas para solucionar problemas de mensagens de parada, que são o resultado de um erro do sistema no sistema operacional. Depois de um erro de sistema, o computador pára de responder, e uma mensagem é exibida em um plano de fundo azul ou preto.

Para obter informações sobre como obter suporte ao produto, consulte Product Support no site da Microsoft (http://www.microsoft.com).

Esta seção aborda:

  • Solucionando problemas de mensagens de parada: estratégias gerais
  • Solucionando problemas de mensagens de parada específicas


Solucionando problemas de mensagens de parada: estratégias gerais

Este tópico descreve um método geral para solucionar problemas de mensagens de parada ou desligamentos inesperados. Para obter mais informações, consulte:

  • Para obter informações gerais sobre como solucionar problemas de mensagens de parada, consulte Solucionando problemas de mensagens de parada.
  • Para obter artigos sobre mensagens de parada específicas, consulte Search the Knowledge Base no site da Microsoft. (http://www.microsoft.com/)
  • Para obter mais informações sobre opções de suporte, consulte Recursos de suporte.
  • Para obter informações sobre solução de problemas de componentes ou tecnologias específicas (por exemplo, discos e sistemas de arquivos), consulte o Windows Server 2003 Technical Reference no site da Microsoft (http://www.microsoft.com/).

Você pode usar a ferramenta de informações do sistema para reunir informações importantes sobre configurações do sistema, dispositivos com problemas e recursos de hardware. Para obter mais informações, consulte Informações do Sistema.

Importante

  • Para garantir a estabilidade do sistema, instale o service pack mais recente apropriado para o seu sistema (siga as instruções do service pack e use somente drivers assinados. Para obter mais informações, consulte Windows Update no site da Microsoft (http://www.microsoft.com). Para obter uma descrição das diferentes formas de usar o Windows Update, consulte Windows Update.

Siga estas etapas para quaisquer erros de parada que não exibam texto de identificação ou etapas específicas para solucionar o problema.

  1. Use a ferramenta Windows Online Crash Analysis no site da Microsoft (http://www.microsoft.com/). Você pode usar essa ferramenta para enviar relatórios de erro para a Microsoft e controlar seu status usando as informações do Microsoft Passport. É possível acessar o site Online Crash Analysis usando o serviço Relatório de erros ou seu navegador da Web. Quando for habilitado, o serviço Relatório de erros monitorará o sistema para procurar falhas dos modos de kernel e de usuário relacionadas a componentes do sistema operacional e aplicativos. Com o relatório do modo de kernel, você pode obter mais informações sobre o problema ou a condição que causou o erro de parada. Para obter mais informações, consulte Visão geral sobre o relatório de erros do sistema e de programas.
  2. Use a ferramenta Verificação de assinatura de arquivo, que identifica drivers não assinados e arquivos de sistema incompatíveis no computador. Os arquivos de sistema e arquivos de drivers de dispositivos fornecidos com a família Microsoft® Windows® Server 2003 possuem uma assinatura digital da Microsoft que indica que os arquivos são originais e inalterados ou que foram aprovados pela Microsoft para uso com o Windows. Para obter mais informações, consulte Usando a Verificação de assinatura de arquivo.
  3. Se a mensagem de parada for causada por um problema de driver, você pode usar o Gerenciador de dispositivos para voltar a uma versão anterior do driver. Para obter mais informações, consulte Voltar a uma versão anterior de um driver. Talvez seja necessário desabilitar os drivers recém-instalados.
  4. Usando uma versão atualizada de um software de proteção contra vírus, verifique se há vírus no computador. Se for encontrado um vírus, execute os procedimentos necessários para eliminá-lo do computador. Consulte a documentação do software antivírus para obter essas informações.
  5. Você pode pesquisar na Base de Conhecimentos informações atualizadas sobre mensagens de parada. Consulte Search the Knowledge Base no site da Microsoft (http://www.microsoft.com/) e siga as instruções na página. Ao digitar palavras-chave, use o número da mensagem de parada (por exemplo, stop 0x0000000A).

    Para obter mais informações sobre artigos, assistentes para solução de problemas e itens disponíveis para download, consulte Informações técnicas atualizadas.

  6. Se você conseguir iniciar o sistema operacional, verifique o log do sistema em Visualizar eventos para obter informações adicionais que possam ajudar a determinar o dispositivo ou driver que está causando o problema. Várias mensagens de parada produzem eventos específicos que podem ser procurados, como a ID de evento 1001 (gerada por várias mensagens de parada) e a ID de evento 6008 (normalmente causada por um desligamento inesperado ou um computador que não reinicia corretamente). Para exibir a descrição de um evento, em Visualizar eventos, clique duas vezes no evento. Para obter mais informações sobre Visualizar eventos, consulte Visualizar eventos.

    Você pode pesquisar na Knowledge Base informações atualizadas sobre IDs de eventos. Consulte Search the Knowledge Base no site da Microsoft, (http://www.microsoft.com/) e siga as instruções na página.

  7. Se estiver com problemas para iniciar o computador, tente iniciá-lo em Última configuração válida ou em Modo de segurança e, em seguida, remova ou desabilite os programas e drivers adicionados por último. Para obter informações sobre como iniciar o computador em modo de segurança, consulte Iniciar o computador em modo de segurança. Para obter mais informações sobre como iniciar o computador em Última configuração válida, consulte Iniciar o computador usando a Última Configuração Válida.

    Importante

    • Quando você usa a Última configuração válida, as alterações nas configurações do sistema efetuadas após a última inicialização bem-sucedida são perdidas.
  8. Remova os hardwares instalados por último (RAM, adaptadores, discos rígidos, modems etc.).
  9. Verifique se você atualizou os drivers dos dispositivos de hardware. Além disso, verifique se possui o BIOS mais atualizado para o sistema (no caso de computadores x86) ou o firmware correto (para computadores baseados na arquitetura Itanium). Os fabricantes de dispositivo ou hardware podem ajudá-lo na obtenção desses itens.
  10. Execute os diagnósticos do sistema fornecidos pelo fabricante do computador, especialmente a verificação de memória.
  11. Confirme se o seu hardware foi projetado para a família Windows Server 2003 clicando no link apropriado em Recursos de suporte.
  12. Se o modo de segurança e outras opções de inicialização não funcionarem, considere a possibilidade de utilizar o Console de recuperação. Esse método é recomendado somente se você for um usuário avançado que pode usar comandos básicos para identificar e localizar problemas com drivers e arquivos. Além disso, você deve ser um administrador para usá-lo. Para obter mais informações, consulte Visão geral sobre o Console de recuperação.


Solucionando problemas de mensagens de parada específicas

Este tópico discute como solucionar problemas de mensagens de parada específicas. Para obter informações gerais sobre como solucionar problemas de mensagens de parada e uma lista de outras fontes de informação, consulte Solucionando problemas de mensagens de parada: estratégias gerais.

Você pode usar a ferramenta de informações do sistema para reunir informações importantes sobre configurações do sistema, dispositivos problemáticos e recursos de hardware. Para obter mais informações, consulte Informações do sistema.

Que mensagem de parada você está recebendo?

Mensagem de parada 0x0000001E

Texto descritivo: KMODE_EXCEPTION_NOT_HANDLED

Causa comum: Esta mensagem tem várias causas possíveis.

Solução:

  1. Use a ferramenta Online Crash Analysis no site da Microsoft. (http://www.microsoft.com/) Essa ferramenta pode ser utilizada para enviar relatórios de erros à Microsoft e rastrear o status com uso das informações do Microsoft Passport. É possível acessar o site Online Crash Analysis usando o serviço Relatório de erros ou seu navegador da Web. Quando for habilitado, o serviço Relatório de erros monitorará o sistema para procurar falhas dos modos de kernel e de usuário relacionadas a componentes do sistema operacional e aplicativos. Com o relatório do modo de kernel, você pode obter mais informações sobre o problema ou a condição que causou o erro de parada. Para obter mais informações, consulte Visão geral sobre o relatório de erros do sistema e de programas.
  2. Verifique se existe espaço adequado em disco, especialmente para novas instalações.
  3. Desabilite os drivers instalados recentemente. É aconselhável também desabilitar um serviço associado ao driver ou a quaisquer programas recém-instalados.
  4. Se o computador não inicializar normalmente, tente iniciá-lo em Última configuração válida ou em Modo de segurança e remova ou desabilite os drivers e programas adicionados por último. Para obter informações sobre como iniciar o computador em modo de segurança, consulte Iniciar o computador em modo de segurança. Para obter mais informações sobre como iniciar o computador em Última configuração válida, consulte Iniciar o computador usando a Última configuração válida.

    Importante

    • Quando você usa a Última configuração válida, as alterações nas configurações do sistema efetuadas após a última inicialização bem-sucedida são perdidas.
  5. Verifique se você tem BIOS mais atualizado para o sistema (no caso de computadores baseados em x86) ou o firmware correto (para computadores baseados na arquitetura Itanium). Contate o fabricante do hardware se precisar de assistência na execução desse procedimento.

Observação

  • É possível pesquisar no site da Microsoft informações atualizadas sobre essa mensagem de parada. Para fazer isso, consulte Welcome to Microsoft Help and Support no site da Microsoft (http://www.microsoft.com), clique em uma opção de pesquisa e siga as instruções da página. Ao digitar palavras-chave, use stop 0x0000001E.

    Para obter mais informações sobre artigos, assistentes para solução de problemas e itens para download, consulte Informações técnicas atualizadas.

Mensagem de parada 0x0000002E

Texto descritivo: DRIVER_IRQL_NOT_LESS_OR_EQUAL

Causa comum: Tentativa de tocar a memória paginável em um nível de solicitação interno de processo (IRQL) muito alto. Isso é geralmente causado por drivers que usam endereços impróprios. Os drivers do modo de kernel não podem acessar a memória paginável em um IRQL alto.

Solução:

  1. Use a ferramenta Online Crash Analysis no site da Microsoft. (http://www.microsoft.com/) Essa ferramenta pode ser utilizada para enviar relatórios de erros à Microsoft e rastrear o status com uso das informações do Microsoft Passport. É possível acessar o site Online Crash Analysis usando o serviço Relatório de erros ou seu navegador da Web. Quando for habilitado, o serviço Relatório de erros monitorará o sistema para procurar falhas dos modos de kernel e de usuário relacionadas a componentes do sistema operacional e aplicativos. Com o relatório do modo de kernel, você pode obter mais informações sobre o problema ou a condição que causou o erro de parada. Para obter mais informações, consulte Visão geral sobre o relatório de erros do sistema e de programas.
  2. Use a ferramenta Verificação de assinatura de arquivo, que identifica drivers não assinados e arquivos de sistema incompatíveis no computador. Os arquivos de sistema e arquivos de drivers de dispositivos fornecidos com a família Windows Server 2003 possuem uma assinatura digital da Microsoft que indica que os arquivos são originais e inalterados ou que foram aprovados pela Microsoft para uso com o Windows. Para obter mais informações, consulte Usando a verificação de assinatura de arquivo.
  3. Use o Gerenciador de dispositivos para voltar a uma versão anterior do driver. Para obter mais informações, consulte Voltar a uma versão anterior de um driver.
  4. Desabilite o driver identificado na mensagem de parada ou quaisquer drivers instalados recentemente.
  5. Se o computador não inicializar normalmente, tente iniciá-lo em Última configuração válida ou em Modo de segurança e remova ou desabilite os drivers e programas adicionados por último. Para obter informações sobre como iniciar o computador em modo de segurança, consulte Iniciar o computador em modo de segurança. Para obter mais informações sobre como iniciar o computador em Última configuração válida, consulte Iniciar o computador usando a Última configuração válida.

    Importante

    • Quando você usa a Última configuração válida, as alterações nas configurações do sistema efetuadas após a última inicialização bem-sucedida são perdidas.
  6. Confirme se o seu hardware foi projetado para a família Windows Server 2003 clicando no link apropriado em Recursos de suporte.

Observação

  • É possível pesquisar no site da Microsoft informações atualizadas sobre essa mensagem de parada. Para fazer isso, consulte Welcome to Microsoft Help and Support no site da Microsoft (http://www.microsoft.com), clique em uma opção de pesquisa e siga as instruções da página. Ao digitar palavras-chave, use stop 0x000000D1.

    Para obter mais informações sobre artigos, assistentes para solução de problemas e itens para download, consulte Informações técnicas atualizadas.

Mensagem de parada 0x000000EA

Texto descritivo: THREAD_STUCK_IN_DEVICE_DRIVER

Causa comum: O driver de vídeo se encontra em um loop infinito. Em geral, isso indica um problema com o hardware ou o driver de vídeo.

Solução:

  1. Use a ferramenta Online Crash Analysis no site da Microsoft. (http://www.microsoft.com/) Essa ferramenta pode ser utilizada para enviar relatórios de erros à Microsoft e rastrear o status com uso das informações do Microsoft Passport. É possível acessar o site Online Crash Analysis usando o serviço Relatório de erros ou seu navegador da Web. Quando for habilitado, o serviço Relatório de erros monitorará o sistema para procurar falhas dos modos de kernel e de usuário relacionadas a componentes do sistema operacional e aplicativos. Com o relatório do modo de kernel, você pode obter mais informações sobre o problema ou a condição que causou o erro de parada. Para obter mais informações, consulte Visão geral sobre o relatório de erros do sistema e de programas.
  2. Desabilite o driver identificado na mensagem de parada ou quaisquer drivers instalados recentemente.
  3. Se o computador não inicializar normalmente, tente iniciá-lo em Última configuração válida ou em Modo de segurança e remova ou desabilite os drivers e programas adicionados por último. Para obter informações sobre como iniciar o computador em modo de segurança, consulte Iniciar o computador em modo de segurança. Para obter mais informações sobre como iniciar o computador em Última configuração válida, consulte Iniciar o computador usando a Última configuração válida.

    Importante

    • Quando você usa a Última configuração válida, as alterações nas configurações do sistema efetuadas após a última inicialização bem-sucedida são perdidas.
  4. Confirme se o seu hardware foi projetado para a família Windows Server 2003 clicando no link apropriado em Recursos de suporte.

Observação

  • É possível pesquisar no site da Microsoft informações atualizadas sobre essa mensagem de parada. Para fazer isso, consulte Welcome to Microsoft Help and Support no site da Microsoft (http://www.microsoft.com), clique em uma opção de pesquisa e siga as instruções da página. Ao digitar palavras-chave, use stop 0x000000EA.

    Para obter mais informações sobre artigos, assistentes para solução de problemas e itens para download, consulte Informações técnicas atualizadas.

Mensagem de parada 0x00000050

Texto descritivo: PAGE_FAULT_IN_NONPAGED_AREA

Causa comum: Dados solicitados não são encontrados na memória. Isso pode ter sido causado por um driver de impressora ou driver de acesso remoto.

Solução:

  1. Use a ferramenta Online Crash Analysis no site da Microsoft. (http://www.microsoft.com/) Essa ferramenta pode ser utilizada para enviar relatórios de erros à Microsoft e rastrear o status com uso das informações do Microsoft Passport. É possível acessar o site Online Crash Analysis usando o serviço Relatório de erros ou seu navegador da Web. Quando for habilitado, o serviço Relatório de erros monitorará o sistema para procurar falhas dos modos de kernel e de usuário relacionadas a componentes do sistema operacional e aplicativos. Com o relatório do modo de kernel, você pode obter mais informações sobre o problema ou a condição que causou o erro de parada. Para obter mais informações, consulte Visão geral sobre o relatório de erros do sistema e de programas.
  2. Use o Gerenciador de dispositivos para voltar a uma versão anterior do driver. Para obter mais informações, consulte Voltar a uma versão anterior de um driver.
  3. Desabilite os drivers instalados recentemente.
  4. Se o computador não inicializar normalmente, tente iniciá-lo em Última configuração válida ou em Modo de segurança e remova ou desabilite os drivers e programas adicionados por último. Para obter informações sobre como iniciar o computador em modo de segurança, consulte Iniciar o computador em modo de segurança. Para obter mais informações sobre como iniciar o computador em Última configuração válida, consulte Iniciar o computador usando a Última Configuração Válida.

    Importante

    • Quando você usa a Última configuração válida, as alterações nas configurações do sistema efetuadas após a última inicialização bem-sucedida são perdidas.
  5. Confirme se o seu hardware foi projetado para a família Windows Server 2003 clicando no link apropriado em Recursos de suporte.

Observação

  • É possível pesquisar no site da Microsoft informações atualizadas sobre essa mensagem de parada. Para fazer isso, consulte Welcome to Microsoft Help and Support no site da Microsoft (http://www.microsoft.com), clique em uma opção de pesquisa e siga as instruções da página. Ao digitar palavras-chave, use stop 0x00000050.

    Para obter mais informações sobre artigos, assistentes para solução de problemas e itens para download, consulte Informações técnicas atualizadas.

Mensagem de parada 0x000000BE

Texto descritivo: ATTEMPTED_WRITE_TO_READONLY_MEMORY

Causa comum: Um driver de dispositivo tentou gravar na memória somente leitura. Este problema pode ocorrer durante uma atualização, embora não esteja limitado a atualizações.

Solução:

  1. Use a ferramenta Online Crash Analysis no site da Microsoft (http://www.microsoft.com/). Você pode usar essa ferramenta para enviar relatórios de erro para a Microsoft e controlar seu status usando as informações do Microsoft Passport. É possível acessar o site Online Crash Analysis usando o serviço Relatório de erros ou seu navegador da Web. Quando for habilitado, o serviço Relatório de erros monitorará o sistema para procurar falhas dos modos de kernel e de usuário relacionadas a componentes do sistema operacional e aplicativos. Com o relatório do modo de kernel, você pode obter mais informações sobre o problema ou a condição que causou o erro de parada. Para obter mais informações, consulte Visão geral sobre o relatório de erros do sistema e de programas.
  2. Confirme se o seu hardware foi projetado para a família Windows Server 2003 clicando no link apropriado em Recursos de suporte.
  3. Se o computador não inicializar normalmente, tente iniciá-lo em Última configuração válida ou em Modo de segurança e remova ou desabilite os drivers e programas adicionados por último. Para obter informações sobre como iniciar o computador em modo de segurança, consulte Iniciar o computador em modo de segurança. Para obter mais informações sobre como iniciar o computador em Última configuração válida, consulte Iniciar o computador usando a Última Configuração Válida.

    Importante

    • Quando você usa a Última configuração válida, as alterações nas configurações do sistema efetuadas após a última inicialização bem-sucedida são perdidas.

Observação

  • É possível pesquisar no site da Microsoft informações atualizadas sobre essa mensagem de parada. Para fazer isso, consulte Welcome to Microsoft Help and Support no site da Microsoft (http://www.microsoft.com), clique em uma opção de pesquisa e siga as instruções da página. Ao digitar palavras-chave, use stop 0x000000BE.

    Para obter mais informações sobre artigos, assistentes para solução de problemas e itens para download, consulte Informações técnicas atualizadas.

Mensagem de parada 0x0000000A em uma instalação existente

Texto descritivo: IRQL_NOT_LESS_OR_EQUAL

Causa comum: Os drivers estão usando endereços de memória inadequados.

Solução:

  1. Use a ferramenta Online Crash Analysis no site da Microsoft (http://www.microsoft.com/). Você pode usar essa ferramenta para enviar relatórios de erro para a Microsoft e controlar seu status usando as informações do Microsoft Passport. É possível acessar o site Online Crash Analysis usando o serviço Relatório de erros ou seu navegador da Web. Quando for habilitado, o serviço Relatório de erros monitorará o sistema para procurar falhas dos modos de kernel e de usuário relacionadas a componentes do sistema operacional e aplicativos. Com o relatório do modo de kernel, você pode obter mais informações sobre o problema ou a condição que causou o erro de parada. Para obter mais informações, consulte Visão geral sobre o relatório de erros do sistema e de programas.
  2. Se você conseguir iniciar o sistema operacional, verifique o log do sistema em Visualizar eventos para verificar se há mensagens de erro adicionais que possam ajudar a identificar o dispositivo ou driver que está causando o problema. XOX
  3. Confirme se o seu hardware foi projetado para a família Windows Server 2003 clicando no link apropriado em Recursos de suporte.
  4. Desabilite os drivers recém-instalados e remova os programas recém-adicionados.
  5. Se o computador não inicializar normalmente, tente iniciá-lo em Última configuração válida ou em Modo de segurança e remova ou desabilite os drivers e programas adicionados por último. Para obter informações sobre como iniciar o computador em modo de segurança, consulte Iniciar o computador em modo de segurança. Para obter mais informações sobre como iniciar o computador em Última configuração válida, consulte Iniciar o computador usando a Última Configuração Válida.

    Importante

    • Quando você usa a Última configuração válida, as alterações nas configurações do sistema efetuadas após a última inicialização bem-sucedida são perdidas.
  6. Remova os hardwares instalados por último (RAM, adaptadores, discos rígidos, modems etc.).
  7. Verifique se você atualizou os drivers dos dispositivos de hardware. Além disso, verifique se possui o BIOS mais atualizado para o sistema (no caso de computadores x86) ou o firmware correto (para computadores baseados na arquitetura Itanium). Os fabricantes de dispositivos podem ajudar na obtenção desses itens.
  8. Execute os diagnósticos de sistema fornecidos pelo revendedor do hardware, especialmente uma verificação de memória.
  9. Desabilite o cache de memória no BIOS (no caso de computadores baseados no x86) ou na EFI (nos computadores com arquitetura baseada em Itanium). Contate o fabricante do hardware se precisar de assistência na execução desse procedimento.

Observação

  • É possível pesquisar no site da Microsoft informações atualizadas sobre essa mensagem de parada. Para fazer isso, consulte Welcome to Microsoft Help and Support no site da Microsoft (http://www.microsoft.com), clique em uma opção de pesquisa e siga as instruções da página. Ao digitar palavras-chave, use stop 0x0000000A.

    Para obter mais informações sobre artigos, assistentes para solução de problemas e itens para download, consulte Informações técnicas atualizadas.

Mensagem de parada 0x0000000A em uma nova instalação

Texto descritivo: IRQL_NOT_LESS_OR_EQUAL

Causa comum: Os drivers estão usando endereços de memória inadequados.

Solução:

  1. Use a ferramenta Online Crash Analysis no site da Microsoft (http://www.microsoft.com/). Você pode usar essa ferramenta para enviar relatórios de erro para a Microsoft e controlar seu status usando as informações do Microsoft Passport. É possível acessar o site Online Crash Analysis usando o serviço Relatório de erros ou seu navegador da Web. Quando for habilitado, o serviço Relatório de erros monitorará o sistema para procurar falhas dos modos de kernel e de usuário relacionadas a componentes do sistema operacional e aplicativos. Com o relatório do modo de kernel, você pode obter mais informações sobre o problema ou a condição que causou o erro de parada. Para obter mais informações, consulte Visão geral sobre o relatório de erros do sistema e de programas.
  2. Durante o processo de instalação, na mensagem "A instalação está inspecionando a configuração de hardware do computador", pressione F5. Selecione o tipo de computador correto quando for solicitado. Por exemplo, se você tiver um computador com um único processador, selecione PC padrão.
  3. Confirme se o seu hardware foi projetado para a família Windows Server 2003 clicando no link apropriado em Recursos de suporte.
  4. Desabilite o cache de memória no BIOS (no caso de computadores x86) ou na EFI (para computadores com arquitetura baseada em Itanium. Contate o fabricante do hardware se precisar de assistência na execução desse procedimento.
  5. Remova todos os adaptadores e desconecte todos os dispositivos de hardware não essenciais.
  6. Se você estiver usando um adaptador SCSI, obtenha o último driver do fornecedor do adaptador, desabilite a negociação sincronizada, verifique terminações e as identificações de SCSI dos dispositivos.
  7. Se você estiver usando dispositivos de circuitos eletrônicos de dispositivos integrados (IDE), defina a porta IDE na placa como canal primário. Verifique as configurações mestre/escravo referentes aos dispositivos IDE. Remova todos os dispositivos IDE exceto o disco rígido. Consulte a documentação do fabricante do hardware para obter mais informações.
  8. Execute os diagnósticos do sistema fornecidos pelo revendedor do hardware, especialmente a verificação de memória.
  9. Se o computador não inicializar normalmente, tente iniciá-lo em Última configuração válida ou em Modo de segurança e remova ou desabilite os drivers e programas adicionados por último. Para obter informações sobre como iniciar o computador em modo de segurança, consulte Iniciar o computador em modo de segurança. Para obter mais informações sobre como iniciar o computador em Última configuração válida, consulte Iniciar o computador usando a Última Configuração Válida.

    Importante

    • Quando você usa a Última configuração válida, as alterações nas configurações do sistema efetuadas após a última inicialização bem-sucedida são perdidas.

Observação

  • É possível pesquisar no site da Microsoft informações atualizadas sobre essa mensagem de parada. Para fazer isso, consulte Welcome to Microsoft Help and Support no site da Microsoft (http://www.microsoft.com), clique em uma opção de pesquisa e siga as instruções da página. Ao digitar palavras-chave, use stop 0x0000000A.

    Para obter mais informações sobre artigos, assistentes para solução de problemas e itens para download, consulte Informações técnicas atualizadas.

Mensagens de parada 0x00000023 e 0x00000024

Texto descritivo: FAT_FILE_SYSTEM ou NTFS_FILE_SYSTEM

Causa comum: O disco rígido está fragmentado ou a E/S de arquivos está excessiva. Esse erro de parada também pode ser causado por espelhamento de unidade ou algum software antivírus.

Solução:

  1. Use a ferramenta Online Crash Analysis no site da Microsoft (http://www.microsoft.com/). Você pode usar essa ferramenta para enviar relatórios de erro para a Microsoft e controlar seu status usando as informações do Microsoft Passport. É possível acessar o site Online Crash Analysis usando o serviço Relatório de erros ou seu navegador da Web. Quando for habilitado, o serviço Relatório de erros monitorará o sistema para procurar falhas dos modos de kernel e de usuário relacionadas a componentes do sistema operacional e aplicativos. Com o relatório do modo de kernel, você pode obter mais informações sobre o problema ou a condição que causou o erro de parada. Para obter mais informações, consulte Visão geral sobre o relatório de erros do sistema e de programas.
  2. Desabilite os programas antivírus ou de backup e desabilite os utilitários de desfragmentação.
  3. Verifique se o disco rígido está danificado executando o chkdsk e reiniciando o computador em seguida. Se você não conseguir executar o chkdsk, talvez seja necessário mover o disco rígido para outro computador que esteja executando um produto da família Windows Server 2003 e executar o comando nessa unidade. Para obter mais informações, consulte Chkdsk. (Observe que o comando chkdsk com diferentes parâmetros, está disponível no Console de recuperação).
  4. Se o computador não inicializar normalmente, tente iniciá-lo em Última configuração válida ou em Modo de segurança e remova ou desabilite os drivers e programas adicionados por último. Para obter informações sobre como iniciar o computador em modo de segurança, consulte Iniciar o computador em modo de segurança. Para obter mais informações sobre como iniciar o computador em Última configuração válida, consulte Iniciar o computador usando a Última Configuração Válida.

    Importante

    • Quando você usa a Última configuração válida, as alterações nas configurações do sistema efetuadas após a última inicialização bem-sucedida são perdidas.

Observação

  • É possível pesquisar no site da Microsoft informações atualizadas sobre essas mensagens de parada. Para fazer isso, consulte Welcome to Microsoft Help and Support no site da Microsoft (http://www.microsoft.com), clique em uma opção de pesquisa e siga as instruções da página. Ao digitar palavras-chave, use stop 0x00000023 ou stop 0x00000024.

    Para obter mais informações sobre artigos, assistentes para solução de problemas e itens para download, consulte Informações técnicas atualizadas.

Mensagem de parada 0x0000007B

Texto descritivo: INACCESSIBLE_BOOT_DEVICE

Causa comum: Ocorreu um problema durante a inicialização do sistema de E/S (normalmente o dispositivo de inicialização ou o sistema de arquivos).

Solução:

  1. Verifique se há vírus no computador. Essa mensagem de parada é freqüentemente exibida quando há um vírus no setor de inicialização.
  2. Reparar ou recuperar o disco rígido. Para obter maneiras de corrigir o disco rígido, consulte Visão geral sobre correções e Visão geral sobre o Console de Recuperação.
  3. Remova quaisquer controladores ou unidades de disco rígido adicionadas recentemente.
  4. Se você estiver usando um adaptador SCSI, obtenha o último driver do fornecedor do adaptador, desabilite a negociação sincronizada, verifique terminações e as identificações de SCSI dos dispositivos.
  5. Se você estiver usando dispositivos de circuitos eletrônicos de dispositivos integrados (IDE), defina a porta IDE na placa como canal primário. Verifique as configurações mestre/escravo referentes aos dispositivos IDE. Remova todos os dispositivos IDE exceto o disco rígido. Consulte a documentação do fabricante do hardware para obter mais informações.
  6. Verifique se há dano no disco rígido executando o chkdsk. Se você não conseguir executar o chkdsk, talvez seja necessário mover o disco rígido para outro computador que esteja executando um produto da família Windows Server 2003 e executar o comando nessa unidade. Para obter mais informações, consulte Chkdsk. (Observe que o comando chkdsk com diferentes parâmetros, está disponível no Console de recuperação).
  7. Se o computador não inicializar normalmente, tente iniciá-lo em Última configuração válida. Para obter mais informações sobre como iniciar o computador em Última configuração válida, consulte Iniciar o computador usando a Última Configuração Válida.

    Importante

    • Quando você usa a Última configuração válida, as alterações nas configurações do sistema efetuadas após a última inicialização bem-sucedida são perdidas.

Observação

  • É possível pesquisar no site da Microsoft informações atualizadas sobre essa mensagem de parada. Para fazer isso, consulte Welcome to Microsoft Help and Support no site da Microsoft (http://www.microsoft.com), clique em uma opção de pesquisa e siga as instruções da página. Ao digitar palavras-chave, use stop 0x0000007B.

    Para obter mais informações sobre artigos, assistentes para solução de problemas e itens para download, consulte Informações técnicas atualizadas.

Mensagem de parada 0x0000007F

Texto descritivo: UNEXPECTED_KERNEL_MODE_TRAP

Causa comum: Há um problema de hardware ou software. Isso geralmente é causado por uma falha de hardware.

Solução:

  1. Use a ferramenta Online Crash Analysis no site da Microsoft (http://www.microsoft.com/). Você pode usar essa ferramenta para enviar relatórios de erro para a Microsoft e controlar seu status usando as informações do Microsoft Passport. É possível acessar o site Online Crash Analysis usando o serviço Relatório de erros ou seu navegador da Web. Quando for habilitado, o serviço Relatório de erros monitorará o sistema para procurar falhas dos modos de kernel e de usuário relacionadas a componentes do sistema operacional e aplicativos. Com o relatório do modo de kernel, você pode obter mais informações sobre o problema ou a condição que causou o erro de parada. Para obter mais informações, consulte Visão geral sobre o relatório de erros do sistema e de programas.
  2. Execute os diagnósticos de sistema fornecidos pelo revendedor do hardware, especialmente uma verificação de memória. Essa mensagem de parada é freqüentemente exibida no caso de memória defeituosa ou inconsistente.
  3. Desabilite o cache de memória no BIOS (no caso de computadores x86) ou na EFI (para computadores com arquitetura baseada em Itanium. Contate o fabricante do hardware se precisar de assistência na execução desse procedimento.
  4. Confirme se o seu hardware foi projetado para a família Windows Server 2003 clicando no link apropriado em Recursos de suporte.
  5. Se o computador não inicializar normalmente, tente iniciá-lo em Última configuração válida ou em Modo de segurança e remova ou desabilite os drivers e programas adicionados por último. Para obter informações sobre como iniciar o computador em modo de segurança, consulte Iniciar o computador em modo de segurança. Para obter mais informações sobre como iniciar o computador em Última configuração válida, consulte Iniciar o computador usando a Última Configuração Válida.

    Importante

    • Quando você usa a Última configuração válida, as alterações nas configurações do sistema efetuadas após a última inicialização bem-sucedida são perdidas.

Observação

  • É possível pesquisar no site da Microsoft informações atualizadas sobre essa mensagem de parada. Para fazer isso, consulte Welcome to Microsoft Help and Support no site da Microsoft (http://www.microsoft.com), clique em uma opção de pesquisa e siga as instruções da página. Ao digitar palavras-chave, use stop 0x0000007F.

    Para obter mais informações sobre artigos, assistentes para solução de problemas e itens para download, consulte Informações técnicas atualizadas.

Mensagem de parada 0x0000002E

Texto descritivo: DRIVER_POWER_STATE_FAILURE

Causa usual: Um driver está em um estado de energia inconsistente ou inválido.

Solução:

  1. Use a ferramenta Online Crash Analysis no site da Microsoft (http://www.microsoft.com/). Você pode usar essa ferramenta para enviar relatórios de erro para a Microsoft e controlar seu status usando as informações do Microsoft Passport. É possível acessar o site Online Crash Analysis usando o serviço Relatório de erros ou seu navegador da Web. Quando for habilitado, o serviço Relatório de erros monitorará o sistema para procurar falhas dos modos de kernel e de usuário relacionadas a componentes do sistema operacional e aplicativos. Com o relatório do modo de kernel, você pode obter mais informações sobre o problema ou a condição que causou o erro de parada. Para obter mais informações, consulte Visão geral sobre o relatório de erros do sistema e de programas.
  2. Desabilite o driver identificado na mensagem de parada ou quaisquer drivers instalados recentemente.
  3. Atualize qualquer software que use drivers de filtro, como programas antivírus ou de backup.
  4. Confirme se o seu hardware foi projetado para a família Windows Server 2003 clicando no link apropriado em Recursos de suporte.
  5. Se o computador não inicializar normalmente, tente iniciá-lo em Última configuração válida ou em Modo de segurança e remova ou desabilite os drivers e programas adicionados por último. Para obter informações sobre como iniciar o computador em modo de segurança, consulte Iniciar o computador em modo de segurança. Para obter mais informações sobre como iniciar o computador em Última configuração válida, consulte Iniciar o computador usando a Última Configuração Válida.

    Importante

    • Quando você usa a Última configuração válida, as alterações nas configurações do sistema efetuadas após a última inicialização bem-sucedida são perdidas.

Observação

  • É possível pesquisar no site da Microsoft informações atualizadas sobre essa mensagem de parada. Para fazer isso, visite o site da Microsoft (http://www.microsoft.com), clique na opção de pesquisa e siga as instruções da página. Ao digitar palavras-chave, use stop 0x0000009F.

    Para obter mais informações sobre artigos, assistentes para solução de problemas e itens para download, consulte Informações técnicas atualizadas.

Mensagem de parada 0xC000021A

Texto descritivo: FATAL_SYSTEM_ERROR

Causa usual: O processo de sistema Processo de logon do Windows terminou de forma inesperada.

Solução:

  1. Use a ferramenta Online Crash Analysis no site da Microsoft (http://www.microsoft.com/). Você pode usar essa ferramenta para enviar relatórios de erro para a Microsoft e controlar seu status usando as informações do Microsoft Passport. É possível acessar o site Online Crash Analysis usando o serviço Relatório de erros ou seu navegador da Web. Quando for habilitado, o serviço Relatório de erros monitorará o sistema para procurar falhas dos modos de kernel e de usuário relacionadas a componentes do sistema operacional e aplicativos. Com o relatório do modo de kernel, você pode obter mais informações sobre o problema ou a condição que causou o erro de parada. Para obter mais informações, consulte Visão geral sobre o relatório de erros do sistema e de programas.
  2. Desabilite o driver identificado na mensagem de parada ou quaisquer drivers instalados recentemente.
  3. Se o computador não inicializar normalmente, tente iniciá-lo em Última configuração válida ou em Modo de segurança e remova ou desabilite os drivers e programas adicionados por último. Para obter informações sobre como iniciar o computador em modo de segurança, consulte Iniciar o computador em modo de segurança. Para obter mais informações sobre como iniciar o computador em Última configuração válida, consulte Iniciar o computador usando a Última Configuração Válida.

    Importante

    • Quando você usa a Última configuração válida, as alterações nas configurações do sistema efetuadas após a última inicialização bem-sucedida são perdidas.
  4. Confirme se o seu hardware foi projetado para a família Windows Server 2003 clicando no link apropriado em Recursos de suporte.

Observação

  • É possível pesquisar no site da Microsoft informações atualizadas sobre essa mensagem de parada. Para fazer isso, consulte Welcome to Microsoft Help and Support no site da Microsoft (http://www.microsoft.com), clique em uma opção de pesquisa e siga as instruções da página. Ao digitar palavras-chave, use stop 0xC000021A.

    Para obter mais informações sobre artigos, assistentes para solução de problemas e itens para download, consulte Informações técnicas atualizadas.

Mensagem de parada 0xC0000221

Texto descritivo: BAD_IMAGE_CHECKSUM

Causa comum: Esta mensagem pode ser causada por um arquivo de sistema ou driver corrompido ou um problema de hardware.

Solução:

  1. Use a ferramenta Online Crash Analysis no site da Microsoft (http://www.microsoft.com/). Você pode usar essa ferramenta para enviar relatórios de erro para a Microsoft e controlar seu status usando as informações do Microsoft Passport. É possível acessar o site Online Crash Analysis usando o serviço Relatório de erros ou seu navegador da Web. Quando for habilitado, o serviço Relatório de erros monitorará o sistema para procurar falhas dos modos de kernel e de usuário relacionadas a componentes do sistema operacional e aplicativos. Com o relatório do modo de kernel, você pode obter mais informações sobre o problema ou a condição que causou o erro de parada. Para obter mais informações, consulte Visão geral sobre o relatório de erros do sistema e de programas.
  2. Substitua o arquivo identificado.
  3. Se o computador não inicializar normalmente, tente iniciá-lo em Última configuração válida ou em Modo de segurança e, em seguida, substitua o arquivo. Para obter informações sobre como iniciar o computador em modo de segurança, consulte Iniciar o computador em modo de segurança. Para obter mais informações sobre como iniciar o computador em Última configuração válida, consulte Iniciar o computador usando a Última Configuração Válida.

    Importante

    • Quando você usa a Última configuração válida, as alterações nas configurações do sistema efetuadas após a última inicialização bem-sucedida são perdidas.

Observação

  • É possível pesquisar no site da Microsoft informações atualizadas sobre essa mensagem de parada. Para fazer isso, consulte Welcome to Microsoft Help and Support no site da Microsoft (http://www.microsoft.com), clique em uma opção de pesquisa e siga as instruções da página. Ao digitar palavras-chave, use stop 0xC0000221.

    Para obter mais informações sobre artigos, assistentes para solução de problemas e itens para download, consulte Informações técnicas atualizadas.

Mensagem de parada 0xC0000218

Texto descritivo: UNKNOWN_HARD_ERROR

Causa comum: Um arquivo do Registro pode estar corrompido.

Solução:

  1. Use a ferramenta Online Crash Analysis no site da Microsoft (http://www.microsoft.com/). Você pode usar essa ferramenta para enviar relatórios de erro para a Microsoft e controlar seu status usando as informações do Microsoft Passport. É possível acessar o site Online Crash Analysis usando o serviço Relatório de erros ou seu navegador da Web. Quando for habilitado, o serviço Relatório de erros monitorará o sistema para procurar falhas dos modos de kernel e de usuário relacionadas a componentes do sistema operacional e aplicativos. Com o relatório do modo de kernel, você pode obter mais informações sobre o problema ou a condição que causou o erro de parada. Para obter mais informações, consulte Visão geral sobre o relatório de erros do sistema e de programas.
  2. Se o computador não inicializar normalmente, tente iniciá-lo em Última configuração válida. Para obter mais informações sobre como iniciar o computador em Última configuração válida, consulte Iniciar o computador usando a Última Configuração Válida.

    Importante

    • Quando você usa a Última configuração válida, as alterações nas configurações do sistema efetuadas após a última inicialização bem-sucedida são perdidas.
  3. Se você tiver um backup de recuperação automática do sistema (ASR), talvez precise utilizar esta opção de recuperação. Para obter mais informações, consulte Visão geral sobre a recuperação automática do sistema (ASR).

Observação

  • É possível pesquisar no site da Microsoft informações atualizadas sobre essa mensagem de parada. Para fazer isso, consulte Welcome to Microsoft Help and Support no site da Microsoft (http://www.microsoft.com), clique em uma opção de pesquisa e siga as instruções da página. Ao digitar palavras-chave, use stop 0xC0000218.

    Para obter mais informações sobre artigos, assistentes para solução de problemas e itens para download, consulte Informações técnicas atualizadas.


Instalando e atualizando em nós de cluster

Com o Windows Server 2003, Enterprise Edition ou o Windows Server 2003, Datacenter Edition, você pode usar clusters para garantir que os usuários tenham acesso constante a recursos importantes do servidor. Com clusters, você cria vários nós de cluster que aparecem para usuários como um servidor. Se um dos nós no cluster falhar, o outro nó começa a fornecer o serviço (processo conhecido como failover). Os aplicativos e recursos de missão crítica e permanecem disponíveis continuamente.

Os tópicos a seguir descrevem as opções de atualização ou de instalação em nós de cluster.

  • Antes de executar uma atualização, consulte a Lista de verificação: Preparação para atualizar um cluster
  • Antes de executar uma nova instalação, consulte a Lista de verificação: Preparação para instalar um cluster
  • Para obter dicas sobre como atualizar e instalar em nós de cluster, consulte Práticas recomendadas
  • Para obter ajuda em tarefas específicas, consulte Como...
  • Para obter informações detalhadas, consulte Conceitos.
  • Para obter instruções sobre como solucionar problemas, consulte Solucionando problemas.


Listas de verificação

  • Lista de verificação: Preparação para atualizar um cluster
  • Lista de verificação: Preparação para instalar um cluster


Lista de verificação: Preparação para atualizar um cluster

Etapa | Referência
Verifique se o hardware, incluindo o hardware de armazenamento de cluster, é compatível com o Windows Server 2003, Enterprise Edition.

Não se esqueça de que clusters de servidores geograficamente dispersos (configuração de nó majoritário) são construídos em uma infra-estrutura de rede e armazenamento com características bem diferentes de um cluster de servidores de dispositivo de quorum padrão e, portanto, são certificados em um programa de testes separado. Se estiver considerando a possibilidade de converter o cluster de servidores existente em um cluster de servidores geograficamente dispersos, trabalhe com o fornecedor de hardware para obter uma configuração de clusters de servidores geograficamente dispersos que tenha sido certificada pela Microsoft.

Para obter mais informações sobre clusters de servidores de conjuntos de nós majoritários, consulte Escolhendo um modelo de cluster.

Compatibilidade de hardware
Verifique com o fabricante do hardware de armazenamento de cluster e confira se possui os drivers necessários. | Drivers de armazenamento em massa e o processo de instalação
Revise conceitos para atualizar nós de clusters, escolha o método a ser utilizado e revise as instruções relativas ao método escolhido.

Cuidado

  • Se você estiver usando um método diferente da atualização sem interrupção (ou uma atualização sem interrupção com um ou mais recursos offline), analise e siga as instruções cuidadosamente para evitar corrupção no armazenamento em cluster. Isto é, para métodos diferentes de uma atualização sem interrupção, conclua a atualização e inicie o serviço de cluster em um nó antes de permitir que outro nó tenha acesso ao armazenamento em cluster.
Conceitos

Como...
Revise a lista de verificação para atualização do sistema operacional. | Lista de verificação: Executando uma atualização
Revise procedimentos para iniciar e executar a instalação. Iniciar a instalação em um computador baseado em x86

Iniciar a instalação em um computador com arquitetura baseada em Itanium
Execute o método escolhido para atualizar os nós de clusters. | Como...


Lista de verificação: Preparação para instalar um cluster

Importante

  • Se estiver usando um dispositivo de armazenamento compartilhado, verifique se o Windows Server 2003, Enterprise Edition e o serviço de cluster estão instalados e funcionando em um servidor antes de iniciar o sistema operacional em outro servidor no cluster. Se o sistema operacional for iniciado em vários servidores antes que o serviço de cluster esteja funcionando em um servidor, o armazenamento do cluster pode ser danificado. Depois que o primeiro servidor for configurado, os servidores restantes podem ser instalados simultaneamente.
Etapa | Referência
Verifique se o hardware, incluindo o hardware de armazenamento de cluster, é compatível com o Windows Server 2003, Enterprise Edition. | Compatibilidade de hardware
Verifique com o fabricante do hardware de armazenamento de cluster e confira se possui os drivers necessários. | Drivers de armazenamento em massa e o processo de instalação
Planeje os detalhes básicos da rede para o cluster, incluindo informações sobre adaptadores de rede, endereçamento IP e o nome e a conta que o cluster usará. Além disso, planeje o volume necessário para os dados de configuração do cluster. | Planejando e preparando a instalação do cluster
Examine a lista de verificação da instalação do sistema operacional e tome decisões sobre questões relacionadas a onde instalar componentes adicionais. | Lista de verificação: Executando uma nova instalação
Siga as etapas restantes para criar um cluster de servidores. | Lista de verificação: Planejando e criando um cluster de servidores


Práticas recomendadas

Siga a lista de verificação apropriada ao instalar ou atualizar em nós de clusters

  • Lista de verificação: Preparação para atualizar um cluster
  • Lista de verificação: Preparação para instalar um cluster

Use a opção de configuração Típica (completa) ao criar um novo cluster

Com o Assistente para criar novo cluster de servidor do Administrador de cluster, você pode escolher entre as opções de configuração Típica (completa) e configuração Avançada (mínima). A configuração Típica é apropriada para a maioria das instalações e resulta em um cluster completamente configurado. Use a opção de configuração Avançada somente para clusters com configurações de armazenamento complexas que o Assistente para criar novo cluster de servidor não consegue validar ou para configurações nas quais você não deseje que o cluster gerencie todo o armazenamento. Os exemplos a seguir descrevem cada situação:

  • Em algumas soluções de armazenamento complexas, como uma estrutura de troca Fiber Channel que contém várias chaves, uma unidade de armazenamento específica pode ter uma identidade diferente em cada computador no cluster. Embora esta seja uma configuração de armazenamento válida, ela viola os heurísticos de validação de armazenamento no Assistente para criar novo cluster de servidor. Se você tiver este tipo de solução de armazenamento, poderá receber uma mensagem de erro se tentar criar um cluster usando a opção de configuração Típica. Se sua configuração de armazenamento estiver definida corretamente, você poderá desabilitar os heurísticos de validação de armazenamento e evitar esse erro reiniciando o Assistente para criar novo cluster de servidor, selecionando a opção de configuração Avançada.
  • Em nós específicos de um cluster, você pode desejar que alguns discos fiquem agrupados em clusters e outros sejam mantidos particulares. A opção de configuração Típica configura todos os discos como discos agrupados em cluster e cria recursos de cluster para todos eles. No entanto, com a opção de configuração Avançada, você pode manter certos discos como particulares porque essa configuração cria um cluster no qual somente o disco de quorum é gerenciado pelo cluster (se você tiver optado por utilizar um disco físico como recurso de quorum). Depois de criar o cluster, use o Administrador de cluster para adicionar outros discos a serem gerenciados pelo cluster.

Para obter mais informações, consulte Opções de configuração de armazenamento.

Importante

  • Se estiver usando um dispositivo de armazenamento compartilhado: Antes de criar um cluster, ao ligar o computador e iniciar o sistema operacional, é muito importante que somente um nó tenha acesso ao disco de cluster. Caso contrário, os discos de cluster podem ser corrompidos. Para impedir que esses discos sejam corrompidos, desabilite todos os nós de clusters, exceto um, ou use outras técnicas (por exemplo, mascaramento de nº da unidade lógica, apresentação seletiva ou zoneamento) para proteger os discos de cluster antes de criar o cluster. Antes de iniciar a instalação do segundo nó e dos subseqüentes, verifique também se todos os discos a serem gerenciados pelo cluster têm recursos de disco associados a eles. Se os recursos de disco não estiverem associados aos discos nesse momento, os dados dos discos serão corrompidos porque os discos não estarão protegidos e vários nós tentarão se conectar com eles ao mesmo tempo.
  • Não use Gerenciar o servidor para configurar nós de clusters.

Proteger o cluster de servidores

Para manter o cluster de servidores protegido de usuários não autorizados:

  • Não defina a conta de serviço Cluster como membro do domínio grupo Administradores. Ao conceder os direitos de usuário mínimos à conta de serviço Cluster, você evita possíveis questões de segurança se essa conta for comprometida.
  • Limite e faça auditoria do acesso aos dados compartilhados (por exemplo, arquivos e pastas em discos de cluster).
  • Limite o acesso do cliente a recursos do cluster.
  • Use contas diferentes para o serviço Cluster e aplicativos no cluster.
  • Use contas de serviço Cluster diferentes para vários clusters.
  • Se você tiver feito uma atualização de um cluster Windows NT 4.0 ou Windows 2000, remova a permissão de leitura associada à pasta Windows\Cluster e à pasta MSCS no disco de quorum (que contém o log de quorum) de todas as contas de usuário que não sejam de administrador.
  • Siga as práticas recomendadas padrão para proteger servidores.

Se desejar fazer auditoria do acesso aos dados compartilhados, habilite a auditoria em todos os nós de clusters. Para obter mais informações, consulte Protegendo dados compartilhados em um cluster. Para obter mais informações sobre os direitos de usuário exigidos pela conta de serviço Cluster, consulte Alterar a conta na qual o serviço Cluster é executado. Para obter mais informações sobre segurança em um cluster de servidor, consulte Gerenciando a segurança em um cluster. Para obter mais informações sobre as práticas recomendadas para proteger servidores, consulte Práticas recomendadas de segurança.

Revisar outras práticas recomendadas para clusters de servidores

Para obter mais informações, consulte as Práticas recomendadas para clusters de servidores.


Como...

Estas seções explicam como configurar clusters no Windows Server 2003, Enterprise Edition. Antes de iniciar a instalação ou atualização de um cluster, examine a Lista de verificação: Preparação para atualizar um cluster ou a Lista de verificação: Preparação para instalar um cluster.

  • Atualizar um cluster do Windows 2000
  • Atualizar um cluster do Windows NT 4.0


Atualizar um cluster do Windows 2000

Se estiver atualizando do Windows 2000 para o Windows Server 2003, Enterprise Edition em nós de cluster, você poderá executar uma atualização sem interrupção do sistema operacional. Em uma atualização sem interrupção, você atualiza seqüencialmente o sistema operacional em cada nó, verificando se um nó está sempre disponível para tratar as solicitações do cliente. Quando você atualiza o sistema operacional, o serviço de cluster também é atualizado automaticamente. Uma atualização sem interrupção maximiza a disponibilidade de serviços de cluster e minimiza a complexidade administrativa.

Os tópicos a seguir descrevem os processos e os procedimentos para atualização do Windows 2000 para o Windows Server 2003, Enterprise Edition.

  • Executar uma atualização sem interrupção do Windows 2000
  • Executar uma atualização sem interrupção do último nó do Windows 2000
  • Atualizar do Windows 2000 em um cluster contendo IIS usando o script fornecido
  • Atualizar do Windows 2000 em um cluster contendo IIS sem usar o script fornecido
  • Atualizar do Windows 2000 em um cluster que contém enfileiramento de mensagens


Executar uma atualização sem interrupção do Windows 2000

Elemento gráfico do Microsoft Windows

Para executar uma atualização sem interrupção do Windows 2000

  1. Confirme se os sistemas estão executando o Windows 2000 e use recursos para os quais há suporte durante a atualização sem interrupção, conforme descrito em "Comportamento do recurso durante atualizações sem interrupção" em Tópicos relacionados.
  2. Confirme se o seu hardware foi projetado para Windows Server 2003, Enterprise Edition ou é compatível com ele. Para obter mais informações, consulte "Lista de verificação: preparação para atualizar um cluster" em Tópicos relacionados.
  3. No Administrador de cluster, clique no nó que deseja atualizar primeiro.
  4. No menu Arquivo, clique em Pausa no nó.
  5. No painel de detalhes da direita, clique em Grupos ativos.
  6. No painel de detalhes, clique em um grupo e, no menu Arquivo, clique em Mover grupo. Repita esta etapa para cada grupo listado.

    Os serviços serão interrompidos durante o tempo em que estão sendo movidos e reiniciados no outro nó. Depois que os grupos forem movidos, um nó fica ocioso e o outro trata todas as solicitações de clientes.

  7. Use a instalação do Windows Server 2003, Enterprise Edition para atualizar o nó em pausa do Windows 2000.

    Para obter informações sobre como iniciar a instalação, consulte Tópicos relacionados.

    A instalação detecta a versão anterior do cluster no nó em pausa e instala automaticamente o cluster para Windows Server 2003, Enterprise Edition. O nó volta ao cluster automaticamente no fim do processo de atualização, mas continua em pausa e não trata nenhum trabalho relacionado a cluster.

    Observações

    • Quando começar o processo de instalação, você receberá uma mensagem de aviso informando sobre como usar a opção tempdrive da instalação. Quando tiver concluído as etapas anteriores, clique em OK e continue a instalação sem usar esta opção.
    • Gerenciar o servidor será exibido quando você fizer logon inicialmente no nó recém-atualizado como Administrador. Feche Gerenciar o servidor para continuar a atualização sem interrupção.
  8. Para verificar se o nó que foi atualizado está totalmente funcional, execute testes de validação, como confirmar se o sistema operacional reconhece as conexões de rede e, usando o Gerenciador de dispositivos, verifique se o sistema operacional reconhece todos os dispositivos de armazenamento.
  9. Em Administrador de cluster, clique no nó que foi interrompido e, em seguida, no menu Arquivo, clique em Reiniciar nó.

    Observação

    • Quando você usa o Administrador de cluster pela primeira vez no nó atualizado, ele solicitará a você Abrir conexão com cluster. No campo Nome do cluster ou servidor, digite um ponto (.). Dessa forma, você se conectará com o cluster no nó atualizado local. Apesar de poder se conectar ao cluster digitando o nome dele, se você fizer isso se conectará ao cluster no nó do Windows 2000 e precisará responder a várias mensagens de aviso.
  10. Repita estas etapas para o nó restante.

Importante

  • Para obter mais informações sobre os recursos para os quais há suporte durante as atualizações sem interrupção, consulte Tópicos relacionados.

Observação

  • Depois de atualizar um nó de cluster do Windows 2000, você deve fazer logon em uma conta que seja membro do grupo Admins. do Domínio ou Administradores em cada nó de cluster antes de reiniciar o serviço Cluster. Esta etapa é necessária mesmo que o grupo Admins. do Domínio já seja um membro do grupo Administradores de cada nó do cluster.
  • Para executar este procedimento, você deve ser membro do grupo Administradores no computador local ou deve ter recebido a autoridade adequada. Se o computador tiver ingressado em um domínio, os participantes do grupo Admins. do domínio poderão executar esse procedimento. Como uma prática recomendada de segurança, é aconselhável usar Executar como para executar este procedimento.

Tópicos relacionados


Executar uma atualização sem interrupção do último nó do Windows 2000

Elemento gráfico do Microsoft Windows

Para executar uma atualização sem interrupção do último nó do Windows 2000

  1. Confirme se os sistemas estão executando o Windows 2000.
  2. Confirme se o seu hardware foi projetado para Windows Server 2003, Enterprise Edition ou é compatível com ele. Para obter mais informações, consulte "Lista de verificação: preparação para atualizar um cluster" em Tópicos relacionados.
  3. Usando as informações em "Comportamento do recurso durante atualizações sem interrupção" em Tópicos Relacionados, identifique os recursos no cluster para os quais o Windows Server 2003, Enterprise Edition não fornece suporte e remova-os.
  4. Novamente, usando as informações em "Comportamento do recurso durante atualizações sem interrupção" em Tópicos relacionados, identifique os recursos no cluster para os quais as atualizações sem interrupção não fornecem suporte nem são abordados por outros procedimentos de atualização de tecnologia específica listados em Tópicos relacionados.
  5. Mova todos os recursos identificados na etapa anterior para um único nó clicando duas vezes na pasta Grupos na árvore de console do Administrador de cluster. Clique no grupo que contém o recurso e, em seguida, no menu Arquivo, clique em Mover grupo.
  6. Atualize o sistema operacional em cada um dos nós que não está hospedando os recursos movidos na etapa anterior. Depois de atualizar cada nó, feche Gerenciar o servidor se ele for exibido.
  7. Mova todos os recursos movidos nas etapas anteriores do nó que não foi atualizado para um dos nós recém-atualizados.
  8. Depois que todos os recursos tiverem sido movidos, atualize o nó final. Depois da atualização, feche a caixa de diálogo Gerenciar o servidor se ela for exibida.

Observações

  • Depois de atualizar um nó de cluster do Windows 2000, você deve fazer logon em uma conta que seja membro do grupo Admins. do Domínio ou Administradores em cada nó de cluster antes de reiniciar o serviço Cluster. Esta etapa é necessária mesmo que o grupo Admins. do Domínio já seja um membro do grupo Administradores de cada nó do cluster.
  • Para executar este procedimento, você deve ser membro do grupo Administradores no computador local ou deve ter recebido a autoridade adequada. Se o computador tiver ingressado em um domínio, os participantes do grupo Admins. do domínio poderão executar esse procedimento. Como uma prática recomendada de segurança, é aconselhável usar Executar como para executar este procedimento.
  • Não é obrigatório mover todos os recursos para um único nó e atualizar esse nó por último. No entanto, se seguir o procedimento conforme descrito, você provavelmente terá a maior disponibilidade dos recursos que não oferecem suporte a atualizações sem interrupção.

Tópicos relacionados


Atualizar do Windows 2000 em um cluster contendo IIS usando o script fornecido

Elemento gráfico do Microsoft Windows

Para atualizar do Windows 2000 em um cluster contendo IIS usando o script fornecido

  1. Confirme se o seu hardware foi projetado para Windows Server 2003, Enterprise Edition ou é compatível com ele.
  2. Atualize todos os nós, exceto o que contém o recurso da instância IIS, do Windows 2000 para Windows Server 2003, Enterprise Edition. Você pode realizar um atualização ininterrupta ou não, o que for apropriado para sua instalação. Antes de atualizar, remova os recursos para os quais não há suporte no Windows Server 2003, Enterprise Edition. Para obter mais informações, consulte Tópicos relacionados.
  3. Se você não tiver o recurso de coordenador de transações distribuídas (DTC) no cluster que estiver atualizando, crie um recurso DTC para esse cluster em um nó atualizado.
  4. Em um nó atualizado, abra o Prompt de comando e navegue até a pasta %systemroot%\system32\inetsrv.
  5. Digite:

    iis_switch nome do cluster [nome do grupo]

    Valor | Descrição
    nome do cluster | O nome de um nó físico no cluster que tenha sido atualizado ou o nome de um servidor virtual.
    nome do grupo | É opcional. Por padrão, o script atualizará todos os recursos de Web e FTP do ISS no cluster. No entanto, se, em vez disso, você desejar atualizar somente um determinado grupo, especifique o nome desse grupo de recursos.

    Importante

  • O grupo de recursos que inclui o recurso IIS precisa estar no nó do Windows 2000 quando você executa o script.
  • O script inclui uma etapa que colocará o grupo de recursos com o recurso de script genérico recém-criado online. No entanto, o script somente colocará o grupo online se todos os recursos no grupo estiverem online antes de o script ser executado. Se o grupo foi colocado online apenas parcialmente ou se estava offline antes da execução do script, o script colocará todo o grupo offline e não colocará nenhum recurso online novamente após a atualização.
  • Depois que o script for concluído, o recurso recém-criado poderá falhar imediatamente. Isso ocorre porque o serviço W3SVC está desabilitado. Você pode corrigir este problema concluindo a seguinte etapa.
  1. Depois que o script for concluído, coloque o recurso de script genérico recém-criado offline, inicie o serviço W3SVC neste nó e defina W3SVC para ser iniciado automaticamente.
  2. Coloque o recurso de script genérico online.
  3. Usando o IIS, inicie o site no nó atualizado.
  4. Atualize o nó final para Windows Server 2003, Enterprise Edition. Depois que a atualização for concluída, inicie o serviço W3SVC neste nó e defina o serviço como iniciar automaticamente.
  5. Se apropriado, adicione o nó de atualização final à lista Possíveis proprietários do recurso de script genérico recém-criado. Para obter mais informações, consulte "Especificar os nós que podem possuir um recurso" em Tópicos relacionados.

Observações

  • Depois de atualizar um nó de cluster do Windows 2000, você deve fazer logon em uma conta que seja membro do grupo Admins. do Domínio ou Administradores em cada nó de cluster antes de reiniciar o serviço Cluster. Esta etapa é necessária mesmo que o grupo Admins. do Domínio já seja um membro do grupo Administradores de cada nó do cluster.
  • Para executar este procedimento, você deve ser membro do grupo Administradores no computador local ou deve ter recebido a autoridade adequada. Se o computador tiver ingressado em um domínio, os participantes do grupo Admins. do domínio poderão executar esse procedimento. Como uma prática recomendada de segurança, é aconselhável usar Executar como para executar este procedimento.
  • XOX
  • Para ISS de cluster no Windows Server 2003, Enterprise Edition, você precisará também de um recurso DTC nesse cluster.
  • O script não atualizará os recursos do IIS que estão no grupo de clusters. Se tiver recursos do IIS no grupo de clusters, você poderá usar o procedimento "Atualizar do Windows 2000 sem usar o script fornecido em um cluster que inclui um recurso do IIS" em Tópicos relacionados.
  • Somente os nós atualizados podem ser proprietários do recurso de script genérico criado neste procedimento, pois esse tipo de recurso não recebe suporte no Windows 2000.
  • Se preferir não usar o script fornecido e executar cada etapa manualmente, consulte "Atualizar do Windows 2000 em um cluster que contém o IIS sem usar o script fornecido", em Tópicos relacionados.
  • Para obter mais informações sobre compatibilidade de hardware, consulte Recursos de suporte.

Tópicos relacionados


Atualizar do Windows 2000 em um cluster contendo IIS sem usar o script fornecido

Elemento gráfico do Microsoft Windows

Para atualizar do Windows 2000 em um cluster contendo IIS sem usar o script fornecido

  1. Confirme se o seu hardware foi projetado para Windows Server 2003, Enterprise Edition ou é compatível com ele.
  2. Atualize todos os nós, exceto o que contém o recurso da instância IIS, do Windows 2000 para Windows Server 2003, Enterprise Edition. Você pode realizar um atualização ininterrupta ou não, o que for apropriado para sua instalação. Antes de atualizar, remova os recursos para os quais não há suporte no Windows Server 2003, Enterprise Edition. Para obter mais informações, consulte Tópicos relacionados.
  3. Se você não tiver o recurso de coordenador de transações distribuídas (DTC) no cluster que estiver atualizando, crie um recurso DTC para esse cluster em um nó atualizado.
  4. No nó Windows 2000, observe as dependências do recurso da instância IIS. Observe os recursos que dependem do recurso IIS e também observe de quais recursos o próprio IIS depende.
  5. Coloque offline o grupo que contém o recurso da instância IIS. Para obter mais informações sobre como fazer isso, consulte "Colocar um recurso offline" em Tópicos relacionados.
  6. Remova as dependências do recurso da instância IIS.
  7. Exclua o recurso da instância IIS.
  8. Mova o grupo para um nó do Windows Server 2003, Enterprise Edition e crie um recurso de script genérico seguindo o procedimento documentado em "Lista de verificação: criando um serviço FTP ou Web de IIS de cluster" em Tópicos relacionados.

    Observações

    • Como parte desse procedimento, recrie as dependências do recurso de script genérico idênticas às do recurso IIS agora excluído. Redefina tudo o que estava dependente do recurso IIS como dependente do recurso de script genérico. Faça também com que o recurso de script genérico fique dependente de tudo que o IIS era dependente.
    • Somente os nós atualizados podem ser proprietários do recurso de script genérico criado neste procedimento, pois esse tipo de recurso não recebe suporte no Windows 2000.
  9. Inicie o serviço W3SVC neste nó e defina o serviço para ser iniciado automaticamente.
  10. Coloque online o grupo que contém o novo recurso de script genérico.
  11. Usando o IIS, inicie o site no nó atualizado.
  12. Atualize o nó final para Windows Server 2003, Enterprise Edition. Uma vez terminada a atualização, inicie o W3SVC nesse nó e defina o serviço para ser iniciado automaticamente.

Observações

  • Depois de atualizar um nó de cluster do Windows 2000, você deve fazer logon em uma conta que seja membro do grupo Admins. do Domínio ou Administradores em cada nó de cluster antes de reiniciar o serviço Cluster. Esta etapa é necessária mesmo que o grupo Admins. do Domínio já seja um membro do grupo Administradores de cada nó do cluster.
  • Para executar este procedimento, você deve ser membro do grupo Administradores no computador local ou deve ter recebido a autoridade adequada. Se o computador tiver ingressado em um domínio, os participantes do grupo Admins. do domínio poderão executar esse procedimento. Como uma prática recomendada de segurança, é aconselhável usar Executar como para executar este procedimento.
  • Para ISS de cluster no Windows Server 2003, Enterprise Edition, você precisará também de um recurso DTC nesse cluster.
  • Somente os nós atualizados podem ser proprietários do recurso de script genérico criado neste procedimento, pois esse tipo de recurso não recebe suporte no Windows 2000.
  • Várias dessas etapas podem ser automatizadas com o uso de um script fornecido com o Windows Server 2003, Enterprise Edition. Para obter mais informações, consulte "Atualizar do Windows 2000 em um cluster contendo IIS usando o script fornecido" em Tópicos relacionados.
  • Para obter mais informações sobre compatibilidade de hardware, consulte Recursos de suporte.

Tópicos relacionados


Atualizar do Windows 2000 em um cluster que contém o Enfileiramento de mensagens

Elemento gráfico do Microsoft Windows

Atualizar do Windows 2000 em um cluster que contém o Enfileiramento de mensagens

  1. Confirme se o seu hardware foi projetado para Windows Server 2003, Enterprise Edition ou é compatível com ele.
  2. Coloque todos os recursos do cluster de Enfileiramento de mensagens offline. Para obter mais informações sobre como fazer isso, consulte "Colocar um recurso offline" em Tópicos relacionados.
  3. Em cada recurso de Enfileiramento de mensagens, coloque o recurso de nome de rede que depende dele offline também.
  4. Atualize todos os nós do Windows 2000 para Windows Server 2003, Enterprise Edition. Você pode realizar um atualização ininterrupta ou não, o que for apropriado para sua instalação. Antes de atualizar, remova os recursos para os quais não há suporte no Windows Server 2003, Enterprise Edition. Para obter mais informações, consulte Tópicos relacionados. Gerenciar o servidor será exibido quando você fizer logon inicialmente no nó recém-atualizado como Administrador. Feche Gerenciar o servidor para continuar a atualização.
  5. Coloque os recursos de nome de rede online novamente. Verifique se o recurso de coordenador de transações distribuídas (DTC) está online e coloque os recursos de Enfileiramento de mensagens online.

Observação

  • Depois de atualizar um nó de cluster do Windows 2000, você deve fazer logon em uma conta que seja membro do grupo Admins. do Domínio ou Administradores em cada nó de cluster antes de reiniciar o serviço Cluster. Esta etapa é necessária mesmo que o grupo Admins. do Domínio já seja um membro do grupo Administradores de cada nó do cluster.
  • Para executar este procedimento, você deve ser membro do grupo Administradores no computador local ou deve ter recebido a autoridade adequada. Se o computador tiver ingressado em um domínio, os participantes do grupo Admins. do domínio poderão executar esse procedimento. Como uma prática recomendada de segurança, é aconselhável usar Executar como para executar este procedimento.

Tópicos relacionados


Atualizar um cluster do Windows NT 4.0

Não é possível executar uma atualização sem interrupção diretamente do Windows NT Server 4.0, Enterprise Edition para o Windows Server 2003, Enterprise Edition. Como alternativa, há duas opções disponíveis:

  • É possível manter a disponibilidade do cluster executando uma atualização para Windows 2000 primeiro e, em seguida, para Windows Server 2003, Enterprise Edition.
  • Você pode executar uma atualização sem interrupção diretamente do Windows NT Server 4.0, Enterprise Edition para o Windows Server 2003, Enterprise Edition, o que não permitirá manter a disponibilidade do cluster.

Para atualizar usando Windows 2000, execute uma atualização do Windows NT Server 4.0 para Windows 2000, conforme as instruções na documentação do Windows 2000. Em seguida, siga os procedimentos para atualização do Windows Server 2003, Enterprise Edition documentados em Atualizar um cluster do Windows 2000. Caso tenha um recurso IIS no cluster Windows NT Server 4.0, depois de concluir as duas atualizações, é necessário excluir o tipo de recurso IIS não suportado, abrindo o prompt de comando e digitando o comando a seguir: Cluster restype "IIS Virtual Root" /delete /type.

Para atualizar sem usar o produto Windows 2000, é necessário interromper a disponibilidade do cluster. As etapas executadas dependem dos recursos incluídos no cluster. Para muitas instalações, o procedimento a seguir é apropriado:

  • Atualizar um cluster do Windows NT

Porém, se o cluster contém um recurso IIS, é necessário usar o procedimento a seguir:

  • Atualizar do Windows NT em um cluster que contém o IIS

Se o cluster contiver um recurso MSMQ ou DTC, você deverá realizar o procedimento documentado no artigo 315993 na Microsoft Knowledge Base. (http://www.microsoft.com/)


Atualizar um cluster do Windows NT

Elemento gráfico do Microsoft Windows

Para atualizar um cluster do Windows NT

  1. Confirme se o seu hardware foi projetado para Windows Server 2003, Enterprise Edition ou é compatível com ele. Para obter mais informações, consulte "Lista de verificação: preparação para atualizar um cluster" em Tópicos relacionados.
  2. Confirme se não tem um recurso IIS, MSMQ ou DTC no cluster. Para obter mais informações, consulte Observações e Tópicos relacionados.
  3. Verifique se o Service Pack 5 ou posterior foi aplicado a todos os computadores que serão atualizados do Windows NT Server 4.0 para o Windows Server 2003, Enterprise Edition.
  4. Conforme apropriado, notifique os usuários que você estará encerrando os aplicativos que eles usam no cluster.
  5. Encerre os aplicativos que estão disponíveis por meio do cluster.
  6. Remova todos os recursos para os quais o Windows Server 2003, Enterprise Edition não fornece suporte, incluindo a Instância de serviço NNTP, a Instância de serviço SMTP e recursos do Serviço de tempo.
  7. Encerre e desligue todos os nós com exceção de um, ou coloque-os em um estado desligado adequado ao seu método de término.

    Cuidado

    • Se estiver usando um dispositivo de armazenamento compartilhado, quando você atualiza e liga o sistema operacional, é importante que somente um nó tenha acesso ao disco do cluster. Do contrário, os discos de cluster poderão ser corrompidos. Para evitar que os discos de cluster sejam danificados, encerre os nós de clusters deixando apenas um ativo ou use outras técnicas (por exemplo, mascaramento de nº da unidade lógica, apresentação seletiva ou zonas) para proteger os discos de cluster, antes de criar o cluster. Depois que o serviço de cluster estiver funcionando com êxito em um nó, os outros nós podem ser instalados e configurados simultaneamente.
  8. Atualize o sistema operacional no nó que está funcionando. Para obter informações sobre como executar a instalação, consulte "Iniciar a instalação" em Tópicos relacionados.

    O software do cluster será atualizado automaticamente durante a atualização do sistema operacional. Observe que você não pode fazer alterações na configuração como configurar discos de cluster como discos dinâmicos. Para obter mais informações, consulte "Limitações de clusters de servidor" em Tópicos relacionados.

    Gerenciar o servidor será exibido quando você fizer logon inicialmente no nó recém-atualizado como Administrador. Feche Gerenciar o servidor para continuar a atualização.

  9. No nó atualizado, clique em Iniciar, aponte para Programas, clique em Ferramentas administrativas e clique em Administrador de cluster.
  10. Verifique se os discos de cluster estão online em Administrador de cluster.

    Cuidado

    • Verifique se os discos de cluster estão online em Administrador de cluster antes de passar para a próxima etapa. Quando os discos estiverem online, o serviço de cluster estará funcionando, o que significa que somente um nó poderá acessar o armazenamento de cluster em qualquer momento. Caso contrário, o armazenamento do cluster pode ser corrompido.
  11. Encerre e desligue o nó atualizado, ou o coloque em um estado desligado adequado ao seu método de término.
  12. Ligue o outro nó no cluster e atualize o sistema operacional desse nó.
  13. Depois que o segundo nó for atualizado, habilite o primeiro nó.
  14. Se desejar adicionar nós ao cluster, atualize-os depois que os dois primeiros nós forem atualizados.

Importante

  • Confirme se toda a sua solução de clusters é compatível com produtos da família Windows Server 2003, clicando no link apropriado em Recursos de suporte.

Observações

  • Para executar este procedimento, você deve ser membro do grupo Administradores no computador local ou deve ter recebido a autoridade adequada. Se o computador tiver ingressado em um domínio, os participantes do grupo Admins. do domínio poderão executar esse procedimento. Como uma prática recomendada de segurança, é aconselhável usar Executar como para executar este procedimento.
  • Se o cluster do Windows NT Server 4.0 inclui um recurso DTC ou MSMQ, é necessário executar etapas adicionais ao atualizar diretamente do Windows NT Server 4.0 para o Windows Server 2003, Enterprise Edition. Para obter mais informações, consulte o artigo 315993 na Microsoft Knowledge Base. (http://www.microsoft.com/)
  • Se o objetivo é ter mais de dois nós no cluster, é necessário usar Fibre Channel (e não SCSI) para armazenamento do cluster. Antes de adicionar os nós adicionais, verifique se toda sua solução de cluster é compatível com os produtos da família Windows Server 2003.
  • Quando estiver atualizando do Windows NT 4.0 para o Windows Server 2003, Enterprise Edition, a conta de usuário do serviço de cluster requer o direito de usuário adicional "Funcionar como parte do sistema operacional". Se possível, a instalação concederá esse direito de usuário automaticamente. Se a instalação não puder conceder o direito de usuário, você precisará fazer essa alteração.

    Por motivos de segurança, é necessário conceder este direito de usuário para a conta de usuário específica que é usada pelo serviço de cluster. Você não pode corrigir esse problema concedendo o direito de usuário a um grupo de segurança do qual a conta de usuário é membro. Normalmente, você deve conceder esse direito de usuário como um direito de usuário local; ele não pode ser um direito de usuário no nível de domínio. No entanto, se o nó for um controlador de domínio, você pode usar o direito de usuário do nível de domínio.

    Para obter mais informações sobre como configurar direitos de usuário, consulte "Editar uma configuração de segurança" na documentação da ajuda do Windows 2000 ou, no Windows NT Server 4.0, abra o Gerenciador de usuários para domínios, clique no menu Ajuda no Gerenciador de usuários e consulte "Gerenciando a diretiva de direitos do usuário".

  • Antes de iniciar a atualização do Windows NT Server 4.0 diretamente para Windows Server 2003, Enterprise Edition, aplique o Service Pack 5 ou posterior.

Tópicos relacionados


Atualizar do Windows NT em um cluster que contém o IIS

Elemento gráfico do Microsoft Windows

Para atualizar do Windows NT em um cluster que contém o IIS

  1. Confirme se o seu hardware foi projetado para Windows Server 2003, Enterprise Edition ou é compatível com ele.
  2. Conforme apropriado, notifique os usuários que você estará encerrando os aplicativos que eles usam no cluster.
  3. Verifique se o Service Pack 5 ou posterior foi aplicado a todos os computadores que serão atualizados do Windows NT Server 4.0 para o Windows Server 2003, Enterprise Edition.
  4. Encerre os aplicativos que estão disponíveis por meio do cluster.
  5. Remova todos os recursos para os quais o Windows Server 2003, Enterprise Edition não fornece suporte, incluindo a Instância de serviço NNTP, a Instância de serviço SMTP e recursos do Serviço de tempo.
  6. Defina o Serviço de cluster para que ele seja iniciado apenas manualmente.
  7. Encerre e desligue o nó que não contém o recurso de IIS, ou o coloque em um estado desligado adequado ao seu método de término.

    Cuidado

    • Se estiver usando um dispositivo de armazenamento compartilhado, quando você atualiza e liga o sistema operacional, é importante que somente um nó tenha acesso ao disco do cluster. Do contrário, os discos de cluster poderão ser corrompidos. Para evitar que os discos de cluster sejam danificados, encerre os nós de clusters deixando apenas um ativo ou use outras técnicas (por exemplo, mascaramento de nº da unidade lógica, apresentação seletiva ou zonas) para proteger os discos de cluster, antes de criar o cluster. Depois que o serviço de cluster estiver funcionando com êxito em um nó, os outros nós podem ser instalados e configurados simultaneamente.
  8. No nó em funcionamento, observe as dependências do recurso da instância IIS. Observe os recursos que dependem do recurso IIS e também observe de quais recursos o próprio IIS depende.
  9. Coloque offline o grupo que contém o recurso da instância IIS. Para obter mais informações sobre como fazer isso, consulte "Colocar um recurso offline" em Tópicos relacionados.
  10. Remova as dependências do recurso da instância IIS.
  11. Exclua o recurso da instância IIS e feche o Administrador de cluster, se estiver aberto. Para obter mais informações, consulte "Excluir um recurso" em Tópicos relacionados.
  12. Exclua o tipo de recurso não suportado: Abra o prompt de comando. Digite o seguinte comando e pressione ENTER:

    Cluster restype "IIS Virtual Root" /delete /type

  13. Pare o Serviço de cluster no nó restante.
  14. Atualize o sistema operacional no nó que está funcionando. Para obter informações sobre como executar a instalação, consulte "Iniciar a instalação" em Tópicos relacionados.

    O software do cluster será atualizado automaticamente durante a atualização do sistema operacional. Observe que você não pode fazer alterações na configuração como configurar discos de cluster como discos dinâmicos. Para obter mais informações, consulte "Limitações de clusters de servidor" em Tópicos relacionados. Depois de atualizar, feche Gerenciar o servidor se ele for exibido.

  15. Inicie o serviço de cluster no nó atualizado.
  16. Reconfigure o serviço de cluster no nó atualizado para início automático.
  17. Encerre e desligue o nó atualizado, ou o coloque em um estado desligado adequado ao seu método de término.
  18. Ligue o outro nó no cluster e atualize o sistema operacional desse nó. Depois de atualizar, feche Gerenciar o servidor se ele for exibido.

    Cuidado

    • Se estiver usando um dispositivo de armazenamento compartilhado, quando você atualiza e liga o sistema operacional, é importante que somente um nó tenha acesso ao disco do cluster. Do contrário, os discos de cluster poderão ser corrompidos. Para evitar que os discos de cluster sejam danificados, encerre os nós de clusters deixando apenas um ativo ou use outras técnicas (por exemplo, mascaramento de nº da unidade lógica, apresentação seletiva ou zonas) para proteger os discos de cluster, antes de criar o cluster. Depois que o serviço de cluster estiver funcionando com êxito em um nó, os outros nós podem ser instalados e configurados simultaneamente.
  19. Depois que o segundo nó for atualizado, inicie o serviço de cluster no segundo nó atualizado. O nó reingressa novamente no cluster existente.
  20. Reconfigure o serviço de cluster no segundo nó atualizado para início automático.
  21. Ligue o primeiro nó.
  22. Em um dos nós atualizados, clique em Iniciar, aponte para Programas, clique em Ferramentas administrativas e clique em Administrador de cluster.
  23. Verifique se os discos de cluster estão online em Administrador de cluster.

    Cuidado

    • Verifique se os discos de cluster estão online em Administrador de cluster antes de passar para a próxima etapa. Quando os discos estiverem online, o serviço de cluster estará funcionando, o que significa que somente um nó poderá acessar o armazenamento de cluster em qualquer momento. Caso contrário, o armazenamento do cluster pode ser corrompido.
  24. Se você não tiver o recurso de coordenador de transações distribuídas (DTC) no cluster que estiver atualizando, crie um recurso DTC neste cluster.
  25. No nó usado para conter o recurso IIS, crie um recurso de script genérico seguindo o procedimento documentado em "Lista de verificação: criando um serviço FTP ou Web de IIS de cluster" em Tópicos relacionados.

    Observações

    • Como parte desse procedimento, recrie as dependências do recurso de script genérico idênticas as do recurso IIS agora excluído. Redefina tudo o que estava dependente do recurso IIS como dependente do recurso de script genérico. Faça também com que o recurso de script genérico fique dependente de tudo que o IIS era dependente.
    • Somente os nós do Windows Server 2003, Enterprise Edition podem ser proprietários do recurso de script genérico criado neste procedimento, pois esse tipo de recurso não recebe suporte no Windows NT Server 4.0.
  26. Inicie o serviço W3SVC em todos os nós e defina o serviço para ser iniciado automaticamente.
  27. Coloque online o grupo que contém o novo recurso de script genérico.
  28. Usando o IIS, inicie o site.
  29. Se desejar adicionar nós ao cluster, atualize-os depois que os dois primeiros nós forem atualizados.

Importante

  • Se o cluster usa SCSI, você pode ter dois nós no cluster, mas não mais. Se o seu objetivo é ter mais de dois nós no cluster, é necessário usar Fibre Channel para armazenamento do cluster. Confirme também se toda a sua solução de clusters é compatível com produtos da família Windows Server 2003, clicando no link apropriado em Recursos de suporte. A solução de cluster deve estar na categoria Cluster do hardware compatível.

Observações

  • Para executar este procedimento, você deve ser membro do grupo Administradores no computador local ou deve ter recebido a autoridade adequada. Se o computador tiver ingressado em um domínio, os participantes do grupo Admins. do domínio poderão executar esse procedimento. Como uma prática recomendada de segurança, é aconselhável usar Executar como para executar este procedimento.
  • Para ISS de cluster no Windows Server 2003, Enterprise Edition, você precisará também de um recurso DTC nesse cluster.
  • Este procedimento aplica-se apenas quando você faz upgrade diretamente do Windows NT Server 4.0 para Windows Server 2003, Enterprise Edition. Se você fizer upgrade do Windows NT Server 4.0 para Windows 2000 e depois para Windows Server 2003, Enterprise Edition, siga as etapas descritas nos tópicos apropriados listados em Tópicos relacionados.
  • Quando estiver atualizando do Windows NT 4.0 para o Windows Server 2003, Enterprise Edition, a conta de usuário do serviço de cluster requer o direito de usuário adicional "Funcionar como parte do sistema operacional". Se possível, a instalação concederá esse direito de usuário automaticamente. Se a instalação não puder conceder o direito de usuário, você precisará fazer essa alteração.

    Por motivos de segurança, é necessário conceder este direito de usuário para a conta de usuário específica que é usada pelo serviço de cluster. Você não pode corrigir esse problema concedendo o direito de usuário a um grupo de segurança do qual a conta de usuário é membro. Normalmente, você deve conceder esse direito de usuário como um direito de usuário local; ele não pode ser um direito de usuário no nível de domínio. No entanto, se o nó for um controlador de domínio, você pode usar o direito de usuário do nível de domínio.

    Para obter mais informações sobre como configurar direitos de usuário, consulte "Editar uma configuração de segurança" na documentação da ajuda do Windows 2000 ou, no Windows NT Server 4.0, abra o Gerenciador de usuários para domínios, clique no menu Ajuda no Gerenciador de usuários e consulte "Gerenciando a diretiva de direitos do usuário".

  • Antes de iniciar a atualização do Windows NT Server 4.0 diretamente para Windows Server 2003, Enterprise Edition, aplique o Service Pack 5 ou posterior.
  • Para obter mais informações sobre compatibilidade de hardware, consulte Windows Update no site da Microsoft (http://www.microsoft.com).

Tópicos relacionados


Conceitos

  • Instalando o Windows Server 2003, Enterprise Edition em nós de cluster
  • Atualizando para Windows Server 2003, Enterprise Edition em nós de cluster
  • Recursos


Instalando o Windows Server 2003, Enterprise Edition em nós de cluster

Esta seção aborda:

  • Planejando e preparando a instalação do cluster
  • Opções do recurso de quorum ao instalar clusters de servidor


Planejando e preparando a instalação do cluster

Antes de executar a instalação do cluster, você precisa planejar os detalhes do hardware e da rede.

Cuidado

  • Se estiver usando um dispositivo de armazenamento compartilhado, antes de criar um cluster, quando ligar o computador e iniciar o sistema operacional, é muito importante que somente um nó tenha acesso ao disco de cluster. Caso contrário, os discos de cluster podem ser corrompidos. Para evitar que os discos de cluster sejam danificados, encerre os nós de clusters deixando apenas um ativo ou use outras técnicas (por exemplo, mascaramento de nº da unidade lógica, apresentação seletiva ou zonas) para proteger os discos de cluster, antes de criar o cluster. Depois que o serviço de cluster estiver funcionando com êxito em um nó, os outros nós podem ser instalados e configurados simultaneamente. Todos os nós do cluster devem estar executando o Windows Server 2003, Enterprise Edition.

No planejamento, examine os seguintes itens:

Hardware e drivers de cluster

A Microsoft só oferece suporte a sistemas completos de clusters de servidores que sejam compatíveis com a família de produtos Windows Server 2003. Confirme se toda a sua solução de clusters é compatível com produtos da família Windows Server 2003, clicando no link apropriado em Recursos de suporte.

Em discos de cluster, você deve usar o sistema de arquivos NTFS e configurar os discos como discos básicos. Você não pode configurar discos de cluster como discos dinâmicos e não pode usar os recursos de discos dinâmicos como volumes estendidos (conjuntos de volume).

Revise com atenção as instruções do fabricante antes de começar a instalar os hardwares de cluster. Caso contrário, o armazenamento do cluster pode ser corrompido. Se o seu hardware de cluster inclui um barramento SCSI, revise cuidadosamente as instruções sobre terminação do barramento SCSI e configuração de IDs SCSI.

Para simplificar a configuração e eliminar problemas de compatibilidade em potencial, considere usar um hardware idêntico em todos os nós.

Adaptadores de rede em nós de cluster

No planejamento, decida o tipo de comunicação que cada adaptador de rede executará. A lista a seguir fornece detalhes sobre os tipos de comunicação que o adaptador pode executar:

  • Somente comunicação nó a nó (rede privada). Isso implica que o servidor tem apenas um ou mais adaptadores para executar outras comunicações.

    Na conexão nó a nó, você conecta o adaptador de rede a uma rede privada que é usada exclusivamente no cluster. Observe que se a rede privada usa um único hub ou comutador de rede, esse equipamento se torna um ponto potencial de falha no cluster.

    Os nós de um cluster devem estar na mesma sub-rede, mas você pode usar comutadores de rede locais virtuais (VLAN) nas interconexões entre dois nós. Se você usar uma VLAN, a latência completa ponto a ponto deve ser menor que 1/2 segundo e a conexão entre dois nós deve ser uma única conexão ponto a ponto da perspectiva do sistema operacional Windows que está executando os nós. Para evitar pontos de falha simples, use o hardware de VLAN independente nos diferentes caminhos entre os nós.

    Se os nós usarem várias rede privadas (nó a nó), os adaptadores dessas redes devem usar endereços IP estáticos em vez do DHCP.

  • Somente comunicação cliente a cluster (rede pública). Isso implica que o servidor tem apenas um ou mais adaptadores para executar outras comunicações.
  • Comunicação nó a nó e cliente a cluster (rede mista). Quando você tem vários adaptadores de rede por nó, um adaptador de rede que executa os dois tipos de comunicação pode funcionar como backup dos outros adaptadores de rede.
  • Comunicação não relacionada ao cluster. Se um nó do cluster também fornece serviços não relacionados ao cluster, e houver adaptadores suficientes no nó de cluster, você pode desejar usar um adaptador para executar a comunicação não relacionada ao cluster.

Os nós do cluster devem estar conectados por duas ou mais redes locais (LANs); são necessárias pelo menos duas redes para impedir um ponto de falha único. Um cluster de servidor cujos nós são conectados por apenas uma rede não é uma configuração suportada. Os adaptadores, cabos, hubs e switches para cada rede devem falhar de forma independente. Isso geralmente implica que os componentes de quaisquer duas redes devem ser fisicamente independentes.

Pelo menos duas redes devem ser configuradas para tratar Todas as comunicações (rede mista) ou Somente comunicações internas (rede privada).

A configuração recomendada para os dois adaptadores é usar um adaptador para a comunicação particular (somente nó a nó) e outro para a comunicação mista (comunicação nó a nó mais cliente a cluster).

Considere escolher um nome para cada conexão que indique para que ela serve. O nome facilita a identificação da conexão sempre que estiver configurando o servidor.

Observações

  • Se forem usados adaptadores de rede tolerantes a falhas, crie várias redes privadas em vez de uma única rede tolerante a falhas.
  • Não use adaptadores de rede de equipe na rede privada.
  • Não configure um gateway padrão ou um servidor DNS ou WINS nos adaptadores de rede privada. Não configure adaptadores de rede privada para que usem servidores de resolução de nomes na rede pública; caso contrário, um servidor de resolução de nomes na rede pública pode mapear um nome para um endereço IP na rede privada. Se um cliente recebeu o endereço IP de um servidor de resolução de nomes, ele poderá falhar ao tentar alcançar o endereço, pois não há nenhuma rota do cliente ao endereço da rede privada.
  • Configure servidores WINS e/ou DNS nos adaptadores de rede pública. Se os recurso de nome de rede forem usados em redes públicas, configure os servidores DNS de forma que ofereçam suporte a atualizações dinâmicas; caso contrário, os recursos de nome de rede podem não falhar corretamente. Além disso, configure um gateway padrão nos adaptadores de rede pública. Se houver várias redes públicas no cluster, configure um gateway padrão em somente uma delas.
  • Os adaptadores de um nó específico devem se conectar às redes em diferentes sub-redes.
  • Quando você usa o Assistente para criar novo cluster de servidor ou o Assistente para adicionar nós para instalar o cluster em um nó que contém dois adaptadores de rede, por padrão o assistente configura os dois adaptadores de rede em comunicações de rede mista. Como prática recomendada, reconfigure um adaptador para comunicações de rede privada somente. Para obter mais informações, consulte Alterar a forma como o cluster usa uma rede.
  • Configure manualmente as configurações de comunicação, como Velocidade, Modo Duplex, Controle de Fluxo e Tipo de Mídia de cada adaptador de rede de cluster. Não use a detecção automática. Você deve configurar todos os adaptadores de rede do cluster para que usem as mesmas configurações de comunicação.
  • Confirme se toda a sua solução de clusters é compatível com os produtos da família Windows Server 2003, clicando no link apropriado em Recursos de suporte.

Endereço IP do cluster

Obter um endereço IP estático do próprio cluster. Você não pode usar o DHCP neste endereço.

Endereçamento IP para nós de cluster

Determinar como tratar do endereçamento IP em nós de cluster individuais. Cada adaptador de rede em cada nó requer o endereçamento IP. É recomendável atribuir a cada adaptador de rede um endereço IP estático. Como alternativa, você pode fornecer o endereçamento IP por meio de DHCP. Se você usar endereços IP estáticos, defina os endereços de cada par de adaptadores de rede vinculado (nó a nó) para que façam parte da mesma sub-rede.

Observe que se você usar o DHCP em nós de cluster individuais, ele pode funcionar como um único ponto de falha. Ou seja, se configurar os nós de cluster de forma que eles dependam de um servidor DHCP para seus endereços IP, a falha temporária do servidor DHCP pode significar uma não disponibilidade dos nós de cluster. Quando decidir se deve usar o DHCP, avalie as maneiras de garantir a disponibilidade de serviços DHCP e considere a possibilidade de usar concessões longas para os nós de cluster. Isso ajuda a garantir que eles sempre terão um endereço IP válido.

Nome do cluster

Determine ou obtenha um nome apropriado para o cluster. Esse será o nome que os administradores usarão para conexões com o cluster. (Os aplicativos reais que estão funcionando no cluster normalmente têm nomes de rede diferentes.) O nome do cluster deve ser diferente do nome de domínio, de todos os nomes de computador no domínio e dos nomes de cluster no domínio.

Contas de computador e atribuição de domínios para nós de cluster

Verifique se os nós de cluster têm contas de computador no mesmo domínio. Os nós de cluster não podem estar em um grupo de trabalho.

Conta de usuário Operador para instalar e configurar o serviço de cluster

Para instalar e configurar o serviço de cluster, você deve estar usando uma conta no grupo Administradores local em cada nó. À medida que instala e configura cada nó, se não estiver usando uma conta no grupo local Administradores, você precisará fornecer as credenciais de logon da conta.

Conta de usuário do serviço de cluster

Criar ou obter a conta de usuário do serviço de cluster. Representam o nome e a senha nos quais o serviço de cluster será executado. Você precisa fornecer esse nome de usuário e essa senha durante a instalação do cluster.

É recomendável que a conta de usuário do serviço de cluster não seja usada para nenhuma outra finalidade. Se tiver vários clusters, configure uma conta de usuário de serviço de cluster exclusiva para cada cluster. A conta deve ser uma conta de domínio; ela não pode ser uma conta local. No entanto, não torne esta conta uma conta de administrador do domínio, pois ela não precisa ter direitos de usuário de administrador do domínio.

Como parte do processo de configuração do cluster, a conta de usuário do serviço de cluster é adicionada ao grupo Administradores local em cada nó. Além de ser membro do grupo de administradores local, a conta de usuário do serviço de cluster requer um conjunto adicional de direitos de usuário:

  • Funcionar como parte do sistema operacional
  • Fazer backup de arquivos e diretórios.
  • Ajustar cotas de memória para um processo.
  • Aumentar a prioridade de agendamento.
  • Fazer logon como um serviço.
  • Restaurar arquivos e diretórios.

Esses direitos de usuário também são concedidos à conta de usuário do serviço de cluster como parte do processo de instalação do cluster. Lembre-se de que a conta de usuário do serviço de cluster continuará a ter esses direitos de usuário mesmo depois que todos os nós forem excluídos do cluster. O risco que isso apresenta é atenuado pelo fato de que esses direitos de usuário não são concedidos em todo o domínio, mas apenas localmente em cada nó antigo. No entanto, remova esta conta de cada nó excluído se ela não for mais necessária.

Não deixe que a senha da conta de usuário do serviço de cluster perca a validade (siga as diretrizes da organização para renovação de senhas). Para obter mais informações, consulte Senhas.

Volume para informações importantes sobre configuração de cluster (ponto de verificação e arquivos de log)

Planeje estabelecer um volume no armazenamento de cluster para manter importantes informações sobre a configuração do cluster. Essas informações formam o recurso de quorum do cluster, que é necessário quando um nó do cluster pára de funcionar. O recurso de quorum fornece armazenamento independente de nós de dados cruciais necessários pelo cluster.

O tamanho mínimo recomendado para o volume é de 500 MB. É recomendável que você não armazene dados do usuário em um volume no recurso de quorum.

Observação

  • Ao planejar e executar a configuração de disco dos discos de cluster, configure-os como discos básicos com todas as partições formatadas como NTFS (elas podem ser compactadas ou não compactadas). Particione e formate todos os discos no dispositivo de armazenamento de cluster antes de adicionar o primeiro nó ao cluster. Não os configure como discos dinâmicos e não use volumes estendidos (conjuntos de volumes) ou o armazenamento remoto nos clusters de disco. Em edições de 64 bits do Windows Server 2003, Enterprise Edition, os discos de cluster no dispositivo de armazenamento de cluster devem ser particionados como MBR e não como discos GPT.

A seção a seguir descreve a instalação física de um armazenamento de cluster.

Iniciando a instalação do hardware do cluster

As etapas que você executa quando conecta fisicamente e instala o hardware de cluster pela primeira vez são cruciais. Siga as instruções do fabricante do hardware nessas etapas iniciais.

Importante

  • Examine cuidadosamente os cabos de rede depois de conectá-los. Verifique se nenhum cabo foi trocado por engano (por exemplo, rede privada conectada à pública).

Etapas iniciais a serem executadas no BIOS ou na EFI ao usar um dispositivo de armazenamento compartilhado SCSI

Se você estiver usando um dispositivo de armazenamento compartilhado SCSI, ao conectar o hardware de cluster (o barramento compartilhado e o armazenamento de cluster), trabalhe apenas a partir das telas de configuração de firmware nos nós de cluster (um nó é um servidor em um cluster). Em um computador de 32 bits, use as telas de configuração do BIOS. Em um computador com arquitetura baseada em Itanium, use as telas de configuração da interface de firmware extensível (EFI). As instruções do fabricante descrevem se essas telas de configuração são exibidas automaticamente ou se você deve, depois de ligar o computador, pressionar teclas específicas para acessá-las. Siga as instruções do fabricante para concluir o processo de configuração do BIOS ou da EFI. Durante essa fase de instalação inicial, permaneça nas telas de configuração do BIOS ou da interface de firmware extensível (EFI) e não permita que o sistema operacional seja iniciado. Complete as etapas a seguir enquanto os nós do cluster ainda estão exibindo as telas de configuração do BIOS ou da EFI, antes de iniciar o sistema operacional no primeiro nó de cluster.

Importante

    • Se os nós de cluster são computadores com arquitetura baseada em Itanium, use um barramento Fiber Channel em vez de um barramento SCSI.
  • Verifique se entendeu e seguiu as instruções do fabricante do hardware para terminação do barramento SCSI.
  • Verifique se cada dispositivo no barramento compartilhado (tanto controladores SCSI como discos rígidos) possuam um ID SCSI exclusivo). Se todos os controladores SCSI tiverem o mesmo ID padrão (com freqüência, SCSI ID 7), mude um controlador para outro ID SCSI, como SCSI ID 6. Se houver mais de um disco no barramento SCSI compartilhado, cada disco também deve ter um ID SCSI exclusivo. Além disso, verifique se o barramento não está configurado para redefinir IDs SCSI automaticamente na inicialização (caso contrário, os IDs mudarão das configurações especificadas).
  • Garanta que você possa varrer o barramento e ver as unidades de todos os nós de cluster (enquanto permanece nas as telas de configuração do BIOS ou da EFI).

Etapas iniciais a serem executadas no BIOS ou na EFI ao usar um dispositivo de armazenamento compartilhado Fiber Channel ou dispositivo de armazenamento não compartilhado

  • Ative um único nó. Deixe todos os outros nós desabilitados.
  • Durante a fase de instalação inicial, permaneça no processo de configuração do BIOS ou da interface de firmware extensível (EFI) e não permita que o sistema operacional seja iniciado. Ao examinar as telas de configuração do BIOS ou da EFI, verifique se pode analisar o barramento e ver as unidades do nó de cluster ativo. Em um computador de 32 bits, use as telas de configuração do BIOS. Em um computador com arquitetura baseada em Itanium, use as telas de configuração da EFI. Consulte as instruções do fabricante para determinar se essas telas de configuração são exibidas automaticamente ou se você deve, depois de ligar o computador, pressionar teclas específicas para acessá-las. Siga as instruções do fabricante para concluir o processo de configuração do BIOS ou da EFI.

Etapas finais para concluir a instalação

Se ainda não tiver instalado o Windows Server 2003, Enterprise Edition no primeiro nó do cluster, instale-o antes de continuar. Depois de concluir a configuração do BIOS ou da EFI, inicie o sistema operacional em um nó de cluster somente e conclua a configuração no serviço de cluster usando o Administrador de cluster.

Com o Assistente de novo cluster de servidor do Administrador de cluster, você pode escolher entre as opções de configuração típica (completa) e de configuração avançada (mínima). A configuração típica é apropriada para a maioria das instalações e resulta em um cluster completamente configurado. Use a opção de configuração Avançada somente para clusters com configurações de armazenamento complexas que o Assistente de novo cluster de servidor não consegue validar ou para configurações nas quais você não deseje que o cluster gerencie todo o armazenamento. Os exemplos a seguir descrevem cada situação:

  • Em algumas soluções de armazenamento complexas, como uma estrutura de troca Fiber Channel que contém várias chaves, uma unidade de armazenamento específica pode ter uma identidade diferente em cada computador no cluster. Embora esta seja uma configuração de armazenamento válida, ela viola os heurísticos de validação de armazenamento no Assistente de novo cluster de servidor. Se você tiver este tipo de solução de armazenamento, poderá receber uma mensagem de erro se tentar criar um cluster usando a opção de configuração Típica. Se sua configuração de armazenamento estiver definida corretamente, você poderá desabilitar os heurísticos de validação de armazenamento e evitar esse erro reiniciando o Assistente de novo cluster de servidor, selecionando a opção de configuração Avançada no lugar da outra.
  • Em nós específicos de um cluster, você pode desejar que alguns discos fiquem agrupados em clusters e outros sejam mantidos particulares. A opção de configuração Típica configura todos os discos como discos agrupados em cluster e cria recursos de cluster para todos eles. No entanto, com a opção de configuração Avançada, você pode manter certos discos como particulares porque essa configuração cria um cluster no qual somente o disco de quorum é gerenciado pelo cluster (se você tiver optado por utilizar um disco físico como recurso de quorum). Após a criação do cluster, use o Administrador de cluster para adicionar outros discos a serem gerenciados pelo cluster.

Para obter mais informações, consulte Opções de configuração de armazenamento.

Importante

  • Se estiver usando um dispositivo de armazenamento compartilhado: Antes de criar um cluster, ao ligar o computador e iniciar o sistema operacional, é muito importante que somente um nó tenha acesso ao disco de cluster. Caso contrário, os discos de cluster podem ser corrompidos. Para impedir que esses discos sejam corrompidos, desabilite todos os nós de clusters, exceto um, ou use outras técnicas (por exemplo, mascaramento de nº da unidade lógica, apresentação seletiva ou zoneamento) para proteger os discos de cluster antes de criar o cluster. Antes de iniciar a instalação do segundo nó e dos subseqüentes, verifique também também se que todos os discos a serem gerenciados pelo cluster têm recursos de disco associados a eles. Se os recursos de disco não estiverem associados aos discos nesse momento, os dados dos discos serão corrompidos porque os discos não estarão protegidos e vários nós tentarão se conectar com eles ao mesmo tempo.
  • Não use Gerenciar o servidor ou o Assistente para configurar o servidor para configurar nós de clusters.

Para obter mais informações sobre as etapas posteriores de instalação de um cluster, consulte a Lista de verificação: Validando o sistema de cluster e a Lista de verificação: Planejando e criando um cluster de servidores.

Para obter informações sobre a instalação autônoma de um cluster, consulte Criar um cluster e "Designing Unattended Installations" (em inglês) no site do Microsoft Windows Resource Kits (http://www.microsoft.com/).


Opções do recurso de quorum ao instalar clusters de servidores

Com clusters de servidores no Windows Server 2003, Enterprise Edition, você pode escolher entre três maneiras de configurar o recurso de quorum (o recurso que mantém a cópia definitiva dos dados de configuração do cluster e que deve estar sempre disponível para que o cluster seja executado).

O primeiro é um cluster de servidor de nó único, que estava disponível no passado e para o qual continua a haver suporte. Um cluster de nó único é usado freqüentemente para desenvolvimento e teste e pode ser configurado com ou sem dispositivos de armazenamento de cluster externos. Em clusters de nó único sem um dispositivo de armazenamento de cluster externo, o disco local é configurado como um dispositivo de quorum do cluster.

A segunda opção é um cluster de servidor do dispositivo de quorum único, que também está disponível nas versões anteriores do Windows. Este modelo coloca os dados de configuração do cluster em um dispositivo de armazenamento de cluster compartilhado que todos os nós podem acessar. A topologia geral é:

Cluster de dispositivo de quorum único

É o modelo mais comum e é recomendado na maioria das situações. Você pode escolher o modelo de dispositivo de quorum único se todos os nós de cluster estiverem no mesmo local e quiser beneficiar-se do fato de que esse cluster continua a oferecer suporte a usuários mesmo se somente um nó estiver funcionando.

A terceira opção, que é nova para o Windows Server 2003, Enterprise Edition, é um "conjunto de nós principal". Um conjunto de nós principal é um recurso de quorum único de uma perspectiva do cluster do servidor; no entanto, os dados de configuração do cluster são, na verdade, armazenados em vários discos no cluster. O recurso de conjunto de nós principal garante que os dados de configuração do cluster sejam mantidos consistentes em discos diferentes. Isso permite topologias de cluster conforme a seguir:

Cluster do conjunto de nós principal

No modelo do conjunto de nós principal, cada nó no cluster usa um diretório em seu disco do sistema local para armazenar os dados de configuração do cluster. Se a configuração do cluster for alterada, a alteração é refletida em todos os discos diferentes. Também é possível ter dispositivos de armazenamento compartilhados em um cluster do conjunto de nós principal. A configuração exata depende dos requisitos de instalação.

Somente use um cluster do conjunto de nós principal nestes cenários, como:

  • Cluster dispersado geograficamente: Um cluster que engloba vários sites.
  • Eliminando pontos únicos de falha: Embora quando você usa um dispositivo de armazenamento de cluster único o disco do quorum possa se tornar altamente disponível via RAID, a porta do controlador de domínio ou os adaptadores de barramento de host (HBA) podem se tornar um único ponto de falha.
  • Clusters sem discos compartilhados: Há algumas configurações especializadas que precisam de recursos de cluster altamente consistentes sem ter discos compartilhados.
  • Clusters que hospedam aplicativos que podem apresentar failover, mas onde houver outra maneira específica do aplicativo para replicar ou espelhar dados entre nós:

Não configure o cluster como um cluster de conjunto de nós principal, a menos que ele seja parte de uma solução de cluster oferecida pelo fabricante original do equipamento (OEM), pelo fornecedor independente de software (ISV) ou pelo fornecedor independente de hardware (IHV).

Considerações sobre o modelo de cluster

Antes de implementar o cluster, considere o tipo de solução de recurso de quorum você planeja usar. Considere as seguintes diferenças entre os clusters do dispositivo de quorum único e o conjunto de nós principal:

Observação

  • As informações a seguir são apresentadas para ajudá-lo a tomar decisões básicas sobre a colocação e o gerenciamento de nós de cluster e do recurso de quorum. Elas não fornecem todos os detalhes sobre os requisitos de cada modelo de cluster ou como cada modelo trata das situações de failover. Se não tiver certeza do modelo a ser usado ou de onde deseja colocar os nós do cluster, consulte as informações em Escolhendo um modelo de cluster.

Comportamento de failover do nó

O comportamento de failover do conjunto de nós principal é muito diferente do comportamento do modelo de dispositivo de quorum único:

  • Usando o modelo de dispositivo de quorum único, você pode manter a disponibilidade do cluster com somente um nó operacional.
  • Se você usa um conjunto de nós principal, mais da metade, ou (Número de nós configurados no cluster/2) + 1 nós devem estar operacionais para manter a disponibilidade do cluster. A tabela a seguir mostra o número de falhas de nó que um determinado cluster do conjunto de nós principal pode tolerar e continuar operacional:
    Número de nós configurados no cluster | Número de falhas de nó permitidas antes da falha do cluster | Números de nós necessários para continuar as operações de cluster
    1 | 0 | 1
    2 | 0 | 2
    3 | 1 | 2
    4 | 1 | 3
    5 | 2 | 3
    6 | 2 | 4
    7 | 3 | 4
    8 | 3 | 5

Considerações geográficas

Você poderia usar comumente um modelo de recurso de quorum se todos os nós no cluster estiverem no mesmo local geográfico. Como parte desse requisito, os nós devem estar conectados ao mesmo dispositivo de armazenamento físico.

Por outro lado, um conjunto de nós principal pode normalmente ser adequado se você tiver nós geograficamente dispersos. Os dados de configuração do cluster são armazenados localmente em cada nó em um compartilhamento de arquivo que é compartilhado com outros nós na rede. No entanto, esses compartilhamentos devem estar sempre acessíveis ou os nós podem falhar.

Há outros requisitos específicos em clusters dispersos geograficamente, incluindo o requisito que indica que a latência completa da rede entre os nós de cluster tenha um máximo de 500 milissegundos. Para obter informações sobre soluções de cluster que atendem a todos os requisitos de um cluster disperso geograficamente, consulte as informações sobre a compatibilidade de hardware, que podem ser encontradas clicando no link apropriado em Recursos de suporte.

Hardware

A Microsoft oferece suporte somente a sistemas de cluster de servidor completos compatíveis com a família de produtos Windows Server 2003. Confirme se toda a sua solução de clusters é compatível com produtos da família Windows Server 2003, clicando no link apropriado em Recursos de suporte.

Para obter mais informações sobre os clusters do conjunto de nós principal, consulte Escolhendo um modelo de cluster e Criar um cluster.

Importante

  • Antes de implementar um conjunto de nós principal, é altamente recomendável que você leia as informações em Escolhendo um modelo de cluster. Essas informações o ajudarão a compreender todas as considerações, requisitos e restrições de cada tipo de solução de recurso de quorum.


Atualizando para Windows Server 2003, Enterprise Edition em nós de cluster

Se estiver atualizando do Windows 2000 para o Windows Server 2003, Enterprise Edition em nós de cluster, você poderá executar uma atualização sem interrupção do sistema operacional. Em uma atualização sem interrupção, você atualiza seqüencialmente o sistema operacional em cada nó, verificando se um nó está sempre disponível para tratar das solicitações do cliente. Quando você atualiza o sistema operacional, o serviço de cluster é atualizado automaticamente também. Uma atualização sem interrupção maximiza a disponibilidade de serviços de cluster e minimiza a complexidade administrativa.

Ao atualizar do Windows NT 4.0, Enterprise Edition para o Windows Server 2003, Enterprise Edition em nós de cluster, não é possível executar uma atualização sem interrupção. Para obter mais informações sobre como executar uma atualização do Windows NT 4.0, Enterprise Edition, consulte Atualizar um cluster do Windows NT 4.0.

Para obter mais informações, consulte os seguintes tópicos:

  • Para obter um diagrama e uma descrição da atualização sem interrupção, consulte Como as atualizações sem interrupção funcionam.
  • Para determinar se você pode executar uma atualização sem interrupção, consulte Restrições das atualizações sem interrupção.
  • Para obter informações de suporte sobre os vários tipos de recursos durante uma atualização sem interrupção, consulte:
    • Operação de novos tipos de recurso em clusters de versão mista
    • Comportamento do recurso durante as atualizações sem interrupção
    • Atualizações que incluem um recurso de spooler de impressão
  • Para obter mais informações sobre maneiras de atualizar os nós de cluster se você não puder executar uma atualização sem interrupção, consulte Alternativas às atualizações sem interrupção.


Como as atualizações sem interrupção funcionam

Este tópico descreve as atualizações sem interrupção em clusters de servidores. Para decidir se você pode executar uma atualização sem interrupção, consulte Restrições das atualizações sem interrupção. Para obter mais informações sobre métodos, restrições e alternativas relacionadas às atualizações sem interrupção, consulte os links no final deste tópico.

Há duas vantagens principais em uma atualização sem interrupção. Primeiramente, há uma interrupção mínima do serviço para os clientes. (No entanto, o tempo de resposta do servidor pode diminuir durante as fases nas quais um número menor de nós tratar do trabalho de todo o cluster.) Em segundo, você não precisa recriar a configuração do cluster. A configuração permanece intacta durante o processo de atualização.

Neste exemplo, a atualização sem interrupção é iniciada com dois nós de cluster que estão funcionando no Windows 2000, chamados Nó 1 e Nó 2. O seguinte diagrama mostra o processo:

Visão geral de uma atualização sem interrupção

Fase 1: preliminar

Cada nó é executado no Windows 2000 Advanced Server com o software a seguir:

  • O componente de serviço de cluster, um dos componentes opcionais do Windows 2000 Advanced Server.
  • Aplicativos que oferecem suporte à atualização sem interrupção. Para obter mais informações, consulte a documentação do aplicativo e Comportamento do recurso durante as atualizações sem interrupção.

Neste momento, o cluster é configurado de forma que cada nó trate das solicitações do cliente (uma configuração ativa/ativa).

Fase 2: atualizar o nó 1

O Nó 1 fica em pausa e o Nó 2 trata dos grupos de recurso do cluster enquanto você atualiza o sistema operacional no Nó 1 para Windows Server 2003, Enterprise Edition.

Você está executando um cluster de versão mista. Em um cluster de versão mista, os nós estão executando versões diferentes do sistema operacional. Apesar de o Windows Server 2003, Enterprise Edition fornecer suporte aos clusters de versão mista, eles não são a configuração ideal. É recomendável que você atualize todos os nós para o mesmo sistema operacional, concluindo as duas fases finais da atualização sem interrupção.

Quando o cluster está em um estado de versão mista, é recomendável não fazer alterações na configuração, como adicionar ou remover nós. Também não é recomendável fazer alterações em qualquer dos recursos do cluster enquanto ele está em um estado de versão mista.

Fase 3: atualizar o nó 2

O Nó 1 ingressa novamente no cluster. O Nó 2 é pausado e o Nó 1 trata dos grupos de recurso do cluster enquanto você atualiza o sistema operacional no Nó 2.

Fase 4: final

O Nó 2 ingressa novamente no cluster e você redistribui os grupos de recurso de volta para a configuração de clusters ativa/ativa.

Observações

  • Se o objetivo é ter mais de dois nós no cluster, é necessário usar Fibre Channel (e não SCSI) para armazenamento do cluster. Adicione os outros nós depois de concluir a atualização sem interrupção. Antes de adicionar outros nós, confirme que toda a solução do cluster é compatível com produtos na família Windows Server 2003 clicando no link apropriado em Recursos de suporte. A solução de cluster deve estar na categoria Cluster do hardware compatível.
  • Em discos de cluster, você deve usar o sistema de arquivos NTFS e configurar os discos como discos básicos. Você não pode configurar discos de cluster como discos dinâmicos e não pode usar os recursos de discos dinâmicos como volumes estendidos (conjuntos de volume). Para obter mais informações, consulte Limitações dos clusters de servidor.

Para obter mais informações sobre atualizações sem interrupção, consulte:

  • Executar uma atualização sem interrupção do Windows 2000
  • Restrições para atualizações sem interrupção
  • Operação de novos tipos de recurso em clusters de versão mista
  • Comportamento do recurso durante as atualizações sem interrupção
  • Atualizações que incluem um recurso de spooler de impressão
  • Alternativas às atualizações sem interrupção


Restrições para atualizações sem interrupção

Há várias restrições básicas para o processo de atualização sem interrupção. As restrições mais básicas são:

  • Só é possível executar uma atualização sem interrupção ao atualizar do Windows 2000 em nós de cluster. Não é possível executar uma atualização sem interrupção do Windows NT Server 4.0, Enterprise Edition.
  • Não se pode misturar computadores baseados em x86 e com arquitetura baseada em Itanium no mesmo cluster. Portanto, você não pode executar uma atualização sem interrupção de um x86 para um computador com arquitetura baseada em Itanium.

As restrições restantes envolvem o início da Fase 3, na qual você opera um cluster de versão mista: um cluster no qual os nós executam versões diferentes do sistema operacional. Para que um cluster de versão mista funcione, as versões diferentes do software que são executadas em cada nó devem ser preparadas para que se comuniquem umas com as outras. Este requisito leva a várias restrições básicas no processo de atualização sem interrupção.

  • Em uma atualização sem interrupção bem-sucedida, todos os recursos gerenciados pelo cluster devem ser compatíveis com atualização sem interrupção. Para obter mais informações, consulte Comportamento do recurso durante atualizações sem interrupção.
  • Durante a fase mista de uma atualização sem interrupção, quando os nós de cluster estão executando versões diferentes do sistema operacional, não altere as configurações de recursos (por exemplo, não altere as configurações de um recurso de impressão).

Se as restrições anteriores não puderem ser atendidas, não execute uma atualização sem interrupção. Para obter mais informações, consulte Alternativas às atualizações sem interrupção.


Operação de novos tipos de recurso em clusters de versão mista

A operação de um cluster de versão mista é complicada se houver suporte para um tipo de recurso que você adicionar ao cluster em uma versão do sistema operacional, mas não em outra. Por exemplo, o serviço de cluster no Windows Server 2003, Enterprise Edition fornece suporte ao tipo de recurso de script genérico. No entanto, versões mais antigas do serviço de cluster não oferecem suporte a ele. Um cluster de versão mista pode executar um recurso de script genérico em um nó que execute o Windows Server 2003, Enterprise Edition, mas não em um nó que execute o Windows 2000.

O serviço de cluster define transparentemente os possíveis proprietários dos novos tipos de recurso para impedir que esses recursos falhem em um nó do Windows 2000 de um cluster de versão mista. Em outras palavras, quando você exibe os possíveis proprietários de um novo tipo de recurso, um nó do Windows 2000 não estará na lista e você não poderá adicioná-lo à lista. Se criou um recurso durante a fase de versão mista de uma atualização sem interrupção, os grupos de recurso que contêm esses recursos não falharão em um nó do Windows 2000.


Comportamento do recurso durante as atualizações sem interrupção

Apesar de o serviço de cluster fornecer suporte às atualizações sem interrupção, nem todos os aplicativos têm comportamento uniforme na atualização sem interrupção. A tabela a seguir descreve os recursos para os quais há suporte durante uma atualização sem interrupção. Se você tiver um recurso para o qual não haja suporte total durante atualizações sem interrupção, consulte Alternativas às atualizações sem interrupção.

Observação

  • Não é possível executar uma atualização sem interrupção em um cluster com Windows NT Server 4.0. Somente clusters com Windows 2000 oferecem suporte a atualizações sem interrupção para Windows Server 2003, Enterprise Edition.
Recurso | Observações sobre as atualizações sem interrupção
DHCP | Não há suporte completo ao DHCP durante atualizações sem interrupção. Você deve executar uma "Atualização sem interrupção do último nó", conforme descrito em Executar uma atualização sem interrupção do último nó do Windows 2000.
Compartilhamento de arquivo | Há suporte durante atualizações sem interrupção.
IIS | Não há suporte para o IIS 6.0 durante atualizações sem interrupção. Quando você estiver atualizando um cluster que contém um recurso do IIS, siga o procedimento descrito em Atualizar do Windows 2000 em um cluster que contém o IIS sem usar o script fornecido ou Atualizar do Windows 2000 em um cluster que contém o ISS usando o script fornecido.
Endereço IP | Há suporte durante atualizações sem interrupção.
Quorum local | Há suporte durante atualizações sem interrupção.
MSDTC | Há suporte durante atualizações sem interrupção. No entanto, não crie ou exclua o recurso MSDTC enquanto estiver operando como um cluster de versão mista. Em vez disso, crie o recurso MSDTC antes de iniciar a atualização em qualquer nó ou aguarde até que a atualização esteja completa em todos os nós. Para obter informações sobre clusters de versão mista, consulte Como as atualizações sem interrupção funcionam e Restrições das atualizações sem interrupção.
Enfileiramento de mensagens (também conhecido como MSMQ) | Não há suporte total para o Enfileiramento de Mensagens durante uma atualização sem interrupção. Para atualizar um cluster que inclui o enfileiramento de mensagens, consulte Atualizar do Windows 2000 em um cluster que contém o enfileiramento de mensagens.
Nome de rede | Há suporte durante atualizações sem interrupção.
Instância de serviço NNTP | A Instância de serviço NNTP não é suportada no Windows Server 2003, Enterprise Edition. Você deve remover os recursos da Instância de serviço NNTP antes de atualizar.
Disco físico | Há suporte durante atualizações sem interrupção.
Spooler de impressão | Os únicos recursos de spooler de impressão para os quais há suporte durante uma atualização sem interrupção são os que estão em portas LPR ou em portas de monitoração de porta padrão. Consulte Atualizações que incluem um recurso de spooler de impressão.
Instância de serviço SMTP | A Instância de serviço SMTP não é suportada no Windows Server 2003, Enterprise Edition. Você deve remover os recursos da Instância de serviço SMTP antes da atualização.
Serviço de tempo | O Serviço de tempo não é suportado no Windows Server 2003, Enterprise Edition. Você deve remover todos os recursos do Serviço de tempo antes da atualização.
WINS | Não há suporte total para o WINS durante atualizações sem interrupção. Você deve executar uma "Atualização sem interrupção do último nó", conforme descrito em Executar uma atualização sem interrupção do último nó do Windows 2000.
Outros tipos de recursos | Consulte o arquivo Relnotes.htm na pasta \Docs do CD de instalação do Windows Server 2003, Enterprise Edition. Além disso, consulte a documentação do produto que acompanha o aplicativo ou recurso.

Quando o cluster está em um estado de versão mista, é recomendável não fazer alterações na configuração, como adicionar ou remover nós. Também não é recomendável fazer alterações em qualquer dos recursos do cluster enquanto ele está em um estado de versão mista.

Atualizações sem interrupção do último nó

Se você tiver recursos no cluster como DHCP e WINS para os quais não haja suporte total durante uma atualização sem interrupção e que não sejam descritos por outros procedimentos específicos de tecnologia (como o IIS), você poderá executar uma "atualização sem interrupção do último nó".

As atualizações sem interrupção do último nó são similares às atualizações sem interrupção padrão. Em uma atualização sem interrupção do último nó, você atualiza todos os nós, exceto o que contém os recursos para os quais não há suporte. Depois que todos os nós forem atualizados, você atualiza o nó final que contém os recursos identificados.

As atualizações sem interrupção do último nó representam uma forma de acomodar recursos que não podem apresentar failover em um sistema operacional mais antigo de um nó que executa o Windows Server 2003, Enterprise Edition. Lembre-se de que esses recursos podem, no entanto, apresentar failover de outra forma, ou seja, do sistema operacional mais antigo para o Windows Server 2003, Enterprise Edition. Para obter mais informações sobre como executar uma atualização sem interrupção do último nó, consulte Executar uma atualização sem interrupção do último nó do Windows 2000.


Atualizações que incluem um recurso de spooler de impressão

Se desejar executar uma atualização sem interrupção de um cluster que tem um recurso de spooler de impressão, você deve considerar duas questões.

Em primeiro lugar, o recurso de spooler de impressão só fornece suporte a atualizações (incluindo atualizações sem interrupção ou qualquer outro tipo de atualização) de impressoras em portas para as quais o cluster oferece suporte (portas LPR ou monitoração de porta padrão). Para obter mais informações sobre o que fazer se não houver suporte para impressora, consulte Alternativas às atualizações sem interrupção.

Em segundo lugar, quando você opera um cluster de versão mista incluindo um recurso de spooler de impressão, observe o seguinte:

  • Não altere as configurações da impressora em um cluster de versão mista com o recurso de spooler de impressão.
  • Evite adicionar novas impressoras enquanto está executando uma atualização sem interrupção. Se você adicionar uma nova impressora, quando instalar os seus drivers, verifique se instalou o driver do Windows 2000 e o do Windows Server 2003, Enterprise Edition em todos os nós.
  • Se as preferências de impressão ou os padrões forem importantes, verifique-os. As preferências de impressão no Windows Server 2003, Enterprise Edition não corresponderão necessariamente aos padrões do documento para a mesma impressora no Windows 2000. Isso pode ser afetado pelas diferenças nos drivers dos dois sistemas operacionais.

Quando a atualização sem interrupção estiver concluída e os dois nós de cluster estiverem executando o sistema operacional atualizado, você pode fazer as modificações que escolher na sua configuração de impressão.


Alternativas às atualizações sem interrupção

Certas situações não permitem que você execute uma atualização sem interrupção padrão. Nesses casos, será preciso executar procedimentos alternativos. Isso ocorre nas seguintes situações:

  • Atualizando do Windows NT Server 4.0, Enterprise Edition. Para obter mais informações, consulte Atualizando um cluster do Windows NT.
  • Atualizando um nó que contém recursos sem suporte durante atualizações sem interrupção. Para determinar se há suporte para os recursos durante atualizações sem interrupção, consulte Comportamento dos recursos durante atualizações sem interrupção. Também não deixe de ler o arquivo Relnotes.htm na pasta \Docs do CD de instalação do Windows Server 2003, Enterprise Edition, assim como a documentação que acompanha o aplicativo ou recurso. Se você tiver um recurso sem suporte integral durante atualizações sem interrupção e que não é descrito por um procedimento para tecnologia específica, como o Internet Information Server (IIS), consulte Executar uma atualização ininterrupta do último nó a partir do Windows 2000.


Recursos

Este tópico fornece fontes de informações adicionais sobre como instalar e atualizar em nós de cluster.

  • A Microsoft só oferece suporte a sistemas completos de clusters de servidores que sejam compatíveis com a família de produtos Windows Server 2003. Confirme se toda a sua solução de clusters é compatível com produtos da família Windows Server 2003, clicando no link apropriado em Recursos de suporte.

  • Para obter as informações mais recentes sobre aplicativos compatíveis e certificados dos produtos da família Windows Server 2003, consulte a seção sobre compatibilidade de software do site da Microsoft (http://www.microsoft.com).
  • Para garantir maior disponibilidade, verifique os aperfeiçoamentos e atualizações para o software Windows e outros softwares Microsoft. Consulte Windows Update no site da Microsoft. (http://www.microsoft.com/)
  • Para obter informações adicionais sobre como implantar clusters, consulte o tópico sobre "implantações de servidor " no site Microsoft Windows Resource Kits. (http://www.microsoft.com/)
  • Para obter informações gerais adicionais sobre clusters e Windows Deployment and Resource Kits, que fornecem informações técnicas detalhadas sobre os produtos da família Windows Server 2003, consulte:
    • O Kit de Implantação do Windows Server 2003 no site da Microsoft. (http://www.microsoft.com/).
    • Windows Deployment and Resource Kits
  • Microsoft TechNet é um serviço que contém recursos para profissionais de tecnologia da informação (IT). Inclui acesso a informes oficiais e artigos sobre clusters escritos por profissionais de suporte da Microsoft, informações sobre a carreira e o ramo, grupos de discussão, comentários técnicos e softwares. Para obter mais informações sobre o TechNet, consulte o site da Microsoft (http://www.microsoft.com/).
  • O site da Information Technology Infrastructure Library (ITIL) fornece orientação para profissionais de Tecnologia da Informação e inclui informações detalhadas relacionadas a alta disponibilidade. Veja a seguir um trecho retirado do site: "A ITIL consiste em uma série de livros que oferecem orientação sobre o fornecimento de serviços de informática de qualidade e sobre os recursos ambientais e de adaptação necessários ao suporte à tecnologia da informação." (Os endereços da Web podem ser alterados, por isso talvez você não consiga se conectar ao site ou sites da Web mencionados aqui).


Solucionando problemas

Qual é o seu problema?

Durante a criação de clusters, o Assistente para criar novo cluster de servidor não detectou todos os possíveis discos de cluster.

Causa possível Solução
  • O hardware, driver de dispositivo ou software não está configurado corretamente.
  • Verifique no Gerenciamento de disco se os discos que você deseja utilizar para armazenamento compartilhado estão disponíveis.

    Consulte também: Gerenciamento de disco

  • Você está utilizando hardware de disco ou drivers incompatíveis.
  • Verifique se os cabos do disco estão conectados corretamente entre o nó em questão e o armazenamento compartilhado.

    Confirme se os hardwares, incluindo os discos de cluster e outros hardwares de cluster, são compatíveis com Windows Server 2003, Enterprise Edition clicando no link apropriado em Recursos de suporte.

    Verifique se o adaptador de host está configurado corretamente de acordo com as instruções do fabricante e se todos os discos estão visíveis para o adaptador de host.

    Verifique se possui os drivers necessários para usar os discos com o Serviço de cluster. Os drivers ficam disponíveis com o fabricante do hardware. Revise com atenção as instruções do fabricante antes de começar a instalar os hardwares de cluster.

    Observação

    • Se você fizer alguma alteração nos hardwares de disco ou drivers, reinicie o Assistente para criar novo cluster de servidor para que as alterações sejam detectadas.
  • Seus discos de armazenamento de cluster não são formatados como NTFS.
  • Verifique se todas as partições nos discos de armazenamento de cluster estão formatadas para utilizar o sistema de arquivos NTFS. Nenhum disco com partição FAT ou FAT32 será reconhecido durante a criação de um cluster.

    Consulte também: NTFS

  • Os discos de armazenamento de cluster não estão configurados como discos MBR básicos.
  • Verifique se os discos de armazenamento de cluster estão configurados como discos MBR básicos. O Windows Server 2003, Enterprise Edition oferece dois tipos de configuração de armazenamento: disco básico e disco dinâmico. Os discos básicos utilizam as mesmas estruturas de disco utilizadas pelo Microsoft Windows NT. Os discos dinâmicos foram introduzidos com o Windows 2000.

    A versão de 64 bits do Windows Server 2003, Enterprise Edition e a versão de 64 bits do Windows Server 2003, Datacenter Edition oferecem discos de tabela de partições global (GPT), além dos discos de registro mestre de inicialização (MBR) com suporte na versão de 32 bits do Windows Server 2003, Enterprise Edition.

    No entanto, os servidores de cluster só podem reconhecer discos MBR básicos. Se um disco que você deseja utilizar como armazenamento compartilhado estiver configurado como disco dinâmico ou GPT, transforme-o de volta em disco MBR básico.

    Consulte também: Atualizando de disco básico para dinâmico e Converter um disco de tabela de partição GUID em disco de registro mestre de inicialização (somente 64 bits)

Durante a criação de um cluster, o Assistente para criar novo cluster de servidor configurou todos os dispositivos de armazenamento disponíveis para serem gerenciados pelo cluster, incluindo armazenamentos que você não queria que fossem gerenciados pelo cluster.

Causa: Com o Assistente para criar novo cluster de servidor do Administrador de cluster, você pode escolher entre as opções de configuração típica (completa) e de configuração avançada (mínima). A opção de configuração Típica configura todos os discos como discos agrupados em cluster e cria recursos de cluster para todos eles. A única exceção é o disco do sistema, que contém o sistema operacional e é o disco a partir do qual o computador inicializa. O disco do sistema não será agrupado em cluster automaticamente.

Solução: Use a opção de configuração Avançada (mínima). Com a opção de configuração Avançada, você pode manter certos discos como particulares porque essa configuração cria um cluster no qual somente o disco de quorum é gerenciado pelo cluster (se você tiver optado por utilizar um disco físico como recurso de quorum). Após a criação do cluster, use o Administrador de cluster para adicionar outros discos a serem gerenciados pelo cluster.

Para obter mais informações, consulte Planejando e preparando-se para instalação de clusters e Opções de configuração de armazenamento.

Ao tentar adicionar um nó a um cluster, você recebe um erro indicando que não é possível criar um cluster de vários nós porque não existe um recurso com capacidade de quorum comum a todos os nós.

Causa: O assistente não conseguiu validar sua configuração de armazenamento. Em algumas soluções de armazenamento complexas que contêm várias chaves, como uma estrutura de troca Fiber Channel, uma unidade de armazenamento específica pode ter uma identidade diferente em cada computador no cluster. Embora essa seja uma configuração de armazenamento válida, ela viola os heurísticos de validação de armazenamento no Assistente para criar novo cluster de servidor e no Assistente para adicionar nós.

Solução: Verifique se a configuração de armazenamento está definida corretamente. Em seguida, se você estiver no Assistente para adicionar nós, desabilite os heurísticos de validação de armazenamento usando o botão Voltar para retornar à página Selecionar computador. Nessa página, clique em Avançado e selecione a opção Configuração avançada (mínima). Se você não estiver no Assistente para adicionar nós, reinicie o assistente e use a opção de configuração avançada da maneira descrita anteriormente.

Para obter mais informações, consulte Planejando e preparando-se para instalação de clusters.

Durante a criação do cluster, o Assistente para criar novo cluster de servidor ou o Assistente para adicionar nós não detectou todos os possíveis adaptadores de rede.

Causa possível Solução
  • O cluster pode não ser capaz de detectar uma rede composta de cabo cruzado.

    Um cluster de dois nós pode usar um cabo cruzado para implementar uma rede privada. Quando o cluster é criado no primeiro nó, o segundo deve ser ativado, mas interrompido no BIOS ou no menu de inicialização. Nesse estado, o recurso Sensor de mídia do Windows pode não reconhecer o adaptador de rede como conectado.

    Quando isso ocorre:

    • Em Conexões de rede, o ícone de conexão que representa o adaptador de rede é exibido com um "X" vermelho.
    • A barra de tarefas exibe um ícone que, ao ficar sob o ponteiro do mouse, exibe Cabo de rede desconectado.
  • Se você continuar a criar o cluster, o cabo cruzado detectará o momento em que você iniciar o segundo nó. A rede será estabelecida no modo padrão, que é misto. É possível alterar o modo de rede para particular através do Administrador de cluster.

    Consulte também: Gerenciar redes
  • As conexões de rede do sistema não estão funcionando. Se a seguinte mensagem de erro for exibida na árvore do Assistente para criar novo cluster de servidor, as conexões de rede podem não estar em funcionamento:

    "Aviso: O sistema não está conectado a todas as redes de cluster definidas."
  • Verifique se as conexões de rede estão habilitadas. Caso contrário, o Serviço de cluster não conseguirá detectá-las e utilizá-las.

    Para verificar as configurações de rede:

    1. Abra Conexões de rede no Painel de controle.
    2. Clique duas vezes na conexão a ser verificada.
    3. Na guia Geral, verifique o status da conexão. Se a conexão não tiver sido iniciada, faça isso.

    Clique em Analisar novamente no Assistente para criar novo cluster de servidor para que as alterações sejam detectadas.

    Consulte também: TCP/IP
  • O hardware de rede não está instalado corretamente.
  • Verifique se os cabos de rede estão conectados corretamente. Verifique se os cabos não estão invertidos por engano (particular–para–público ou público–para–particular) e se cada adaptador de rede está conectado conforme planejado. Com mais de dois nós, use um hub dedicado (não uma chave) para a rede privada.

    Ajuste todos os adaptadores de rede de múltiplas velocidades em uma rede particular ou mista para a mesma velocidade. Não use a configuração de detecção automática.

    Se forem usados adaptadores de rede tolerantes a falha, crie várias redes privadas em vez de uma única rede tolerante a falhas.

    Verifique se todos os adaptadores de rede estão corretamente conectados e os drivers corretos estão instalados de acordo com as instruções do fabricante. Confirme se o hardware é compatível com Windows Server 2003, Enterprise Edition clicando no link apropriado em Recursos de suporte.
  • As redes de cluster não estão na sub-rede correta. Todos os adaptadores de rede projetados para uso de cluster em um único nó precisam estar em sub-redes diferentes. Caso contrário, somente o primeiro adaptador de rede em uma sub-rede é detectado pelo Assistente para criar novo cluster de servidor ou pelo Assistente para adicionar nós, e é utilizado para comunicação de clusters ou de clientes (dependendo da função escolhida).

    No entanto, para que os nós subseqüentes captem as funções de rede definidas no primeiro nó do cluster, os adaptadores de rede em cada nó devem estar nas mesmas sub-redes dos adaptadores correspondentes no primeiro nó.
  • O Serviço de cluster pode detectar e utilizar vários adaptadores de rede no mesmo computador se os seguintes requisitos forem atendidos:
    • Os adaptadores de rede estiverem interligados por TCP/IP.
    • Você estiver utilizando um hardware compatível com Windows Server 2003, Enterprise Edition. Para confirmar isso, clique no link apropriado em Recursos de suporte.
    • Cada adaptador de rede esteja em uma sub-rede diferente.

    Não use o mesmo endereço IP para dois adaptadores de rede, mesmo que estejam conectados a duas redes diferentes.

    Depois que os adaptadores de rede estiverem configurados corretamente, use o comando ping para verificar a conectividade de cada adaptador de rede com o endereço de auto-retorno (127.0.0.1), o endereço IP próprio do adaptador e o endereço IP de outro computador.

    Verifique se cada adaptador está funcionando corretamente e pode se comunicar em cada rede e, em seguida, reinicialize o Assistente para criar novo cluster de servidor ou o Assistente para adicionar nós.

    Consulte também: Configurar o TCP/IP para endereçamento estático
  • O cluster não tem conectividade de rede.
  • Use o comando ping para testar a conectividade. Faça ping no nome de domínio totalmente qualificado do nó.

    Se você não conseguir fazer ping no controlador de domínio do nó por nome, consulte Solução de problemas de hardware. Você também pode saber mais sobre o problema fazendo ping no controlador de domínio por endereço IP e fazendo ping em outros servidores de rede por nome e endereço IP, incluindo o servidor DNS ou WINS do nó.

    Consulte também: Gerenciar redes

Durante a criação do cluster, você está enfrentando problemas para criar o primeiro nó do cluster.

Causa possível Solução
  • Você não está usando um endereço IP válido para a interface de rede.
  • Os endereços de cada par vinculado de adaptadores de rede devem estar na mesma sub-rede.

    Para verificar os endereços IP, clique em Iniciar, em Executar e digite ipconfig /all. Em seguida, pressione ENTER. Isso exibirá sua configuração IP, incluindo endereço IP, máscara de sub-rede, gateway padrão, endereço de servidor DNS e disponibilidade de DHCP. Confirme se as configurações estão corretas. Se estiver usando DHCP, passe para endereços IP estáticos.

    Se não for exibido um endereço IP nem outra configuração IP e aparecer a mensagem Estado da mídia = cabo desconectado, pode não haver conectividade de rede ponto a ponto do adaptador de rede ao dispositivo de rede de conexão. Verifique se as conexões físicas estão firmes e válidas. Se aparecer um endereço de endereçamento IP particular automático (APIPA), transforme-o em um IP estático.

    Não use um endereço IP que esteja na mesma faixa IP da rede pública.

    Consulte também: TCP/IP
  • O cluster não tem conectividade de rede.
  • Use o comando ping para testar a conectividade. Faça ping no nome de domínio totalmente qualificado do nó.

    Se você não conseguir fazer ping no controlador de domínio do nó por nome, abra Conexões de rede e verifique o status do adaptador de rede. Você também pode tentar mapear uma unidade para o outro nó no cluster para verificar a comunicação e autenticação. Se essas soluções não funcionarem, consulte Solução de problemas de hardware. Você também pode saber mais sobre o problema fazendo ping no controlador de domínio por endereço IP e fazendo ping em outros servidores de rede por nome e endereço IP, incluindo o servidor DNS ou WINS do nó.

    Consulte também: Gerenciar redes
  • Você não está usando um nome de cluster exclusivo.
  • O nome do cluster deve ser diferente do nome do domínio, de todos os nomes de computadores na rede, dos nomes de outros clusters na rede e de todos os nomes de servidores virtuais na rede.

    Use o comando net view para determinar se o nome do seu cluster é exclusivo.

    Para usar o comando net view, clique em Iniciar, depois em run, digite o comando a seguir e pressione ENTER:

    net view nomedocluster

    Nomedocluster é o nome do cluster.

    Se o nome do seu cluster não for exclusivo, atribua um nome exclusivo. Quando o Assistente para criar novo cluster de servidor solicitar o nome do cluster, digite um novo nome de cluster adequado.
  • O cluster pode não ser capaz de detectar uma rede composta de cabo cruzado.

    Um cluster de dois nós pode usar um cabo cruzado para implementar uma rede privada. Quando o cluster é criado no primeiro nó, o segundo deve ser ativado, mas interrompido no BIOS ou no menu de inicialização. Nesse estado, o recurso Sensor de mídia do Windows pode não reconhecer o adaptador de rede como conectado.

    Quando isso ocorre:

    • Em Conexões de rede, o ícone de conexão que representa o adaptador de rede é exibido com um "X" vermelho.
    • A barra de tarefas exibe um ícone que, ao ficar sob o ponteiro do mouse, exibe Cabo de rede desconectado.
  • Se você continuar a criar o cluster, o cabo cruzado detectará o momento em que você iniciar o segundo nó. A rede será estabelecida no modo padrão, que é misto. É possível alterar o modo de rede para particular através do Administrador de cluster.

    Consulte também: Gerenciar redes
  • As redes de cluster não estão na sub-rede correta. Todos os adaptadores de rede projetados para uso de cluster em um único nó precisam estar em sub-redes diferentes. Caso contrário, somente o primeiro adaptador de rede em uma sub-rede é detectado pelo Assistente para criar novo cluster de servidor ou pelo Assistente para adicionar nós, e é utilizado para comunicação de clusters ou de clientes (dependendo da função escolhida).

    No entanto, para que os nós subseqüentes captem as funções de rede definidas no primeiro nó do cluster, os adaptadores de rede em cada nó devem estar nas mesmas sub-redes dos adaptadores correspondentes no primeiro nó.

  • O Serviço de cluster pode detectar e utilizar vários adaptadores de rede no mesmo computador se os seguintes requisitos forem atendidos:
    • Os adaptadores de rede estiverem interligados por TCP/IP.
    • Você estiver utilizando um hardware compatível com Windows Server 2003, Enterprise Edition. Para confirmar isso, clique no link apropriado em Recursos de suporte.
    • Cada adaptador de rede esteja em uma sub-rede diferente. Verifique a sub-rede inserida para cada nó.

    Não use o mesmo endereço IP para dois adaptadores de rede, mesmo que estejam conectados a duas redes diferentes.

    Depois que os adaptadores de rede estiverem configurados corretamente, use o comando ping para verificar a conectividade de cada adaptador de rede com o endereço de auto-retorno (127.0.0.1), o endereço IP próprio do adaptador e o endereço IP de outro computador.

    Verifique se cada adaptador está funcionando corretamente e pode se comunicar em cada rede e, em seguida, reinicialize o Assistente para criar novo cluster de servidor ou o Assistente para adicionar nós.

    Consulte também: Configurar o TCP/IP para endereçamento estático
  • O hardware de rede não está instalado corretamente.
  • Verifique se os cabos de rede estão conectados corretamente. Verifique se os cabos não estão invertidos por engano (particular–para–público ou público–para–particular) e se cada adaptador de rede está conectado conforme planejado.

    Ajuste todos os adaptadores de rede de múltiplas velocidades em uma rede particular ou mista para a mesma velocidade. Não use a configuração de detecção automática.

    Se forem usados adaptadores de rede tolerantes a falha, crie várias redes privadas em vez de uma única rede tolerante a falhas.

    Verifique se todos os adaptadores de rede estão corretamente conectados e os drivers corretos estão instalados de acordo com as instruções do fabricante. Confirme se o hardware é compatível com Windows Server 2003, Enterprise Edition clicando no link apropriado em Recursos de suporte.
  • O cliente WINS não está configurado corretamente no nó.
  • Se você usa o WINS, todos os nomes de recursos de cluster com endereços IP associados são registrados com WINS. Use as instruções a seguir para verificar a configuração WINS.

    Primeiro, verifique se a conexão do cliente tem pelo menos um servidor WINS especificado na configuração IP clicando em Iniciar, em Executar e digitando ipconfig /all. Confirme se o endereço IP exibido para servidores WINS primário e (se listado) secundário são os mesmos endereços IP utilizados com êxito em outros computadores na mesma sub-rede que estão procurando os mesmos recursos.

    Em seguida, determine se o nome é resolvido clicando em Iniciar, em Executar e digitando ping servidor, onde servidor é o nome de rede do servidor. Em seguida, pressione ENTER.

    Se você estiver usando endereçamento IP estático para os nós de cluster, será preciso configurar o WINS nos endereços IP disponibilizados na rede pública.

    Se os clientes tiverem problemas para se conectar com servidores virtuais, desabilite o WINS na rede de cluster particular.

    Importante

    • Não desabilite para o adaptador de rede utilizado para comunicação de clientes.

    Depois de configurar o WINS, se você já tiver criado o cluster em pelo menos um nó, faça ping no nome do cluster para testar a conectividade.

    Consulte também: Configurar o TCP/IP para usar WINS.

  • O TCP/IP não está configurado corretamente.
  • Se algum dos testes de ping a seguir falhar, há um problema na configuração de TCP/IP:
    • Fazendo ping no endereço de auto-retorno
    • Fazendo ping no endereço do protocolo Internet (IP) local (interconexões públicas e particulares)
    • Fazendo ping no endereço IP de outro nó (interconexões públicas e particulares)

    Observações

    • Para testar a resolução de nomes através de interconexão pública, desconecte o cabo de interconexão particular.

    Se o ping de outro nó por nome falhar, mas o ping do endereço IP do nó for bem-sucedido, há um problema de resolução de nome. Contate o administrador da rede para obter assistência.

    Os erros de TCP/IP causados por endereço IP ou máscara de sub-rede incorreto(a) são geralmente registrados no log do sistema. Use Visualizar eventos para verificar se há esse tipo de erro no log do sistema.

    Mesmo que não haja erros de TCP/IP no log do sistema, verifique as configurações de TCP/IP para verificar se estão corretas clicando em Iniciar, em Executar e digitando ipconfig /all. Verifique se o endereço IP e a máscara de sub-rede listados são os valores corretos para o computador. Se você não souber os valores de endereço IP e máscara de sub-rede corretos para o computador, pergunte ao administrador da rede.

    Consulte também: TCP/IP
  • As conexões de rede do sistema não estão funcionando. Se a seguinte mensagem de erro for exibida na árvore do Assistente para criar novo cluster de servidor, as conexões de rede podem não estar em funcionamento:

    "Aviso: O sistema não está conectado a todas as redes de cluster definidas."
  • Verifique se as conexões de rede estão habilitadas. Caso contrário, o Serviço de cluster não conseguirá detectá-las e utilizá-las.

    Para verificar as configurações de rede:

    1. Abra Conexões de rede no Painel de controle.
    2. Clique duas vezes na conexão a ser verificada.
    3. Na guia Geral, verifique o status da conexão. Se a conexão não tiver sido iniciada, faça isso.

    Clique em Analisar novamente no Assistente para criar novo cluster de servidor para que as alterações sejam detectadas.

    Consulte também: TCP/IP
  • Você não está usando um endereço IP válido.
  • Obtenha um endereço IP estático para o cluster. Você não pode usar o DHCP para atribuir esse endereço.

    Cada adaptador de rede em cada nó de cluster também precisa de um endereço IP. Atribua um endereço IP estático a cada adaptador. Os endereços de cada par vinculado de adaptadores de rede (vinculados nó a nó) devem estar na mesma sub-rede.

    Se os nós do cluster utilizarem DHCP para obter endereços IP que não são do cluster, no prompt de comando, use o comando ipconfig para verificar se o endereço IP primário para as redes em questão é válido.

    Use o comando ping para confirmar se há conectividade IP com o endereço de cluster e se o endereço IP foi atribuído à rede correta. Se o teste de ping falhar, não há conectividade de rede básica.

    Se você tiver feito alguma alteração, reinicie o Assistente para criar novo cluster de servidor. Você deve reiniciar o assistente para que as alterações sejam detectadas.

    Consulte também: Gerenciar redes
  • Você não tem a conta de domínio correta nem os direitos de usuário apropriados.
  • Verifique se está atendendo aos seguintes requisitos:
    • Para criar um cluster, faça logon com uma conta que seja membro do grupo Administradores local em cada nó. Recomenda-se o uso de uma conta de domínio. Cada nó precisa também ser membro desse domínio ou membro de um domínio de confiança para o domínio que contém a conta na qual você está fazendo o logon.
    • Você pode administrar o Serviço de cluster usando um domínio ou uma conta local; porém, outros nós só podem ser incluídos em um cluster com uso de uma conta de domínio.

    Se você fizer alguma alteração de conta ou direito de usuário, clique em Analisar novamente no Assistente para criar novo cluster de servidor para que as alterações sejam detectadas. Talvez você também tenha que fazer logoff e voltar a fazer logon para que as alterações de segurança tenham efeito.

    Consulte também: Segurança

Durante a criação do cluster, você está enfrentando problemas para criar os nós seguintes depois de criar o primeiro nó do cluster.

Causa possível Solução
  • Você não está usando um endereço IP válido para a interface de rede.
  • Os endereços de cada par vinculado de adaptadores de rede devem estar na mesma sub-rede.

    Para verificar os endereços IP, clique em Iniciar, em Executar e digite ipconfig /all. Em seguida, pressione ENTER. Isso exibirá sua configuração IP, incluindo endereço IP, máscara de sub-rede, gateway padrão, endereço de servidor DNS e disponibilidade de DHCP. Confirme se as configurações estão corretas. Se estiver usando DHCP, passe para um endereço IP estático.

    Se não for exibido um endereço IP nem outra configuração IP e aparecer a mensagem Estado da mídia = cabo desconectado, pode não haver conectividade de rede ponto a ponto do adaptador de rede ao dispositivo de rede de conexão. Verifique se as conexões físicas estão firmes e válidas.

    Consulte também: TCP/IP
  • O cluster não tem conectividade de rede.
  • Use o comando ping para testar a conectividade. Faça ping no nome de domínio totalmente qualificado do nó.

    Se você não conseguir fazer ping no controlador de domínio do nó por nome, consulte Solução de problemas de hardware. Você também pode saber mais sobre o problema fazendo ping no controlador de domínio por endereço IP e fazendo ping em outros servidores de rede por nome e endereço IP, incluindo o servidor DNS ou WINS do nó.

    Consulte também: Gerenciar redes
  • O cluster pode não ser capaz de detectar uma rede composta de cabo cruzado.

    Um cluster de dois nós pode usar um cabo cruzado para implementar uma rede privada. Quando o cluster é criado no primeiro nó, o segundo deve ser ativado, mas interrompido no BIOS ou no menu de inicialização. Nesse estado, o recurso Sensor de mídia do Windows pode não reconhecer o adaptador de rede como conectado.

    Quando isso ocorre:

    • Em Conexões de rede, o ícone de conexão que representa o adaptador de rede é exibido com um "X" vermelho.
    • A barra de tarefas exibe um ícone que, ao ficar sob o ponteiro do mouse, exibe Cabo de rede desconectado.
  • Se você continuar a criar o cluster, o cabo cruzado detectará o momento em que você iniciar o segundo nó. A rede será estabelecida no modo padrão, que é misto. É possível alterar o modo de rede para particular através do Administrador de cluster.

    Consulte também: Gerenciar redes
  • As redes de cluster não estão na sub-rede correta. Todos os adaptadores de rede projetados para uso de cluster em um único nó precisam estar em sub-redes diferentes. Caso contrário, somente o primeiro adaptador de rede em uma sub-rede é detectado pelo Assistente para criar novo cluster de servidor ou pelo Assistente para adicionar nós, e é utilizado para comunicação de clusters ou de clientes (dependendo da função escolhida).

    No entanto, para que os nós subseqüentes captem as funções de rede definidas no primeiro nó do cluster, os adaptadores de rede em cada nó devem estar nas mesmas sub-redes dos adaptadores correspondentes no primeiro nó.

  • O Serviço de cluster pode detectar e utilizar vários adaptadores de rede no mesmo computador se os seguintes requisitos forem atendidos:
    • Os adaptadores de rede estiverem interligados por TCP/IP.
    • Você estiver utilizando um hardware compatível com Windows Server 2003, Enterprise Edition. Para confirmar isso, clique no link apropriado em Recursos de suporte.
    • Cada adaptador de rede esteja em uma sub-rede diferente. Verifique a entrada de sub-rede de cada nó.

    Não use o mesmo endereço IP para dois adaptadores de rede, mesmo que estejam conectados a duas redes diferentes.

    Depois que os adaptadores de rede estiverem configurados corretamente, use o comando ping para verificar a conectividade de cada adaptador de rede com o endereço de auto-retorno (127.0.0.1), o endereço IP próprio do adaptador e o endereço IP de outro computador.

    Verifique se cada adaptador está funcionando corretamente e pode se comunicar em cada rede e, em seguida, reinicialize o Assistente para criar novo cluster de servidor ou o Assistente para adicionar nós.

    Consulte também: Configurar o TCP/IP para endereçamento estático
  • O hardware de rede não está instalado corretamente.
  • Verifique se os cabos de rede estão conectados corretamente. Verifique se os cabos não estão invertidos por engano (particular–para–público ou público–para–particular) e se cada adaptador de rede está conectado conforme planejado.

    Verifique se há conflito de recursos no Gerenciador de dispositivos.

    Ajuste todos os adaptadores de rede de múltiplas velocidades em uma rede particular ou mista para a mesma velocidade. Não use a configuração de detecção automática.

    Se forem usados adaptadores de rede tolerantes a falha, crie várias redes privadas em vez de uma única rede tolerante a falhas.

    Verifique se todos os adaptadores de rede estão corretamente conectados e os drivers corretos estão instalados de acordo com as instruções do fabricante. Confirme se o hardware é compatível com Windows Server 2003, Enterprise Edition clicando no link apropriado em Recursos de suporte.

    Consulte também: Gerenciador de dispositivos
  • O cliente WINS não está configurado corretamente no nó.
  • Se você usa o WINS, todos os nomes de recursos de cluster com endereços IP associados são registrados com WINS. Use as instruções a seguir para verificar a configuração WINS.

    Primeiro, verifique se a conexão do cliente tem pelo menos um servidor WINS especificado na configuração IP clicando em Iniciar, em Executar e digitando ipconfig /all. Confirme se o endereço IP exibido para servidores WINS primário e (se listado) secundário são os mesmos endereços IP utilizados com êxito em outros computadores na mesma sub-rede que estão procurando os mesmos recursos.

    Em seguida, determine se o nome é resolvido clicando em Iniciar, em Executar e digitando ping servidor, onde servidor é o nome de rede do servidor. Em seguida, pressione ENTER.

    Se você estiver usando endereçamento IP estático para os nós de cluster, será preciso configurar o WINS nos endereços IP disponibilizados na rede pública.

    Se os clientes tiverem problemas para se conectar com servidores virtuais, desabilite o NetBios por TCP/IP na rede de cluster particular.

    Importante

    • Não desabilite para o adaptador de rede utilizado para comunicação de clientes.

    Depois de configurar o WINS, se você já tiver criado o cluster em pelo menos um nó, faça ping no nome do cluster para testar a conectividade.

    Consulte também: Configurar o TCP/IP para usar WINS.

  • O TCP/IP não está configurado corretamente.
  • Se algum dos testes de ping a seguir falhar, há um problema na configuração de TCP/IP:
    • Fazendo ping no endereço de auto-retorno
    • Fazendo ping no endereço do protocolo Internet (IP) local (interconexões públicas e particulares)
    • Fazendo ping no endereço IP de outro nó (interconexões públicas e particulares)

    Observação

    • Para testar a resolução de nomes através de interconexão pública, desconecte o cabo de interconexão particular.

    Se o ping de outro nó por nome falhar, mas o ping do endereço IP do nó for bem-sucedido, há um problema de resolução de nome. Contate o administrador da rede para obter assistência.

    Os erros de TCP/IP causados por endereço IP ou máscara de sub-rede incorreto(a) são geralmente registrados no log do sistema. Use Visualizar eventos para verificar se há esse tipo de erro no log do sistema.

    Mesmo que não haja erros de TCP/IP no log do sistema, verifique as configurações de TCP/IP para confirmar se estão corretas clicando em Iniciar, em Executar e digitando ipconfig /all. Verifique se o endereço IP e a máscara de sub-rede listados são os valores corretos para o computador. Se você não souber os valores de endereço IP e máscara de sub-rede corretos para o computador, pergunte ao administrador da rede.

    Verifique as ligações e a prioridade do adaptador de rede. O(s) adaptador(es) de rede pública devem ser os primeiros. Em seguida, os adaptadores de rede privada.

    Consulte também: TCP/IP
  • As conexões de rede do sistema não estão funcionando. Se a seguinte mensagem de erro for exibida na árvore do Assistente para criar novo cluster de servidor, as conexões de rede podem não estar em funcionamento:

    "Aviso: O sistema não está conectado a todas as redes de cluster definidas."
  • Verifique se as conexões de rede estão habilitadas. Caso contrário, o Serviço de cluster não conseguirá detectá-las e utilizá-las.

    Para verificar as configurações de rede:

    1. Abra Conexões de rede no Painel de controle.
    2. Clique duas vezes na conexão a ser verificada.
    3. Na guia Geral, verifique o status da conexão. Se a conexão não tiver sido iniciada, faça isso.

    Clique em Analisar novamente no Assistente para criar novo cluster de servidor para que as alterações sejam detectadas.

    Consulte também: TCP/IP
  • Você não está usando um endereço IP válido.
  • Obtenha um endereço IP estático para o cluster. Você não pode usar o DHCP para atribuir esse endereço.

    Cada adaptador de rede em cada nó de cluster também precisa de um endereço IP. Atribua um endereço IP estático a cada adaptador. Os endereços de cada par vinculado de adaptadores de rede (vinculados nó a nó) devem estar na mesma sub-rede.

    Se os nós do cluster utilizarem DHCP para obter endereços IP que não são do cluster, no prompt de comando, use o comando ipconfig para verificar se o endereço IP primário para as redes em questão é válido.

    Use o comando ping para confirmar se há conectividade IP com o endereço de cluster e se o endereço IP foi atribuído à rede correta. Se o teste de ping falhar, não há conectividade de rede básica.

    Se você tiver feito alguma alteração, reinicie o Assistente para criar novo cluster de servidor. Você deve reiniciar o assistente para que as alterações sejam detectadas.

    Consulte também: Gerenciar redes
  • Você não tem a conta de domínio correta nem os direitos de usuário apropriados.
  • Verifique se está atendendo aos seguintes requisitos:
    • Para criar um cluster, faça logon com uma conta de domínio que seja membro do grupo Administradores local em cada nó, e cada nó deve ser membro desse domínio.
    • Você pode administrar o Serviço de cluster usando um domínio ou uma conta local; porém, outros nós só podem ser incluídos em um cluster com uso de uma conta de domínio.

    Se você fizer alguma alteração de conta ou direito de usuário, clique em Analisar novamente no Assistente para criar novo cluster de servidor para que as alterações sejam detectadas.

    Consulte também: Segurança
  • O sistema não atende aos requisitos mínimos de um cluster.
  • Verifique se todos os requisitos, incluindo os de hardware, configuração do software do sistema operacional, rede e disco, estão sendo atendidos.

    Consulte também: Planejando e preparando-se para instalação de clusters
  • Os nós de cluster estão em domínios separados ou não estão em um domínio.
  • Todos os nós de cluster devem ser membros ou controladores de domínio do mesmo domínio e devem usar a mesma conta para o Serviço de cluster.

    Para verificar o nome de computador e o nome de domínio de um nó, clique com o botão direito do mouse em Meu Computador, clique em Propriedades e, em seguida, clique na guia Nome do computador. Verifique se cada nó de cluster pertence ao mesmo domínio. Use a mesma conta e senha de serviço em cada nó. Essa conta deve ter os seguintes direitos de usuário:

    • Fazer backup de arquivos e diretórios
    • Aumentar a prioridade de agendamento
    • Efetuar logon como um serviço

    Se você tiver feito alguma alteração, reinicie o Assistente para criar novo cluster de servidor. Você deve reiniciar o assistente para que as alterações sejam detectadas.
  • O nome do cluster não está online.
  • Para verificar se o nome do cluster está online:

    1. No primeiro nó, abra o Administrador de cluster clicando em Iniciar, em Executar e digitando CluAdmin.
    2. Abra Grupos, clique em Grupo de clusters e verifique o status de Nome do cluster.
    3. Se o status não for On-line, clique com o botão direito do mouse em Nome do cluster e, em seguida, clique em Colocar on-line.
    4. Reinicie o Assistente para criar novo cluster de servidor. Você deve reiniciar o assistente para que as alterações sejam detectadas.

    Observação

    • Se o endereço de protocolo Internet (IP) não estiver online, o nome do cluster não ficará online. Verifique se o endereço IP está online antes de tentar colocar o nome do cluster online.
  • O Serviço de cluster não está funcionando no primeiro nó.
  • Confirme se o Serviço de cluster está funcionando no primeiro nó e se todos os recursos dentro do grupo de clusters estão online antes de tentar instalar outro nó.

    Para confirmar se o Serviço de cluster foi iniciado:

    1. No primeiro nó, abra Gerenciamento do computador.
    2. Clique duas vezes em Serviços e aplicativos.
    3. Clique em Serviços.
    4. No painel de detalhes, localize a entrada Serviço de cluster e verifique a coluna Status. Se o serviço não estiver iniciado, clique nele com o botão direito do mouse, em seguida, clique em Iniciar.
    5. Reinicie o Assistente para criar novo cluster de servidor. É necessário reiniciar o assistente para que as alterações sejam detectadas.

    Se o Serviço de cluster não tiver sido iniciado, revise os registros no log de eventos para ver o motivo.

Durante a criação do cluster, os recursos de disco físico não são criados automaticamente para discos de cluster.

Causa: Geralmente, quando você cria um cluster, os recursos de disco físico são criados automaticamente para discos de cluster que utilizam letras de unidade. No entanto, se os discos de cluster utilizarem pontos de montagem, os recursos de disco físico não serão criados automaticamente para esses discos.

Solução: Você precisa criar manualmente os recursos de discos de cluster que utilizam pontos de montagem.

Para obter mais informações, consulte Lista de verificação: Instalando um recurso de disco físico.

Depois de configurar um novo cluster, o Administrador de cluster não consegue conectar-se com ele.

Causa: O novo cluster recebeu um nome que corresponde a um objeto de computador já existente no serviço de diretório do Active Directory.

Solução: Determine se deseja que o recurso de nome de rede do cluster use a autenticação Kerberos. Se for o caso, execute os seguintes procedimentos:

  1. Usando a linha de comando, coloque offline o recurso de nome de rede do cluster.
  2. Usando a linha de comando, habilite a autenticação Kerberos para o recurso de nome de rede.
  3. Analise as permissões no objeto de computador correspondente no Active Directory e verifique se a conta de usuário do Serviço de cluster tem acesso a esse objeto.
  4. Usando a linha de comando, coloque online o recurso de nome de rede do cluster.

Como alternativa, se você optar por não utilizar a autenticação Kerberos para o recurso de nome de rede, exclua o objeto de computador correspondente no Active Directory. Antes disso, assegure-se primeiro de que o objeto de computador não seja exigido em outro local pela instalação.

Para obter mais informações, consulte os artigos 307532 e 302389 na Microsoft Knowledge Base. (http://www.microsoft.com/) Consulte também Recurso de cluster e Localizando informações de diretório.


Acessibilidade para portadores de deficiência física

A Microsoft tem o compromisso de tornar seus produtos e serviços mais fáceis para o uso de todos. Este tópico fornece links para informações sobre recursos e serviços que tornam os produtos da família Windows Server 2003 mais acessíveis a portadores de deficiências.

Observação

  • As informações contidas neste tópico aplicam-se somente aos usuários que obtiveram licença para os produtos Microsoft nos Estados Unidos. Se você adquiriu este produto fora dos Estados Unidos, seu pacote conterá um folheto de informações sobre a subsidiária que lista os endereços e os números de telefone dos serviços de suporte da Microsoft. Você pode contatar uma subsidiária para saber se os tipos de produtos e serviços descritos neste tópico estão disponíveis em sua área.

As fontes de informações a seguir podem ajudá-lo a aprender sobre os recursos e serviços de acessibilidade:

  • Para saber mais sobre os produtos Microsoft disponíveis para portadores de deficiência física, consulte as informações sobre acessibilidade no site da Microsoft (http://www.microsoft.com).
  • Para obter informações detalhadas sobre os recursos e as opções de acessibilidade, consulte Ajuda das opções de acessibilidade.
  • Para obter mais informações sobre a utilização de atalhos do teclado no Centro de ajuda e suporte, consulte Usando os atalhos do teclado de Ajuda e suporte.
  • Para obter mais informações sobre como usar atalhos do teclado no Console de Gerenciamento Microsoft (MMC), consulte Acessibilidade para MMC.

Além disso, os tópicos a seguir fornecem informações básicas sobre recursos e opções de acessibilidade.

  • Recursos e opções de acessibilidade
  • Obtendo mais informações sobre acessibilidade

Observação

  • XOX


Recursos e opções de acessibilidade

Os produtos da família Windows Server 2003 incluem vários recursos de acessibilidade que podem melhorar as configurações de vídeo, som, mouse e teclado para usuários com deficiências visuais, motoras ou auditivas. Muitos desses recursos são igualmente úteis para pessoas não portadoras de deficiências.

Para obter informações detalhadas sobre os recursos e as opções de acessibilidade, consulte Ajuda das opções de acessibilidade.

  • Recursos de acessibilidade
  • Configurando opções de acessibilidade
  • Usando o teclado para mover o ponteiro do mouse

Observação

  • XOX

Para obter links para outras informações sobre recursos de acessibilidade, consulte Acessibilidade para portadores de deficiência física.


Recursos de acessibilidade

Os produtos da família Windows Server 2003 incluem os seguintes utilitários que ajudam a atender às suas necessidades de visão, audição ou mobilidade:

  • Lente de aumento. Amplia uma parte da tela para facilitar a visualização.
  • Narrator. Lê as informações na tela, incluindo nomes de caixas de diálogo, menus e conteúdo. O Narrator fornece um nível mínimo de acessibilidade de modo que os usuários portadores de deficiência visual possam interagir com produtos da família Windows Server 2003 durante a configuração ou em situações de emergência.

    Observações

    • O Narrator só está disponível em inglês norte-americano.
    • O Narrator requer o serviço Áudio do Windows, que por padrão tem o Tipo de Inicialização definido como Desabilitado em computadores executando Windows Server 2003, Web Edition; Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition. Para usar o Narrator, verifique se o serviço Áudio do Windows está ativado e defina o Tipo de inicialização como Automático. Para obter mais informações, consulte Configurações padrão para serviços.
  • Teclado virtual. Permite que um dispositivo apontador, como um mouse ou um dispositivo de entrada de tecla, digite em um teclado exibido na tela. O Teclado virtual é compatível com vários teclados e configurações de teclado, mas não com todos.

Os produtos da família Windows Server 2003 também oferecem opções personalizáveis para usuários com deficiências visuais, motoras ou auditivas:

  • Esquemas de cores da área de trabalho em alto contraste. Fornecem outras formas de alterar as cores e os tamanhos de fonte na tela.
  • Esquemas de som. Fornecem comentários sonoros úteis para eventos de tela importantes, como a abertura e o fechamento de janelas.
  • Esquemas de ponteiro de mouse de alta visibilidade. Fornecem mais opções para ajudar a controlar o ponteiro visualmente.

Para obter links para outras informações sobre recursos de acessibilidade, consulte Acessibilidade para portadores de deficiência física.


Configurando opções de acessibilidade

Você pode configurar opções de acessibilidade em produtos da família Windows Server 2003 de várias maneiras, visando atender a necessidades visuais, auditivas ou motoras. Os recursos de acessibilidade são instalados no computador por padrão.

Você pode configurar rapidamente as opções de acessibilidade usando o Assistente de acessibilidade. Esse assistente indaga sobre as suas necessidades de acessibilidade e define automaticamente as configurações para você. Uma outra alternativa é abrir as Opções de acessibilidade no Painel de controle e personalizar diretamente as funções de teclado, vídeo e mouse.

Observação

Se você estiver usando um dispositivo de entrada que não seja um mouse, em vez de clicar, execute a ação apropriada para executar comandos ou selecionar itens.

Para definir as opções de acessibilidade usando o Assistente de acessibilidade

  1. Abra o Assistente de acessibilidade.
  2. Siga as instruções que aparecerem na tela.

Observação

  • XOX

Para habilitar ou configurar as opções de acessibilidade usando o Painel de controle

  1. Abra Opções de acessibilidade.

Observação

  • XOX

Você pode habilitar e desabilitar alguns recursos de acessibilidade usando combinações de teclado, independentemente desses recursos estarem habilitados ou não. Quando você usa uma das combinações de teclas a seguir, o computador responde com avisos sonoros (bips) e visuais (caixas de diálogo) que indicam se a função de acessibilidade está habilitada ou desabilitada.

Para | Pressione
Habilitar e desabilitar teclas de filtragem | SHIFT DIREITA por oito segundos
Habilitar e desabilitar o alto contraste | ALT ESQUERDA+SHIFT ESQUERDA+PRINT SCREEN
Habilitar e desabilitar teclas para mouse | ALT ESQUERDA+SHIFT ESQUERDA+NUM LOCK
Habilitar e desabilitar teclas de aderência | SHIFT cinco vezes
Habilitar e desabilitar teclas de alternância | NUM LOCK por cinco segundos


Usando o teclado para mover o ponteiro do mouse

Caso tenha dificuldades para usar o mouse, você poderá alterar as configurações das teclas para mouse e usar o teclado numérico para mover o ponteiro do mouse. Utilize o Assistente de acessibilidade ou o procedimento a seguir para definir esta opção no Painel de controle.

Para ativar as teclas para mouse

  1. XOX
  2. Na guia Mouse, marque a caixa de seleção Usar as teclas para mouse.

A ilustração a seguir mostra quais teclas devem ser utilizadas para replicar as ações do mouse.

Ilustração de teclas para mouse

Observação

  • XOX


Obtendo mais informações sobre acessibilidade

Para obter informações detalhadas sobre os recursos e as opções de acessibilidade, consulte Ajuda das opções de acessibilidade.

Para obter links para outras informações sobre recursos de acessibilidade, consulte Acessibilidade para portadores de deficiência física.

Para obter informações adicionais, consulte:

  • Documentação em formatos mais acessíveis
  • Download de observações e utilitários de acessibilidade
  • Outros produtos e serviços de acessibilidade

Observação

  • XOX


Documentação em formatos mais acessíveis

A documentação de muitos produtos Microsoft está disponível em formatos alternativos. Caso tenha dificuldade em ler ou manusear a documentação impressa, você poderá obter diversas publicações da Microsoft. Consulte as informações sobre acessibilidade no site da Microsoft (http://www.microsoft.com).

Você também pode obter publicações da Microsoft através da Recording for the Blind & Dyslexic, Inc. A RFB&D distribui esses documentos para os associados qualificados e registrados em seus serviços de distribuição, como fitas cassetes ou disquetes. A coleção da RFB&D contém mais de 80.000 títulos, incluindo documentação e manuais de produtos Microsoft publicados pela Microsoft Press.

Para obter mais informações, contate a Recording for the Blind & Dyslexic em:

Recording for the Blind & Dyslexic, Inc.
20 Roszel Road
Princeton, NJ 08540
Telefone: (800) 803-7201 (nos Estados Unidos e no Canadá) ou (609) 452-0606

Site da Recording for the Blind & Dyslexic

Observação

  • Os endereços da Web podem ser alterados; portanto, você talvez não consiga se conectar ao site ou sites da Web mencionados aqui.


Download de observações e utilitários de acessibilidade

Se tiver um modem ou outro tipo de conexão de rede, você poderá exibir ou baixar informações sobre acessibilidade a partir dos seguintes serviços de rede:

  • Informações sobre acessibilidade no site da Microsoft (http://www.microsoft.com).
    • .
  • Servidor da Internet da Microsoft em ftp.microsoft.com.

    Abra a pasta /Softlib e use os arquivos leiame ou índice para informar-se sobre o site. No índice, procure palavras como "personalizando" e "deficiências". Escolha um arquivo e localize-o na pasta /Softlib/Mslfiles. No disco rígido, crie uma pasta, em seguida, execute o arquivo escolhido da localidade no momento. Siga as instruções para descompactar o arquivo na pasta criada.


Outros produtos e serviços de acessibilidade

Outros produtos, serviços e recursos para pessoas com deficiências são disponibilizados pela Microsoft e por outras organizações.

A Microsoft fornece um catálogo de ferramentas de acessibilidade que você pode usar com os sistemas operacionais Microsoft, inclusive os sistemas operacionais da família Windows Server 2003. Para obter esse catálogo, consulte as informações sobre acessibilidade no site da Microsoft. (http://www.microsoft.com)

Para obter informações sobre produtos e serviços do sistema operacional Macintosh para portadores de deficiências, consulte o site da Apple Computer.

O Trace R&D Center na University of Wisconsin-Madison mantém um site com diversos recursos para portadores de deficiências e desenvolvedores de tecnologia de assistência. Para obter informações, contate:

Trace R&D Center
University of Wisconsin-Madison
5901 Research Park Boulevard
Madison, WI 53719-1252

Telefone: (608) 262-6966
TTY/TDD: (608) 263-5408
Fax: (608) 262-8848

site do Trace Center

Os endereços da Web podem ser alterados; portanto, você talvez não consiga se conectar ao site ou sites da Web mencionados aqui.


Escolhendo os componentes a serem instalados

A família de produtos Windows Server 2003 inclui uma grande variedade de componentes principais, além de várias ferramentas administrativas, com instalação automática. Além disso, você pode escolher vários componentes opcionais que ampliam a funcionalidade do servidor. Esses componentes podem ser instalados após a instalação inicial. Outra forma para instalar componentes, utilize Gerenciar o servidor, através do qual é possível especificar uma função de servidor, como um servidor de impressão, em vez de selecionar os componentes individuais necessários à função de tal servidor.

Para obter instruções sobre como instalar componentes do Windows usando Adicionar ou remover programas no Painel de controle, consulte Adicionar ou remover um componente do Windows. Para obter informações sobre Gerenciar o servidor, que inclui o Assistente para configurar o servidor, consulte Configurando funções para o servidor.

Escolher mais componentes significa fornecer mais possibilidades ao servidor. Porém, escolha somente os componentes necessários, já que cada componente requer espaço em disco adicional. A tabela a seguir e a lista subseqüente ajudarão na escolha dos componentes que serão necessários à instalação.

Funções de servidor e componentes de software associados

Função do servidor | Possíveis componentes
DHCP, DNS e/ou servidor WINS (em uma rede TCP/IP) | Protocolo de configuração dinâmica de hosts (DHCP), sistema de nomes de domínios (DNS) e/ou serviço de cadastramento na Internet do Windows (WINS), todos incluídos nos Serviços de rede
Administração centralizada de redes | Ferramentas de gerenciamento e monitoração Serviços de instalação remota Terminal Server; Licenciamento do Terminal Server Observe que a área de trabalho remota para administração (anteriormente conhecida como serviços de terminal no Modo de Administração Remota) foi inserida em produtos da família Windows Server 2003 e não precisa ser instalada como um componente.
Autenticação e comunicação segura | Serviço de autenticação da Internet (parte dos serviços de rede) Serviços de certificados Atualizar certificados raiz
Servidor de arquivos | Serviço de indexação Armazenamento remoto Outros serviços de arquivos e impressão de rede (suporte a sistemas operacionais Macintosh e UNIX)
Servidor de fax ou de impressão | Serviços de fax Outros serviços de arquivos e impressão de rede (suporte a sistemas operacionais Macintosh e UNIX)
Servidor de aplicativos, servidor da Internet (Web) | Terminal Server; Licenciamento do Terminal Server Serviços de Informações da Internet (parte de Servidor de aplicativo) ASP .NET (parte do servidor de aplicativos) Serviço de enfileiramento de mensagens (parte de Servidor de aplicativo) Serviços UDDI O Microsoft .NET Framework foi inserido em todos os produtos da família Windows Server 2003, exceto nas versões de 64 bits. Para obter informações sobre componentes da Web usados com freqüência com o Microsoft .NET Framework, consulte "Servidor de aplicativos" na lista a seguir.
Suporte a email e comunicação, incluindo acesso dial-up | Serviço de protocolo de agência de correio versão 3 (POP3) (parte dos serviços de email) , serviço de protocolo de transferência de correio simples (SMTP) (parte dos serviços de email) Serviços de ponto de conexão (parte das ferramentas de gerenciamento e monitoração) Kit de administração do gerenciador de conexões (parte das ferramentas de gerenciamento e monitoração) Observe que o serviço Roteamento e acesso remoto foi inserido em produtos da família Windows Server 2003 e não precisa mais ser instalado como um componente.
Comunicações multimídia | Windows Media Services
Suporte a vários sistemas operacionais cliente | Outros serviços de arquivos e impressão de rede (suporte a sistemas operacionais Macintosh e UNIX). Consulte também "Administração centralizada de redes", anteriormente nesta tabela.

A listagem a seguir descreve os componentes da tabela anterior e todos os outros componentes que podem ser instalados.

Acessórios e utilitários
Inclui o Assistente de acessibilidade, com acessórios da área de trabalho, como o WordPad, o Paint e a Calculadora, e os acessórios de comunicações e mídia, como o Hyperterminal e o Media Player. Para selecionar itens individuais no Assistente de componentes do Windows, clique em Detalhes e selecione na lista.
Servidor de aplicativos
Inclui Serviços de Informações da Internet (IIS), ASP .NET, enfileiramento de mensagens e componentes relacionados, para fornecer uma plataforma unificada para Web na qual é possível executar aplicativos da Web de classe empresarial.

A Microsoft .NET Framework está inserida em todos os produtos da família Windows Server 2003, exceto nas versões de 64 bits. Se você planeja usar a Microsoft .NET Framework com ASP .NET, instale IIS, ASP .NET e quaisquer outros componentes (como o Enfileiramento de mensagens) que fornecem os serviços dos quais você precisa.

O IIS também inclui o protocolo de transferência de notícias de rede (NNTP), o protocolo de transferência de arquivo (FTP) e o protocolo de transferência de correio simples (SMTP).

Serviços de certificados
Fornece serviços personalizáveis para emissão e gerenciamento de certificados usados em sistemas de segurança de software que empregam tecnologia de chave pública. Os certificados podem facilitar o fornecimento de email seguro, a autenticação baseada na Web, a autenticação de cartões inteligentes e outras formas de segurança. Para obter informações sobre autenticação de usuários da rede dial-up, consulte Serviços de rede, posteriormente nesta lista.
Serviços de email
Inclui o protocolo de agência de correio versão 3 (POP3) e o protocolo de transferência de correio simples (SMTP). Você pode usar o serviço POP3 para armazenar e gerenciar contas de email no servidor de correio.
Serviços de fax
Oferece suporte ao envio e recebimento de faxes.

XOX

Serviço de indexação
Oferece funções de indexação para documentos armazenados em disco, permitindo a realização de pesquisas rápidas em textos completos.
Ferramentas de gerenciamento e monitoração
Fornece ferramentas para monitoração de rede, bem como ferramentas para administração e monitoração de comunicações, incluindo suporte ao desenvolvimento de discadores cliente personalizados para usuários remotos e suporte à implementação de catálogos telefônicos que podem ser atualizados automaticamente a partir de um servidor central. Além disso, inclui o protocolo de gerenciamento de rede simples (SNMP) e o provedor SNMP de Windows Management Instrumentation (WMI).
Serviços de rede
Fornece importante suporte a rede, incluindo os itens na lista a seguir. Para selecionar itens individuais no Assistente de componentes do Windows, clique em Detalhes e selecione na lista.

Para obter informações sobre como monitorar redes, consulte "Ferramentas de gerenciamento e monitoramento", anteriormente nesta lista. Para obter informações detalhadas sobre os serviços nesta lista, consulte Gerenciando os principais serviços de rede e Serviço de autenticação da Internet.

  • Sistema de nomes de domínios (DNS). Fornece o serviço de resolução de nomes necessário ao Active Directory. O DNS também é o serviço geralmente usado por clientes que executam o Windows 2000, o Windows XP e os produtos da família Windows Server 2003. Com a resolução de nomes, os usuários podem acessar servidores por nome, em vez usarem endereços IP difíceis de serem reconhecidos e lembrados.
  • Protocolo de configuração dinâmica de hosts (DHCP). Fornece ao servidor a capacidade de atribuir endereços IP dinamicamente aos dispositivos de rede. Normalmente, esses dispositivos incluem servidores e computadores de estação de trabalho, mas também podem incluir outros dispositivos, como impressoras e scanners. Com o DHCP, não é preciso definir e manter endereços IP estáticos em nenhum desses dispositivos, exceto para servidores de intranet que fornecem os serviços DHCP, DNS e/ou WINS.
  • Serviços de autenticação da Internet (IAS). Executa autenticação, autorização e estatísticas para usuários de rede dial-up eVPN. O IAS fornece suporte ao protocolo RADIUS.
  • RPC sobre Proxy HTTP. Fornece suporte a chamada de procedimento remoto (RPC) e modelo de objeto componente distribuído (DCOM) sobre HTTP, através de Serviços de Informações da Internet (IIS).
  • Serviços TCP/IP Simples. Fornece suporte a Character Generator, Daytime, Discard, Echo e Quote of the Day.
  • Serviço de cadastramento na Internet do Windows (WINS). Fornece o serviço de resolução de nomes geralmente utilizado por clientes que executam o Windows NT e versões anteriores dos sistemas operacionais Microsoft. Com a resolução de nomes, os usuários podem acessar servidores por nome, em vez usarem endereços IP difíceis de serem reconhecidos e lembrados.
Outros serviços de arquivos e impressão de rede
Oferece o seguinte:
  • Serviços de arquivos para o sistema operacional Macintosh.
  • Serviços de impressão para o sistema operacional Macintosh.

    XOX

  • Serviços de impressão para UNIX.
Serviços de instalação remota
Oferece serviços que podem ser usados para criar imagens de instalações de sistemas operacionais ou mesmo de configurações completas de computadores, incluindo configurações de área de trabalho e aplicativos. Depois, você pode disponibilizar essas imagens aos usuários em computadores clientes. Os clientes de destino devem oferecer suporte a inicialização remota com a ROM do ambiente Pré-Boot Execution (PXE) ou devem ser iniciados com um disquete de inicialização remota. No servidor, você precisará de uma partição separada para os serviços de instalação remota. Para obter mais informações, consulte Considerações ao planejar partições de disco.
Armazenamento remoto
Fornece uma extensão para o espaço em disco tornando a mídia removível (fitas, por exemplo) mais acessível. Raramente, os dados usados podem ser transferidos de forma automática para a fita e recuperados quando necessário.
Terminal Server
Oferece a capacidade de executar aplicativos cliente no servidor, enquanto o software cliente leve atua como emulador de terminal no cliente. Cada usuário vê uma sessão individual, exibida como uma área de trabalho, e cada sessão é gerenciada pelo servidor, independentemente de qualquer outra sessão de cliente. Se instalar o Terminal Server, você também deverá instalar o Licenciamento do Terminal Server em pelo menos um computador (não necessariamente no computador onde o Terminal Server for instalado). No entanto, há um período de cortesia de 120 dias durante o qual você pode usar o Terminal Server mesmo não tendo configurado servidores de licenças e não tendo instalado pacotes de chaves de licença de cliente.
Licenciamento do Terminal Server
Fornece um serviço de licenciamento que permite baixar, emitir e controlar licenças de clientes do Terminal Server. Se instalar o Terminal Server, você também deverá instalar o Licenciamento do Terminal Server em pelo menos um computador (não necessariamente no computador onde o Terminal Server for instalado). No entanto, há um período de cortesia de 120 dias durante o qual você pode usar o Terminal Server mesmo não tendo configurado servidores de licenças e não tendo instalado pacotes de chaves de licença de cliente.

Para habilitar um servidor de licenças rapidamente, instale-o em um computador com acesso à Internet.

Durante a instalação do Licenciamento do Terminal Server, você pode optar por um dos dois tipos de servidor de licença: servidor de licenças corporativo (o padrão) ou servidor de licenças de domínio. A orientação básica é selecionar o servidor de licenças corporativo, a menos que você esteja fazendo a instalação em um grupo de trabalho ou em um domínio em que todos os controladores de domínio executam o Windows NT 4.0. Pata obter mais informações, consulte Licenciamento do Terminal Server.

Serviços UDDI
Oferece suporte à publicação e à localização de informações sobre serviços da Web, com base na especificação da indústria denominada UDDI. Com os serviços UDDI, os desenvolvedores corporativos podem localizar, compartilhar e reutilizar serviços da Web de forma eficiente através de suas ferramentas de desenvolvimento.

Os Serviços UDDI não estão incluídos no Windows Server 2003, Web Edition. Além disso, o Windows Server 2003, Standard Edition fornece suporte apenas a instalações autônomas dos Serviços UDDI. O suporte a instalação distribuída está disponível com Windows Server 2003, Enterprise Edition e Windows Server 2003, Datacenter Edition. Em uma instalação autônoma dos Serviços UDDI, o componente de servidor Web UDDI e o componente de banco de dados UDDI são instalados em um único servidor. Em uma instalação distribuída, os componentes UDDI são distribuídos em vários servidores.

Para obter mais informações sobre o Windows Server 2003, Web Edition, consulte Visão geral sobre o Windows Server 2003, Web Edition.

Atualizar certificados raiz
Fornece um serviço que baixa automaticamente os certificados raiz mais atualizados para email seguro, navegação na Web e envio de softwares.
Windows Media Services
Fornece suporte a multimídia, permitindo gerenciar, enviar e arquivar conteúdo de mídia do Windows, incluindo fluxo de áudio e vídeo, pela intranet ou Internet.

XOX


Recursos de Internet e multimídia

Elemento gráfico do Microsoft Windows

Recursos da Internet

Para obter links para mais informações sobre os recursos desta versão, consulte Novos recursos.

Esta seção aborda:

  • Serviços e recursos da Internet
  • Recursos de colaboração