Atualização dos Serviços de Implantação do Windows

Você pode usar os Serviços de Implantação do Microsoft® Windows® para instalar o sistema operacional Windows® em um arquivo de Imagem do Windows (WIM). Os Serviços de Implantação do Windows facilitam a configuração básica, incluindo:

  • Particionamento e formatação da mídia física.

  • Instalação do sistema operacional e tarefas de pós-configuração .

  • Simplificação da instalação.

  • Consistência no seu ambiente de computador.

Você também pode usar os Serviços de Implantação do Windows para reinstalar o sistema operacional nos computadores existentes.

Para obter mais informações sobre como implantar o sistema operacional Microsoft® Windows Vista™, consulte Windows Vista Recursos para Profissionais de TI (http://go.microsoft.com/fwlink/?LinkID=53518).

  • Visão geral da atualização dos Serviços de Implantação do Windows

  • Lista de verificação: instalar e desinstalar a atualização dos Serviços de Implantação do Windows

  • Lista de verificação: criar uma imagem de instalação personalizada

  • Instalar e desinstalar a atualização dos Serviços de Implantação do Windows

  • Configurar Serviços de Implantação do Windows

  • Gerenciar um servidor dos Serviços de Implantação do Windows

  • Gerenciar clientes dos Serviços de Implantação do Windows

  • Gerenciar imagens do Windows

  • Solução de problemas dos Serviços de Implantação do Windows

  • Recursos dos Serviços de Implantação do Windows


Visão geral da atualização dos Serviços de Implantação do Windows

Os Serviços de Implantação do Windows foram desenvolvidos para os administradores que são responsáveis pela implantação de novos computadores em médias e grandes organizações. Se você estiver instalando um pequeno número de computadores, consulte Implantando o Windows Vista (http://go.microsoft.com/fwlink/?LinkId=71130).

Os Serviços de Implantação do Windows permitem fazer o seguinte:

  • Gerenciar imagens e scripts de instalação autônoma.

  • Fornecer opções de instalação assistida e autônoma.

Os profissionais de TI que usam os Serviços de Implantação do Windows devem estar familiarizados com o seguinte:

  • Conceitos de serviços de diretório do Active Directory® e do protocolo de configuração dinâmica de hosts (DHCP).

  • Ambiente de Pré-instalação do Windows (Windows PE).

  • Ambiente de Execução de Pré-inicialização do Windows (PXE).

  • Formato de arquivo de Imagem (WIM) do Windows.

As seções a seguir descrevem os Serviços de Implantação do Windows, incluindo componentes de gerenciamento, servidor e cliente, requisitos de implantação e novos recursos.

  • Introdução aos Serviços de Implantação do Windows

  • Requisitos para os Serviços de Implantação do Windows

  • Novidades nos Serviços de Implantação do Windows

Introdução aos Serviços de Implantação do Windows

Os Serviços de Implantação do Windows incluem um servidor PXE e um servidor TFTP (Trivial File Transfer Protocol). Os Serviços de Implantação do Windows também incluem uma interface do cliente e um snap-in de gerenciamento.

Componentes de servidor

Os componentes de servidor incluem um servidor PXE e um servidor TFTP para inicialização de rede em um cliente, com a intenção de carregar e eventualmente instalar um sistema operacional. Além disso, inclui uma pasta compartilhada e um repositório de imagens que contém imagens de inicialização, imagens de instalação e arquivos que podem ser necessários especificamente para a inicialização da rede.

Componentes de cliente

Os componentes de cliente incluem uma interface gráfica de usuário (GUI) executada no Windows PE e que se comunica com os componentes de servidor para selecionar e instalar uma imagem do sistema operacional.

Componentes de gerenciamento

Os componentes de gerenciamento incluem o snap-in Console de Gerenciamento Microsoft (MMC) do Gerenciamento dos Serviços de Implantação do Windows e algumas ferramentas de linha de comando que você pode usar para gerenciar o servidor, as imagens do sistema operacional e as contas de computadores clientes.

Benefícios dos Serviços de Implantação do Windows

Os Serviços de Implantação do Windows podem beneficiar empresas que estão implantando sistemas operacionais Windows das seguintes maneiras:

  • Reduz os custos associados a processos de instalação manual ineficientes.

  • Melhora a consistência do desempenho do sistema operacional e dos aplicativos.

  • Reduz o número de chamadas ao suporte técnico quando comparados com a instalação manual.

  • Reduz o tempo necessário para o usuário instalar o novo sistema operacional e os aplicativos comuns.

Ambiente de pré-instalação do Windows

Os Serviços de Implantação do Windows usam o Ambiente de Pré-instalação do Windows (Windows PE) para os serviços de inicialização de cliente. O cliente dos Serviços de Implantação do Windows usa o Windows PE com o objetivo de fornecer um menu de fácil uso para imagens de instalação disponíveis e uma experiência de instalação consistente com a Instalação do Windows.

Requisitos para os Serviços de Implantação do Windows

Os Serviços de Implantação do Windows não têm requisitos explícitos de RAM ou de velocidade de CPU para computadores servidores ou clientes. O servidor dos Serviços de Implantação do Windows requer uma partição de sistema de arquivo NTFS para o armazenamento de imagens com espaço em disco suficiente para acomodar todas as imagens necessárias.

Requisitos do sistema operacional

Os sistemas operacionais a seguir dão suporte aos Serviços de Implantação do Windows:

  • Windows Server "Longhorn"

  • Windows Server 2003 com Service Pack 1 (SP1)

    Observação

    O pacote de atualização dos Serviços de Implantação do Windows atualmente está disponível para o Windows Server 2003 SP1. Os Serviços de Instalações Remotas (RIS) devem estar instalados, mas não precisam estar configurados.

  • Windows Server 2003 com Service Pack 2 (SP2)

    Observação

    O Windows Server 2003 com SP2 instala os Serviços de Implantação do Windows por padrão se os RIS já estiverem instalados.

Requisitos de ambiente

Os Serviços de Implantação do Windows devem ser implantados em um ambiente que atenda aos seguintes requisitos:

  • O servidor dos Serviços de Implantação do Windows deve ser membro de um domínio do Active Directory.

  • O DHCP é necessário para tirar vantagem de computadores capazes de inicializar o PXE.

Novidades nos Serviços de Implantação do Windows

Os Serviços de Implantação do Windows para Windows Server "Longhorn" incluem várias modificações nos recursos dos Serviços de Instalação Remota (RIS). Essas modificações dão suporte à implantação dos sistemas operacionais Windows Vista e Windows Server "Longhorn" da Microsoft. As alterações incluem:

  • Suporte nativo para o Windows PE como um sistema operacional inicializável.

  • Suporte nativo para o formato WIM.

  • Um componente de servidor PXE extensível e de alto desempenho.

  • Um novo formato de menu de inicialização para selecionar os sistemas operacionais de inicialização.

  • Uma nova interface de usuário gráfica (GUI) que você pode usar para selecionar e implantar imagens e gerenciar os servidores e clientes dos Serviços de Implantação do Windows.

Referências adicionais

  • Implantando o Windows Vista http://go.microsoft.com/fwlink/?LinkId=71130)


Lista de verificação: instalar e desinstalar a atualização dos Serviços de Implantação do Windows

As referências a seguir fornecem informações sobre como instalar e configurar corretamente os Serviços de Implantação do Windows para o seu ambiente.

Tarefa | Referência
Mais informações sobre os Serviços de Implantação do Windows. | Visão geral da atualização dos Serviços de Implantação do Windows
Instalar os Serviços de Implantação do Windows. | Instalar a atualização dos Serviços de Implantação do Windows
Configurar os Serviços de Implantação do Windows para o seu ambiente. | Configurar Serviços de Implantação do Windows
Adicionar o seu servidor ao snap-in dos Serviços de Implantação do Windows. | Adicionar um servidor ao snap-in dos Serviços de Implantação do Windows
Adicionar imagens ao seu servidor do Serviços de Implantação do Windows. | Adicionar uma imagem
Verificar ou definir as propriedades do seu servidor dos Serviços de Implantação do Windows. | Gerenciar propriedades do servidor
Configurar definições do cliente para os Serviços de Implantação do Windows. | Gerenciar clientes dos Serviços de Implantação do Windows


Lista de verificação: criar uma imagem de instalação personalizada

Você pode criar imagens personalizadas que contenham aplicativos comuns ao ambiente ou um grupo de usuários exclusivo. Além disso, pode automatizar aspectos da instalação e associar um ou mais pacotes de idioma a uma imagem, em vez de criar uma imagem separada para cada idioma.

Tarefa | Referência
Crie uma imagem de captura. | Criar uma imagem
Crie uma imagem de instalação personalizada para o seu ambiente. | Criar uma imagem
Modifique a imagem de instalação. | Modificar uma imagem
Crie um grupo de imagens para suas imagens personalizadas. | Grupos de imagens
Adicione a imagem ao servidor dos Serviços de Implantação do Windows. | Adicionar uma imagem
Habilite opções de instalação autônoma para a imagem. | Arquivos de instalação autônoma
Associe um ou mais pacotes de idiomas a uma imagem. | Pacotes de idioma


Instalar e desinstalar a atualização dos Serviços de Implantação do Windows

Você pode instalar a atualização dos Serviços de Implantação do Windows a partir do Windows Explorer ou em um prompt de comando. Para desinstalar a atualização dos Serviços de Implantação do Windows, use Adicionar ou Remover Programas no Painel de Controle.

  • Instalar a atualização dos Serviços de Implantação do Windows

  • Desinstalar a atualização dos Serviços de Implantação do Windows


Instalar a atualização dos Serviços de Implantação do Windows

Os Serviços de Implantação do Windows podem ser instalados com o uso do pacote de atualização em um servidor executando o Windows Server 2003 com Service Pack 1 (SP1) e com os Serviços de Instalação Remota (RIS) já instalado. RIS does not have to be configured for the update package to install. A atualização dos Serviços de Implantação do Windows é instalada por padrão como o Windows Server 2003 com Service Pack 2 (SP2).

  • Usando o Windows Explorer

  • Em um prompt de comando

Usando o Windows Explorer

Para instalar a atualização dos Serviços de Implantação do Windows usando o Windows Explorer

  1. Usando o Windows Explorer, navegue para localizar o pacote de atualização localmente ou em um compartilhamento de rede.

  2. Clique duas vezes em windows-deployment-services-update.exe referente à arquitetura do servidor e sistema operacional instalado para iniciar a instalação.

    Observação

    Se a página Aviso de Segurança aparecer, clique em Executar.

  3. Na página inicial do Assistente de Instalação de Atualização de Software, siga todas as recomendações e clique em Avançar para continuar.

  4. Na página Termos de Licença de Software da Microsoft, clique em Eu concordo e em Avançar.

  5. Na página de conclusão do Assistente de Instalação de Atualização de Software, clique em Concluir para reiniciar o computador.

    Observação

    Se não quiser reiniciar, clique em Não reiniciar agora antes de clicar em Concluir.

Considerações e referências adicionais

  • Para executar esse procedimento, você deve ser membro do grupo Operadores de Contas, do grupo Administradores do Domínio ou deve ter sido delegado com a autoridade apropriada.

  • Se o sistema que você está tentando atualizar não atender aos requisitos mínimos, uma página Falha na Instalação será apresentada. Se isso ocorrer, anote os motivos da falha, execute a ação corretiva apropriada e execute novamente o pacote de atualização.

  • Se o sistema que você está tentando atualizar não atender aos requisitos recomendados, uma página Aviso de Instalação será apresentada. Anote as recomendações e execute as ações corretivas recomendadas na conclusão da atualização. Clique em Avançar para continuar.

  • Instalar e desinstalar a atualização dos Serviços de Implantação do Windows

Em um prompt de comando

Para instalar a atualização dos Serviços de Implantação do Windows em um prompt de comando

  1. Altere a pasta que contém o pacote de atualização.

  2. Em um prompt de comando, digite windows-deployment-services-update /quiet /forcerestart, referente à arquitetura do computador e à arquitetura do sistema operacional.

Considerações e referências adicionais

  • Para executar esse procedimento, você deve ser membro do grupo Operadores de Contas, do grupo Administradores do Domínio ou deve ter sido delegado com a autoridade apropriada.

  • Instalar e desinstalar a atualização dos Serviços de Implantação do Windows

Opções de instalação da atualização dos Serviços de Implantação do Windows

Você pode usar essas opções de linha de comando para modificar o comportamento padrão da atualização de forma a adequá-lo ao seu cenário de instalação.

Opção | Finalidade
/help | Use na linha de comando para listar essas opções.
/quiet | Use quando não for necessário nenhuma interação e nenhuma informação exibida durante a instalação.
/passive | Use quando não for necessário nenhuma interação do usuário, mas quando você quiser que a barra de status monitore o progresso da instalação.
/norestart | Use para suprimir uma reinicialização após a instalação.
/forcerestart | Use quando quiser garantir uma reinicialização após a instalação.
/warnrestart[:<segundos>] | Use quando quiser ser avisado antes do computador reinicializar após a instalação. O padrão, se nenhum argumento for fornecido, é esperar 30 segundo antes de reiniciar.
/promptrestart | Use quando quiser ser avisado se uma reinicialização for necessária.
/overwriteoem | Use se quiser substituir os diretórios do fabricante de equipamentos originais (OEM) e excluir os arquivos existentes nos diretórios.
/nobackup | Use se você não quiser fazer o backup dos arquivos necessários para desinstalar os Serviços de Implantação do Windows.
/forceappsclose | Use quando quiser fechar outros aplicativos que podem impedir a reinicialização do computador.
/integrate:<caminho_completo> | Use para instalar as atualizações de software junto com os Serviços de Implantação do Windows.
/log:<caminho_completo> | Use para criar um arquivo de log no caminho especificado.


Desinstalar a atualização dos Serviços de Implantação do Windows

A Atualização dos Serviços de Implantação do Windows pode ser removida através de Adicionar ou Remover Programas no Painel de Controle. Quando os Serviços de Implantação do Windows são removidos, as configurações dos Serviços de Instalação Remota (RIS) são mantidas e todos os compartilhamentos, diretórios e imagens criados durante a configuração dos Serviços de Implantação do Windows permanecem intactas.

Para remover a Atualização dos Serviços de Implantação do Windows

  1. Clique em Iniciar, em Painel de Controle e em Adicionar ou Remover Programas.

  2. Selecione Atualização dos Serviços de Implantação do Windows para o Windows Server 2003.

  3. Clique em Remover.

  4. No Assistente de Remoção dos Serviços de Implantação do Windows , clique em Avançar.

  5. Na página Conclusão, clique em Concluir.
Observação

Clique em Não reiniciar agora antes de clicar em Concluir se não quiser reiniciar imediatamente depois de remover os Serviços de Implantação do Windows.

  1. Quando o computador reiniciar, a Atualização dos Serviços de Implantação do Windows será removida.

Considerações e referências adicionais

  • Para executar esse procedimento, você deve ser membro do grupo Operadores de Contas, do grupo Administradores do Domínio ou deve ter sido delegado com a autoridade apropriada.

  • Instalar e desinstalar a atualização dos Serviços de Implantação do Windows


Configurar Serviços de Implantação do Windows

Nesta seção:

  • Modos funcionais dos Serviços de Implantação do Windows

  • Configurar Serviços de Implantação do Windows

  • Configurar o DHCP para os Serviços de Implantação do Windows

Modos funcionais dos Serviços de Implantação do Windows

Os Serviços de Implantação do Windows dão suporte aos três modos de operação a seguir.

Modo herdado

O modo Herdado dos Serviços de Implantação do Windows é funcionalmente equivalente ao dos Serviços de Instalação Remota (RIS). Nesse modo, somente OSChooser será apresentado como o sistema operacional de inicialização e somente as imagens RISETUP e RIPREP serão suportadas. As novas ferramentas de Gerenciamento dos Serviços de Implantação do Windows não serão usadas e, portanto, os utilitários RIS herdados serão a única maneira de gerenciar o servidor. O modo Herdado dos Serviços de Implantação do Windows é obtido com a instalação da Atualização dos Serviços de Implantação do Windows, mas não com a configuração desses serviços por meio do assistente de configuração ou com o uso de WDSUTIL a partir de um prompt de comando. Apenas existe suporte para o modo Herdado no Windows Server 2003.

Modo misto

O modo Misto dos Serviços de Implantação do Windows descreve um estado do servidor que suporta o RIS herdado e a nova funcionalidade dos Serviços de Implantação do Windows. No modo misto, o menu OSChooser está disponível junto com imagens de inicialização do Windows PE. Nesse modo, o acesso aos tipos antigos de imagem (RISETUP e RIPREP) será possível por meio de OSChooser, e novas imagens no formato wim estarão disponíveis com o uso de uma imagem de inicialização do Windows PE (a imagem de inicialização do Windows Vista™ PE com o cliente dos Serviços de Implantação do Windows). Sob o ponto de vista do cliente, um menu de inicialização poderá ser selecionado no RIS ou no Windows Server® codinome "Longhorn" Windows PE. Sob o ponto de vista da capacidade de gerenciamento, um administrador usará ferramentas de gerenciamento herdadas para gerenciar imagens RISETUP e RIPREP e usará as novas ferramentas dos Serviços de Implantação do Windows para gerenciar o servidor e as imagens WIM. O modo Misto dos Serviços de Implantação do Windows só pode existir no Windows Server 2003, sendo obtido com a instalação da Atualização dos Serviços de Implantação do Windows em um servidor RIS anteriormente configurado, e, em seguida, com a configuração dos Serviços de Implantação do Windows usando o assistente de configuração ou o WDSUTIL em a partir de um prompt de comando.

Modo nativo

O modo Nativo dos Serviços de Implantação do Windows descreve um servidor dos Serviços de Implantação do Windows apenas com imagens de inicialização do Windows PE. Nesse modo, OSChooser não estará presente, e as imagens WIM serão o único tipo de imagem suportado a ser implantado para os clientes. O gerenciamento do servidor ocorrerá completamente a partir dos novos utilitários de gerenciamento dos Serviços de Implantação do Windows. O modo Nativo dos Serviços de Implantação do Windows pode existir no Windows Server 2003 e no Windows Server "Longhorn". No Windows Server "Longhorn", esse é o único modo suportado dos Serviços de Implantação do Windows. Para operação no modo nativo em um servidor que executa o Windows Server 2003, instale, mas não configure, o RIS; em seguida, instale e configure os Serviços de Implantação do Windows. Você também pode forçar a movimentação do servidor para o modo Nativo executando WDSUTIL /set-server /ForceNative.

Caminhos de atualização para os modos funcionais dos Serviços de Implantação do Windows

Funcionalidade | Sistema operacional | Etapas
Modo nativo: instale apenas novos WIMs. | Windows Server "Longhorn" | Instale e configure a função de servidor dos Serviços de Implantação do Windows.
Modo nativo: instale apenas novos WIMs. | Windows Server 2003 | Instale o RIS, mas não o configure. Instale e configure a Atualização dos Serviços de Implantação do Windows ou instale o SP2 e configure os Serviços de Implantação do Windows.
Modo nativo: instale apenas novos WIMs. | Windows Server 2003 | Remova a instalação existente do RIS. Instale o RIS, mas não o configure. Instale e configure a Atualização dos Serviços de Implantação do Windows ou instale o SP2 e configure os Serviços de Implantação do Windows.
Modo misto: instale os WIMs e as imagens RIS existentes. | Windows Server 2003 | Instale a Atualização dos Serviços de Implantação do Windows ou o SP2 no servidor RIS existente e configure os Serviços de Implantação do Windows.
Modo herdado: instale apenas imagens RIS existentes. | Windows Server 2003 | Instale, mas não configure, a Atualização dos Serviços de Implantação do Windows ou o SP2 no servidor RIS existente e não configure os Serviços de Implantação do Windows.

Configurar Serviços de Implantação do Windows

Você pode desempenhar a configuração inicial dos Serviços de Implantação do Windows usando um dos procedimentos a seguir:

  • Usando o Assistente de Configuração dos Serviços de Implantação do Windows.

  • Usando WDSUTIL a partir de uma linha de comando.

Para configurar os Serviços de Implantação do Windows usando o Assistente de Configuração dos Serviços de Implantação do Windows

  1. Para abrir o snap-in dos Serviços de Implantação do Windows, clique em Iniciar, Ferramentas Administrativas e Serviços de Implantação do Windows.

  2. No painel esquerdo do snap-in dos Serviços de Implantação do Windows, clique com o botão direito do mouse no servidor e clique em Configurar Servidor.

  3. Na Página de Boas-vindas do Assistente de Configuração dos Serviços de Implantação do Windows, verifique se o ambiente atende aos requisitos listados e clique em Avançar.

  4. Digite um caminho para a pasta de instalação remota e clique em Avançar.

  5. Se você optar por instalar os Serviços de Implantação do Windows na unidade do sistema, uma mensagem de aviso será exibida. Clique em Sim para continuar a instalação ou em Não para escolher um novo local de instalação (recomendado).

  6. Defina uma diretiva de resposta apropriada para o ambiente e clique em Concluir para finalizar a configuração.

  7. Na Página de Conclusão da Configuração dos Serviços de Implantação do Windows, você pode adicionar imagens ao servidor (padrão) ou desmarcar a opção Adicionar imagens ao servidor dos Serviços de Implantação do Windows agora para adicionar essas imagens posteriormente.

Considerações e referências adicionais

  • Se os clientes com base em x64 não detectarem imagens x64 no menu de inicialização, digite WDSUTIL /set-server /autodiscovery:yes em um prompt de comando.

  • Para executar esse procedimento, você deve ser membro do grupo Operadores de Contas, do grupo Administradores do Domínio ou deve ter sido delegado com a autoridade apropriada.

  • Atualização dos Serviços de Implantação do Windows

Para configurar os Serviços de Implantação do Windows a partir de um prompt de comando

  1. Clique em Iniciar, aponte para Todos os Programas, aponte para Acessórios, clique com o botão direito do mouse em Prompt de Comando e clique em Execução Privilegiada.

  2. No prompt de comando, digite: WDSUTIL /initialize-server /reminst:letra_da_unidade\nome_da_pasta, em que letra_da_unidade é o nome da unidade formatada para NTFS e nome_da_pasta é o nome do diretório no qual você deseja criar a pasta compartilhada, e pressione ENTER.

  3. Para definir a diretiva de resposta para atender a todos os clientes, digite: WDSUTIL /set-server /answerclients:all

    Observação

    Se você estiver instalando os Serviços de Implantação do Windows em um sistema com o Microsoft DHCP instalado, digite: WDSUTIL /set-server /usedhcpports:no /DHCPoption60:yes.

  4. Para adicionar uma imagem de inicialização, digite: WDSUTIL /add-image /imagefile:\\server\share\sources\boot.wim /imagetype:boot, em que caminho corresponde ao caminho completo para a imagem de inicialização.

  5. Para adicionar uma imagem de instalação, digite: WDSUTIL /add-image /imagefile:\\server\share\sources\install.wim /imagetype:install, no qual caminho corresponde ao caminho completo para a imagem de instalação.

Considerações e referências adicionais

  • Se os clientes com base em x64 não detectarem imagens x64 no menu de inicialização, digite WDSUTIL /set-server /autodiscovery:yes em um prompt de comando.

  • Para obter ajuda com WDSUTIL, digite WDSUTIL /? em um prompt de comando.

  • WDSUTIL, a ferramenta de gerenciamento de linha de comando dos Serviços de Implantação do Windows, requer privilégios elevados para ser executada.

  • Atualização dos Serviços de Implantação do Windows

Configurar o DHCP para os Serviços de Implantação do Windows

Os Serviços de Implantação do Windows requerem um servidor DHCP (Dynamic Host Configuration Protocol) ativo na rede. Os Serviços de Implantação do Windows dependem do PXE (Pre-Boot Execution Environment), que, por sua vez, depende do DHCP. Serão necessárias alterações na configuração do DHCP se os Serviços de Implantação do Windows e o DHCP estiverem instalados em um único servidor.

Opção 60 do DHCP

Se o Microsoft DHCP estiver instalado no mesmo computador físico dos Serviços de Implantação do Windows, o Assistente de Configuração dos Serviços de Implantação do Windows adicionará a marca opção 60 do DHCP, com a configuração de cliente PXE selecionada, a todos os escopos DHCP (como uma opção DHCP global). Isso é necessário para que um cliente PXE de inicialização possa ser notificado de que existe um servidor PXE de escuta na rede.

Configurando a opção 60 do DHCP

Se você adicionar o serviço DHCP a um servidor existente dos Serviços de Implantação do Windows, será necessário reconfigurar manualmente a opção 60 do DHCP. Existem dois procedimentos para a configuração dessa opção 60:

  • Configurando a opção 60 do DCHP com o uso do snap-in dos Serviços de Implantação do Windows.

  • Configurando a opção 60 do DHCP com o uso de WDSUTIL.

Para configurar a Opção 60 do DCHP usando o snap-in dos Serviços de Implantação do Windows

  1. Clique em Iniciar, Ferramentas Administrativas e Serviços de Implantação do Windows.

  2. No painel esquerdo do snap-in dos Serviços de Implantação do Windows, clique para expandir a lista Servidores.

  3. Clique com o botão direito do mouse no servidor e clique em Propriedades.

  4. Na página Propriedades do Servidor , clique na guia DHCP.

  5. Na página Opções DHCP, clique em Configurar Opção 60 do DHCP como 'PXEClient'.

Considerações e referências adicionais

  • Para executar esse procedimento, você deve ser membro do grupo Operadores de Contas, do grupo Administradores do Domínio ou deve ter sido delegado com a autoridade apropriada.

  • Atualização dos Serviços de Implantação do Windows

Para configurar a Opção 60 do DHCP com o uso de WDSUTIL

  1. Clique em Iniciar, Todos os Programas, Acessórios, clique com o botão direito do mouse em Prompt de Comando e clique em Execução Privilegiada.

  2. Em um prompt de comando, digite WDSUTIL /set-server /DHCPOption60:yes

Considerações e referências adicionais

  • WDSUTIL, a ferramenta de gerenciamento de linha de comando dos Serviços de Implantação do Windows, requer privilégios elevados para ser executada.

  • Atualização dos Serviços de Implantação do Windows

Porta 67

Se o serviço Microsoft DHCP estiver instalado no mesmo computador físico dos Serviços de Implantação do Windows, o Assistente de Configuração dos Serviços de Implantação do Windows configurará os Serviços de Implantação do Windows selecionando a opção Não escutar na porta 67. Isso é necessário para que os clientes de inicialização possam localizar o servidor DHCP na rede.

Configurando a porta 67

  • Se você adicionar o serviço DHCP a um servidor existente dos Serviços de Implantação do Windows, precisará reconfigurar a porta 67. Essa porta pode ser configurada com um dos dois procedimentos a seguir.

Para configurar a porta 67 usando o snap-in dos Serviços de Implantação do Windows

  1. No menu Iniciar, clique em Ferramentas Administrativas e em Serviços de Implantação do Windows.

  2. Clique para expandir a lista Servidores.

  3. Clique com o botão direito do mouse no servidor e clique em Propriedades.

  4. Na página Propriedades do Servidor, clique na guia DHCP.

  5. Na página Opções DHCP, clique em Não escutar na porta 67.

Considerações e referências adicionais

  • Para executar esse procedimento, você deve ser membro do grupo Operadores de Contas, do grupo Administradores do Domínio ou deve ter sido delegado com a autoridade apropriada.

  • Atualização dos Serviços de Implantação do Windows

Para configurar a porta 67 usando WDSUTIL

  1. Clique em Iniciar, aponte para Todos os Programas, aponte para Acessórios, clique com o botão direito do mouse em Prompt de Comando e clique em Execução Privilegiada.

  2. Em um prompt de comando, digite WDSUTIL /set-server /usedhcpports:no

Considerações e referências adicionais

  • WDSUTIL, a ferramenta de gerenciamento de linha de comando dos Serviços de Implantação do Windows, requer privilégios elevados para ser executada.

  • Atualização dos Serviços de Implantação do Windows


Gerenciar um servidor dos Serviços de Implantação do Windows

  • Adicionar um servidor ao snap-in dos Serviços de Implantação do Windows

  • Remover um servidor do snap-in dos Serviços de Implantação do Windows

  • Gerenciar propriedades do servidor


Adicionar um servidor ao snap-in dos Serviços de Implantação do Windows

O snap-in dos Serviços de Implantação do Windows fornece gerenciamento com base em console de todos os servidores dos Serviços de Implantação do Windows no seu ambiente. Para gerenciar os servidores dos Serviços de Implantação do Windows, adicione-os primeiramente ao snap-in dos Serviços de Implantação do Windows.

Para adicionar um servidor ao snap-in dos Serviços de Implantação do Windows

  1. Para abrir o snap-in dos Serviços de Implantação do Windows, clique em Iniciar, Ferramentas Administrativas e Serviços de Implantação do Windows.

  2. Clique com o botão direito do mouse no nó Servidores e em Adicionar Servidor.

  3. Na caixa de diálogo Adicionar Servidor, clique para selecionar o servidor a ser adicionado e selecione OK para continuar.

  4. Na caixa de diálogo Aviso de Adicionar Servidor, clique em Sim para adicionar o servidor.

  5. Ao sair do snap-in, clique em Sim para salvar as configurações.

Considerações e referências adicionais

  • Para executar esse procedimento, você deve ser membro do grupo Operadores de Contas, do grupo Administradores do Domínio ou deve ter sido delegado com a autoridade apropriada.

  • Gerenciar um servidor dos Serviços de Implantação do Windows


Remover um servidor do snap-in dos Serviços de Implantação do Windows

Você pode usar o procedimento a seguir para remover um servidor dos Serviços de Implantação do Windows do snap-in dos Serviços de Implantação do Windows.

Para remover um servidor do snap-in dos Serviços de Implantação do Windows

  1. Para abrir o snap-in dos Serviços de Implantação do Windows, clique em Iniciar, Ferramentas Administrativas e Serviços de Implantação do Windows.

  2. Clique para expandir a lista Servidores.

  3. Clique com o botão direito do mouse no servidor que você deseja remover do console.

  4. Clique em Remover Servidor.

Considerações e referências adicionais

  • Para executar esse procedimento, você deve ser membro do grupo Operadores de Contas, do grupo Administradores do Domínio ou deve ter sido delegado com a autoridade apropriada.

  • Gerenciar um servidor dos Serviços de Implantação do Windows


Gerenciar propriedades do servidor

Você pode usar a página Propriedades do Servidor de um servidor dos Serviços de Implantação do Windows para configurar diversos aspectos da operação do servidor.

  • Propriedades DHCP

  • Propriedades do servidor PXE

  • Propriedades gerais

  • Propriedades dos serviços de diretório

  • Propriedades de inicialização

  • Propriedades do cliente


Propriedades DHCP

As opções de configuração DHCP (Dynamic Host Configuration Protocol) dos Serviços de Implantação do Windows são configuradas na página Propriedades DHCP de cada servidor ou durante a configuração inicial usando o Assistente para Configuração dos Serviços de Implantação do Windows.

  • Configurar opção 60 do DCHP

  • Configurar porta 67

Configurando a opção 60 do DHCP

A configuração padrão dos Serviços de Implantação do Windows considera que o servidor Microsoft DHCP e o servidor dos Serviços de Implantação do Windows estejam em computadores físicos separados. Quando o DHCP e os Serviços de Implantação do Windows existem no mesmo computador, o DHCP deve informar ao computador cliente que há um servidor PXE escutando na rede, incluindo a marca de Opção 60 do DHCP no pacote Oferta do DHCP.

Para configurar a opção 60 do DCHP usando o snap-in dos Serviços de Implantação do Windows

  1. No menu Iniciar, clique em Ferramentas Administrativas e em Serviços de Implantação do Windows.

  2. Clique para expandir a lista Servidores.

  3. Clique com o botão direito do mouse no servidor e clique em Propriedades.

  4. Na página Propriedades do Servidor, clique na guia DHCP.

  5. Na página Opções DHCP, clique em Configurar Opção 60 do DHCP como 'PXEClient'.

Considerações e referências adicionais

  • Para executar esse procedimento, você deve ser membro do grupo Operadores de Contas, do grupo Administradores do Domínio ou deve ter sido delegado com a autoridade apropriada.

  • Gerenciar propriedades do servidor

Para configurar a opção 60 do DHCP com o uso de WDSUTIL

  • No prompt de comando, digite: WDSUTIL /set-server /DHCPoption60:yes

Considerações e referências adicionais

  • WDSUTIL, a ferramenta de gerenciamento de linha de comando dos Serviços de Implantação do Windows, requer privilégios elevados para ser executada.

  • Gerenciar propriedades do servidor

Configurando a porta 67

Como o DHCP escuta na porta 67 por padrão, quando os Serviços de Implantação do Windows e o DHCP existirem no mesmo computador, o servidor PXE dos Serviços de Implantação do Windows não conseguirá escutar na porta 67 para solicitações de inicialização do PXE de entrada.

Para configurar a porta 67 usando o snap-in dos Serviços de Implantação do Windows

  1. No menu Iniciar, selecione Ferramentas Administrativas e clique em Serviços de Implantação do Windows.

  2. Clique para expandir a lista Servidores.

  3. Clique com o botão direito do mouse no servidor e clique em Propriedades.

  4. Na página Propriedades do Servidor, clique na guia DHCP.

  5. Na página Opções DHCP, clique em Não escutar na porta 67.

Considerações e referências adicionais

  • Para executar esse procedimento, você deve ser membro do grupo Operadores de Contas, do grupo Administradores do Domínio ou deve ter sido delegado com a autoridade apropriada.

  • Gerenciar propriedades do servidor

Para configurar a porta 67 com o uso de WDSUTIL em um prompt de comando

  • No prompt de comando, digite: WDSUTIL /set-server /usedhcpports:no.

Considerações e referências adicionais

  • WDSUTIL, a ferramenta de gerenciamento de linha de comando dos Serviços de Implantação do Windows, requer privilégios elevados para ser executada.

  • Gerenciar propriedades do servidor

    Importante

    As opções Configurar Opção 60 do DHCP como PXEClient e Não escutar na porta 67 deverão ser selecionadas se o Microsoft DHCP e os Serviços de Implantação do Windows estiverem em execução no mesmo computador.


Propriedades do servidor PXE

As configurações do servidor PXE são definidas na guia Configurações da Resposta do PXE da página Propriedades do Servidor. Essas configurações determinam para quais clientes os Serviços de Implantação do Windows responde, qual ação é tomada ao responder a um cliente desconhecido e quanto tempo é necessário aguardar antes de responder a um cliente. É possível modificar as seguintes diretivas, conforme necessário:

  • Diretiva de resposta do PXE

  • Atraso da Resposta do PXE

Diretiva de resposta do PXE

Essa opção especifica se o servidor PXE dos Serviços de Implantação do Windows deve responder às solicitações PXE do cliente de entrada. Com essa opção selecionada, nenhum cliente poderá inicializar o PXE para o servidor dos Serviços de Implantação do Windows.

Não responder a nenhum computador cliente. Use essa configuração quando quiser que o servidor responda às solicitações de cliente.

Responder apenas aos computadores clientes conhecidos. Você pode habilitar essa opção quando a diretiva "Responder a computadores cliente" estiver selecionada. Essa opção requer o pré-teste de clientes no Active Directory. Esses clientes pré-testados são mencionados como dispositivos "conhecidos"; clientes que não foram pré-testados são "conhecidos" e não podem inicializar o PXE para os Serviços de Implantação do Windows.

Responder a todos os computadores cliente (conhecidos e desconhecidos). Essa opção permite que todos os clientes inicializem o PXE para o servidor dos Serviços de Implantação do Windows.

Para os clientes desconhecidos, notificar o administrador e responder após aprovação. Escolha essa opção, juntamente com Responder a todos os computadores cliente (conhecidos e desconhecidos), se quiser aprovar novos clientes antes de permitir que eles recebam serviços de inicialização de um servidor dos Serviços de Implantação do Windows.

Para obter mais informações sobre como pré-testar computadores clientes, consulte Pré-testar computadores clientes (http://go.microsoft.com/fwlink/?LinkId=50166).

Atraso da Resposta do PXE

Use a configuração Atraso da Resposta do PXE para ajustar a velocidade de resposta do servidor aos clientes que entram na rede. O Atraso da Resposta do PXE, que configura o tempo de espera do servidor PXE até que os outros servidores PXE respondam, é configurado como zero por padrão. A configuração deve permanecer como zero, a menos que haja outros respondentes na rede que exijam precedência ou que a rede exija mais atraso de resposta do PXE.

Recursos adicionais

  • Gerenciar propriedades do servidor


Propriedades gerais

A página Propriedades Gerais contém as seguintes informações:

  • Nome do computador. O nome do servidor que está executando os Serviços de Implantação do Windows.

  • Local de instalação remota. O nome do compartilhamento que contém as imagens do sistema operacional Windows.

  • Modo do servidor. O modo operacional dos Serviços de Implantação do Windows. Pode ser nativo, misto ou herdado.

    • Modo nativo - Quando configurados para o modo nativo, os Serviços de Implantação do Windows suportam apenas o formato de arquivo de Imagem do Windows (WIM) e os conjuntos de comandos. No modo nativo, os Serviços de Implantação do Windows não fornecem suporte para comandos nem imagens RIS.

    • Modo misto - Quando configurados para o modo misto, os Serviços de Implantação do Windows suportam o RIS bem como os conjuntos de comandos e os tipos de imagem nativos.

    • Modo herdado - Quando configurados para o modo herdado, os Serviços de Implantação do Windows suportam apenas os tipos de imagem RIPREP e RISETUP bem como os conjuntos de comandos RIS.

Recursos adicionais

  • Gerenciar propriedades do servidor


Propriedades dos serviços de diretório

Diretiva de nomenclatura de novo cliente e local da conta

Você pode usar a página Propriedades dos Serviços de Diretório para configurar a diretiva de nomenclatura de cliente padrão e local da conta do computador. Os Serviços de Implantação do Windows fornecem quatro métodos para nomenclatura de um computador e sua colocação em uma unidade organizacional.

  • O administrador especifica o nome da máquina e a unidade organizacional.

  • O servidor especifica o nome da máquina e a unidade organizacional.

  • O cliente desempenha todas as ações de ingresso no domínio na primeira inicialização.

  • O administrador cria uma interface do usuário personalizada.

O administrador especifica o nome do computador e a unidade organizacional

Você pode especificar o nome do computador e a unidade organizacional para ingresso em cada máquina. Esse cenário requer a habilitação da diretiva de adição automática de dispositivos pendentes e o uso do snap-in dos Serviços de Implantação do Windows para especificar o nome do cliente e a unidade organizacional quando o computador for aprovado. As configurações são usadas de duas formas:

  • Como parte do processo de aprovação de dispositivos pendentes. Essas são configurações por servidor e por arquitetura que se aplicam a todos os dispositivos aprovados. O administrador pode substituir essas configurações para cada dispositivo ao aprovar um dispositivo.

  • Para cenários de ingresso no domínio que envolvam o cliente WDS. Por padrão, todas as instalações que ocorram usando o Cliente WDS farão com que a máquina ingresse no domínio no fim do processo. Se a instalação estiver ocorrendo em um cliente pré-testado (criado manualmente ou em Dispositivos Pendentes), o cliente ingressará como o dispositivo existente. Se a instalação estiver ocorrendo em uma máquina nova, o Cliente WDS criará uma conta de computador no Active Directory com base nessas configurações de diretiva. O cliente ingressará como essa conta recém-criada.

Para especificar a diretiva de nomenclatura do cliente e a unidade operacional durante a aprovação

  1. Clique com o botão direito do mouse no servidor e clique em Propriedades.

  2. Clique na guia Configurações da Resposta do PXE.

  3. Clique em Responder a todos os computadores cliente (conhecidos e desconhecidos).

  4. Clique em Para os clientes desconhecidos, notificar o administrador e responder após aprovação.

  5. Inicialize o computador cliente no PXE.

  6. No computador cliente, você verá uma mensagem informando a Identificação da solicitação e o endereço IP do servidor que foi contatado quando o computador cliente foi iniciado.

  7. No snap-in dos Serviços de Implantação do Windows, selecione o servidor que o cliente contatou para exibir o novo cliente em Dispositivos Pendentes.

  8. Clique com o botão direito do mouse no dispositivo e clique em Aprovar.

  9. Digite um nome de computador e uma unidade organizacional.

  10. Clique em OK.

  11. No computador cliente, escolha uma imagem no menu e clique em Enter.

O servidor especifica o nome do computador e a unidade organizacional

Você pode definir o nome do computador e a unidade organizacional por servidor, e todos os clientes internos de um determinado servidor serão criados com uma diretiva de nomenclatura do computador consistente e no mesmo domínio. As configurações são definidas nas guias Propriedades do Servidor , e os valores são usados quando o cliente Serviços de Implantação do Windows inicia a primeira fase da instalação.

Para especificar a diretiva de nomenclatura do cliente e a unidade operacional por servidor

  1. Clique com o botão direito do mouse no servidor e clique em Propriedades.

  2. Clique na guia Configurações da Resposta do PXE.

  3. Clique em Responder a todos os computadores cliente (conhecidos e desconhecidos).

  4. Clique na guia Serviços de Diretório.

  5. Defina a diretiva de nomenclatura do cliente.

    Observação

    A diretiva de nomenclatura do cliente padrão é definida como o nome do usuário seguido por dois dígitos aleatórios. Você pode usar os números de 1 a 9 para alterar o número de dígitos após o nome do usuário.

  6. Em Local da conta do cliente, escolha a unidade operacional padrão (mesmo domínio do servidor dos Serviços de Implantação do Windows) ou defina uma unidade organizacional padrão para o servidor.

  7. Inicialize no PXE um computador cliente para criá-lo usando a diretiva de nomenclatura do cliente e a unidade organizacional especificados.

Desempenhar todas as ações de ingresso no domínio na primeira inicialização

Informações de ingresso no domínio, incluindo nome do computador, domínio e credenciais do usuário, são adicionadas pelo cliente dos Serviços de Implantação do Windows ao arquivo de instalação autônoma da imagem usado durante a instalação do cliente. Se um arquivo de instalação autônoma existente estiver associado à imagem que o cliente está instalando, esse arquivo será atualizado. Se a imagem que o cliente estiver instalando não tiver um arquivo de instalação autônoma associado, será usado um arquivo de instalação autônoma “modelo”. O modelo de instalação autônoma para imagens de baixo nível está localizado no diretório \Templates, no compartilhamento ‘REMINST’. O modelo de instalação autônoma para imagens Windows Vista e Windows Server "Longhorn" está localizado na própria imagem como \Windows\system32\WdsUnattendFile.xml.

Se você estiver usando um arquivo de instalação autônoma, certifique-se de que o arquivo contenha as marcas corretas:

  • <UnsecureJoin> é usada para Unattend.xml.

  • 'DoOldStyleDomainJoin’ é usada para Sysprep.inf.

A presença dessas marcas é sinal de que o WDS deve inserir as informações de ingresso no domínio.

Também é necessário que a seção Microsoft-Windows-Shell-Setup do passo <specialize> esteja presente no arquivo autônomo. O nome do computador não será adicionado se não tiver pelo menos uma seção Microsoft-Windows-Shell-Setup vazia no passo <specialize>. Isso serve para evitar atributos embutidos em código para este componente, como publicKeyToken e language.

Criar uma interface do usuário personalizada

Você também pode criar uma interface do usuário personalizada para especificar o nome do computador e a unidade organizacional antes da instalação. Por exemplo, você pode gravar um script executado no WinPE que capture informações de nome do computador e unidade organizacional, coloque-o em um arquivo de instalação autônoma e chame Setup.exe. Se precisar de um aplicativo não incluído que forneça esse nível de personalização, consulte o Microsoft Solution Accelerator for Business Desktop Deployment 2007 (http://go.microsoft.com/fwlink/?LinkId=71137).

Considerações adicionais

  • Para executar esses procedimentos, você deve ser membro do grupo Operadores de Contas, do grupo Administradores do Domínio ou deve ter sido delegado com a autoridade apropriada.

Referências adicionais

  • Microsoft Solution Accelerator for Business Desktop Deployment 2007 (http://go.microsoft.com/fwlink/?LinkId=71137)

  • Amostra de arquivos de instalação autônoma

  • Gerenciar propriedades do servidor


Propriedades de inicialização

A página Propriedades de inicialização dos Serviços de Implantação do Windows permite configurar o programa de inicialização padrão e as imagens de inicialização padrão por arquitetura.

  • Programa de inicialização padrão

  • Imagem de inicialização padrão

Programa de inicialização padrão

Você pode definir as configurações de programas de inicialização padrão para determinar como o cliente PXE interage com o servidor WDS por arquitetura. A tabela a seguir descreve os programas de inicialização disponíveis.

Programa de inicialização Funcionalidade

Abortpxe.com

Esse programa é enviado a um computador cliente quando o administrador rejeita um dispositivo pendente.

Bootmgfw.efi

A versão EFI de pxeboot.com inclui toda a funcionalidade de pxeboot.com, pxeboot.n12, abortpxe.com e bootmgr.exe. Atualmente, apenas está disponível para ia64.

Hdlscom1.com

Você pode usar esse programa para redirecionar a saída de firmware para a porta COM1 em sistemas nos quais não há suporte para redireção de firmware para o console. Você pode pressionar F12 para prosseguir com o processo de inicialização ou pode encerrar esse processo sem pressionar essa tecla.

Hdlscom1.n12

Você pode usar esse programa para redirecionar a saída de firmware para a porta COM1 em sistemas nos quais não há suporte para redireção de firmware para o console. Esse programa ignorará a tecla F12 e inicializará diretamente no servidor PXE.

Hdlscom2.com

Você pode usar esse programa para redirecionar a saída de firmware para a porta COM2 em sistemas nos quais não há suporte para redireção de firmware para o console. Você pode pressionar F12 para prosseguir com o processo de inicialização ou pode encerrar esse processo sem pressionar essa tecla.

Hdlscom2.n12

Você pode usar esse programa para redirecionar a saída de firmware para a porta COM2 em sistemas nos quais não há suporte para redireção de firmware para o console. Esse programa ignorará a tecla F12 e inicializará diretamente no servidor PXE.

Pxeboot.com

Você pode usar esse programa de inicialização (padrão) para solicitar que o usuário pressione a tecla F12 para acessar os serviços de inicialização.

Pxeboot.n12

Você pode usar esse programa de inicialização para ignorar a tecla F12 e inicializar diretamente no servidor PXE.

Wdsnbp.com

Wdsnbp.com é um programa de inicialização de rede usado pelos Serviços de Implantação do Windows; nunca deve ser usado como um programa de inicialização padrão. Wdsnbp.com tem os seguintes objetivos gerais:

  • Interrompe a inicialização do PXE. Permite que os Serviços de Implantação do Windows realizem a lógica de resposta avançada sem que o cliente atinja o tempo limite ao aguardar o servidor.

  • Reporta a arquitetura do cliente de inicialização quando esta não pode ser determinada a partir de um pacote de rede de inicialização do PXE. Isso é particularmente importante em sistemas x64 que não reportam sua arquitetura de 64 bits.

  • Resolve casos de referência do PXE quando os Serviços de Implantação do Windows e os RIS existem na mesma rede ou no mesmo segmento de rede.

  • Age como um Protocolo de Inicialização de Rede para casos de adição automática em que ele interromperá o processo de inicialização do PXE e sonda o servidor para saber o status da aprovação.

Você pode usar a página Propriedades de Inicialização do servidor ou o WDSUTIL para configurar o programa de inicialização padrão.

Para configurar o programa de inicialização padrão específico da arquitetura por servidor

  1. Abra o snap-in dos Serviços de Implantação do Windows.

  2. Clique para expandir a lista Servidores.

  3. Clique com o botão direito do mouse no servidor e clique em Propriedades.

  4. Clique na guia Inicializar.

  5. Na página Propriedades de Inicialização, em Programa de Inicialização Padrão (opcional), localize a arquitetura desejada e clique em Procurar.

  6. Clique para selecionar o arquivo apropriado e, em seguida, clique em Abrir.

  7. Clique em OK.

  8. Se aparecer um aviso, verifique se você fez a escolha correta e clique em Sim.

Imagem de inicialização padrão

Você pode usar essa opção para especificar uma imagem padrão por arquitetura e por servidor. É possível fazer isso para que os clientes x64 sempre recebam imagens do sistema x64, ou se você incluir ferramentas específicas da arquitetura na sua imagem.

Para selecionar uma imagem de inicialização padrão por servidor

  1. Abra o snap-in dos Serviços de Implantação do Windows.

  2. Clique para expandir a lista Servidores.

  3. Clique com o botão direito do mouse no servidor e clique em Propriedades.

  4. Clique na guia Inicializar.

  5. Na página Propriedades de Inicialização, em Imagem de inicialização padrão (opcional), escolha a arquitetura desejada e clique em Selecionar.

  6. Na caixa de diálogo de procura, clique na imagem que você deseja usar como padrão e clique em OK.

Considerações e referências adicionais

  • Para executar esse procedimento, você deve ser membro do grupo Operadores de Contas, do grupo Administradores do Domínio ou deve ter sido delegado com a autoridade apropriada.

  • Gerenciar propriedades do servidor


Propriedades do cliente

A página Propriedades do cliente dos Serviços de Implantação do Windows permite configurar o cliente para o modo de operação autônomo ou guiado e substituir a criação da conta de cliente padrão. No modo autônomo, as páginas do cliente dos Serviços de Implantação do Windows que determinam a seleção da imagem e a configuração do disco são eliminadas, e os padrões fornecidos pelo administrador são usados.

  • Habilitar cliente autônomo

  • Criação da conta de cliente

Habilitar instalação autônoma do cliente

Para habilitar a instalação autônoma do cliente no snap-in dos Serviços de Implantação do Windows

  1. Abra o snap-in dos Serviços de Implantação do Windows.

  2. Clique para expandir a lista de servidores.

  3. Clique com o botão direito do mouse no servidor e clique em Propriedades.

  4. Clique na guia Cliente.

  5. Clique em Habilitar instalação autônoma.

  6. Clique em Procurar para selecionar um arquivo de instalação autônoma por arquitetura.

  7. Clique para selecionar o arquivo.

  8. Clique em OK.
Observação

Convém copiar o arquivo de instalação autônoma do cliente dos Serviços de Implantação do Windows para a pasta \WDSClientUnattend, no compartilhamento REMINST.

Para habilitar a instalação autônoma do cliente em um prompt de comando

  • Digite WDSUTIL /Set-Server /WdsUnattend /Policy:Enabled /File:WDSClientUnattend \unattend.xml /Architecture:x86

Criação da conta de cliente

Para desabilitar a criação da conta de cliente usando o snap-in dos Serviços de Implantação do Windows

  1. Abra o snap-in dos Serviços de Implantação do Windows.

  2. Clique para expandir a lista de servidores.

  3. Clique com o botão direito do mouse no servidor e clique em Propriedades.

  4. Clique na guia Cliente.

  5. Clique para selecionar Não criar conta no domínio após a execução do cliente do WDS.
Para desabilitar a criação da conta de cliente usando o WDSUTIL em um prompt de comando

  • Digite WDSUTIL /JoinDomain:No

Considerações e referências adicionais

  • Para executar esse procedimento, você deve ser membro do grupo Operadores de Contas, do grupo Administradores do Domínio ou deve ter sido delegado com a autoridade apropriada.

  • Antes de concluir esse procedimento, você precisará copiar um arquivo de instalação autônoma do cliente para \Reminst\WDSClientUnattend.

  • Amostra de arquivos de instalação autônoma

  • Arquivos de instalação autônoma

  • Gerenciar propriedades do servidor


Gerenciar clientes dos Serviços de Implantação do Windows

Você pode usar as informações a seguir para saber mais sobre a diretiva de cliente desconhecido, a nomenclatura de computadores e a pasta de dispositivos pendentes.

  • Pré-testar computadores clientes

  • Definir a diretiva de nomenclatura do computador

  • Dispositivos pendentes


Pré-testar computadores clientes

O pré-teste de computadores clientes permite que o administrador designe computadores a um servidor específico dos Serviços de Implantação do Windows. Quando usado com a diretiva Responder apenas aos computadores clientes conhecidos, o pré-teste também permite controlar quais computadores podem ser implantados usando os Serviços de Implantação do Windows.

Os Serviços de Implantação do Windows fornecem métodos automatizados e manuais para o pré-teste de computadores clientes. Para conhecer o método automatizado, consulte Dispositivos pendentes.

  • Usando a interface do Windows

  • Em um prompt de comando

Pré-testar computadores usando Usuários e Computadores do Active Directory

Para pré-testar computadores clientes usando a interface do Windows

  1. Para abrir Usuários e Computadores do Active Directory, clique em Iniciar, Executar, digite dsa.msc e clique em OK.

  2. Na árvore de console, clique com o botão direito do mouse na unidade organizacional que conterá o novo computador cliente.

  3. Clique em Novo e em Computador.

  4. Digite o nome do computador cliente, clique em Avançar e em Este é um computador gerenciado.

  5. No campo de entrada de texto, digite o identificador global exclusivo (GUID) do computador cliente e clique em Avançar.

  6. Clique em uma das opções a seguir para especificar qual servidor ou servidores darão suporte para este computador cliente.

    • Qualquer servidor de instalação remota disponível

    • O seguinte servidor de instalação remota

    Observação

    A seleção da segunda opção designa um servidor específico para atender a este computador cliente.

  7. Clique em Avançar e em Concluir.

Considerações e referências adicionais

  • Para executar esses procedimentos, você deve ser membro do grupo Operadores de Contas, do grupo Administradores do Domínio ou deve ter sido delegado com a autoridade apropriada.

  • Quando um computador é pré-testado em um domínio com vários controladores de domínio, o atraso de replicação das informações de conta do computador cliente pode fazer com que esse computador seja atendido por outro servidor dos Serviços de Implantação do Windows.

  • Gerenciar propriedades do servidor

  • Dispositivos pendentes

Pré-testar computadores usando WDSUTIL

Para pré-testar computadores clientes usando WDSUTIL

  • Digite WDSUTIL /add-device /device:<nome_do_dispositivo> /ID:<Endereço_MAC> /options, em que nome_do_dispositivo é o nome, Endereço_MAC é o endereço MAC do novo computador e options são as configurações opcionais.

Considerações e referências adicionais

  • WDSUTIL, a ferramenta de gerenciamento de linha de comando dos Serviços de Implantação do Windows, requer privilégios elevados para ser executada.

  • Você pode pré-testar um computador cliente em Usuários e Computadores do Active Directory e por meio de WDSUTIL, usando o GUID ou o endereço MAC. Se o endereço MAC for usado, deverá ser precedido por vinte zeros "0".

  • Quando um computador é pré-testado em um domínio com vários controladores de domínio, o atraso de replicação das informações de conta do computador cliente pode fazer com que esse computador seja atendido por outro servidor dos Serviços de Implantação do Windows.

  • Gerenciar propriedades do servidor

  • Dispositivos pendentes


Definir a diretiva de nomenclatura do computador

Para garantir que cada computador cliente receba um nome exclusivo, escolha uma das opções na lista de opções de nomenclatura automática. Todas as opções de nomenclatura automática com base no nome do usuário adicionam um número incremental no final para garantir que o nome do computador seja exclusivo.

Selecione uma das opções na tabela a seguir para criar automaticamente o nome do computador personalizado.

Variável | Resultado
%First | O nome do usuário é usado como o nome do computador.
%Last | O sobrenome do usuário é usado como o nome do computador.
%Username | O nome de usuário é usado como o nome do computador.
%MAC | O endereço de controle de acesso de mídia (MAC) do adaptador de rede é usado como o nome do computador.
%[0][n]# | O nome do computador inclui um número incremental contendo n dígitos. Para incluir preenchimento igual a zero no número incremental, digite um zero, conforme mostrado a seguir. Por exemplo, se você usar %03#, será usado um número de três dígitos no intervalo de 001 a 999.
Importante

Evite criar uma convenção de nomenclatura que possa resultar em nomes de computador duplicados. Uma forma de evitar isso é usar a opção de número incremental descrita na tabela anterior.

Ao definir uma diretiva de nomenclatura de computador, você pode limitar o tamanho de nomes de computador, adicionando um valor numérico à seqüência de caracteres de texto. Por exemplo, para limitar o nome do computador a três caracteres do sobrenome do usuário, acrescentado com um número incremental de dois dígitos, use esta seqüência de caracteres: %3Last%02#. Dessa forma, para o quinto usuário do computador cujo sobrenome for Smith, o nome do computador correspondente será Smi05.

Você pode usar opções de nomenclatura personalizadas separadamente ou pode combiná-las. Por exemplo, para que o nome do computador consista nas três primeiras letras do nome do usuário, seguidas pelas três primeiras letras do sobrenome desse usuário, seguidas por um número incremental de três dígitos, use esta seqüência de caracteres: %3First%3Last%03#.

Considerações e referências adicionais

  • Para executar esse procedimento, você deve ser membro do grupo Operadores de Contas, do grupo Administradores do Domínio ou deve ter sido delegado com a autoridade apropriada.

  • Gerenciar propriedades do servidor


Dispositivos pendentes

Se você não optar por aprovar automaticamente dispositivos, poderá usar a pasta de dispositivos pendentes para aprovar ou rejeitar instalações de clientes a partir dos Serviços de Implantação do Windows. Nos Serviços de Instalação Remota (RIS), a criação de dispositivos na etapa de pré-teste era um processo manual. Os Serviços de Implantação do Windows oferecem uma forma automatizada e simplificada para a criação de objetos de conta do computador na etapa de pré-teste por meio da diretiva de Adição Automática.

Há dois tipos de diretiva diferentes que podem ser configurados para controlar o comportamento da diretiva de Adição Automática:

  • Nenhuma ação

  • Pendente

Nenhuma ação

Essa é a configuração padrão e corresponde a não ativar a diretiva de Adição Automática. Na verdade, essa opção significa “se ‘responder a clientes’ = sim, ‘responder apenas a clientes conhecidos’ = não, e um dispositivo na etapa de pré-teste não for localizado; não fazer mais nada”. Isso significa que os Serviços de Implantação do Windows não criarão uma conta de computador em nome do cliente desconhecido que está solicitando serviço. Entretanto, ele ainda responderá, porque a Diretiva de Resposta do PXE especifica a resposta a todos os clientes, mesmo os que não estão na etapa de pré-teste.

Pendente

Quando essa opção for usada, um dispositivo desconhecido será colocado na pasta de dispositivos pendentes. O dispositivo permanecerá nessa fila até que uma das quatro situações a seguir ocorra:

  • O dispositivo é aprovado.

  • O dispositivo é rejeitado.

  • O tempo limite é atingido.

  • A tentativa de inicialização da rede é cancelada.

Todos os dispositivos colocados na fila pendente são representados como uma entrada no banco de dados de dispositivos pendentes, no servidor dos Serviços de Implantação do Windows que respondeu à solicitação de inicialização PXE inicial do cliente. O objetivo deste local de armazenamento temporário é:

  • Fornecer aos utilitários de gerenciamento uma interface comum para obter a lista de todos os dispositivos pendentes em um servidor.

  • Servir como “trilha de auditoria” para registrar quais dispositivos foram aprovados/rejeitados.

  • Manter o Active Directory livre de objetos de conta de computador com crescimento de tamanho/obsoletos; problemas que poderiam ocorrer se todos os dispositivos de inicialização fossem adicionados automaticamente ao Active Directory e apenas removidos se fossem rejeitados.

Usando as ferramentas de gerenciamento dos Serviços de Implantação do Windows, você pode recuperar a lista de dispositivos atualmente na fila pendente a partir do banco de dados de dispositivos pendentes. Em seguida, pode aprovar e rejeitar dispositivos de forma seletiva. A aprovação de um dispositivo permite que o computador cliente continue com a operação de inicialização da rede. Além disso, um objeto de conta do computador é criado no Active Directory para representar o dispositivo físico. A rejeição de um dispositivo faz com que o computador físico interrompa a tentativa de inicialização da rede e continue a partir do dispositivo seguinte, conforme definido na ordem de inicialização do BIOS do computador. Uma conta de computador no Active Directory não será criada para um dispositivo rejeitado.

Considerações e referências adicionais

  • Para executar esse procedimento, você deve ser membro do grupo Operadores de Contas, do grupo Administradores do Domínio ou deve ter sido delegado com a autoridade apropriada.

  • Você precisará delegar permissões ao objeto de máquina do servidor dos Serviços de Implantação do Windows para que a diretiva de dispositivos pendentes crie com êxito objetos de computador no AD quando os dispositivos forem aprovados. Consulte o Guia de Implantação dos Serviços de Implantação do Windows, em http://go.microsoft.com/fwlink/?LinkId=71130.

  • Gerenciar propriedades do servidor


Gerenciar imagens do Windows

Você pode gerenciar imagens do Windows usando o snap-in dos Serviços de Implantação do Windows ou a partir de um prompt de comando com o uso de WDSUTIL.

  • Tipos de imagem

  • Adicionar uma imagem

  • Criar uma imagem

  • Modificar uma imagem

  • Remover uma imagem

  • Exportar uma imagem

  • Propriedades da imagem

  • Grupos de imagens

  • Arquivos de instalação autônoma

  • Pacotes de idioma

  • Imagens herdadas

  • Amostra de arquivos de instalação autônoma


Tipos de imagem

Os principais tipos de imagem usados nos Serviços de Implantação do Windows são imagens de instalação (instalação) e imagens de inicialização. Imagens de instalação são arquivos de Imagem do Windows (WIM) ou imagens herdadas criadas com o uso de ferramentas contidas nos Serviços de Instalação Remota (RIS). As imagens de inicialização são arquivos WIM e incluem imagens de instalação, que funcionam com os Serviços de Implantação do Windows para instalar o Windows e capturar imagens, que são usadas para capturar imagens preparadas com o uso de imagens Sysprep.exe para implantação em novos clientes e imagens de descoberta, que são usados para inicializar sistemas não compatíveis com o PXE em um servidor dos Serviços de Implantação do Windows.

  • Imagens de instalação

  • Imagens de inicialização

Imagens de instalação

Imagens de instalação são imagens do sistema operacional, a serem instaladas nos computadores clientes, que são inicializadas em um servidor dos Serviços de Implantação do Windows.

  • Formato WIM. Arquivos WIM são um novo formato de arquivo que contém uma ou mais imagens compactadas do Windows. Em vez de usarem setores como base, eles usam arquivos, o que facilita a atualização das imagens existentes. Além disso, usam a tecnologia de armazenamento de instância única (SIS), eliminando a duplicação de arquivos em um WIM.

  • Imagens RIPREP. Imagens RIPREP são imagens RIS herdadas. Os Serviços de Implantação do Windows, no modo herdado ou misto, são capazes de implantar imagens RIPREP. As imagens RIPREP são dependentes do HAL e do idioma, o que torna dispendioso o seu suporte.

  • Imagens RISETUP. Imagens RISETUP são o primeiro tipo de imagem do RIS. Basicamente, trata-se de uma cópia da estrutura de diretórios do CD (diretório i386) em um compartilhamento de arquivos no servidor RIS. Imagens RISETUP têm uma vantagem principal sobre imagens RIPREP no RIS: não são dependentes do HAL.

Imagens de inicialização

Imagens de inicialização são imagens do Windows PE que contêm o cliente WDS e são usadas em um menu de inicialização inicial quando o cliente contata um servidor dos Serviços de Implantação do Windows.

  • As imagens de instalação são o tipo de imagem padrão quando você exporta uma imagem de inicialização a partir do armazenamento de imagens. Quando um cliente inicializa em uma imagem de instalação, a Instalação do Windows é chamada imediatamente.

  • As imagens de captura são uma alternativa para o utilitário de linha de comando ImageX.exe ao capturar uma imagem preparada com o utilitário Sysprep.exe. Quando um cliente inicializa em uma imagem de captura, o Utilitário de Captura dos Serviços de Implantação do Windows é chamado e prossegue capturando e adicionando uma nova imagem.

  • Imagens de descoberta são imagens de inicialização dos Serviços de Implantação do Windows que podem ser copiadas para um CD de forma a serem usadas quando os serviços de inicialização do PXE não estiverem disponíveis. Ao inicializar em uma imagem de descoberta, o usuário é apresentado ao menu do cliente Serviços de Implantação do Windows e continua com a instalação da mesma forma quando ocorre uma inicialização no PXE.

Referências adicionais

  • Gerenciar imagens do Windows

  • Imagens herdadas


Adicionar uma imagem

Você pode adicionar imagens usando o snap-in dos Serviços de Implantação do Windows ou usando WDSUTIL em um prompt de comando.

  • Adicionar uma imagem de inicialização

  • Adicionar uma imagem de instalação

  • Adicionar uma imagem herdada

Adicionar uma imagem de inicialização

Para adicionar uma imagem de inicialização usando o snap-in dos Serviços de Implantação do Windows

  1. Clique para expandir a lista de servidores.

  2. Clique para expandir o servidor.

  3. Clique com o botão direito do mouse na pasta Imagens de Inicialização e clique em Adicionar Imagem de Inicialização.

  4. Clique em Procurar para selecionar a imagem a ser adicionada.

  5. Clique em OK.
Para adicionar uma imagem de inicialização usando WDSUTIL em um prompt de comando

  • Para adicionar uma imagem de inicialização, digite:

    WDSUTIL /add-image /imagefile:\\server\share\sources\boot.wim /imagetype:boot

    Em que o caminho corresponde ao caminho completo para a imagem de inicialização.
Observação

A imagem a ser carregada deve ser boot.wim no DVD do Windows Vista. Há outras imagens do WinPE disponíveis, como no Windows AIK, ou outras imagens personalizadas que podem não funcionar como uma imagem de “configuração”.

Adicionar uma imagem de instalação

Para adicionar uma imagem de instalação usando o snap-in dos Serviços de Implantação do Windows

  1. Clique para expandir a lista de servidores.

  2. Clique para expandir o servidor.

  3. Clique para expandir a pasta Imagens de Instalação.

  4. Clique com o botão direito do mouse no grupo de imagens ao que você deseja adicionar a imagem e clique em Adicionar Imagem de Instalação.

  5. Clique em Procurar para selecionar a imagem a ser adicionada.

  6. Clique em OK.
Para adicionar uma imagem de instalação usando WDSUTIL em um prompt de comando

  • Para adicionar uma imagem de instalação, digite:

    WDSUTIL /add-image /imagefile:\\server\share\sources\install.wim /image type:install

    Em que o caminho corresponde ao caminho completo para a imagem de instalação.

Adicionar uma imagem herdada

Você pode adicionar uma imagem RIS ao servidor dos Serviços de Implantação do Windows usando as ferramentas e os métodos RIS herdados.

Para adicionar uma imagem herdada

  1. Abra Usuários e Computadores do Active Directory.

  2. Na árvore de console, clique com o botão direito do mouse no servidor dos Serviços de Implantação Remota (RIS).

  3. Clique em Propriedades e, na caixa de diálogo Propriedades, clique na guia Instalação Remota.

  4. Clique em Configurações Avançadas e na guia Imagens.

  5. Clique em Adicionar.

  6. Clique em Adicionar uma nova imagem de instalação e clique em Avançar para iniciar o Assistente para Instalação dos Serviços de Instalação Remota.

  7. Clique em Avançar e digite o local dos arquivos de instalação. O local pode ser um disco compacto ou uma pasta compartilhada.

  8. Digite o nome da pasta da nova imagem de instalação.

  9. Digite a descrição amigável e o texto de ajuda, e clique em Avançar.

  10. Especifique se você deseja usar novas telas .osc e fazer o backup das telas .osc anteriores, usar novas telas .osc e substituir as telas anteriores ou deixar as telas .osc anteriores no lugar.

  11. Examine o resumo da instalação e clique em Concluir.

Considerações e referências adicionais

  • Para executar este procedimento, você deve ser membro do grupo Administradores no computador local ou deve ter recebido a autoridade adequada. Se o computador fizer parte de um domínio, é possível que os membros do grupo Administradores do domínio possam executar esse procedimento. Por questões de segurança, convém usar Executar como para executar o procedimento.

  • Para abrir Usuários e Computadores do Active Directory, clique em Iniciar, Executar, digite dsa.msc e clique em OK.

  • Gerenciar imagens do Windows


Criar uma imagem

Você pode usar os Serviços de Implantação do Windows para criar imagens de instalação e de inicialização, incluindo imagens de captura e de descoberta. As imagens de captura são usadas para criar novas imagens de instalação em um sistema preparado com Sysprep.exe e para adicioná-las ao armazenamento de imagem. As imagens de descoberta fornecem um meio para os adaptadores de rede não compatíveis com PXE acessarem o servidor WDS PXE. Você também pode usar os Serviços de Implantação do Windows para exportar um WIM de inicialização da instalação.

Criar uma mídia inicializável a partir de um arquivo WIM requer a instalação do Windows AIK. Para obter mais informações, consulte o Guia do Usuário do Windows para WAIK (Kit de Instalação Automatizada do Windows) referente ao Windows Vista (http://go.microsoft.com/fwlink/?LinkID=53552)

  • Criar uma imagem de instalação

  • Criar uma imagem de captura

  • Criar uma imagem de descoberta

  • Criar uma mídia de inicialização

Criar uma imagem de instalação

As imagens de instalação são criadas a partir de instalações de referência do sistema operacional Windows e são implantadas na área de trabalho do cliente quando os Serviços de Implantação do Windows são usados para instalar o Windows. Uma instalação de referência pode ser uma instalação padrão do Windows ou pode ser configurada para um ambiente específico ou usada antes para criar a imagem.

Para criar uma imagem de instalação

  1. Crie um computador de referência.

  2. Em um prompt de comando no computador de referência, altere os diretórios para \Windows\system32\Sysprep ou para um diretório contendo Sysprep.exe e Setupcl.exe.

  3. Digite sysprep /OOBE /Generalize /Reboot.

  4. Quando o computador de referência reinicializar, pressione F12.

  5. No Gerenciador de Inicialização do Windows, opte por inicializar para a imagem de captura apropriada.

  6. Na página de Boas-Vindas do Assistente de Captura de Imagem, clique em Avançar.

  7. Na página Fonte de Captura de Imagem, use o controle suspenso Volume a Capturar para escolher o volume apropriado e, em seguida, forneça um nome e uma descrição para a imagem. Clique em Avançar para continuar.

  8. Na página Destino da Captura de Imagem, clique em Procurar e procure o local onde deseja armazenar a imagem capturada.

  9. Na caixa de texto Nome do arquivo, digite um nome para a imagem usando a extensão de nome de arquivo .WIM e clique em Salvar.

  10. Clique em Carregar imagem para servidor WDS.

  11. Digite o nome do servidor WDS e clique em Conectar.

  12. Se as credenciais forem solicitadas, forneça um nome de usuário e uma senha para uma conta com privilégios suficientes para conectar ao servidor WDS.

  13. Usando o controle suspenso Grupo de Imagens, escolha o grupo de imagens no qual armazenar a imagem.

  14. Clique em Concluir.
Observação

A estrutura de diretórios na etapa um é válida somente para o Windows Server "Longhorn" e o Windows Vista. Para o Windows 2003 e o Windows XP, use a versão de Sysprep apropriada a partir de Deploy.cab.

Observação

Essa sintaxe na etapa dois é válida somente para o Windows Server "Longhorn" e o Windows Vista. Verifique a sintaxe referente à sua versão do Windows digitando sysprep /?

Criar uma imagem de captura

Imagens de captura são usadas para capturar imagens do Windows preparadas com Sysprep.exe para serem implantadas como imagens de instalação. Essas imagens são imagens de inicialização que iniciam o Assistente de Captura de Imagem. As imagens de captura são primeiramente salvas em um arquivo e, em seguida, adicionadas ao armazenamento de imagens.

Para criar uma imagem de captura usando os Serviços de Implantação do Windows

  1. Expanda a pasta Imagem de Inicialização.

  2. Clique com o botão direito do mouse na imagem a ser usada como imagem de captura.

  3. Clique em Criar Imagem de Inicialização de Captura.

  4. Escolha um nome e uma descrição para a imagem de captura.

  5. Escolha um local e um nome para o novo arquivo.

  6. Clique em OK para criar a imagem de captura.

  7. Clique em Concluir.

  8. Clique com o botão direito do mouse na pasta Imagem de Inicialização.

  9. Clique em Adicionar Imagem de Inicialização.

  10. Procure para selecionar a nova imagem de captura e clique em Avançar.

  11. Opcionalmente, atualize o nome e a descrição da imagem de captura e clique em Avançar.

  12. Clique em Avançar.

  13. Clique em Concluir.
Para criar uma imagem de captura usando WDSUTIL

  1. WDSUTIL, a ferramenta de gerenciamento de linha de comando dos Serviços de Implantação do Windows, requer privilégios elevados para ser executada: clique em Iniciar, Todos os Programas, Acessórios, clique com o botão direito do mouse em Prompt de Comando e clique em Execução Privilegiada.

  2. No prompt de comando, digite:

    WDSUTIL /new-captureimage /image: imagem_de_inicialização /architecture:x86 /filepath:imagem_de_captura

    Onde imagem_de_inicialização é o nome da imagem de inicialização que você deseja usar para criar a imagem de captura e imagem_de_captura é o caminho de arquivo e o nome de arquivo da nova imagem de captura.

  3. No prompt de comando, digite:

    WDSUTIL /add-image /imagefile: imagem_de_captura /imagetype:boot

    Em que imagem_de_captura é o caminho de arquivo e o nome de arquivo da imagem de captura que você deseja adicionar ao armazenamento de imagem.
Observação

Para obter ajuda com WDSUTIL, digite WDSUTIL /? em um prompt de comando.

Criar uma imagem de descoberta

Imagens de descoberta são usada para implantar o sistema operacional Windows por meio dos Serviços de Implantação do Windows em computadores que não dão suporte à inicialização do PXE. Essas imagens são imagens de inicialização que iniciam o Assistente de Descoberta dos Serviços de Implantação do Windows. As imagens de descoberta são salvas em um arquivo, convertidas em um formato ISO e, em seguidas, gravadas em CD ou DVD.

Para criar uma imagem de descoberta usando os Serviços de Implantação do Windows

  1. Expanda a pasta Imagem de Inicialização.

  2. Clique com o botão direito do mouse na imagem a ser usada como imagem de descoberta.

  3. Clique em Criar Imagem de Inicialização de Descoberta.

  4. Escolha um nome e uma descrição para a imagem de descoberta.

  5. Escolha um local e um nome para o novo arquivo, usando a extensão de nome de arquivo .wim.

  6. Clique em OK para criar a imagem de captura.

  7. Clique em Concluir.
Para criar uma imagem de descoberta usando WDSUTIL

  1. WDSUTIL, a ferramenta de gerenciamento de linha de comando dos Serviços de Implantação do Windows, requer privilégios elevados para ser executada: clique em Iniciar, Todos os Programas, Acessórios, clique com o botão direito do mouse em Prompt de Comando e clique em Execução Privilegiada.

  2. No prompt de comando, digite:

    WDSUTIL /new-discoverimage /image: boot_image /architecture:x86 /filepath: imagem_de_descoberta

    Onde imagem_de_inicialização é o nome da imagem de inicialização que você deseja usar para criar a imagem de descoberta e imagem_de_descoberta é o caminho de arquivo e o nome de arquivo da nova imagem de captura.
Observação

Para obter ajuda com WDSUTIL, digite WDSUTIL /? em um prompt de comando.

Criar uma mídia de inicialização

Para criar uma mídia inicializável

  1. Instale o Kit de Instalação Automatizada do Windows.

  2. Abra um prompt de comando e altere para a pasta PETools:

    Cd C:\Program Files\Windows AIK\Tools\PETools

  3. Para criar um ambiente de criação do WinPE, digite:

    CopyPE <architecture> C:\Winpe

  4. Copie a imagem de descoberta criada no procedimento anterior:

    Copy /y c:\boot.wim c:\Winpe\ISO\Sources

  5. Volte para a pasta PETools:

    Cd C:\Program Files\Windows AIK\Tools\PETools

  6. Crie a imagem ISO inicializável:

    Oscdimg -n -bc:\winpe\boot\etfsboot.com c:\winpe c:\winpe.iso

  7. Use um utilitário que possa criar um CD ou DVD para transferir a imagem ISO à mídia apropriada.
Observação

Esse procedimento requer um utilitário de cópia de CD de terceiros.

Referências adicionais

  • Gerenciar imagens do Windows

  • Imagens herdadas

  • Exportar uma imagem

  • O Kit de Instalação Automatizada do Windows http://go.microsoft.com/fwlink/?LinkID=53552


Modificar uma imagem

Você pode modificar as imagens para adicionar arquivos ou drivers sem precisar criar uma nova imagem. Os processos são semelhantes para uma imagem de inicialização ou de instalação; porém, os conjuntos de ferramentas e as sintaxes variam entre os tipos de imagem. Informações detalhadas sobre a modificação de imagens WIM estão disponíveis no Guia do Usuário do Windows para WAIK (Kit de Instalação Automatizada do Windows) referente ao Windows Vista (http://go.microsoft.com/fwlink/?LinkID=53552).

  • Modificar uma imagem de inicialização

  • Modificar uma imagem de instalação

Modificar uma imagem de inicialização

Para modificar uma imagem de inicialização

  1. Localize a imagem para manutenção e marque como offline. Se você estiver usando o snap-in dos Serviços de Implantação do Windows para desempenhar essa operação, clique com o botão direito do mouse na imagem e selecione Desabilitar. Isso permitirá que as instalações existentes continuem, mas novos clientes não poderão enumerar a imagem.

  2. Exporte a imagem.

  3. Execute a manutenção da imagem.

  4. Adicione a imagem ao servidor. Existem duas formas de fazer isso:

    1. Como uma nova imagem ao mesmo grupo de imagens. Posteriormente, será possível remover a imagem antiga (que não será enumerada, porque está offline).

    2. Substitua a imagem existente (considerando que todas as instalações que a usam foram concluídas) pela versão submetida a manutenção recentemente. (Essa etapa é recomendada.)

Modificar uma imagem de instalação

Para modificar uma imagem de instalação

  1. Localize a imagem para manutenção e marque como offline. Se você estiver usando o snap-in dos Serviços de Implantação do Windows para desempenhar essa operação, clique com o botão direito do mouse na imagem e selecione Desabilitar. Isso permitirá que as instalações existentes continuem, mas novos clientes não poderão enumerar a imagem.

  2. Exporte a imagem.

  3. Execute a manutenção da imagem.

  4. Adicione a imagem ao servidor. Existem duas formas de fazer isso:

    1. Como uma nova imagem ao mesmo grupo de imagens. Posteriormente, será possível remover a imagem antiga (que não será enumerada, porque está offline).

    2. Substitua a imagem existente (considerando que todas as instalações que a usam foram concluídas) pela versão submetida a manutenção recentemente. (Essa etapa é recomendada.)

Referências adicionais

  • Gerenciar imagens do Windows

  • O Guia do Usuário do Windows para WAIK (Kit de Instalação Automatizada do Windows) referente ao Windows Vista (http://go.microsoft.com/fwlink/?LinkID=53552)


Remover uma imagem

Você pode remover uma imagem usando o snap-in dos Serviços de Implantação do Windows ou usando WDSUTIL em um prompt de comando.

  • Remover uma imagem de inicialização

  • Remover uma imagem de instalação

Remover uma imagem de inicialização

Para remover uma imagem de inicialização usando o snap-in dos Serviços de Implantação do Windows

  1. Expanda o servidor que contém a imagem a ser excluída.

  2. Clique para selecionar Imagens de Inicialização.

  3. No painel de ação, clique com o botão direito do mouse na imagem e em Excluir Imagem.

  4. Na caixa de diálogo de confirmação, clique em Sim para excluir a imagem.
Para remover uma imagem de inicialização usando WDSUTIL em um prompt de comando

  • Digite WDSUTIL /Remove-Image /Image:Nome_da_imagem /ImageType:boot

    /Architecture: Aqu, em que Nome_da_imagem é o nome da imagem e Arqu é a sua arquitetura (x86 ou x64).

Remover uma imagem de instalação

Para remover uma imagem de instalação usando o snap-in dos Serviços de Implantação do Windows

  1. Expanda o servidor que contém a imagem a ser excluída.

  2. Clique para selecionar Imagens de Instalação.

  3. Clique para selecionar o grupo de imagens que contém a imagem.

  4. No painel de ação, clique com o botão direito do mouse na imagem e em Excluir Imagem.

  5. Na caixa de diálogo de confirmação, clique em Sim para excluir a imagem.
Para remover uma imagem de instalação usando WDSUTIL em um prompt de comando

  • Digite WDSUTIL.exe /verbose /Remove-Image /Image:"Windows Vista com o Office"

    /Server:MyWDSServer /ImageType:install /ImageGroup:ImageGroup1

    /Filename:install.wim

Considerações e referências adicionais

  • Para executar este procedimento, você deve ser membro do grupo Administradores no computador local ou deve ter recebido a autoridade adequada. Se o computador fizer parte de um domínio, é possível que os membros do grupo Administradores do domínio possam executar esse procedimento. Por questões de segurança, convém usar Executar como para executar o procedimento.

  • Gerenciar imagens do Windows


Exportar uma imagem

Você pode exportar imagens para fazer alterações nessas imagens, como adicionar drivers ou atualizações. Também pode exportar uma imagem de inicialização como uma etapa na criação de uma mídia inicializável.

  • Exportar uma imagem de inicialização

  • Exportar uma imagem de instalação

Exportar uma imagem de inicialização

Para exportar uma imagem de inicialização usando o snap-in dos Serviços de Implantação do Windows

  1. Clique para expandir a lista de servidores.

  2. Clique para expandir o servidor.

  3. Clique para expandir a pasta Imagens de Inicialização.

  4. Clique com o botão direito do mouse na imagem e clique em Exportar Imagem.

  5. Digite um caminho e um nome de arquivo para a imagem e clique em Salvar.
Para exportar uma imagem de inicialização usando WDSUTIL a partir de um prompt de comando

  • Para exportar uma imagem de inicialização, digite:

    WDSUTIL /Export-Image /Image: Nome_da_imagem /ImageType:Boot

    /Architecture:x86 /DestinationImage /FilePath: Caminho_do_arquivo.

    Em que Nome_da_imagem corresponde ao nome da imagem original e Caminho_do_arquivo corresponde ao caminho completo e ao nome da imagem de inicialização exportada.

Exportar uma imagem de instalação

Para exportar uma imagem de instalação usando o snap-in dos Serviços de Implantação do Windows

  1. Clique para expandir a lista de servidores.

  2. Clique para expandir o servidor.

  3. Clique na pasta Imagens de Instalação.

  4. Clique para expandir um grupo de imagens.

  5. Clique com o botão direito do mouse na imagem e clique em Exportar Imagem.

  6. Digite um caminho e um nome de arquivo para a imagem e clique em Salvar.
Para exportar uma imagem de instalação usando WDSUTIL a partir de um prompt de comando

  • Para exportar uma imagem de instalação, digite:

    WDSUTIL.exe /Export-Image /Image: Nome_da_imagem

    /ImageType:Install /DestinationImage /FilePath: Caminho_do_arquivo.

    Em que Nome_da_imagem corresponde ao nome da imagem original e Caminho_do_arquivo corresponde ao caminho completo e ao nome da imagem de inicialização exportada.

Considerações e referências adicionais

  • Para executar este procedimento, você deve ser membro do grupo Administradores no computador local ou deve ter recebido a autoridade adequada. Se o computador fizer parte de um domínio, é possível que os membros do grupo Administradores do domínio possam executar esse procedimento. Por questões de segurança, convém usar Executar como para executar o procedimento.

  • Gerenciar imagens do Windows


Propriedades da imagem

As páginas de Propriedades da Imagem fornecem uma descrição abrangente sobre uma imagem. As páginas de Propriedades da Imagem referentes a uma imagem de inicialização incluem as guias Geral e Versão. As páginas de Propriedades da Imagem referentes às imagens de instalação adicionam uma guia Segurança.

Além de visualizar as propriedades, a página de propriedades permite renomear uma imagem e alterar uma descrição da imagem. Para imagens de instalação, você pode habilitar a instalação autônoma ou selecionar a guia Segurança para modificar as configurações de segurança na imagem.

Visualizando propriedades da imagem

Você pode visualizar as propriedades da imagem de inicialização usando o snap-in Serviços de Implantação do Windows ou usando WDSUTIL em um prompt de comando.

Para visualizar propriedades da imagem usando o snap-in Serviços de Implantação do Windows

  1. Clique com o botão direito do mouse em uma imagem e selecione Propriedades.

  2. Clique em uma guia para escolher quais propriedades visualizar.
Para visualizar propriedades da imagem usando WDSUTIL em um prompt de comando

  • Digite WDSUTIL.exe /Get-Image /Image:Nome_da_imagem /ImageType:Tipo_de_imagem/Architecture:Arqu.

    Em que Nome_da_imagem é o nome da imagem, Tipo_de_imagem é boot ou install e Arqu é x86 ou x64.

Propriedades da imagem

As tabelas a seguir listam as propriedades de uma imagem e fornecem uma breve descrição de cada propriedade.

Guia Geral

Propriedade | Descrição
Nome da imagem | O nome da imagem é fornecido em uma caixa de texto. Você pode alterar o nome da imagem aqui usando OK ou Aplicar para atualizar a imagem.
Tipo de imagem | Indica se a imagem é uma imagem de inicialização ou de instalação.
Estado | Indica se a imagem está online ou offline.
Arquitetura | Indica a arquitetura do processador, x86 ou x64.
Descrição | A descrição da imagem é fornecida em uma caixa de texto. Você pode alterar o nome da imagem aqui usando OK ou Aplicar para atualizar a imagem.
Grupo de imagens | O grupo de imagens em que a imagem está atualmente armazenada.
Nome do arquivo | O nome do arquivo de imagem, incluindo a extensão do arquivo.
Tamanho | O tamanho da imagem não compactada, não necessariamente o tamanho real da imagem ou o WIM que contém a imagem.
Criada | A data em que a imagem foi criada.
Modificada | A data em que a imagem foi modificada.
Tipo HAL | Somente imagens de instalação - indica o tipo HAL no qual a imagem foi criada.
Modo autônomo | Marque esta caixa e selecione um arquivo de instalação autônoma para habilitar a instalação autônoma.

Guia Versão

Propriedade | Descrição
Versão da imagem | A versão principal do Windows e o número da compilação.
Nome interno | O nome original da imagem.
Idioma | O idioma original do arquivo WIM.
Nome de arquivo original | O nome original do arquivo WIM.
Nome do produto | O nome do produto Microsoft do sistema operacional contido na imagem.
Família do produto | A família do produto Microsoft da imagem do sistema operacional contido na imagem.
Nível do Service Pack | O nível do Service Pack da imagem do Windows.

Guia Segurança

Propriedade | Descrição
Nomes de grupo ou de usuário | Você pode alterar quem tem acesso a uma imagem adicionando ou removendo usuários dessa caixa de diálogo.
Permissões para Administradores | Você pode modificar as permissões de um usuário, incluindo permissões especiais, por meio dessa caixa de diálogo.
Avançado | Você pode clicar no botão Avançado para apropriar-se de um arquivo de imagem, auditar o acesso a um arquivo de imagem ou para modificar a permissão herdada a um arquivo de imagem.

Referências adicionais

  • Gerenciar imagens do Windows


Grupos de imagens

Um grupo de imagens é uma coleção de arquivos de imagem WIM que compartilham recursos e segurança de arquivos comuns. Grupos de Imagens são um limite de manutenção, porque o ato de manutenção de uma imagem em um Grupo de Imagens, como a aplicação de um hotfix, de um Service Pack ou a atualização de arquivos, exigirá acesso exclusivo a esse grupo. Recursos de arquivos são compartilhados entre o grupo de imagens (instância única), mesmo que os metadados de cada imagem residam em um arquivo físico WIM à parte. Grupos de imagens contêm dois tipos de arquivo:

  • Res.rwm – contém os fluxos de arquivo de imagens, conforme definido em Install.wim, Install2.wim e WinXP.wim. Observe que cada grupo de imagens tem seu próprio arquivo Res.rwm.

  • Install.wim – contém metadados de imagem que descrevem o conteúdo de uma imagem do sistema operacional. Os recursos de arquivo reais da imagem residem em Res.rwm.

Cada grupo de imagens terá um arquivo Res.rwm criado quando a primeira imagem for adicionada a um grupo de imagens. Res.rwm é conhecido como um WIM somente para recursos; ou seja, todos os recursos de todos os arquivos residem em Res.rwm. O arquivo .rwm é um arquivo .wim renomeado para diferenciar .wim (somente para recursos) de .wims (de metadados), bem como para agilizar a enumeração de imagens. Como a enumeração de imagens funciona apenas em arquivos .wim, o arquivo Res.rwm será ignorado.

Os dados de um arquivo WIM têm instância única; portanto, os arquivos duplicados serão armazenados somente uma vez, reduzindo significantemente o tamanho de armazenamento em disco de imagens de um Grupo de Imagens.

Referências adicionais

  • Gerenciar imagens do Windows


Arquivos de instalação autônoma

Os Serviços de Implantação do Windows permitem automatizar o cliente Serviços de Implantação do Windows e os estágios posteriores da Instalação do Windows. Essa abordagem de duas fases é realizada com dois arquivos de instalação autônoma diferentes. O arquivo de instalação autônoma dos Serviços de Implantação do Windows é armazenado no servidor dos Serviços de Implantação do Windows, na pasta \WDSClientUnattend, e é usado para automatizar a primeira fase da instalação. O arquivo usado para configurar as opções de instalação autônoma durante a Instalação do Windows é armazenado em uma subpasta (uma estrutura $OEM$ ou \Unattend), na pasta de cada imagem, e é usado para automatizar da segunda à sétima fase de instalação.

Para automatizar qualquer fase de instalação, você precisará criar um arquivo Unattend.xml, copiá-lo para o local apropriado e designá-lo para uso. A designação do arquivo de instalação autônoma pode ser desempenhada em nível de servidor ou em nível de cliente. A designação em nível de servidor pode ser decomposta pela arquitetura, o que permite ter diferentes configurações para clientes x86 e x64. A designação em nível de cliente substitui as configurações em nível de servidor.

Observação

As ferramentas de gerenciamento dos Serviços de Implantação do Windows suportam apenas imagem de instalação autônoma para imagens do Windows Vista e do Windows Server "Longhorn". Imagens de nível inferior requerem o uso dos arquivos Sysprep.inf existentes e a criação manual de uma estrutura de diretórios $OEM$.

Siga estas etapas para configurar a instalação autônoma:

  1. Crie um arquivo autônomo apropriado, dependendo de você estar configurando o cliente dos Serviços de Implantação do Windows, a instalação do Windows ou a instalação herdada. Observe que o Gerenciador de Imagem de Sistema do Windows, fornecido como parte do Windows AIK, oferece um excelente ambiente para a criação de arquivos autônomos.

  2. Associe o arquivo autônomo a uma imagem ou um tipo de máquina.

Os procedimentos a seguir descrevem como configurar para instalação autônoma. O primeiro procedimento explica o processo de configuração das opções autônomas para o cliente dos Serviços de Implantação do Windows por arquitetura; o procedimento seguinte descreve como configurar opções autônomas por computador. O procedimento final explica como configurar opções autônomas para Instalação do Windows.

  • Serviços de Implantação do Windows autônomos

  • Instalação do Windows autônoma

Configurando Serviços de Implantação do Windows autônomos

Para associar um arquivo autônomo do cliente WDS por arquitetura usando o snap-in dos Serviços de Implantação do Windows

  1. Crie um arquivo Unattend.xml com as configurações aplicáveis ao cliente Serviços de Implantação do Windows.

  2. Copie o arquivo XML para RemoteInstall\WDSClientUnattend.

  3. Abra o snap-in dos Serviços de Implantação do Windows.

  4. Expanda a lista no painel esquerdo para expor a lista Servidores.

  5. Clique com o botão direito do mouse no servidor dos Serviços de Implantação do Windows que contém a imagem Windows Vista ou Windows Server "Longhorn" que você deseja associar ao arquivo autônomo e clique em Propriedades.

  6. Clique na guia Cliente.

  7. Clique em Habilitar instalação autônoma.

  8. Clique no botão Pesquisar próximo à arquitetura apropriada.

  9. Selecione o arquivo autônomo e clique em Abrir.

  10. Clique em OK.

  11. Para fechar Propriedades do Servidor, clique em OK.
Para associar um arquivo autônomo do cliente WDS por arquitetura usando WDSUTIL

  1. WDSUTIL, a ferramenta de gerenciamento de linha de comando dos Serviços de Implantação do Windows, requer privilégios elevados para ser executada: clique em Iniciar, Todos os Programas, Acessórios, clique com o botão direito do mouse em Prompt de Comando e clique em Execução Privilegiada.

  2. No prompt de comando, digite:

    WDSUTIL /set-server /wdsunattend /policy:enabled /file:caminho_do_arquivo /architecture:x86

    Em que caminho_do_arquivo é o nome do caminho e do arquivo autônomo e arquitetura é a arquitetura do cliente a ser automatizado.
Observação

Para obter ajuda com WDSUTIL, digite WDSUTIL /? em um prompt de comando.

Para associar um arquivo autônomo do cliente dos Serviços de Implantação do Windows por computador usando WDSUTIL

  • Em um prompt de comando, digite:

    WDSUTIL /set-device /device: nome_do_computador /ID: GUID ou endereço MAC /WdsClientUnattend: caminho relativo

    Em que caminho relativo é o caminho a partir do compartilhamento REMINST para a pasta que contém WdsClientUnattend.xml.

Configurando a Instalação do Windows autônoma

Para associar um arquivo autônomo de Instalação do Windows a uma imagem usando o snap-in dos Serviços de Implantação do Windows

  1. Nesse snap-in, clique para expandir o grupo de imagens que contém as imagens Windows Vista ou Windows Server "Longhorn".

  2. Clique com botão direito do mouse na imagem que você deseja associar ao arquivo autônomo e clique em Propriedades.

  3. Clique em Permitir instalação de imagem em modo autônomo.

  4. Clique em Selecionar Arquivo.

  5. Digite o nome e o caminho ou navegue até o arquivo autônomo e clique em Abrir.

  6. Clique em OK.

  7. Para fechar a página Propriedades do Servidor, clique em OK.
Para associar um arquivo autônomo de Instalação do Windows a uma imagem usando WDSUTIL

  1. WDSUTIL, a ferramenta de gerenciamento de linha de comando dos Serviços de Implantação do Windows, requer privilégios elevados para ser executada: clique em Iniciar, Todos os Programas, Acessórios, clique com o botão direito do mouse em Prompt de Comando e clique em Execução Privilegiada.

  2. Em um prompt de comando, digite:

    WDSUTIL /set-image /image: nome_da_imagem /imagetype:install /imagegroup: nome_do_grupo_de_imagens /unattendfile: arquivo_autônomo

    Em que nome_da_imagem é o nome da imagem ao qual associar o arquivo autônomo, nome_do_grupo_de_imagens é o nome do grupo de imagens que contém o arquivo de imagem e arquivo_autônomo é o nome do caminho e do arquivo autônomo a ser associado à imagem.
Observação

Para obter mais informações sobre a instalação autônoma, consulte a documentação do produto Windows AIK.

Para associar Sysprep.inf a uma imagem de nível inferior

  1. Em um prompt de comando, navegue pelos diretórios até o grupo de imagens que contém uma imagem de nível inferior.

  2. No grupo de imagens que contém a imagem herdada, crie um diretório com o mesmo nome do WIM ao qual você deseja associar à imagem:

    Md C:\RemoteInstall\Images\ nome_do_grupo_de_imagens \ nome_do_arquivo_de_imagem

  3. Crie uma estrutura de diretórios $OEM$:

    Mc C:\RemoteInstall\Images\ nome_do_grupo_de_imagens \ nome_do_arquivo_de_imagem \$OEM$

  4. Copie um sysprep.inf apropriado à imagem para o diretório $OEM$ :

    Copie C:\Sysprep.inf C:\RemoteInstall\Images\ nome_do_grupo_de_imagens \ nome_do_arquivo_de_imagem \$OEM$

  5. Adicione arquivos ou faça outras alterações conforme necessário e apropriado, seguindo as convenções para $OEM$.

  6. Quando a imagem for aplicada, o diretório $OEM$ inteiro será copiado, e o conteúdo será aplicado à imagem.
Observação

Para obter mais informações sobre Sysprep.inf e o diretório $OEM$, consulte Projetando tarefas de configuração automatizadas (http://go.microsoft.com/fwlink/?LinkId=66136).

Referências adicionais

  • Gerenciar imagens do Windows


Pacotes de idioma

Você pode associar vários pacotes de idioma a uma única imagem, reduzindo o número de imagens que precisam ser mantidas. Para usar um pacote de idiomas, crie a estrutura do diretório apropriada e copie o pacote de idiomas.

Para associar um pacote de idiomas a uma imagem

  1. Na pasta do grupo de imagens que contém a imagem, crie um diretório com o mesmo nome do arquivo de imagem. Nessa pasta, crie um diretório chamado langpacks. Se o nome do grupo de imagens for Vista e o da imagem for Install, digite:

    md c:\remoteinstall\images\vista\install\langpacks

  2. No diretório langpacks, crie um diretório para cada pacote de idiomas a ser instalado. Para criar um diretório langpacks para o idioma japonês, digite:

    md c:\remoteinstall\images\vista\install\langpacks\ja-jp

  3. Copie o pacote de idiomas japonês para C:\Remoteinstall\images\vista\install\langpacks\ja-jp.

Considerações adicionais

  • Pacotes de idiomas apenas são suportados nos sistemas operacionais Windows Vista e Windows Server "Longhorn".

Referências adicionais

  • Gerenciar imagens do Windows


Imagens herdadas

As imagens herdadas RISETUP e RIPREP são gerenciadas com o uso dos utilitários RISETUP e RIPREP dos Serviços de Implantação Remota (RIS) e o snap-in Usuários e Computadores do Active Directory. Você pode exibir a lista de imagens usando as ferramentas dos RIS ou as ferramentas de gerenciamento dos Serviços de Implantação do Windows.

  • Imagens RISETUP

  • Imagens RIPREP

Imagens RISETUP

Você pode mover imagens RISETUP existentes para imagens WIM nativas usando o procedimento a seguir.

Para converter uma imagem RISETUP em uma imagem WIM

  1. Inicialize um computador de referência no menu OSChooser.

  2. Opte por instalar a imagem apropriada.

  3. Use Sysprep.exe para preparar a imagem.

  4. Use uma imagem de captura para salvar a imagem e adicioná-la ao servidor dos Serviços de Implantação do Windows.

Considerações adicionais

  • Como os sistemas operacionais Windows anteriores ao Windows Vista são dependentes do HAL (Hardware Abstraction Layer), são necessárias imagens separadas para cada tipo de HAL.

Referências adicionais

  • Gerenciar imagens do Windows

  • Serviços de Instalação Remota (http://go.microsoft.com/fwlink/?LinkId=71138)

Imagens RIPREP

Imagens RIPREP são imagens preparadas com Sysprep.exe, sem um banco de dados de dispositivos totalmente preenchido e crítico. Imagens RIPREP armazenam o banco de dados de dispositivos crítico em uma imagem RISETUP complementar.

Você pode usar dois procedimentos para converter imagens RIPREP no formato WIM.

  • Use o utilitário de conversão para converter imagens de RIPREP para WIM

  • Implante uma imagem RIPREP em um computador de referência e capture a imagem para o servidor WDS, usando o novo utilitário de captura de imagem WDS

Convertendo uma imagem RIPREP

Depois de atualizar seu servidor para os Serviços de Implantação do Windows, você pode usar um dos procedimentos a seguir para converter suas imagens RIPREP em WIMs.

Para converter uma imagem RIPREP em um WIM usando o snap-in dos Serviços de Implantação do Windows

  1. Clique para expandir Imagens Herdadas.

  2. Clique com o botão direito do mouse na imagem a ser convertida e clique em Converter Imagem.

  3. Quando a conversão de imagem estiver concluída, adicione a imagem ao grupo de imagens apropriado.
Para converter uma imagem usando WDSUTIL em um prompt de comando

  1. Digite WDSUTIL /convert-riprepimage /filepath:file_path1 /destinationimage /filepath:file_path2, em que file_path1 é o caminho completo para o arquivo .sif e file_path2 é o caminho completo para o novo WIM.

  2. Digite WDSUTIL /add-image /imagefile:file_path2 /image type:install
Para converter uma imagem RIPREP em uma imagem WIM usando o utilitário de captura

  1. Inicialize um computador de referência no menu OSChooser.

  2. Opte por instalar a imagem apropriada.

  3. Use Sysprep.exe para preparar a imagem.

  4. Use uma imagem de captura para salvar a imagem e adicioná-la ao servidor dos Serviços de Implantação do Windows.
Importante

Você deve ter controle total da imagem RIPREP para concluir o processo de conversão. Se não tiver controle total, a conversão falhará com o código do erro 0x522.

Considerações adicionais

  • Se estiver executando os Serviços de Implantação do Windows no Windows Server 2003, poderá usar qualquer um dos métodos de conversão. Se os Serviços de Implantação do Windows estiverem em execução no Windows Server "Longhorn", você poderá usar somente o utilitário de conversão. Isso porque não é possível implantar uma imagem RIPREP do servidor dos Serviços de Implantação do Windows Windows Server "Longhorn", pois não há mais suporte para OSChooser.

  • É recomendável copiar as imagens e arquivos de imagem em um diretório temporário antes de converter as imagens. Se o processo falhar ou se você quiser reverter para a imagem original, a imagem original não será modificada.

  • O processo de conversão RIPREP requer APIs de duas DLLs externas – drvstore.dll e cmiv2.dll. Em computadores Windows Vista e Windows Server "Longhorn", esses binários existem como parte da instalação. No Windows Server 2003 e no Windows XP, os binários não existem. Para que a tarefa de gerenciamento de conversão RIPREP funcione no Windows Server 2003, as seguintes etapas devem ser desempenhadas:

    1. Instale o Windows AIK no Windows Server 2003 WDS Server. O Windows AIK contém os arquivos de suporte necessários - drvstore.dll e cmiv2.dll - e os instala por padrão.

    2. Certifique-se de que os arquivos estejam no caminho do arquivo.

  • As imagens sysprep anteriores ao Windows Vista eram dependentes do HAL. É necessária uma imagem separada para cada tipo de HAL no seu ambiente.

Referências adicionais

  • Gerenciar imagens do Windows

  • Serviços de Instalação Remota (http://go.microsoft.com/fwlink/?LinkId=71138)


Amostra de arquivos de instalação autônoma

Você pode usar arquivos de instalação autônoma para automatizar muitos aspectos da instalação. Use essas amostras para resolver problemas na instalação ou como um ponto de partida para criar seus próprios arquivos de instalação autônoma.

  • Cliente autônomo

  • Imagem autônoma

Arquivo de instalação autônoma do cliente

Esse arquivo de instalação autônoma permitirá uma experiência de instalação completamente automatizada com o uso do Cliente dos Serviços de Implantação do Windows. Você pode salvar o arquivo de amostra como um arquivo XML usando um um editor de texto.

<?xml version="1.0" ?>

<unattend xmlns="urn:schemas-microsoft-com:unattend">

<settings pass="windowsPE">

<component name="Microsoft-Windows-Setup" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="x86">

<WindowsDeploymentServices>

<Login>

<WillShowUI>OnError</WillShowUI>

<Credentials>

<Username>username</Username>

<Domain>wds-dom</Domain>

<Password>my_password</Password>

</Credentials>

</Login>

<ImageSelection>

<WillShowUI>OnError</WillShowUI>

<InstallImage>

<ImageName>Windows Vista with Office</ImageName>

<ImageGroup>ImageGroup1</ImageGroup>

<Filename>Install.wim</Filename>

</InstallImage>

<InstallTo>

<DiskID>0</DiskID>

<PartitionID>1</PartitionID>

</InstallTo>

</ImageSelection>

</WindowsDeploymentServices>

<DiskConfiguration>

<WillShowUI>OnError</WillShowUI>

<Disk>

<DiskID>0</DiskID>

<WillWipeDisk>false</WillWipeDisk>

<ModifyPartitions>

<ModifyPartition>

<Order>1</Order>

<PartitionID>1</PartitionID>

<Letter>C</Letter>

<Label>TestOS</Label>

<Format>NTFS</Format>

<Active>true</Active>

<Extend>false</Extend>

</ModifyPartition>

</ModifyPartitions>

</Disk>

</DiskConfiguration>

</component>

<component name="Microsoft-Windows-International-Core-WinPE" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="x86">

<SetupUILanguage>

<WillShowUI>OnError</WillShowUI>

<UILanguage>en-US</UILanguage>

</SetupUILanguage>

<UILanguage>en-US</UILanguage>

</component>

</settings>

</unattend>

Referências adicionais

  • Gerenciar imagens do Windows

  • Arquivos de instalação autônoma

  • Imagens herdadas

Amostra de arquivo de instalação autônoma de imagem

Esse arquivo configura a chave do produto e permite que a operação de ingresso no domínio seja bem-sucedida. Você pode salvar o arquivo de amostra como um arquivo XML usando um editor de texto.

<?xml version="1.0" encoding="utf-8"?>

<unattend xmlns="urn:schemas-microsoft-com:unattend">

<settings pass="specialize">

<component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<Identification>

<UnsecureJoin>true</UnsecureJoin>

</Identification>

</component>

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<ProductKey>XXXX-XXXX-XXXX-XXXX-XXXX</ProductKey>

</component>

</settings>

</unattend>

Referências adicionais

  • Gerenciar imagens do Windows

  • Arquivos de instalação autônoma

  • Imagens herdadas


Solução de problemas dos Serviços de Implantação do Windows

Esta seção lista alguns problemas comuns que você pode encontrar ao usar os Serviços de Implantação do Windows.

Qual é o seu problema?

  • Meu cliente com base em x64 não vê nenhuma imagem com base em x64 na página de seleção da imagem de inicialização.

  • Meu computador cliente x64 é detectado como x64, mas falha ao inicializar em uma imagem padrão.

  • Meu computador é carregado, mas a imagem de inicialização não pode acessar uma imagem de instalação.

  • Criei um arquivo de instalação autônoma, mas, quando a instalação é concluída, meu computador cliente não ingressa no domínio.

  • O Assistente de Captura dos Serviços de Implantação do Windows não reconhece a unidade de disco que contém o volume a ser capturado.

    Observação

    Uma boa opção de solução de problemas é procurar logs de eventos gerados pelos Serviços de Implantação do Windows. As entradas do log de eventos dos Serviços de Implantação do Windows podem ser encontradas no log de eventos do Aplicativo, nas origens: BNLSVC, WDSPXE, WDSIMGSRV e WDSServer.

Meu cliente com base em x64 não vê nenhuma imagem com base em x64 na página de seleção da imagem de inicialização

Muitos BIOSs de sistema com base em x64 não identificam adequadamente o computador como x64 durante o processo de inicialização. Se os Serviços de Implantação do Windows não reconhecerem os sistemas como x64, apenas serão apresentadas imagens x86. Você pode digitar WDSUTIL /set-server /architecturediscovery:yes em um prompt de comando para forçar o servidor dos Serviços de Implantação do Windows a reconhecer computadores x64.

Meu computador cliente x64 é detectado como x64, mas falha ao inicializar em uma imagem padrão.

Se um sistema PXE com base em x64 for inicializado, mas não encontrar uma imagem com base em x64, não conseguirá concluir o processo de inicialização. Verifique se há uma imagem de inicialização (e instalação) x64 adicionada ao servidor dos Serviços de Implantação do Windows. Como alternativa, você pode forçar todos os clientes X64 a receberem apenas os arquivos de inicialização x86, configurando o programa de inicialização padrão para clientes x64 de forma a usarem o programa de inicialização de rede apropriado, por exemplo, Pxeboot.com de \RemoteInstall\boot\x86.

Meu computador é carregado, mas a imagem de inicialização não pode acessar uma imagem de instalação.

A imagem de inicialização pode não conter o driver de rede necessário para o computador. Pressione Shift-F10 para abrir uma janela de comando e digite IPConfig. Se nenhum endereço IP e nenhuma máscara de sub-rede for relatado, significa que a rede não foi iniciada e é provável que um driver de rede não esteja presente. Verifique o procedimento em Modificar uma imagem e consulte a documentação do Windows AIK em http://go.microsoft.com/fwlink/?LinkID=53552.

Criei um arquivo de instalação autônoma, mas, quando a instalação é concluída, meu computador cliente não ingressa no domínio.

A causa comum desse erro é que o arquivo autônomo da imagem não está formatado corretamente. Para saber se o arquivo está formatado corretamente, verifique Arquivos de instalação autônoma ou use o arquivo autônomo de amostra em Amostra de arquivos de instalação autônoma.

Outra causa comum desse problema é um erro de permissão durante o ingresso no domínio. Verifique esse erro em \Windows\panther\setupact.log, em domainjoininformation. Tome uma ação corretiva com base nas informações do arquivo de log.

O Assistente de Captura dos Serviços de Implantação do Windows não reconhece a unidade de disco que contém o volume a ser capturado.

O Assistente de Captura dos Serviços de Implantação do Windows não informará uma unidade como disponível se não localizar uma imagem válida preparada usando Sysprep.exe. Reinstale o sistema operacional de destino e prepare a imagem para captura usando Sysprep.exe. Verifique Criar uma imagem e Imagens herdadas para obter mais informações.


Recursos dos Serviços de Implantação do Windows

Para obter mais informações sobre os Serviços de Implantação do Windows, consulte as seguintes informações no site da Microsoft.

  • Para obter mais informações sobre a etapa de pré-teste de computadores clientes, consulte Pré-testar computadores clientes (http://go.microsoft.com/fwlink/?LinkId=50166).

  • Para obter mais informações sobre Sysprep.inf e o diretório $OEM$, consulte Projetando tarefas de configuração automatizadas (http://go.microsoft.com/fwlink/?LinkId=66136).

  • Para obter a versão mais atualizada deste documento, consulte o site da Microsoft (http://go.microsoft.com/fwlink/?LinkId=66145).

  • Se precisar de suporte ao produto, consulte o site de Conexão da Microsoft (http://go.microsoft.com/fwlink/?LinkId=49779).

  • Para acessar grupos de notícias dos Serviços de Implantação do Windows, siga as instruções fornecidas no site de Conexão da Microsoft (http://go.microsoft.com/fwlink/?LinkId=50067).

  • Para obter mais informações sobre o Windows AIK, consulte o Guia do Usuário do Windows para WAIK (Kit de Instalação Automatizada do Windows) referente ao Windows Vista (http://go.microsoft.com/fwlink/?LinkID=53552).

  • Para obter mais informações sobre como implementar os Serviços de Implantação do Windows, consulte Implantando o Windows Vista (http://go.microsoft.com/fwlink/?LinkId=71130).

  • Para obter mais informações sobre os Serviços de Implantação Remota (RIS), consulte Serviços de Implantação Remota (http://go.microsoft.com/fwlink/?LinkId=71138).

  • Para obter mais informações sobre o Microsoft Solution Accelerator for Business Desktop Deployment 2007, consulte (http://go.microsoft.com/fwlink/?LinkId=71137).